gifts2017

Обработка "Свертка остатков ТиС 9.хх"

Опубликовал Михаил (mdzen) в раздел Обработки - Свертка базы

Обработка предназначена для облегчения рутинной работы по свертке базы 1С. В сворачиваемой базе указанной обработкой формирует документы ввода остатков, например на 1 января, далее переносим полученные документы в подготовленную чистую базу стандартной обработкой 1С, проводим - получаем чистую базу с остатками на 1 января.

Обработка формирует остатки по кассе, банку, остатки по покупателям, остатки по поставщикам, остатки ТМЦ. По остаткам ТМЦ формируется несколько документов "Ввод остатков ТМЦ" . Остатки ТМЦ формируются на основании остатков партий. Количество документов ввода остатков ТМЦ зависит от максимального количества оставшихся партий.

Скачать файлы

Наименование Файл Версия Размер
- 906
.ert 35,50Kb
27.02.13
906
.ert 35,50Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Anonymous 25.03.07 19:54
2. Виктор (pino2007) 15.11.07 17:38
Автору, респект, давно нужна такая обработка - мне очень помогла, еще раз спасибо.
3. Наталья (GNG) 26.12.07 13:01
у меня косяк....
дело в том, что несколько складов может принадлежать одному МОЛ
доки дублируются поэтому....((((
4. Михаил (mdzen) 26.12.07 22:03
Это у 1С косяк.
Партии привязываются к МОЛам вместо того чтоб ввести измерение Склад.
Поставь на склады различных МОЛов, перепроведи и выгружай.
В новой базе оставь как было.

У себя добавил измерение в регистры Партий и подшаманил обработки использующие
эти регистры. Проблема с МОЛами отпала...
5. triant (triant) 15.01.08 09:20
глПриИзмененииФирмы<<?>>(Док2);
{E:\TEMP\SVERTKA.ERT(500)}: Процедура не обнаружена (глПриИзмененииФирмы)
ГлПриИзмененииФирмы<<?>>(ДокОст);
{E:\TEMP\SVERTKA.ERT(743)}: Процедура не обнаружена (ГлПриИзмененииФирмы)
Сообщить("Распроведен " + глПредставлениеДокумента<<?>>(Док.ТекущийДокумент()));
{E:\TEMP\SVERTKA.ERT(3284)}: Функция не обнаружена (глПредставлениеДокумента)
Сообщить("Распроведен " + глПредставлениеДокумента(Док.ТекущийДокумент()<<?>>));
{E:\TEMP\SVERTKA.ERT(3284)}: Неопознанный оператор
ЗаписатьЛог("Распроведен " + глПредставлениеДокумента<<?>>(Док.ТекущийДокумент()));
{E:\TEMP\SVERTKA.ERT(3286)}: Функция не обнаружена (глПредставлениеДокумента)
ЗаписатьЛог("Распроведен " + глПредставлениеДокумента(Док.ТекущийДокумент()<<?>>));
{E:\TEMP\SVERTKA.ERT(3286)}: Неопознанный оператор
ЗаписатьЛог("Распроведен " + глПредставлениеДокумента(Док.ТекущийДокумент()))<<?>>;
{E:\TEMP\SVERTKA.ERT(3286)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
ЗаписатьЛог("Распроведен " + глПредставлениеДокумента(Док.ТекущийДокумент()))<<?>>;
{E:\TEMP\SVERTKA.ERT(3286)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
<<?>>КонецЕсли;
{E:\TEMP\SVERTKA.ERT(3287)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
6. triant (triant) 15.01.08 09:20
7. Михаил (mdzen) 15.01.08 21:26
Где запускаешь? Какой релиз ТиС?
Работает в 9.28 -9.49.
Может под 8.5 или 8.7 - так там свои траблы и своя метода.
8. Михаил (mdzen) 15.01.08 21:32
Да ты видимо не туда пишешь комменты. Запьюлталь однако.
Чью обработку юзаешь?
Такого г-на: " ЗаписатьЛог("Распроведен " + глПредставлениеДокумента(Док.ТекущийДокумент()))"
в моей нет! Повнимательней, пожалуйста.
9. Михаил Семенов (Shaman100M) 15.01.08 22:20
(5) Похоже на код в моей свертке. Ругается на процедуры из глобального. Скорее всего запускали не в 9-й ТиС.
(8) А какое же есть в твоей?
11. triant (triant) 17.01.08 09:06
Да да это у шамана :(
извините ошибся
12. triant (triant) 17.01.08 09:07
СкладыФирмы = СоздатьОбъект("Справочник.Склады"); //Справочник Склады
{E:\TEMP\SVERTKA(2).ERT(21)}: Неудачная попытка создания объекта (Справочник.Склады)
РегКасса.УстановитьЗначениеФильтра("Фирма", ФирмаДляСвертки, 1);
{E:\TEMP\SVERTKA(2).ERT(119)}: Реквизит с данным идентификатором не найден!
РегБанк =ВремРегистры.Банк; //Регистр Банк
{E:\TEMP\SVERTKA(2).ERT(155)}: Поле агрегатного объекта не обнаружено (Банк)
ПартииНаличие = ВремРегистры.Покупатели; //Регистр Покупатели
{E:\TEMP\SVERTKA(2).ERT(200)}: Поле агрегатного объекта не обнаружено (Покупатели)
ПартииНаличие = ВремРегистры.Поставщики; //Регистр Поставщики
{E:\TEMP\SVERTKA(2).ERT(285)}: Поле агрегатного объекта не обнаружено (Поставщики)
ваше?
13. Михаил (mdzen) 18.01.08 08:36
12 - Наше. Но для 9.xx в 8.7 нет таких объектов...
14. Michailo Бахтин (lordmb) 23.06.08 14:10
А розничные склады будут?
15. Михаил Ражиков (tango) 23.06.08 14:19
братья и сестры, нужно это самое, только в комплексную, польцем покажите, где копать?
16. Michailo Бахтин (lordmb) 23.06.08 14:53
А на сколько ваша комплексная задействована?
17. Михаил (mdzen) 23.06.08 21:05
(14) Код обработки открытый.
Дерзайте.
Если не заморачиваться с партиями то ввод остатков можно делать по остаткам регистра "ОстаткиТМЦ". Дорабатывать нет желания. Копаю 8.1
(15) В Комплексной все сложнее. Нсли используете в полный рост, то попробуй разобраться со стандартной сверткой.
18. Decker (twilight5023) 06.07.11 00:28
Супер ... до конца правда еще не успел потестить, но время сэкономило реально. Собирался тут такую же писать, правда идея была не создавать непроведенные документы в этой же базе, а выгружать остатки в текстовый файл, который потом разбирать в новой, очищенной базе и создавать там документы ввода остатков. Вот что значит невыспавшийся мозг ;) Естественно проще создать сначала документы ввода остатков, затем удалить все лишнее, почистив базу, и потом провести их.
19. Decker (twilight5023) 10.07.11 15:08
Улучшенная обработка "Свертка остатков ТиС 9.хх"- вообщем немного доделал обработку. Из основного - работа с розничными складами, т.е. продажная цена товара учитывается в документах ввода остатков ТМЦ. Теперь для корректного переноса остатков ТМЦ вовсе не обязательно чтобы склады были привязаны к МОЛ, обработка анализирует, как содержимое регистра ОстаткиТМЦ, так и ПартииНаличие. Протестировано на нескольких объемных базах крупных компаний (размер DBF порядка 6 Gb). При условии того что последовательность восстановлена и нет ошибок по партиям и остаткам (нет отрицательных итогов) - все переносится "один в один". Скорость анализа остатков ТМЦ и партий существенно увеличена по-сравнению с первоначальным вариантом. Вообщем еще раз спасибо автору за изначальный вариант, по-крайней мере отпала необходимость писать что-то свое для касс, банков и взаиморасчетов.
20. Vadim A (avavadim) 19.12.11 01:01
21. Alonzomozley (alonzomozley) 04.11.12 11:06
Спасибо.
Пришлось правда переписать процедуру ввода остатков ТМЦ - теперь остатки партий корректно вводятся с учетом статуса партии и поставщика.
22. Сергей Житков (it-storg1) 23.02.15 02:16
Подскажите в чем проблема?

ДокОстБанк.Записать();
{C:\USERS\АДМИН\DESKTOP\НОВАЯ ПАПКА (2)\СВЕРТКА 2015.ERT(179)}: Номер не уникальный!
ДокОстДолгНам.Записать();
{C:\USERS\АДМИН\DESKTOP\НОВАЯ ПАПКА (2)\СВЕРТКА 2015.ERT(264)}: Номер не уникальный!
ДокОстДолгНам.Записать();
{C:\USERS\АДМИН\DESKTOP\НОВАЯ ПАПКА (2)\СВЕРТКА 2015.ERT(327)}: Номер не уникальный!
23. Михаил (mdzen) 06.03.15 21:20
(22) it-storg1,
Проверьте нумерацию документов.
Система не может присвоить новый номер ....
24. Алексей Тихомиров (AlexeyT1978) 18.03.16 16:23
Если дата свертки в прошлом году, то все документы пытаются сохраниться с номером 0000000001.
Долги по покупателям, если в регистре 0, сохраняются как долг покупателя N и сразу же как долг фирмы на ту же сумму N, в результате имеем тысячи таких документов.
Глючный мусор, а не свертка.
25. Михаил (mdzen) 18.03.16 22:29
(24) AlexeyT1978,
Обработке 10 лет.
ТИС наверное остался у единиц, а тема свертки все еще востребована?
Неожиданно!
Недостатки есть, согласен с Вами. Но на момент создания такое решении посчитали лучшим, чем
много часовая, а иногда и много суточная свертка стандартной обработкой....
Сейчас сделал бы по другому, но уже тема не актуальна.
А по поводу "глючного мусора" - это Вы, наверное погорячились? Однако Вы уделили внимание этому "мусору",
значит вам это было нужно, иначе зачем же тогда копаться в мусоре....
P.S. С удовольствием удалил бы некоторые публикации, но почему-то в профиле есть только кнопка создания публикации,
кнопки редактирования или удаления после смены дизайна не нашел...