Динамическая фильтрация в справочнике при вводе наименования

Опубликовал Максим Шуйский (maxpiter) в раздел Программирование - Практика программирования

Позволяет в открытой форме списка, выбора или подбора справочника производить динамическую фильтрацию по набранному наименованию.

Предлагаю способ, наверное уже избитый, но в поиске не нашел.

Смысл решения, практически тоже самое что предложено Ёпрст. На практике это использую почти год.

Фильтрация происходит по набранным символам разделенных пробелами. Сортировка происходит по первому набору символов (до пробела)
Требования: 1С++
Версия: SQL (с DBF сто лет не работал, наверное что-то нужно поменять :) )
Ограничения. Если установлен отбор из диалога 1С, фильтрация не работает (скорее всего я не разобрался как программно снимать отбор, надеюсь в комментах подскажут)

Код приведенный ниже, добавить в нужную форму.

У меня в ГМ при начале работы системы присвоена глРС = СоздатьОбъект("ODBCRecord");
и глСтрокаРазрешенныхСимволов = " .,-+*/\_0123456789абвгдеёжзийклмнопрстуфхцчшщъыьэюяabcdefghijklmnopqrstuvwxyz";
Их необходимо создать и объявить для работы данного алгоритма. 

 

Перем СтрокаСимволов;

Перем ТекФлагИерархическогоСписка;
Перем СпЗн;
Перем ОтборУстановлен;

Процедура ПриУстановкеОтбора(ТипОтбора,ЗначениеОтбора)
   
ОтборУстановлен = ТипОтбора;
КонецПроцедуры

Функция
ПолучитьСписокЭлементов(ВидСправочника, СтрокаСимволов)
   
СтрДляПозиции = СтрокаСимволов;
   
Пробел = Найти(СтрДляПозиции," ");
    Если
Пробел>0 Тогда
       
СтрДляПозиции = Лев(СтрДляПозиции,Пробел-1);
    КонецЕсли;
   
ТекстЗапроса = "
    |SELECT ID [Ссылка $Справочник."
+ВидСправочника+"]
    |   , case when CHARINDEX ('"
+СтрДляПозиции+"', "+ВидСправочника+".DESCR)=0 then 999 else CHARINDEX ('"+СтрДляПозиции+"', "+ВидСправочника+".DESCR) end ПозицияВСтроке
    |FROM $Справочник."
+ВидСправочника+" AS "+ВидСправочника+" With (NOLOCK)
    |WHERE ("
+ВидСправочника+".ISFOLDER >= 0)
    |"
;
    Если
ПустаяСтрока(СтрокаСимволов)=0 Тогда
       
СтрДляЗапроса = "
        |AND ("
+ВидСправочника+".DESCR LIKE '%"+СтрЗаменить(СтрокаСимволов," ","%') AND ("+ВидСправочника+".DESCR LIKE '%");
       
СтрДляЗапроса = СтрДляЗапроса + "%')
        |"
;
       
ТекстЗапроса=ТекстЗапроса+СтрДляЗапроса;
    КонецЕсли;
   
ТекстЗапроса = ТекстЗапроса + "
    |ORDER BY ПозицияВСтроке, "
+ВидСправочника+".DESCR
    |"
;
   
глРС.ВыполнитьИнструкцию(ТекстЗапроса, СпЗн);
    Возврат
СпЗн;
КонецФункции

Процедура
ПриНажатииКнопкиКлавиатуры(_код, , , , _симв, ФСО)
    Если
Лев(Форма.ТекущаяКолонка(),12)="Наименование" Тогда
        Если
ПустоеЗначение(ОтборУстановлен)=0 Тогда
           
УстановитьОтбор("","");
            Возврат;
        КонецЕсли;
        Если (
=1) или (=1) или (=1) Тогда
           
ФСО=1;
            Возврат;
        КонецЕсли;
        Если
_код = 27 Тогда
            Если СтрокаСимволов="" Тогда 
                Фсо = 1
                Возврат;
            КонецЕсли;

            КурсорНаЭлементе = ТекущийЭлемент();
           
СтрокаСимволов = "";
           
Форма.Наименование.Заголовок("Наименование");
            
СпЗн.УдалитьВсе();
            ИспользоватьСписокЭлементов();
            
ИерархическийСписок(ТекФлагИерархическогоСписка,1);
            Попытка
               
АктивизироватьОбъект(КурсорНаЭлементе);
            Исключение
            КонецПопытки;
           
ФСО = 1;
            Возврат;
        ИначеЕсли
_код = 8 Тогда
           
СтрокаСимволов = Лев(СтрокаСимволов, СтрДлина(СтрокаСимволов)-1);
        ИначеЕсли
_симв="" Тогда
           
ФСО = 1;
            Возврат;
        ИначеЕсли
Найти(глСтрокаРазрешенныхСимволов, Нрег(_симв))>0 Тогда
           
СтрокаСимволов = СтрокаСимволов + _симв;
        Иначе
           
ФСО = 1;
            Возврат;
        КонецЕсли;
       
Форма.Наименование.Заголовок("Наименование ("+СтрокаСимволов+")");
       
СпЗн = ПолучитьСписокЭлементов("Номенклатура", СтрокаСимволов);
       
ИспользоватьСписокЭлементов(СпЗн);
       
ИерархическийСписок(0,0);
       
ФСО = 0;
    КонецЕсли;
КонецПроцедуры

Процедура
ПриОткрытии()
    ТекФлагИерархическогоСписка = ВосстановитьЗначение("ТекФлагИерархическогоСпискаНоменклатура");
    СтрокаСимволов = "";
    СпЗн = СоздатьОбъект("СписокЗначений");
КонецПроцедуры

Процедура ПриСменеИерархии(Способ)
    ТекФлагИерархическогоСписка = Способ;
КонецПроцедуры

Процедура ПриЗакрытии()
    СохранитьЗначение("ТекФлагИерархическогоСпискаНоменклатура",ТекФлагИерархическогоСписка);
КонецПроцедуры

См. также

Добавить вознаграждение
Комментарии
1. Модератор раздела Артур Аюханов (artbear) 03.07.12 16:59 Сейчас в теме
Плюсанул.
Тема интересна, хоть я от 77 и 1С++ отошел.

Не описан глРС, будет ошибка.
Дбф? скуль?
2. Максим Шуйский (maxpiter) 139 04.07.12 00:35 Сейчас в теме
(1)Поправил замечания в описании.
Работаю с SQL, но для DBF алгоритм такой же, возможно код запросов чуток другой.

p.s. Спасибо за +, от artbear плюс вообще приятно :)
3. Igоr Sаulеviсh (gutentag) 249 04.07.12 10:18 Сейчас в теме
4. Ёпрст (Ёпрст) 1012 04.07.12 10:56 Сейчас в теме
Только вот по первым символам и так есть поиск в форме списка справочника..
5. Ёпрст (Ёпрст) 1012 04.07.12 10:57 Сейчас в теме
6. Максим Шуйский (maxpiter) 139 04.07.12 10:59 Сейчас в теме
(4) вот вредный, видно же что ищет не по первым символам, а сортирует по первым
7. Ёпрст (Ёпрст) 1012 04.07.12 11:03 Сейчас в теме
(6)
1.глСтрокаРазрешенныхСимволов - это что за зверь такой ?
2. не видно вводимых символов на форме (лучше уж тогда через ДобавитьАтрибут добавлять поле, как у A'Dirks-а)
3. запрос, на сколько я понял выполняется при каждом нажатии на кнопку клавиатуры, если это не эескейп, бекспейс ?
це-же медленно на большом спраочнике, лучше или начиная с 3-4 символа, или задержку втыкаить, как в софтпоинте сделали
8. Ёпрст (Ёпрст) 1012 04.07.12 11:05 Сейчас в теме
>>>как программно снять отбор ?

УстановитьОтбор("");
9. Максим Шуйский (maxpiter) 139 04.07.12 11:19 Сейчас в теме
(7)
1. упустил
глСтрокаРазрешенныхСимволов = " .,-+*/\_0123456789абвгдеёжзийклмнопрстуфхцчшщъыьэюяabcdefghijklmn­opqrstuvwxyz";
набор символов по которым можно выполнять отбор.
2. видно, они набираются в поле "Наименование"
3. на справочнике более чем 5к элементов, примлемо. Действительно думал, чтобы начать фильтрацию с 3 символа, но пришел к выводу, что лучше с первого.
Разве что, при наборе первого символа искать не все вхождения а именно только те у которыех он первый, но тут будут не очень нормальные варианты с ё, й, ы, ь, ъ.

(8)
спасибо, так пробовал, вываливалось с ошибкой, а вот УстановитьОтбор("",""); только сейчас предположил и получилось, хотя второй параметр и написано что необязательный.

изменил в коде и описание.
10. Ёпрст (Ёпрст) 1012 04.07.12 11:47 Сейчас в теме
(9) ааа...
т.е "МАМА Мыла РАМУ" уже не канает для поиска ?
жаль..
11. Максим Шуйский (maxpiter) 139 04.07.12 12:57 Сейчас в теме
(10) почему не канает-то???? где сказано что не канает?
уже столько написал, давно бы попробовал :)
12. Максим Шуйский (maxpiter) 139 04.07.12 13:00 Сейчас в теме
+11 SQL ищет без учета регистра, если ему конкретно не скажут что нужно учитывать регистр.
13. Ёпрст (Ёпрст) 1012 04.07.12 13:04 Сейчас в теме
(12) при чем тут то, что ищет скуль ?

Ты сам ограничил набор вводимых символов - у тебя заглавные символы ввести нельзя.

:))))
14. Ёпрст (Ёпрст) 1012 04.07.12 13:06 Сейчас в теме
А ёпт.. Нрег не заметил в Найти..
Забираю слова обратно
15. Максим Шуйский (maxpiter) 139 04.07.12 13:07 Сейчас в теме
(14) попробуй уже а? и напиши че нить хорошее :)
16. Максим Шуйский (maxpiter) 139 04.07.12 13:08 Сейчас в теме
(13) а заглавные ввести нельзя, потому что shift, alt и ctrl вообще из поиска исключаю
17. Ёпрст (Ёпрст) 1012 04.07.12 13:08 Сейчас в теме
И это, ставить не буду - тёткам удобно видеть весь справочник, им и штатный поиск по первым символам в форме списка устраивает, причем, он штатно "множественный", т.е нашли первое совпадение, потом можно "бегать" по форме списка вверх вниз по этим совпадениям - привыкли так ужо.
18. Ёпрст (Ёпрст) 1012 04.07.12 13:10 Сейчас в теме
Хотя..ща прикручу, "послушаю" народное мнение..
:)
19. Максим Шуйский (maxpiter) 139 04.07.12 13:11 Сейчас в теме
(17) мои тоже привыкли, но когда в списке ароматизаторов около 200 штук и все начинаются Ароматизатор и только потом различие, то проще набрать аром лимон :) и уже бегать глазками по оставшемуся десятку.
>> привыкли так ужо. - привычка дело может быть навязанной, причем в данном случае 1С :)
20. Ёпрст (Ёпрст) 1012 04.07.12 13:13 Сейчас в теме
Это ..еще недочет:

в ПриОткрытии, нужно проверить, что флагиерархического просмотра восстановлен..иначе болт
21. Максим Шуйский (maxpiter) 139 04.07.12 13:14 Сейчас в теме
22. Ёпрст (Ёпрст) 1012 04.07.12 13:18 Сейчас в теме
СпЗн = ПолучитьСписокЭлементов("Номенклатура"<<?>>);
{Справочник.Номенклатура.ФормаСписка.ФормаСписка.Модуль(100)}: Недостаточно фактических параметров
При проверке модуля обнаружены синтаксические ошибки!
23. Ёпрст (Ёпрст) 1012 04.07.12 13:20 Сейчас в теме
(21) этого нету

Процедура ПриОткрытии()
ТекФлагИерархическогоСписка = ВосстановитьЗначение("ТекФлагИерархическогоСпискаНоменклатура");

вот тут болт, ибо нет еще сохраненного "ТекФлагИерархическогоСпискаНоменклатура" при открытии при первом открытии, да и при закрытии сохранять нечего, если иерархию не меняли.
24. Максим Шуйский (maxpiter) 139 04.07.12 13:28 Сейчас в теме
(22) СпЗн = ПолучитьСписокЭлементов("Номенклатура",СтрокаСимволов);
(23) согласен, если пустое значение после ВосстановитьЗначение, то нужно получить текущее
25. Ёпрст (Ёпрст) 1012 04.07.12 13:33 Сейчас в теме
(24) :)

Это.. при нажатии Эскейп, нужно проверить, если строка символов не пустая (или было уже нажатия и потом удалили символы, короче, что уже есть использоватьсписокэлементов), то ФСО нужно делать = 0, а не 1, иначе справочник закроется.
26. Ёпрст (Ёпрст) 1012 04.07.12 13:38 Сейчас в теме
ну и это, чариндекс выкинуть из селекта и запихать в ордербай
27. Максим Шуйский (maxpiter) 139 04.07.12 13:46 Сейчас в теме
28. Ёпрст (Ёпрст) 1012 04.07.12 13:46 Сейчас в теме
29. Максим Шуйский (maxpiter) 139 04.07.12 13:54 Сейчас в теме
(28) ммм, вот это аргумент, в данном случае каждая миллисекунда дорога :)
30. Ёпрст (Ёпрст) 1012 04.07.12 14:00 Сейчас в теме
И это.. фсо всё же поправь для Esc
31. Максим Шуйский (maxpiter) 139 04.07.12 14:00 Сейчас в теме
+29 хотя у меня case в select работает все таки чуток быстрее, может быть кеш.
Отличие ооочень мизерное. Оставлю как есть :)
32. Максим Шуйский (maxpiter) 139 04.07.12 14:02 Сейчас в теме
(30) код который я представил у меня в форме списка, в форме выбора дейстивтельно есть небольшая добавочка
Если _код = 27 Тогда
Если СтрокаСимволов="" Тогда
Фсо = 1;
Возврат;
КонецЕсли;
....
33. Максим Шуйский (maxpiter) 139 04.07.12 14:22 Сейчас в теме
Вообще то. зная имя отбора и значение отбора, можно сгенерить условие фильтрации с учетом отбора :) и будет вообще хорошо
34. Евгений Долиновский (Dolly_EV) 262 05.07.12 15:38 Сейчас в теме
(0) CHARINDEX для 1SQLite (dbf) чем заменить? :-((
35. Евгений Долиновский (Dolly_EV) 262 05.07.12 16:37 Сейчас в теме
+(34) Мдаа... без CHARINDEX на DBF нелогично сортировка получается, юзер не поймет :-(
36. Максим Шуйский (maxpiter) 139 05.07.12 17:06 Сейчас в теме
37. Максим Шуйский (maxpiter) 139 05.07.12 17:09 Сейчас в теме
38. Dima Dima (dumal) 05.07.12 23:55 Сейчас в теме
Хорошая вещь. Можно внедрить в тех местах, где народ пользуется 7.7 и даже не планирует переходить на 8ку. Жаль только, sql...
39. Максим Шуйский (maxpiter) 139 05.07.12 23:59 Сейчас в теме
(38) в DBF пока уперлось в CHARINDEX, но может это все таки решаемо?
40. Dima Dima (dumal) 06.07.12 00:13 Сейчас в теме
Да, я прочитал в комментариях. Решения у меня нет :(
41. Евгений Долиновский (Dolly_EV) 262 06.07.12 05:48 Сейчас в теме
(36) 1.0.2.4 (уже 1.0.2.6)
Вместо чариндекс можно конечно огород нагородить с тз и Найти(СтрДляПозиции,Наименование), но скорость потеряется :-(
42. Ёпрст (Ёпрст) 1012 06.07.12 09:11 Сейчас в теме
(41) юзай запрос на фоксе - он быстрее и там есть аналог чариндекса - AT()
43. Евгений Долиновский (Dolly_EV) 262 06.07.12 09:49 Сейчас в теме
(42) а с монопольностью там нормально? и пример бы в студию
44. Ёпрст (Ёпрст) 1012 06.07.12 10:11 Сейчас в теме
(43) нормально.
Ставишь решение от hogik и привет
45. Ёпрст (Ёпрст) 1012 06.07.12 10:31 Сейчас в теме
+44
|select id as [Элем $Справочник.Номенклатура]
|,iif(at('туф',lower(descr))=0,999,at('туф',lower(descr))) as вася
|from $Справочник.Номенклатура спр
|where 
|(lower(descr) like '%туф%') 
|and 
|(lower(descr) like '%жен%')
|order by вася
...Показать Скрыть
46. Максим Шуйский (maxpiter) 139 06.07.12 10:38 Сейчас в теме
47. Ёпрст (Ёпрст) 1012 06.07.12 10:45 Сейчас в теме
(46) я твой код переделал..
мне лень даже 1cqa открыть
48. Евгений Долиновский (Dolly_EV) 262 06.07.12 10:58 Сейчас в теме
(44) ADS муторно :-(... хотя в 2009-м он меня реально спас. Сейчас решил по периферийкам - по дорастанию до критической массы - переводить на SQL
49. Евгений Долиновский (Dolly_EV) 262 06.07.12 11:00 Сейчас в теме
(45) дрова для Фокса - достаточно библиотек вот отсюда http://www.1cpp.ru/forum/YaBB.pl?num=1210677779/30 ?
50. Ёпрст (Ёпрст) 1012 06.07.12 11:09 Сейчас в теме
51. Ёпрст (Ёпрст) 1012 06.07.12 11:11 Сейчас в теме
52. Евгений Долиновский (Dolly_EV) 262 06.07.12 11:50 Сейчас в теме
(51) ааа, я это как-то упустил :-(( думал, ты имеешь ввиду вот эту: http://infostart.ru/public/15211/
53. Евгений Долиновский (Dolly_EV) 262 06.07.12 13:05 Сейчас в теме
(45) В ПриОткрытии():
		СтрСоединение = "Provider=VFPOLEDB.1;Data Source=" + КаталогИБ() + ";Exclusive=Yes;Mode=ReadWrite;Collating Sequence=MACHINE";
		ДБ = СоздатьОбъект("OLEDBData");
		Рез = ДБ.Соединение(СтрСоединение);
		лЗапросФокс = ДБ.СоздатьКоманду();
		лЗапросФокс.Выполнить("EXECSCRIPT('SET ANSI OFF')");  
		лЗапросФокс.Выполнить("EXECSCRIPT('SET REFRESH TO 0,-1')");
		лЗапросФокс.Выполнить("Exec('SET TABLEVALIDATE TO 0')");
		лЗапросФокс.Отладка(1);
...Показать Скрыть

ТекстЗапроса:
SELECT
	ID [Ссылка $Справочник.Номенклатура],
	iif(at('в',lower(Номенклатура.DESCR))=0,999,at('в',lower(Номенклатура.DESCR))) AS ПозицияВСтроке
FROM
	Справочник.Номенклатура AS Номенклатура
WHERE
	(Номенклатура.ISFOLDER >= 0)

AND (lower(Номенклатура.DESCR) LIKE '%в%')

ORDER BY ПозицияВСтроке,Номенклатура.DESCR
...Показать Скрыть


лТЗ=лЗапросФокс.ВыполнитьИнструкцию(ТекстЗапроса);
{Справочник.Номенклатура.ФормаСписка.Основная.Модуль(101)}: FAILED! ICommandText::Execute(): Too many arguments.

Где засада?
54. Евгений Долиновский (Dolly_EV) 262 06.07.12 13:14 Сейчас в теме
(53) все, разобрался.. ВЗЛЕТЕЛО! УРА! осталось только hogika прикрутить, чтобы в монопольном взлетело
P.S. Теперь и монопольно - спасибо hogik'у
55. Максим Шуйский (maxpiter) 139 06.07.12 13:16 Сейчас в теме
(54) при наборе текста, скорость фильтрации приемлемая?
56. Евгений Долиновский (Dolly_EV) 262 06.07.12 13:30 Сейчас в теме
(55) Приемлемо (Номенклатура 25K), причем на dbf через фокса - заметно бастрее получилось, чем через SQLite. На SQL - медленнее, но там у меня еще заморочка с получением остатков.

Только стоит все-таки наверно с третьего символа начинать фильтровать ?
и еще: для Esc при НЕпустой СтрокаСимволов надо ФСО=0 - а то форма выбора закрывается (30)
57. Максим Шуйский (maxpiter) 139 06.07.12 14:17 Сейчас в теме
(56) >> Только стоит все-таки наверно с третьего символа начинать фильтровать ?
Тоже не совсем логично может получиться.
В качестве идеи для обсуждения. Сделать как в поисковиках.
При открытии выдавать пустой справочник, при наборе выводить то что нашлось скажем TOP 20 пока не наберет больше 3х символов. Как больше трех набрал выводит все.
58. Максим Шуйский (maxpiter) 139 06.07.12 14:18 Сейчас в теме
+57 ну понятно, что эта опция для каждого может индивидуально настраиваться в настройках пользователя.
59. Евгений Долиновский (Dolly_EV) 262 06.07.12 15:06 Сейчас в теме
(56) Пока как есть оставил, пусть юзеры потестят, потом расспросим
60. Максим Шуйский (maxpiter) 139 26.07.12 10:22 Сейчас в теме
(18)(59) какой результат тестов, пользуются юзвери? :)
61. Евгений Долиновский (Dolly_EV) 262 31.07.12 03:51 Сейчас в теме
(60) из отпуска только сегодня, но судя по тому, что вопросов нет - пользуются, и видимо понравилось))