IE 2016

Установка 1С Предприятие 8.3 в Ubuntu Linux 12.04

Опубликовал bestuzhev в раздел Администрирование - Системное

Не так давно компания 1С выпустила новую платформу 8.3. Теперь есть клиент под Linux, вот его мы и будем ставить.

1. Ставим Ubuntu

Сперва нам нужно поставить сам Linux Ubuntu 12.04. Скачать его можно с официального сайта Ubuntu. Я выбрал версию i386.

Инструкцию можно найти на правторах интернета, например вот.

После установки Ubuntu и всех обновлений в итоге получаем:

2.Скачиваем все пакеты

Итак, нам понадобятся:

- Сама 1с 8.3 (Скачать можно отсюда). Нам нужна как клиентская так и серверная часть.

- Драйвер для HASP (Качаем отсюда)

Все архивы распаковываем и все складываем в одну папку. В итоге получаем список файлов:

1c-enterprise83-client_8.3.1-531_i386.deb
1c-enterprise83-client-nls_8.3.1-531_i386.deb
1c-enterprise83-common_8.3.1-531_i386.deb
1c-enterprise83-common-nls_8.3.1-531_i386.deb
1c-enterprise83-crs_8.3.1-531_i386.deb
1c-enterprise83-server_8.3.1-531_i386.deb
1c-enterprise83-server-nls_8.3.1-531_i386.deb
1c-enterprise83-ws_8.3.1-531_i386.deb
1c-enterprise83-ws-nls_8.3.1-531_i386.deb
dkms-aksparlnx_3.2-eter1ubuntu_all.deb
haspd_3.3-eter2ubuntu_i386.deb
haspd-modules_3.3-eter2ubuntu_i386.deb

3, Установка

Теперь нам нужно установить все это добро, для этого открываем терминал, переходим в дирректорию с нашими файлами и выполняем следующие команды:

sudo dpkg -i 1c-enterprise83-common_8.3.1-531_i386.deb

sudo dpkg -i 1c-enterprise83-common-nls_8.3.1-531_i386.deb

sudo dpkg -i 1c-enterprise83-server_8.3.1-531_i386.deb

sudo dpkg -i 1c-enterprise83-server-nls_8.3.1-531_i386.deb

sudo dpkg -i 1c-enterprise83-ws_8.3.1-531_i386.deb

sudo dpkg -i 1c-enterprise83-ws-nls_8.3.1-531_i386.deb

sudo dpkg -i 1c-enterprise83-crs_8.3.1-531_i386.deb

sudo dpkg -i 1c-enterprise83-client_8.3.1-531_i386.deb

sudo dpkg -i 1c-enterprise83-client-nls_8.3.1-531_i386.deb

Теперь ставим HASP

sudo dpkg -i haspd_3.3-eter2ubuntu_i386.deb

sudo dpkg -i haspd-modules_3.3-eter2ubuntu_i386.deb

sudo dpkg -i dkms-aksparlnx_3.2-eter1ubuntu_all.deb

Теперь настраиваем саму 1с.

Сперва устраняем зависимости:

sudo apt-get install imagemagick

sudo apt-get install unixodbc

sudo apt-get install libgsf-bin

sudo apt-get install t1utils

И последняя команда:

sudo /opt/1C/v8.3/i386/utils/config_system /usr/share/fonts

Выполняется не быстро.

4.Запуск

Втыкаем ключик HASP, ищем среди программ 1С Предприятие и запускаем.

Дальше добавляем базу и работаем!

См. также

PowerTools от 1 000

Лучшие комментарии

20. EfremoVich 12.07.2012 11:02
1. Установка ОС

Нам необходимо скачать и установить Ubuntu 12.04 на свой ПК.

Потом ставим все обновления. Стоить заметить что мы делали все это на 32 битовой ОС.

2. Скачиваем нужный нам дистрибутив.

Забегая на перед скажу что скачать нам надо как северный вариант так и толстый клиент. Софт без библиотек не будет работать, а нужные библиотеки почему то включили тока в серверный пакет.

И так качаем:

- Cервер 1С:Предприятия для DEB-based Linux-систем

- Клиент 1С:Предприятия для DEB-based Linux-систем

Посмотреть другие варианты пакетов под другие ОС можно здесь.

Ну вот скачали ? необходимо все извлечь из архивов, например на рабочий стол. Получаем список:

- 1c-enterprise83-client_8.3.1-531_i386.deb
- 1c-enterprise83-client-nls_8.3.1-531_i386.deb
- 1c-enterprise83-common_8.3.1-531_i386.deb
- 1c-enterprise83-common-nls_8.3.1-531_i386.deb
- 1c-enterprise83-crs_8.3.1-531_i386.deb
- 1c-enterprise83-server_8.3.1-531_i386.deb
- 1c-enterprise83-server-nls_8.3.1-531_i386.deb
- 1c-enterprise83-ws_8.3.1-531_i386.deb
- 1c-enterprise83-ws-nls_8.3.1-531_i386.deb

Жирным показано нужные нам дистрибутивы.

3. Установка 1С 8.3 - святое дело

Ставим пакеты в такое последовательности:

1) 1c-enterprise83-common_8.3.1-531_i386.deb

2) 1c-enterprise83-common-nls_8.3.1-531_i386.deb

3) 1c-enterprise83-server_8.3.1-531_i386.deb

4) 1c-enterprise83-server-nls_8.3.1-531_i386.deb

5) 1c-enterprise83-client_8.3.1-531_i386.deb

6) 1c-enterprise83-client-nls_8.3.1-531_i386.deb

Ну вот все и готово, а вы боялись злых бухгалтерш

Стоить заметить что в момент установки надо игнорировать источники пакетов.

Если установка будет проводиться через терминал, стоить нужные нам пакеты переместить в домашнюю папку пользователя, и выполнить такие команды в терминале:

1) sudo dpkg -i 1c-enterprise83-common_8.3.1-531_i386.deb

2) sudo dpkg -i 1c-enterprise83-common-nls_8.3.1-531_i386.deb

3) sudo dpkg -i 1c-enterprise83-server_8.3.1-531_i386.deb

4) sudo dpkg -i 1c-enterprise83-server-nls_8.3.1-531_i386.deb

5) sudo dpkg -i 1c-enterprise83-client_8.3.1-531_i386.deb

6) sudo dpkg -i 1c-enterprise83-client-nls_8.3.1-531_i386.deb

После установки мы получаем готовую 1с-ку:
+ 4 [ 1yh1; FSmile; Nelli_A86; efpara; ]
# Ответить
1. serega3333 06.07.2012 17:53
если бы дополнили как на виртуалку vmware еще поставить, было еще лучше
Ответили: (2) (77) (103) (126)
# Ответить
107. pablo_escobar 06.12.2013 12:26
Кто-нибудь ставил 8.3 на ubuntu 13.10? Сделал все по инструкции, но при запуске 1С вылетает ошибка "ошибка загрузки компоненты frame"
Ответили: (117)
# Ответить
36. Requiem 11.08.2012 20:36
Мне еще потребовался mscorefonts

sudo apt-get install msttcorefonts


И сконфигурировалось без ошибок только так

sudo /opt/1C/v8.3/i386/utils/config_system /usr/share/fonts/truetype/msttcorefonts
+ 1 [ nouscode; ]
# Ответить
15. arjuna 11.07.2012 08:20
Хоть бы один рассказал как конфигурацию ставил и показалл рабочий пример.
Ответили: (16) (42)
+ 1 [ kirillkr; ]
# Ответить

Комментарии

1. serega3333 06.07.2012 17:53
если бы дополнили как на виртуалку vmware еще поставить, было еще лучше
Ответили: (2) (77) (103) (126)
# Ответить
2. bestuzhev 06.07.2012 18:48
(1) (1) serega3333, А всем проблема? Тоже самое только в виртуальной машине
# Ответить
3. Stamper 07.07.2012 10:04
(0) а толковая инструкция по установке PostgreSQL для 1С на Ubuntu имеется?
заранее благодарен
# Ответить
4. no_registration 07.07.2012 10:26
Зделал все как написано (ubuntu 12.04 x64). Запускаю 1С, окно программы появляется и сразу пропадает. Ошибок не пишет. Кто с таким сталкивался?
Ответили: (10)
# Ответить
5. DoctorRoza 07.07.2012 16:32
Поделитесь, как работает 1с в Ubuntu? Давно хочу слезть со взломанной винды 7 на свободную операционную систему, но все в 1с упиралось. Теперь же, думаю, все образуется! ))
Ответили: (37)
# Ответить
6. dedtver 08.07.2012 09:53
Спасибо за обзор, сегодня буду ставить. Тоже слезаю.
# Ответить
7. dedtver 08.07.2012 09:56
Установить пакеты можно и так: переход в папку cd /home/user/1c/
Sudo dpkg -i *.deb
# Ответить
8. bforce 10.07.2012 15:00
Чем ваша статья отличается от этой?
Публикация по ссылке появилась на 2 дня раньше.
Ответили: (9) (14)
+ 1 [ Vladal; ]
# Ответить
9. Reaper_1C 10.07.2012 16:38
(8) bforce, спасибо. Я до сих пор в недоумении, зачем нужна модерация при таком подходе?..
# Ответить
10. Meloman1 10.07.2012 17:07
(4) no_registration, У меня была та же ботва. Я откатил Ubuntu 11.04 до состояния, кот. было до установки 1с и сделал всё последовательно строго по этой инструкции, только пришлось ещё доустановить пакет "tt2pt1" и запустить последний скрипт ещё раз. И - заработало!
Ответили: (17)
# Ответить
11. kirillkr 10.07.2012 17:41
Я что-то не нашел как создавать пустую базу в клиенте. Это возможно или только из установленных, или подключаться к имеющейся базе?
# Ответить
12. awk 11.07.2012 00:18
(0) Зависимости...
на:
No truetype conversion utility found!
Please install ttf2afm or ttf2pt1!

делаем:

sudo apt-get install texlive-binaries
+ 1 [ chizh.84; ]
# Ответить
13. soba 11.07.2012 02:22
А с программными лицензиями нормально дружит? А то 1С HASP теперь не любит поставлять
# Ответить
14. bestuzhev 11.07.2012 07:16
(8) bforce, Более подробно написано + есть как ставить дрова на HASP.
Не все же хорошо знают Linux.
# Ответить
15. arjuna 11.07.2012 08:20
Хоть бы один рассказал как конфигурацию ставил и показалл рабочий пример.
Ответили: (16) (42)
+ 1 [ kirillkr; ]
# Ответить
16. bestuzhev 11.07.2012 11:10
(15) arjuna, Ну как я понял развернуть exe-шник с конфой можно только в винде. Напиши что именно тебя интересует, без проблем сделаю и дополню.
Ответили: (18)
# Ответить
17. no_registration 11.07.2012 13:30
(10) Meloman1, Это меня и пугает :-). Подожду финальной версии. И тогда уже буду дальше стучать в бубен. За совет спасибо.
# Ответить
18. arjuna 11.07.2012 21:23
(16) bestuzhev,

Умеет ли линукс читать файл бызы 1Cv8.1CD ?
Ответили: (25)
+ 1 [ bestuzhev; ]
# Ответить
19. arjuna 12.07.2012 10:32
и куда это все умники подевались?
# Ответить
20. EfremoVich 12.07.2012 11:02
1. Установка ОС

Нам необходимо скачать и установить Ubuntu 12.04 на свой ПК.

Потом ставим все обновления. Стоить заметить что мы делали все это на 32 битовой ОС.

2. Скачиваем нужный нам дистрибутив.

Забегая на перед скажу что скачать нам надо как северный вариант так и толстый клиент. Софт без библиотек не будет работать, а нужные библиотеки почему то включили тока в серверный пакет.

И так качаем:

- Cервер 1С:Предприятия для DEB-based Linux-систем

- Клиент 1С:Предприятия для DEB-based Linux-систем

Посмотреть другие варианты пакетов под другие ОС можно здесь.

Ну вот скачали ? необходимо все извлечь из архивов, например на рабочий стол. Получаем список:

- 1c-enterprise83-client_8.3.1-531_i386.deb
- 1c-enterprise83-client-nls_8.3.1-531_i386.deb
- 1c-enterprise83-common_8.3.1-531_i386.deb
- 1c-enterprise83-common-nls_8.3.1-531_i386.deb
- 1c-enterprise83-crs_8.3.1-531_i386.deb
- 1c-enterprise83-server_8.3.1-531_i386.deb
- 1c-enterprise83-server-nls_8.3.1-531_i386.deb
- 1c-enterprise83-ws_8.3.1-531_i386.deb
- 1c-enterprise83-ws-nls_8.3.1-531_i386.deb

Жирным показано нужные нам дистрибутивы.

3. Установка 1С 8.3 - святое дело

Ставим пакеты в такое последовательности:

1) 1c-enterprise83-common_8.3.1-531_i386.deb

2) 1c-enterprise83-common-nls_8.3.1-531_i386.deb

3) 1c-enterprise83-server_8.3.1-531_i386.deb

4) 1c-enterprise83-server-nls_8.3.1-531_i386.deb

5) 1c-enterprise83-client_8.3.1-531_i386.deb

6) 1c-enterprise83-client-nls_8.3.1-531_i386.deb

Ну вот все и готово, а вы боялись злых бухгалтерш

Стоить заметить что в момент установки надо игнорировать источники пакетов.

Если установка будет проводиться через терминал, стоить нужные нам пакеты переместить в домашнюю папку пользователя, и выполнить такие команды в терминале:

1) sudo dpkg -i 1c-enterprise83-common_8.3.1-531_i386.deb

2) sudo dpkg -i 1c-enterprise83-common-nls_8.3.1-531_i386.deb

3) sudo dpkg -i 1c-enterprise83-server_8.3.1-531_i386.deb

4) sudo dpkg -i 1c-enterprise83-server-nls_8.3.1-531_i386.deb

5) sudo dpkg -i 1c-enterprise83-client_8.3.1-531_i386.deb

6) sudo dpkg -i 1c-enterprise83-client-nls_8.3.1-531_i386.deb

После установки мы получаем готовую 1с-ку:
+ 4 [ 1yh1; FSmile; Nelli_A86; efpara; ]
# Ответить
21. EfremoVich 12.07.2012 11:04
Однако это еще не все. При новом запуске проверочного скрипта он выдал сообщение:

No truetype conversion utility found!

Please install ttf2afm or ttf2pt1!

Поиск в каталоге Ubuntu не дал результата, однако в интернете я нашел требуемый пакет, скачал в папку Загрузки, нажал правой клавишей на нем и выбрал пункт меню «Открыть в Центр приложений Ubuntu». Далее в Центре приложений выбрал пункт «Установить».

Этот пакет вы можете скачать на нашем сайте по нижеприведенной ссылке:

ttf2pt1_3.4.4-1.3_amd64.deb

Ну вот и все. Осталось только установить ключ. Версия для Linux работает как с аппаратной защитой, так и с программной. У меня куплена программная защита, однако инсталляцию программной лицензии мы разберем в следующей статье.

Что касается аппаратной защиты, то вам надо будет скачать и установить драйвер аппаратного ключа.
Ответили: (28)
+ 1 [ titakovserg; ]
# Ответить
22. EfremoVich 12.07.2012 11:04
Все архивы распаковываем и все складываем в одну папку. В итоге получаем список файлов:
1c-enterprise83-client_8.3.1-531_i386.deb
1c-enterprise83-client-nls_8.3.1-531_i386.deb
1c-enterprise83-common_8.3.1-531_i386.deb
1c-enterprise83-common-nls_8.3.1-531_i386.deb
1c-enterprise83-crs_8.3.1-531_i386.deb
1c-enterprise83-server_8.3.1-531_i386.deb
1c-enterprise83-server-nls_8.3.1-531_i386.deb
1c-enterprise83-ws_8.3.1-531_i386.deb
1c-enterprise83-ws-nls_8.3.1-531_i386.deb
dkms-aksparlnx_3.2-eter1ubuntu_all.deb
haspd_3.3-eter2ubuntu_i386.deb
haspd-modules_3.3-eter2ubuntu_i386.deb
3, Установка
Теперь нам нужно установить все это добро, для этого открываем терминал, переходим в дирректорию с нашими файлами и выполняем следующие команды:
sudo dpkg -i 1c-enterprise83-common_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-common-nls_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-server_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-server-nls_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-ws_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-ws-nls_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-crs_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-client_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-client-nls_8.3.1-531_i386.deb
Теперь ставим HASP
sudo dpkg -i haspd_3.3-eter2ubuntu_i386.deb
sudo dpkg -i haspd-modules_3.3-eter2ubuntu_i386.deb
sudo dpkg -i dkms-aksparlnx_3.2-eter1ubuntu_all.deb
Теперь настраиваем саму 1с.
Сперва устраняем зависимости:
sudo apt-get install imagemagick
sudo apt-get install unixodbc
sudo apt-get install libgsf-bin
sudo apt-get install t1utils
И последняя команда:
sudo /opt/1C/v8.3/i386/utils/config_system /usr/share/fonts
Выполняется не быстро.
# Ответить
23. EfremoVich 12.07.2012 11:06
Пользуйтесь поиском друзья. Мое личное мнение что под WINE 8.2 работает быстрее чем 8.3
# Ответить
24. Denov 12.07.2012 14:35
Здорово, теперь и на линухе можно работать в 1С. Ща попробую установить. Спасибо!
# Ответить
25. bestuzhev 12.07.2012 14:36
(18) arjuna,
Конечно, причем работает в управляемой и обычном интерфейсе.
Ответили: (27)
# Ответить
26. SERJ_1CC 12.07.2012 17:38
Вот это да, а я голову ломал, надо затестить, может что путевого и получится))).. Хотя судя по отзывам на других форумах, глючит, вылетает постоянно...
А на мак сделают когда нить?
# Ответить
27. arjuna 17.07.2012 21:43
(25) bestuzhev,
Ну в управляемом это понятно, а вот в толстом клиенте это конечно супер. Т.е если я правильно понял установка конфигураций в виде exe файла конечно работать не будет (возможно скоро выпустят спец пакеты для линукса). Нужно обязательно имет машину с виндой для установки обновлений и извлечения файлов конфигурации, а потом подготовленные файлы переносить на линукс и там обновлять. Кстати а CF файлы конфигурации будут читаться на линуксе? никто не пробовал обновлять на линуксе через CF или через CFU?
Ответили: (29)
# Ответить
28. Meloman1 18.07.2012 16:07
29. Meloman1 18.07.2012 19:13
(27) arjuna, Я установил 1с 8.3 на Xubuntu 12.10 i386 и через конфигуратор без проблем обновил конфигурацию БП 3.0 (клиент-сервер SQL),(правда, в HOSTS пришлось добавить строчку со своим сервером).
Ответили: (30)
# Ответить
30. arjuna 19.07.2012 15:13
(29) Meloman1, Только в серверном варианте? в файловом не пробовали.
Ответили: (31)
# Ответить
31. Meloman1 19.07.2012 16:23
(30) arjuna, Установил (ради Вас) "Retail 2.0 demo" в файловом варианте на Xubuntu без всяких проблем! Работает в режиме "тонкого клиента".
Ответили: (32)
# Ответить
32. arjuna 19.07.2012 18:18
(31) Meloman1,
И, правда правда, самый последний вопрос. Файловый вариант ТОЛСТЫЙ КЛИЕНТ тоже работает?
Ответили: (34)
# Ответить
33. sergiobargio1 20.07.2012 00:18
попытался установить 1с:предприятия 8.3 на 64-битную ubuntu 12.04.
все команды использовал те же только "_i386" заменял на "_amd64".
так же файлы для ключа защиты скачал уже из папки ftp://ftp.etersoft.ru/pub/Etersoft/HASP/last/x86_64/Ubuntu/12.04/
после выполнения строки каждой команды выдаёт сообщение:
"...При обработке следующих пакетов произошли ошибки ..."
или "... Выбор ранее не выбранного пакета 1c-enterprise83-common-nls.
dpkg: не удалось обработать параметр 1c-enterprise83-common-nls_8.3.1-531_amd64.deb (--install): ..."
пожалуйста подскажите какие нюансы при установке 1 с предприятия 8.3 на 64-битную ubuntu ?
# Ответить
34. Meloman1 20.07.2012 18:08
(32) arjuna, Установил и Налогоплательщик 3.0. Работает в режиме "толстого" клиента.
# Ответить
35. xzevsx 01.08.2012 13:13
Тоже планируем переход
# Ответить
36. Requiem 11.08.2012 20:36
Мне еще потребовался mscorefonts

sudo apt-get install msttcorefonts


И сконфигурировалось без ошибок только так

sudo /opt/1C/v8.3/i386/utils/config_system /usr/share/fonts/truetype/msttcorefonts
+ 1 [ nouscode; ]
# Ответить
37. kirilka 29.08.2012 14:59
(5) DoctorRoza, Не образумиться! 8.3 еще долго будет в тестовом режиме.
# Ответить
38. soft070 05.09.2012 22:33
Если кому интересно. У меня возникли следующие проблемы: после перезагрузки не работал демон HASP и соответственно не видел ключа.
помогло:
sudo hasplmd -s
sudo reboot
# Ответить
39. q_i 10.09.2012 23:16
что нужно сделать чтобы оно увидело ключ по сети?
----------
разобрался
нужно в /opt/1C/v8.3/i386/conf закинуть правильно настроенный nethasp.ini
+ 1 [ sh_max; ]
# Ответить
40. Tsr1c 28.09.2012 14:26
Скажите а у всех получилось завести hasp на 12.04 вроде в ней не работают указанные драйвера.
У меня получилось завести эти драйвера под ядром 2.6... , но это не рабочий вариант.
Кто как решал эту проблему?
# Ответить
41. titakovserg 18.10.2012 16:20
У меня получилось поставить на ubuntu 12.4-i386. Делал всё как описано в статье. Тоже возникла проблема со шрифтами "No truetype conversion utility found! Please install ttf2afm or ttf2pt1!", решил способом указанным в сообщении 21. Аппаратный ключ увиделся только после перезагрузки.

А подскажите теперь как настроить в ubuntu доступ к сетевому ключу, какой здесь (в версии 1С под ubuntu) аналог файла nethasp.ini?

З.Ы. Увидел ответ на свой вопрос в посте (39) :)
# Ответить
42. titakovserg 18.10.2012 16:46
(15) arjuna, для тебя принципиально именно устанавливать конфу? А если просто *.cf загрузить?
Ответили: (43)
# Ответить
43. arjuna 18.10.2012 19:26
(42)да нет не принципиально.
# Ответить
44. Damian 31.10.2012 21:09
dkms-aksparlnx_3.2-eter1ubuntu_all.deb
haspd_3.3-eter2ubuntu_i386.deb
haspd-modules_3.3-eter2ubuntu_i386.deb
С этими пакетами ключ не пошел, писало постоянно, что ключ не найден.
Пришлось их снести и установить Sentinel HASP/LDK Ubuntu, DEB Run-time Installer
После этого все заработало.

Попробовал конфигурации "Бухгалтерия для Украины" и "Управление торговым предприятием для Украины".
С шаблонами не парился, скопировал файлы *.1CD да и все )

В Бухгалтерии попытался выгрузить налоговую накладную в XML, 1С благополучно молча упала с сообщением "Ключ защиты больше недоступен".

В УТП попробовал выгрузить данные в идентичную конфигурацию (опять-таки XML :). Выпало с той же ошибкой о ключе, но успело написать: "Ошибка при создании COM-объекта Msxml2.DOMDocument".

Предполагаю, что COM-объекты вообще никакие работать не захотят, в том числе внешние компоненты и компоненты защиты конфигураций...
Таким образом, получается, что полностью пересесть на Linux не получится пока... :)
Ответили: (45)
# Ответить
45. arjuna 02.11.2012 13:12
(44) С этими пакетами ключ не пошел, писало постоянно, что ключ не найден.
Пришлось их снести и установить Sentinel HASP/LDK Ubuntu, DEB Run-time Installer
После этого все заработало.

Спасибо большое, я уж несколько вариантов линукса переставлял и драйвера от єтерсофт все перепробовал, ничего не получалось. Теперь по поводу железа: не пытайтесь ставить на старые машины, 1с не потянут. У меня при попытке открыть любой документ отваливался ключ. Только после установки на современный комп все прошло успешно.Выгрузить в XML тоже не получилось, т.е. для бухгалтерии пока не в полном объеме работает, а вот для торговли вполне пойдет.
# Ответить
46. 1977 27.11.2012 17:27
Не кто не пыталься сделать на линуксе веб раздачу?
# Ответить
47. San40s 11.01.2013 15:31
У меня на Xubuntu 11.10 была следующая проблема при запуске через консоль выдавало сообщение:
WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-e1WHkO/pkcs11: Нет такого файла или каталога
Лечится данная проблема правкой файла /etc/xdg/autostart/gnome-keyring-pkcs11.desktop
в сторочке OnlyShowIn=GNOME;Unity; дописать или заменить на параметр Xfce;
OnlyShowIn=Xfce;
Перезапустить комп. При первом перезапуске система немного притормаживает но на следующий перезапуск все норм.
Пока что не могу никак вылечить сообщение:
Gtk-CRITICAL **: gtk_window_realize: assertion `!gtk_widget_get_realized (widget)' failed
# Ответить
48. 1977 05.02.2013 20:54
Все сделал по инструкции. Проблема со шрифтами . Не пропорционально. Для работы в терминале линукса понадобилась команда mc (старый добрый нортон командер).

Прикрепленные файлы:

щрифт.jpg
# Ответить
49. Prompak 11.02.2013 20:29
Пробовал ubuntu12.04lts 32bit + rx@etersoft + 1C8.3 фаловая, итог - еще сыро и мокро, будем надеяться что к финальному релизу хоть что-то допилят. Сейчас экспериментирую с вайном, не эторсофт, поскольку последний - платный. Пакеты *nls не обязательны, если язык интерфейса русский, это языковые пакеты.
# Ответить
50. Bukaska 11.02.2013 21:05
Короче делаю вывод.. Для Линухов ещё почва сырая))) Лучше подождёмс)
# Ответить
51. AlexxJ 12.02.2013 17:39
никто не пробовал прописать сетевую БД?
# Ответить
52. maverick76 14.02.2013 01:11
Давно хотел поэкспериментировать...
# Ответить
53. 1977 14.02.2013 21:47
Ключ usb не пошёл, платформа 8.3 лечиться ?
Ответили: (66)
# Ответить
54. Prompak 16.02.2013 02:01
Можно ключ использовать по сети с виндовой машины если таковая имееися.
# Ответить
55. swamp 04.03.2013 14:29
1. как ее теперь удалить?
2. кто нибудь работал в связке с postgreSQL?
Ответили: (56)
# Ответить
56. q_i 04.03.2013 14:45
(55) swamp, в теории apt-get remove (или apt-get purge) ;)
для связки с postgresql нужен сервер 1С (собственно, а что там может не работать, если оно работает даже в 8.2 на продакшене).
Ответили: (57)
# Ответить
57. swamp 04.03.2013 15:40
(56) q_i, тут такая ситуация - нужна альтернатива COM-соединению, которая работает только на Винде
# Ответить
58. swamp 04.03.2013 15:41
не могу понять почему не получается установить только клиент.

root@ilya:/home/swamp/tmp# dpkg -i *.deb
Выбор ранее не выбранного пакета 1c-enterprise83-client.
(Чтение базы данных ... на данный момент установлено 174459 файлов и каталогов.)
Распаковывается пакет 1c-enterprise83-client (из файла 1c-enterprise83-client_8.3.2-172_i386.deb)...
Выбор ранее не выбранного пакета 1c-enterprise83-client-nls.
Распаковывается пакет 1c-enterprise83-client-nls (из файла 1c-enterprise83-client-nls_8.3.2-172_i386.deb)...
dpkg: зависимости пакетов не позволяют настроить пакет 1c-enterprise83-client:
1c-enterprise83-client зависит от 1c-enterprise83-common (= 8.3.2-172), однако:
Пакет 1c-enterprise83-common не установлен.
1c-enterprise83-client зависит от 1c-enterprise83-server (= 8.3.2-172), однако:
Пакет 1c-enterprise83-server не установлен.
dpkg: не удалось обработать параметр 1c-enterprise83-client (--install):
проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет 1c-enterprise83-client-nls:
1c-enterprise83-client-nls зависит от 1c-enterprise83-client (= 8.3.2-172), однако:
Пакет 1c-enterprise83-client пока не настроен.
dpkg: не удалось обработать параметр 1c-enterprise83-client-nls (--install):
проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Обрабатываются триггеры для desktop-file-utils ...
Обрабатываются триггеры для gnome-menus ...
При обработке следующих пакетов произошли ошибки:
1c-enterprise83-client
1c-enterprise83-client-nls
root@ilya:/home/swamp/tmp#



как устранить проблемы зависимостей?
# Ответить
59. swamp 04.03.2013 16:03
хотя установив все пакеты все установилось, но в выборе только тонкий клиент. мне нужен обычный. ЧЯДНТ?
# Ответить
60. andrewks 06.03.2013 19:28
1.в процессе выполнения команды "sudo /opt/1C/v8.3/i386/utils/config_system /usr/share/fonts" выкинуло ошибку системы:
/opt/1C/v8.3/i386/utils/config_system: строка 33: 2757 Ошибка сегментирования (подготовлен дамп ядра) ttf2afm ${ttfPath} 2> /dev/null > ${afmPath}

но после этого 1с запускается. чем это может грозить?

2. ни в одном поле ввода 1ски (модуль в конфигураторе, название реквизита, поля в режиме предприятия, даже поле в индексе справки) не вводятся буквы (ни в английском, ни в русском регистре). при этом знаки препинания, цифры вводятся нормально. это что за нереальная жесть, и как с ней бороться?
(если копипастить, то текст вставляется, а с клавиатуры - никак)

ubuntu 12.04 lts x32, 1c 8.3.2.172
# Ответить
61. logdog 06.03.2013 20:20
я вот думаю рано тестить бету версию...
Ответили: (62)
# Ответить
62. andrewks 06.03.2013 21:04
(61) logdog, больше смахивает на альфу
# Ответить
63. logdog 06.03.2013 23:26
хотя да, с учетом их переноса срока выпуска первого стабильного релиза с февраля на апрель)
# Ответить
64. V_V_V 21.03.2013 13:49
UbuntuStudio 12.10
Ставится (и ставилось) все без проблем. Только обычно допиливал по рекомендациям отсюда. А сейчас при выполнении sudo /opt/1C/v8.3/i386/utils/config_system /usr/share/fonts выдает ошибку:
/opt/1C/v8.3/i386/utils/config_system: строка 33: 19946 Ошибка сегментирования (подготовлен дамп ядра) ttf2afm ${ttfPath} 2> /dev/null > ${afmPath}
При выполнении sudo /opt/1C/v8.3/i386/utils/config_system /usr/share/fonts/truetype/msttcorefonts все проходит замечательно. Но 1С так и не стартует, в логах пишет что-то типа:
1cv8[29932]: segfault at 0 ip b7071470 sp bfd227d0 error 6 in wbase.so[b6fe6000+1ad000]
Никто не сталкивался?
Ответили: (65)
# Ответить
65. MegaMouse 30.03.2013 22:41
(64) Только что поставил (правда инструкцию эту нашел пока платформа 1с ставилась) 12,04
Встало без проблемм, выдало аналогичную ошибку в конце , списал это на параллельное обновление Убунты.
Перед установкой 1С устранил все неудовлетворенные зависимости.(проверь, может в этом дело).
Для распаковки сетапа конфы установил wine из репов - около 90 метров выкачало.
До перезагрузки не видело ключ, теперь все в норме. Позже уберу этот атавизм - неудобно туда-сюда его дергать.
На данный момент проблеммы с установкой каталога шаблонов для Вайна и 1С - но это не смертельно можно и скопировать.
И возможно небудет шрифта в реготчетах.
# Ответить
66. MegaMouse 30.03.2013 23:01
(53) Все прекрасно идет . Ссылка на хасп дрова выше была. А если не пойдет - к Вайну присмотритесь.
# Ответить
67. ivpavlovsky 13.04.2013 19:21
На Ubuntu 12.10-32 1С 8.3.2 завелась нормально... без лишних вопросов
# Ответить
68. mexicanose 30.04.2013 16:35
поставил а как включить режим совместимости с базой 8.2 ?
# Ответить
69. Nigelist 02.06.2013 16:58
Народ, а чем заменить утилиту config_system в финальной версии 8.3.3.641? А то утилиту выпилили, а как проверить не понятно.
Ответили: (71)
# Ответить
70. Bukaska 02.06.2013 22:24
Ну как на убунте 12.04 работает 8.3? Или есть ещё какие проблемы со шрифтами или ещё с чем?
# Ответить
71. bzmax 03.06.2013 02:32
(69) Nigelist,

А просто запусти 1С, оно теперь при запуске само анализ делает и говорит чего не хватает.
("набор джентльмена" остался прежним:
imagemagick
unixodbc
libgsf-bin
t1utils
ttf2pt1
)

В Ubuntu 13.04 после установки все работает отлично, кроме конфигуратора (он запускается но визуально его не видно). Баг с юнити и компизом.
Приходиться временно ставить окружение xfce, запускать конфигуратор. После первого запуска конфигуратор в юнити становится видимым. (Эх и тут без бубна не обошлось).
Ответили: (72) (87)
# Ответить
72. Nigelist 03.06.2013 13:48
(71) запустить на сервере 1С? Сам сервис? Сервис стартует без проблем.
# Ответить
73. bzmax 03.06.2013 16:39
Если ты имел ввиду именно 1С-сервер. (то что я описал относится к клиентскому приложению).
В варианте с сервером скорее всего можно только догадываться. Либо читать логи сервера.
Но у меня при установке "джентельменсокго набора" и запуске 1С-сервер на Ubuntu 12.04 (server) 1C-сервер запустился "из коробки".
Ответили: (74)
# Ответить
74. Nigelist 03.06.2013 17:09
(73) Да... Всё чудесатее и чудесатее! Почему эти пакеты не добавить в зависимости клиента и сервера 1с? И как базу создавать из Linux'a? Вроде утилита какая то должна быть, никто не в курсе?
Ответили: (76)
# Ответить
75. Nigelist 03.06.2013 18:14
При попытке создания базы в Windows 7 х64 получаю:
Ответили: (77)

Прикрепленные файлы:

1cv83_db_create_error_01.png
# Ответить
76. bzmax 03.06.2013 19:23
(74) Nigelist,
Утилитка есть. Только она консольная :) Т.е. открываешь в линуксе консоль и руками вбиваешь комманды по созданию и администрированию баз данных.
Ответили: (78)
# Ответить
77. bzmax 03.06.2013 19:28
(75) Nigelist,
А вот такие перлы как правильно из-за некорректных записей в файле /etc/hosts

допустим полное имя твоего сервера srv1c.mydomain.loc , а адрес 192.168.100.5

В этом файле должна быть следующие строки

127.0.0.1 localhost
192.168.100.5 srv1c.mydomain.loc srv1c

И больше ничего.

Но самое интересное что это должно быть перед(!) установкой сервера 1С иначе в своих конфигурационных файлах он(1С) неверно пропишет адресацию сервера.
Ответили: (79)
# Ответить
78. Nigelist 03.06.2013 19:55
(76) не подскажете где эту утилиту искать?
# Ответить
79. Nigelist 04.06.2013 08:15
(77) или вы имеете в виду команду создания баз createdb?
# Ответить
80. aserg 04.06.2013 08:33
Вместо перечня команд:

sudo dpkg -i 1c-enterprise83-common_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-common-nls_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-server_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-server-nls_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-ws_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-ws-nls_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-crs_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-client_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-client-nls_8.3.1-531_i386.deb

Можно: sudo dpkg -i 1c-enterprise83*.deb

Для проверки того, все ли пакеты установились корректно выполняем комадну:
$ dpkg -l | grep 1c-enterprise83

1C была установлена в ОС LinuxMint x32
Ответили: (102)
# Ответить
81. Nigelist 04.06.2013 09:10
Кстати, для чего нужны nls пакеты?
# Ответить
82. irq15 18.06.2013 11:03
Вопрос маленько не в топку, но уже весь инет облазил.
1с и сервер и клиент встала нормально, нужно запустить config_server из папки utils ... а у меня нет этой папки.
Сначала думал мало ли может в 64х забыли положить, поставил 32х та же фигня у меня просто нет этой папки
есть папки doc license redme и все.
Может кто сталкивался?

либо если у всех все нормально, вышлите плиз эту папочку от 64 1с последнего релиза
Ответили: (83)
# Ответить
83. Nigelist 18.06.2013 11:13
(82) так нету этой утилиты в последнем релизе 8.3. Думаете просто так эту тему я поднимал? Кстати, в бета-версиях 8.3 утилита называлась config_system, а не config_server.
# Ответить
84. irq15 18.06.2013 11:48
Тогда вопрос
при запуске клиент ругается на libwand.so. как это исправлять без утилитки?
Ответили: (85)
# Ответить
85. Nigelist 18.06.2013 12:12
(84) imagemagick ставить надо. А искать можно примерно так:
sudo apt-cache search wand

Получаете примерно такую выдачу и среди выдачи ищете нужный вам пакет.
x-pgp-sig-el - X-PGP-Sig mail and news header utility for Emacs
gjay - An automatic and learning DJ for audacious
libmagickcore5 - low-level image manipulation library
libmagickwand-dev - image manipulation library - development files
libmagickwand5 - image manipulation library
r-cran-kernsmooth - GNU R package for kernel smoothing and density estimation
lbdb - Little Brother's DataBase for the mutt mail reader
libreoffice-l10n-rw - office productivity suite -- Kinarwanda language package
libtemplate-perl - the "Template Toolkit" template processing system in perl
libpacketdump3 - network trace processing library supporting many input formats
libpacketdump3-dev - development headers for the libtrace network processing library
libtrace-tools - helper utilities for use with the libtrace process library
libtrace3 - network trace processing library supporting many input formats
libtrace3-dev - development headers for the libtrace network processing library
mhc - schedule management tool for emacsen
morla - GTK+ RDF editor
mu-cite - message citation utility for emacsen
openoffice.org-l10n-rw - office productivity suite -- Kinarwanda language package
r-recommended - GNU R collection of recommended packages [metapackage]
select-xface - utility for selecting X-Face on emacsen
sugarplum - an automated and intelligent spam trap/cache-poisoner
wl - mail/news reader supporting IMAP for emacsen
wl-beta - mail/news reader supporting IMAP for emacsen (development version)
xscreensaver-data-extra - data files to be shared among screensaver frontends
...Показать Скрыть
+ 1 [ irq15; ]
# Ответить
86. irq15 18.06.2013 13:35
спасибо сегодня попробую, я так понял
libmagickwand5 а потом на него ссылку сделать
Ответили: (87)
# Ответить
87. Nigelist 18.06.2013 13:53
(86) попробуйте для начала поставить все пакеты указанные в сообщении (71), а уж потом, если проблема не решиться, то ставьте этот пакет.
# Ответить
88. irq15 19.06.2013 06:02
ttf2pt1 в репах 13.04 не нашла, остальное поставилось, 1с фурычет.
Спасибо за ответ.
Ответили: (89)
# Ответить
89. Nigelist 19.06.2013 07:48
(88) можете поставить texlive-base. Этот пакет может заменить ttf2pt1.
# Ответить
90. irq15 19.06.2013 12:56
Спасибо попробую, это я так понимаю дабы виндовые шрифты робили?

и вопрос философского плана, можно ли на базе сервера 8.3 запустить 1с 8.1, 8.0?
Ибо сейчас 3 физических на 3х виндовых серверах, что вообще не удобно да и дорого. А вместе они не работают
Ответили: (97)
# Ответить
91. Nigelist 19.06.2013 17:24
Нет, для установки шрифтов MS, есть пакет: ttf-mscorefonts-installer
# Ответить
92. irq15 20.06.2013 06:06
по поводу шрифтов да, а на 90 пост кто нить что-то ответить может? никто не пробовал?
Ответили: (93)
# Ответить
93. Nigelist 20.06.2013 06:42
(92)На одном физическом сервере можно запустить три версии сервера 1С: 8.1, 8.2 и 8.3. Каждая версия устанавливается в отдельный каталог.
# Ответить
94. irq15 20.06.2013 22:04
еще вопрос по аппаратной части, 3 ключа не сильно "посруться" между собой на 1 железке?
Ответили: (96)
# Ответить
95. irq15 20.06.2013 22:05
а для 8.0 получается без вариантов отдельную?
Ответили: (96)
# Ответить
96. Nigelist 21.06.2013 06:47
(94)Вообще-то не рекомендуется, но не пробовал.
(95)В принципе можно на ту же машину.
# Ответить
97. artemka 21.06.2013 08:06
(90) irq15, А зачем вам 8.0?
# Ответить
98. irq15 21.06.2013 08:17
сейчас рабочая 82, 81 и 80 там бух архив, они туда иногда ползают, доки сверяют.
вот и приходиться их держать (
# Ответить
99. irq15 21.06.2013 08:18
просто в винде не прокатывало держать их вместе (
Ответили: (100)
# Ответить
100. Nigelist 21.06.2013 09:12
(99)на Linux можно, только порты переназначить надо. Для рабочей базы оставьте по умолчанию, а для архивных измените.
# Ответить
101. irq15 24.06.2013 18:01
спасибо попробую
# Ответить
102. bzmax 28.06.2013 03:22
(80) aserg,
Зачем весь "мусор" то тащить в систему?

sudo dpkg -i 1c-enterprise83-common_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-common-nls_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-server_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-server-nls_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-ws_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-ws-nls_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-crs_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-client_8.3.1-531_i386.deb
sudo dpkg -i 1c-enterprise83-client-nls_8.3.1-531_i386.deb


NLS-ы точно не нужно (это для дистрибов где русской кодировки нет, а такие сейчас поискать нужно :))
WS-ка нужна только если собираешся веб-сервис публиковать (не путать с управляемыми формами по HTML они и без публикации WS работают, при правильной настройке "Апача")
# Ответить
103. bzmax 28.06.2013 03:29
(1) serega3333,
если бы дополнили как на виртуалку vmware еще поставить, было еще лучше


что то я не вразумил эту фразу...
vmware - и есть виртуалка. Зачем на виртуалку еще виртуалку ставить? СубВиртуалка получается что ли?
Если интересует виртуалка на линукс то используйте virtualbox от Oracle почти для всех возможных дистрибов есть бинарники и репы (кому что по вкусу). А самое главное безотказный проброс на гостевую ОС любых(!) USB-девайсов.
# Ответить
104. irq15 28.06.2013 05:15
NLS-ы точно не нужно (это для дистрибов где русской кодировки нет, а такие сейчас поискать нужно :))
WS-ка нужна только если собираешся веб-сервис публиковать

спасибо за инфу не знал
# Ответить
105. lexius 11.09.2013 16:29
Люди добрые, подскажите.

На винде крутится файловая ИБ. Расшарил и подмонтировал её в линукс через fstab по самбе. И теперь можно подключиться или с винды или с линукса. Вместе никак, пишет ошибка совместного доступа. В чем я натупил? Или вообще нереально так запустить файловую базу?
Ответили: (112)
# Ответить
106. Gnaf 08.10.2013 08:55
Спасибо , пригодилось .
# Ответить
107. pablo_escobar 06.12.2013 12:26
Кто-нибудь ставил 8.3 на ubuntu 13.10? Сделал все по инструкции, но при запуске 1С вылетает ошибка "ошибка загрузки компоненты frame"
Ответили: (117)
# Ответить
108. b3nga13zu 07.12.2013 01:45
Привет всем, как правильно патчить 1С под ubuntu 13.10 (х32), с помощью 1c8_uni2patch_lin, тоести все по порядку, а то попробовал пару методов и не получилось,спасибо заранее!(1C 8.3.4.365)
# Ответить
112. blackapple 27.01.2014 22:00
(105) Смотри как монтируешь. А лучше скрипт при запуске сделать, который будет монтировать через mount

Прикрепленные файлы:

ba.gif
# Ответить
113. Hot_Serg 31.01.2014 08:22
У кого-нибудь есть опыт установки 1С server на ubuntu-server 64-bit?
Ответили: (114)
# Ответить
114. bzmax 02.02.2014 13:09
(113) Hot_Serg,
И не один. Несколько сетей магазинов уже так работают.
Что хотел то?
Ответили: (115)
# Ответить
115. Yunus 21.02.2014 20:24
(114) bzmax,

пытаюсь поднять связку из Postgre@Etersoft+ubuntu 13.10/12.04.4+1c 8.3.4.408. Как не меняю компоненты, в конце при добавление базы получаю ошибку, что 1ска не может запустить библиотеку fasttrun.so. Как можно решить данный вопрос?
# Ответить
116. Андрей139 24.03.2014 15:54
Спасибо
# Ответить
117. lev6975 05.04.2014 12:24
(107) pablo_escobar, я, вчера поставил вмваре10, убунту 13-10,а, на 1с не хватило времени - успел, только, сделать dpkg всех пакетов, а зависимости не обработал, отвлекли от сего милого дела:-)
В понедельник продолжу и посмотрю, что получится...
Ответили: (118)
# Ответить
118. pablo_escobar 08.04.2014 16:58
(117) lev6975, Как успехи? получилось запустить?
# Ответить
119. m_aster 16.05.2014 22:53
В Ubuntu 14.04 x64 все пакеты ставятся двойным щелчком без проблем, эска запускается, проблема в том, что HASP-драйвера .deb не хотят ставиться, пишут ошибку, а жаль(скачивал с оф.сайта по ссылке с ИТС)
Ответили: (121)
# Ответить
120. Evgeniy762004 19.05.2014 10:54
Здравствуйте. Подскажите как обновлять платформу 8.3 в Ubuntu 14.04 x64. Удалять старые пакеты или просто установить новые? нужно ли открывать порты в брендмауере Ubuntu для того чтоб включить этот сервер в кластер?
# Ответить
121. frogo 16.09.2014 12:25
(119) m_aster, hasp только i386, так что просто по "щелчку" мышкой не встанет. Выше кто-то писал команду, как его устанавливать надо.
У меня другая "беда".
Есть 2 системы: ноут с Ubuntu Desktop 14.04 x64 и стационарный комп с аналогичной ОС.
На оба поставил 8.3.5. На ноуте все почему-то работает без ключика - устанавливал из пакетов скачанных с оффсайта 1С. Ключик не загорается, но сама 1С работает. Только не печатает и не дает сохранить печатную форму (табличный документ). Ругается на libWand.so.
А на стационарном компе - без ключа ничего не запускается, но зато сама 1С работает без проблем...

Вот мне интересно, почему 1С без ключа-то работает..
# Ответить
122. onec.developer 20.11.2014 21:51
Эх, еще бы unipath кто к ней сделал...
Ответили: (123)
# Ответить
123. tabarigen 19.12.2014 10:11
(122) onec.developer, и я о том же, кто бы вылечил по Linux..
# Ответить
124. linuxmaster 15.03.2015 15:12
Будет ли подобная или лучше статья для Ubuntu 14.04? Почему спрашиваю, вот:

Версии ПО у меня:
Ubuntu 14.04 x86_64
1c-enterprise83-client_8.3.5-1248_amd64.deb


Когда заканчиваешь делать документы продажи получает такое:
Код
Mar 15 13:53:04 shop03 kernel: [94307.614744] 1cv8c[13214]: segfault at 0 ip 00007f0c91641886 sp 00007fff1c98d130 error 4 in frame.so[7f0c91046000+1dbe000]
Mar 15 13:57:20 shop03 kernel: [94563.778428] 1cv8c[7938]: segfault at 0 ip 00007f19b5641886 sp 00007fffecc448d0 error 4 in frame.so[7f19b5046000+1dbe000]
Mar 15 14:11:10 shop03 kernel: [95394.346870] 1cv8c[11296]: segfault at 0 ip 00007fa724f7e886 sp 00007fffbdbc8fd0 error 4 in frame.so[7fa724983000+1dbe000]
Показать полностью


1. Может что-то недоставлено из зависимостей? Но в целом запускается и работает. Под Wine - вообще русские буквы глотались в формах при вводе.
2. Может лучше будет работать 32-битный клиент? Какие ваши советы?
# Ответить
125. Dilovar9 02.04.2015 07:20
Забыли добавить sudo service haspd start
# Ответить
126. alfaservice 16.07.2015 14:04
(1) serega3333, чем виртуалка отличается от реального железа? ничем... могу установленную, готовую в VirtualBox выложить если нужно
# Ответить
127. drseele 13.11.2015 10:55
Здравствуйте! Установил Ubuntu 14.04 (64bit), установил 1С (64bit) и HASP, когда USB-ключ стоит в системнике все работает. Подскажите пожалуйста, какие настройки нужно сделать:
1. Чтобы ключи тянулись с сети
2. Если база находится на другом компе, то она подтягивается только после того как зайдешь на этот комп в папку с базой, как этот вопрос решить?
За ранее спасибо!
Ответили: (128)
# Ответить
128. frogo 25.11.2015 14:51
(127) drseele,
2. Если база находится на другом компе, то она подтягивается только после того как зайдешь на этот комп в папку с базой, как этот вопрос решить?

1. попробуйте монтировать шару при старте Ubuntu
2. если конфигурация позволяет (УФ) - опубликуйте через вэб - и работать быстрее будет и с правами на доступ к сетевой папке проблем меньше.
# Ответить
129. lotran 19.06.2016 23:49
Добрый день! Подскажите пожалуйста что делать? 1c 8.3 (8.3.8.1652) ошибка загрузки библиотеки libWand.so по причине dlopen невозможно продолжать загрузку объекта со статичным TLS у нас ubuntu 12.04
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл