gifts2017

Анализ конфигурации (справочники и документы)

Опубликовал Алексей Бобылкин (alex_bob) в раздел Программирование - Практика программирования

Эта универсальная обработка может пригодиться программистам, имеющим дело со сложными конфигурациями 1С, насчитывающими сотни объектов метаданных. Разобраться во взаимосвязи таких объектов в конфигураторе 1С очень сложно. Данная обработка позволяет строить дерево (до 10 уровней иерархии) объектов, связанных с объектом метаданных типа "Справочник" и "Документ".
Для справочников можно получить реквизиты, подчиненные справочники, группы и свойства.
Для документов - общие реквизиты, реквизиты шапки, реквизиты табличной части, свойства.
Для перечислений - значения перечисления.
Построенное дерево объектов можно напечатать и использовать для анализа и документирования конфигурации. Буду рад всем замечаниям и предложениям.

PS: Обработка с 2001 года валяется на 1c.PROCLUB.ru, однако последнее время мне стали по почте приходить просьбы выслать обработку, т.к. архив битый. Поэтому решил выложить также и здесь, ничего не меняя.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Analyze1.zip
.zip 21,03Kb
25.09.09
325
.zip 21,03Kb 325 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Доржи Цыденов (support) 01.09.06 14:35
а почему развернуть ветку нельзя?
2. Alex_Bob (alex_bob) 01.09.06 16:39
Собственно только и можно делать, что разворачивать и сворачивать ветки для наиболее удобного вывода на печать :). Только щелкать надо не по плюсу, а по тексту. Почему? А он больше и по нему мышом попасть проще.
3. Олег Чалаев (OlegTor) 01.09.06 17:31
Для того, чтобы разобраться во взаимосвязях между объектами, больше подходит не дерево объектов, а модель в нотации IDEF1X, например.

Все равно + 1
4. Alex_Bob (alex_bob) 06.09.06 19:39
5. Serg (The_Serg) 15.03.07 12:43
Интересная разработка...
6. Сhe Burashka (CheBurator) 15.03.07 13:13
Надо взять себе, полезно...
+1
7. Сhe Burashka (CheBurator) 15.03.07 20:19
Очень было бы здорово, если бы это было сделано на форме, а не отчетом...
8. Сhe Burashka (CheBurator) 15.03.07 20:21
А чего это при клике становятся видимым заголовки столбцов - отключаешь, при новом клике - снова вылазют...
9. cs25 (cs25) 15.03.07 21:35
Однако полезная штуковина !!! + !!!
10. Александр Шишкин (Шёпот теней) 03.10.07 16:31
Очень вкусная штука и идея... Спасибо!
11. Ludena (ludena) 24.10.08 22:06
12. Михаил Зыков (ZyMik) 16.02.09 11:44
Спасибо!
Не хватает анализа где данный объект используется.
13. Дмитрий (Froloid) 24.02.09 17:23
Нужна была такая штука. Спасибо!
14. vladal (Vladal) 14.04.09 10:53
Не разворачиваются группировки справочника. В чем причина? 1Cv77 7.70.027
15. Епрст (Ёпрст) 14.04.09 12:13
(14) тыркай мышкой не на крестик а на название...

Гы...делал аналогичную поделку, только на активиксе..
http://s60.radikal.ru/i168/0904/f8/aaf936d0335f.jpg
16. Дмитрий Курышев (wert) 15.04.09 12:07
полезная штука, вот только с разворотом проблема, так как после сохранения документа разворот перестает работать круто было бы сделать так что бы можно было при формировании указать что разворачивать нужно все до упора.
17. Дмитрий Курышев (wert) 15.04.09 12:30
Сам дописал алгоритм, не сложно в сумме сделать.

процедура

Процедура РазвернутьВсе()
для итерация = 1 по 10 цикл
для нн = 1 по Иерархия.КоличествоСтрок() цикл
ТЗ.ПолучитьСтрокуПоНомеру(нн);
Иерархия.ПолучитьСтрокуПоНомеру(нн);
ПлюсМинус=АнализСтрокиИерархии(0);
Если (ПлюсМинус=1) Или (ПлюсМинус=5) Тогда
Развернуть();
КонецЕсли;
КонецЦикла;
КонецЦикла;
КонецПроцедуры // РазвернутьВсе

и вызвать ее в конце процедуры сформировать перед
ПоказатьТаблицу();
18. Дмитрий Курышев (wert) 15.04.09 13:31
блин, не срабатывает, на маленьких объектах прокатывает а большие падает с ошибкой.
19. Епрст (Ёпрст) 15.04.09 13:39
(18) по уму, всю структуру дерева не хранят нигде, а формируют её динамически при разворачивании узла, и удаляют всю ветку при сворачивании...

Ибо есть деревья с хрен знает какой вложенности :)
20. Дмитрий Курышев (wert) 15.04.09 13:49
да тут просто появилась необходимость скинуть структуру парочки документов со вложенностью. Вот и заморочился.
21. Владислав Данилин (Legavaz) 12.01.10 18:06
22. Филипп (Филипп) 31.05.11 15:56
великолепная ВЕЩЬ!
Есть еще в 7-очке чудеса!
После вставки алгоритма "wert" и увеличения числа уровней Иерархии до 25 сработала на очень большом сложном справочнике в нестандартной конфигурации!!!
Спасибо!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа