Мобильные "Инструменты Разработчика" 2.82.2 (устарели)

Опубликовал khaoos в раздел Программирование - Инструментарий

Portable-версия известной подсистемы "Инструменты разработчика" (c) авторства tormozit. Версия 2.82.2 (УСТАРЕЛА). Версии, начиная с 3.01.1, выпускаются tormozit. Подробности на сайте подсистемы.

Добавлено 08.06.2013:

 Выпущена новая версия 2.82.2.  По сравнению с версией 2.82.1:

- Убрал временно запрет на вызов "серверных" функций, реализованный в 2.82.1. Как и ранее, они будут выполняться на клиенте.

- Исправлена ошибка в консоли компоновок: табличные поля параметров схемы "потеряли" свои источники

Добавлено 08.06.2013:

 Выпущена новая версия 2.82.1.  По сравнению с версией 2.79.1:

- Включает обновление оригинальных инструментов версии 2.82

- При попытке обратиться к "серверным" процедурам в клиент-серверном варианте

будет возбуждаться исключение о недоступности функционала в мобильной версии

- Исправлена ошибка в форме консоли компоновки, которая делала инструмент неработоспособным:
неверное наименование реквизита формы

- Исправлена ошибка освобождения индикаторов процесса (могла проявлять себя в разных инструментах)

 Добавлено 21.05.2013: 

 Выпущена новая версия 2.79.1.  По сравнению с версией 2.76.1:

- Включает обновление оригинальных инструментов версии 2.79

 Добавлено 25.04.2013:

 Выпущена новая версия 2.76.1.  По сравнению с версией 2.73.1:

- Включает обновление оригинальных инструментов версии 2.76

- Доработки от Damian
  * добавлена возможность управлять видимостью кнопок подключаемых обработок
  * добавлена возможность выборочного автозапуска подключаемых обработок при старте ИР(м)
  * добавлена возможность подключения произвольных обработок (отчетов) без редактирования метаданных системы (обработка    добавляется в папку "Подключаемые обработки", иконка кнопки - в папку "Иконки кнопок")

В последних релизах оригинальных инструментов проведено достаточно много рефакторинга, поэтому ошибки, связанные с переносом кода, очень вероятны. В связи со сменой деятельности сам сейчас разработкой не пользуюсь и на толковое тестирование времени не хватает. Поэтому держите под рукой более ранний и стабильный релиз. 

 Добавлено 06.04.2013:

 Выпущена новая версия 2.73.1.  По сравнению с версией 2.72.1:

- Включает обновление оригинальных инструментов версии 2.73
- Исправлена критическая ошибка версии 2.72.1, которая не позволяла работать в клиент-серверной базе.
- Доработка от Damian: в форме настройки появился флажок "Запускать при старте системы", при его взведении в параметры запуска текущей базы (в стандартный файл списка баз *.v8i) добавится параметр автозапуска мобильных инструментов по пути, по которому запущен текущий экземпляр. Флажок не запоминается, то есть для другой базы вам нужно будет повторить процедуру его взведения.

31.07.2012 (переработано 23.10.2012):

 С позволения автора оригинальной разработки http://infostart.ru/public/15126/, выкладываю мобильную версию «Инструментов разработчика» (с) Старых С.А (tormozit).  Пригодится в том случае, если неудобно или невозможно по каким-либо причинам изменять конфигурацию.

Состав: 

Инструменты состоят из внешней обработки «ирМобильные.epf» и внешних обработок-инструментов, которые находятся в подкаталоге «Подключаемые обработки» каталога обработки. Обработка «ирМобильные» является так сказать «запускалкой» (менеджером) инструментов, форма которой повторяет основной интерфейс оригинальных инструментов (с тем отличием, что можно прикреплять ее к любой части экрана). Сами по себе, подключаемые внешние обработки не имеют ценности, то есть отдельно от «запускалки» работать не будут, так как не смогут инициализироваться. История версий храниться в текстовом файле, входящим в поставку. Здесь буду выкладывать изменения последних двух версий, чтобы не загромождать публикацию. 

Недостатки по сравнению с оригинальной подсистемой: 

- Только обычный интерфейс (в том смысле, что нельзя запустить в управляемом приложении)

- Не поддерживается отложенная отладка в случае создания объекта отладки внутри выполняющейся транзакции

- Нет возможности редактировать объект базы данных с помощью обработки "Редактирование объекта БД" с помощью команды формы самого объекта, а также использования других полезных команд.

- Невозможно передать выполнение кода на сервер (консоль кода, а также "запись на сервере" во многих обработках)

- Невозможно получение "точного" серверного времени в клиент-серверном варианте

- Невозможно работать с файлами настройки технологического журнала и с самими файлами техн. журнала на сервере

- Невозможно запустить в базе, в которой используется оригинальная подсистема "Инструменты Разрабочика"(из-за конфликтов имен)

- Менее удобное сравнение/объединение "нетиповых" мобильных инструментов при выпуске новых версий. Придется сравнивать каждую обработку-инструмент отдельно.

Особенности: 

- Справочник «ирАлгоритмы» имитируется с помощью использования внешних файлов с расширением «.alg», которые должны лежать в каталоге обработки в подкаталоге «Алгоритмы». Случайно был сделан иерархическим в отличие от оригинальных инструментов :). Выглядит все это похожим на оригинал: работаете как с обычным справочником, при этом будут появляться в соответствующем каталоге файлы «.alg» (элементы справочника) и каталоги (группы справочника). Также реализовал внешнюю обработку, призванную конвертировать имеющиеся уже «немобильные» алгоритмы в файлы, которые можно положить в каталог «Алгоритмы» или в любой его подкаталог. Обработка не входит в состав инструментов, но находится в архиве. Единственное, поддерживая требования оригинальных инструментов в уникальности наименования алгоритма, файлы также должны иметь уникальное имя, даже находясь в разных каталогах-«группах». Иначе в процессе инициализации, программа сообщит, что не удалось считать алгоритм с дублирующимся названием (если проигнорировать это сообщение и не исправить ситуацию, возможны казусы с замещением этого алгоритма). 

- Справочник «Объекты для отладки» реализован с помощью хранилища настроек. Выполнение отложенной отладки в случае создания объекта отладки внутри выполняющейся транзакции, реализованное в оригинальных инструментах версии 2.53, не реализовано в мобильной версии. Если это будет принципиально кому-нибудь нужно, могу попытаться сделать, tormozit подкинул идею, как это сделать. 

- В корне обработки содержится файл "settings.xml". Содержит настройки "РасположениеПанелиЗапуска", которая управляет расположеним заглавной формы при открытии, и "Получение времени сервера в клиент-серверном варианте", которая предлагает обход проблемы получения времени сервера. Файл настраивается интерактивно с помощью формы настроек (пиктограмма "шестеренка" на панели запуска). 

Файлы

Наименование Файл Версия Размер Кол. Скачив.
ирМобильные 2.82.2.zip
.zip 3,26Mb
13.06.13
400
.zip 3,26Mb 400 Скачать
ирМобильные 2.79.1.zip
.zip 3,25Mb
08.06.13
67
.zip 3,25Mb 67 Скачать
ирМобильные 2.76.1.zip
.zip 3,06Mb
08.06.13
57
.zip 3,06Mb 57 Скачать
ирМобильные 2.73.1.zip
.zip 2,93Mb
08.06.13
64
.zip 2,93Mb 64 Скачать
ирМобильные 2.72.1.zip
.zip 2,93Mb
08.06.13
27
.zip 2,93Mb 27 Скачать
ирМобильные 2.71.1.zip
.zip 2,91Mb
08.06.13
57
.zip 2,91Mb 57 Скачать
ирМобильные 2.70.1.zip
.zip 2,92Mb
08.06.13
39
.zip 2,92Mb 39 Скачать
ирМобильные 2.69.1.zip
.zip 2,91Mb
08.06.13
84
.zip 2,91Mb 84 Скачать

См. также

Лучшие комментарии

192. tormozit (файл скачал) 29.12.2013 01:18
Теперь мобильная версия инструментов выпускается мной, начиная с 3.01.1. Подробности на основном сайте подсистемы.
Ответили: (193)
+ 2 [ SirYozha; 1cmax; ]
# Ответить
76. Kom-off 24.08.2012 11:16
khaoos, скачал, поставил, понравилось. Однозначно "плюс" и автору оригинальной обработки и автору мобильной версии. В связи с большим количеством баз, встраивать оригинальную систему не было возможности, а мобильная версия - это то что нужно.
Первым делом напоролся на проблему (версия мобильные ИР 2.56.1): не на всех компьютерах работает Синтакс-помощник - не отображается сожержание синтакс-помощника. У коллеги на компьютере работает, у меня нет. Посмотрел код. В обработке ирСинтаксПомощник.epf в процедуре модуля формы ЗагрузитьСодержание() не отрабатывает ZIP-распаковщик. Исправил так:
Строку:
мПлатформа.ЗапуститьСкрытоеПриложениеИДождатьсяЗавершения(ФайлРаспаковщикаZIP.Имя + " -o " + ФайлСодержания.ПолноеИмя + " -d " + РабочийКаталог);

заменил на строку:
мПлатформа.ЗапуститьСкрытоеПриложениеИДождатьсяЗавершения("""" + ФайлРаспаковщикаZIP.Имя + """" + " -o " + """" + ФайлСодержания.ПолноеИмя  + """" + " -d " + """" + РабочийКаталог + """");

Т.е. все имена файлов и каталогов обрамил кавычками.
Функциональность восстановилась.
Ответили: (79) (80)
+ 1 [ khaoos; ]
# Ответить
52. khaoos 10.08.2012 19:15
(51) dima1c, сообщением выше смотри, что точно в последней версии не работает или работает не так, как ожидается. Еще нашел после этого: в "Подбор и Обработка объектов" не работают "Произвольный алгоритм" и "Установка реквизитов". Все уже поправил и что найду плохого, еще поправлю. Думаю, в воскресенье или понедельник выпустить версию 2.55.2.
+ 1 [ artbear; ]
# Ответить
82. khaoos 11.09.2012 05:13
(81) headMade, я могу заблуждаться в правильности работы, так как не работал почти с оригинальными инструментами. Сделал вроде по науке (также как и у вас написано). Посмотрите скриншот: так должно быть? И какая версия мобильных инструментов?
Ответили: (83)
+ 1 [ headMade; ]
# Ответить
50. khaoos 10.08.2012 10:11
(49) artbear, есть еще ошибки, связанные с моей неспособностью поддерживать внимание при монотонной работе: переносе доработок оригинальных инструментов. Сейчас прочесываю все: нахожу косяки. Из того, что нашел критического в последней версии: не работает "Поиск ссылок на объект" (обнаружил tormozit); заявленная возможность многотабличной выборки в "Подборе И Обработке объектов" оригинальных инструментов 2.55 у меня благополучно "отвалилась" :); в контекстной подсказке не работает отбор по подстроке; "Синтакс-помощник" открывается каждый раз в новой форме (обнаружил tormozit); в консоли запросов что-то напутал с обработкой результатов в части параметров (не тестировал, но в коде пробелы нашел) - наверняка не работало. Также не приятно смотреть на картинки с нелепым фоном во всяких менюшках и табличках (а где-то их вообще пропустил). Фон картинок вроде бы победил с подачи tormozit'а. Думаю, что пара-тройка релизов еще понадобится, чтобы стабилизировать разработку, потом буду пореже обновлять, чтобы не терроризировать народ своими ляпами :).
+ 1 [ artbear; ]
# Ответить

Комментарии

1. pumbaE (файл скачал) 31.07.2012 18:43
1. Достойный труд, я сам часто смотрел на "Подсистему разработчика" и все никак не мог себя заставить попробовать перенести во внешние обработки.
2. Первое впечатление : работает. Попробую применить в реальной работе.
3. Желательно текстовый файл в архив положить с описанием особенностей и отличий.

И есть предложение: я как "яростный" сторонник хранения внешних обработок под версионным контролем хотел бы предложить вам выложить на github или bitbucket ?
Ответили: (2) (3) (33)
# Ответить
2. khaoos 31.07.2012 19:30
(1) pumbaE, буду признателен за активное использование разработки. На счет описаний: постараюсь исправиться в следующей версии :). Про версионный контроль я пока не в теме, но если тема хорошая, то и сам могу стать "яростным" сторонником :). Как это работает в случае 1с? Нужно будет выкладывать бинарники обработок или тексты модулей?
Ответили: (4)
# Ответить
3. khaoos 31.07.2012 19:36
(1) pumbaE, увидел вашу статью про версионность, думаю она мне многое прояснит, почитаю на досуге
# Ответить
4. pumbaE (файл скачал) 31.07.2012 19:38
(2) khaoos, пока только бинарники.
1С даже в 8.3 как всегда забыла об огромном пласте внешних обработок и отдельно выгружать их в xml не предлагает. Конечно с учетом новых веяний платформы и модели безопасности большенство обработок так и так перекачуют в корень конфигурации, но отчеты и внешние печатные формы все равно необходимо где-то хранить.

Я добавлял для bzr и fossil Версионный контроль и 1С возможность просматривать изменения в diff для внешних обработок и cf.
Так же разрабатываю дополнительный модуль в проекте Снегопат по удобному доступу к системам версионного контроля из конфигуратора. Пока в основном для внешних обработок применимо, но возможно с выходом 8.3 можно будет добавить и прозрачную поддержку для конфигурации.
# Ответить
5. pumbaE (файл скачал) 31.07.2012 19:48
В git уже исправили ошибку с русскими файлами, так что можно пользоваться смело bzr/fossil/git/svn.
Ответили: (154)
# Ответить
6. ~gekK@~ 01.08.2012 09:30
полезная вещь для каждого дня
# Ответить
7. a-novoselov (файл скачал) 01.08.2012 11:08
(0) Хорошая вещь, однозначно "+"

При закрытии обработки (основной вертикальной панели, самая нижняя кнопка) выдает ошибку:
{ВнешняяОбработка.ирГлобальный.МодульОбъекта(1926)}: Значение не является значением объектного типа (ПолучитьПиктограммуТипаЛкс)
КартинкаТипа = ирНеглобальный.ПолучитьПиктограммуТипаЛкс(ТипЗначения);

При том при нажатии "Ок" ошибка выскакивает снова и не позволяет продолжить работу, 1С приходится останавливать только через Подробно.../ Завершить работу, больше ничего сделать не удается.

Ошибка возникает только если открыт хотя бы один из инструментов. Если все инструменты закрыты работает корректно.
Ответили: (8)
# Ответить
8. khaoos 01.08.2012 11:15
(7) a-novoselov, у вас при любом открытом инструменте так происходит? Я сейчас для пяти штук проверил, все мимо :) : не выскакивает ошибка
Ответили: (10)
# Ответить
9. a-novoselov (файл скачал) 01.08.2012 11:19
(0) Еще хотелка небольшая: При открытии синтаксис-помощника он перекрывает основную панель обработки, можно ли открывать синтаксис-помощник прикрепленным окном справа (как в конфигураторе по-умолчанию)? или дофига делов оно само так?)
# Ответить
10. a-novoselov (файл скачал) 01.08.2012 11:22
(8) Нет, не при любом. При открытом редакторе констант или редакторе параметров сеанса.
Ответили: (11)
# Ответить
11. khaoos 01.08.2012 11:30
(10) a-novoselov. Я, наверное, понял. В статье, наверное, моя мысль оказалась расплывчатой. Основная обработка является менеджером остальных обработок и без нее последние будут нежизнеспособными :). При закрытии основной формы удаляются из памяти вспомогательные обработки-модули. Ошибка возникает в тот момент, когда пытаетесь воспользоваться функциональностью инструмента, которая вызывает эти модули. Я еще думал в следующих версиях сделать так, чтобы при закрытии основной формы, она искала незакрытые инструменты и предлагала их закрыть сначала. Но пока ни шага в сторону :).
Насчет хотелки: по идее он не перекрывать должен, а расположиться в отдельной вкладке: потом переключаться можно, правда основную форму приходится сделать шире и становится некрасиво. Так же происходит при вызове интерфейсной панели. Может быть в правую часть экрана задвинуть запускалку? Я по-разному пробовал, сам не смог определиться, где лучше :)

Добавлено: а то, что не могли закрыть с первой попытки, так это наверное потому что в цикле вызов происходил.
Ответили: (12) (14)
# Ответить
12. a-novoselov (файл скачал) 01.08.2012 11:33
(11) Да, думаю удобнее было бы с разных сторон расположить основную панель и интерфейсную панель/синтаксис помощник.
Ответили: (13)
# Ответить
13. khaoos 01.08.2012 11:38
(12) a-novoselov, постараюсь сделать настраиваемым, а вообще можно и самому при должном умении перетащить вправо, тогда при следующем запуске, она там и откроется (1с сама запомнит расположение).
Ответили: (15)
# Ответить
14. a-novoselov (файл скачал) 01.08.2012 11:38
(11) Добавлено: Да, после 12 нажатий "Ок" (в конфе 12 параметров сеанса) панель закрывается.
# Ответить
15. a-novoselov (файл скачал) 01.08.2012 11:40
(13) Согласен. Но это придется делать постоянно у каждого клиента/на каждом терминальном сервере...

Добавлено: По поводу настраиваемого отображения не критично, а вот закрытие окон вместе с уничтожением служебных модулей было бы очень кстати.
Ответили: (16)
# Ответить
16. khaoos 01.08.2012 11:47
(15) a-novoselov, ну тогда мне нужно решиться раз и навсегда ее туда задвинуть, иначе если делать настраиваемым, то запустить один раз все равно придется :). А вообще последнее время работаю с ЗУПом, там справа задачи пользователя прикреплены. Вверху из-за заголовка формы место отъедает много, внизу - тоже
# Ответить
18. serega3333 (файл скачал) 01.08.2012 12:54
"нет сынок, это фантастика!" (с)
Отличная тулза, тоже всегда пытался выдернуть из подсистемы нужные куски и модули, не получалось, буду пользоваться вашей
Ответили: (19)
# Ответить
19. khaoos 01.08.2012 13:08
(18) serega3333, пользуйтесь, конечно. Пока о багах не сообщают, но всякие интерфейсные казусы я встречаю (привязки элементов - некоторые элементы остаются маленькими при растягивании формы, отсутствие картинок - вследствие чего командные панели становятся несколько больше и не видно все элементы без прокрутки). Поправляю, что вижу. Уже вышли инструменты 2.54 и я уже синхронизировался, но хотелось бы побольше багов перед выпуском исправить, да и хотелки уже появляются :).
Ответили: (20)
# Ответить
20. Den_D 01.08.2012 13:20
(19) khaoos, у меня малый вопрос, может быть не по теме.
Этой разработкой вы занимаетесь в рабочее или в свободное время?
Ответили: (21)
# Ответить
21. khaoos 01.08.2012 13:23
(20) Den_D, ответ зависит от того, работаем ли мы вместе с вами или нет :)

Добавлено: и к тому же, разработкой занимается tormozit. Я за редким исключением занимаюсь мартышкиным трудом, правда внимательности и сосредоточенности мне всегда не хватало на такую работу, поэтому и ляпы всякие возможны
Ответили: (22)
# Ответить
22. Den_D 01.08.2012 13:29
(21) khaoos, Нет, мы с вами вместе не работаем)
Но судя по ответу, время разработки рабочее ;)
Ответили: (23) (118)
# Ответить
23. khaoos 01.08.2012 13:36
(22) Den_D, на самом деле, основная работа была сделана за пару дней и кхм..., и столько же ночей :) еще месяц назад. Да и то, непонятно в какой момент косячнув, фактически удвоил свои трудозатраты :). В остальном так, наскоками: в основном, в свободное время.
# Ответить
24. vec435 01.08.2012 14:33
"за глаза" плюс
# Ответить
25. mamanelli (файл скачал) 01.08.2012 17:57
Не сомневаясь, +
Давно пользуюсь этой Штукой! Великолепный инструмент. Спасибо.
# Ответить
26. Hany 01.08.2012 18:47
Оч. люблю эту подсистему.
Встраивать в конфу и обновлять проблем нет.
Но автору однозначно "+" за переделку в моб. версию!!
# Ответить
27. khaoos 02.08.2012 08:28
Обнаружил ошибку инициализации конструктора выражений Консоли Компоновок.

Добавлено: также не инициализируется конструктор выражений встроенного языка.

Исправления будут в версии 2.55.

А еще многие картинки имеют черный или серый непрозрачный фон.
# Ответить
28. Рамзес (файл скачал) 02.08.2012 09:10
Инструмент "Поиск ссылок и замена дублей". При нажатии на кнопку "Замена ссылок" возникает ошибка:
{Форма.Форма.Форма(2352)}: Значение не является значением объектного типа (ОбновитьНайденныеСсылки)
ОбработкаПоискаСсылок.ОбновитьНайденныеСсылки(МассивЗаменяемых, Ложь);
Ответили: (29) (30)
# Ответить
29. khaoos 02.08.2012 09:50
(28) Рамзес, спасибо! Ошибка из того же разряда, что две описанные выше. Надо будет прошерстить все обработки до следующего релиза в поисках таких косяков.

Добавлено: хотя, если честно этим уже один раз занимался. Каюсь, монотонная работа с трудом дается.
# Ответить
30. khaoos 02.08.2012 11:23
(28) Рамзес, хорошо, что выявили ошибку. Здесь ситуация оказалась хуже, пришлось придумывать обходные пути. Исправление будет в 2.55.
# Ответить
31. tormozit (файл скачал) 02.08.2012 11:31
khaoos
Наверное корректнее писать, что "исправление будет в следующей версии" или хотя бы "исправление будет в 2.55.1".
Ответили: (32)
# Ответить
32. khaoos 02.08.2012 11:47
(31) tormozit, да пожалуй. Просто решил, что пока багов еще много, не буду исправление каждого отдельным билдом-заплаткой выкладывать (хотя может было бы интересно некоторым иметь доступ к текущему development build'у), а ждать выхода нового релиза оригинальных инструментов. Поэтому скорее всего на этой стадии, крайняя цифра всегда будет единичкой. Потом когда более менее все устаканится и с выходом нового релиза оригинальных инструментов я случайно что-нибудь не так обновлю, то здесь может быть уместно выпускать горячую заплатку с цифрой 2 и более. Я думаю меня поняли, но я исправлюсь: буду писать "в следующей версии".
# Ответить
33. AlexO 02.08.2012 12:12
(1) pumbaE,
Достойный труд, я сам часто смотрел на "Подсистему разработчика" и все никак не мог себя заставить попробовать перенести во внешние обработки.

мне вот интересно - а почему сам автор ТормоИТ не сделал мобильные версии, а рекомендует всем встраивать ИР? Там же жесткая завязка с доп объектами из ИР.
Ответили: (34) (35)
# Ответить
34. tormozit (файл скачал) 02.08.2012 14:21
(33) Причин много. На самом деле, думаю было бы не лишним в описании этой публикации указать все преимущества подсистемы по отношению к мобильному набору инструментов. Постепенно я буду их сюда писать.

Начнем с команд. При использовании подсистемы для вызова ее инструментов с передачей им объектов данных доступны команды как в управляемом, так и обычном приложениях. Например лично я несколько раз в день пользуюсь командой "Редактировать объект (ИР)".
Ответили: (36)
# Ответить
35. tormozit (файл скачал) 02.08.2012 14:30
(33) Еще о преимуществах подсистемы.
Некоторые пользователи подсистемы делают свои доработки в инструментах, которые более затратно по одной обработке сравнивать/объединять при частом обновлении.
# Ответить
36. khaoos 02.08.2012 15:54
(34) tormozit, я уж тогда скорее в недостатки мобильной версии буду писать, раз создал такой раздел. Команды держал в голове, но упомянуть забыл. Указал только то, что на поверхности и было очевидно для меня на тот момент. Команды допишу. По сравнению/объединению тоже верно. Хотя могу предложить кое-какой костыль с конфигурацией-носителем, да думаю, не сильно выиграет во времени. Если есть еще что-то очевидное выкладывай, я одним постом сделаю, чтоб модератора не мучать частыми изменениями публикации.
# Ответить
38. Arebazzz0 03.08.2012 14:42
Отлично, автору "+"! Обязательно потестирую, после зп.
# Ответить
39. tormozit (файл скачал) 05.08.2012 23:00
Левое вертикальное прикрепление основной формы использовать очень неудобно. Я рекомендую сделать сверху, хотя при этом и потеряется небольшая часть по высоте рабочей области (см. скриншот).

Прикрепленные файлы:

2012-08-05_225721.jpg
# Ответить
40. khaoos 06.08.2012 04:40
Да, это был первоначальный вариант. На широкоформатных (и самых распространенных ныне мониторах) не айс тоже (так как от типовых конфигураций еще много интерфейсных панелек рисуется). В следующей версии сделал опциональным размещением: слева или справа (через конфигурируемый с помощью специальной формы xml-файл настроек). Хотел еще и сверху/снизу варианты добавить, но после часовых танцев с бубном психанул и бросил: не хочет мне 1с динамически правильно изменять размер формы перед открытием, может чего простого не знаю: никогда этим не занимался еще. Проще наплевать на принципы программирования и еще одну форму горизонтальную нарисовать с дублированием всего кода :). Попробую еще сейчас, может утро вечера мудреннее :).
# Ответить
41. khaoos 06.08.2012 05:14
О,кажется, нащупал вариант: в обработчике "перед открытием" вроде помогает изменение размеров программным образом. А я пытался на этапе инициализации формы все провернуть (так как в обработчике "перед открытием" уже нельзя поменять вариант прикрепления, например).
# Ответить
42. khaoos 06.08.2012 06:29
Будут настраиваться все варианты прикрепления: сверху, снизу, слева, справа.
# Ответить
43. tormozit (файл скачал) 06.08.2012 13:24
В недостатках узко освещен момент с командами
"Нет возможности использования команды редактирования данных с помощью "Редактора объекта БД" прямо из формы прикладного объекта". На самом деле команд там много и не все они связаны с редактированием данных. Команду "Редактировать объект БД" я привел в качестве примера, как самую популярную.
# Ответить
44. Збянтэжаны Саўка (файл скачал) 08.08.2012 09:23
(0) в Консоле )

сегодня уже три попытки делал, а файл вер. 2.55.1 скачать не могу - обрывается?
Ответили: (45) (48)
# Ответить
45. khaoos 08.08.2012 09:28
(44) Збянтэжаны Саўка, 12 человек успешно скачало с момента выпуска. Может и поломалось чего. Если жалобы еще будет, перезалью. Могу на электронную почту отправить.

Добавлено: насчет орфографии благодарю, поправлю в следующий раз. Было б русское слово, наверняка бы правильно написал. А так, с мужским родом, видимо, ассоциировалось в мозгу из-за транскрипции "консоул".
Ответили: (46)
# Ответить
46. Збянтэжаны Саўка (файл скачал) 08.08.2012 11:48
(45) khaoos, о, вот счас (10:30) скачал, все ок!
# Ответить
47. mtv:) (файл скачал) 08.08.2012 21:23
(0) Хороший и нужный проект поднял автор.
Спасибо, будем тестить и использовать в своей работе.
# Ответить
49. artbear (файл скачал) 10.08.2012 09:50
Отличная публикация.
Начал тестировать, пока работает :)
ИР юзаю с самых первых версий, но часто приходится сожалеть об ее отсутствии в типовых конфах на поддержке или у клиентов на выезде.
Ответили: (50)
# Ответить
50. khaoos 10.08.2012 10:11
(49) artbear, есть еще ошибки, связанные с моей неспособностью поддерживать внимание при монотонной работе: переносе доработок оригинальных инструментов. Сейчас прочесываю все: нахожу косяки. Из того, что нашел критического в последней версии: не работает "Поиск ссылок на объект" (обнаружил tormozit); заявленная возможность многотабличной выборки в "Подборе И Обработке объектов" оригинальных инструментов 2.55 у меня благополучно "отвалилась" :); в контекстной подсказке не работает отбор по подстроке; "Синтакс-помощник" открывается каждый раз в новой форме (обнаружил tormozit); в консоли запросов что-то напутал с обработкой результатов в части параметров (не тестировал, но в коде пробелы нашел) - наверняка не работало. Также не приятно смотреть на картинки с нелепым фоном во всяких менюшках и табличках (а где-то их вообще пропустил). Фон картинок вроде бы победил с подачи tormozit'а. Думаю, что пара-тройка релизов еще понадобится, чтобы стабилизировать разработку, потом буду пореже обновлять, чтобы не терроризировать народ своими ляпами :).
+ 1 [ artbear; ]
# Ответить
51. dima1c (файл скачал) 10.08.2012 16:40
Спасибо! То что нужно, очень уж не хотелось объединять конфигурации, а функционал ИР был нужен. На первый взгляд все работает !
Ответили: (52)
# Ответить
52. khaoos 10.08.2012 19:15
(51) dima1c, сообщением выше смотри, что точно в последней версии не работает или работает не так, как ожидается. Еще нашел после этого: в "Подбор и Обработка объектов" не работают "Произвольный алгоритм" и "Установка реквизитов". Все уже поправил и что найду плохого, еще поправлю. Думаю, в воскресенье или понедельник выпустить версию 2.55.2.
+ 1 [ artbear; ]
# Ответить
53. 1cmax (файл скачал) 12.08.2012 22:27
Отлично! Пару раз выковыривал обработки из подсистемы в самостоятельные обработки, потом бросил это занятие и стал всюду ставить подсистему.
А теперь все прекрасно :) Спасибо
# Ответить
54. tormozit (файл скачал) 14.08.2012 14:39
Добавил возможность скачивания этого файла на сайте ИР.
# Ответить
55. dumal (файл скачал) 15.08.2012 22:34
Из всех инструментов чаще всего использую консоль запросов, она-то всегда под рукой. Все остальное почти всегда приходится делать лапками, потому как разворачивать полноценное рабочее место часто некогда/лень. Может, теперь освоюсь :)
# Ответить
56. pumbaE (файл скачал) 16.08.2012 10:09
Баги куда писать? Сюда на форум или tormozit ?
* консоль кода, периодически ругается на невозможность получить границы выделения.
Ответили: (57) (58)
# Ответить
57. tormozit (файл скачал) 16.08.2012 10:15
(56) Если используется именно эта версия инструментов, то писать следует сюда. Если же ты проявишь инициативу и успешно проверишь воспроизведение проблемы в подсистеме ИР, то писать следует сразу туда.
Ответили: (59)
# Ответить
58. khaoos 16.08.2012 10:19
(56) pumbaE, пишите в комментарии, не пропадут ). Есть хотя бы примерный алгоритм воспроизведения проблемы?
Ответили: (59)
# Ответить
59. pumbaE (файл скачал) 16.08.2012 11:37
(57) В подсистеме все нормально.
(58)
1. Открываем консоль запросов, вкладка "Обработка строки результата", клацаем на "Обработка результата в консоли кода" , внизу "Вставить ссылку на объект" Видео пример
2. не критично: Привязки . Но, повторить пример не получается.
Ответили: (60) (62)
# Ответить
60. khaoos 16.08.2012 16:29
(59) pumbaE, спасибо за качественные баг-репорты. Первый баг исправил, он же на 99% и был причиной ругани на границы выделения. В качестве временной меры (до выхода следующей версии) везде вставляй "ссылку на объект БД" в первой строчке текстового документа, должно работать :). Второй баг один раз чудом поймал, но диагностировать не удалось, с тех пор не могу пока поймать :).
# Ответить
62. khaoos 17.08.2012 05:21
(59) pumbaE, с привязками вполне возможно, что баг платформы какой-то. Сейчас на 8.2.15.319 в ЗУПе у пользователя видел "косую" форму списка справочника "Сотрудники". Повторное открытие формы вылечило проблему :).
Ответили: (63)
# Ответить
63. pumbaE (файл скачал) 17.08.2012 11:04
(62) khaoos, Консоль компоновки тоже привязки слетели, но здесь повторяется каждый раз.
Ответили: (64) (65)
# Ответить
64. khaoos 17.08.2012 11:11
(63) pumbaE, спасибо, здесь точно косяк, который между прочим я уже убирал. Наверное внес обратно, когда делал "работу над ошибками" :). Будет исправлено в следующей версии
Ответили: (67)
# Ответить
65. tormozit (файл скачал) 17.08.2012 11:25
(63) Это баг подсистемы. Он будет исправлен в новой версии.
Ответили: (66)
# Ответить
66. khaoos 17.08.2012 11:40
(65) tormozit, я точно помню, что в какой-то консоли на каждой вкладке исправлял привязки (именно маленькие табличные поля были), но, может быть, не посмотрел, как было в подсистеме. А потом вернул видимо, когда контрольной проход при сравнении делал.
# Ответить
67. pumbaE (файл скачал) 17.08.2012 12:48
(64) khaoos, вел бы версионный контроль, сразу знал бы, когда ошибку внес.

P.s.: Еще раз спасибо за мобильность, включил ее в свой выездной снегопатовский репозитарий полезных обработок.
Ответили: (68)
# Ответить
68. khaoos 17.08.2012 13:02
(67) pumbaE, поймал :). Но если честно, я не понимаю, что я смогу вынести из хранения бинарников версий. Пока багов было много, всякие интерфейсные баги я писал одной кучей. Сейчас буду описывать детальней. Недавно скачал полезняшку v8Reader, пока сильно не разбирался, может быть ее как-нибудь приспособлю в своем мобильном хозяйстве :).
# Ответить
69. pumbaE (файл скачал) 17.08.2012 13:20
Бинарники от 1С - это и вправду проблема. Не получиться делать атомарные коммиты, т.е. минимально необходимое изменение. Приходится в куче коммитить, но это значительно лучше чем копирование резервных копий и добавление в конец даты или 1, 2, 3. Есть у меня некоторые обработки, к которым раз в месяц или полгода надо возвращаться и добавлять что либо и знаешь за 7 месяцев постоянного использования уже значительно реже возникает вопрос "Зачем, я так делал, почему так или иначе.", в истории видно развитие и муки творчества и муки выбора решения.
# Ответить
70. tormozit (файл скачал) 21.08.2012 01:36
2.56.1
Попытался открыть в новой базе с пустой конфигурацией интерфейсную панель и получил ошибку
{ВнешняяОбработка.ирИнтерфейснаяПанель.МодульОбъекта(637)}: Поле объекта не обнаружено (Справочник1)
		Возврат Справочники[ИмяОбъектаМД].ПолучитьСсылку(ИдОбъекта);
Ответили: (73) (74)
# Ответить
71. tormozit (файл скачал) 21.08.2012 01:52
В "Подготовка БД к усечению типов измерений" флажок "запись на сервере" включен, хотя и недоступен, но немного путает, т.к. фактически запись то будет выполняться на клиенте.
Ответили: (72)
# Ответить
72. khaoos 21.08.2012 03:58
(71) tormozit, пока не знаю, что с флажками делать. Сначала пометил в скобках, что не поддерживается, потом в некоторых местах убрал (не влазит в интерфейс), где-то сделал недоступными. Надо будет к единообразию свести.
На пустой не открывал еще, попробую.
Добавлено: может вообще невидимыми сделать флажки?
# Ответить
73. khaoos 21.08.2012 05:14
(70) tormozit, не удалось воспроизвести: и на пустой, и со справочником Справочник1.
Попробовал еще так: создал Справочник1, открыл интерфейсную панель, открыл список справочника, создал элемент. В "недавно использованных" появился "Справочник1". Удалил Справочник1, открыл интерфейсную панель: все пусто и ошибки нет.
Добавил: еще с поиском побаловался (думал, здесь останется ссылка, которую в следующий раз не даст открыть панель) - нашел другую ошибку: найденные элементы не открываются, так как не может найти "редактор объекта БД"
# Ответить
74. tormozit (файл скачал) 21.08.2012 08:18
(70) Оказалась ошибкой в оригинальном коде интерфейсной панели. Проявляется при отсутствии таблицы для запомненной ссылки на объект БД в избранном интерфейсной панели. Будет исправлена в следующей версии подсистемы.
Ответили: (75)
# Ответить
75. khaoos 21.08.2012 08:27
(74) tormozit, да, в "Избранное" не догадался добавить, хотя напрашивалось. В поиске, наверное, закопался, и прошел мимо.
# Ответить
76. Kom-off 24.08.2012 11:16
khaoos, скачал, поставил, понравилось. Однозначно "плюс" и автору оригинальной обработки и автору мобильной версии. В связи с большим количеством баз, встраивать оригинальную систему не было возможности, а мобильная версия - это то что нужно.
Первым делом напоролся на проблему (версия мобильные ИР 2.56.1): не на всех компьютерах работает Синтакс-помощник - не отображается сожержание синтакс-помощника. У коллеги на компьютере работает, у меня нет. Посмотрел код. В обработке ирСинтаксПомощник.epf в процедуре модуля формы ЗагрузитьСодержание() не отрабатывает ZIP-распаковщик. Исправил так:
Строку:
мПлатформа.ЗапуститьСкрытоеПриложениеИДождатьсяЗавершения(ФайлРаспаковщикаZIP.Имя + " -o " + ФайлСодержания.ПолноеИмя + " -d " + РабочийКаталог);

заменил на строку:
мПлатформа.ЗапуститьСкрытоеПриложениеИДождатьсяЗавершения("""" + ФайлРаспаковщикаZIP.Имя + """" + " -o " + """" + ФайлСодержания.ПолноеИмя  + """" + " -d " + """" + РабочийКаталог + """");

Т.е. все имена файлов и каталогов обрамил кавычками.
Функциональность восстановилась.
Ответили: (79) (80)
+ 1 [ khaoos; ]
# Ответить
77. khaoos 24.08.2012 11:52
(76). Спасибо. Сообщите, пожалуйста, версию Windows, которая установлена на том компьютере, где не отрабатывал код. И отличаются ли вообще версии ОС на том и на другом компьютере?
Ответили: (78)
# Ответить
78. Kom-off 24.08.2012 18:07
(77) На проблемном компьютере Windows XP SP3, на другом - Windows 7 SP1.
# Ответить
79. tormozit (файл скачал) 25.08.2012 08:55
(76) Это - ошибка подсистемы "Инструменты разработчика". Будет исправлена в следующей версии.
# Ответить
80. tormozit (файл скачал) 05.09.2012 17:05
(76) Исправлено в 2.57
# Ответить
81. headMade 10.09.2012 22:38
Подскажите мне. В полной версии в вычислении выражения можно было прописывать "Вычислить(Пер())" или "Вычислить(Поп())".
В мобильной как такую конструкцию записать?
я пробывал ВнешниеОбработки.Создать("D:\1C\Разработка\Мобильные инструменты разработчика\ирМобильные.epf").Пер() и еще по всякому крутил, но что-то не сработало
Ответили: (82)
# Ответить
82. khaoos 11.09.2012 05:13
(81) headMade, я могу заблуждаться в правильности работы, так как не работал почти с оригинальными инструментами. Сделал вроде по науке (также как и у вас написано). Посмотрите скриншот: так должно быть? И какая версия мобильных инструментов?
Ответили: (83)

Прикрепленные файлы:

скриншот.JPG
+ 1 [ headMade; ]
# Ответить
83. headMade 11.09.2012 14:51
(82) khaoos,
да так, это я просто ступил.
Спасибо
# Ответить
84. artbear (файл скачал) 18.09.2012 19:25
Обратил внимание, что не сохраняются настройки некоторых форм.
Например, после перезапуска Конфигуратора не видно ранее введенных/использованных объектов в Интерфейсной панели, еще где-то видел (пока не могу вспомнить)
Ответили: (85) (86)
# Ответить
85. khaoos 19.09.2012 04:57
(84) artbear, ок, постараюсь воспроизвести. А так, настройки, в основном, в хранилище настроек сохраняются, как я понимаю. Точно под тем же пользователем заходишь?
# Ответить
86. khaoos 20.09.2012 07:36
(84) artbear, насчет интерфейсной панели: настройки сохраняются в файл, который зависит от пользователя ОС, от строки подключения к базе и пользователя ИБ. У меня сейчас вот такой путь к файлу получился:
"C:\Documents and Settings\v.antonov\Application Data\1C\File$D$$bases$Инструменты Разработчика$$Usr$Антонов.cfg".
Так что способов "забыть" настройки можно придумать не один :). Я думаю, что это заимствованный код по сохранению/восстановлению настроек оригинальной интерфейсной панели, которая, видимо, разрабатывалась еще под 8.0/8.1, в которых хранить настройки в базе было проблематично.

Добавлено: думаю имеет смысл пролоббировать доработку оригинальной подсистемы для более надежного хранения настроек. Хотя, быть может, есть еще какие-то независимые от этого способы "забыть" настройки именно в мобильной версии.
Ответили: (87)
# Ответить
87. artbear (файл скачал) 20.09.2012 07:49
(86) khaoos,
Цитата: Добавлено: думаю имеет смысл пролоббировать доработку оригинальной подсистемы для более надежного хранения настроек.
Хотя, быть может, есть еще какие-то независимые от этого способы "забыть" настройки именно в мобильной версии.
==
По обоим пунктам согласен, нужные хотелки.
# Ответить
88. tormozit (файл скачал) 20.09.2012 09:12
По сохранению настроек. Давайте сначала проблему поймем. Нужно описать способ ее воспроизведения. А потом уже будем думать над решением.
Ответили: (89)
# Ответить
89. khaoos 20.09.2012 10:29
(88) tormozit, постараюсь по убыванию вероятностей событий :)

1. Зайти в базу с другого компа в сети

2. Зайти на комп / терминальный сервер под другим пользователем ОС

3. Перенести файловую базу в другое место / переименовать кластер серверов / переименовать базу

Но в этом ли была причина у artbear, я не уверен.
Ответили: (90)
# Ответить
90. tormozit (файл скачал) 20.09.2012 10:44
(89) Ясно. Проблему записал.
# Ответить
91. tormozit (файл скачал) 24.09.2012 12:55
В оригинальной подсистеме в интерфейсной панели реализовано хранение настроек в профиле пользователя базы 1С
Ответили: (92)
# Ответить
92. artbear (файл скачал) 24.09.2012 20:20
(91) Спасибо.
# Ответить
93. headMade 26.09.2012 11:00
на 8.2.13 в Тестирование метаданных (ИР) (ирТестированиеМетаданных)
вываливается на строке КоллекцияМетаОбъектов = Метаданные[СтрокаТипаМетаданных.Множественное]; (167)
при СтрокаТипаМетаданных.Множественное = "ОбщиеРеквизиты"

Общие реквизиты появились вроде с 8.2.15

Спасибо.
Ответили: (94)
# Ответить
94. tormozit (файл скачал) 26.09.2012 11:12
(93) Спасибо. Ошибку зафиксировал. Общие реквизиты появились в 2.14 релизе.
# Ответить
95. khaoos 26.09.2012 11:16
(94), Ты быстрее меня что ли оповещения получаешь? :)
# Ответить
96. headMade 28.09.2012 17:59
Посмотрите еще пожалуйста.
на 2.60.1 в консоле запросов сохранить запрос в .sel получается только со 2-ой попытки.
т.е.:
1. в консоле нажимаем "Сохранить список зап-ов" в новом файле.
2. Задаем путь и имя для .sel
3. нажимаем кнопку "Сохранить", при этом в указанном месте файл не появляется
4. еще раз жмем "Сохранить список зап-ов".
5. не меняя путь и имя, нажимаем кнопку "Сохранить", после чегофайл sel появляется
Ответили: (97)
# Ответить
97. tormozit (файл скачал) 28.09.2012 18:07
(96) Это ошибка подсистемы "Инструменты разработчика". Подробнее здесь http://devtool1c.ucoz.ru/forum/2-110-1 . В ближайшие дни выйдет исправленная версия.
# Ответить
98. Requiem (файл скачал) 12.10.2012 14:20
Не могу сообразить. Как в консоли запросов посмотреть данные временной таблицы?
Ответили: (99)
# Ответить
99. headMade 12.10.2012 19:16
(98) Requiem,
слево от кнопки "результат", есть такая кнопка "Режим дерева запросов".
1. Включаете этот режим.
2. В дереве запросов находите строки с "Создание_ХХХХХ" (где ХХХХХ - это будет имя вашей ВТ)
3. Становитесь на эту строку.
4. Нажимаете кнопку "Выполнить".

При необходимости редактирования текста запроса ВТ нажимаете кнопку "Конструктор".
Ответили: (100)
# Ответить
100. Requiem (файл скачал) 15.10.2012 07:59
(99) headMade, ясно. Замудренно.
# Ответить
101. khaoos 15.10.2012 08:07
(100), Нужно наловчиться использовать дерево запросов. Вознаграждение многократно окупит затраты на изучение :).
# Ответить
102. tormozit (файл скачал) 28.11.2012 21:33
Надо внести небольшое исправление в твою версию функции ОткрытьПодборСВыборомТипаЛкс

ПараметрыФормы = Новый Структура("МножественныйВыбор, РежимВыбора", Истина, Истина);

// * АВВ [29.06.2012]{ обход проблемы получения формы
Менеджер = ирГлобальный.ЛксПолучитьМенеджер(Метаданные.НайтиПоПолномуИмени(ПолноеИмяМД));
Попытка
//ФормаВыбора = ПолучитьФорму(ПолноеИмяМД + ".ФормаВыбора", ПараметрыФормы, ВладелецФормы);
ФормаВыбора = Менеджер.ПолучитьФорму("ФормаВыбора", ВладелецФормы);
Исключение
ФормаВыбора = ПолучитьФорму(ПолноеИмяМД + ".ФормаСписка", ПараметрыФормы, ВладелецФормы);
ФормаВыбора = Менеджер.ПолучитьФорму("ФормаСписка", ВладелецФормы);
КонецПопытки;
// * АВВ [29.06.2012] }
ФормаВыбора.ЗакрыватьПриВыборе = Ложь;
Если ТипЗнч(ФормаВыбора) = Тип("Форма") Тогда
ФормаВыбора.МножественныйВыбор = Истина;
ФормаВыбора.РежимВыбора = Истина;
КонецЕсли;
ФормаВыбора.Открыть();


Старый вариант в мобильной версии приводил к невозможности делать подбор в список значений (ИР).
Ответили: (103) (104)
# Ответить
103. khaoos 29.11.2012 04:56
(102) tormozit, спасибо, вижу, что строчку забыл закомментировать
# Ответить
104. khaoos 02.12.2012 17:17
(102) tormozit, кстати, для большей надежности мобильной версии было бы идеально для получения формы здесь (и в других общих модулях ИР) вместо ПолучитьФорму использовать ее обертку ПолучитьФормуЛкс. Я последнюю переписал, чтобы она умела в мобильной версии получать формы.
# Ответить
105. headMade 27.02.2013 17:39
насчет ф-ии Поп()

при выполнении этой ф-ии:
ВнешниеОбработки.Создать("j:\1С\1С\ирМобильные.epf").Поп();

возвращается текст вида Оперировать("Плотность = """";АктивностьДеловой = """";АктивностьДровяной = """";", 1, "", )"


для открытия консоли кода приходится еще перед Оперировать(.... вставлять кусок кода ""ВнешниеОбработки.Создать(""j:\1С\1С\ирМобильные.epf"").""
для того чтобы на выходе получить строку:

"ВнешниеОбработки.Создать("j:\1С\1С\ирМобильные.epf").Оперировать("Плотность = """";АктивностьДеловой = """";АктивностьДровяной = """";", 1, "", )"

иначе ф-ия Вычислить просто не сработает

Не могли бы вы доработать ф-ию Поп, чтобы она возвращала значение "Оперировать(...)" с приставкой "ВнешниеОбработки.Создать(...)"
спасибо.
Ответили: (106)
# Ответить
106. khaoos 28.02.2013 04:46
(105) headMade, законное требование :). Постараюсь к выходу следующей версии доработать. Единственное, что смущает, там в табло, кажется, достаточно ограниченное количество символов можно ввести? (с 1с 4 месяца уже как не работаю, всякие мелочи уж точно из памяти стираются)
# Ответить
107. headMade 28.02.2013 11:07
количество символов можно ввести около 300, но сработать должно все норм т.к. фактически должно влезть только
Вычислить(ВнешниеОбработки.Создать("j:\1С\1С\ирМобильные.epf").Поп())

а уже сама ф-ия Поп() будет возвращать длинную строку
Ответили: (116)
# Ответить
108. chmod660 (файл скачал) 01.03.2013 11:11
За ваш труд неимоверное спасибо, рыдаю и не представляю, как жил без них раньше....

Замечена ошибка:
"Консоль кода" не желает сохранять свои настройки в файл (*.f1c)
Ответили: (109) (111)
# Ответить
109. khaoos 01.03.2013 11:56
(108) chmod660, спасибо за отзыв, но кого уж благодарить, так это tormozit'а, автора разработки, а я лишь немного интеллектуальным копи-пастингом занимаюсь :). За замеченную ошибку также благодарю, к следующей версии постараюсь исправить.
# Ответить
110. Itilive.ru (файл скачал) 01.03.2013 23:59
Привет а добавь к себе в консользапроса замер времени выполнения вложенных запросов. я делаю так:

Функция пРазницаЧисловыхСтруктур(Знач Структура1,Структура2)
	Для каждого Стр Из Структура2 Цикл
		Если Структура1.Свойство(Стр.Ключ) Тогда
			Структура1[Стр.Ключ]=Структура1[Стр.Ключ]-Структура2[Стр.Ключ];
		КонецЕсли;
	КонецЦикла; 
	Возврат Структура1;
КонецФункции

Функция пВыровнятьСтруктуруВремени(СтруктураВремени)
	Если СтруктураВремени.МиллиСекунда<0 Тогда
		СтруктураВремени.МиллиСекунда=1000+СтруктураВремени.МиллиСекунда;
		СтруктураВремени.Секунда=СтруктураВремени.Секунда-1;
	КонецЕсли;
	Если СтруктураВремени.Секунда<0 Тогда
		СтруктураВремени.Секунда=60+СтруктураВремени.Секунда;
		СтруктураВремени.Минута=СтруктураВремени.Минута-1;
	КонецЕсли;
	Если СтруктураВремени.Минута<0 Тогда
		СтруктураВремени.Минута=60+СтруктураВремени.Минута;
		СтруктураВремени.Час=СтруктураВремени.Час-1;
	КонецЕсли;
	Если СтруктураВремени.Час<0 Тогда
		СтруктураВремени.Час=24+СтруктураВремени.Час;
		СтруктураВремени.Дата=СтруктураВремени.Дата-1;
	КонецЕсли;
	Возврат СтруктураВремени;
КонецФункции

Функция пПолучитьСтруктуруВремени(Время)
	ВозвЗнач=Новый Структура;
	ВозвЗнач.Вставить("Год",Число(Лев(Время,4)));
	ВозвЗнач.Вставить("Месяц",Число(Сред(Время,5,2)));
	ВозвЗнач.Вставить("Дата",Число(Сред(Время,7,2)));
	ВозвЗнач.Вставить("Час",Число(Сред(Время,9,2)));
	ВозвЗнач.Вставить("Минута",Число(Сред(Время,11,2)));
	ВозвЗнач.Вставить("Секунда",Число(Сред(Время,13,2)));
	ВозвЗнач.Вставить("МиллиСекунда",Число(Сред(Время,16,3)));
	Возврат ВозвЗнач;
КонецФункции

Функция пПолучитьСтрокуВремени(Структура)
	ВозвЗнач=Строка(Структура.Дата)+"-"+Строка(Структура.Месяц)+"-"+Строка(Структура.Год)+" "+
	Структура.Час+":"+Структура.Минута+":"+Структура.Секунда+"."+Формат(Структура.МиллиСекунда,"ЧЦ=3; ЧВН=");
	Возврат ВозвЗнач;
КонецФункции

Функция пПолучитьКоличествоМиллиСекундИзСтруктуры(Структура)
	мМесяцев=Структура.Год*12+Структура.Месяц;
	мДней=мМесяцев*30+Структура.Дата;
	мЧас=мДней*24+Структура.Час;
	мМинута=мЧас*60+Структура.Минута;
	мСекунда=мМинута*60+Структура.Секунда;
	Возврат мСекунда*60+Структура.МиллиСекунда;
КонецФункции

Функция пКоличествоМиллисекунд(ВремяНачала, ВремяОкончания) Экспорт
	Если ТипЗнч(ВремяНачала)=Тип("Строка") Тогда
		СтруктураВремениНачала=пПолучитьСтруктуруВремени(ВремяНачала);
		СтруктураВремениОкончания=пПолучитьСтруктуруВремени(ВремяОкончания);
		
		Возврат пПолучитьКоличествоМиллиСекундИзСтруктуры(
						пВыровнятьСтруктуруВремени(
						пРазницаЧисловыхСтруктур(
						СтруктураВремениОкончания,СтруктураВремениНачала)));
						
	ИначеЕсли ТипЗнч(ВремяНачала)=Тип("Дата") Тогда
		Период=ВремяОкончания-ВремяНачала;
		Возврат Период;	
	КонецЕсли;
КонецФункции

Функция пРазницаВремени(ВремяНачала, ВремяОкончания) Экспорт
	Если ТипЗнч(ВремяНачала)=Тип("Строка") Тогда
		СтруктураВремениНачала=пПолучитьСтруктуруВремени(ВремяНачала);
		СтруктураВремениОкончания=пПолучитьСтруктуруВремени(ВремяОкончания);
		Возврат пПолучитьСтрокуВремени(пВыровнятьСтруктуруВремени(пРазницаЧисловыхСтруктур(СтруктураВремениОкончания,СтруктураВремениНачала)));
	ИначеЕсли ТипЗнч(ВремяНачала)=Тип("Дата") Тогда
		Период=ВремяОкончания-ВремяНачала;
		КоличествоДней=Цел(Период/86400);
		КоличествоЧасов=Цел((Период-КоличествоДней*86400)/3600);
		КоличествоМинут=Цел((Период-КоличествоДней*86400-КоличествоЧасов*3600)/60);
		КоличествоСек=Цел(Период-КоличествоДней*86400-КоличествоЧасов*3600-КоличествоМинут*60);
		Возврат ?(КоличествоДней<>0,"Дней:"+КоличествоДней+" ","")+
		?(КоличествоЧасов<>0,"Час.:"+КоличествоЧасов+" ","")+
		?(КоличествоМинут<>0,"Мин.:"+КоличествоМинут+" ","")+
		?(КоличествоСек<>0,"Сек.:"+КоличествоСек+" ","");	
	КонецЕслИ;
КонецФункции

Функция пПолучитьМеткуВремени() Экспорт
Процедура КоманднаяПанельФормыВычислитьВремяВыполненияПакетногоЗапроса­(Кнопка)
	ОбъектЗапрос = Новый Запрос;
	ОбъектЗапрос.МенеджерВременныхТаблиц=Новый МенеджерВременныхТаблиц;
	
	Для каждого СтрокаПараметров Из мФормаПараметров.Параметры Цикл
		Если СтрокаПараметров.ЭтоВыражение Тогда
			ОбъектЗапрос.УстановитьПараметр(СтрокаПараметров.ИмяПараметра, Вычислить(СтрокаПараметров.ЗначениеПараметра));
		Иначе
			ОбъектЗапрос.УстановитьПараметр(СтрокаПараметров.ИмяПараметра, СтрокаПараметров.ЗначениеПараметра);
		КонецЕсли;
	КонецЦикла;
	
	ПолныйТекстЗапроса = СтрЗаменить(вПолучитьТекстЗапроса(Истина), "|", "");
	Если ПустаяСтрока(ПолныйТекстЗапроса) Тогда
		Предупреждение("Не заполнен текст запроса!", 30);
		Возврат;
	КонецЕсли;
	
	МассивЗапросов=_РазложитьСтрокуВМассивПодстрок(ПолныйТекстЗапроса,";");
	
	КодОбработки=СокрЛП(ЭлементыФормы.КодОбработки1.ПолучитьТекст());
	Если НЕ ПустаяСтрока(КодОбработки) Тогда
		Выполнить(КодОбработки);
	КонецЕсли;
	
	ОбщееВремяВыполнения=0;
	НомерЗапроса=0;
	
	Для Каждого _ТекстЗапроса Из МассивЗапросов Цикл
		НомерЗапроса=НомерЗапроса+1;
		ОбъектЗапрос.Текст=_ТекстЗапроса;
		_ТекстЗапроса=ВРег(_ТекстЗапроса);
		
		ПозицияПоместить=Найти(_ТекстЗапроса,"ПОМЕСТИТЬ ");
		ИмяВременнойТаблицы="";
		Если ПозицияПоместить>0 Тогда
			НачалоИмениТаблицы=ПозицияПоместить+СтрДлина("ПОМЕСТИТЬ ");
			Для н=НачалоИмениТаблицы ПО СтрДлина(_ТекстЗапроса) Цикл 
				Символ=Сред(_ТекстЗапроса,н,1);
				Если Символ=" " ИЛИ Символ=Символы.ВК ИЛИ Символ=Символы.ВТаб ИЛИ Символ=Символы.НПП ИЛИ Символ=Символы.ПС  ИЛИ Символ=Символы.ПФ  ИЛИ Символ=Символы.Таб Тогда
					ИмяВременнойТаблицы=Сред(ОбъектЗапрос.Текст,НачалоИмениТаблицы,н-НачалоИмениТаблицы);
					Прервать;
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
		
		ВремяНачалаВыполнения=пПолучитьМеткуВремени();
		РезультатЗапроса=ОбъектЗапрос.Выполнить();
		ВремяОкончанияВыполнения=пПолучитьМеткуВремени();
		ИспользованноВремени=пКоличествоМиллисекунд(ВремяНачалаВыполнения,ВремяОкончанияВыполнения);
		ОбщееВремяВыполнения=ОбщееВремяВыполнения+ИспользованноВреме­ни;
		КоличествоСтрокРезультата=0;
		Если Не РезультатЗапроса.Пустой() Тогда
			Таблица=РезультатЗапроса.Выгрузить();
			Если Таблица.Количество()=1 И Таблица.Колонки.Количество()=1 И Таблица.Колонки.Найти("Количество")<>Неопределено Тогда
				КоличествоСтрокРезультата=Таблица[0].Количество;
			Иначе 
				КоличествоСтрокРезультата=Таблица.Количество();
			КонецЕсли;
		КонецЕсли;
			
		Сообщить("Запрос:"+НомерЗапроса+?(Не ПустаяСтрока(ИмяВременнойТаблицы),"; Имя таблицы:"+ИмяВременнойТаблицы,"")+"; Время выполнения(Сек.): "+пРазницаВремени(ВремяНачалаВыполнения,ВремяОкончанияВыполнения)+"; Количество строк в результате:"+КоличествоСтрокРезультата+"; Скорость(мс. на строку):"+ИспользованноВремени/?(КоличествоСтрокРезультата=0,1,КоличествоСтрокРезультата));
	КонецЦикла;
КонецПроцедуры
...Показать Скрыть
Ответили: (112)
# Ответить
111. khaoos 02.03.2013 07:15
(108) chmod660, ошибку повторить не удалось. Версия последняя используется? Если ошибка стабильно воспроизводится, хорошо бы получить алгоритм ее воспроизведения.
Ответили: (113)
# Ответить
112. khaoos 02.03.2013 07:18
(110) Itilive.ru, консоль запросов не моя. В статье есть ссылка на оригинальные инструменты разработчика. Предложите их автору данную идею. Инструменты охотно адаптируются под адекватные требования ее пользователей. :)
# Ответить
113. chmod660 (файл скачал) 02.03.2013 14:16
(111) khaoos,
шаги.

0. Разпаковываю скачанный архив с версией 2.59.1
1. открываю базу с конфигурацией "УПП для Украины"
2. открываю в ней корневую обработку ирМобильные
3. открываю из панельки консоль кода
4. пишу код, нажимаю кнопку с дискеткой вверху формы обработки ("Сохранить файл")
5. указываю в диалоге имя тест_123, нажимаю кнопку "Сохранить"

файла с указанным именем в выбранной папке не появляется. также его нет в каталоге базы или каталоге обработки.



Ошибка происходит потому, что в обработке "ирНеГлобальный" в строке 3445 где вызывается
ЗначениеВФайл(ИмяСохраняемогоФайла, ДанныеДляФайла);

ИмяСохраняемогоФайла=="".
Если перед строчкой добавить
 ИмяСохраняемогоФайла=ДиалогВыбораФайла.ПолноеИмяФайла;
тогда все хорошо сохраняется.
Ответили: (114)
# Ответить
114. khaoos 03.03.2013 07:50
(113) chmod660, если версия действительно 2.59.1, то рекомендую скачать более свежую версию. Например, в строчке 3445 в 2.69.1 совершенно другой код. Много воды уже утекло за 10 релизов :). Свежие версии также дублируются на сайте оригинальных инструментов.
Ответили: (115)
# Ответить
115. chmod660 (файл скачал) 03.03.2013 11:00
(114) khaoos, мильен извинений.
замыленный трудовой неделей глаз не увидел, что версии отличаются, искренне верил, что использую самую последнюю.
# Ответить
116. khaoos 03.03.2013 18:05
(107) headMade, в 2.70.1 изменил поведение функции Поп() на предложенное вами.
# Ответить
117. headMade 04.03.2013 10:03
спасибо, будем работать
# Ответить
118. Константин С. (файл скачал) 01.04.2013 13:50
{ВнешняяОбработка.ирСервер.МодульОбъекта(22)}: Ошибка при вызове метода контекста (Выполнить)
по причине:
{ВнешняяОбработка.ирСервер.МодульОбъекта(22)}: Ошибка при вызове метода контекста (Выполнить)

по причине:
Метод задания не найден:  ирСервер:ПоместитьСтрокуСоединенияВХранилищеЛкс
...Показать Скрыть


Отшибка при открытии версии 2.72.1 в КА 1.1
Ответили: (119)
# Ответить
119. khaoos 01.04.2013 14:02
(118) Константин С., да косяк. Задания в мобильной версии работать не будут, не досмотрел. Наверное, часто вываливается? При каких действиях?
ЗЫ Увидел, что при открытии. Каюсь, с 1С фактически уже не работаю. Открывал только на файловой базе. На любой клиент-серверной должно заваливаться. Походу нужно изъять из обращения версию 2.72
# Ответить
120. tormozit (файл скачал) 01.04.2013 14:20
В версии 2.75 подсистемы ИР я добавлю заплатку, чтобы не нужно было вручную менять здесь код при преобразовании в мобильную версию.

Функция ПолучитьСтрокуСоединенияСервераЛкс() Экспорт
	
	Если ирКэш.ЭтоФайловаяБазаЛкс() Тогда
		Результат = СтрокаСоединенияИнформационнойБазы();
	Иначе
		Если ирКэш.ЛиНемобильныйРежимЛкс() Тогда
			АдресХранилища = ПоместитьВоВременноеХранилище("");
			Параметры = Новый Массив();
			Параметры.Добавить(АдресХранилища);
			ФоновоеЗадание = ФоновыеЗадания.Выполнить("ирСервер.ПоместитьСтрокуСоединенияВХранилищеЛкс", Параметры);
			ФоновоеЗадание.ОжидатьЗавершения();
			Результат = ПолучитьИзВременногоХранилища(АдресХранилища);
		Иначе
			Результат = СтрокаСоединенияИнформационнойБазы();
		КонецЕсли; 
	КонецЕсли; 
	Возврат Результат;
	
КонецФункции
...Показать Скрыть
Ответили: (121) (122)
# Ответить
121. khaoos 01.04.2013 17:30
(120) tormozit, да спасибо, я уже сейчас воспользуюсь. Я заметил этот новый хитрый участок кода, но что-то за несколько месяцев редкой работы с 1С нюх подрастерял.
# Ответить
122. khaoos 01.04.2013 17:35
(120) tormozit, кстати я хочу занести это в ограничения мобильной версии. С чем связаны эти хитрости? С использованием кластера?
Ответили: (123)
# Ответить
123. tormozit (файл скачал) 01.04.2013 18:34
(122) Это изменение (получение строки соединения сервера вместо клиентской) носит некритичный для функционирования подсистемы характер. Поэтому о нем можно не сообщать в ограничениях.
# Ответить
124. vsuh (файл скачал) 02.04.2013 14:14
Мобильные ИР 2.71.1
Платформа 8.2.15.310 клиент-сервер
{ВнешняяОбработка.ирМобильные.МодульОбъекта(794)}: Метод объекта не обнаружен (мирИнициализировать)
по причине:
{ВнешняяОбработка.ирМобильные.МодульОбъекта(794)}: Метод объекта не обнаружен (мирИнициализировать)

...Показать Скрыть
Ответили: (125)
# Ответить
125. khaoos 02.04.2013 15:02
(124) vsuh, точно 2.71.1? Функции мирИнициализировать вроде только в 2.72.1 понавтыкал. Сейчас спецом скачал отсюда архив 2.71.1. Ни глобальным поиском ни глазами ничего не нашел. Не могли как-нибудь в ту же папку разархивировать и одни объекты скопировать с заменой, а другие нет, ну или тому подобное действие сделать?
Ответили: (126)
# Ответить
126. vsuh (файл скачал) 03.04.2013 08:28
(125) khaoos, Мда уж..
Где-то ступил. Сейчас запустил из папки download - все нормально запустилось. Видимо обновляя что-то не перезаписал.
Прошу прощения.
И, примите мою нижайшую благодарность за Ваш труд!
# Ответить
127. SamNeSvoy (файл скачал) 19.04.2013 11:55
Выполнял произвольный алгоритм в обработке объектов. Отработало хорошо, о чем свидетельствует сообщение в табло, но в конце выпала в ошибку
{Форма.ПодборИОбработка.Форма(1405)}: Ошибка при вызове метода контекста (Выполнить)
ТаблицаРезультата = Запрос.Выполнить().Выгрузить();
по причине:
{(4, 18)}: Поле не найдено "Т.Дата1"
ВЫБРАТЬ Т.Дата,Т.<<?>>Дата1, Т.Ссылка ИЗ (ВЫБРАТЬ
Ответили: (128) (130)
# Ответить
128. khaoos 25.04.2013 19:09
(127) SamNeSvoy, сообщите, пожалуйста, версию.
Ответили: (129)
# Ответить
129. SamNeSvoy (файл скачал) 28.04.2013 08:04
(128) khaoos, 2.73.1
Ответили: (130)
# Ответить
130. tormozit (файл скачал) 14.05.2013 19:24
(127),(129) Такая ошибка была исправлена в одной из последующих версий подсистемы ИР.
# Ответить
131. Smart_Fox 15.05.2013 17:17
Нашел небольшую багу в форме редактирования таблицы значений (версия 2.76.1).
Ошибка заключается в невозможности изменения названия колонки ТЗ.
Предлагаю решение:
ирПлатформа.epf->Форма:"ТаблицаЗначений"->Процедура: "ОбновитьКолонкиТаблицы";
Процедура ОбновитьКолонкиТаблицы()
	
	Таблица = ЭлементыФормы.ПолеТаблицы.Значение;
	КолонкиДляУдаления = Новый Массив;
	Для Каждого КолонкаДляУдаления Из Таблица.Колонки Цикл
		КолонкиДляУдаления.Добавить(КолонкаДляУдаления);
	КонецЦикла;
	
	Для Каждого СтрокаКолонки Из ТаблицаКолонок Цикл
		Если СтрокаКолонки.ИмяСтаройКолонки <> "" Тогда
			ИмяСтаройКолонки = СтрокаКолонки.ИмяСтаройКолонки;
			СтараяКолонка = Таблица.Колонки[ИмяСтаройКолонки];
			КолонкиДляУдаления.Удалить(КолонкиДляУдаления.Найти(СтараяКолонка));
			
//-->>Smart_Fox 15.05.2013 16:12:53
			Если ИмяСтаройКолонки <> СтрокаКолонки.Имя Тогда
				СтараяКолонка.Имя = СтрокаКолонки.Имя;
				Колонка = ЭлементыФормы.ПолеТаблицы.Колонки.Найти(ИмяСтаройКолонки);
				Колонка.Имя = СтрокаКолонки.Имя;
				СтрокаКолонки.ИмяСтаройКолонки = СтрокаКолонки.Имя;
				ОбновитьКолонкуТабличногоПоляПоКолонкеДанных(СтараяКолонка);			
			КонецЕсли;
//<<--Smart_Fox 15.05.2013 16:12:53 
			
			Если Не ирНеглобальный.СериализацииРавныЛкс(СтараяКолонка.ТипЗначения, СтрокаКолонки.ТипЗначения) Тогда
				ВременноеИмя = ирКэш.Получить().ПолучитьИдентификаторИзПредставления(Новый УникальныйИдентификатор());
				ВременнаяКолонка = Таблица.Колонки.Добавить(ВременноеИмя, СтрокаКолонки.ТипЗначения);
				Если ЭтоДерево Тогда
					ВсеСтроки = ирНеглобальный.ПолучитьВсеСтрокиДереваЗначенийЛкс(Таблица);
				Иначе
					ВсеСтроки = Таблица;
				КонецЕсли; 
				Для Каждого СтрокаТаблицы Из ВсеСтроки Цикл
					ОбработкаПрерыванияПользователя();
					СтрокаТаблицы[ВременноеИмя] = СтрокаТаблицы[ИмяСтаройКолонки];
				КонецЦикла; 
				Таблица.Колонки.Удалить(ИмяСтаройКолонки);
				ВременнаяКолонка.Имя = СтрокаКолонки.Имя;
				ОбновитьКолонкуТабличногоПоляПоКолонкеДанных(ВременнаяКолонка);
				СтараяКолонка = ВременнаяКолонка;
			КонецЕсли;
		Иначе
			Если СтрокаКолонки.Имя = "" Тогда
				 Продолжить;
			КонецЕсли; 
			СтараяКолонка = Таблица.Колонки.Добавить(СтрокаКолонки.Имя, СтрокаКолонки.ТипЗначения);
		КонецЕсли;
		ЗаполнитьЗначенияСвойств(СтараяКолонка, СтрокаКолонки, "Заголовок, Ширина"); 
		ОбновитьКолонкуТабличногоПоляПоКолонкеДанных(СтараяКолонка);
		Если СтрокаКолонки.ИмяСтаройКолонки = "" Тогда
			СтрокаКолонки.ИмяСтаройКолонки = СтрокаКолонки.Имя;
		КонецЕсли;
	КонецЦикла;
	
	Для Каждого КолонкаДляУдаления Из КолонкиДляУдаления Цикл
		ЭлементыФормы.ПолеТаблицы.Колонки.Удалить(ЭлементыФормы.ПолеТаблицы.Колонки[КолонкаДляУдаления.Имя]);
		Таблица.Колонки.Удалить(КолонкаДляУдаления);
	КонецЦикла; 
	Если ЭлементыФормы.ПолеТаблицы.Колонки.Количество() > 0 Тогда
		ЭлементыФормы.ПолеТаблицы.Колонки[0].ОтображатьИерархию = Истина;
	КонецЕсли; 
	
КонецПроцедуры

...Показать Скрыть
Ответили: (132) (133)
# Ответить
132. tormozit (файл скачал) 15.05.2013 23:54
(131) Спасибо. Исправление войдет в версию 2.81 подсистемы ИР.
# Ответить
133. tormozit (файл скачал) 20.05.2013 21:54
(131) Исправлено в версии 2.81 подсистемы.
# Ответить
134. tormozit (файл скачал) 22.05.2013 16:23
Есть предложение. Во всех серверных функциях (общий модуль ирСервер) вставить вызов исключения "В мобильном варианте функция не поддерживается". Сейчас многие пользователи обращаются с проблемами, которые возникают из-за того, что функции просто вызываются на клиенте. В частности проблема остро касается инструмента "Настройка техножурнала", в которой флажок "На сервере" молча работает как "На клиенте", а пользователь об этом не подозревает.
Ответили: (135) (136)
# Ответить
135. khaoos 23.05.2013 15:44
(134) tormozit, ок, вставлю в следующей версии.
# Ответить
136. tormozit (файл скачал) 31.05.2013 12:10
(134) Хочу добавить, что исключение должно вызываться только в клиент-серверном режиме. Пример
Процедура ОчиститьКаталогЖурналаЛкс(КаталогЖурнала, ВыводитьПредупрежденияИСообщения = Истина) Экспорт
    #Если Клиент И Не Сервер Тогда
	ВызватьИсключение "В мобильном варианте функция не поддерживается. Для ее использования встраивайте подсистему.";
    #КонецЕсли 
	ирНеглобальный.ОчиститьКаталогЖурналаЛкс(КаталогЖурнала, , ВыводитьПредупрежденияИСообщения);
КонецПроцедуры // ОчиститьКаталогЖурналаЛкс()
...Показать Скрыть
# Ответить
137. dovenok2 31.05.2013 12:53
попробуюприменитьп ри случае
# Ответить
138. zqzq (файл скачал) 06.06.2013 12:00
Поиск и замена ссылок при нажатии автозамена ошибка
{ВнешняяОбработка.ирГлобальный.МодульОбъекта(4461)}: Ошибка при вызове метода контекста (ПодключитьОбработчикОжидания)
			ПодключитьОбработчикОжидания("ЛксОсвободитьВсеИндикаторыПроцессов", 0.1, Истина);
по причине:
Недопустимое значение параметра (параметр номер '1')
...Показать Скрыть

База клиент-сервер, 8.2.15.289.
Ответили: (139)
# Ответить
139. tormozit (файл скачал) 06.06.2013 12:11
(138) Строку
ПодключитьОбработчикОжидания("ЛксОсвободитьВсеИндикаторыПроцессов", 0.1, Истина);

общего модуля ирГлобальный в мобильных инструментах сэмулировать будет очень сложно. Поэтому предлагаю ее просто закомментировать, а в недостатках указать "Некорректная работа индикаторов процессов после прерывания пользователем".
Ответили: (140) (147)
+ 1 [ zqzq; ]
# Ответить
140. zqzq (файл скачал) 06.06.2013 13:35
(139) tormozit,
Закомментил, теперь индикатор прогресс-бара всегда на 0% (я ничего не прерывал :)). В строке состояния процент отображается. В принципе не важно, главное работает.
Ответили: (141)
# Ответить
141. tormozit (файл скачал) 06.06.2013 13:54
(140) Индикатор в виде отдельной формы в инструменте "Поиск дублей и замена ссылок" уже давно всегда показывает 0%. Это сделано умышленно, т.к. от него в будущем планирую отказаться.
# Ответить
142. zqzq (файл скачал) 07.06.2013 09:53
Вот ещё обнаружил, консоль СКД, загружаю схему СКД (рабочий отчет), ОК, ошибка:
{Форма.Форма.Форма(1524)}: Поле объекта не обнаружено (Имя)
				СтрокаРесурса.Имя = ПолеИтога.ПутьКДанным;

На одной из предыдущих версий не было.
Ответили: (143)
# Ответить
143. tormozit (файл скачал) 07.06.2013 10:56
(142) Выложи файл для воспроизведения.
Ответили: (144) (145)
# Ответить
144. zqzq (файл скачал) 07.06.2013 13:08
(143) tormozit,
Вот пример воспроизведения: берём демо-УПП (1.3.35.1 файловая, но в принципе неважно), в конфигураторе находим отчет КалькуляцияСебестоимости, Схема компоновки - вложенная схема "Затраты на выпуск (упр. учет)", выгружаем её в xml, в предприятии в консоли ИР СКД добавляем отчет, загружаем схему, ОК - ошибка.
Ответили: (145)
# Ответить
145. tormozit (файл скачал) 07.06.2013 13:17
(144) У меня нет этой конфигурации. Если хочешь, чтобы ошибку исправили, выполни просьбу (143).
Ответили: (146)
# Ответить
146. zqzq (файл скачал) 07.06.2013 14:10
(145) tormozit,
Вот вышеописанная схема. Можно в любой базе проверять, ошибка присутствует (не в УПП ещё пару раз ругнётся на отсутствие Перечисление.РазделыУчета).
Ответили: (148)

Прикрепленные файлы:

затратынавыпускрегл.xml
# Ответить
147. khaoos 07.06.2013 19:58
(138), (139) tormozit, вроде сэмулировал посредством подключения обработчика ожидания открытой панели мобильных инструментов. Не знаю, корректно ли работает, но исключений не выкидывает никаких. Включу в следующую версию.
Ответили: (149)
# Ответить
148. khaoos 07.06.2013 20:05
(146) zqzq, Да в версии 2.79.1 действительно есть проблема. В 2.82.1 не воспроизвелась. Специально ничего не исправлял в мобильной версии. Заметил другую проблему зато: командная панель над деревом отчетов "потеряла" свой источник и кнопки неактивные все, почему-то кроме одной :). Исправлю и завтра, думаю, выложу 2.82.1

Добавлено: когда спать ложился, осенило, почему баг в 2.79.1. Причина та же, по которой командная панель потеряла свой источник. При обновлении когда копировал из оригинальной версии табличное поле, соответствующий ему реквизит получил суффикс "1". При обновлении до 2.82.1 это случайно заметил, и реквизит переименовал обратно, но о последствиях не было времени подумать :).
# Ответить
149. tormozit (файл скачал) 07.06.2013 20:33
(147) А ну да. Она же всегда открыта должна быть?
Ответили: (150)
# Ответить
150. khaoos 07.06.2013 20:39
(149) tormozit, ага, на этом и расчет строится:)
# Ответить
151. zqzq (файл скачал) 13.06.2013 15:50
Консоль СКД поломалась в версии 2.82.1.

В клиент-серверной 1С при выполнении любой схемы выдаёт ошибку
{ВнешняяОбработка.ирСервер.МодульОбъекта(316)}: В мобильном варианте серверная функция "ПолучитьИмяФайлаАктивнойНастройкиТехноЖурналаЛкс" не поддерживается. Для ее использования встраивайте подсистему.
   ВызватьИсключение "В мобильном варианте серверная функция """ + ИмяФункции +


В файловом варианте нет этой ошибки, но не заполняется таблица параметров, отборов и т.д.
Ответили: (152) (157)

Прикрепленные файлы:

ТестМакетСКД_ир82.xml
# Ответить
152. khaoos 13.06.2013 16:49
(151) zqzq, спасибо. Внес соответствующие исправления, выложил как версию 2.82.2. Поставил пока заглушку на запрет серверных функций. Впредь, если сами можете исправить ошибку, буду благодарен, если будете присылать исправленные версии. Проект как бы "open source" :). Сам не пользуюсь разработкой, поэтому даже самые глупые ошибки не вижу.
# Ответить
153. Ndochp (файл скачал) 26.06.2013 15:43
У меня вдруг откуда не возьмись перестала работать команда "ВнешниеОбработки.Создать("C:\mir\ирМобильные.epf").Отладить(Запрос, Истина)" из отладки. Пишет "Ошибка при вызове метода контекста "Создать". Из консоли кода в предприятии работает, проверочная пустая обработка создается.
Виноваты точно не инструменты, так как еще вчера все работало, то пишу сюда, может кто сталкивался и победил?
(попытки вставить отладочную печать в модуль объекта и перед открытием формы ни к чему не привели платформа 8,2,15,157, но она тоже не менялась)
# Ответить
154. vsuh (файл скачал) 28.06.2013 15:05
ИР мобильные 2.79.1. Платформа 1С:Предприятие 8.2 (8.2.15.310), Конфигурация УПП 1.3.40.3

1. Обработка Анализ журнала регистрации.
При щелчке в любой колонке ошибка:
{Форма.ФормаСобытия.Форма(5)}: Поле объекта не обнаружено (ТаблицаЖурнала)
		ЭлементыФормы.ТаблицаЖурнала.ТекущаяСтрока = НачальноеЗначениеВыбора;

2. Обработка Анализ журнала регистрации.
При нажатии на кнопку "Открыть таблицу в консоли компоновки"
{Форма.Форма.Форма(1524)}: Поле объекта не обнаружено (Имя)
				СтрокаРесурса.Имя = ПолеИтога.ПутьКДанным;

3. В непредсказуемые моменты вываливается ошибка:
{ОбщийМодуль.ЭлектронныеДокументы1СТакскомСлужебный.Модуль(898,2)}: Переменная не определена (ЭлектронныеДокументыФорматОбмена)
	<<?>>ЭлектронныеДокументыФорматОбмена.ВыгрузитьЭДвФайл(ЭД, ИмяФайла, УказаниеТипа);
{ОбщийМодуль.ЭлектронныеДокументы1СТакскомСлужебный.Модуль(2311,4)}: Переменная не определена (ЭлектронныеДокументыФорматОбмена)
			<<?>>ЭлектронныеДокументыФорматОбмена.ПолучитьТипЗначенияCML("Card", "http://api-invoice.taxcom.ru/card"));
{ОбщийМодуль.ЭлектронныеДокументы1СТакскомСлужебный.Модуль(2342,4)}: Переменная не определена (ЭлектронныеДокументыФорматОбмена)
			<<?>>ЭлектронныеДокументыФорматОбмена.ПолучитьТипЗначенияCML("ContainerDescription", "http://api-invoice.taxcom.ru/meta"));
{ОбщийМодуль.ЭлектронныеДокументы1СТакскомСлужебный.Модуль(2556,3)}: Переменная не определена (ЭлектронныеДокументыФорматОбмена)
		<<?>>ЭлектронныеДокументыФорматОбмена.ОшибкаФормированияЭлектронногоДокумента(ОписаниеОшибки(), СтруктураДопПараметров,
{ОбщийМодуль.ЭлектронныеДокументы1СТакскомСлужебный.Модуль(2639,3)}: Переменная не определена (ЭлектронныеДокументыФорматОбмена)
		<<?>>ЭлектронныеДокументыФорматОбмена.ОшибкаФормированияЭлектронногоДокумента(ОписаниеОшибки(), СтруктураДопПараметров,
{ОбщийМодуль.ЭлектронныеДокументы1СТакскомСлужебный.Модуль(2682,2)}: Переменная не определена (ЭлектронныеДокументыФорматОбмена)
	<<?>>ЭлектронныеДокументыФорматОбмена.ЗаполнитьСвойствоXDTO(ОбъектXDTO, ИмяСвойства, Значение, Обязательное, ТекстОшибки);
{ОбщийМодуль.ЭлектронныеДокументы1СТакскомСлужебный.Модуль(2688,10)}: Переменная не определена (ЭлектронныеДокументыФорматОбмена)
	Возврат <<?>>ЭлектронныеДокументыФорматОбмена.ПолучитьОбъектТипаCML(Тип, ВерсияСхемы);
...Показать Скрыть

В этот раз, при попытке прервать (Ctrl-Break) выполнения процедуры обработки строки результата из консоли запросов.

4. Консоль запросов
При нажатии на кнопку "Сформировать схему и настройки компоновки и открыть...." в форме консоли компоновки данных, в командной панели ТЧ отчетов, кнопка "Изменить" недоступна (F2 работает),
в СКД на закладке "Параметры", присутствуют параметры из предыдущих запросов, списочные параметры из ссылок представляют собой список пустых значений (вернее, список пустых списков значений).
На закладке "Настройка" \ "Параметры" у параметров не установлена галка.
Ответили: (155)

Прикрепленные файлы:

ир2.png
# Ответить
155. khaoos 01.07.2013 09:39
(154) vsuh, скачайте последнюю версию 2.82.2 (если напряг со стартмани, скачивайте с сайта оригинальных инструментов). Проблемы 1,2,4 не должны там проявляться. Проблема 3 больше похожа на ошибку в конфигурации. Могу предположить, чтоподключен с помощью настроек инфобазы некоторый обработчик ожидания, который лезет периодически в модуль ЭлектронныеДокументы1СТакскомСлужебный, но в модуле есть ошибки, которые не дают ему скомпилироваться
Ответили: (156)
# Ответить
156. vsuh (файл скачал) 01.07.2013 11:14
(155) khaoos,
ИР мобильные 2.82.1. Платформа 1С:Предприятие 8.2 (8.2.15.310), Конфигурация УПП 1.3.40.3

1. Ошибка по-прежнему имеет место быть.
2. Ошибка исчезла.

Теперь в консоли запросов и в консоли СКД при нажатии на кнопку "Сформировать":
{ВнешняяОбработка.ирСервер.МодульОбъекта(316)}: В мобильном варианте серверная функция "ПолучитьИмяФайлаАктивнойНастройкиТехноЖурналаЛкс" не поддерживается. Для ее использования встраивайте подсистему.
ВызватьИсключение "В мобильном варианте серверная функция """ + ИмяФункции +

Ответили: (157)
# Ответить
157. khaoos 01.07.2013 11:24
(156) vsuh, я рекомендовал 2.82.2. В 2.82.1 действительно так было (исключения при вызове "серверных" функций), после первой же жалобы (151) это убрал, и выпустил 2.82.2. Первую ошибку тоже не смог воспроизвести на 2.82.2. Дома гляну еще раз, если не отпишитесь, что все таки на 2.82.2 нормально все.
# Ответить
158. vsuh (файл скачал) 01.07.2013 12:12
Скачал 2.82.2
1 проблема осталась
2 исчезла.
3. да, к ИР отношения не имеет
4. формулируется теперь так:
4. Консоль запросов
При нажатии на кнопку "Сформировать схему и настройки компоновки и открыть...."
в СКД на закладке "Параметры", присутствуют параметры из предыдущих запросов, списочные параметры из ссылок представляют собой список пустых значений (вернее, список пустых списков значений).
Ответили: (160)

Прикрепленные файлы:

ир2.png
# Ответить
159. Requiem (файл скачал) 02.07.2013 09:21
Версия 2.82.2
Обработка поиска и замены дублей. При попытке выполнить замену зависимых элементов вываливается ошибка

{Форма.Форма.Форма(1809)}: Поле объекта не обнаружено (ПравильныйЭлемент3463)
СоответствиеЗамен.Вставить(Строка.НеПравильный, Строка[мИмяФлагаПравильныйЭлемент]);
Ответили: (168)
# Ответить
160. khaoos 02.07.2013 16:28
(158) vsuh,
1. Будет исправлено в следующей версии. Проблема возникала при двойном щелчке на любой колонке? Если так, то понятно, почему я не мог воспроизвести.
4. Из описания к оригинальным инструментам 2.83
"...Консоль запросов
*Исправлено некорректное заполнение параметров-списков в генерируемой по запросу схеме компоновки...".
Так что тоже в следующей версии можно ожидать исправления.
# Ответить
161. Aleksey.z (файл скачал) 02.07.2013 17:03
В след. версиях желательно реализовать запуск при старте с привязкой к конкретному пользователю или интерфейсу. А то настроил а она зараза запускается под любым пользователем что чревато последствиями.
# Ответить
162. vsuh (файл скачал) 11.07.2013 09:23
Вы, наверное, запускаете мобильные инструменты через ключ /Execute в файле общих информационных баз v8i.
В последних версиях появилась возможность настраивать автозапуск обработки (и автозапуск ее компонентов) через форму настройки.
При этом ключ AdditionalParameters=/Execute ... добавляется в локальный файл списка информационных баз %userprofile%\AppData\Roaming\1C\1CEStart\ibases.v8i только для текущего пользователя.

Прикрепленные файлы:

ир2.png
# Ответить
163. Gvozdod 18.07.2013 14:28
В консоли запросов, в дереве запросов, по нажатию "Выполнить подзапрос F7" выскакивает:
{Форма.Форма.Форма(1108)}: Преобразование значения к типу Число не может быть выполнено
ОбщаяДлительностьДочерних = ОбщаяДлительностьДочерних + ДочерняяДлительность;

Версия ир: 2.82.2
Версия платформы: 8.2.18.104

Подскажите, пожалуйста, в чем проблема
Ответили: (164) (167)
# Ответить
164. tormozit (файл скачал) 18.07.2013 14:49
(163) По такому описанию понять причину ошибки тяжело. В данном случае видеоролик очень помог бы. Если не освоили соответствующего инструмента, то рекомендую для начала Jing.
Ответили: (165)
# Ответить
165. Gvozdod 19.07.2013 08:29
(164) спасибо, я уже сам поправил. почему-то в некоторых случаях в переменных подсчета длительности возникают значения неопределенного типа или пустая строка.
Ответили: (166)
# Ответить
166. tormozit (файл скачал) 19.07.2013 09:20
(165) Для меня лучшая благодарность - помощь в устранении проблемы в самом продукте. Если ты исправил сам, то хотя бы опиши, в чем именно заключается твое исправление. Возможно это прольет свет на причину проблемы. Но в идеале, повторюсь, хочется видео с возникновением ошибки начиная с открытия формы консоли запросов.
# Ответить
167. tormozit (файл скачал) 21.07.2013 13:03
(163) Предположительно исправлено в 2.86
# Ответить
168. tormozit (файл скачал) 21.07.2013 13:04
(159) Исправлено в 2.86
# Ответить
169. kapustinag (файл скачал) 31.07.2013 14:16
Похоже, нашел ошибку в обработке "Редактор изменений на узле (ИР)" (версия мобильных - 2.82.2).
Ошибка проявляется после добавления строки по регистратору для регистра сведений или регистра накопления, и при последующих операциях со строками этого табличного поля.
Текст ошибки:
{Форма.Форма.Форма(842)}: Ошибка при установке значения атрибута контекста (Использование)
ЭлементОтбора.Использование = Истина;
по причине:
Значение данного реквизита изменять нельзя!

Ситуация, в которой потребовалось это делать:
Обнаружилось, что в базе-приемнике отсутствует один документ, который в базе-источнике есть и проведен.
Проводить документ уже нельзя в базе-источнике.
Зарегистрировал этот документ вручную с помощью данной обработки.
Он успешно перешел при обмене в базу-приемник, НО БЕЗ ДВИЖЕНИЙ.
Получается, одно из двух:
- либо теперь провести этот документ в базе-приемнике - что не всегда можно делать;
- либо вручную зарегистрировать для обмена наборы записей по данному документу-регистратору.
Ошибка эта появилась при добавлении строки по документу-регистратору в нижнее табличное поле обработки, но строка добавилась все-же. Далее, при нажатии на некоторые кнопки над этим табличным полем, ошибка выходит вновь, но функция не выполняется. Например, при нажатии на кнопку "Показать результат сериализации в XML".

Если обновить данные формы, то строки по этому документу-регистратору пропадают. То есть они в действительности не добавились в список зарегистрированных изменений.
Ответили: (170) (171)
# Ответить
170. tormozit (файл скачал) 06.08.2013 23:39
(169) Ошибку воспроизвел. Будет исправлена в следующей версии подсистемы (2.88)
# Ответить
171. tormozit (файл скачал) 12.08.2013 03:04
(169) Исправлено в версии 2.88 подсистемы
Ответили: (172)
# Ответить
172. kapustinag (файл скачал) 12.08.2013 10:20
(171)Большое спасибо. Вчера, пользуясь по-прежнему мобильной версией 2.82, заметил вот еще что:
- В обработке "Поиск и замена значений (ИР)", если менять значение ссылки на справочник ПодразделенияОрганизаций, то в ПРОВЕДЕННЫХ кадровых и зарплатных документах обработка рапортует, что замена произошла, но в обновленном списке документов документы остаются, и в действительности в них остается старое значение. После перезапуска обработки эти документы снова находятся, в них как-бы производится замена, но остается старое значение. Установка флага "Обмен данными. Загрузка = Истина" не влияет.

Проверял на УПП 1.3.41.1, "почти" типовой. Конфигурация измененная, но в кадровой и зарплатной части все типовое полностью. Платформа 8.2.16.368.

Документы, в которых оставалась старая ссылка:
- Прием на работу в организацию,
- Кадровое перемещение организаций,
- Увольнение из организаций,
- Начисление заработной платы работникам организаций,
- Невыходы в организациях,
- Начисление отпуска,
- Отражение з/п в регл.учете,
- еще несколько зарплатных документов, уже не помню какие.

Замену все-таки удалось выполнить с помощью другой обработки, взятой достаточно давно с Инфостарта. По-моему, вот этой: http://infostart.ru/projects/1134/

Думаю, дело в последовательности замены ссылки в реквизитах документа, табличных частях и в наборах записей регистров.
Да, настройку "В транзакции" не включал в данном случае, так что не могу сказать, влияет ли она на это.
Ответили: (173)
# Ответить
173. tormozit (файл скачал) 12.08.2013 10:55
(172) Обработки "Поиск и замена значений (ИР)" не существует. Видимо имелась ввиду "Поиск дублей и замена ссылок (ИР)". Чтобы разобраться в проблеме, мне нужно знать детально в каких местах находятся ссылки, подлежащие замене. Это можно узнать, открыв редактор объекта БД из списка ссылающихся объектов
Ответили: (174)

Прикрепленные файлы:

2013-08-12_105537.jpg
# Ответить
174. kapustinag (файл скачал) 12.08.2013 15:10
(173) tormozit, Да, именно она имелась в виду, приношу извинения.
Я смотрел, где находились ссылки. Во всех этих документах ссылки на старое подразделениеОрганизации находились в табличных частях.

Если нужно конкретно, в каких табличных частях, то...
В документе ПриемНаРаботуВОрганизацию - в ТЧ РаботникиОрганизации.
В документе КадровоеПеремещениеОрганизаций - в ТЧ РаботникиОрганизации.
В документе УвольнениеИзОрганизаций - было нетиповое наше поле в ТЧ, забудем про это.
В документе НачислениеЗарплатыРаботникамОрганизаций - в ТЧ Начисления и ДополнительныеНачисления.
В документе ОтражениеЗарплатыВРеглУчете - во всех ТЧ, по-моему. Этот момент сейчас не могу проверить - чуть занят, но сделаю это при необходимости.
Ответили: (175) (178)
# Ответить
175. tormozit (файл скачал) 12.08.2013 15:37
(174) Здесь помогла бы видеодемонстрация, которую можно сделать например с помощью инструмента JING.
# Ответить
176. SoulPower (файл скачал) 16.08.2013 14:30
Файл -> Открыть -> ирМобильные ->

{ВнешняяОбработка.ирМобильные.МодульОбъекта(694,9)}: Процедура или функция с указанным именем уже определена (Отладить)
Функция <<?>>Отладить(Объект, Модально = Ложь, НастройкаКомпоновки = Неопределено, ВнешниеНаборыДанных = Неопределено, ОтложенноеВыполнение = Ложь,
Ответили: (177)
# Ответить
177. tormozit (файл скачал) 17.08.2013 08:02
(176) Открываешь в конфигурации, где уже есть глобальная функция Отладить. Если в конфигурации есть подсистема "Инструменты разработчика", то это нормально (нет смысла использовать мобильные ИР там, где есть подсистема ИР). Иначе найди определение глобального метода Отладить и сообщи его расположение, определение и название конфигурации.
Ответили: (179)
# Ответить
178. tormozit (файл скачал) 17.08.2013 08:07
(174) Описанную проблему в подсистеме ИР воспроизвести не удалось. Рекомендую:
1. Постараться проверить воспроизведение именно последней версии подсистемы ИР.
2. Записать видеодемонстрацию воспроизведения проблемы (например с помощью JING) или хотя бы снять скриншоты всех шагов воспроизведения, включая форму настроек.
Ответили: (179) (180)
# Ответить
179. SoulPower (файл скачал) 19.08.2013 18:07
(178)(177) Да, в глобальном модуле есть процедурка "Отладить". Лень было разбираться и поэтому сразу сюда написал.
# Ответить
180. kapustinag (файл скачал) 19.08.2013 21:14
(178)Ок, скачаю последнюю версию и попробую, чуть позже. Пока не тратьте на это Ваше время.
# Ответить
181. ugroblin (файл скачал) 29.08.2013 10:56
Скачал последнюю версию, в ней отсутствует settings.xml. Выложите файл в общий доступ, не перекачивать же предыдущие версии чтобы найти файл без которого обработка не работает. Или это такой метод увеличения скачиваний и дохода?
Ответили: (183)

Прикрепленные файлы:

gordon-freeman.gif
# Ответить
182. CratosX (файл скачал) 04.09.2013 01:42
http://forum.infostart.ru/forum24/topic21000/message974298/#message974298
Дублирую вопрос:
Доброго дня!
Использую мобильную версию 2.82.2.
Консоль запросов, при переходе с текста запросов на закладку Параметры выдал ошибку в цикле, при нажатии на любую кнопку сообщение повторялось. Пришлось убивать сеанс.

{ВнешняяОбработка.ирГлобальный.МодульОбъекта(1694)}: Значение не является значением объектного типа (ПолучитьПиктограммуТипаЛкс)
КартинкаТипа = ирНеглобальный.ПолучитьПиктограммуТипаЛкс(ТипЗначения);
# Ответить
183. CratosX (файл скачал) 04.09.2013 01:44
(181) ugroblin, у меня тоже не сразу заработало. То ли со 2-3 раза появляется, то ли я создавал пустой этот файл, а потом он заполнился - но, помогло.
# Ответить
184. _also (файл скачал) 10.09.2013 11:36
У меня очень много баз. В большинстве стоит подсистема, но где-то нет возможности поставить и в этих базах используются мобильные. Достаточно тяжело помнить каждый раз где стоит, а где нет. Было бы удобно, если бы мобильные при старте пытались по какому-либо параметру понять, что в текущей конфе уже есть встроенная подсистема и просто подавляла ошибки о том, что "данная процедура уже определена" и не открывалась.
# Ответить
185. babys (файл скачал) 11.09.2013 10:01
Замечен косяк в обработке "Редактор объекта БД". При некорректном содержании проводки по валютному и количественному признаку (дт5001 кт70), исправить не позволяет.
Помогает другая обработка.
Ответили: (187)
# Ответить
186. vsuh (файл скачал) 19.09.2013 08:27
Уважаемый khaos прекратил поддержку разработки?
Очень жаль...
Ответили: (188)
# Ответить
187. tormozit (файл скачал) 01.10.2013 11:51
(185) По такому описанию ошибку понять очень тяжело. Попробуй описать подробнее. Самое эффективное - напечатать полный текст ошибки и записать и выложить видеоролик.
Ответили: (191)
# Ответить
188. tormozit (файл скачал) 01.10.2013 11:56
(186) Да, он перестал заниматься 1С. Возможно найдется его последователь. За 6 лет развития подсистемы десятки отважных рыцарей ломали копья, пытаясь сделать мобильную версию инструментов подсистемы. Лишь одному ему это удалось. Но теперь дорожка протоптана и повторить его подвиг будет уже заметно легче. Остается подождать нового рыцаря.
Ответили: (189)
# Ответить
189. RainyAugust22 (файл скачал) 01.10.2013 12:21
(188) tormozit, откуда инфа?
# Ответить
190. u_n_k_n_o_w_n (файл скачал) 19.11.2013 13:24
Надо было иногда просто благодарить разработчиков и тогда бы я думаю у них был стимул к действиям.
# Ответить
191. babys (файл скачал) 05.12.2013 11:17
(187) tormozit, прошу прощения за задержку с ответом, пропустил сообщение :(
Ситуация поправлена и больше не возникала.
Суть проблемы сводится к следующему у счетов 50.01 и 70 признаки Валютный и Количественный не установлены. Но после какого-то сбоя, вдруг часть проводок между этими счетами начинают попадать в отчёты по Валютному и Количественному движению. Анализ ситуации выявил, что у этих проводок у реквизитов Валюта и Количество установлен тип, т.е. они не являются NULL.
Так вот обработка "Редактор объект БД", в данной базе используется мобильная версия, открывает проводку, ничего в ней не меняя, и это +. Но когда я пытался изменить, содержимое полей Валюта Дт/Кт, ВалютнаяСумма Дт/Кт и Количество Дт/Кт в табличном поле "Движения" "Журнал проводок (бухгалтерский учет)" то туда можно записать только 0, что там собственно и стояло. И при записи проблема не корректировалась.
В упоминаемой обработке данная проблема решается при записи проводок некорректного документа, да, именно без редактирования данных проводки.
# Ответить
192. tormozit (файл скачал) 29.12.2013 01:18
Теперь мобильная версия инструментов выпускается мной, начиная с 3.01.1. Подробности на основном сайте подсистемы.
Ответили: (193)
+ 2 [ SirYozha; 1cmax; ]
# Ответить
193. 1cmax (файл скачал) 29.12.2013 12:16
(192) tormozit, Дичайше одобряю!
# Ответить
194. Ionmuerto 15.01.2014 08:44
Данная обработка Поиск и замена дублирующихся элементов справочников подходит под управляемые формы 1с Управление Торговлей 11.1?
# Ответить
195. Mark1274 31.08.2015 09:36
Есть-ли возможность использовать "Мобильные ИР" для 1с 8.1?
Ответили: (196)
# Ответить
196. tormozit (файл скачал) 31.08.2015 20:53
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл