gifts2017

Алкогольная декларация 2012

Опубликовал Bosma Иванов (Bosma) в раздел Печать - Регламентированная отчетность

Для тех кто не успел подготовить выгрузки для Алкогольной декларации 2012
Работающий вариант!!!
Можно использовать в качестве заготовке в своей конфигурации

Алкогольная декларация 2012

 

 

За основу взята обработка http://infostart.ru/public/118836/

Огромное спасибо автору за начало.

Компания представляет собой порядка 80 магазинов, получающие алкоголь, как от производителей так и от поставщиков.

Используется сильно измененная Торговля-24.

Предварительно проверяется правильность заполнения реквизитов у товаров и поставщиков. Строиться две основные таблицы значений – таблица продаж и таблица закупок. Учитываются возвраты поставщикам и возвраты покупателей, не учитываются внутренние перемещения.  На основании этих таблиц строиться файл XML и печатные формы.

 

Дополнительно был разработан модуль по работе с адресными классификаторами формата dbf.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
АлкДекл2012_Магазин.ert
.ert 100,50Kb
06.08.12
269
.ert 100,50Kb 269 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Владимир (hogik) 06.08.12 15:35
(0)
"автора не нашел, но есть мыло"(с)

Может это оно: http://infostart.ru/public/118836/
P.S. Потратил две минуты на поиск. ;-)
2. Bosma Иванов (Bosma) 07.08.12 08:21
3. Sergey Ivanov (sergb1979) 08.08.12 09:46
скажите, а формат утвержден
4. Voka (voka_64) 08.08.12 11:03
На сайте пока изменений к нему нет
5. John Doe (winterspring) 17.08.12 15:18
А перемещения между обособленными подразделениями учитываются?
6. John Doe (winterspring) 20.08.12 11:02
Неплохо бы было включить в обработку недостающие процедуры из глобального модуля. А так же указать, что в обработке использована компонента 1с++
Функция не обнаружена (глПолучитьВыборку)
Переменная не определена (гл_rs)
Процедура не обнаружена (глСтрокаСообщения)
DefaultUsers; +1 Ответить 1
7. Name Fam (DefaultUsers) 20.08.12 11:29
(6) winterspring, Поддерживаю!
Автор, пришлите пожалуйста недостающие функции или сделайте полностью автономной обработку, чтобы можно было запустить на типовой ТиС.
8. Sergey Ivanov (sergb1979) 22.08.12 09:17
9. Денис Денисовский (апостол) 22.08.12 10:37
(8) подскажи, а где можно скачать утвержденный формат, а то на сайте росалкоголь регулирования не могу найти
10. Алексей (afecn42) 22.08.12 15:40
Постановление от 9 августа 2012 г. №815 О представлении деклараций об объеме производства, оборота ...
http://government.ru/gov/results/20165/

Форматы
http://www.fsrar.ru/files/structure/1366.pdf
Информации что утвердили форматы пока не видел.
11. Денис Денисовский (апостол) 23.08.12 08:30
12. Sergey Ivanov (sergb1979) 23.08.12 08:58
вообщем и постановление пока не опубликовано, странно уже 23 число...
http://base.consultant.ru/cons/cgi/online.cgi?req=doc;base=LAW;n=134109
13. Sergey Ivanov (sergb1979) 23.08.12 09:08
(9) апостол, В последнем деклорант-алко как раз актулаьные схемы
14. Денис Денисовский (апостол) 23.08.12 09:16
(13) подскажи, везде написано про розничную продажу пива, а если имеется только оптовая, тогда что декларировать не нужно?
15. Андрей Михайлов (Mihand) 23.08.12 10:42
Е(14) апостол,
Если у вас только оптовая торговля пивом, то Вы сдаете 5,6,7 декларации точно. Пиво - это алкоголь. Для них ввели специально 3 кода в классификаторе.
16. Денис Денисовский (апостол) 23.08.12 11:00
(15) спасибо за информацию, а еще не знаешь есть инструкция по заполнению этих деклараций. сейчас посмотрел их и есть некоторые вопросы.
17. Андрей Крючин (maskva) 23.08.12 11:34
как запустить эту обработку в тисе? одни ошибки почему то
18. Sergey Ivanov (sergb1979) 23.08.12 14:07
(15) Mihand, скажите а 8-ую форму надо заполнять?
19. soba (soba) 23.08.12 16:53
Присоединяюсь к просьбе добавить недостающие процедуры из глабальника
20. igoren032 (igoren032@mail.ru) 24.08.12 09:24
(12) sergb1979,
Постановление уже есть:
http://правительство.рф/gov/results/20165/
21. Sergey Ivanov (sergb1979) 24.08.12 09:27
(20) igoren032, а что оно не требует опубликования в российской газете?
22. Иван Демидов (ivanov_alex) 24.08.12 09:29
да. хотелось бы недостающие гл_rs и глПолучитьВыборку
строка сообщения непринципиальна
23. Андрей Михайлов (Mihand) 24.08.12 12:28
(16) апостол,
Нет. Инструкции пока нет. Сами ждем.
24. Алексей (afecn42) 24.08.12 14:54
Человек на форуме ФСРАР пишет:

Постановление 815 опубликовано
Источник публикации
"Собрание законодательства РФ", 20.08.2012, N 34, ст. 4735
В КонсультантПлюс: примечание.
Начало действия документа - 28.08.2012.

Сайт ЗакСобрания не выложил 34 номер. Наверно типа тупо набирают текст.

Присоединяюсь к (18).
Мы тоже не можем понять кто же сдает 8 форму. Надо ли сдавать оптовику перевозящему в розницу на своем транспорте только фасованную продукцию?
25. Андрей Крючин (maskva) 24.08.12 14:56
ребятки, подскажите пожалуйста, как эту обработку попробовать?
26. Андрей Крючин (maskva) 26.08.12 23:12
подниму темку. актуально.
27. Андрей Крючин (maskva) 28.08.12 21:04
Работающий вариант!!!
Исправьте тогда на Неработающий вариант!!!
28. Иван Кудинов (ivankudinr) 30.08.12 10:20
Подскажите, что нужно установить, чтобы появились Функция (глПолучитьВыборку) и Переменная (гл_rs)? Или их автор сам написал?
29. Bosma Иванов (Bosma) 30.08.12 14:03
(28) ivankudinr,

Функция глПолучитьВыборку(ODBCRecordset,Текст, Отладка=0, Очищать = 1, ТЗ2 = "") Экспорт
ODBCRecordset.Отладка(Отладка);
Если ODBCRecordset.Открыть(Текст)=0 Тогда
Ошибка=ODBCRecordset.ПолучитьОписаниеОшибки();
Если ПустаяСтрока(Ошибка)=0 Тогда
ВыполняемыйМодуль=СоздатьОбъект("ВыполняемыйМодуль");
ВыполняемыйМодуль.СформироватьОшибку(Ошибка);
КонецЕсли;
КонецЕсли;
Если ПустоеЗначение(ТЗ2) = 1 Тогда
ТЗ2=СоздатьОбъект("ТаблицаЗначений");
КонецЕсли;
ODBCRecordset.ПолучитьРезультатыВ_ТЗ(ТЗ2,Очищать);
ODBCRecordset.Закрыть();
Возврат ТЗ2;
КонецФункции
Эта функция для запуска SQL запроса. Будет работать если стоит компонента 1С++
гл_rs=СоздатьОбъект("ODBCRecordset");
30. Bosma Иванов (Bosma) 30.08.12 14:06
Повторимся. Этот вариант работающей нашей конфигурации измененной очень сильно Торговле 24
И выложен как заготовка для вашей базы, чтобы печатные формы не делать, и формирование файла.
31. DonPedro (donpedro) 31.08.12 23:19
Большое спасибо за обработку, а можете выложить образец xml файла, который формируется с помощью обработки? Хочу наглядно посмотреть струткуру файла, а то описание формата 4.20 что-то плохо до меня доходит.
32. Андрей Крючин (maskva) 31.08.12 23:46
(29) Bosma, Функция глПолучитьВыборку(ODBCRecordset,Текст, Отладка=0, Очищать = 1, ТЗ2 = "") Экспорт
ODBCRecordset.Отладка(Отладка);
Если ODBCRecordset.Открыть(Текст)=0 Тогда
Ошибка=ODBCRecordset.ПолучитьОписаниеОшибки();
Если ПустаяСтрока(Ошибка)=0 Тогда
ВыполняемыйМодуль=СоздатьОбъект("ВыполняемыйМодуль");
ВыполняемыйМодуль.СформироватьОшибку(Ошибка);
КонецЕсли;
КонецЕсли;
Если ПустоеЗначение(ТЗ2) = 1 Тогда
ТЗ2=СоздатьОбъект("ТаблицаЗначений");
КонецЕсли;
ODBCRecordset.ПолучитьРезультатыВ_ТЗ(ТЗ2,Очищать);
ODBCRecordset.Закрыть();
Возврат ТЗ2;
КонецФункции


гл_rs=СоздатьОбъект("ODBCRecordset");



В КАКОЕ МЕСТО ГЛОБАЛЬНОГО МОДУЛЯ ЭТО ВСТАВИТЬ?
Ps. далек от программирования 1С, решил потестиь бекап.
33. Светлана Синицына (Svetlya4ok13) 03.09.12 09:16
У нас КА, доработанная под алкоголь. Поправила запрос на выборку данных. Форма заполняется, но при попытке выгрузки файла ругается
Следующие отчеты сохранены с единицей измерения и/или точностью, не соответствующими требованиям формата выгрузки:
 - Объемы розничной продажи алкогольной и спиртсодержащей продукции за 1 квартал 2012 г. (Первичный) должен быть сохранен с единицей измерения "в рублях" с точностью "0"
Сохраните отчеты с нужной единицей измерения и перезапустите процесс формирования.
Продолжение невозможно! Формирование текстов выгрузки прервано.
...Показать Скрыть


Почему? Что поправить надо?
34. Bosma Иванов (Bosma) 03.09.12 12:02
(33) Svetlya4ok13
куда выгружаете? не понимаю откуда ошибка
35. Светлана Синицына (Svetlya4ok13) 03.09.12 14:26
Автор, извините ради Бога, ошиблась с веткой - не к вам вопрос.
36. Борис Чистов (pudmma) 04.09.12 15:53
Попробовал открыть в торговле 24h выдала кучу ошибок
1С 7,70,027 24h 7.70.345 что сделать?
37. Bosma Иванов (Bosma) 05.09.12 09:59
(36) pudmma,

допиливать!
структура обработки простая, сбор и обработка данных разделены
оставляйте движок формирования, а запросы к данным делайте свои или правьте имеющиеся

наша конфигурация поддерживается самостоятельно, с Торговлей24 уже мало чего общего осталось.
38. Иван Демидов (ivanov_alex) 05.09.12 14:30
Переменная не определена (гл_mdw)
объявление переменной нуно
И да, нужно добавить что конфигурация должна быть sql-ной
с дбф не работает
39. Стасилло Аверкин (21stas) 23.12.12 11:23
У нас пока типовая 24h (файловая). Тоже хотим алкогольную декларацию. За сколько возьмётесь сделать?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа