gifts2017

Обработка для регистра сведений "СоответствиеОбъектовДляОбмена"

Опубликовал Дмитрий Ткачев (Ткачев) в раздел Обмен - Перенос данных из 1C8 в 1C8

Просмотр и редактирование объектов для обмена в типовых конфигураций

Обработка для редактирования регистра сведений СоответствиеОбъектовДляОбмена с просмотром и редактированием объектов второй базы.

Скачать файлы

Наименование Файл Версия Размер
Соответствие объектов для обмена 73
.epf 22,90Kb
07.09.12
73
.epf 22,90Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Александр Журавлев (apostal86) 29.09.12 16:45
А обработкой можно "переуказывать" объект из второй информационной базы вместо того, который сейчас использован в связи?
2. Vlad (KillHunter) 29.09.12 18:05
3. Дмитрий Ткачев (Ткачев) 30.09.12 07:25
Менять можно как объект из первой базы, так и ссылку из второй.
4. Андрей Николаев (Andruykha) 09.10.12 14:36
+1 полезная обработка. Тока кое что поправил в процедуре подключения:

Процедура ПодключениеКБазе()

ЭлементыФормы.Таб.ТолькоПросмотр = Истина;
ЭлементыФормы.ОсновныеДействияФормы.Кнопки.ОчисткаБазы.Доступность = Ложь;
ЭлементыФормы.Таб.УстановитьДействие("ПриПолученииДанных", Неопределено);
Если Не ПустаяСтрока(КаталогБазы) И Не (ВариантОбмена И ПустаяСтрока(Сервер1С)) Тогда
Попытка
V82 = Новый COMОбъект("V" + Версия1С + ".COMConnector");
Если ВариантОбмена Тогда
КатБазы = "Srvr=""" + СокрЛП(Сервер1С) + """;Ref=""" + СокрЛП(КаталогБазы)+"";
Иначе
КатБазы = "File=""" + СокрЛП(КаталогБазы)+"";
КонецЕсли;
БазаСОМ = V82.Connect(КатБазы + """;Usr=""" + СокрЛП(Пользователь) + """;Pwd=""" + СокрЛП(Пароль) + """;");
ЭлементыФормы.Таб.УстановитьДействие("ПриПолученииДанных", Новый Действие("ТабПриПолученииДанных"));
ЭлементыФормы.Таб.ТолькоПросмотр = Ложь;
ЭлементыФормы.ОсновныеДействияФормы.Кнопки.ОчисткаБазы.Доступность = Истина;
ЭлементыФормы.ОсновныеДействияФормы.Кнопки.ПодключениеКБазе.Доступность = Ложь;
Исключение
Предупреждение("База данных не открыта!!!
|" + ОписаниеОшибки());
КоманднаяПанельРегистраНастройкиСоединения();
КонецПопытки;
Иначе
КоманднаяПанельРегистраНастройкиСоединения();
КонецЕсли;

КонецПроцедуры
5. Дмитрий Ткачев (Ткачев) 09.10.12 15:19
(4)А зачем кавычки нужны ?

p.s. Я их раньше ставил, а потом перестал.
6. Андрей Николаев (Andruykha) 09.10.12 15:31
(5) Ткачев, без кавычек ошибки выдает при подключении.
Еще такое пожелание, при добавлении записи нужно чтобы поле ИмяТипаПриемника определялось автоматически.
7. Андрей Николаев (Andruykha) 09.10.12 15:51
(5) Ткачев, Предлагаю сделать так:
При изменении колонки СобственнаяСсылка, вставить процедуру:
Процедура ТабСобственнаяСсылкаПриИзменении(Элемент)
ДанныеСтроки = ЭлементыФормы.Таб.ТекущиеДанные;
ДанныеСтроки.ИмяТипаПриемника=Строка(ТипЗнч(Элемент.Значение));
МетаТипа = Метаданные.НайтиПоТипу(ТипЗнч(Элемент.Значение));
Если Метаданные.Справочники.Содержит(МетаТипа) Тогда
ДанныеСтроки.ИмяТипаПриемника="СправочникСсылка."+Строка(ТипЗнч(Элемент.Значение));
ИначеЕсли Метаданные.Документы.Содержит(МетаТипа) Тогда
ДанныеСтроки.ИмяТипаПриемника="ДокументСсылка."+Строка(ТипЗнч(Элемент.Значение));
КонецЕсли;

КонецПроцедуры
8. Petr (sevipa) 13.01.13 23:30
А можно ли данный механизм использовать чтобы прикрутить Розницу 1.0 работающую обособлено для выгрузки данных в БП 2.0 ?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа