gifts2017

Консоль отчетов СКД+

Опубликовал Дмитрий Глух (IronDemon) в раздел Программирование - Инструментарий

Внешний отчет "Консоль отчетов" основан на системе компоновки данных и использует большинство ее возможностей (c) 1С.
Добавленные возможности:
Просмотр текста запроса.
Известно время выполнения.

В начале освоения системы компоновки данных непонятно, во что превращается запрос, написанный в ней. Особенно это касается параметров. Включив "Выводить текст запроса", мы увидим привычный запрос.
Возможность увидеть время выполнение запроса + вывод в табличный документ положительно влияет на качество кода :)

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
КонсольОтчетовКД.erf
.1187800947 54,02Kb
11.07.13
1844
.1187800947 54,02Kb 1844 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Геннадий Пиганов (Totoro) 23.08.07 08:48
Было бы лучше, если текст запроса выводился в отдельную закладку, которая бы появлалясь при включении этой возможности. А, то прокручивать окно сообщений не так уж и удобно :)
2. Геннадий Пиганов (Totoro) 23.08.07 15:23
Доделал твой отчет так, чтобы запросы отображались на отдельной закладке и для нескольких запросов можно выбрать нужный. Если интересно, могу выложить.
3. Геннадий Пиганов (Totoro) 23.08.07 16:31
Можно еще добавить табличку с значениями параметров, переданными в макет из коллекции МакетКомпоновкиДанных.ЗначенияПараметров
4. Дмитрий Глух (IronDemon) 23.08.07 18:16
Текст запросов выводится в отдельную закладку. Также выводятся параметры и отборы.
5. Геннадий Пиганов (Totoro) 24.08.07 11:35
Уже лучше :) Посмотри личное сообщение.
6. Molot (molot) 26.08.07 13:57
Спасибо. Буду юзить и тестить по возможности...

Особое спасибо и глубокий респект - за открытый код!
7. sstvit2 20.11.07 15:31
Зачёт. to (Toroto) Если улучшил - может выложить?
8. jarojar (jarOjar) 30.11.07 16:49
Замечательный отчет. А как задать собственный макет? Мне надо создать внешнюю печатную форму ТОРГ-29
9. Евгений (jk3) 18.09.09 15:12
больше 1000 скачиваний и меньше 20 плюсов :(
спасибо, + однозначно
yurii_host; DrAku1a; SmArtist; zoolog; FractalizeR; Anetkaaa; IgorXml; +7 Ответить 1
10. Igor2010 (IgorXml) 24.11.09 18:58
(9) Да, мало плюсов. Д.Б. больше.
11. Павел (d0dger) 29.07.10 17:51
Косметика:

Процедура СохранитьПозициюВРезультате()
	
	Область = ЭлементыФормы.РезультатТабДок.ТекущаяОбласть;
	Если Не Область = Неопределено Тогда
		ПозицияЛево = Область.Лево;
		ПозицияВерх = Область.Верх;
		Если ТипЗнч(Область) = Тип("ОбластьЯчеекТабличногоДокумента") Тогда
			ПозицияПраво = Область.Право;
			ПозицияНиз = Область.Низ;
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть

12. Илья Макаров (ilia_m) 28.09.11 19:42
Спасибо. Помогла приблудина
13. bar_s (bar_s) 01.12.11 15:22
Спасибо, полезная штука.
14. Al (al_zzz) 19.02.12 17:54
"Scr = Новый COMОбъект("MSScriptControl.ScriptC" - это отчего?
15. Al (al_zzz) 19.02.12 20:59
Точнее, весь текст ошибки вот: "{Форма.Форма(796)}: Ошибка при вызове конструктора (COMОбъект): Недопустимая строка с указанием класса
Scr = Новый COMОбъект("MSScriptControl.ScriptControl");
по причине:
Недопустимая строка с указанием класса
"
16. Дмитрий Глух (IronDemon) 20.02.12 11:54
(15) Попробуй Windows Script Host переустановить.
ОС случаем не Server 2008?
18. Al (al_zzz) 20.02.12 17:08
Обновить не получилось - при установке появилась надпись о том, что обновление не требуется... :-(
19. Александр Никитин (ManyakRus) 01.07.12 19:58
{Форма.Форма.Форма(355)}: Поле объекта не обнаружено (Право)
ПозицияПраво = Область.Право;

постоянно так ругается :(
а мне уже было понравилась обработка
20. Илья Парамонов (Crush) 05.12.12 11:37
(19) ManyakRus, нужно щелкнуть по полю результат и будет щастье!
Сам только что споткнулся:)
21. Ярослав Радкевич (WKBAPKA) 30.01.13 17:36
какая то хрень с выводом текста запроса... я текст запроса
по набору данных и так могу посмотреть, хотелось бы увидеть окончательный результат, уже после компоновки, а так выводит тексты запроса по каждому набору
22. Вадим Янчук (vadimlp77) 21.10.13 00:47
Полезная штука - помогло
23. Алекс zhu4 (Arxxximed) 23.10.13 21:02
(19) Сам столкнулся с этим только что. Но правда ответ еще в (11) встретил. Но как временное решение и (20) помогает. Просто у картинкитабличногоДокумента действительно нету поля Право и Низ
24. Алекс zhu4 (Arxxximed) 23.10.13 21:09
(14) al_zzz, Это что бы время в милисекундах выводить потом. Т.е за сколько отработал запрос
25. Влад Не важно (vladislav_kz) 09.12.13 20:53
А как тут параметры задавать? Чет не нашел)))
26. Владислав Раструсный (FractalizeR) 18.04.14 13:28
Отличная штука! Есть что-нибудь подобное для 8.3 УФ?
27. Александр Майнагашев (dedicated) 06.03.15 06:30
Спасибо! Все работает на УПП.
28. Павел Семенов (pavel06) 17.08.15 17:09
Не написано в какой версии эта консоль работает. Загружал в КА 8.2.19.130 без УФ, сказала, что этой версией внешний отчет не загружается.
29. Виктория Дорохина (vikad) 17.08.15 17:24
(28) pavel06, на странице публикации в свойствах (справа) написано, что платформа 8.1. Поэтому в режиме предприятие платформы 8.2 будет возникать предупреждение, что "Внешний отчет не может быть прочитан текущей версии программы". В этом случае файл отчета нужно открыть в режиме конфигуратора и согласиться с тем, что он будет сконвертирован с учетом структуры платформы 8.2. После этого Вы сможете им пользоваться в режиме Предприятия.
30. Анастасия Егорова (AEgorova) 19.08.15 10:28
Не могу загрузить настройки из XML файла. Выдает ошибку: "Ошибка преобразования данных XDTO:....". Настройки были сохранены в файл из внешнего отчета из основной схемы компоновки данных. В чем может быть проблема?
31. Виктория Дорохина (vikad) 19.08.15 10:44
(30) AEgorova, формат XML для схемы СКД меняется в зависимости от версии платформы, на которой он был создан. Если вы выгрузили схему из отчета, созданного на более новой версии платформы, а потом загружаете ее в одной из ранних версий - будет возникать такая ошибка.
32. Алексей Белоусов (AllexSoft) 05.02.16 18:28
может кто знает, есть что нибудь такое (с выводом текста запроса) под УФ ?
33. Николай Гаврилов (ShootNICK) 15.04.16 14:57
34. Арман Бегов (Dream_kz) 26.04.16 09:53
(32) AllexSoft, есть, ищи на диске ИТС КонсольСистемыКомпоновкиДанных.erf
35. Алексей Белоусов (AllexSoft) 27.04.16 10:16
(34) Dream_kz, на ИТСной нет текста запроса после компановки схемы
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа