gifts2017

Загрузка проводок из Excel (для 1С:Бухгалтерия 7.7 Азербайджан)

Опубликовал Best Soft MMC (PaRaDoX) в раздел Обработки - Обработка документов

Обработка, позволяющая загружать проводки из Excel в 1С: Бухгалтерия 7.7

По данным из файла Excel создается документ "Операция". Пример файла Excel в приложенном архиве.

Для 1С:Бухгалтерия 7.7 Азербайджан.

Скачать файлы

Наименование Файл Версия Размер
ЗагрузкаПроводокИзЭксел 310
.1195559463 294,61Kb
25.09.09
310
.1195559463 294,61Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Александр (karpekin) 17.11.07 13:11
Обработка понравилась. Все просто, без наворотов, легко понять что к чему.
2. Best Soft MMC (PaRaDoX) 17.11.07 13:13
Спасибо за отзыв) Стараемся...)
3. Khaim Gokh (gohaim) 19.11.07 06:02
Обработка хорошая, поможет многим начинающим
4. CODER_ (CODER_) 19.11.07 16:23
А какой пароль на обработку?
5. филипп (Филипп) 20.11.07 16:21
Еще бы пример этого файла в формате Excel, было бы совсем хорошо
6. Евгений (chev) 22.11.07 09:20
Спасибо. Обработка понравилась.
7. Best Soft MMC (PaRaDoX) 22.11.07 10:54
4. К сожалению обработка закодирована, и в принципе пароль вам и не поможет...
8. Best Soft MMC (PaRaDoX) 22.11.07 11:17
5. Архив обновлен, пример файла загрузки внутри.
9. Олег (LiOn) 01.12.07 20:55
Да очень удобно и полезно
10. Абдурасул (alsoft) 07.09.08 14:21
Рахмат !
Спасибо !
Thank you !
11. Евгений Ганшин (lhfrjy) 09.10.08 09:12
Все фигня что она запаролена, вот ее код:
//**********************************************************************
// Обработка, позволяющая загружать проводки из Excel.
// (с) 1С:Marco Computer Technologies 2007 г. Баку
// Версия - 1.1
// Разработчик - Эльдар Шихалиев
// E-mail - eldar@marco.az
//**********************************************************************
Перем zBFF2421348B4,zE05F212CB7CB,z2356621CEE3B,z9484F304E88C,zB06325B9B582,zFB78C932E218,z78079F7A6C9C;
Функция zB7C76F4806E1(z037B4C7EE440,zEF337099CBF5)
Справочник=СоздатьОбъект(z037B4C7EE440.ТипСубконто());
Если Справочник.НайтиПоНаименованию(zEF337099CBF5)=0 Тогда
Справочник.Новый();Справочник.Наименование=zEF337099CBF5;
Справочник.УстановитьНовыйКод();
Справочник.Записать();
КонецЕсли;
z55584BE91D05=Справочник.ТекущийЭлемент();
Возврат z55584BE91D05;
КонецФункции
Функция z5EA1DA209796(zF27C24EE71E0,z67D69D0C4868)
z9F4D9E855396=СоздатьОбъект("Справочник.Валюты");
Если z9F4D9E855396.НайтиПоНаименованию(zF27C24EE71E0)=0 Тогда
z9F4D9E855396.Новый();
z9F4D9E855396.Наименование=zF27C24EE71E0;
z9F4D9E855396.УстановитьНовыйКод();
z9F4D9E855396.Записать();
КонецЕсли;
Валюта=z9F4D9E855396.ТекущийЭлемент();
Если ПустоеЗначение(Валюта.Курс.Получить(z67D69D0C4868))=1 Тогда
Сообщить("Не установлен курс для валюты: "+Валюта+" на дату "+z67D69D0C4868,"i");
КонецЕсли;
Возврат Валюта;
КонецФункции
Процедура z4C3EB9A3BB1F()
НачальнаяСтрока=1;
z3797286793FE=1;
zFB78C932E218=0;
Попытка
zE05F212CB7CB=СоздатьОбъект("Excel.Application");
Исключение
z3797286793FE=0;
Предупреждение("MS Excel не загружен!");
КонецПопытки;
Если z3797286793FE=1 Тогда
Попытка
zE05F212CB7CB.Application.Workbooks.Open(НазваниеФайла);
Исключение
zE05F212CB7CB.Quit();
КонецПопытки;
zFB78C932E218=1;
КонецЕсли;
Если zFB78C932E218=1 Тогда
ЧислоКолонок=1;
Пока ПустаяСтрока(zE05F212CB7CB.ActiveSheet.Cells(1,ЧислоКолонок).Value)=0 Цикл
ЧислоКолонок=ЧислоКолонок+1;
КонецЦикла;
ЧислоКолонок=Макс(ЧислоКолонок-1,1);
ЧислоСтрок=1;
Пока ПустаяСтрока(zE05F212CB7CB.ActiveSheet.Cells(ЧислоСтрок,1).Value)=0 Цикл
ЧислоСтрок=ЧислоСтрок+1;
КонецЦикла;
ЧислоСтрок=Макс(ЧислоСтрок-1,1);
z78079F7A6C9C.УдалитьВсе();
Для zFEF8DF239C43=1 По ЧислоКолонок Цикл
zBFF2421348B4=zE05F212CB7CB.ActiveSheet.Cells(1,zFEF8DF239C43).Value;
Если ПустаяСтрока(zBFF2421348B4)>0 Тогда
zBFF2421348B4="Колонка №"+Строка(zFEF8DF239C43);
КонецЕсли;z78079F7A6C9C.ДобавитьЗначение(zFEF8DF239C43,СокрЛП(zBFF2421348B4));
КонецЦикла;
zE05F212CB7CB.ActiveWorkbook.Close();zE05F212CB7CB.Quit();
Иначе Предупреждение("Не удалось открыть файл "+НазваниеФайла);
КонецЕсли;
КонецПроцедуры
Процедура ПриВыбореЗакладки(zCE68D87779E5)
Если zCE68D87779E5=1 Тогда
Форма.ИспользоватьСлой("Основной",2);
ИначеЕсли zCE68D87779E5=2 Тогда
Форма.ИспользоватьСлой("Информация",2);
КонецЕсли;
КонецПроцедуры
Процедура Выгрузить()
z10F3AF511FAB=0;z003EBD9B860E=0;
Проводка=СоздатьОбъект("Операция");
zE05F212CB7CB=СоздатьОбъект("Excel.Application");
zE05F212CB7CB.Application.Workbooks.Open(НазваниеФайла);
zF8EBBE9D654F=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(1,"Значение"));
Сообщить("Время начала загрузки: "+ТекущееВремя());
Для z19F1AAFBB267=НачальнаяСтрока По ЧислоСтрок Цикл
z10F3AF511FAB=z10F3AF511FAB+1;
Если z19F1AAFBB267=НачальнаяСтрока Тогда
Проводка.Новая();
zF8EBBE9D654F=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(1,"Значение"));
z50A84E5F149E=Дата(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zF8EBBE9D654F).Value);
Проводка.ДатаОперации=z50A84E5F149E;
КонецЕсли;
Если(z19F1AAFBB267>НачальнаяСтрока)и(Дата(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267-1,zF8EBBE9D654F).Value)<>Дата(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zF8EBBE9D654F).Value))Тогда
Проводка.Документ.УстановитьНовыйНомер();
Проводка.Записать();
z003EBD9B860E=z003EBD9B860E+1;
Сообщить("Записана операция: "+Проводка,"i");
Проводка.Новая();
zF8EBBE9D654F=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(1,"Значение"));
z50A84E5F149E=Дата(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zF8EBBE9D654F).Value);
Проводка.ДатаОперации=z50A84E5F149E;
КонецЕсли;
Проводка.НоваяПроводка();
zD24F2A9EF2BC=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(2,"Значение"));
СчетДт=СчетПоКоду(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zD24F2A9EF2BC).Value);
Если Найти(СчетДт,",")<>0 Тогда
СчетДт=СтрЗаменить(СчетДт,",",".");
КонецЕсли;
Проводка.Дебет.Счет=СчетДт;z7C37E052078B=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(3,"Значение"));
СубконтоДт1=СокрЛП(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,z7C37E052078B).Value);
Если ПустоеЗначение(СубконтоДт1)=0 Тогда
z1E3EE63BBD15=СчетДт.ВидСубконто(1);
z460E57376730=ТипЗначенияСтр(Проводка.Дебет.Субконто(1));
Если z460E57376730="Справочник" Тогда
Проводка.Дебет.Субконто(z1E3EE63BBD15,zB7C76F4806E1(z1E3EE63BBD15,СубконтоДт1));
ИначеЕсли z460E57376730="Перечисление" Тогда
Проводка.Дебет.Субконто(z1E3EE63BBD15,Перечисление.ПолучитьАтрибут(z1E3EE63BBD15.Идентификатор()).ЗначениеПоИдентификатору(СубконтоДт1));
КонецЕсли;
КонецЕсли;
zC5E043867BCB=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(4,"Значение"));
СубконтоДт2=СокрЛП(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zC5E043867BCB).Value);
Если ПустоеЗначение(СубконтоДт2)=0 Тогда
z761A6B1921AC=СчетДт.ВидСубконто(2);
z32D8A28AA38C=ТипЗначенияСтр(Проводка.Дебет.Субконто(2));
Если z32D8A28AA38C="Справочник" Тогда
Проводка.Дебет.Субконто(z761A6B1921AC,zB7C76F4806E1(z761A6B1921AC,СубконтоДт2));
ИначеЕсли z32D8A28AA38C="Перечисление" Тогда
Проводка.Дебет.Субконто(z761A6B1921AC,Перечисление.ПолучитьАтрибут(z761A6B1921AC.Идентификатор()).ЗначениеПоИдентификатору(СубконтоДт2));
КонецЕсли;
КонецЕсли;
zCE1C0F2A5C37=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(5,"Значение"));
СубконтоДт3=СокрЛП(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zCE1C0F2A5C37).Value);
Если ПустоеЗначение(СубконтоДт3)=0 Тогда
z8CFE2F5FCC60=СчетДт.ВидСубконто(3);
zBD06EEB4830C=ТипЗначенияСтр(Проводка.Дебет.Субконто(3));
Если zBD06EEB4830C="Справочник" Тогда
Проводка.Дебет.Субконто(z8CFE2F5FCC60,zB7C76F4806E1(z8CFE2F5FCC60,СубконтоДт3));
ИначеЕсли zBD06EEB4830C="Перечисление" Тогда
Проводка.Дебет.Субконто(z8CFE2F5FCC60,Перечисление.ПолучитьАтрибут(z8CFE2F5FCC60.Идентификатор()).ЗначениеПоИдентификатору(СубконтоДт3));
КонецЕсли;
КонецЕсли;
zCE6950B19AA3=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(6,"Значение"));
СчетКт=СчетПоКоду(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zCE6950B19AA3).Value);
Если Найти(СчетКт,",")<>0 Тогда
СчетКт=СтрЗаменить(СчетКт,",",".");
КонецЕсли;
Проводка.Кредит.Счет=СчетКт;
zC07728EFE011=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(7,"Значение"));
СубконтоКт1=СокрЛП(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zC07728EFE011).Value);
Если ПустоеЗначение(СубконтоКт1)=0 Тогда
z216E2F3CB9F2=СчетКт.ВидСубконто(1);
z4CE7DEBA0C4F=ТипЗначенияСтр(Проводка.Кредит.Субконто(1));
Если z4CE7DEBA0C4F="Справочник" Тогда
Проводка.Кредит.Субконто(z216E2F3CB9F2,zB7C76F4806E1(z216E2F3CB9F2,СубконтоКт1));
ИначеЕсли z4CE7DEBA0C4F="Перечисление" Тогда
Проводка.Кредит.Субконто(z216E2F3CB9F2,Перечисление.ПолучитьАтрибут(z216E2F3CB9F2.Идентификатор()).ЗначениеПоИдентификатору(СубконтоКт1));
КонецЕсли;
КонецЕсли;
z5D293E246F50=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(8,"Значение"));
СубконтоКт2=СокрЛП(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,z5D293E246F50).Value);
Если ПустоеЗначение(СубконтоКт2)=0 Тогда
zC12E4D53E2FF=СчетКт.ВидСубконто(2);
zE3E2F3437008=ТипЗначенияСтр(Проводка.Кредит.Субконто(2));
Если zE3E2F3437008="Справочник" Тогда
Проводка.Кредит.Субконто(zC12E4D53E2FF,zB7C76F4806E1(zC12E4D53E2FF,СубконтоКт2));
ИначеЕсли zE3E2F3437008="Перечисление" Тогда
Проводка.Кредит.Субконто(zC12E4D53E2FF,Перечисление.ПолучитьАтрибут(zC12E4D53E2FF.Идентификатор()).ЗначениеПоИдентификатору(СубконтоКт2));
КонецЕсли;
КонецЕсли;
zAE20DE9B1C29=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(9,"Значение"));
СубконтоКт3=СокрЛП(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zAE20DE9B1C29).Value);
Если ПустоеЗначение(СубконтоКт3)=0 Тогда
zEA92BB4E675B=СчетКт.ВидСубконто(3);
z325CF517D953=ТипЗначенияСтр(Проводка.Кредит.Субконто(3));
Если z325CF517D953="Справочник" Тогда
Проводка.Кредит.Субконто(zEA92BB4E675B,zB7C76F4806E1(zEA92BB4E675B,СубконтоКт3));
ИначеЕсли z325CF517D953="Перечисление" Тогда
Проводка.Кредит.Субконто(zEA92BB4E675B,Перечисление.ПолучитьАтрибут(zEA92BB4E675B.Идентификатор()).ЗначениеПоИдентификатору(СубконтоКт3));
КонецЕсли;
КонецЕсли;
zC1F9C2A3C45E=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(10,"Значение"));
Если ПустоеЗначение(zC1F9C2A3C45E)=0 Тогда
zF27C24EE71E0=СокрЛП(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zC1F9C2A3C45E).Value);
Если ПустоеЗначение(zF27C24EE71E0)=0 Тогда
Проводка.Валюта=z5EA1DA209796(zF27C24EE71E0,z50A84E5F149E);
КонецЕсли;
КонецЕсли;
zDDDF238BDF92=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(11,"Значение"));
Если ПустоеЗначение(zDDDF238BDF92)=0 Тогда
z9F109CD36740=Число(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zDDDF238BDF92).Value);
Если ПустоеЗначение(z9F109CD36740)=0 Тогда
Проводка.ВалСумма=z9F109CD36740;
КонецЕсли;
КонецЕсли;
z2795CF21C847=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(12,"Значение"));
Проводка.Количество=Число(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,z2795CF21C847).Value);
Если ПустоеЗначение(z9F109CD36740)=1 Тогда
z279D6B525A8B=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(13,"Значение"));
Проводка.Сумма=Число(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,z279D6B525A8B).Value);
Иначе
Проводка.Сумма=z9F109CD36740*Проводка.Валюта.Курс.Получить(z50A84E5F149E);
КонецЕсли;
z167BF6C487E0=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(14,"Значение"));
Проводка.СодержаниеПроводки=СокрЛП(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,z167BF6C487E0).Value);
z43CAAF31639A=z78079F7A6C9C.Получить(ИмпортируемыеПоля.ПолучитьЗначение(15,"Значение"));
Если ПустоеЗначение(z43CAAF31639A)=0 Тогда
Проводка.НомерЖурнала=СокрЛП(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,z43CAAF31639A).Value);
КонецЕсли;
Состояние("Загружаемая проводка: "+Проводка.ДатаОперации+" - "+Проводка.Дебет.Счет+" - "+Проводка.Дебет.Субконто(1)+" - "+Проводка.Дебет.Субконто(2)+" - "+Проводка.Дебет.Субконто(3)+" - "+Проводка.Кредит.Счет+" - "+Проводка.Кредит.Субконто(1)+" - "+Проводка.Кредит.Субконто(2)+" - "+Проводка.Кредит.Субконто(3)+" - "+Проводка.Валюта+" - "+Проводка.ВалСумма+" - "+Проводка.Количество+" - "+Проводка.Сумма+" - "+Проводка.Содержание+" - "+Проводка.НомерЖурнала);
КонецЦикла;
Проводка.Документ.УстановитьНовыйНомер();Проводка.Записать();
Сообщить("Время окончания загрузки: "+ТекущееВремя());
Сообщить("Количество загруженных проводок: "+z10F3AF511FAB);
Сообщить("Количество загруженных операций: "+z003EBD9B860E);zE05F212CB7CB.ActiveWorkbook.Close();zE05F212CB7CB.Quit();
КонецПроцедуры
Процедура УстановитьЗначениеИмпортируемогоПоля()
Если ИмпортируемыеПоля.ТекущаяКолонка()="Значение" Тогда
Попытка
z78079F7A6C9C.ВыбратьЗначение(z2356621CEE3B,"",,,2);z78079F7A6C9C.ПолучитьЗначение(z2356621CEE3B,z9484F304E88C);
ИмпортируемыеПоля.УстановитьЗначение(ИмпортируемыеПоля.ТекущаяСтрока(),"Значение",z9484F304E88C);
Исключение
КонецПопытки;
КонецЕсли;
КонецПроцедуры
Процедура ПриВыбореФайла()
Перем z48B6B65BE917,zF9A5E9C98E1D,zA70B9FABC2CE;
zA70B9FABC2CE=НазваниеФайла;
zF9A5E9C98E1D="XLS-таблица(*.xls)|*.xls";
z7B59A5E23FAC="";
Если ФС.ВыбратьФайл(0,z7B59A5E23FAC,z48B6B65BE917,"Выберите импортируемый файл",zF9A5E9C98E1D,,)=1 Тогда
НазваниеФайла=z48B6B65BE917+z7B59A5E23FAC;
Иначе
НазваниеФайла=zA70B9FABC2CE;
КонецЕсли;
z4C3EB9A3BB1F();
КонецПроцедуры
Процедура ПриНачалеВыбораЗначения(z55584BE91D05,zDA85CED3119D)
Если z55584BE91D05="НазваниеФайла" Тогда
zDA85CED3119D=0;
ПриВыбореФайла();
КонецЕсли;
КонецПроцедуры
Процедура ПриИзменениеРазмеров()
zE05F212CB7CB=СоздатьОбъект("Excel.Application");zE05F212CB7CB.Application.Workbooks.Open(НазваниеФайла);
z78079F7A6C9C.УдалитьВсе();
Для zFEF8DF239C43=1 По ЧислоКолонок Цикл
zBFF2421348B4=zE05F212CB7CB.ActiveSheet.Cells(1,zFEF8DF239C43).Value;
Если ПустаяСтрока(zBFF2421348B4)>0 Тогда
zBFF2421348B4="Колонка №"+Строка(zFEF8DF239C43);
КонецЕсли;
z78079F7A6C9C.ДобавитьЗначение(zFEF8DF239C43,СокрЛП(zBFF2421348B4));
КонецЦикла;
zE05F212CB7CB.ActiveWorkbook.Close();
zE05F212CB7CB.Quit();
КонецПроцедуры
Процедура ОчиститьТЗ()
Если Вопрос("Вы действительно хотите очистить схему импорта?","Да+Нет")="Да" Тогда
ИмпортируемыеПоля.УдалитьСтроки();
ЧислоСтрок=0;ЧислоКолонок=0;
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Дата";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СчетДт";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоДт1";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоДт2";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоДт3";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СчетКт";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоКт1";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоКт2";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоКт3";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Валюта";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Валютная сумма";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Количество";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Сумма";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Содержание";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Номер журнала";
КонецЕсли;
КонецПроцедуры
Процедура ПриОткрытии()
Форма.ИспользоватьЗакладки(1);
Форма.Закладки.ДобавитьЗначение("Основная");
Форма.Закладки.ДобавитьЗначение("Информация");
Форма.ИспользоватьСлой("Основной",2);
Если(ПустоеЗначение(НазваниеФайла)=0)и(ФС.СуществуетФайл(НазваниеФайла)=1)Тогда
z4C3EB9A3BB1F();
КонецЕсли;
КонецПроцедуры
ИмпортируемыеПоля.НоваяКолонка("ИмпортируемоеПоле",,,,"Импортируемое поле");
ИмпортируемыеПоля.НоваяКолонка("Значение",,,,"Значение");
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Дата";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СчетДт";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоДт1";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоДт2";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоДт3";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СчетКт";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоКт1";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоКт2";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="СубконтоКт3";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Валюта";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Валютная сумма";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Количество";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Сумма";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Содержание";
ИмпортируемыеПоля.НоваяСтрока();
ИмпортируемыеПоля.ИмпортируемоеПоле="Номер журнала";
z78079F7A6C9C=СоздатьОбъект("СписокЗначений");

Может конечно не совсем читаемо, но тем не менее.
12. Евгений Ганшин (lhfrjy) 17.10.08 09:44
Хотел поставить минус, но оказалось, что для этого нужен рейтинг не менее 5. Интересно кто те 16 человек которые поставили плюс?
Обработка соответствует начальному уровню знания 1С, даже я когда начинал работать в 1С и то при переносе данных
из базы DBF в 1С не написал-бы такой чуши, или 16 человек считают, что загрузить 500 строк Ексель в виде 500 бухгалтерских
операций это нормально?
13. Best Soft MMC (PaRaDoX) 17.10.08 13:35
Уважаемый коллега, вместо того чтобы называть мою разработку чушью, даже если она, по вашему мнению, не корректна, стоило бы написать свою, и в ней учесть все те недостатки, которые не учел я, заработать тот самый недостающий рейтинг “5” (в вашем случае нужен 6) и смело ставить минусы.…Насчет создания операций, хочу заметить, что группировка проводок в операцию происходит по дате, и соответственно если у вас все проводки в Экселе с разными датами, то и операций будет соответствующие количество. Но если у вас есть метод присваивания разных дат проводкам одной операции, то поделитесь со мною, и я с радостью сделаю соответствующий исправления в своей разработке.
14. Веснушка (ilsiya_rebenok@mail.ru) 20.12.08 10:36
а если в Exele несколько листов, она не сможет загрузить данные со всех листов?
15. Igоr Sаulеviсh (gutentag) 10.01.09 13:23
У ВАС варианта для загрузки в документ "Бухгалтерская справка" нет обработки?
Т.к. это более продуктивный способ работу(во всяком случае в России)
16. Анна (Lotika) 05.02.09 16:23
Не видит файлов, сохраненных в Экселе 2007...
17. ELnur Osmanov (Elnur) 24.03.09 14:30
Вывело вот такую ошибку

));z50A84E5F149E=Дата(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267,zF8EBBE9D654F).Value);Проводка.ДатаОперации
{C:\DOCUMENTS AND SETTINGS\ANAR-M\DESKTOP\ZAGRUZKAPROVODOKIZEKSEL\ЗАГРУЗКАПРОВОДОКИЗЭКСЕЛ.ERT(36)}: :
forrain@rambler.ru; +1 Ответить
18. romanova (m_kanak@mail.ru) 05.10.09 15:09
19. Zaytuna Hasunson (zayka_64) 02.12.09 11:37
У Вас процедура работает только если Субконто1,Субконто2,Субконто3 независимые справочники, а если Субконто2 является зависимым справочником, например Субконто1=Контрагент, а Субконто2=Договор. Т.е. для справочника Договора справочником-владельцем является справочник Контрагенты. Как быть в этом случае? Очень надо.(1)
20. Иван Иванов (vverix01) 05.08.10 15:55
Тоже возникает ошибка

Время начала загрузки: 16:08:37
=z50A84E5F149E;КонецЕсли;Если(z19F1AAFBB267>НачальнаяСтрока)и(Дата(zE05F212CB7CB.ActiveSheet.Cells(z19F1AAFBB267

Даже при выборе файла примера!!!
forrain@rambler.ru; +1 Ответить
21. Natalia Z (droplet) 02.12.11 09:26
После собственной творческой переработки все становится вполне рабочим и полезным
22. Vitya Bog (LoboVik) 14.05.12 13:36
Спасибо. Обработка очень помогла.
23. Дядя Федор (ufedor) 16.04.13 16:22
Автору:
Спасибо, конечно, но что если мне нужно поменять правила поиска например искать номенклатуру по коду а не по наименованию?
Придется искать способ снять пароль. Снял пароль, внес необходимые изменения. В том числе возможность не создавать не найденные элементы.
Обработка полезная, но не вижу смысла скрывать код.
forrain@rambler.ru; +1 Ответить
24. Александр Забалуев (zabaluev) 07.04.14 17:16
Что за детский сад с паролем?