gifts2017

Статистическая форма Т-57 2007 года (бета)

Опубликовал Алексей Лапицкий (Lapitskiy) в раздел Печать - Регламентированная отчетность

T-57 2007 года.
Сдача 1 раз в 2 года.
Предлагаю потестировать.
Основа формы и часть кода взята из чей-то чужой обработки с проклаба.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Форма 57Т
.1195555271 41,94Kb
25.09.09
164
.1195555271 41,94Kb 164 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр (Джуджик) 22.11.07 19:26
отчет хороший, а главное своевременно, Так лень его было писать.
хотя первая ошибка если кого то угораздило уйти в отпуск по уходу за ребенком.А точнее окончание ухода до 1,5 и начало до 3 лет.В качестве дока прием на работу выдается приказ на отпуск В рез. в стр 1390 и 1710 Поле агрегатного объекта не обнаружено (ВидРаботы)
2. Алексей Лапицкий (Lapitskiy) 23.11.07 03:40
Да, вот исправление.
savantonio; +1 Ответить
3. Salimbek (Salimbek) 25.11.07 22:35
"отчет хороший, а главное своевременно, Так лень его было писать." Полностью присоединяюсь

Маленькое замечание: Когда собираются данные по полностью отработавшим - то обязательно первым расчетом должен быть "ОплатаПоОкладу" и т.п., иначе Сотрудник не будет найден в ТЗ и данный расчет не будет включен в начисления. Для себя переделал в виде сбора информации за 2 прохода. В первый раз ищем только окладников, второй раз остальные расчеты по этим сотрудникам. Но есть и более эффективные алгоритмы, просто сделал то, что было быстрее всего.
С Уважением.
4. Алексей Лапицкий (Lapitskiy) 26.11.07 15:04
Новая версия. Исправлена ошибка (3), и еще когда стаж был пустой, выводилось неправильно.
5. Vladimir (Boroda) 27.11.07 14:12
Собственно, я переделал для себя ещё ту, что на Проклабе была пару лет назад, т.к. под "современность" не подходила. А в этой такие замечания вылезли (может, только у меня):
1. Сразу же, во всех проверяемых базах, в Табл. 1 (Справочно), где показывается общее число среднесписочной численности для Табл. 2 заначение выводится с "минусом", хотя в самом разделе 1 считает прекрасно.
2. В Разделе 2 в тарифный заработок попадают лишь оклады, хотя в тар. заработок может включаться ещё куча всяких доплат: за классность, вредность и т.п., на каждом предприятии свои. Было бы неплохо выложить возможность их выбора в какую-нибудь ТЗ на закладочке, скажем, 2.
6. Алексей Лапицкий (Lapitskiy) 27.11.07 15:43
Да, есть такое, поправлю...
7. yurii123 (yurii123) 30.11.07 10:05
ИначеЕсли ПриказОПриеме.ВидРаботы<>1 Тогда
{C:\DOCUMENTS AND SETTINGS\РАБОЧИЙ СТОЛ\ФОРМА-57Т\ФОРМА57-Т2007.ERT(1390)}: Поле агрегатного объекта не обнаружено (ВидРаботы)
Заморочка с дикретницами, была в дикрете до июля. При начислении сумм з/п по сотруднику выдает это.
8. inspam (inspam) 30.11.07 10:43
To Lapitskiy: Огромное спасибо!
9. Татьяна (Локт) 03.12.07 12:18
10. Vitaly (vitalukalo1) 10.12.07 11:27
ИначеЕсли ПриказОПриеме.ВидРаботы<>1 Тогда
{C:\DOCUMENTS AND SETTINGS\РАБОЧИЙ СТОЛ\ФОРМА-57Т\ФОРМА57-Т2007.ERT(1390)}: Поле агрегатного объекта не обнаружено (ВидРаботы)
11. Алексей . (mamanelli) 13.12.07 09:24
2 vitalukalo1:

Попытка

Если ПриказОПриеме.ВидРаботы <> 1 Тогда
КонецЕсли;

Исключение
Если Вопрос("Это отпуск по уходу за ребьенком?", "Да+Нет") = "Да" Тогда
Сообщить("Вопросов больше не имею ;)", "i");
Иначе
Сообщить("Свободу Юрию Деточкину!", "!!");
КонецЕсли;

КонецПопытки
12. Наталья Болотнова (bol) 18.11.11 12:59
13. Фаниль Хасанов (Fanil) 12.03.12 15:24
У меня такая же ошибка Попытка

Если ПриказОПриеме.ВидРаботы <> 1 Тогда
КонецЕсли;

Исключение
Если Вопрос("Это отпуск по уходу за ребьенком?", "Да+Нет") = "Да" Тогда
Сообщить("Вопросов больше не имею ", "i");
Иначе
Сообщить("Свободу Юрию Деточкину!", "!!");
КонецЕсли;

КонецПопытки
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа