gifts2017

Добавление фотографий из 1с в ActiveDirectory

Опубликовал Анастасия Фамилия (Nas'ka) в раздел Программирование - Практика программирования

Расскажу Вам о том как я добавляла фотографию из 1с (справочника физические лица) в карточку пользователя ActiveDirectory

Допустим что перед нами стоит задача выгрузить фотографии сотрудников из 1с в ActiveDirectory.

С чего начнем. Начнем с создания подключения к AD.

     

    // Подключимся к AD
   
Попытка
       
oConnect = ПолучитьCOMОбъект("","ADODB.Connection");
       
oConnect.Provider = "ADSDSOObject";
       
oConnect.Properties("User ID").Value = "ВашАдминскийЮзер";
       
oConnect.Properties("Password").Value = "ЕгоПароль";
       
oConnect.Properties("Encrypt Password").Value = True;
       
oConnect.Open("Active Directory Provider");
    Исключение
        Возврат;
    КонецПопытки;

Затем необходимо прочитать фото в 1с. Для этого я пользовалась своим РегистромСведений ИзменениеФотоФизЛица, который заполняется каждый раз при изменении фото у физ лица. Вы можете напрямую смотреть в карточке физ лица

 

// Список записанных фото
   
СписокФотоФизЛиц = Новый СписокЗначений;
   
// Прочитаем регистр изменений фотографий физ. лиц
   
ИзменениеФотоФизЛица = РегистрыСведений.ИзменениеФотоФизЛица.СоздатьНаборЗаписей();
   
ИзменениеФотоФизЛица.Прочитать();
    Для каждого
ФотоФизЛица Из ИзменениеФотоФизЛица Цикл
       
Записали = Ложь;
       
// Получить имя временного файла
       
ИмяФайла = ПолучитьИмяВременногоФайла();
       
мТекущееИзображение = ФотоФизЛица.Фото.Хранилище.Получить();
       
// Страховой номер ПФР является поисковым реквизитом
       
НомерПФР = ФотоФизЛица.Физлицо.СтраховойНомерПФР;
        Если Не
ПустаяСтрока(НомерПФР) И мТекущееИзображение <> Неопределено Тогда
           
мТекущееИзображение.Записать(ИмяФайла);

 

Как вы заметили Страховой номер у меня это уникальный идентификатор, т.е. в AD в EmployeeID должно быть равно номеру ПФР.

Для помещения картинки в AD она должна соответствовать размеру (не более 10 К и ширина, высота - 96). Для изменения размера картинки воспользуемся стандартной библиотекой Windows Image Acquisition Automation Library (в Windows 7 входит в состав дистрибутива). Библиотеку wiaaut.dll придется зарегистрировать командой regsvr32.

 

     Попытка
        
Фото       = Новый COMОбъект("WIA.ImageFile");
        
Процессор  = Новый COMОбъект("WIA.ImageProcess");
        
Фото.LoadFile(ИмяФайла);
         Если
Окр(Фото.FileData.Count / 1024, 2) > 10 Тогда  //Сравниваем размер файла
            
Процессор.Filters.Add(Процессор.FilterInfos("Scale").FilterID);
            
Процессор1 = Процессор.Filters(1);
             Для
К = 1 По Процессор1.Properties.Count Цикл
                 Если
Процессор1.Properties(К).Name = "MaximumWidth" Тогда
                    
Процессор1.Properties(К).Value = 96; //Задаем ширину
                
КонецЕсли;
                 Если
Процессор1.Properties(К).Name = "MaximumHeight" Тогда
                    
Процессор1.Properties(К).Value = 96; //Задаем высоту
                
КонецЕсли;
             КонецЦикла;
            
Фото = Процессор.Apply(Фото);
         КонецЕсли;
        
ИмяФайла = Лев(ИмяФайла, СтрДлина(ИмяФайла) - 4) + ".jpg";
        
Фото.SaveFile(ИмяФайла);
        
Фото = Новый COMОбъект("ADODB.Stream");
        
Фото.Type = 1;
        
Фото.Open();
        
Фото.LoadFromFile(ИмяФайла);
     Исключение
        
Сообщить("Возникла проблема " + ОписаниеОшибки());
     КонецПопытки;

 

Ну а теперь находим пользователя в AD и записываем ему фото:

       Query = "SELECT Name, sAMAccountName, ADsPath FROM 'LDAP://Домен/DC=ВашСервер,DC=ru' WHERE objectCategory='User' And employeeID='"+НомерПФР+"'";
      
Records = oConnect.Execute(query);
       Если НЕ
Records.EOF Тогда
          
ADsPath = Records.Fields("ADsPath").Value;
          
CN = ПолучитьCOMОбъект(Records.Fields("ADsPath").Value).Name;
          
ADsPath = СтрЗаменить(ADsPath, CN+",", "");
          
PreObj = ПолучитьCOMОбъект("LDAP:");
          
objContainer = PreObj.OpenDSObject(ADsPath, "ВашАдминскийЮзер", "ЕгоПароль", 1);
          
UpdateObject = objContainer.GetObject("User", CN);
          
UpdateObject.Put("thumbnailPhoto", Фото.Read());
          
UpdateObject.SetInfo();
       КонецЕсли;
      
Записали = Истина;
   Исключение
   КонецПопытки;

Закрываем подключение. Прибираемся. Уходим. Вот и всё!!!

 

        // Удалим фото из регистра
       
СписокФотоФизЛиц.Добавить(ФотоФизЛица);
       
// Удалим временный файл
       
УдалитьФайлы(ИмяФайла);
    КонецЕсли;
КонецЦикла;
// Закроем AD
oConnect.Close();
// Запишим изменения в регистр изменений фотографий физ. лиц
Для каждого ФотоФизЛица Из СписокФотоФизЛиц Цикл
   
ИзменениеФотоФизЛица.Удалить(ФотоФизЛица.Значение);
КонецЦикла;
ИзменениеФотоФизЛица.Записать(Истина);

 

Успехов Wink. В прикрепленных файлах есть обработка (не забудьте изменить строки подключения)

На скриншотах Вы можете увидеть результат работы обработки - на закладке Редактор аттрибутов в атрибуте thumbnailPhoto появилась строка с двоичными данными. В дальнейшем эти фотографии могут быть импортированы в Outlook.

Скачать файлы

Наименование Файл Версия Размер
Пример обработки по загрузки фото в AD 30
.epf 7,45Kb
28.09.12
30
.epf 7,45Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Олег Филиппов (comol) 02.10.12 09:05
Если есть установленный sharepoint то это всё делается много проще...
2. Анастасия Фамилия (Nas'ka) 02.10.12 09:28
(1) comol, Поделитесь с нами опытом
3. dimaster dimaster (dimaster) 25.10.12 08:18
есть еще такая удобная штука:

Скачать библиотеку можно тут: www.dewdney.co.uk/adext/adext.zip
оф кос, это не пакетная загрузка, но удобней смотреть, чем
4. Анастасия Фамилия (Nas'ka) 25.10.12 08:28
(3) Есть еще и такая "CodeTwo Active Directory Photos". Я ею пользовалась. Удобная софтинка. Не принципиально.
5. nanik nanik (nanik) 11.09.15 05:14
Подскажите, можно ли получить фото из AD средствами 1с?
6. Анастасия Фамилия (Nas'ka) 11.09.15 09:06
(5) Конечно можно, например следующий код открывает фото на просмотр:
Query = "SEL ECT Name, sAMAccountName, ADsPath, thumbnailPhoto  FR OM 'LDAP://ИмяДомена/DC=ИмяДомена,DC=ru' WHERE objectCategory='User' And employeeID='"+НомерПФР+"'";  //или какой то другой уникальный признак
	Records = oConnect.Execute(query); 
	Пока НЕ Records.EOF Цикл 
		Если Records.Fields("thumbnailPhoto").Value = Null Тогда //Или вместо thumbnailPhoto ваше поле с фото
			Предупреждение("Пусто");
		Иначе
			ИмяФайла 	= ПолучитьИмяВременногоФайла("bmp");
			
			Поток 		= Новый COMОбъект("ADODB.Stream");
			Поток.Type 	= 1;
			Поток.Mode 	= 3;
			Поток.Open();
			Поток.Write(Records.Fields("thumbnailPhoto").Value);
			Поток.SaveToFile(ИмяФайла);
			Поток.Close();
			
			ЗапуститьПриложение("explorer " + ИмяФайла);
		КонецЕсли;
		Records.MoveNext();
	КонецЦикла;
...Показать Скрыть
7. nanik nanik (nanik) 14.09.15 02:15
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа