gifts2017

Ошибка формата потока

Опубликовал Иван Захаров (IZaharov) в раздел Администрирование - Тестирование и исправление

Указанное сообщение было обнаружено при обновлении.

При обновлении конфигурации "Бухгалтерия гос. учреждения" Появилось сообщение "Ошибка формата потока" и два варианта, не самых приятных, "Завершить" и "Перезапустить".

Попытки тестирования БД, как и chdbfl не дали никакого результата.

Проверка конфигурации, с галочкой "Поиск некорректных ссылок" привела к такому же сообщению (Ошибка формата...).

Вывод - БД ни при чем. Проблема в конфигурации.

При сравнении с заведомо-рабочей конфигурацией, той же версии, найдены различия в типах числовых реквизитов, хотя и там и там стоит тип Число(15,2).

Из всей кучи советов, найденых "на просторах" подошел 1: перенести данные в другую БД.

Как это сделать:

1. На основе рабочей конфигурации создаем новую базу. (Хоть с шаблона, хоть создать новую - загрузить конфигурацию).

2. Запускаем в режиме предприятие. Наверняка пойдет обновление, до требуемой версии.

3.Запускаем обработку MD82Exp (на просторах свободно). У кого 8.1 тем MD81Exp. Там есть настройки, позволяющие не выгружать регистры, я выгрузил все, кроме регистров расчета. У меня их нет. Сохраняем файл описания конфигурации.

4. Повторяем последнее, для "битой" конфигурации.

5. С помощью конфигурации "Конвертация данных" на основе этих двух файлов описания, создаем правила переноса.

6. Возможно, Ваши бухи добавляли счета или субконто к ним. Если их не будет добавлено в новой базе, то перенос вылетит на ошибку, да и бухам потеря данных не понравится. Чтобы найти эти добавленные использунем простейшую обработку:

Процедура КнопкаВыполнитьНажатие(Кнопка)

  План=ПланыСчетов.ЕПСБУ.Выбрать();
  Пока План.Следующий() Цикл

     Если План.ЭлементГруппа Тогда              //Внимание! Это реквизит счета в бюджете! Если у вас другая конфигурация проверьте 
        Продолжить;                                          //признак группы иначе.
     КонецЕсли;


    Для каждого ВС Из План.ВидыСубконто Цикл
       Если ВС.Предопределенное ИЛИ  Тогда
          Продолжить;
      КонецЕсли;
      Сообщить("Счет "+План.Код+" Вид субконто "+ВС.ВидСубконто.Наименование);
    КонецЦикла;
  КонецЦикла;
КонецПроцедуры

Кто хочет может выбрать запросом, не думаю, что будет быстрее. Просматриваем весь план счетов.

Получаем 2 списка непредопределенных счетов и субконто. Сравниваем, добавляем, каких нет в новой базе.

7. Запускаем "битую" базу в режиме предприятие и переносим данные Универсальным обменом... 

У меня оборотки получились как близнецы. Бухи счастливы.

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Сергей Дашков (serega_sun) 28.11.12 04:06
А не пробовали полностью загрузить заведомо рабочую конфигурацию в базу с ошибкой?
2. Зеленцов Константин (Nordgreen) 08.02.13 13:29
(1) serega_sun, Была такая же ситуация, увы, не помогло. Пришлось так же переносить в чистую базу конвертацией данных.
3. Денис Кожевников (kdv) 05.09.13 09:54
В аналогичной ситуации помогло удаление из списка баз битой базы и создание новой строки в списке баз
4. Iren (sknarid) 09.07.14 15:28
Подтверждаю. Помогло простое удаление из списка ИБ, и занесение базы в список заново.
5. Сергей (Star_SU) 10.10.15 08:05
Столкнулся с "Ошибка формата потока" при обновлении конфигурации.
Решил найти обновление без ошибок, оказалось что все конфигурации выдают эту ошибку при ее проверке, но на разных процентах - то на каком либо документе, то на справочнике.
Например ЗУП:
2.5.46.2 - Неразрешимые ссылки на картинки
2.5.48.2 - ВозвратНаРаботуВОрганизацию
2.5.55.3 - Физлица

Что это за странность такая?

6. Сергей (Star_SU) 10.10.15 08:06
Весь интернет перелазил - ничего подобного не нашел
7. Андрей Григорьев (Borisych) 10.10.15 10:55
(6) Star_SU, платформа актуальна для используемой версии конфигурации? дальше как обычно - кеш, перенос базы на другой комп, ТиИ и др.
8. Cooler (Cooler) 10.10.15 11:35
+(7) Если база файловая, то еще chdbfl.exe в качестве "и др.". И лучше пораньше, перед переносом базы.