gifts2017

Лицевой счет (Форма Т-54) дополненный

Опубликовал Алексей Коробов (WiseSnake) в раздел Печать - Универсальные печатные формы

Дополненный лицевой счет формы Т-54

Удобная для бухгалтеров (расчетчиков) форма

Для щедрых людей которым помогла обработка:
Яндекс деньги № 41001241519720 , не откажусь :)

Скачать файлы

Наименование Файл Версия Размер
- 1114
.1220932737 108,00Kb
25.09.09
1114
.1220932737 108,00Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. elena (buchals) 09.09.08 11:37
Желательно, что-бы данный об отпсуках брал не из начисления, а из приказа об отпуске
2. Алексей Коробов (WiseSnake) 09.09.08 11:46
(1) Они должны совпадать, но из начисления он важнее потому что делает движения по отпуску, а кадровый документ является всего лишь основанием.
3. elena (buchals) 15.09.08 16:18
Но при формировании данные включаются дважды: из приказа и из начисления отпуска
4. Андрей (ankr) 08.03.09 13:40
Скачал файл, а он не открывается :(
1С говорит: Неправильный формат файла...???
5. Алексей Коробов (WiseSnake) 09.03.09 19:08
6. Николай Васильев (GeenS) 18.03.09 12:30
все равно ругается на неправильный формат!
7. Николай Васильев (GeenS) 18.03.09 12:32
повторно качнул - не ругаецца...
8. Алексей Коробов (WiseSnake) 18.03.09 20:18
Если будут у кого проблемы, пишите в личку, вышлю на мыло
9. maxim48 (maxim48) 28.07.09 15:15
Ошибка: Неправильный формат файла
10. Алексей Коробов (WiseSnake) 28.07.09 16:06
(9) Читаем посты 5-7 вчитываемся в п.8
11. Igor Kox (IgorKox) 28.09.09 14:51
А есть такой для бухгалтерии 80?
12. Александр Волков (Uragan) 09.02.10 02:24
Спасибо. Классно. Если не секрет можешь написать на a_l_e_k_s@mail.ru, как ты сделал, чтобы больничный по уходу за ребенком выводился, я мучался инифига
13. Алексей Коробов (WiseSnake) 10.02.10 22:36
(11) Нет, нету
(12) Писал это много-много лет назад... конечно уже не помню... но не вижу ничего сложного в вашей проблемме
14. Armando Armando (Armando) 07.07.10 12:07
Все хорошо, но почему нельзя было сделать явное указание года?
15. Sergey Truhin (struhin) 28.07.11 12:02
17. Юрий Петрович (YuPiter) 28.11.11 04:29
Большое спасибо за обработку! Уж очень проверяющие хотят видеть эти лицевые счета, а бухгалтерша и не знала, что в ЗиК`е только есть Т-54а,а Т-54 нет. Подцепил - ее радости нет предела!!!
18. Елена (m-xolding) 28.03.12 14:19
Спасибо автору! Иногда сама дорабатываю печатную форму. Удачи Вам и побольше программ для нас-бухгалтеров!!!
19. Алексей (АлексейН) 28.02.13 14:10
Автору респект и признательность,
облегчает работу бухгалтеров.
А то бухгалтер в "тихом шоке" надо распечать за последние 3 года на полсотни человек.
Спасибо
20. Виктор Левченко (lvictor58) 30.12.14 13:01
немного подправил выбор периода:
СписокПериодов = СоздатьОбъект("СписокЗначений");
//	СписокПериодов.ДобавитьЗначение(1,	"за текущий год");
//	СписокПериодов.ДобавитьЗначение(2,	"за прошлый год");
//
//	ВыбранныйПериод = "";
//	Если СписокПериодов.ВыбратьЗначение(ВыбранныйПериод, , , , 1) = 0 тогда
//		Возврат;
//	КонецЕсли;
//
//	ЖрнЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");
//	ДатаНачГода = ЖрнЗарплата.НачалоТекущегоПериода();
//	
//	Если (ВыбранныйПериод = 1) тогда
//		ДатаНачГода = НачГода(ДатаНачГода);
//		ДатаКонГода = КонГода(ДатаНачГода);
//	ИначеЕсли (ВыбранныйПериод = 2) тогда
//		ДатаНачГода = НачГода(НачГода(ДатаНачГода) - 1);
//		ДатаКонГода = КонГода(ДатаНачГода);
//	КонецЕсли;  

	ТекГод = ДатаГод(ТекущаяДата()) + 1;
	ЖрнЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");
	Для А = 1 По 10 Цикл
		ПромДата = Дата(ТекГод - А, 01, 01);
    	   Рез = ЖрнЗарплата.ВыбратьПериодПоОбъекту(Человек, ПромДата);
		// сотрудник мог быть как принят на работу так и уволен в средине года 
		Если Рез = 0 Тогда
			ПромДата = Дата(ТекГод - А, 12, 31);
	        Рез = ЖрнЗарплата.ВыбратьПериодПоОбъекту(Человек, ПромДата); 
		КонецЕсли;
		Если Рез = 0 Тогда продолжить КонецЕсли;
		СписокПериодов.ДобавитьЗначение(ПромДата,	""+ДатаГод(ПромДата)+" год");
	КонецЦикла;
	
	ВыбранныйПериод = "";
	Если СписокПериодов.ВыбратьЗначение(ВыбранныйПериод, , , , 1) = 0 тогда
		Возврат;
	КонецЕсли;
	ДатаНачГода = НачГода(НачГода(ВыбранныйПериод));
	ДатаКонГода = КонГода(ВыбранныйПериод);
...Показать Скрыть


Еще изящнее - это добавить список периодов как элемент формы. Но ладно уж, и так сойдет.

И еще с приказами на отпуск как-то непонятно.
21. Виктор Левченко (lvictor58) 30.12.14 16:56
Документы по отпуску должны следовать в последовательности Приказ ---> Начисление
Поэтому предлагаю такой алгоритм:

ДокументОтпуск = СоздатьОбъект("Документ");    
	ДокументПодч = СоздатьОбъект("Документ");
	НайденПриказ = 0;
	ДокументОтпуск.ВыбратьПоЗначению(ДатаНачГода, ДатаКонГода, "Сотрудник", Человек); 
	Пока ДокументОтпуск.ПолучитьДокумент() = 1 Цикл
		Если (ДокументОтпуск.Проведен()=0) Тогда
			Продолжить
		КонецЕсли; 
		Если (ДокументОтпуск.Вид()="ПриказПоОтпуску") ИЛИ (ДокументОтпуск.Вид()="НачислениеОтпуска") Тогда Иначе продолжить КонецЕсли;
		
		Если ДокументОтпуск.Вид()="ПриказПоОтпуску" Тогда   
			НайденПриказ = 1;
			НайденНачисление = 0;
			ТаблицаОтпусков.НоваяСтрока(); 
			ТаблицаОтпусков.Документ = ДокументОтпуск.ТекущийДокумент();
			ТаблицаОтпусков.Начало = ДокументОтпуск.Начало;
			ТаблицаОтпусков.Окончание = ДокументОтпуск.Окончание;
			Если ДокументПодч.ВыбратьПодчиненныеДокументы(ДатаНачГода,ДатаКонГода,ДокументОтпуск.ТекущийДокумент()) > 0 Тогда
				Пока ДокументПодч.ПолучитьДокументт() > 0 Цикл
					Если (ДокументПодч.Проведен()=0)или(ДокументПодч.Вид()<>"НачислениеОтпуска") Тогда
						Продолжить
					КонецЕсли;
					НайденНачисление = 1;
					ТаблицаОтпусков.Начало = ДокументПодч.Начало;
					ТаблицаОтпусков.Окончание = ДокументПодч.Окончание;
					ТаблицаОтпусков.КоличествоДней = ДокументПодч.КоличествоДнейОтпуска; 
					прервать;
				КонецЦикла;	
			КонецЕсли; 
			
			Если НайденНачисление = 0 Тогда
				ТаблицаОтпусков.Начало = ДокументОтпуск.Начало;
				ТаблицаОтпусков.Окончание = ДокументОтпуск.Окончание;
				ТаблицаОтпусков.КоличествоДней = ДокументОтпуск.КоличествоДнейОтпуска; 
			КонецЕсли;
		ИначеЕсли ДокументОтпуск.Вид()="НачислениеОтпуска" Тогда   
			Если НайденПриказ = 0 Тогда
				ТаблицаОтпусков.НоваяСтрока();
				ТаблицаОтпусков.Документ = ДокументОтпуск.ТекущийДокумент();
			КонецЕсли;
			ТаблицаОтпусков.Начало = ДокументОтпуск.Начало;
			ТаблицаОтпусков.Окончание = ДокументОтпуск.Окончание;
			ТаблицаОтпусков.КоличествоДней = ДокументОтпуск.КоличествоДнейОтпуска; 
			НайденПриказ = 0;
		КонецЕсли;
	КонецЦикла;	
...Показать Скрыть