gifts2017

Новый запрос и новая таблица значений как функции

Опубликовал Сергей (ildarovich) в раздел Программирование - Практика программирования

Предлагается две простые функции,  использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

Программы на языке программирования платформы «1С:Предприятие» довольно многословны. В них часто повторяются одни и те же шаблоны. Например, постоянно приходится видеть повторение конструкций вида:

Запрос = Новый Запрос;

Запрос.УстановитьПараметр("ИмяПараметра1", ЗначениеПараметра1);
...
Запрос.УстановитьПараметр("ИмяПараметраN", ЗначениеПараметраN);

Запрос.Текст = "ВЫБРАТЬ ... ";

Или конструкций вида:

ТЗ = Новый ТаблицаЗначений;

ТЗ.Колонки.Добавить(ИмяКолонки1);

...

ТЗ.Колонки.Добавить(ИмяКолонкиN);

Для ускорения ввода конструкций языка по шаблонам есть соответствующие средства. Однако существует и другой путь справиться со ставшей уже привычной избыточностью кода. Этот путь – использование функций.

Для получения готового к выполнению запроса можно использовать функцию:

Функция НовыйЗапрос(Текст, Параметры = 0) Экспорт

   
Результат = Новый Запрос(Текст);

    Для Каждого
Параметр Из Результат.НайтиПараметры() Цикл Результат.Параметры.Вставить(Параметр.Имя)
    КонецЦикла;

    Если
Параметры <> 0 Тогда ЗаполнитьЗначенияСвойств(Результат.Параметры, Параметры)
    КонецЕсли;

    Возврат
Результат

КонецФункции

Здесь параметрами является текст запроса и структура или объект, реквизиты которого содержат значения параметров запроса. В модуле объекта удобнее использовать в качестве параметра значение «ЭтотОбъект». А параметры запроса именовать также как реквизиты этого объекта.

Примеры использования функции:

Для получения количества всех элементов справочника можно использовать код:


ВсегоВНоменклатуре = НовыйЗапрос("ВЫБРАТЬ Ссылка ИЗ Справочник.Номенклатура").Выполнить().Выгрузить().Количество();

 

Для получения таблицы значений из табличной части "Товары" документа "РеализацияТоваровИУслуг" можно использовать код:


Товары_ = НовыйЗапрос("ВЫБРАТЬ * ИЗ Документ.РеализацияТоваровУслуг.Товары ГДЕ Ссылка = &Ссылка", ЭтотОбъект).Выполнить().Выгрузить();

Также, например, в обработке заполнения табличной части для удаления строк с нулевой суммой в модуле объекта обработки достаточно будет записать такую короткую процедуру:

Процедура Инициализировать (Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта)  Экспорт

   
Объект.Товары.Загрузить(

   
НовыйЗапрос("ВЫБРАТЬ * ИЗ Документ.РеализацияТоваровУслуг.Товары ГДЕ Ссылка = &Ссылка И Сумма > 0"

   
, Объект).Выполнить().Выгрузить())

КонецПроцедуры

Конечно, это только небольшая часть возможных примеров. После того, как использование этой функции входит в привычку, к обычному варианту через повторение "УстановитьЗначениеПараметра" возвращаться уже не хочется. В редких случаях, когда объекта-параметра с походящим набором свойств подобрать не удается, в качестве параметра можно использовать Новый Структура("ИмяПараметра1, ... ", ЗначениеПараметра1, ... ). Все равно за счет возможности записать после функции через точку метод "Выполнить" код получается короче.

 

Для получения таблицы значений, имена колонок которой перечислены в строке через запятую, можно использовать функцию:

Функция НоваяТаблицаЗначений(ИменаКолонокЧерезЗапятую) Экспорт

   
Результат = Новый ТаблицаЗначений;

    Для Каждого
Элемент Из Новый Структура(ИменаКолонокЧерезЗапятую) Цикл Результат.Колонки.Добавить(Элемент.Ключ)
    КонецЦикла;

    Возврат
Результат

КонецФункции

 

Пример использования функции:


ВзаимоРасчетыФИФО = НоваяТаблицаЗначений("ДокументОтгрузки, ДокументОплаты, Сумма");


Скачать файлы

Наименование Файл Версия Размер
Пример обработки очистки табличной части от строк с нулевой суммой 38
.epf 4,25Kb
26.11.12
38
.epf 4,25Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Яков Коган (Yashazz) 27.11.12 12:26
Не понимаю, зачем это всё. То, что автор снисходительно назвал "многословностью", на самом деле называется читабельность и наглядность. Это избавляет от ошибок и делает код понятным. С трудом представляю себе функцию, которая объявляет мне таблицу значений с 30 колонками, каждая своего типа и заголовка.

пы.сы. Многократное обращение через точку - зло. И в плане отладки, и в плане оптимальности выполнения (о чём на ИС многажды говорено), и в плане читабельности, т.к. уезжает за край экрана.
rpgshnik; sasha777666; alevnev; klinval; i.d.Kravchenko; necropunk; bashirov.rs; Kubik1984; Lotar; bforce; Solvolna; SedovSU@mail.ru; AlexKo84; krv2k; mailwood; l_men; Spacer; Бубузяка; papami; СергейКа; vanleo; awk; Артано; Hany; keln; Yury1001; +26 Ответить 4
2. Сергей (ildarovich) 27.11.12 13:00
(1) Вопрос действительно спорный. Стиль - дело вкуса. Мне больше нравится краткость. Можно найти компромисс.
Когда Вы говорите "уезжает за край экрана", то говорите только о правом крае (за него я стараюсь не залезать), а забываете о нижнем, за который код 1С уезжает гораздо чаще.
Многократное обращение через точку - зло. И в плане отладки, и в плане оптимальности выполнения (о чём на ИС многажды говорено)
В плане отладки - да, наверное, рефакторинг можно сделать после отладки (которая, вообще говоря, чаще делается в консоли запросов). А вот в плане оптимальности - тут Вы просто путаете с обращением через точку в запросах. В коде все наоборот.
Артано; +1 Ответить
3. Сергей Ожерельев (Поручик) 27.11.12 13:05
(1) В запросе обращение через точку не совсем зло. Зло - когда в запросах обращаются к ссылке ссылочного реквизита. Вот за это убивать долго и мучительно.
skiller3000; the1; +2 Ответить
4. abc2000 (abc2000) 28.11.12 01:33
Не нравится мне такой код. Это как минимум - неуважение к тому, кто будет работать после кодера. В программирование, даже на 1С есть стандарты, хоть некоторые не описаны в статье на ИТС, есть практика применения стандартных конструкций. Хотя, за время своей практики с 1С, я видел и более радикальные варианты кода.:)
unichkin; baton_pk; awk; Артано; +4 Ответить
5. Артано Майаров (Артано) 28.11.12 03:38
Присоединюсь к предыдущим ораторам. Читабельность кода, в общих случаях, снижается существенно. Функции сокращающие размер кода формировать нужно, но еще более важно соблюдать меру и иметь хороший вкус. Код должен быть красивым и понятным без бутылки.
В своей практике работы с запросами часто использую лишь одну функцию:


Функция ПоместитьТЗВоВременнуюТаблицу(парамТЗ, парамИмяВТ, парамМВТ = Неопределено, парамСписокПолейИндексирования = Неопределено) Экспорт


Программное формирование запроса или ТЗ только в случаях динамического формирования, т.е. тогда когда заранее неизвестно как будет выглядеть текст запроса.

Резюме:
-Указанный метод, в некоторых ситуациях имеет право на жизнь, но увлекаться не стоит.
-Посвящение отдельной статьи такому, в общем-то, банальному вопросу считаю нецелесообразным. Иначе нас ждет волна публикации типа "Случаи применения оператора `Если... Тогда` и функции ?()".
6. Roman Biblbox (mr zafod) 28.11.12 04:50
Это все от того, что 1С уже давно не радует программистов синтаксическим сахарком.
Последним нововведением в язык, которое хоть как-то помогло в жизни это появление "ЗначениеЗаполнено"
dabu-dabu; BorisMor; +2 Ответить
7. Александр Орефков (orefkov) 28.11.12 08:58
Автор, не слушай хулителей. Очень красивое решение. Для небольших adhoc запросов.
И я бы еще функцию добавил с оберткой для выполнитьвыгрузить.
DrAku1a; AndreyKyiv07; +2 Ответить 1
8. Fomix (fomix) 28.11.12 09:37
Странно, что разработчики 1С до этого пока еще сами не допёрли!
Частенько в типовых конфах встречаются функции типа:

Функция ПолучитьВерсиюПостановления(Дата) Экспорт
НачалоПримененияИсправленныхСчетовФактур = Константы.НачалоПримененияИсправленныхСчетовФактур.Получить();
Если ЗначениеЗаполнено(НачалоПримененияИсправленныхСчетовФактур)
И Дата >= НачалоПримененияИсправленныхСчетовФактур Тогда
Возврат 2;
Иначе
Возврат 1;
КонецЕсли;
КонецФункции

Так что, у (ildarovich) идет в ногу... Молодца! +
9. 12e3 1sd (mymyka) 28.11.12 09:49
про запросы не совсем понятно, как создание коллекции параметров + объявление текста, через доп.переменную будет меньше установки параметров/текста явно, все же в виде параметров чаще передаются не реквизиты, а объекты ссылочного типа из выборок. А так рациональное зерно в публикации есть. Добавил бы еще функции свертки/сложения массивов/списка значений.
10. Александр Орефков (orefkov) 28.11.12 09:53
(9)
Тут как раз фишка в том, что при грамотном построении текста запроса, объект для передачи коллекции параметров даже создавать не надо. Да даже если и надо, это тоже пишется в одну строку
Новый Структура("Парам1,Парам2,Парам3", Парам1, Парам2, Парам3)
11. Артано Майаров (Артано) 28.11.12 10:01
(7) Тут особо и не хулили, зря Вы, словно рыцарь без страха и упрёка, так лихо встали на защиту "угнетённого". Смысл всех комментариев сводился к двум тезисам:
В рабочем коде не всегда удобно (с точки зрения восприятия) выводить формирование запроса в отдельную функцию
Заявленный программный прием вполне очевиден и не тянет на отдельную статью. Есть же отдельные статьи типа "1С борьба" и.т.д. где автор раскрывает свои приемы и уловки в программировании. Ключевой момент здесь множественное число этих уловок и приемов.
12. Никита Грызлов (nixel) 28.11.12 10:02
Для получения количества всех элементов справочника можно использовать код:

ВсегоВНоменклатуре = НовыйЗапрос("ВЫБРАТЬ Ссылка ИЗ Справочник.Номенклатура").Выполнить().Выгрузить().Количество();


Простите, что?
"Выбрать Количество(Ссылка) Из Справочник.Номенклатура" религия не позволяет? Или сервер резиновый? А если номенклатуры миллион позиций?
shard; spogo; den_bat; alevnev; igormiro; androgin; bashirov.rs; bforce; Sanario; Solvolna; cheburashka; krv2k; vanleo; Артано; +14 Ответить 2
13. Артано Майаров (Артано) 28.11.12 10:07
(12) "Хулителю" плюс один :D

За идеологическими и эстетическими деревьями железного забора не увидели ))

Но если серьезно, то это частный случай, автор демонстрировал возможности функции
14. Сергей (ildarovich) 28.11.12 11:17
(12) Согласен с Вашим замечанием. По хорошему нужно было написать
НовыйЗапрос("ВЫБРАТЬ Количество(*) ИЗ Справочник.Номенклатура").Выполнить().Выгрузить()[0].Поле1
Но для примера так было менее понятно. Возможно, заменю этот пример в статье.
15. игорь ром (djd.sf) 28.11.12 11:32
(14) а если номенклатуры вообще нет? то выбросит исключение. так, что не все в одну строчку получится написать.
16. Сергей Кучеров (СергейКа) 28.11.12 14:34
Присоединюсь к (1).
С трудом себе сейчас могу представить, для чего может представлять интерес таблица значений с нетипизированными колонками. Да и создание самой таблицы уж очень по семерочному...
Если уж потребовалось, то дешевле будет эту таблицу получить из запроса, а не обходом цикла.
17. игорь ром (djd.sf) 28.11.12 14:59
(16) но ведь ничто не мешает изменить функцию, добавив в качестве параметра описание колонок+описание типов. непонятно при чем здесь "семерочность", очень даже неплохо, часто используемые куски кода выносить в процедуры и функции. зачем нужны таблицы значений? открыть типовую конфигурацию, глобальный поиск, таблицазначений, и немало примеров. на ум также приходит, считывание данных из внешних источников (например Excel)
18. Maxim Kolkin (the1) 28.11.12 15:32
Автору плюс. Давно мечтаю про метод ТЗ = Новый ТаблицаЗначений("Поле1, Поле2, Поле2, ..., ПолеN") и Запрос.УстановитьЗначенияПараметров(РанееОпределеннаяСтруктура)

В общем, взял на заметку)
19. Сергей Кучеров (СергейКа) 28.11.12 16:20
(17) djd.sf,
непонятно при чем здесь "семерочность", очень даже неплохо, часто используемые куски кода выносить в процедуры и функции

А где возражения против выносов? Хотя иногда излишне дробить тоже не хорошо.
Семерка - в лишних циклах.
В публикации приведен пример использования. Добавьте в список перечисленных реквизитов слова "ВЫБРАТЬ ПЕРВЫЕ 0", "из *регистр*", выполните через первую указанную процедуру, выгрузите в ТЗ.
Получите:
1) ускорение создания, особенно актуально если таблица большая;
2) все колонки будут сразу типизированы, без всяких "добавив в качестве параметра описание колонок+описание типов"

зачем нужны таблицы значений?

Где что-то против таблиц? Против нетипизированных таблиц. Ну получите вы таблицу с колонками произвольных типов. И что дальше?
Используете во временных таблицах запросов?
Используете в отчетах на СКД?
А если нет, то нафига она нужна в прикладном смысле?
Согласен что бывают случаи. Но они настолько редки... При чем тут считывание вообще не понял.
the1; Ish_2; SirYozha; +3 Ответить 1
20. Сергей (ildarovich) 28.11.12 18:12
(15) Специально проверял: запрос
ВЫБРАТЬ Количество(*) ИЗ Справочник.Номенклатура
возвратит ОДНУ строку даже если в справочнике нет ни одного элемента.
Также пришло в голову, что "Поле1" можно не писать, будет работать и следующий код:
НовыйЗапрос("ВЫБРАТЬ Количество(*) ИЗ Справочник.Номенклатура").Выполнить().Выгрузить()[0][0]
21. игорь ром (djd.sf) 28.11.12 18:15
(20) а дело же не в запросе (я про него не говорил), а именно в Поле1, а писать [0][0] - конечно решение, но потом непонятно, что такое [0][0]
ЗЫ, а хотя да, я ошибся, приношу свои извинения
22. игорь ром (djd.sf) 28.11.12 18:18
(19) ну я и написал, нужны типизированные ТЗ, пишите. не надо спорить с тем, чего я не говорил (я нигде не писал, что я за нетипизированные таблицы)
23. Александр (aet) 29.11.12 05:14
Почему бы не выполнить запрос в самой функции?
24. Сергей (ildarovich) 29.11.12 10:29
(23) Потому что бывают случаи, когда нужно сохранить запрос как объект. Например, поменять параметры или текст (или даже ничего не менять - так тоже бывает) и выполнить его снова.
25. Александр (aet) 29.11.12 10:49
(24) ответ предсказуем...
Ваша публикация нацелена на минимализм, а нечастую надобность поправить запрос, не создавая новый, вы оставляете. Как будто даже редкий раз нельзя выполнить классический кусок кода.
26. Бубузяка (Бубузяка) 29.11.12 22:23
(1) Yashazz, угу, а еще добавим имя общего модуля перед именем функции ... :)
Согласен с (1). Имхо, оптимизация кода - это не уменьшение количества строк и символов, а понятная логика и читабельность.
27. Андрей Акулов (DrAku1a) 02.12.12 17:22
Код создания ТЗ - весьма полезен!
Добавьте в начале функции:
ИменаКолонокЧерезЗапятую = СтрЗаменить(СтрЗаменить(СтрЗаменить(ИменаКолонокЧерезЗапятую, Символы.Таб, ""), Символы.ПС, ""), " ", "");

И теперь можно передавать строку с пробелами, символами табуляции и переноса строки - это решит проблему "вылезания за края экрана".

ВЫБРАТЬ Количество(*) ИЗ Справочник.Номенклатура - текст запроса в одну строчку... ИМХО нечитабельно.
Но тем не мение - сама идея передачи ссылки и заполнения из нее параметров - гениальна и элегантна!

Буду пользовать по мере возможности :-)
28. Андрей Акулов (DrAku1a) 03.12.12 02:24
Еще момент - насчет кода ТЗ. Сделал так:
Процедура СоздатьКолонки(ДЗилиТЗ, знач ИменаКолонокЧерезЗапятую)
	Перем КолонкиДЗилиТЗ;
	ИменаКолонокЧерезЗапятую = СтрЗаменить(СтрЗаменить(СтрЗаменить(ИменаКолонокЧерезЗапятую, Символы.Таб, ""), Символы.ПС, ""), " ", "");
	КолонкиДЗилиТЗ = ДЗилиТЗ.Колонки;
	//---> //http://infostart.ru/public/71130/#Pro_bystrye_massivy
	МассивИменКолонок = ЗначениеИзСтрокиВнутр("{""#"",51e7a0d2-530b-11d4-b98a-008048da3034,{0,{""S"",""" + СтрЗаменить(СтрЗаменить(ИменаКолонокЧерезЗапятую, """", """"""), ",", """},{""S"",""") + """}}}");
	Для Каждого ИмяКолонки Из МассивИменКолонок Цикл КолонкиДЗилиТЗ.Добавить(ИмяКолонки) КонецЦикла;
КонецПроцедуры
...Показать Скрыть
Теперь можно использовать для создания колонок не только таблицы, но и дерева значений:
	ТЗ = новый ТаблицаЗначений;
	СоздатьКолонки(ТЗ, "Колонка1,Колонка2,Колонка3");
или
	ДЗ = новый ДеревоЗначений;
	СоздатьКолонки(ДЗ, "Колонка1,Колонка2,Колонка3");
29. Александр Сленючев (Draconus) 03.12.12 19:09
Очень хороший подход к кодированию, спасибо :)
30. Яков Коган (Yashazz) 04.12.12 11:44
Судя по массе плюсов за эту, пардон, очевидную публикацию, количество не наступавших на грабли громоздкого нечитабельного кода ещё велико. Ничо, всё впереди. 8)

Вот чего мне не хватает, так это конструктора массива: Новый Массив("Знач1","Знач2",12,Истина) и т.д.
31. Дмитрий Глеков (glek) 05.12.12 12:35
Идея понятна. Не совсем понятна область применения. Для упрощения формирования запроса? С таблицей значений вообще все не очень хорошо: а где типизация?
32. Сергей (ildarovich) 05.12.12 20:14
(31)Область применения – СОКРАЩЕНИЕ ИЗБЫТОЧНОСТИ трех видов в тексте программ на языке платформы «1С: Предприятие 8»:
1. В данном фрагменте кода
Запрос = Новый Запрос(ТекстЗапроса);
ЧтоСобственноИнтересует = Запрос.Выполнить().Выгрузить()  
переменная Запрос не несет никакой смысловой нагрузки. Она ИЗБЫТОЧНА. На этом операторе обычно не ставят точку остановки в отладчике, а самой переменной, как правило, не дают само-объясняющее имя, оставляя его ничего не говорящем. Тогда зачем вообще нужно тратить место и время на эту переменную? - Созданный функцией запрос можно сразу выполнить и выгрузить через точку, не сохраняя на него ссылку, исключая избыточность переменной Запрос.
2. В следующем фрагменте кода
Запрос.УстановитьПараметр(Имя1, Значение1);
...
Запрос.УстановитьПараметр(Имя10, Значение10)

много раз повторяются слова УстановитьПараметр, а это 18 символов в каждой строке, отнимающие место и внимание при чтении кода. Кстати, в анекдоте на эту тему «повторение – мать заикания» всего на 8 символов больше!
3. В следующем фрагменте кода
Запрос.УстановитьПараметр(«Параметр», Параметр)

Повторяется слово «Параметр». Как правило, название параметра внутри запроса совпадает с именем переменной вне запроса, особенно если это имя дано правильно, со смыслом. Зачем тогда повторять эти слова в тексте программы? – Использование предлагаемой функции исключает такую необходимость.
По сути, предлагаемая функция играет при работе с запросом такую же роль, что функция «ЗаполнитьЗначенияСвойств» при работе с объектами. Использование этой функции обычно не вызывает вопросов читабельности программ, поэтому, кажется, что высказанные в обсуждении возражения объясняются силой привычки и естественным человеческим консерватизмом.
yurii_host; skif47; zqzq; +3 Ответить 1
33. Сергей (ildarovich) 05.12.12 20:27
(31) Про таблицу значений и типизацию. У автоматизаторов есть золотое правило: не автоматизируй редкое! Здесь также. Кажется, что создавать таблицу значений и так приходится не так часто, а таблицу значений с типизированными колонками - еще во много раз реже (сужу по типовым). Функция приведена "за компанию", для пары. Хотелось продемонстрировать найденный прием парсинга строки наименований, разделенных запятыми, через использование конструктора структуры.
34. Алексей Опарихин (Al-X) 20.06.13 13:45
Интересный подход для минимизации лишней "писанины". Но все же код для "чужого" человека намного станет трудно читаемым или как ?
Надо будут у себя попробовать... Вдруг и понравиться ))))))
35. Юрий Лу (yura1960) 15.06.14 10:44
Да, поле для применения крайне узкое. Согласен с ildarovich. Отложим в заначку. Может и пригодится когда нибудь. Поэтому скажу авансом - спасибо. Но, если честно: не айс. И не пишите через точку, а то я не завидую, кто будет после вас это разгребать.
36. Александр (МимохожийОднако) 15.06.14 10:56
Для облегчения написания кода есть шаблоны, которые используют гораздо чаще, чем предложенные функции. Статья неплохая.
37. Александр Шкут (alex_shkut) 17.07.14 17:13
Да, если подойти разумно, то (32) как раз в мою тему.
Добавляю в отчет где-то 40-й запрос = Новый Запрос задумался об избыточности.
Это ведь 40 раз создается и разрушается один и тот-же объект. Это зачем?
Может проще глобальную переменную Запрос в модуле прописать и юзать 40 раз?
Итого экономия - 39 созданий-разрушений объекта. Идем дальше...
Вынести инициализацию общих параметров, которые повторяются во всех 40-ка случаях в одну функцию после запуска Сформировать.
Например Организация, НачалоПериода, КонецПериода.

Далее инициализировать только тексты и отличия в параметрах.
Хотя все мои 40 запросов выполняются всего :) 47 сек - буду пробовать быстрее.

Был случай, когда запрос вызывался более 9000 раз (да-да более 9 тысяч раз) и глобальная переменная спасла ситуацию.

Поскольку в моем случае все результаты (пока не придумал другого) пакуются в ТЗ, то Перем Запрос мне нужна только одна в единицу времени выполнения. Пока не появится многопоточность - смысла в Новый Запрос()*40 раз не имеет смысла.
39. Ololo Anonim (ololoanonim) 08.12.14 08:15
А мне понравилось. и да, комментарии еще никто не отменял. :)
40. И Б (hornet_X) 19.11.15 10:14
41. Франко Деллиани (Franco) 04.12.15 10:59
ага-ага. Выполнение запроса я показал в публикации Хранение текстов запросов в справочнике и выполнение в общем модуле описал этот спобоб. Правда, там код на более привычном мне английском.
Спобоб несколько по-другому выглядит


Функция ПолучитьРезультатЗапроса(ТекстЗапроса, СтруктураПараметров = Неопределено) Экспорт
	Запрос = Новый Запрос(ТекстЗапроса);
	Если Не СтруктураПараметров = Неопределено Тогда
		Для Каждого Параметр Из СтруктураПараметров Цикл
			Запрос.УстановитьПараметр(Параметр.Ключ, Параметр.Значение);
		КонецЦикла;
	КонецЕсли;
	РезультатЗапроса = Запрос.Выполнить();
	Запрос = Неопределено;
	Возврат РезультатЗапроса;
КонецФункции
...Показать Скрыть



То есть перебор параметров запроса из струкутуры в 1 действие.
И ещё: можно сделать шаблон с обработкой запроса:


РезультатЗапроса = НаСервере.ПолучитьРезультатЗапроса(
		"", Новый Структура("", )
	);
	Если РезультатЗапроса.Пустой() Тогда РезультатЗапроса = Неопределено;Возврат;КонецЕсли;
	Выборка = РезультатЗапроса.Выбрать();
	РезультатЗапроса = Неопределено;
	Пока Выборка.Следующий() Цикл
	КонецЦикла;
	Выборка = Неопределено;
...Показать Скрыть



и без труда формировать получение результата запроса.

Но всё равно, однозначно, +
42. Франко Деллиани (Franco) 04.12.15 11:00
Прошу прощения за недооформленность в предыдущем комментарии...
А как вставлять код в комментарии, чтобы он с расцветкой был?
43. Сергей (ildarovich) 04.12.15 12:02
(41) Franco, данная публикация была сделана раньше, чем "Хранение".
Функции похожи, но за счет использования "ЗаполнитьЗначенияСвойств" в качестве параметра может ссылка на объект и тому подобное использоваться, а не только структура. Чем я, в основном и пользуюсь. Кроме того, возвращается не результат запроса, а сам запрос, что расширяет круг применения функции.
(42) Я использую alt+p (оформление текста в виде кода). Тогда код расцвечивается сам.
44. Олег (olbu) 13.09.16 15:55
Мне это понравилось:
Для Каждого Элемент Из Новый Структура(ИменаКолонокЧерезЗапятую) Цикл Результат.Колонки.Добавить(Элемент.Ключ)
45. Михаил Филимонов (NN2P) 15.11.16 10:02
(43) ildarovich, приятно читать Ваши статьи. Спасибо !
46. Николай ~ ~ (kuzyara) 15.11.16 10:13
— Ты функциональщик! - прокричал Яков на весь оупен-спейс-рум номер 14.
Комната притихла в ожидании развязки.
— Я видел, как ты вчера вечером каррировал и декаррировал прямо за рабочим компьютером!
Неодобрительный ропот и возгласы удивления прокатились по комнате. Кто-то громким шепотом сказал “какой ужас, а я с ним за руку здоровался”.
— Знаешь что, Яков, — сказал Сергей, вставая из-за рабочего стола, — любой нормальный мужчина, если у него всё в порядке, может позволить себе позаниматься функциональным программированием. Это естественно. Каждый хотя бы раз, да пробовал. Зачем только об этом кричать на всю комнату? Я же не кричу, что ты объектно-ориентированный!
Девушки захихикали, кто-то снова громко пробормотал “ну надо же, а по нему и не скажешь”.
Присутствовавший при этом Александр Снегопатович сильнее вжался в кресло. Только бы никто не узнал про его процедурные наклонности!
shard; NN2P; Inkasor; ildarovich; +4 Ответить