gifts2017

Особенности обмена данными с использованием "ручной" регистрации

Опубликовал Александр Хомяк (logarifm) в раздел Администрирование - Распределенная БД (УРИБ, УРБД)

Эта статья рассчитана на программистов, которые используют обмен данными с помощью метода "ВыбратьИзменения" и последующую их запись. Только для планов обменов, имеющих "ручную" регистрацию.

Причиной создания данной статьи послужил разбор непонятной ситуации, когда работал себе обмен более года и все было отлично, но, как обычно, в один прекрасный момент стали вылазить непонятные ситуации, о которых я попытаюсь подробно описать.

В детали обмена я вникать не буду, так как это никому не нужно, но в саму сущность придется все же посветить, например, куда идет обмен, сколько узлов там задействовано, какой принцип регистрации обмена (так как в этом вся важность), ну, и самое интересное - почему обмен перестал работать.

Смысл заложен таков, что есть определенное количество баз, которые обмениваются в одну "Базу отчетности". В этой базе никто ничего не вводит, она только аккумулирует все базы в единое целое для управленческой отчетности.

Опишу прикрепленный рисунок "BaseExchange". В нем отражено, что в базу для отчетности по какой-то причине перестали доходить движения по документам (сами же документы доходили).

 

Также видно, что при обмене используется два разных плана обмена, а это значит, что когда данные получает база "Магазин Самара" от базы "Магазин Владимир", то на узлах регистрации плана обмена "TraidePoint" должна произойти регистрация обмена по выделенным обработчикам событий: "ПередЗаписьюДокументаДляTradePointОбмен", "ПриЗаписиРегистрыНакопленияДляTradePointОбмен" (есть еще обработчики справочников и регистров сведений). 

На этих обработчиках прописан соответствующий код с условиями, например обмен должен идти только по организации "ООО Добро". 

При отладке кода стало ясно, что когда пытался зарегистрироваться набор записей регистра накоплений, условие по Регистратор.Организация не срабатывало лишь потому, что документ загружался позже. То есть он в файле загрузке был, но очередность его была после наборов записей и таким образом условие не срабатывало.

Здесь есть два выхода из ситуации:

  1. это попытаться использовать отбор по измерениям где есть Организация. Таким образом условие накладывается на текущий набор и на его измерение (данный метод меня не устроил, так как не все регистры которые мне нужны при обмене имеют измерение "Организация" или ссылку на этот справочник).
  2. при выгрузке обмена прописать правила очередности, а именно:
Функция ВыгрузитьИзмененияДанныхДляУзла(УзелОбмена, КолвоЭлементовВТранзакцииНаВыгрузкуДанных, ЗаписьXML) Экспорт

    ЗаписьСообщения = ПланыОбмена.СоздатьЗаписьСообщения();
    ЗаписьСообщения.НачатьЗапись(ЗаписьXML,УзелОбмена);

    ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(ЗаписьСообщения.Получатель,ЗаписьСообщения.НомерСообщения);

    //1. Справочники
    Пока ВыборкаИзменений.Следующий() Цикл
        #Если Клиент Тогда
            ОбработкаПрерыванияПользователя();
        #КонецЕсли

        ТекОбъектОбмена = ВыборкаИзменений.Получить();

        Если ТипЗнч(ТекОбъектОбмена) = Тип("УдалениеОбъекта") Тогда
            ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
            Продолжить;
        КонецЕсли;

        МетаданныеОбъекта = ТекОбъектОбмена.Метаданные();

        Если Не ОбщегоНазначения.ПринадлежностьКлассуМетаданных("Справочники",МетаданныеОбъекта) Тогда
            Продолжить;
        КонецЕсли;

        ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
    КонецЦикла;

    //2.Документы
    ВыборкаИзменений.Сбросить();
    Пока ВыборкаИзменений.Следующий() Цикл
        #Если Клиент Тогда
            ОбработкаПрерыванияПользователя();
        #КонецЕсли

        ТекОбъектОбмена = ВыборкаИзменений.Получить();

        Если ТипЗнч(ТекОбъектОбмена) = Тип("УдалениеОбъекта") Тогда
            ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
            Продолжить;
        КонецЕсли;

        МетаданныеОбъекта = ТекОбъектОбмена.Метаданные();

        Если Не ОбщегоНазначения.ПринадлежностьКлассуМетаданных("Документы",МетаданныеОбъекта) Тогда
            Продолжить;
        КонецЕсли;

        ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
    КонецЦикла;

    //3.Регистры
    ВыборкаИзменений.Сбросить();
    Пока ВыборкаИзменений.Следующий() Цикл
        #Если Клиент Тогда
            ОбработкаПрерыванияПользователя();
        #КонецЕсли

        ТекОбъектОбмена = ВыборкаИзменений.Получить();

        Если ТипЗнч(ТекОбъектОбмена) = Тип("УдалениеОбъекта") Тогда
            ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
            Продолжить;
        КонецЕсли;

        МетаданныеОбъекта = ТекОбъектОбмена.Метаданные();

        Если Не ОбщегоНазначения.ПринадлежностьКлассуМетаданных("РегистрыСведений",МетаданныеОбъекта)
            и НЕ ОбщегоНазначения.ПринадлежностьКлассуМетаданных("РегистрыНакопления",МетаданныеОбъекта) Тогда
            Продолжить;
        КонецЕсли;


        ЗаписатьXML(ЗаписьXML,ТекОбъектОбмена);
    КонецЦикла;


    ЗаписьСообщения.ЗакончитьЗапись();
    ЗаписьXML.Закрыть();

    Возврат Истина;

КонецФункции
Вот собственно и все! А, кстати, чуть не забыл, а как оно работало раньше, Вы спросите?! Каким образом в базу отчетности движения попадали, и никто ничего не трогал в коде по обмену и данные вдруг перестали доходить.

Здесь все просто, как оказалось человек, который ежедневно перепроводил всю пачку документов ушел в отпуск. А когда документы он перепроводил - то срабатывала подписка, и если документ в базе уже был, то, естественно, условие уже на Регистратор.Организация успешно срабатывало. 

Будьте внимательны и бдительны при разработке такого рода обмена. 

Диме - отдельная благодарность за нахождение и устранение ошибочной ситуации. 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Антон (anton.fly7) 14.01.13 18:22
я движения перегружаю только по тем регистрам, по которым нет обмена регистраторами
например накопления по дисконтным картам
остальные движения создаются проведениям регистраторов в базе получателе после обмена
2. Александр Капустин (kapustinag) 15.01.13 00:40
(1) anton.fly7, не для любого обмена подойдет вариант с проведением документов после обмена в базе-приемнике. Так как в общем случае не все документы охвачены обменом, то проведение документа вообще может завершиться ошибкой в базе-приемнике.
3. Александр Хомяк (logarifm) 15.01.13 19:34
И также не забываем, что проведение документов это доп. затраты на ресурсоемкость. И да - ошибок при проведении может быть масса, которых устранять некому, а по отчетам будет видно основные проблемы которые будут исправлятся в базах соответствующего назначения.
4. Виталий Андрющенко (via64) 16.01.13 13:55
Можно, в правилах обмена, установить, у ПВД документа, более высокий приоритет, чем у ПВД регистра. Тогда, документы, будут выгружаться раньше. Но, я бы, вообще отключил ПВД регистра и вызывал бы ПКО регистра, по ссылке, из ПКО документа.
5. Александр Хомяк (logarifm) 17.01.13 18:27
Читаем вниамтельно САБЖ: "ручной" регистрации
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа