gifts2017

Дебиторская задолженность по срокам долга

Опубликовал Alex Newman (alexnov) в раздел Отчеты - Бухгалтерские

Дебиторская задолженность по срокам долга на дату отчета с учетом предоставленных по договору дней отсрочки

Отчет «Дебиторская задолженность по срокам долга» позволяет получить информацию о суммах дебиторской задолженности на дату отчета с учетом предоставленных по договору дней отсрочки.

ВНИМАНИЕ: в справочнике "Договоры контрагентов" нужно добавить  свойства "Количество дней отсрочки" и "Лимит ДЗ".

 

 

Скачать файлы

Наименование Файл Версия Размер
Главный файл 267
.erf 22,47Kb
06.02.13
267
.erf 22,47Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Денис Лашев (911service) 06.02.13 09:36
Вот бы еще по кредиторской такую.
2. Павел Белан (webcisp) 08.02.13 02:13
ПО кредиторке есть подобие
http://infostart.ru/public/172119/
Задолженность поставщикам по срокам долга (УПП 1.3/БП 2.0)
3. Павел Белан (webcisp) 08.02.13 02:16
Да,забыл спросить - а чем этот отчет отличается от стандартного в УПП ?
4. Alex Newman (alexnov) 08.02.13 08:11
(3) webcisp, думаю можете сравнить со стандартным:
5. Денис Лашев (911service) 12.02.13 00:49
Там без учета отсрочки по договору
6. ssn5810 (ssn5810) 13.02.13 20:32
попробовал открыть в ут 10.3
{Форма.Форма.Форма(32)}: Поле объекта не обнаружено (мДействиеФормыВыполнитьВнешнююОбработку)
УниверсальныйОтчет.мДействиеФормыВыполнитьВнешнююОбработку = Новый Действие("ДействияФормыВыполнитьВнешнююОбработку");
7. WellMaster (WellMaster) 28.02.13 13:07
Скачал в надежде, что этот отчет будет учитывать "Допустимое число дней задолженности", выставляемое в договоре контрагента. Запустил, сравнил со встроенным. Все тоже самое. Отчет не работает на заявленный функционал.
Группировки строк: Контрагент, Договор, Документ расчетов с контрагентом (реализация)

UPD. Сорри, оказывается там дальше еще один ряд колонок. В нем как раз таки все правильно.
Спасибо.

UPD2. Колонки хоть и есть, а вот данных в них нет. Не работает. Пруф в аттаче
Прикрепленные файлы:
8. Alex Newman (alexnov) 01.03.13 11:23
(7) WellMaster, свойство в договоре нужно добавить "Количество дней отсрочки" (код 00000000027) и "Лимит ДЗ" (код 00000000038). Скорее всего из-за этого. Честно говоря уже не помню, но думаю если текст запроса помотрите будет понятно чего не хватает в Вашей базе. Скорее всего какого-то совйства нет или в договоре или у контрагента.
9. WellMaster (WellMaster) 01.03.13 11:42
(8) alexnov, Да, вчера ковырялся в коде. Действительно нету этих свойств. Ну добавлю я их, а их еще и заполнять придется? А зачем, если есть реквизит договора "Допустимое число дней отсрочки"?
10. Alex Newman (alexnov) 01.03.13 11:48
(9) WellMaster, ну придется заполнить конечно. У нас в УПП 1.3.34.1 нету такого реквизита (.
11. Алексей (manoff) 27.06.13 14:57
Пытаюсь отчет прикрутить у УТ 10.3 свойства у договора заполнил, проверил даже в дебагере, находит их. НО в отчете графа лимит ДЗ напротив соответствующего договора не заполняется. Ну и просрочку не обсчитывает.
Что не так могу делать?
12. Алексей (manoff) 27.06.13 14:58
(7) Если разобрался как с ним работать, отпиши пожалуйста
infostatuser; +1 Ответить 1
13. WellMaster (WellMaster) 27.06.13 16:02
(12) manoff, нет, написал свой отчет )
14. Алексей (manoff) 28.06.13 01:27
15. WellMaster (WellMaster) 28.06.13 08:25
(14) manoff, уже поделился судя по всему :)
16. AlexBar (AlexBar) 09.09.13 17:19
(105) Gazza,
С каких это пор в УПП нет реквизита "Допустимое число дней отсрочки"? Этот реквизит существовал еще с первых редакций УПП. То же самое и с суммой задолженности.
Прикрепленные файлы:
17. Максим Анпилов (Mx00) 27.09.13 18:37
(13) WellMaster, если есть возможность поделись отчетом Дебиторская задолженность по срокам долга с учетом дней отсрочки
18. WellMaster (WellMaster) 27.09.13 20:48
(17) Mx00, Так вроде скачивается нормально. Или нету SM? Могу кинуть, если не в минусах.
19. Максим Анпилов (Mx00) 27.09.13 21:07
(18) Скачать я скачал, но там нужно заводить свойства, а ты писал про "Допустимое число дней отсрочки", вот мне как раз по этому реквизиту нужно, если у тебя именно так, то буду очень благодарен :-)
mx(аt)mail.ru
20. WellMaster (WellMaster) 28.09.13 11:42
21. Ильнур Гильфанов (iln00r) 03.03.14 12:54
Неплохо было бы систематизировать все отчеты по дебиторской/кредиторской задолженности
23. Петр Лунегов (pvlunegov) 16.06.15 07:07
Скачал. Запустил в УТ 10.3. Ошибка
{Форма.Форма.Форма(32)}: Поле объекта не обнаружено (мДействиеФормыВыполнитьВнешнююОбработку)
УниверсальныйОтчет.мДействиеФормыВыполнитьВнешнююОбработку = Новый Действие("ДействияФормыВыполнитьВнешнююОбработку");


ЗАмечательно! Спасибо за супер отчет с небольшими ошибочками...
24. Петр Лунегов (pvlunegov) 16.06.15 07:09
Коли отчет не тестировали для всех типовых конф, то хоть напишите в описании, в каких конфах отчет железно работает.

Получается я скачиваю, и потом оказывается что автор не тестировал свою работу на типовой конфе Ут 10.3
25. Петр Лунегов (pvlunegov) 16.06.15 07:23
Зашел в конфигураторе в вашу обработку. В процедуре ПриОткрытии закомментировал строки:

Процедура ПриОткрытии()

УниверсальныйОтчет.мДействиеПолеВводаВидСравненияПриИзменении = Новый Действие("ПолеВводаВидСравненияПриИзменении");
УниверсальныйОтчет.мДействиеПолеВводаЗначениеПриИзменении = Новый Действие("ПолеВводаЗначениеПриИзменении");
УниверсальныйОтчет.мДействиеКоманднаяПанельФормыПечать = Новый Действие("КоманднаяПанельФормыПечать");
//УниверсальныйОтчет.мДействиеФормыВыполнитьВнешнююОбработку = Новый Действие("ДействияФормыВыполнитьВнешнююОбработку");

//УниверсальныйОтчет.мДействиеКоманднаяПанельФормыСправкаФормы = Новый Действие("КоманднаяПанельФормыСправкаФормы");
//УниверсальныйОтчет.мДействиеВстроеннаяСправкаonclick = Новый Действие("ВстроеннаяСправкаonclick");
//УниверсальныйОтчет.мДействиеВстроеннаяСправкаonmouseout = Новый Действие("ВстроеннаяСправкаonmouseout");
//УниверсальныйОтчет.мДействиеВстроеннаяСправкаonmouseover = Новый Действие("ВстроеннаяСправкаonmouseover");

УниверсальныйОтчет.ФормаПриОткрытии(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма);

КонецПроцедуры // ПриОткрытии()


После этого отчет стал работать.
Спасибо! Все ок вроде, будем проверять с менеджерами.

Если какие-то проблемы будут возникать, напишу.


Просьба в процедуре ПриОткрытии сделать проверку на имя конфигурации, вот код ниже:

Процедура ПриОткрытии()

УниверсальныйОтчет.мДействиеПолеВводаВидСравненияПриИзменении = Новый Действие("ПолеВводаВидСравненияПриИзменении");
УниверсальныйОтчет.мДействиеПолеВводаЗначениеПриИзменении = Новый Действие("ПолеВводаЗначениеПриИзменении");
УниверсальныйОтчет.мДействиеКоманднаяПанельФормыПечать = Новый Действие("КоманднаяПанельФормыПечать");

Если не (Метаданные.Имя = "УправлениеТорговлей" и лев(Метаданные.Версия, 4) = "10.3") тогда
УниверсальныйОтчет.мДействиеФормыВыполнитьВнешнююОбработку = Новый Действие("ДействияФормыВыполнитьВнешнююОбработку");

УниверсальныйОтчет.мДействиеКоманднаяПанельФормыСправкаФормы = Новый Действие("КоманднаяПанельФормыСправкаФормы");
УниверсальныйОтчет.мДействиеВстроеннаяСправкаonclick = Новый Действие("ВстроеннаяСправкаonclick");
УниверсальныйОтчет.мДействиеВстроеннаяСправкаonmouseout = Новый Действие("ВстроеннаяСправкаonmouseout");
УниверсальныйОтчет.мДействиеВстроеннаяСправкаonmouseover = Новый Действие("ВстроеннаяСправкаonmouseover");
КонецЕсли;
УниверсальныйОтчет.ФормаПриОткрытии(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма);

КонецПроцедуры // ПриОткрытии()


В моей УТ 10.3 стало работать!
26. Тертышный Денис (petronas) 21.11.16 13:29
Уважаемые коллеги, небольшое дополнение. Указанные автором свойства должны иметь тип значений "Число".
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа