gifts2017

Кнопки сворачивания и разворачивания группировок в отчете СКД в управляемых формах

Опубликовал mxm2 mxm2 (mxm2) в раздел Программирование - Практика программирования

Сверуть и развернуть группировки можно через контекстное меню, горячими клавишами, а можно разместить соответствующие кнопки на форме отчета. Как оказалось, для этого не нужно ни строчки кода.

В обычных формах это реализуется как описано в Универсальный отчет (4.2.0.1), в управляемых такое действие можно произвести, если включить в пользовательском режиме отображение заголовков табличного документа через меню (Главное меню [формы отчета] -> Таблица -> Вид ->  Отображать заголовки) или вообще выводить с включенными заголовками (В табличном документе Результат, в который производится вывод, установить ОтображатьЗаголовки в значение Истина). После этого можно пользоваться возможностью сворачивать и разворачивать по группировкам:Группировки при включенных заголовках

Этот способ очень удобен, но когда количество группировок велико, то поля табличного документа занимают очень много места, кроме того заголовки строк и колонок вообще часто не несут полезной информации.

Реализуем похожий функционал другим способом, для этого нам потребуется любой готовый отчет на СКД, в нем должна быть основная форма (если нет - её легко добавить), демонстрируем на примере отчета: Прайс лист с картинками для УТ11 (логотип, картинки товаров, свободные текстовые поля в заголовке, остатки, отбор по остаткам, возможность "объединения одинаковых картинок"). Открываем его в конфигураторе, открываем основную форму:

ФормаОтчета

 Переходим в

1. Команды

2. Стандартные комадны

3 Разворачиваем Результат:

 Команды

 Видим команды табличного документа, которые можем разместить на форме:

Результат

Перетаскиваем нужную команду мышкой в соответствующее место командной панели:Перетаскивание:

И удивляемся тому, что кнопка не появилась в прогнозируемом месте... (она появилась в меню Все действия, что не совсем удобно).

Принудительно заставим вновь добавленную кнопку отображаться (установив для нее параметр ТолькоВоВсехДействиях в значение Нет):

Отображаем кнопку

Кнопка появилась, производим аналогичные действия для команд Свернуть все группы и Развернуть все группы:

Другие кнопки 

Сохраняем отчет, запускаем в пользовательском режиме:

Отчет 

P. S. В УТ11.1 кнопки сворачивания и разворачивания уж включены в форму стандартных отчетов. 

Р. P. S. Горячие клавиши: сворачивания  Ctrl + Shift + Num - и разворачивания  Ctrl + Shift + Num +  (работают в любом табличном документе даже без выноса кнопок)

Р. Р. P. S. У объекта ТабличныйДокумент есть методы: ПоказатьУровеньГруппировкиСтрок(Уровень) и ПоказатьУровеньГруппировкиКолонок(Уровень), которые позволяют раскрывать документ до нужного уровня группировок.

Скачать файлы

Наименование Файл Версия Размер
ПрайсЛист.erf 39
.erf 20,50Kb
10.04.13
39
.erf 20,50Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Сергей (seermak) 10.04.13 21:50
Иногда в отчетах кнопки стандартные не работают Тогда делаю так: (кидаю кнопки в КонтекстноеМеню)

&НаКлиенте
Процедура СвернутьГруппы(Команда)
ГруппыСтрок("01");
КонецПроцедуры

&НаКлиенте
Процедура РазвернутьГруппы(Команда)
ГруппыСтрок("02");
КонецПроцедуры

&НаКлиенте
Процедура ГруппыСтрок(Имя)
Уровень = Число(Сред(Имя, 2)) - 1;
У = Результат.КоличествоУровнейГруппировокСтрок() - 1;
Пока У > Уровень Цикл
Результат.ПоказатьУровеньГруппировокСтрок(У);
У = У - 1;
КонецЦикла;
Результат.ПоказатьУровеньГруппировокСтрок(Уровень);
КонецПроцедуры
2. al petrov (petrov_al) 12.04.13 08:37
Спасибо, очень полезная информация.
3. Алексей (1C_tradeomsk) 18.04.13 09:43
Мужик, ты красавец!!!! Огромное спасибо!!!
4. ффф ыыы (zqzq) 18.04.13 09:55
Р. P. S. Горячие клавиши: сворачивания Ctrl + Shift + Num- и разворачивания Ctrl + Shift + Num+ (работают в любом табличном документе даже без выноса кнопок)

Ещё есть Ctrl + Num(+/-) разворачивает/сворачивает текущую группировку и Ctrl + Alt + Num(+/-) разворачивает/сворачивает текущую группировку и вложенные группировки.

Так что метод в статье по сути трата времени на бантики. Лучший отчет это вообще без формы (с автогенерируемой).
5. mxm2 mxm2 (mxm2) 18.04.13 10:24
(4) zqzq, согласен, но бантики тоже иногда полезны, чтобы не грузить пользователя запоминанием горячих клавиш.
6. Виталий Трач (vitalya24) 13.08.13 14:42
вопрос может немного не в тему но все же. Как сделать так чтобы пользователь мог "+" сворачивать заголовки полей отчете, как вот например с заголовком самого отчета?
7. mxm2 mxm2 (mxm2) 13.08.13 14:59
(6) vitalya24, Для этого заголовки нужно будет помещать в сворачиваемую группировку, например как это обычно делается в стандартном отчете с параметрами и отборами СКД. скорее всего придется вмешиваться в вывод информации средствами СКД в табличный документ.