gifts2017

Внешняя компонента для отображения часов

Опубликовал Евгений (le_) в раздел Программирование - Внешние компоненты

Многие пользователи работают с 1С в терминальных сессиях, с ограниченными правами, когда не запускается ничего, кроме 1С.
Эта внешняя компонента позволяет отобразить маленькое окошко с системным временем поверх окна 1С, не мешая, при этом, работе пользователя.

Компонента разработана по технологии Native.

Работает только в Windows с 1С v. 8.2 (обычное приложение, толстый и тонкий клиент управляемого приложения).

Пример использования (конфигурация) прилагается (обычное и управляемое приложение).

 

Методы компоненты:

Показать (ЦветФона, ЦветТекста, ЦветРамки, Прозрачность)

Описание:

Отображает на экране плавающее окошко с текущим системным временем
   
Параметры:
ЦветФона (необязательный)
Тип: строка
Строка, в которой через запятую перечислены значения интенсивности красной, зеленой и синей составляющих цвета фона, на котором будет отображено время. Значения интенсивности указываются числами из диапазона 0-255.
Значение по-умолчанию: "252, 250, 235"

ЦветТекста (необязательный)
Тип: строка
Строка, в которой через запятую перечислены значения интенсивности красной, зеленой и синей составляющих цвета текста.
Значение по-умолчанию: "0, 0, 0"

ЦветРамки (необязательный)
Тип: строка
Строка, в которой через запятую перечислены значения интенсивности красной, зеленой и синей составляющих цвета рамки, обрамляющей время.
Значение по-умолчанию: "179, 172, 134"

Прозрачность (необязательный)
Тип: число
Число в диапазоне 0-255, определяющее насколько прозрачной будет форма, на которой отображается время. 0 - полностью прозрачная форма, 255 - непрозрачная форма.
Значение по-умолчанию: 255.

 

Закрыть()

Описание:

Скрывает форму, отображающую время.

 

Форму, отображающую время, можно свободно перемещать по экрану, используя левую кнопку мышки.

Координаты, описывающие положение формы на экране, "запоминаются" при закрытии формы и будут использованы при следующем её открытии.

Закрыть форму можно щелкнув на ней правой кнопкой мышки.

Форма имеет всплывающее сообщение с "подсказкой".

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Внешняя компонента для отображения часов
.rar 34,31Kb
17.04.13
23
.rar 34,31Kb 23 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей (seermak) 17.04.13 20:21
нате без компоненты
&НаКлиенте
Процедура ПриОткрытии(Отказ)
ПодключитьОбработчикОжидания("Часы", 1, Ложь);
КонецПроцедуры
&НаКлиенте
Процедура Часы()
Скрипт = Новый ComОбъект("MSScriptControl.ScriptControl");
Скрипт.Language = "javascript";
Часы = Скрипт.eval("new Date().getHours()");
Минуты = Скрипт.eval("new Date().getMinutes()");
Секунды = Скрипт.eval("new Date().getSeconds()");
ВремяСтрокой = "" + Часы + ?(Минуты < 10, ":0", ":") + Минуты + ?(Секунды < 10, ":0", ":") + Секунды;
КонецПроцедуры
2. Евгений (le_) 17.04.13 21:58
(1)
&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПодключитьОбработчикОжидания("Часы", 1, Ложь);
КонецПроцедуры

&НаКлиенте
Процедура Часы()
	Элементы.Декорация1.Заголовок = Формат(ТекущаяДата(), "ДЛФ=T");
КонецПроцедуры
...Показать Скрыть


Только смысл в том, чтобы отобразить это вместо часов на панели задач (когда её (панели) нет), чтобы в любой момент было видно без переключений окон и т.п.
3. Роман Г (Stradivari) 07.05.13 16:01
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа