gifts2017

ООП. Инкапсуляция, часть 2.

Опубликовал fez (fez) в раздел Программирование - Практика программирования

Продолжаем обсуждать инкапсуляцию, как первую из основ объектного подхода к программированию.

Второй простой пример инкапсуляции.

Допустим, есть в конфигурации константа ОсновнаяФирма. И повсюду в конфигурации разбросаны вызовы Константа.ОсновнаяФирма. Как инкапсулировать эту константу и зачем (и в каких случаях) это надо делать?

Для начала отвечу на вопрос "как". Очень просто.

класс Константы = __Константы@MD {};  

Функция ОсновнаяФирма() Экспорт
Возврат Константа.ОсновнаяФирма;
КонецФункции

Вы спросите - зачем огород городить? Отвечаю. Мы отделили реализацию от представления. Скрыли реализацию за интерфейсом. Теперь мы можем свободно менять реализацию, оставив старый интерфейс. Кстати, отличный повод для подобного разделения - это несоответствие названия константы реальному состоянию дел. Вместо, или вместе со сменой идентификатора константы можно сразу провести данный рефакторинг. Все равно глобальным поиском трясти.

Примеры, когда нужно вдруг поменять реализацию.

1. Теперь вдруг понадобилось сделать константу периодической. Мы даже интерфейс можем не менять, а расширить:

класс Константы = __Константы@MD  
{
Справочник ОсновнаяФирма(Дата _Дата = ТекущаяДата());
};

Функция ОсновнаяФирма(_Дата) Экспорт
Возврат Константа.ОсновнаяФирма.Получить(_Дата);
КонецФункции

2. Вдруг провели измерения быстродействия и выяснили, что обращения к таблице констант занимают существенное время в работе конфигурации. Решение - кэшировать значения тех констант, которые в середине дня ну никак не могут поменяться. ОсновнаяФирма - одна из таких констант (обратный пример - это константа ДатаЗапретаРедактирования, ее кэшировать не стоит).

класс Константы = __Константы@MD {};  

Перем КэшОсновнойФирмы;
Процедура Конструктор()
КэшОсновнойФирмы = "";
КонецПроцедуры
Функция ОсновнаяФирма() Экспорт
Если КэшОсновнойФирмы = "" Тогда
КэшОсновнойФирмы = Константа.ОсновнаяФирма;
КонецЕсли;
Возврат КэшОсновнойФирмы;
КонецФункции

3. Мы решили разгрузить таблицу констант от блокировок. И хотим хранить значение основной фирмы в специальном справочнике.

класс Константы = __Константы@MD {};  

Функция ОсновнаяФирма() Экспорт
СпрКонстанты = СоздатьОбъект("Справочник.Константы");
СпрКонстанты.НайтиЗначениеПоКоду("ОсновнаяФирма");
Возврат СпрКонстанты.Константа;
КонецФункции

4. У константы не может быть двух идентификаторов, а вот в классе вполне может оказаться два (и даже больше) метода с разными названиями, но которые делают одно и то же. Зачем это может понадобиться - придумайте сами :)

См. также

Подписаться Добавить вознаграждение
Комментарии
1. fez (fez) 11.12.08 14:03
2. Дмитрий Воробьев (vde69) 11.12.08 14:30
вот было-бы хорошо если бы расшифровал строку
класс Константы = __Константы@MD {};

а то далеко не все 1с ники понимают, чего это за синтаксис... видимо и шапку надо поменять.

На сколько я понял к 1с (обычной, без надстроек) это не имеет отношение???
3. fez (fez) 11.12.08 15:56
(2) Естественно, к обычной 1с это не имеет отношения. Поскольку оригинальный язык 1С - не объектно-ориентированный, то об этом не может быть и речи.

Представленный синтаксис - это синтаксис 1С++.
6. fez (fez) 14.12.08 19:29
(5) Я не помню, в восьмерке в обработке можно хранить какие-нибудь данные, или это чисто хранилище для методов?
7. fez (fez) 14.12.08 19:30
Например кэширование, как во втором примере, можно сделать?
10. fez (fez) 15.12.08 14:08
(8) Эээ... А как можно без проперти гет/сет хранить данные?
Покажи кусочек кода, думаю, будет нагляднее.
12. fez (fez) 15.12.08 15:24
(11) А что тогда, по вашему, property get/set?