gifts2017

Поиск нерассчитаных записей в журнале расчетов

Опубликовал larissa builova (larisab) в раздел Администрирование - Поиск данных

Поиск нерассчитаных записей в журнале расчетов. Простенькая обработка, но не нашла нигде, может быть кому-нибудь пригодится.

Клик по строке в таблице открывает журнал расчетов на выбранной записи и делает отбор по объекту. Делалось в конфигурации для Казахстана.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1232465376 7,57Kb
20.08.14
288
.1232465376 7,57Kb 288 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. LenaTorpeda 19.01.09 02:30
Ларис,ещё как пригодилось!!! Поставила твою обработку в фирму с ЗИК.Когда
расчетчик(мужчинка) увидел количество ошибок за год ,его первое было:"Не может быть".
Видела бы ты его кислую мину... За год исправлять не охота(как я поняла).
Мне понравилось!!!! Молодец!!! Такую бы еще теперь для ЗУП.
2. Альтаир (Altair777) 19.01.09 03:17
(1) Это важно, что расчетчик был мужского пола?
У расчетчиков женского пола мины не такие кислые?
3. larissa builova (larisab) 19.01.09 15:30
Ну хоть кому то пригодилась, а то думаю ерунда, есть ли смысл выкладывать, а когда сама нашла мягкую смену периода от Poppy - так радовалась! Мне к казахстан. конфам почти ничего не подходит, а эта подошла!
4. Игорь Савонов (savonov) 19.01.09 17:10
Нормальная обработка.
Только сделать ее чуть универсальнее. Выбор журнала - как у Рорру. Проверку расчетчика - убрать.

В качестве пожелания. Добавить колонку - Период, еслы выбран не один месяц. При клике по таблице открывать журнал расчетов.
5. larissa builova (larisab) 19.01.09 18:27
>При клике по таблице открывать журнал расчетов.
Не получается, делала вроде бы все правильно, вываливается, не поняла, в чем дело. У меня под вистой стоит 25 платф. ессно без ключа, некуда вставить - нет LPT порта, может поэтому...
А остальное сделаю, писалось под расчетчиков - специфика такая в базе
6. larissa builova (larisab) 19.01.09 19:59
7. LenaTorpeda 19.01.09 23:10
(4)Точно! Я и забыла.Расчетчика банила.В их кофе расчетчика нет.
8. LenaTorpeda 19.01.09 23:14
(2)У расчетчиков женского пола кислых мин не бывает.Только сладкие.:-)
9. Magus (magus) 20.01.09 01:26
(0) Для обработки клика по таблице необходимо вставить в Основную форму справочника "Сотрудники" в процедуру ПриОткрытии() строку: АктивизироватьОбъект(Форма.Параметр);
Ужос. Лучше напиши так:
Код
   Конт = "";
   ОткрытьФорму("Справочник.Сотрудники.Основная", Конт);
   Конт.АктивизироватьОбъект(ТЗНерассчит.ПолучитьЗначение(СтрТабл, "Сотрудник"));
Показать полностью

10. Magus (magus) 20.01.09 01:29
[i]>При клике по таблице открывать журнал расчетов.
Не получается, делала вроде бы все правильно, вываливается,[i]
Кто тебя учил программить?
Код
   ОткрытьФорму("ЖурналРасчетов.Зарплата", Конт);
   Конт.АктивизироватьОбъект(ТЗНерассчит.ПолучитьЗначение(СтрТабл, "Запись"));
Показать полностью
11. Альтаир (Altair777) 20.01.09 10:18
(8) Еще как бывает :-)
Бывают такие, что лучше их вечером не видеть, а то сон будет беспокойный и с кошмарами.
Кстати, и не только у расчетчиц, а и у программисток, бухгалтерш и других представительниц женского пола.
seven77782; +1 Ответить 1
12. larissa builova (larisab) 20.01.09 18:55
(9)(10) Спасибо за науку, ужос убрала, обновила. Училась в основном на чужом коде и на синтаксисе-помощнике, в общем "на коленке":-))))
13. larissa builova (larisab) 20.01.09 18:57
(11) >и других представительниц женского пола>, как печально...
14. Альтаир (Altair777) 20.01.09 19:07
(13) Я не имел в виду всех, а только некоторых.
Это Торпеда виноват(а) :-) Он(а) сделал(а) акцент на мужчине-расчетчике.
Имхо, такие вещи нужно писать в своей закрытой группе.

P.S. Извиняюсь, что отвлек Инфостартовцев от хорошей разработки.
P.P.S. И кстати, Торпеда, почитай правила, пункт 1

Вы соглашаетесь не использовать сервисы предоставляемы Infostart.ru для:
Загрузки, посылки, передачи или любого другого способа размещения контента, который является незаконным, вредоносным, угрожающим, клеветническим, оскорбляет нравственность, нарушает авторские права, пропагандирует ненависть и/или дискриминацию людей по расовому, этническому, половому, религиозному, социальному признакам, содержит оскорбления в адрес конкретных лиц или организаций;
15. LenaTorpeda 20.01.09 22:49
(14) Сплошные комплексные конфигурации.

А то что ты написал(а) обязательно приму к своему женскому(мужскому) сведенью.
16. Альтаир (Altair777) 20.01.09 22:55
Мой-то пол как раз известен, а ты свой утаил(а) :-)
Но, судя по аватарке, ты - мужик.
И комплексов у меня нет, я не создаю такие группы.
Из которых модераторы бегут. Чем же ты их так напугал(а)?
Личико показал(а)? :-)
17. Альтаир (Altair777) 20.01.09 22:57
18. Poppy (poppy) 21.01.09 00:11
Повторять участки кода без особой необходимости не очень хорошо.
Попробуй такой код:
Код
Пока ЖрнЗарплата.ПолучитьЗапись()=1 Цикл
   Попытка
      Если не (ЖрнЗарплата.Объект.Расчетчик = Расчетчик) Тогда
         Продолжить;
      КонецЕсли;
   Исключение
   КонецПопытки;
   
   Если ЖрнЗарплата.ТекущаяЗапись().Рассчитана = 0 Тогда 
      ТЗНерассчит.НоваяСтрока();
      ТЗНерассчит.ПериодДействия = ЖрнЗарплата.ПериодДействия;
      ТЗНерассчит.ПериодРегистрации = ЖрнЗарплата.ПериодРегистрации;
      ТЗНерассчит.Сотрудник = ЖрнЗарплата.Объект;
      ТЗНерассчит.Расчет = ЖрнЗарплата.ВидРасч;
      ТЗНерассчит.Запись = ЖрнЗарплата.ТекущаяЗапись();
   КонецЕсли;
КонецЦикла;
Показать полностью
19. larissa builova (larisab) 21.01.09 00:39
(18) согласна. Так то лучше:-))))
20. Аркадий Кучер (Abadonna) 21.01.09 03:52
(15) Она:
за слово "мужчинка" просто надо прибить
1. Уже давно меня раздражает
2. Надоели активгые нули
3. Хотела опубликовать, что писал в личку? Пишу впрямую: по мере сил и возвожностей буду гнобить и чморить на этом сайте
21. Сергей (seermak) 21.01.09 07:28
(18) нерасчитанные записи выбираете только для расчетчика? :))))
Если не (ЖрнЗарплата.Объект.Расчетчик = Расчетчик) Тогда
Продолжить; //переход на начало цикла
КонецЕсли;
22. Сергей (seermak) 21.01.09 07:31
+21 и зачем выбор вообще расчетчика - делитесь кто накосячил? так это не так важно - кому-то не заплатили - это важнее
23. Vasily Kushnir (vasilykushnir) 21.01.09 09:28
А ну брысь! А то сечас кого-то забаню. (ой! букву "я" пропустил).
(0) Товарищ Торпеда, у меня к вам даже не упрек, а больше простое любопытство (всегда видите-ли вызывает интерес не адекватное поведение) - вам нравится когда девушек, женщин называеют бабами, бабъем, сосками (курящих) и в том же духе? Согласен с (20) за "мужчинку" в приличном обществе бъют больно по лицу, хотя женщина - и друг человека.
Altair777; +1 Ответить
24. Vasily Kushnir (vasilykushnir) 21.01.09 09:30
25. Vasily Kushnir (vasilykushnir) 21.01.09 09:43
А автору темы пожалуй плюсану - любую инициативу следоват поддерживать-с.
26. larissa builova (larisab) 21.01.09 19:27
(21) Косяков всегда много бывает, на самом деле это делалось для устранения косяков переноса-слияния четырех филиалов в одну организацию из разных типов конфигураций:-))))
27. larissa builova (larisab) 21.01.09 19:29
28. Александр Венгер (venger) 23.01.09 01:02
(1) Та ладно вам, это ж просто эпитет ко всем не относящийся:-) Я надеюсь:-)
29. Альтаир (Altair777) 23.01.09 01:30
(16) > Но, судя по аватарке, ты - мужик.

подейстовало :-)
оно поменяло аватарку
30. kva52 (kva52) 26.01.09 11:09
Для перехода по клику в ТЗ на запись в журнале лучше поставить:
Конт.УстановитьПредставление(2,ТЗНерассчит.ПолучитьЗначение(СтрТабл, "Сотрудник"));
Конт.ГраницаПросмотра(ТЗНерассчит.ПолучитьЗначение(СтрТабл, "ПериодРегистрации"));
Конт.АктивизироватьОбъект(ТЗНерассчит.ПолучитьЗначение(СтрТабл, "Запись"));

вместо одной последней записи. Иначе (проверено в ЗиК) не находит нужную запись.
31. larissa builova (larisab) 28.01.09 11:51
Находит, только когда отбор стоит "все объекты" , но Ваш метод лучше, т.к. он находит и еще отбор делает по этому объекту, спасибо за совет!
32. larissa builova (larisab) 28.01.09 13:30
+(31) Изменила, перезалила с учетом (30).
33. Сергей (seermak) 07.02.09 15:26
В строке Если ЖрнЗарплата.ТекущаяЗапись().Рассчитана = 0 Тогда - неточность = в список отобранных попадают строки, рассчитанные вручную...
Если изменить на строку Если (ЖрнЗарплата.ТекущаяЗапись().Рассчитана = 0) И (ЖрнЗарплата.ТекущаяЗапись().Исправлена = 0) Тогда - неточность снимается:)
34. larissa builova (larisab) 07.02.09 20:15
Да и правда, ручные попадают, но только в открытом периоде, в закрытых периодах - нет. Можно добавить.
35. dandfam (dandfam) 02.04.09 11:44
ой, ребята, весело у вас тут!:-))
за обработку спасибо! перепроверила у себя, все ок! так довольна! :-))
36. Lady-mo (Lady-mo) 29.05.09 12:49
Списабо большое за обработку!
Это замечательнейшая вещь!
37. larissa builova (larisab) 29.05.09 19:00
(35) (36) И вам спасибо за доброе слово!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа