gifts2017

Работа с шаблоном MS Word, как с табличным (текстовым) документом.

Опубликовал Андрей Крутских (K_A_O) в раздел Программирование - Практика программирования

Внешняя обработка с функциями, позволяющими обращаться к файлу в формате MS Word, как к табличному документу (например использовать методы: ПолучитьОбласть(), Вывести()). Можно использовать как объект, чтобы воспользоваться готовым кодом на языке 1С или, например, конструктором выходной формы отчета, внести небольшие изменения в код и получить отчет в Word.

Примеров работы с MS Word достаточно много, однако практически всегда это заполнение шапки файла. В случае существования различных таблиц в теле файла, положение гораздо хуже. Если есть время на разработку, можно использовать методы ConvertToTable или макросы в Word – скорость заполнения таблиц будет явно быстрее, если же нужно подготовить сложный документ срочно - можно воспользоваться данной обработкой.

Шаблон файла достаточно прост и позволяет менять его пользователям (почти).
Файл в формате MS Word  рассматривается как набор областей, каждая из которых имеет набор параметров.
Область – это закладка в Word. Имена параметров должны быть заключены в квадратные скобки ([ИмяПараметра]).

В архиве находятся файлы:

  • WordTemplate.epf - основной объект, позволяющий работать с шаблоном.
  • ПримерРаботыСШаблономWord.epf - обработка, которая должна находится в той же директории и показывающая пример работы.
  • Шаблон.doc - простой шаблон в формате MS Word.

Скачать файлы

Наименование Файл Версия Размер
CreateWord (последняя версия от 10.05.2010) 1241
.zip 19,51Kb
12.06.10
1241
.zip 19,51Kb Скачать
Описание (02.02.2009) 615
.1233603161 122,41Kb
25.09.09
615
.1233603161 122,41Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. halushka (halushka) 03.02.09 04:29
Плюс. 1.- оформление, 2.- простота.
2. - - (Rebelx) 03.02.09 10:50
вопросы:
реализована ли работа с таблицами, и в какой версии ворда это проверялось?
3. Андрей Крутских (K_A_O) 03.02.09 10:59
(2) Именно для работы с таблицами объект и хорош, поскольку имитируется обычный вывод в табличный документ, и доступно достаточно сложное оформление.
Я планировал только 2003 word, но работа с закладками не изменилась в 2007 - так что там тоже работает, 97, 2000 - не проверял :-)
4. - - (Rebelx) 03.02.09 11:04
так ты проверял работу с таблицами в 2003 и 2007?
Гномище; +1 Ответить 1
5. Андрей Крутских (K_A_O) 03.02.09 12:25
(4) проверял. ты попробуй запустить пример. там есть работа с таблицами.
6. - - (Rebelx) 03.02.09 12:34
(5) в обоих? я просто делал подобное, но нашел в разницу в поведении 2003 и 2007 ворда с таблицами. точно не скажу сейчас, в чем разница, но сделать одинаково для обоих не получилось
7. Андрей Крутских (K_A_O) 03.02.09 13:09
(6) да я тоже сталкивался. можно сказать что на сложных таблицах эта обработка проверена для 2003 ворда. но там заполнялись достаточно сложные договора.
Функция Вывести() имеет два варианта:
// если Уровень=0 - использует обычную вставку (метод Paste())
// если Уровень>0 - считаем, что работаем с таблицей и используется метод (PasteAppendTable())
Функция Вывести(Область,Уровень=0) экспорт
8. Гном Планетарный (Гномище) 30.03.09 10:13
что за фомат описания .р ? как его прочесть?
9. Андрей Крутских (K_A_O) 30.03.09 16:06
(8) странно изменилось расширение, это вообще-то pdf, сейчас попробую сменить
10. Alex_Sun (Alex_Sun) 23.06.09 10:11
А если мне надо вставить в документ ворда штрих код?!
11. dushelov (Душелов) 23.06.09 10:23
(10) Генеришь штрихкод, сохраняешь, как картинку и вставляешь в ворд.
12. dushelov (Душелов) 23.06.09 10:23
Либо внедряешь активХ объект в ворд.
13. Alex_Sun (Alex_Sun) 23.06.09 10:30
А есть приме с актив иксом? я ни под каким соусом не смог его вставить туда.
Мысль с картинкой очень интересна:).
14. dushelov (Душелов) 23.06.09 10:32
А что с примером? Тот же barcode.ocx, вставляем в шаблон ворда и работаем так же, как и из 1С-ки. Но тут тоже есть проблема - у других пользователей активХ могут быть заблокированы в ворде в целях безопасности.

Так что самый правильный вариант - картинка.
15. Alex_Sun (Alex_Sun) 23.06.09 10:38
Разблокируем это не проблема. Может есть пример с картинкой где бы подглядеть интерфейс с вордом
16. dushelov (Душелов) 23.06.09 10:40
17. Alex_Sun (Alex_Sun) 23.06.09 10:43
Уточню еще разок в 2007 вворде при попытке вставить любой их ШК типа актив баркод или 1с штрих код. В списке объектов его нету.
18. dushelov (Душелов) 23.06.09 10:52
Как минимум из другого приложения через буфер обмена...
19. Олег Каратаев (Kyrales) 24.06.09 09:52
Возможно ли как то это использовать с OpenOffice?
20. Андрей Крутских (K_A_O) 25.06.09 10:11
21. Олег Каратаев (Kyrales) 26.06.09 05:05
(20) очень бы хотелось. Вообще бы цены не было :)
22. Александр Тарасов (tarasoff) 08.07.09 08:06
(20) А есть в планах на реализацию вывода в OpenOffice?
23. Федор Программист (fedor40) 04.09.09 10:41
А как в Ворде объявлять области.
Например, где определять границы подвала?

ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
24. Федор Программист (fedor40) 04.09.09 10:49
Что за метод такой Параметры_Заполнить()? Нет в синтаксис помощнике.
ОбластьДетальныхЗаписей.Параметры_Заполнить(ВыборкаДетали);
25. Андрей Крутских (K_A_O) 06.09.09 12:32
(23), (24) Так вроде же все в описании написано
26. Андрей Крутских (K_A_O) 06.09.09 12:37
(23) Область – это закладка в Word
(24) Мне не хотелось создавать новый объект (форму) в обработке только для выполнения метода Заполнить(). Поэтому вместо "Параметры.Заполнить()" вызывается "Параметры_Заполнить()"
27. Федор Программист (fedor40) 07.09.09 07:34
С Закладками разобрался. Но вот новость. В обработки ничего не менял. Вывожу одну область ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Договор"); Все заполняется, но документ становится Альбомным.


28. Андрей Крутских (K_A_O) 07.09.09 10:04
(27) похоже в закладке сохранены параметры страницы, может там новый раздел есть.

Можно попробовать
Док.Вывести(ОбластьДетальныхЗаписей,0);
29. Федор Программист (fedor40) 12.09.09 10:58
Работает, но как обратиться к колонтитолу? Это не Заклазка в Ворде.
30. Андрей Крутских (K_A_O) 12.09.09 16:40
(29) Колонтитулы заполняются при установке параметров у документа.
Т.е. если в колотитуле есть шаблон "[Номер]" - должно сработать

Док.Параметры.Вставить("Номер","111")
Док.Подготовить();

Если не сработает можно посмотреть функцию Подготовить() в обработке. Именно там пытаются установиться колонтитулы.
31. Федор Программист (fedor40) 15.09.09 09:12
Ну ничего не получается.

Нужна простая процедура присвоения колонтитула.

Функция Подготовить() передает управление другой функции, та еще другой....
в конце FF.Execute( Ключ ,,,,,,,,, ВыбЗначение, 2)

Вот как мне ее применить к объекту Док = Init.ИнициализироватьДокумент();
Вот в чем вопрос.

Как взять и присвоить колотитул?


32. Федор Программист (fedor40) 15.09.09 09:46
Отрабатывает, но колонтитул не заполняет. Вообще Find только для текста документа, колонтитул туда не входит.

Замена = Док.Объект.Application.ActiveDocument.Content.Find;
Замена.Wrap = 1; //чтобы не писать каждый раз Find
Док.Вывести(ОбластьДетальныхЗаписей, 0);
Замена.Execute("ЮрАдресКонтрагента", , , , , , , , ,Выборка.Представление,2);





33. Андрей Крутских (K_A_O) 15.09.09 11:13
В функции Подготовить() заменяются шаблоны в областях:
CurrObject.Sections(1).Headers(1).Range
CurrObject.Sections(1).Footers(1).Range

Это и есть колонтитулы документа, у меня нормально срабатывает.
Но поскольку секций Sections может быть несколько - можно посмотреть в отладке в какой секции находятся колонтитулы.
Надо будет мне изменить и проверять в цикле.
34. Федор Программист (fedor40) 15.09.09 16:05
Все допер. Вот обращение к нижнему колонтитулу:

Замена = Док.Объект.Application.ActiveDocument.Content.Sections(1).Footers(1).Range.Find;
Замена.Execute("ЮрАдресКонтрагента", , , , , , , , ,Выборка.Представление,2);

Но документ все равно альбомный. Где это может настраиваться?
cargobird; +1 Ответить
35. Федор Программист (fedor40) 16.09.09 00:16
Решил вопрос. Последняя стр в шаблоне была альбомной и после заполнения из 1с весь документ становится альбомным.
36. Сергей Ожерельев (Поручик) 26.09.09 14:45
Спасибо автору, очень пригодилось. Как раз сейчас делаю печать договоров по утверждённой форме.
37. dfg kjn (zergey128) 06.10.09 16:28
Функция _ЗаменитьПараметр(FF, Знач Ключ, Знач ВыбЗначение)
	ВыбЗначение = СтрЗаменить(ВыбЗначение,Символы.ПС, "^p");
	// Чтобы обойти ограничение на 255 символов, делаем такой финт ушами 
	// Заменяем 230 символов и добавляем спец метку, которую заменяем на оставшиеся 
	Если (СтрДлина(ВыбЗначение) > 255) тогда 
		НовЗначение = Сред(ВыбЗначение,1,230) + "{{{continue_continue}}}"; 
//++++++++++++++	
               Если Сред(НовЗначение,230,1)="^" Тогда
			Сообщить("Ошибка преобразования апострофа ^ ! Необходимо изменить длину поля "+Ключ+", которое содержит:<"+НовЗначение+">");
		КонецЕсли;
//+++++++++++++++++
		// Если ничего не нашли то дальше можно не мучаться 
		Если НЕ _ЗаменитьПараметр(FF, Ключ, НовЗначение) тогда 
			return false ; 
		КонецЕсли ; 
		// Берем следующие 230 символов и дальше по рекурсии 
		return _ЗаменитьПараметр(FF,"{{{continue_continue}}}", Сред(ВыбЗначение,231)); 
	Иначе
		return FF.Execute( Ключ ,,,,,,,,, ВыбЗначение, 2);
	КонецЕсли ;
КонецФункции
...Показать Скрыть


эту функцию надо вот так дописать. потому как при разбиении строки если перед {{{continue_continue}}} попадется ^ т.е. получиться "ляляля^{{{continue_continue}}}" то ворд вывалит ошибку и весь вывод шаблона выпадет в исключение. быстрое решение - добавить/убрать пробел :)
38. Андрей Крутских (K_A_O) 12.06.10 15:40
39. Андрей Крутских (K_A_O) 13.06.10 09:42
40. Сергей Данилов (pencroff) 05.08.10 14:37
Рекомендую. Один вопрос.
Как изменить обработки что бы шаблон можно было хранить в конфигурации.
А то не удобно в файле.
Пробовал как АктивИкс. Ничего не вышло.
Подставлял полученный из макета в CurrObject
Функция ПрочитатьМакет (Объект, ИмяМакета) экспорт
	Макет = Объект.ПолучитьМакет(ИмяМакета);
	CurrObject = Макет.Получить();	
	Если CurrObject=Неопределено тогда
		Сообщить("Не удалось получить макет: " +Макет + Символы.ПС , СтатусСообщения.Внимание);
		возврат ложь;
	КонецЕсли ;
	ПозицияКурсора = CurrObject.Content.End-1;
	CurrRange = CurrObject.Content;
	возврат истина; 
КонецФункции
...Показать Скрыть

Но выводит только окно Word. Что посоветуете?
41. Андрей Крутских (K_A_O) 08.08.10 09:35
(40) может по простому, шаблон хранится как двоичный макет, сохраняется во временный файл и обрабатывается обычным образом.
42. Сергей Данилов (pencroff) 09.08.10 10:31
(41) Пока просто положил файл в общую папку. Думал может есть более элегантное решение работать просто в памяти. Спасибо.
43. Harley Davidson (HarleyDavidson) 27.09.11 20:23
44. MOHAX (MOHAX1905) 18.11.11 08:12
Спасибо большое. Отличное пособие для начала работы с вордом!
45. Алексей (ASoft) 26.11.11 11:42
46. Валентин Гуров (gurovvv) 06.12.11 14:23
Спасибо! Весьма удобно и просто! Познал азы работы с вордом из 1С.
47. Осипов Сергей (fixin) 06.12.11 14:45
Я тоже такое делал. Поэтому сразу дам совет - "спилите мушку", т.е. хотел сказать, совсем не нужно использовать закладки. Шаблоны редактируют "девочки", они не поймут что такое закладки.
Обычно секция - это одна строка табличной части. Вот и ставьте прямо в строке табличной части или шапки в квадратных скобках название секции и по ней идентифицируйте секцию. Дешево и сердито, если надо - стучите, скину код.
Может самому выложить подобное? ХЗ, надо подумать.
48. Андрей Крутских (K_A_O) 06.12.11 15:07
(47) Эту обработку я развивать не планировал, в случае прямой работы с rtf (http://infostart.ru/public/71345/) можно как закладки использовать, так и свои метки: квадратные скобки или фигурные, как в новых шаблонах 1С.
49. Евгений Языков (trudyaga) 16.12.11 16:04
Думаю пригодится в будущем. СПАСИБО.
50. arr arrr (need1cc) 07.01.12 19:17
51. Денис Зубарев (MeaTDeN) 10.01.12 21:45
52. Наталья (chadilla) 23.01.12 21:54
53. nanik nanik (nanik) 01.05.12 03:28
Спасибо, очень помогли Ваши комментарии по работе с колонтитулами.
54. Александр (Мощный) 24.04.13 23:57
(48) K_A_O, Спасибо большое, даст Бог поможет ваша обработка ускорить разработку.. Клиенту нужен Вердовский файл с договором, который бы он мог бы корректировать самостотельно, Ежли у вас строчки заполняются, значится все ок..
u_n_k_n_o_w_n; +1 Ответить
55. Юрий Ульянов (spy-83) 10.02.14 10:14
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа