Структура подчинённости

Опубликовал Эстер Коган (e.kogan) в раздел Печать - Печатные формы документов

Немного переписанная типовая обработка "Структура подчинённости". Отличается от типовой тем, что видит все подчинённые документы, а не только упомянутые в критерии отбора.

Легко интегрируется в любую из типовых конф 1С - как внешняя печатная форма и взамен типовой (в типовой добавляется только 1 строка перед открытием).

Полностью инкапсулирована.

Скачать файлы

Наименование Файл Версия Размер
-
.1233744150 17,79Kb
25.09.09
1128
.1233744150 17,79Kb 1128 Бесплатно

См. также

Добавить вознаграждение
Комментарии
1. Ёпрст (Ёпрст) 1012 04.02.09 14:01 Сейчас в теме
А почему бы не сдублировать их в коде обработки ?
2. Эстер Коган (e.kogan) 1816 04.02.09 14:06 Сейчас в теме
Некогда, увы. Обработку выложили для нескольких в ней срочно нуждающихся, а тянуть неизвестно сколько процедур и функций из буховских модулей совсем некогда.
3. Igоr Sаulеviсh (gutentag) 249 04.02.09 16:05 Сейчас в теме
У меня, почему-то, бухгалтерия(типовая), редакция (1.6.12.4) обработка выдает ошибку при открытии:
{ВнешняяОбработка.СтруктураПодчиненностиДополненная(371,40)}: Переменная не определена (ДополнительныйРАТ)
СтрокаДерева.ДокументПредставление = <<?>>ДополнительныйРАТ.ПредставлениеДокумента(рДокумент);
4. Эстер Коган (e.kogan) 1816 04.02.09 16:59 Сейчас в теме
Упс (((( И правда, это забыли убрать. Постараюсь сейчас выложить нормальный.
5. Артур Аюханов (artbear) 847 05.02.09 07:23 Сейчас в теме
А никто не видел/делал структуру подчиненности в виде универсального отчета/обработки - не привязанного к типовым конфам 1С ?
6. Эстер Коган (e.kogan) 1816 05.02.09 15:55 Сейчас в теме
А она должна работать, во всяком случае, на нашей маленькой самописной работает...
7. Артур Аюханов (artbear) 847 10.02.09 15:24 Сейчас в теме
О, спасибо. Проверю на своих конфах.
8. Артур Аюханов (artbear) 847 10.02.09 15:27 Сейчас в теме
(6) На своей с некоторыми добавками от типовых
{ВнешняяОбработка.СтруктураПодчиненностиДополненная(429,11)}: Процедура или функция с указанным именем уже определена (СообщитьОбОшибке)
Процедура <<?>>СообщитьОбОшибке(Знач ТекстСообщения, Отказ = Ложь, Заголовок = "", Знач Статус = Неопределено, ВызыватьИсключение = Истина) Экспорт
{ВнешняяОбработка.СтруктураПодчиненностиДополненная(469,9)}: Процедура или функция с указанным именем уже определена (СформироватьТекстСообщения)
Функция <<?>>СформироватьТекстСообщения(Знач ТекстСообщения) Экспорт

ЗЫ вроде в типовых также есть эти функции?
9. Артур Аюханов (artbear) 847 10.02.09 15:43 Сейчас в теме
А в остальном работает. Плюсую.
Спасибо.

У самого руки никак не доходили :(
10. Артур Аюханов (artbear) 847 10.02.09 15:45 Сейчас в теме
ОФФ
(7-9 +) прикольно посмотреть на время моих сообщений :)
7 - 15:02:37
8 - 15:02:05 (назад в прошлое)
9 - 15:02:33 - опять в будущее :)

ЗЫ да и время явно отличается от текущего. У меня счас 17.50 - 02 никак не монтируется :(
11. Эстер Коган (e.kogan) 1816 10.02.09 16:26 Сейчас в теме
Ну так добавьте к встроенной с отчёт СфоримрвоатьТекстСообщения букву р впереди и позаменяйте :)
12. Артур Аюханов (artbear) 847 11.02.09 09:09 Сейчас в теме
(11) Ну это понятно :)
Я тебе написал, чтобы твоя обработка еще чуток поуниверсальнее стала :)
13. Эстер Коган (e.kogan) 1816 11.02.09 10:59 Сейчас в теме
14. skiza (skiza) 22.07.09 12:14 Сейчас в теме
А как ее вызывать вместо типовой?
15. Эстер Коган (e.kogan) 1816 22.07.09 12:25 Сейчас в теме
(14) Написано же - как внешняя печатная форма.
16. skiza (skiza) 22.07.09 13:36 Сейчас в теме
и взамен типовой (в типовой добавляется только 1 строка перед открытием) ? не совсем понятно
17. Эстер Коган (e.kogan) 1816 22.07.09 13:40 Сейчас в теме
(16) Если вам нужно именно встроить её в типовую конфигурацию из-за наличия в ней нетиповых документов, то:
Модуль РаботаСДокументами
Процедура ПоказатьСтруктуруПодчиненностиДокумента(ДокументСсылка) Экспорт
	// Добавлено
	рПриоритетная=ВосстановитьЗначение("ДополненнаяСтруктураПодчиненностиПриоритетнееТиповой");
	Если ТипЗнч(рПриоритетная)=Тип("Булево") и рПриоритетная Тогда
		рОбработка=Обработки.СтруктураПодчиненностиДополненная.Создать();
		рОбработка.СсылкаНаОбъект=ДокументСсылка;
		рФорма=рОбработка.ПолучитьФорму("ФормаСтруктурыПодчиненности");
		рФорма.Открыть();
		Возврат;
	КонецЕсли;	
	// Добавлено
	
	ФормаСтруктурыПодчиненности = ПолучитьОбщуюФорму("ФормаСтруктурыПодчиненности");
	Если ФормаСтруктурыПодчиненности.Открыта() Тогда
		ФормаСтруктурыПодчиненности.Закрыть();
	КонецЕсли;
	ФормаСтруктурыПодчиненности.ДокументСсылка = ДокументСсылка;
	ФормаСтруктурыПодчиненности.Открыть();
	 
КонецПроцедуры
...Показать Скрыть
18. dindzilin@yandex.ru (dindzilin) 20.11.11 14:02 Сейчас в теме
Пригадилась, а то юзеры весь мозг вынесли...
19. Roman Tarasov (raym0n) 16.12.11 16:46 Сейчас в теме
Очень помогла на этапе моего становления 1с-программером.

Спасибо большое!
20. Петр Лунегов (pvlunegov) 95 23.06.14 08:42 Сейчас в теме
Большое спасибо за обработку, помогла и выручила в трудную минуту скоростного поиска ответа на вопрос - "Откуда брать информацию по подчиненности типовых документов".
21. Эстер Коган (e.kogan) 1816 26.06.14 15:47 Сейчас в теме
22. Константин Куликов (Светлый ум) 192 09.06.15 14:17 Сейчас в теме
Крутая штука +1
- это не просто печатная форма с со списком документов.
- это обработка которую можно добавить в дерево объектов и в документах поставить рядом с типовой,
получая при этом полноценный список подчиненных типовых и нетиповых документов (с сылками)

спасибо
TomskTNP; +1 Ответить
23. Олег Атлант-С (atlants_buh) 09.09.15 13:29 Сейчас в теме
Пробую загрузить обработку, выходит ошибка:
Внешняя обработка не может быть прочитана текущей версией программы.
Для какой версии эта обработка?
24. Эстер Коган (e.kogan) 1816 09.09.15 22:26 Сейчас в теме
(23) atlants_buh, да чуть ли не под 8.1 ещё. В конфигураторе открыть пробовали перед тем?
25. Aleksandr Karpov (kvaleksandr) 21.02.17 07:36 Сейчас в теме
(24) Огромное спасибо за обработку.

Заменять стандартную не стал, добавил дополнительно, т.к. надо всего для 4 документов такое отображение сделать. Галочка "Использовать заместо типовой" не работает.

Платформа 8.3 Конфигурация УПП 1.3.87.2 - полет нормальный.

Может кому пригодится как я ее вызывал

Сам вызов
ЯОбщийМодуль.ВызовПодключеннойВнешнейОбработки("Структура подчиненности дополненная",ЭтотОбъект.Ссылка);		


В общем модуле
Процедура ВызовПодключеннойВнешнейОбработки(ИмяОбработки, СсылкаНаОбъект) Экспорт	
	ТекОбработка = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОбработки);
    
    ДвоичныеДанные = ТекОбработка.ХранилищеВнешнейОбработки.Получить();
    	ИмяФайла = ПолучитьИмяВременногоФайла("erf");    
        ДвоичныеДанные.Записать(ИмяФайла);
        Обработка = ВнешниеОбработки.Создать(ИмяФайла);
        ФормаОбработки = Обработка.ПолучитьФорму();
		ФормаОбработки.СсылкаНаОбъект = СсылкаНаОбъект;
        ФормаОбработки.Открыть();	
КонецПроцедуры
...Показать Скрыть
26. Эстер Коган (e.kogan) 1816 21.02.17 16:58 Сейчас в теме
(25) Чтобы использование вместо типовой работало, обработка должна быть вставлена в конфигураторе и в типовой должен стоять перехватчик.
Рада, что пригодилось :)