gifts2017

Структура подчинённости

Опубликовал Эстер Коган (e.kogan) в раздел Печать - Печатные формы документов

Немного переписанная типовая обработка "Структура подчинённости". Отличается от типовой тем, что видит все подчинённые документы, а не только упомянутые в критерии отбора.

Легко интегрируется в любую из типовых конф 1С - как внешняя печатная форма и взамен типовой (в типовой добавляется только 1 строка перед открытием).

Полностью инкапсулирована.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1233744150 17,79Kb
25.09.09
1042
.1233744150 17,79Kb 1042 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Епрст (Ёпрст) 04.02.09 14:01
А почему бы не сдублировать их в коде обработки ?
2. Эстер Коган (e.kogan) 04.02.09 14:06
Некогда, увы. Обработку выложили для нескольких в ней срочно нуждающихся, а тянуть неизвестно сколько процедур и функций из буховских модулей совсем некогда.
3. Igоr Sаulеviсh (gutentag) 04.02.09 16:05
У меня, почему-то, бухгалтерия(типовая), редакция (1.6.12.4) обработка выдает ошибку при открытии:
{ВнешняяОбработка.СтруктураПодчиненностиДополненная(371,40)}: Переменная не определена (ДополнительныйРАТ)
СтрокаДерева.ДокументПредставление = <<?>>ДополнительныйРАТ.ПредставлениеДокумента(рДокумент);
4. Эстер Коган (e.kogan) 04.02.09 16:59
Упс (((( И правда, это забыли убрать. Постараюсь сейчас выложить нормальный.
5. Артур Аюханов (artbear) 05.02.09 07:23
А никто не видел/делал структуру подчиненности в виде универсального отчета/обработки - не привязанного к типовым конфам 1С ?
6. Эстер Коган (e.kogan) 05.02.09 15:55
А она должна работать, во всяком случае, на нашей маленькой самописной работает...
7. Артур Аюханов (artbear) 10.02.09 15:24
О, спасибо. Проверю на своих конфах.
8. Артур Аюханов (artbear) 10.02.09 15:27
(6) На своей с некоторыми добавками от типовых
{ВнешняяОбработка.СтруктураПодчиненностиДополненная(429,11)}: Процедура или функция с указанным именем уже определена (СообщитьОбОшибке)
Процедура <<?>>СообщитьОбОшибке(Знач ТекстСообщения, Отказ = Ложь, Заголовок = "", Знач Статус = Неопределено, ВызыватьИсключение = Истина) Экспорт
{ВнешняяОбработка.СтруктураПодчиненностиДополненная(469,9)}: Процедура или функция с указанным именем уже определена (СформироватьТекстСообщения)
Функция <<?>>СформироватьТекстСообщения(Знач ТекстСообщения) Экспорт

ЗЫ вроде в типовых также есть эти функции?
9. Артур Аюханов (artbear) 10.02.09 15:43
А в остальном работает. Плюсую.
Спасибо.

У самого руки никак не доходили :(
10. Артур Аюханов (artbear) 10.02.09 15:45
ОФФ
(7-9 +) прикольно посмотреть на время моих сообщений :)
7 - 15:02:37
8 - 15:02:05 (назад в прошлое)
9 - 15:02:33 - опять в будущее :)

ЗЫ да и время явно отличается от текущего. У меня счас 17.50 - 02 никак не монтируется :(
11. Эстер Коган (e.kogan) 10.02.09 16:26
Ну так добавьте к встроенной с отчёт СфоримрвоатьТекстСообщения букву р впереди и позаменяйте :)
12. Артур Аюханов (artbear) 11.02.09 09:09
(11) Ну это понятно :)
Я тебе написал, чтобы твоя обработка еще чуток поуниверсальнее стала :)
13. Эстер Коган (e.kogan) 11.02.09 10:59
14. skiza (skiza) 22.07.09 12:14
А как ее вызывать вместо типовой?
15. Эстер Коган (e.kogan) 22.07.09 12:25
(14) Написано же - как внешняя печатная форма.
16. skiza (skiza) 22.07.09 13:36
и взамен типовой (в типовой добавляется только 1 строка перед открытием) ? не совсем понятно
17. Эстер Коган (e.kogan) 22.07.09 13:40
(16) Если вам нужно именно встроить её в типовую конфигурацию из-за наличия в ней нетиповых документов, то:
Модуль РаботаСДокументами
Процедура ПоказатьСтруктуруПодчиненностиДокумента(ДокументСсылка) Экспорт
	// Добавлено
	рПриоритетная=ВосстановитьЗначение("ДополненнаяСтруктураПодчиненностиПриоритетнееТиповой");
	Если ТипЗнч(рПриоритетная)=Тип("Булево") и рПриоритетная Тогда
		рОбработка=Обработки.СтруктураПодчиненностиДополненная.Создать();
		рОбработка.СсылкаНаОбъект=ДокументСсылка;
		рФорма=рОбработка.ПолучитьФорму("ФормаСтруктурыПодчиненности");
		рФорма.Открыть();
		Возврат;
	КонецЕсли;	
	// Добавлено
	
	ФормаСтруктурыПодчиненности = ПолучитьОбщуюФорму("ФормаСтруктурыПодчиненности");
	Если ФормаСтруктурыПодчиненности.Открыта() Тогда
		ФормаСтруктурыПодчиненности.Закрыть();
	КонецЕсли;
	ФормаСтруктурыПодчиненности.ДокументСсылка = ДокументСсылка;
	ФормаСтруктурыПодчиненности.Открыть();
	 
КонецПроцедуры
...Показать Скрыть
18. dindzilin@yandex.ru (dindzilin) 20.11.11 14:02
Пригадилась, а то юзеры весь мозг вынесли...
19. Roman Tarasov (raym0n) 16.12.11 16:46
Очень помогла на этапе моего становления 1с-программером.

Спасибо большое!
20. Петр Лунегов (pvlunegov) 23.06.14 08:42
Большое спасибо за обработку, помогла и выручила в трудную минуту скоростного поиска ответа на вопрос - "Откуда брать информацию по подчиненности типовых документов".
21. Эстер Коган (e.kogan) 26.06.14 15:47
22. Константин Куликов (Светлый ум) 09.06.15 14:17
Крутая штука +1
- это не просто печатная форма с со списком документов.
- это обработка которую можно добавить в дерево объектов и в документах поставить рядом с типовой,
получая при этом полноценный список подчиненных типовых и нетиповых документов (с сылками)

спасибо
TomskTNP; +1 Ответить
23. Олег Атлант-С (atlants_buh) 09.09.15 13:29
Пробую загрузить обработку, выходит ошибка:
Внешняя обработка не может быть прочитана текущей версией программы.
Для какой версии эта обработка?
24. Эстер Коган (e.kogan) 09.09.15 22:26
(23) atlants_buh, да чуть ли не под 8.1 ещё. В конфигураторе открыть пробовали перед тем?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа