gifts2017

Напоминалка дня рождения по ИНН

Опубликовал Алексей (stalker) в раздел Отчеты - Разное

Используя конфигурацию для сельского хозяйства в Украине, понадобилась напоминалка о днях рождения сотрудников. В самой конфигурации не предусмотрено поле "День рождения", но зато есть ИНН, который и был использован для этой цели. Не судите строго, это первая разработка, выложенная мной на Ваш сайт.

Используя конфигурацию для сельского хозяйства в Украине, понадобилась напоминалка о днях рождения сотрудников. В самой конфигурации не предусмотрено поле "День рождения", но зато есть ИНН, который и был использован для этой цели.

Не судите строго, это первая разработка, выложенная мной на Ваш сайт.

Скачать файлы

Наименование Файл Версия Размер
Напоминалка об именинниках 101
.1238583304 40,50Kb
25.09.09
101
.1238583304 40,50Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Serj (Serj1C) 02.04.09 07:40
7.7 у меня нету, но как можно было использовать ИНН, когда в нем данные хранятся?
2. Сергей Старовойтов (AVARY) 02.04.09 08:56
to (1) Там вот такой алгоритм
Код
   НомерДня = Число(Лев(Сотрудник.ИНН,5)); ДатаРождения="";
   Для н = 1900 По Число(Прав(Формат(Дата1,"ДДДММГГГГ"),4)) Цикл
      Ном = НомерДня - НомерДняГода("31.12."+Строка(н));
      Если Ном > 0 Тогда
         НомерДня = Ном;
      Иначе
         Для ч = 1 По 12 Цикл
            НомерДняМес = ДатаЧисло(КонМесяца("01."+Прав("0"+Строка(ч),2)+"."+н));
            Если НомерДня > НомерДняМес Тогда
               НомерДня = НомерДня - НомерДняМес;
            Иначе
               ДатаРождения=строка(Прав("0"+НомерДня,2)+"."+Прав("0"+ч,2));   
               ГодРождения = Число(н);
               Прервать;
            КонецЕсли;
         КонецЦикла;
         Прервать;
      КонецЕсли;
   КонецЦикла;          
Показать полностью
3. Алексей Плутенко (Noy) 02.04.09 09:51
(2) Замени на
ДатаРождения=Дата("01.01.1900")+Число(Лев(Сотрудник.ИНН),5);
4. vladal (Vladal) 02.04.09 10:00
(0) - Взгляните сюда:
Проверка данных сотрудников (пол, дата рождения) по ИНН (для Украины)
http://www.infostart.ru/projects/3680/

Проверка ИНН для Украины
http://www.infostart.ru/projects/1573/

С первой обработкой Вы можете еще и пол проверить, и корректность введенного ИНН
5. Алексей (alexqc) 02.04.09 12:35
Алгоритм ИНН - 5 первых цифр дата начиная с 01/01/1900, 4 следующих - порядковый номер, при чем четный для Ж и нечетный для М - это известно еще со времени введения ИНН, и так сказать в открытом доступе. Гораздо интереснее 10-я цифра, контрольная. Вот она считается по "секретному" алгоритму, который никто не знает :). Хотя лично мне, например, это странно: таким образом что, хотят от каких-то мошенников защитится? Так это довольно спорная защита: во-первых, "кому надо - тот знает", во-вторых - могут просто надыбать базу с готовыми ИННами.

Так вот, может кто знает алгоритм контрольной суммы?
6. Алексей Плутенко (Noy) 02.04.09 12:41
Присоединяюсь к вопросу в (5)
7. sergeante (sergeante) 02.04.09 15:07
8. Алексей (alexqc) 02.04.09 15:58
(7) ....Во блин, какой я идиот, пояндексить не додумался...

На самом деле, тут не рулит ни яндекс, ни гугль :) . Это распространенное заблуждение: спрашиваешь про ИНН _физлица в Украине_ - а тебе в ответ - ИНН _организации в России_.