gifts2017

[ПОЛЕЗНЯШКА] Указание номера платежно-расчетного документа в счет-фактуре выданном

Опубликовал Сергей (Che) Коцюра (CheBurator) в раздел Программирование - Практика программирования

Типовая ТиС 7.7 Руководство к исправлению типовой печатной формы для указания номера(ов) платежно-расчетного(ых) документа(ов) в выданном счет-фактуре.

ст.169 НК
5. В счете-фактуре, выставляемом при реализации товаров (работ, услуг), передаче имущественных прав, должны быть указаны:
4) номер платежно-расчетного документа в случае получения авансовых или иных платежей в счет предстоящих поставок товаров (выполнения работ, оказания услуг);

.
основной вопрос: как ПРАВИЛЬНО и на основании чего трактовать данный п.4?
а) номер указывается только в СЧФ на аванс?
б) номер указывается в СЧФ отгрузки, по которым зачтены авансы?

.

Для нас, неспециалистов, в области БУ, НУ, налогового законодательства и прочих "нормативно-правовых" документов становится очевидно: что трактуют все как хотят. Чья версия правильнее - решать не нам (в конфликтных ситуациях решает только суд?). Общее правило такое: налогоплательщики трактуют "по минимуму", налоговики - "по макисмуму", т.е. "приплетая" то, что явно в НК не указано, обосновывая это фиг знает чем. Например, следующая подборочка:

http://www.pravcons.ru/publ09-02-05-1.php
http://www.r59.nalog.ru/document.php?id=136370&topic=imm59
http://www.gazeta-unp.ru/doc.htm?id=230

. делать будем просто - как поступает много бухгалтеров, по принципу: больше бумаги - чище жопа - будем указывать ВСЁ.

Необходимые действия.

1. Берем внешнюю печатную форму типовой формы счет-фактуры выданного.

2. В начало модуля внедряем следующую функцию:


Функция глПолучитьСписокПлатежноРасчетныхДокументов(Докум)

   Если Докум.Проведен() = 0
   Тогда Возврат "№ от";
   КонецЕсли;

   Если Докум.Вид() <> "СчетаФактурыВыданные"
   Тогда Возврат "№ от";
   КонецЕсли;

   локТЗ = СоздатьОбъект("ТаблицаЗначений");
   локТЗ.НоваяКолонка("НомерДок" ,"Строка");
   локТЗ.НоваяКолонка("ДатаДок" ,"Дата");

   СторнированАванс = Перечисление.КодыОпераций.СторнированАванс;

   РегП = СоздатьОбъект("Регистр.Покупатели");
   РегП.ВыбратьДвиженияДокумента(Докум.ДокОснование);
   Пока РегП.ПолучитьДвижение()=1
   Цикл
     Если РегП.КодОперации <> СторнированАванс
     Тогда Продолжить;
     КонецЕсли;

     ПлРаДок = РегП.КредДокумент;
     локТЗ.НоваяСтрока();
     Если ПлРаДок.Вид()="ПКО"
     Тогда //кассовые чеки
       локТЗ.НомерДок = СокрЛП(ПлРаДок.НомерДок);
       локТЗ.ДатаДок = ПлРаДок.ДатаДок;
     Иначе //строки выписки банка и доки корректировки долгов...
       Попытка
         локТЗ.НомерДок = СокрЛП(ПлРаДок.НомерДокВходящий);
         локТЗ.ДатаДок = ПлРаДок.ДатаДок;
       Исключение
         ЗаписьЖурналаРегистрации("глПолучитьСписокПлатежноРасчетныхДокументов(): ПОПЫТКА: ошибка "+ОписаниеОшибки(),,,5);
         локТЗ.УдалитьСтроку(локТЗ.КоличествоСтрок());
       КонецПопытки; 
     КонецЕсли;
   КонецЦикла;
   

 

   Если локТЗ.КоличествоСтрок()=0
   Тогда Возврат "№ --- от ---"
   КонецЕсли; 

 

   локТЗ.Свернуть("ДатаДок,НомерДок",);
   локТЗ.Сортировать("ДатаДок,НомерДок");

   Результат = "";
   локТЗ.ВыбратьСтроки();
   Пока локТЗ.ПолучитьСтроку() = 1
   Цикл Результат = Результат+РазделительСтрок+"№"+локТЗ.НомерДок+" от "+локТЗ.ДатаДок;
   КонецЦикла;
   Результат = СтрЗаменить(СокрЛП(Результат),РазделительСтрок,",");
   Возврат Результат;

КонецФункции //глПолучитьСписокПлатежноРасчетныхДокументов()

.

Что делает данная функция: по документу-основанию счет-фактуры собирает записи по зачету авансов по регистру взаиморасчетов с покупателями, для ПКО выбирает номер и дату чека, для прочих кредитных доков - входящие номера и формирует результирующую строку пл.-расчетных документов через зпт.

.

далее: ищем процедуру типа

Процедура ПодготовитьРеквизитыШапки(Докум, Рекв)

определяем в ней оператор типа

Рекв.ДобавитьЗначение(Шаблон("К платежно-расчетному документу...

 

и модифицируем этот оператор чтобы он выглядел так:

Рекв.ДобавитьЗначение(Шаблон("К платежно-расчетному документу [глПолучитьСписокПлатежноРасчетныхДокументов(Докум)]"), "ПоДокументу");

 .

В общем и главном - это все. В кончном итоге в счет-фактуре получаем что-то похожее на это: "К платежно-расчетному документу №566 от 14.09.09". В случае зачета нескольких авансов - реквизиты будут перечислены через запятую.

.

В данном материале не обсуждаем правильность/неправильность трактовок НК и правильность предложенного выше решения... Также никоим образом здесь я не буду обсуждать варианты определения платежно-расчетного документа на основании структуры подчиненности. Причины (кому охота) могут почитать здесь

.

В заключение можно отметить, кто хочет сэкономить на бумаге - может воспользоваться следующими соображениями: ВАС РФ разрешил не указывать в счете-фактуре номер платежки, если товары оплачены и отгружены в одном периоде. Покупатель оплатил товары, и в том же квартале продавец произвел отгрузку. В таком случае перечисленные суммы нельзя считать авансом. Значит, заполнять строку 5 счета-фактуры не обязательно. Комментируемое постановление Президиума ВАС РФ дополняет сложившуюся в пользу компаний арбитражную практику. (ПОСТАНОВЛЕНИЕ ПРЕЗИДИУМА ВЫСШЕГО АРБИТРАЖНОГО СУДА РФ от 10.03.09 № 10022/08) 

Скачать файлы

Наименование Файл Версия Размер
- 42
.1253195591 34,87Kb
23.07.13
42
.1253195591 34,87Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Валерий (VV) 17.09.09 20:08
2. Сергей (Che) Коцюра (CheBurator) 17.09.09 20:12
(1) спсб за теплое слово...
3. Александр Шишкин (Шёпот теней) 17.09.09 20:13
... краток .... и... однозначен ...

... ну А про крАсноречивость и обрАзность сравнений и совсем "песня" ...

... однако "авАтар" - что-то новенькое ... ? ... !

... вОт ...
4. Валерий (VV) 17.09.09 20:14
да я сам когда-то делал нечто подобное, но востребовано не было, на раз только.
5. Александр Венгер (venger) 17.09.09 21:50
6. Сергей (Che) Коцюра (CheBurator) 17.09.09 22:03
(5) так я эту картинку регулярно рассылаю по персоналу офиса...
7. Александр Рытов (Арчибальд) 18.09.09 08:44
Я так перечень не стал формировать. Больше одного аванса у нас встречается настолько редко...
8. Игорь Исхаков (Ish_2) 18.09.09 13:05
(6) Я извиняюсь.
Выражение "Больше бумаги - чище жопа" - народное ? Или автор Чебуратор ?
9. Сергей (Che) Коцюра (CheBurator) 18.09.09 13:21
(8) Слова - народные, музыка - моя.
10. Игорь Исхаков (Ish_2) 18.09.09 13:43
Правильно ли я понял , что если документ печатался дважды в разное время,
то позиция " К платежно-расчетному документу " , возможно , будет заполнена разными значениями (некоторые документы были перепроведены или удалены). Так ?
11. Сергей (Che) Коцюра (CheBurator) 18.09.09 16:12
Да, правильно понял.
При отсутствии порядка в работе - гарантий нет никаких.
В принципе ничто не мешаетпри распечатке "зафиксировать" вычисленное значение и при повторной печати использовать его... но, опять же, лопустим зафиксировались номера авансовых платежей, при повторной печати - использовать их - можно и налететь - если выяснится, что какой-то авансовый платеж был введен ошибочно и его удалили - а в распечатке повторной - он остался...
12. Татьяна Малова (tanya1605) 15.03.12 13:53
а для новой счет-фактуры 2012 года, что надо сделать, чтобы это работало?
13. zavsom1 zavsomovich (zavsom) 25.07.13 16:16
а для бухгалтерии где? Мне счас надо то же самое, но для бухгалтерии 7.7 - в 8.2 это реализовано.
14. Сергей (Che) Коцюра (CheBurator) 27.07.13 00:32
(13) Для бухии это немножко посложнее будет, так как авансы учитываются в "куче" на 62.2 (и их зачет) не раскладываясь, на кредитные-партионные доки. В принципе, выдрать кусок алгоритма из документа "формирование книги покупок/продаж" в части определения авансовых СЧФ, но мне это делать лениов, потому как а) неинтересно и б) по московским ставкам вы мне вряд ли заплатите ;-)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа