gifts2017

Использование сборок .NET в 1С 7.x b 8.x. Создание внешних Компонент.

Опубликовал Сергей Смирнов (Serginio) в раздел Программирование - Внешние компоненты

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

Также добавлена возможность использования внешних событий в 1С, в том числе примеры обмена сообщениями по TCP/IP и Работа со сканером ШК, события отслеживание изменений в директории. 
Примеры использование сборок для подключения к Вэб - сервисам, не поддерживаемые 1С. Использование конфигурационных файлов. 

Реализацию ВК внутри сборки для получения Глобального контекста. Использование для установки владельца окна формы главного окна 1С,
вызов внешнего события, использование методов глобального контекста.
Так же добавил возможность показать окно семерки созданное через Новый COMОбъект("V77.Application");

Добавил динамическую компиляцию класса обертки для использования .Net событий через ДобавитьОбработчик или ОбработкаВнешнегоСобытия Статья по их использованию лежит здесь http://infostart.ru/public/417830/
Реализация 1C Messenger описанного здесь http://infostart.ru/public/434771/
Использование классов .Net в 1С для новичков http://infostart.ru/public/448668/
Быстрое создание Внешних Компонент на C#. Примеры использования Глобального Контекста, IAsyncEvent, IExtWndsSupport, WinForms и WPF
http://infostart.ru/public/457898/
.Net в 1С. Примеры использования HTTPClient, AngleSharp. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д http://infostart.ru/public/466052/
.Net в 1С. На примере использования HTTPClient,AngleSharp.Удобный парсинг сайтов с помощью библиотеки AngleSharp в том числе с авторизацией аля JQuery с использованием CSS селекторов. http://infostart.ru/public/466196/
Так же статья invertercant 
Строка в дату. Универсальное решение. Применение NetObjetToIDispatch45 http://infostart.ru/public/434345/
.Net в 1С. На примере использования HTTPClient,AngleSharp.Удобный парсинг сайтов с помощью библиотеки AngleSharp в том числе с авторизацией аля JQuery с использованием CSS селекторов. http://infostart.ru/public/466196/

Кроссплатформенное использование классов .Net в 1С через Native ВК. Или замена COM на Linux http://infostart.ru/public/534901/

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM объекты которые можно использовать в 1С. Достигается это путем создания класса реализующим методы интерфейса

IReflect publi cclass AutoWrap : IReflect

Внутри него есть метод который оборачивает объекты не поддерживаемые в 1С в экземпляр класса AutoWrap.

Для облегчения работы с этим классом создан другой класс NetObjectToIDispatch

У него есть следующие методы

public object ПолучитьТип(string type)

Получает тип используя типы загруженных сборок полученный объект позволяет использовать статические методы класса

и члены перечислений примеры взятые отсюда

 http://www.forum.mista.ru/topic.php?id=664174#62

http://dev.mista.ru/topic.php?id=686516

Пример отправки письма по протоколу Ssl

врап=новый COMОбъект("NetObjectToIDispatch45");

            smtp = "smtp.yandex.ru";
            login = "XXXXX@yandex.ru";
            password = "XXXXXXX";
            Кому = "XXXXXXX@YYYYYYYY.ru";
            Port=25;

            mail = врап.СоздатьОбъект("System.Net.Mail.SmtpClient",smtp, Port);

            mail.EnableSsl = true;
            mail.UseDefaultCredentials = false;
            mail.Credentials = врап.СоздатьОбъект("System.Net.NetworkCredential",login, Password);
 
            mail.DeliveryMethod = Врап.ПолучитьТип("System.Net.Mail.SmtpDeliveryMethod").Network;

            Message = врап.СоздатьОбъект("System.Net.Mail.MailMessage");
            MailAddressType= Врап.ПолучитьТип("System.Net.Mail.MailAddress");
            Message.From = врап.СоздатьОбъект(MailAddressType,login);
            Message.To.Add(врап.СоздатьОбъект(MailAddressType,Кому));
            Message.Subject = "Тема Тест отправки почты SSL";
            Message.IsBodyHtml = true;
            Message.Body = "Тело Тест отправки почты SSL";

            mail.Send(Message);//отправка

            Message.Dispose();
            mail.Dispose();

Но есть один минус: для типа нельзя вызвать методы типа. Для этого существует метод

public object ТипКакОбъект(object Тип)

из которого можно использовать методы и свойства Type (Например, AssemblyQualifiedName)

public object СоздатьОбъект(object Тип, paramsobject[] args)

Создает объект по типу или по строке, используя параметры, которые можно перечислять через запятую. Например

сервер=врап.СоздатьОбъект(тип,парам1,парам2);

public Object ChangeType(string type, object value)

Используя для преобразования типа в нужный тип. В C# используется перегрузка по параметрам. В .Net для чисел много типов, а  1С только один тип.

public object ПолучитьИнтерфейс(object obj, string InterfaseName)

получить интерфейс  объекта.

public object ЗагрузитьСборку(string ПутьКСборке)

загружает сборку и возвращает ссылку на нё.

К сожалению, иногда не все методы выполняются. Например ToArray() для List

Или методы с параметром типа GUID (сам метод выполняется, но при передаче результата в 1С выдается ошибка «типы не совпадают» )

Для этого добавлен метод

public object ВыполнитьМетод(object obj, string ИмяМетода, params object[] args)

И вызов из 1С

//Ком=ЗагрузкаComОбъекта.ЗагрузитьОбъект(ИмяФайла,стр.Гуид); ошибка  типа
                 Ком=Врап.ВыполнитьМетод(ЗагрузкаComОбъекта,"ЗагрузитьОбъект",ИмяФайла,стр.Гуид);
// Выполняется без ошибок

В Net особенно в WCF активно используются конфигурационные файлы.

Для использования их в 1С можно создать такой файл в директории запускаемой программы под именем ИмяЗапускаемойПрограммы.exe.config, например

C:\Program Files (x86)\1Cv77\BIN\1cv7s.exe.config

Или

C:\Program Files (x86)\1cv8\8.3.4.317\bin\1cv8.exe.config

Иногда стоит заменить этот файл на другой. Для этого есть метод

 ЗаменитьConfigFile(string имяФайла)

Если имяФайла=”” тогда берется файл

 typeof(NetObjectToIDispatch45).Assembly.Location + ".config"

Как пример показано программное изменение настроек

УстановитьDefaultProxy()

Другие методы созданы для отладки.

Также заложена возможность использования итераторов в 1С, например

рез= сервер.GetForms("Ваяся Пупкин");
Для каждого стр  Из рез Цикл
   сообщить(стр)
КонецЦикла;

Для использования в 1С 7.7 предусмотрено установка УстЭтоСемерка() так как в ней не поддерживается беззнаковые, Decimal и ограничена DateTime без времени.

Приведены примеры для 1С 7.7 и 8.3

Использующие сборку для доступа к Веб Сервису

http://www.morpher.ru/WebServices/Morpher.asmx

Использующие загрузку сборок, замену м модификацию конфигурационных файлов.

Вы можете создавать любые сборки или использовать стандартные библиотеки без регистрации.

NestNet45.dll для тестирования 4.5 TestWebServices.dll для тестов 2.0

Также добавлена возможность получения событий в 1С.

Для этого нужно создать сборку в которой создать делегаты и события

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Runtime.InteropServices;

using System.Windows.Forms;

using System.Threading;

using System.Reflection;

namespace NetObjectToIDispatch45

{

   [ComVisible(true)]

    [InterfaceType(ComInterfaceType.InterfaceIsIDispatch)]

    [Guid("33B45C9D-1AED-41F9-8880-36AB6AE84749")]

   

public interface IEventFor1C

    {

        [DispId(0x60020000)]

  void Событие();

        [DispId(0x60020001)]

 void СобытиеСПараметром(object value);

    }

    [ComVisible(true)]

    [ClassInterface(ClassInterfaceType.AutoDual)]

    [Guid("62F8156C-13B9-4484-B152-82023243E1D3")]

    [ComSourceInterfaces(typeof(IEventFor1C))]

 public class ClassForEvent1C : System.Windows.Forms.UserControl

    {

        [ComVisible(false)]

 public delegate void Событие_Delgate();

 public delegate void СобытиеСПараметром_Delgate(object value);

public object Объект;

 private SynchronizationContext Sc;

public ClassForEvent1C(object Объект,String СобытиеОбъекта,bool ЕстьПараметр=false)

        {

  this.Объект = Объект;

  bf = BindingFlags.DeclaredOnly | BindingFlags.Public | BindingFlags.NonPublic | BindingFlags.Instance;

 EventInfo ei = Объект.GetType().GetEvent(СобытиеОбъекта, bf);

 if (ЕстьПараметр)

            ei.AddEventHandler(Объект,new System.Action(ВнешнееСобытие));

   else

            ei.AddEventHandler(Объект,new System.Action<object>(ВнешнееСобытиеСПараметром));

  SynchronizationContext.SetSynchronizationContext(newWindowsFormsSynchronizationContext());

            Sc =SynchronizationContext.Current;

        }

     

 public event Событие_Delgate Событие;

 public event СобытиеСПараметром_Delgate СобытиеСПараметром;

private void ВнешнееСобытие()

        {

if (this.Событие != null) //Событие();

              Sc.Send(d => Событие(),null);

       }

     

private void ВнешнееСобытиеСПараметром(object value)

        {

if (this.СобытиеСПараметром != null) //Событие();

                Sc.Send(d => СобытиеСПараметром(AutoWrap.ОбернутьОбъект(value)), null);

        }

    }

}

Использование в 1С

Перем ОбъектССобытием;
Процедура ТестСобытияНажатие(Элемент)
врап=новый COMОбъект("NetObjectToIDispatch45");
Сборка=врап.загрузитьСборку(ИмяФайлаСборки); //ПроектИспользованияДелегатов.dll
тип=Сборка.GetType("ПроектИспользованияДелегатов.КлассДляВнешнихСобытий");

ОбъектССобытием=врап.СоздатьОбъект(Тип,КаталогДляОтслеживанияИзменений);
Событие=Врап.ПолучитьОбъектДляСобытий(ОбъектССобытием,"Событие");
СобытиеПереименования=Врап.ПолучитьОбъектДляСобытий(ОбъектССобытием,"СобытиеПереименованияФайла");

ДобавитьОбработчик Событие.Событие, ПриИзмененииДиректории;
ДобавитьОбработчик СобытиеПереименования.Событие, ПриПереименованииФайла;

  КонецПроцедуры

  Процедура ПриИзмененииДиректории()
      Сообщить(ОбъектССобытием.ИзмененныйФайл);
  КонецПроцедуры

  Процедура ПриПереименованииФайла()
      Сообщить(ОбъектССобытием.ПереименованныйФайл);
  КонецПроцедуры

Так же добавил сборку для обмена сообщениями по TCP/IP и сканера Штрих кода

В сборке ОбменПоTCPIP., при этом данные сжимаются GZip ом.

Пример использования на сервере

Функция СоздатьСерверTCP(Врап)

      Если не ЗначениеЗаполнено(ИмяФайлаСборки) Тогда
   вызватьИсключение   "Не выбрано Имя Файла Сборки"
   
КонецЕсли;


     врап=новый COMОбъект("NetObjectToIDispatch45");
ФайлСборки=ИмяФайлаСборки;//"d:\MyPrograms\Test\ОбменПоTCPIP\ОбменПоTCPIP\bin\Debug\ОбменПоTCPIP.dll";
Сборка=врап.загрузитьСборку(ФайлСборки); //ПроектИспользованияДелегатов.dll
тип=Сборка.GetType("TCPConnectTo1C.TCPConnector");

СерверTCP=врап.СоздатьОбъект(Тип);
возврат   СерверTCP

  КонецФункции // СоздатьTCP()

  Процедура ЗапуститьСерверTCPIPНажатие(Элемент)
      // Вставить содержимое обработчика.
      перем Врап;
СерверTCP=СоздатьСерверTCP(Врап);

  Событие=Врап.ПолучитьОбъектДляСобытийСПараметром(СерверTCP,"ПришлоСообщениеПоTCP");

ДобавитьОбработчик Событие.СобытиеСПараметром, ПолучениеДанныхПоTCP;
СерверTCP.ОткрытьАйПиПортСНомеромПорта(6891);

ЭлементыФормы.ОтправитьКоманду.Видимость=ложь;

КонецПроцедуры

Процедура ПолучениеДанныхПоTCP(Данные)
Сообщить("Команда="+Данные.Команда);
Сообщить("Данные="+Данные.Данные);
Сообщить("ЕстьОтвет="+Данные.ЕстьОтвет);

Если Данные.ЕстьОтвет Тогда
Ответ="Ответ на команду "+Данные.Команда+"
|Данные "+Данные.Данные+"
|ВремяНаСервере="+XmlСтрока(ТекущаяДата());
СерверTCP.Ответить(Ответ);


КонецЕсли;

КонецПроцедуры


На Клиенте

Процедура ОтправитьКомандуНажатие(Элемент)
перем Врап;

    КлиентTCP=СоздатьСерверTCP(Врап);

    ServerAdress="127.0.0.1";
    порт=6891;
    Команда="Тест Отправки Сообщения";
    ДанныеДляКоманды=XmlСтрока(ТекущаяДата());

    ЕстьОтвет=истина;
    ЗакрытьСоединение=истина;
    ОшибкаСоединения=false;

    резулт=КлиентTCP.ОтправитьКоманду(ServerAdress,порт,Команда,ДанныеДляКоманды,ЕстьОтвет,ЗакрытьСоединение);
    Сообщить(резулт.Данные);
        Если резулт.ОшибкаСоединения Тогда
            СтрОшибки="ОшибкаСоединения
            |"+резулт.Данные;
        Предупреждение(СтрОшибки);
        КонецЕсли;
КонецПроцедуры

И добавлена работа со Сканером ШК. К сожалению проверить его работу не могу, ввиду отсутствия сканера

Процедура ОткрытьПортСканераНажатие(Элемент)
    перем Врап;
    // Вставить содержимое обработчика.
    НомерПорта=0;
    Если не ВвестиЧисло(НомерПорта,"Введите номе COM порта",4,0) Тогда
        возврат
    КонецЕсли;
     СерверTCP=СоздатьСерверTCP(Врап);
    Событие=Врап.ПолучитьОбъектДляСобытийСПараметром(СерверTCP,"ДанныеОтСканера");
    ДобавитьОбработчик Событие.СобытиеСПараметром, ПолучениеДанныхПоTCP;

    СерверTCP.ПодключитьСканер(НомерПорта);

КонецПроцедуры

Процедура ПолучениеДанныхОтСканераШК(Данные)
Сообщить("ИмяПорта="+Данные.ИмяПорта);
Сообщить("ШтрихКод="+Данные.Данные);


КонецПроцедуры

И добавлен приер загрузки объекта из DLL без регистрации на примере загрузки

Из comcntr.dll класс COMConnector. Для примера когда нужно подключиться к Базе  с версией отличной от текущей

Добавил пример использования конфигурационного файла в WCF клиентах в DLL

public object СоздатьКлиентаWCFConfigFile(string ИмяФайла, object TChannel, string endpointConfigurationName, object endpointAddress)

        {

  ExeConfigurationFileMap fileMap = newExeConfigurationFileMap();

            fileMap.ExeConfigFilename = ИмяФайла;

 Configuration newConfiguration = ConfigurationManager.OpenMappedExeConfiguration(

                fileMap,

 ConfigurationUserLevel.None);

 Type ТипКанала=ТипДляСоздатьОбъект(TChannel);

 Type type= typeof(ConfigurationChannelFactory<>);

 Type constructed = type.MakeGenericType(ТипКанала);

 dynamic factory1 = System.Activator.CreateInstance(constructed,

                endpointConfigurationName,

                newConfiguration,

            AutoWrap.ПолучитьРеальныйОбъект(endpointAddress)

                );

return AutoWrap.ОбернутьОбъект(factory1.CreateChannel());

        }

Процедура ВызовСервисаИспользуяConfigFileНажатие(Элемент)     // Вставить содержимое обработчика.         врап=новый COMОбъект("NetObjectToIDispatch45");
    //Сборка=врап.загрузитьСборку("d:\MyPrograms\Test\NestNet45\NestNet45\bin\Debug\NestNet45.dll");     Сборка=врап.загрузитьСборку(ИмяФайлаСборки);     TChannel=Сборка.GetType("NestNet45.ServiceReference1.MorpherSoap");     ConfigFile=ИмяФайлаСборки+".config";     endpointConfigurationName="MorpherSoap";     endpointAddress=Неопределено;     Клиент=врап.СоздатьКлиентаWCFConfigFile(ConfigFile,TChannel,endpointConfigurationName,endpointAddress);
    // Вызываю метод и вывожу результат     рез = Клиент.GetForms("Ваяся Пупкин");
    Для каждого стр  Из рез Цикл         сообщить(стр)     КонецЦикла;
КонецПроцедуры

Подправил обертку объектов. Теперь массивы примитивных типов строки, дата, Decimal возвращаются как родные для 1С COMSafeArray.

Для массива объектов нужно отдельно преобразовать через функция

ПолучитьSafeArrayИзЭнумератора(Object Массив)

Так же при работе с событиями проще сделать комовский класс с событиями например
// Создаем интерфейс доступных событий из 1С
  [ComVisible(true)]
    [InterfaceType(ComInterfaceType.InterfaceIsIDispatch)]
    public interface IEventFor1C
    {
        [DispId(0x00000001)]
        void Событие();

        [DispId(0x00000002)]
        void СобытиеПереименованияФайла(object ИмяДиректории);
    }


// Указываем какие комовские события будет реализовывать класс
    [ComVisible(true)]
    [ClassInterface(ClassInterfaceType.AutoDual)]
    [ComSourceInterfaces(typeof(IEventFor1C))]
    public class КлассДляВнешнихСобытий2
    {
        public string ИзмененныйФайл;
        public string ПереименованныйФайл;
        public event System.Action Событие;
        [ComVisible(false)]
        public delegate void СобытиеСПараметром_Delgate(object value);
        public event СобытиеСПараметром_Delgate СобытиеПереименованияФайла;
        public FileSystemWatcher watcher;
        dynamic Врапер;
        private SynchronizationContext Sc;
        private void ИзмененияВДиректории(object source, FileSystemEventArgs e)
        {
            // Specify what is done when a file is changed, created, or deleted.
            ИзмененныйФайл = e.FullPath + " " + e.ChangeType;
            if (this.Событие != null)
                Sc.Send(d => Событие(), null);

        }

// Врапер это объект который создается через
//врап=новый COMОбъект("NetObjectToIDispatch45");
// Нужен для обертки объектов в AutoWrap
        public КлассДляВнешнихСобытий2(Object  Врапер,string Директория)
        {
        this.Врапер=Врапер;
// SynchronizationContext нужен для того, что вызов проходил в потоке 1С
        SynchronizationContext.SetSynchronizationContext(new System.Windows.Forms.WindowsFormsSynchronizationContext());
        Sc = SynchronizationContext.Current;

            watcher = new FileSystemWatcher();
            watcher.Path = Директория;
            /* Watch for changes in LastAccess and LastWrite times, and
               the renaming of files or directories. */
            watcher.NotifyFilter = NotifyFilters.LastAccess | NotifyFilters.LastWrite
               | NotifyFilters.FileName | NotifyFilters.DirectoryName;
            // Only watch text files.
            watcher.Filter = "*.*";

            // Add event handlers.
            watcher.Changed += new FileSystemEventHandler(ИзмененияВДиректории);
            watcher.Created += new FileSystemEventHandler(ИзмененияВДиректории);
            watcher.Deleted += new FileSystemEventHandler(ИзмененияВДиректории);
            watcher.Renamed += new RenamedEventHandler(OnRenamed);

            // Begin watching.
            watcher.IncludeSubdirectories = true;

            watcher.EnableRaisingEvents = true;



        }

        private void OnRenamed(object source, RenamedEventArgs e)
        {
            // Specify what is done when a file is renamed.

            ПереименованныйФайл = string.Format("File: {0} renamed to {1}", e.OldFullPath, e.FullPath);
            if (this.СобытиеПереименованияФайла != null)
               Sc.Send(d => СобытиеПереименованияФайла(Врапер.ОбернутьОбъект(ПереименованныйФайл)),null);
// В данном случае ПереименованныйФайл это строка и Врапер.ОбернутьОбъект(ПереименованныйФайл) для примера,
// что бы показать как обернуть любой объек в AutoWrap не читаемый из 1С Net объект
        }

    }
И соответственно вызов из 1С

врап=новый COMОбъект("NetObjectToIDispatch45");
    Сборка=врап.загрузитьСборку(ИмяФайлаСборки); //ПроектИспользованияДелегатов.dll
    тип=Сборка.GetType("ПроектИспользованияДелегатов.КлассДляВнешнихСобытий2");

    ОбъектССобытием2=врап.СоздатьОбъект(Тип,врап,КаталогДляОтслеживанияИзменений);

// Нужен для доступа к комовским событиям
    КомОбъектССобытием=Врап.ПолучитьРеальныйОбъект(ОбъектССобытием2);

    ДобавитьОбработчик КомОбъектССобытием.Событие, ПриИзмененииДиректории;
    ДобавитьОбработчик КомОбъектССобытием.СобытиеПереименованияФайла, ПриПереименованииФайла2;

При выходе можно очистить события.

Если ОбъектССобытием2<>Неопределено  Тогда

        врап.ОчиститьСобытияОбъекта(ОбъектССобытием2.watcher);
        врап.ОчиститьСобытияОбъекта(ОбъектССобытием2);

КонецЕсли;

Добавил реализацию ВК внутри сборки для получения Глобального контекста. Использование

Если ПодключитьВнешнююКомпоненту("AddIn.GlobalContext1C") Тогда
        объект=Новый ("AddIn.GlobalContext1C");
ГлобальныйКонтекст=объект.ГлобальныйКонтекст;
  AppDispatch=ГлобальныйКонтекст.AppDispatch;
  AppDispatch.Сообщить("Привет");
        иначе
        сообщить("Компонента не загружена");
    КонецЕсли;


Использование Внутри Net.

public ТестВК(object Object1C)

    {

        this.Object1C = Object1C;

        ГК = new ДинамикГК(Object1C);

}

public string СоздатьОкно() {

    //    m_1cApp.AppDispatch.Сообщить("Привет из ВК");

    // не работает для упрощения работы создань динамический объект ДинамикГК

    // выполняющий аналогичную фунцию

            IExtWndsSupport n;

            ГК.Сообщить("Привет из ВК", ГК.СтатусСообщения.Важное);

            n = (IExtWndsSupport)Object1C;

            IntPtr hwnd;

             n.GetAppMainFrame(out hwnd);

    // Создаем форму, устанавливаем нативные хэндлы и устанвливаем окно 1С владельцем нетовского окна

            var form = new Form1();

            form.CreateControl();

            SetOwner(form.Handle.ToInt32(), hwnd.ToInt32());

            form.EventTo1C = Object1C as IAsyncEvent;

          form.Show();

            return "Методы ВК выполнены!";

        }

private async void button1_Click(object sender, EventArgs e)

        {

            var ПотокПриложения = Thread.CurrentThread.ManagedThreadId;

            // Для чистоты эксперимента вызовим события из потока отличного от потока приложения.

            // Что бы await не использовал текущий контекст установим ConfigureAwait(false)

            await Task.Delay(1000).ConfigureAwait(false); // делаем задержку в секунду и вызываем событие

            var ПотокСобытия = Thread.CurrentThread.ManagedThreadId;

            // Для вызова в тотоке приложения вызовем метод из его потока

            Sc.Send(d => EventTo1C.ExternalEvent("ДанныеИзТестВК", "Тест", string.Format("Поток Приложения={0} Поток события {1}",ПотокПриложения,ПотокСобытия)), null);

            // Если очень быстро кликать по кнопке то потоки события будут разными

        }

Также добавил возможность показать окно семерки созданное через Новый COMОбъект("V77.Application");

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ФайлыNetObjectToIDispatch.zip
.zip 41,18Mb
14.07.16
130
.zip 41,18Mb 130 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Олег (oleg_km) 28.11.13 20:05
Некоторые примеры использования:

Процедура Приостановить(ВремяПаузы) Экспорт
ПолучитьТип("System.Threading.Thread").Sleep(ВремяПаузы);
КонецПроцедуры

Функция ПолучитьКоманднуюСтроку() Экспорт
Возврат ПолучитьТип("System.Environment").CommandLine;
КонецФункции

Функция ПолучитьТекущийПринтер() Экспорт
Возврат СоздатьОбъект(ПолучитьТип("System.Drawing.Printing.PrinterSettings", "System.Drawing")).PrinterName;
КонецФункции

Функция ПолучитьТекущийПроцесс() Экспорт
Возврат ПолучитьТип("System.Diagnostics.Process", "System").GetCurrentProcess().Id;
КонецФункции

Процедура СкопироватьПоток(вхПоток, исхПоток, РазмерПорции = 100000) Экспорт
Пока Истина Цикл
мсДанные = СоздатьМассив(ПолучитьТип("System.Byte"), РазмерПорции);
число = вхПоток.Read(мсДанные, 0, мсДанные.Length);
Если число = 0 Тогда Прервать; КонецЕсли;
исхПоток.Write(мсДанные, 0, число);
КонецЦикла;
КонецПроцедуры

// Компрессия
Процедура GZIPУпаковать(вхФайл, исхФайл) Экспорт
УдалитьФайлы(исхФайл);

типФайл = ПолучитьТип("System.IO.FileStream");
типРежим = ПолучитьТип("System.IO.FileMode");
типДоступ = ПолучитьТип("System.IO.FileAccess");
типРазделение = ПолучитьТип("System.IO.FileShare");

обФайлИсходный = СоздатьОбъект(типФайл, вхФайл, типРежим.Open, типДоступ.Read, типРазделение.ReadWrite);
обФайлАрхив = СоздатьОбъект(типФайл, исхФайл, типРежим.CreateNew, типДоступ.Write);
обПотокКомпр = СоздатьОбъект(ПолучитьТип("System.IO.Compression.GZipStream", "System"),
обФайлАрхив, ПолучитьТип("System.IO.Compression.CompressionMode", "System").Compress);

СкопироватьПоток(обФайлИсходный, обПотокКомпр);

обПотокКомпр.Close();
обФайлАрхив.Close();
обФайлИсходный.Close();
КонецПроцедуры

Процедура GZIPРаспаковать(вхФайл, исхФайл) Экспорт
УдалитьФайлы(исхФайл);

типФайл = ПолучитьТип("System.IO.FileStream");
типРежим = ПолучитьТип("System.IO.FileMode");
типДоступ = ПолучитьТип("System.IO.FileAccess");
типРазделение = ПолучитьТип("System.IO.FileShare");

обФайлАрхив = СоздатьОбъект(типФайл, вхФайл, типРежим.Open, типДоступ.Read, типРазделение.ReadWrite);
обФайлНовый = СоздатьОбъект(типФайл, исхФайл, типРежим.CreateNew, типДоступ.Write);
обПотокКомпр = СоздатьОбъект(ПолучитьТип("System.IO.Compression.GZipStream", "System"),
обФайлАрхив, ПолучитьТип("System.IO.Compression.CompressionMode", "System").Decompress);

СкопироватьПоток(обПотокКомпр, обФайлНовый);

обПотокКомпр.Close();
обФайлАрхив.Close();
обФайлНовый.Close();
КонецПроцедуры

// Получение хеша
Функция ПолучитьХешСтроки(текСтрока, Провайдер = "MD5") Экспорт
мсДанные = ПолучитьКодировку().GetBytes(текСтрока);
Возврат Хеш2Строка(СоздатьКриптоПровайдер(Провайдер).ComputeHash(мсДанные));
КонецФункции

Функция ПолучитьХешФайла(ИмяФайла, Провайдер = "MD5") Экспорт
обФайл = СоздатьОбъект(ПолучитьТип("System.IO.FileStream"), ИмяФайла,
ПолучитьТип("System.IO.FileMode").Open,
ПолучитьТип("System.IO.FileAccess").Read,
ПолучитьТип("System.IO.FileShare").ReadWrite);

Рез = Хеш2Строка(СоздатьКриптоПровайдер(Провайдер).ComputeHash(обФайл));
обФайл.Close();

Возврат Рез;
КонецФункции

Функция СоздатьКриптоПровайдер(Провайдер)
//SHA SHA1CryptoServiceProvider
//SHA1 SHA1CryptoServiceProvider
//System.Security.Cryptography.SHA1 SHA1CryptoServiceProvider
//System.Security.Cryptography.HashAlgorithm SHA1CryptoServiceProvider
//MD5 MD5CryptoServiceProvider
//System.Security.Cryptography.MD5 MD5CryptoServiceProvider
//SHA256 SHA256Managed
//SHA-256 SHA256Managed
//System.Security.Cryptography.SHA256 SHA256Managed
//SHA384 SHA384Managed
//SHA-384 SHA384Managed
//System.Security.Cryptography.SHA384 SHA384Managed
//SHA512 SHA512Managed
//SHA-512 SHA512Managed
//System.Security.Cryptography.SHA512 SHA512Managed

КлючПровайдера = "Hash_" + Провайдер;
обПровайдер = КешОбъектов[КлючПровайдера];

Если обПровайдер = Неопределено Тогда
обПровайдер = ПолучитьТип("System.Security.Cryptography.HashAlgorithm").Create(Провайдер);
КешОбъектов.Вставить(КлючПровайдера, обПровайдер);
КонецЕсли;

Возврат обПровайдер;
КонецФункции

Функция Хеш2Строка(мсХеш)
стрРез = СоздатьОбъект(ПолучитьТип("System.Text.StringBuilder"), мсХеш.Length * 2);
Для ии = 0 По мсХеш.Length - 1 Цикл
стрРез.AppendFormat("{0:X2}", мсХеш.GetValue(ии));
КонецЦикла;
Возврат СокрЛП(стрРез.ToString());
КонецФункции
mrDSide; awk; +2 Ответить
2. Сергей Смирнов (Serginio) 23.10.14 13:01
Исправил метод СоздатьКлиентаWCFConfigFile(string ИмяФайла, object TChannel, string endpointConfigurationName, object endpointAddress=null,string UserName=null, string Password=null)
Для передачи UserName и Password при соединении

public object СоздатьКлиентаWCFConfigFile(string ИмяФайла, object TChannel, string endpointConfigurationName, object endpointAddress=null,string UserName=null, string Password=null)
        {
            ExeConfigurationFileMap fileMap = new ExeConfigurationFileMap();
            fileMap.ExeConfigFilename = ИмяФайла;
            Configuration newConfiguration = ConfigurationManager.OpenMappedExeConfiguration(
                fileMap,
                ConfigurationUserLevel.None);


            Type ТипКанала = ТипДляСоздатьОбъект(TChannel);
            Type type = typeof(ConfigurationChannelFactory<>);
            Type constructed = type.MakeGenericType(ТипКанала);

            dynamic factory1 = System.Activator.CreateInstance(constructed,
                endpointConfigurationName,
                newConfiguration,
                AutoWrap.ПолучитьРеальныйОбъект(endpointAddress)
                );

            if (!String.IsNullOrWhiteSpace(UserName))
            {
               
                factory1.Credentials.UserName.UserName = UserName;
                factory1.Credentials.UserName.Password = Password;
           
            }

            return AutoWrap.ОбернутьОбъект(factory1.CreateChannel());
        }
...Показать Скрыть


И применение в 1С
Функция ПолучитьКлиента()
  TChannel=Сборка.GetType(namespace + "IService");
    ConfigFile=ИмяФайлаСборки+".config";
    endpointConfigurationName=""BasicHttpBinding_IService";
  //  endpointAddress=Неопределено;




    _client=врап.СоздатьКлиентаWCFConfigFile(ConfigFile,TChannel,endpointConfigurationName,,_UserName_,_Password_);

возврат _client

 КонецФункции
...Показать Скрыть
3. Dima Dima (bayce) 09.01.15 14:28
Эта компонента будет работать в УФ?
4. Сергей Смирнов (Serginio) 11.01.15 12:11
(3) bayce, Это не компонента, а COM объект который доступен Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение

При этом библиотека регистрируется как 32 так 64 разрядная. То есть можно использовать на 64 разрядном сервере приложений
5. Василий Зайцев (vasiliy_b) 28.07.15 15:58
Добрый день. У меня вопрос по Вашей публикации, как я понял с ее помощью, можно будет реализовать взаимодействие с COM портом на тонком клиенте.
В моей задаче стоит считывание данных с com порта и запись данных в порт.
Из выше описаного можно попробовать прочитать данные с порта, но как отправить в порт некоторые значения мне не совсем понятно.
есть ли у Вас примеры подобной реализации.

И еше в статье используется понятеи "Сборок", это терминалогия как я понял от .Net, значит мне будет нужна сборка для работы с com портом, верно?
Есть ли где-то уже готовые сборки, которые можно было бы использовать?
6. Сергей Смирнов (Serginio) 28.07.15 16:25
Там есть пример работы с ком портами, но я его не проверял.
Для записи в ком порт можно использовать SerialPort напрямую
https://msdn.microsoft.com/en-us/library/system.io.ports.serialport.writeline(v=vs.110).aspx
7. Сергей Смирнов (Serginio) 28.07.15 16:31
В примере для чтения из ком порта используется кнопка ОткрытьПортСканера
и обработка события в ДанныеОтСканера
8. Сергей Смирнов (Serginio) 28.07.15 17:36
Кстати работать со сборками проще загрузив их в макет или хранилище

Процедура ПриОткрытии()
	
	врап=новый COMОбъект("NetObjectToIDispatch45");
	врап.ВыводитьСообщениеОбОшибке=ложь;

	Каталог=КаталогВременныхФайлов();
	ФайлWebSocket1C=Каталог+"WebSocket1C2.dll";
	
	
	
	
	попытка
			ПолучитьМакет("WebSocket1C").Записать(ФайлWebSocket1C);
			
		исключение
			Сообщить(ОписаниеОшибки());
	конецпопытки;
	
//	ФайлWebSocket1C="D:\TestProgramms\WebSocket1C2\WebSocket1C2\bin\Debug\WebSocket­1C2.dll";
	

	Сборка=врап.загрузитьСборку(ФайлWebSocket1C); 
	


	
	
КонецПроцедуры
...Показать Скрыть

9. Сергей Смирнов (Serginio) 28.07.15 17:47
Правда нужно не забывать помещать туда же зависимые сборки.
10. Сергей Смирнов (Serginio) 12.08.15 15:19
Добавил реализацию ВК внутри сборки для получения Глобального контекста. Использование

Если ПодключитьВнешнююКомпоненту("AddIn.GlobalContext1C") Тогда
		объект=Новый ("AddIn.GlobalContext1C");
		иначе
		сообщить("Компонента не загружена");
	КонецЕсли;
...Показать Скрыть


Использование Внутри Net.
public ТестВК(object Object1C)
    {
        this.Object1C = Object1C;
        ГК = new ДинамикГК(Object1C);

}

public string СоздатьОкно() {
    //    m_1cApp.AppDispatch.Сообщить("Привет из ВК");
    // не работает для упрощения работы создань динамический объект ДинамикГК
    // выполняющий аналогичную фунцию
    
            IExtWndsSupport n;
            ГК.Сообщить("Привет из ВК", ГК.СтатусСообщения.Важное);
            n = (IExtWndsSupport)Object1C;
            IntPtr hwnd;
             n.GetAppMainFrame(out hwnd);

    // Создаем форму, устанавливаем нативные хэндлы и устанвливаем окно 1С владельцем нетовского окна
            var form = new Form1();
            form.CreateControl();
            SetOwner(form.Handle.ToInt32(), hwnd.ToInt32());
            form.EventTo1C = Object1C as IAsyncEvent;
           
          form.Show();
            
            return "Методы ВК выполнены!";
        }

private async void button1_Click(object sender, EventArgs e)
        {
            var ПотокПриложения = Thread.CurrentThread.ManagedThreadId;
            // Для чистоты эксперимента вызовим события из потока отличного от потока приложения.
            // Что бы await не использовал текущий контекст установим ConfigureAwait(false)
            await Task.Delay(1000).ConfigureAwait(false); // делаем задержку в секунду и вызываем событие
            var ПотокСобытия = Thread.CurrentThread.ManagedThreadId;

            // Для вызова в тотоке приложения вызовем метод из его потока
            Sc.Send(d => EventTo1C.ExternalEvent("ДанныеИзТестВК", "Тест", string.Format("Поток Приложения={0} Поток события {1}",ПотокПриложения,ПотокСобытия)), null);
            // Если очень быстро кликать по кнопке то потоки события будут разными
        }
...Показать Скрыть

Так же добавил возможность показать окно семерки созданное через Новый COMОбъект("V77.Application");
11. Александр Александров (qvvert) 13.09.15 23:57
Доброго времени суток, подскажите пожалуйста, как быть с символом перевода строки при hmac_sha1 некорректно шифруется...
12. Александр Александров (qvvert) 14.09.15 00:13
Гугл подсказывает что как то надо заменить Символы.Пс на Environment.NewLine - в дотнете... подскажите пожалуйста как это сделать?
13. Сергей Смирнов (Serginio) 14.09.15 00:29
https://msdn.microsoft.com/ru-ru/library/fk49wtc1(v=vs.110).aspx

В объекте есть ОбернутьЛюбойОбъект


Врап.ОбернутьЛюбойОбъект(Строка).Replace(@"\n",Environment.NewLine)
14. Сергей Смирнов (Serginio) 14.09.15 00:47
Хотя проще использовать 1С функцию
Строка=СтрЗаменить(Строка,Символы.Пс,Символы.Пс+Символы.ВК)
15. Александр Александров (qvvert) 14.09.15 00:53
(13) Serginio, а как определить Environment.NewLine?
Врап.ОбернутьЛюбойОбъект(Строка).Replace("\n",Environment.NewLine) - Не прокатывает
создание объекта Врап.СоздатьОбъект("System.Environment.NewLine") - тоже не прокатывает....

Не знает что такое Environment.NewLine как его определить?

Символы.ПС+Символы.ВК - не спасают отца русской демократии... hmac_sha1 - с символом перевода строки генерится неверно...
16. Александр Александров (qvvert) 14.09.15 01:08
Вопрос Снимается Спасибо!
в рамках получения hmac Нужно заменять перевод строки на системную переменную (Если в ключе или в сообщении используется перевод строки) соответсвенно в строке вместо символы.пс - передавать служебный например ("\n") - где столкнулся я - в апи викимпарта

новаяСтрока = Врап.ПолучитьТип("System.Environment").NewLine;

message = Врап.ОбернутьЛюбойОбъект(message).Replace("\n",новаяСтрока);
key = Врап.ОбернутьЛюбойОбъект(key).Replace("\n",новаяСтрока);
17. Сергей Смирнов (Serginio) 14.09.15 08:11
(16) Да уж 1С с переводом строки не совсем корректно все сделали.
18. Сергей Смирнов (Serginio) 17.11.15 11:31

Случайно изменил в AssemblyInfo.cs [assembly: ComVisible(true)] и
Для каждого Цикл перестал работать
Который работает через EnumVariantImpl : IEnumVARIANT

/ Параметр ComVisible со значением FALSE делает типы в сборке невидимыми
// для COM-компонентов. Если требуется обратиться к типу в этой сборке через
// COM, задайте атрибуту ComVisible значение TRUE для этого типа.
[assembly: ComVisible(false)]
19. Сергей Смирнов (Serginio) 17.11.15 14:40
Добавил возможность использования ExpandoObject напрямую с добавлением свойств и методов
Объект=ЗагрузкаComОбъекта.ПолучитьExpandoObject();
// Получим словарь для чтения и добавления свойств и методов
Объект2=Врап.ПолучитьИнтерфейс(Объект,"IDictionary`2");

// Установим свойсва через словарь
Объект2.set_Item("Число",5);

//Сообщить(Объект.Item("Имя"));
Сообщить(Объект2.get_Item("Имя"));
Сообщить(Объект2.get_Item("Число"));
Объект2.set_Item("Имя","Вызов Метода");
Сообщить(Объект2.get_Item("ВСтроку").DynamicInvoke());

// Теперь можно обращаться в свойствам и методам напрямую
Объект.Число=6;
Сообщить(Объект.Имя);
Сообщить(Объект.Число);
Объект.Имя="Вызов Метода";
Сообщить(Объект.ВСтроку());

// Добавим новое поле
Объект2.Add("НовоеПоле",66);

// Нужно обновить информацию о новых методах и свойствах
Объект=врап.ОбновитьДанныеОметодахИСвойствах(Объект);
//
Сообщить(Объект.НовоеПоле);
...Показать Скрыть

20. Rauan Sandybaev (sandybaev) 18.11.15 15:28
Serginio, а вы не планируете развить в этой сборке TSL авторизацию? Она остро в нем нуждается, допустим для тех случаев когда есть связка 1С+Exchange 2013 и почту надо отправлять во внешний мир.
21. Сергей Смирнов (Serginio) 18.11.15 15:49
(20) Эта сборка нужна для подгрузки сборок .Net. То есть нужно найти, или создать сборку для обмена с Exchange 2013 на Net и использовать её. Например берем примеры https://code.msdn.microsoft.com/office/Exchange-2013-101-Code-3c38582c/view/SamplePack#content и использум их через NetObjectToIDispatch45. После того, как добавил динамическую компиляцию использования событий Net стало значительно проще использовать эту компоненту. Просто нужно начальное знание Net.

Здесь есть примеры http://habrahabr.ru/post/117268/
Несложно их переписать на 1С
22. Rauan Sandybaev (sandybaev) 18.11.15 15:55
Ясно. трабл в том что я слабоват в C#.
23. Сергей Смирнов (Serginio) 18.11.15 16:05
На самом деле не все так сложно. Возьмем для примера код

var esb = new ExchangeServiceBinding();
    // Указываем используемые креды
    esb.Credentials = new NetworkCredential(user, password, domain);
    // Задаем входную точку для EWS
    esb.Url = "https://" + server + "/EWS/Exchange.asmx";
    esb.RequestServerVersionValue = new RequestServerVersion();
    // Указываем тип Exchange сервера 
    // Для Exchange 2007 SP1 и 2010 подходит Exchange2007_SP1
    // Для Exchange 2007 без SP нужно указать Exchange2007
    esb.RequestServerVersionValue.Version = ExchangeVersionType.Exchange2007_SP1;
            
    return esb;
...Показать Скрыть

Нужно знать Простанство имен в котором находится ExchangeServiceBinding
врап=новый COMОбъект("NetObjectToIDispatch45");
врап.ЗагрузитьСборку(ПутьКСборке);
ПИ="НужноеПространствоИмен";
esb = Врап.СоздатьОбъект(ПИ+"ExchangeServiceBinding");
    // Указываем используемые креды
    esb.Credentials = врап.СоздатьОбъект("System.Net.NetworkCredential",user, password, domain);
    // Задаем входную точку для EWS
    esb.Url = "https://" + server + "/EWS/Exchange.asmx";
    esb.RequestServerVersionValue =  врап.СоздатьОбъект("RequestServerVersion);
    // Указываем тип Exchange сервера 
    // Для Exchange 2007 SP1 и 2010 подходит Exchange2007_SP1
    // Для Exchange 2007 без SP нужно указать Exchange2007
    esb.RequestServerVersionValue.Version = врап.ПолучитьТип("ExchangeVersionType").Exchange2007_SP1;
            
    return esb;
...Показать Скрыть


Просто в модуле C# указываются пространство имен, и поэтому можно опускать их при написании класса.
24. Xer shi (Xershi) 19.11.15 15:20
Тяжело читается публикация. Можете структурировать информацию?
25. Сергей Смирнов (Serginio) 19.11.15 15:36
(24) Она больше для тех кто знаком с Net. Надо отдельную статью написать про использование для тех, кто с Net не знаком. Тут главное понять, что не понятно
26. Xer shi (Xershi) 19.11.15 15:43
(25) Serginio, да учили на C# писать лабораторные, но работаю с 1С профессионально. В принципе понятно. Но вникать долго нужно.
27. Сергей Смирнов (Serginio) 19.11.15 15:47
(26) Так ты задавай вопросы, я буду отвечать. А затем, может и статью напишем для лучшего понимания. Просто в Net можно найти классы на все возможные случаи.
28. Дмитрий Жичкин (zhichkin) 18.01.16 09:48
(27) Serginio,
Добрый день, Сергей!
Есть решение, реализованное на C# WPF: интерфейс, бизнес логика, сервисы, работа с данными. Всё как положено, но ... Клиент хочет, чтобы всё было в 1С =) Другими словами, нужно всё наше богатство "прикрутить" к интерфейсу 1С. Размышляю над возможностью использовать MVVM в применении к формам и контролам 1С (пока что речь идёт о толстом клиенте). Может быть посоветуете что-нибудь?
29. Сергей Смирнов (Serginio) 18.01.16 10:01
Я бы сделал класс враппер для событий формы создания формы и свойства для доступа к этой форме.
События можно сгенерить динамически или статически пример есть здесь http://infostart.ru/public/417830/

В примерах ВК есть использования WinForms с привязкой к главному окну 1С.
30. Сергей Смирнов (Serginio) 18.01.16 10:08
Еще вариант это обмен через TCP/IP пример есть в примерах к статье
31. Дмитрий Жичкин (zhichkin) 18.01.16 10:12
(29) Serginio,
MVVM предполагает наличие класса ViewModel, который использует интерфейс INotifyPropertyChanged. Идея заключается в том, чтобы при создании формы 1С создавать класс ViewModel и каким-то образом выполнять привязку его свойств к элементам управления формы 1С. Вероятно нужна реализация специального биндера контролов 1С к классу .NET.
32. Сергей Смирнов (Serginio) 18.01.16 10:37
Ты можешь вызывать события, к которым из 1С будет подключаться и обрабатывать
33. Сергей Смирнов (Serginio) 18.01.16 10:38
То есть ты можешь подключиться к событиям ViewModel через http://infostart.ru/public/417830/
34. Сергей Смирнов (Serginio) 18.01.16 10:39
Посмотри примеры. Будет понятнее.
35. Сергей Смирнов (Serginio) 18.01.16 12:07
Кстати используя WindowInteropHelper можно использовать окна WPF передавя ему оно владельца хэндл главного окна 1С. И можешь использовать окна WPF в 1С
36. Дмитрий Жичкин (zhichkin) 18.01.16 23:43
37. Сергей Смирнов (Serginio) 19.01.16 10:03
(36) Еще можно передать в нетовский объект ссылку на общий модуль, модуль отчета, модуль формы и вызывать все их экспортные методы. В сборке ТестВК. присоздании объекта класса ТестВК передается глобальный контекст 1С Object1C, через который можно вызваь методы глобального контекста 1С, получать хэндл главного окна 1С GetAppMainFrame и получать интерфейс IAsyncEvent через который вызывать внешнееСобытие в 1С.
По сути вам нужно по минимуму изменить C# проект
38. Сергей Смирнов (Serginio) 19.01.16 15:11
35+ Специально проверил на WPF Window
Создал класс

public partial class Window1 : Window
    {
        dynamic Модуль1С;
        public Window1(dynamic модуль1С, dynamic Object1C)
        {
            InitializeComponent();
            Модуль1С = модуль1С;
            IExtWndsSupport n;
             n = (IExtWndsSupport)Object1C;
             IntPtr hwnd;
                    n.GetAppMainFrame(out hwnd);

            var wih = new System.Windows.Interop.WindowInteropHelper(this);
            wih.Owner = hwnd;

        }

        private void button_Click(object sender, RoutedEventArgs e)
        {
            Модуль1С.СообщитьСтр(textBox.Text);
        }
    }
...Показать Скрыть


В модуле отчета прописал

Процедура СообщитьСтр(стр) Экспорт

Сообщить(стр)	

КонецПроцедуры
...Показать Скрыть


И соответственно вызов

врап=новый COMОбъект("NetObjectToIDispatch45");
	тип=Врап.ПолучитьТипИзСборки("WPFLibrary.Window1","d:\Vs2015Programs\SignalR\WPFLibrary\WPFLibrary\bin\Debug\WPFL­ibrary.dll");
	ПодключитьВнешнююКомпоненту("AddIn.GlobalContext1C");
	объект=Новый ("AddIn.GlobalContext1C");
		ГлобальныйКонтекст=объект.ГлобальныйКонтекст;

	Окно=Врап.СоздатьОбъект(тип,ЭтотОбъект,ГлобальныйКонтекст);
	Окно.Show();
...Показать Скрыть
39. Сергей Смирнов (Serginio) 19.01.16 15:35
Еще нужно при закрытии уничтожить ссылку на модуль

 private void Window_Closed(object sender, EventArgs e)
        {
            Модуль1С.СообщитьСтр("Форма закрыта");
            Marshal.Release(Marshal.GetIDispatchForObject(Модуль1С));
            Marshal.ReleaseComObject(Модуль1С);
            Модуль1С = null;
            GC.Collect();
            GC.WaitForPendingFinalizers();
        }
...Показать Скрыть
40. Сергей Смирнов (Serginio) 20.01.16 12:47
Добавил в ТестВК использование WPF форм
41. Сергей Смирнов (Serginio) 28.01.16 11:37
Сейчас в .Net широко применяют оператор await. Он применяется к методам возвращающие Task или Task<TResult>.
Task это задача представляет асинхронную операцию. Доступ к результату осуществляется через свойство Result.
В 1С можно использовать либо синхронный вариант например
ДанныеРесурса=Клиент.GetStringAsync("https://msdn.microsoft.com/ru-ru/library/hh551745(v=vs.118).aspx").Result;


Но для того, что бы этот метод выполнить асинхронно я создал класс с помощью которого легко использовать эти методы асинхронно.

врап=новый COMОбъект("NetObjectToIDispatch45");
Выполнитель=Врап.ПолучитьАсинхронныйВыполнитель();
ДобавитьОбработчик Выполнитель.ПриОкончанииВыполненияЗадачи, ПриОкончанииВыполнения;

Обработчик события выглядит так
Процедура ПриОкончанииВыполнения(Задача,ДанныеКЗадаче)

    // Обязательно нужно отлавливать ошибку в 1С
    // Иначе она передается в .Net где обрабатывается там
    Попытка
Так как задача может завершиться с ошибкой
Мы должны проверить, и если ошибка нужно предпринять какие то действия
        Если (Задача.IsFaulted) Тогда  // Ошибка выполнения

            Сообщить("Ошибка "+Врап.ВСтроку(Задача.Exception));
            Сообщить("Данные к задаче "+Врап.ВСтроку(ДанныеКЗадаче));

        иначе
            Сообщить("=====Выполнена задача ====");
            Сообщить("Данные к задаче "+Врап.ВСтроку(ДанныеКЗадаче));
            Сообщить(Врап.ВСтроку(Задача.Result));


        КонецЕсли;

    Исключение
        Сообщить("Ошибка в процедуре");
        Сообщить(ОписаниеОшибки());
    КонецПопытки

КонецПроцедуры
...Показать Скрыть

Вызываем задачу так
HttpClient=Врап.ПолучитьТипИзСборки("System.Net.Http.HttpClient","System.Net.Http.dll");
    Клиент=Врап.СоздатьОбъект(HttpClient);
    Задача=Клиент.GetStringAsync("https://msdn.microsoft.com/ru-ru/library/hh551745(v=vs.118).aspx");
    Выполнитель.Выполнить(задача,ТекущаяДата());
...Показать Скрыть

Вторым параметром можно передавать любые данные, что бы понять какая задача выполнена и что с ней делать, так одновременно может работать множество задач

Например

АсинхМетоды = Врап.СоздатьОбъект(КлассДляТестаАсинхронныхМетодов);

    Для сч=1 по 10 Цикл
        задача=АсинхМетоды.ДолгаяЗадача(Строка("Задача "+сч));
        Выполнитель.Выполнить(задача,сч);
    КонецЦикла
...Показать Скрыть
42. Сергей Смирнов (Serginio) 20.02.16 14:32



Очень часто приходится использовать битовую операци OR

например
 AutomaticDecompression = DecompressionMethods.GZip | DecompressionMethods.Deflate



или
 watcher.NotifyFilter = NotifyFilters.LastAccess | NotifyFilters.LastWrite| NotifyFilters.FileName | NotifyFilters.DirectoryName;





Поэтому добавил метод OR. Теперь те же операции можно вызвать

DecompressionMethods= Врап.ПолучитьТип("System.Net.DecompressionMethods");
  handler.AutomaticDecompression=Врап.OR(DecompressionMethods.GZip,DecompressionMethods.Deflate) ;

или

NotifyFilters=врап.ПолучитьТип("System.IO.NotifyFilters");
    рез=Врап.OR(NotifyFilters.LastAccess,NotifyFilters.LastWrite,NotifyFilters.FileName,NotifyFilters.DirectoryName);


43. Артём Артёмов (TeMochkiN) 04.09.16 22:32
Подскажите, пожалуйста, зависимые сборки нужно как-то загружать или ещё что-то делать, или достаточно чтобы они находились в одном каталоге с основной сборкой, чтобы всё корректно работало??
44. Сергей Смирнов (Serginio) 04.09.16 23:14
(43) Достаточно, что бы находились в одном каталоге. Но иногда для динамической компиляции нужно что бы были в каталоге программы (основной Домен) . http://infostart.ru/public/466196/
TeMochkiN; +1 Ответить
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа