1C Messenger для отправки сообщений, файлов и обмена данными между пользователями 1С, вэб страницы, мобильными приложениями а ля Skype, WhatsApp

Публикация № 434771

Разработка - Практика программирования

Messenger SignalR .Net C#

Данная разработка позволяет пользователям 1С обмениваться сообщениями, файлами (до 3 мб). Запрашивать данные у клиента как Вэб или HTTP сервисах. Основано на технологиях ASP.Net SignaR который использует WebSockets и т.д. для двунаправленного обмена данными. Используется обертка над классами .Net

 

В  свое  время  делал  клиента  для  Whats  App,  и  многие  приемы  взяты  оттуда.  Но  постоянно  они  что-то  меняют.  Плюс  нельзя  отправлять  любые  файлы,  использовать  клиента  как  web  сервис  и т.д.

Эта  статья  является  продолжением  статей

  Использование  сборок  .NET  в    7.x  b  8.x.  Создание  внешних  Компонент 

(Здесь же лежат и файлы клиентов и сервера)

И

  .NET(C#)  для  1С.  Динамическая  компиляция  класса  обертки  для  использования  .Net  событий  в    через  ДобавитьОбработчик  или  ОбработкаВнешнегоСобытия 

 

В  этой  разработке  используются  обе  эти  разработки  и  служит  примером  того,  как  можно  легко  использовать  технологии  .Net  в  1С.

В  данной  разработке  можно  обмениваться  сообщениямиайлами,  запрашивать  данные  от  других  клиентов.  Клиенты  могут  быть  как  на  1С,  так  и  с  использованием  вэб  браузера,  WPF  приложения  и  даже  андроид  приложения  и т.д.

Ну,  начнем  по  порядку.  Начну  с  кода  на  1С.

Первое,  что  нам  нужно, это  подключиться.

 

Попытка

                SignalRClietHello=Врап.ПолучитьТипИзСборки("SignalRClient.SignalRClietHello",Объект.КаталогDLL+"SignalRHelloClient.dll");
                //Сборка=врап.загрузитьСборку(Объект.КаталогDLL+"SignalRHelloClient.dll");
                Клиент=Врап.СоздатьОбъект(SignalRClietHello);
                Клиент.Соединиться(Объект.АдресСервера).Wait();


                фрм=ПолучитьФорму("ВнешняяОбработка.SignalRClient.Форма.ФормаОбработки");
                ЗаполнитьЗначенияСвойств(Фрм.Объект,Объект,"АдресСервера,КаталогDLL,КаталогПолученныхФайлов,ИспользоватьСкомпилированнуюСборку");
                Фрм.врап=врап;
                Фрм.Клиент=Клиент;

                фрм.Открыть();
                Закрыть();
        исключение
                Сообщить(ОписаниеОшибки());

                //    ПоказатьПредупреждение(,Врап.ПоследняяОшибка.Message);
                Врап.ВывестиПоследнююОшибку();
        конецПопытки

При  удачном  подключении  открываем  форму  обмена  сообщениями

И  добавим  обработчики  событий

&НаКлиенте
Процедура  СоздатьОбертку(NetОбъект)
        //  Создаём  обертку  для  событий  и  подключаем  обработчики
        //ОберткаСобытий=врап.СоздатьОберткуДляСобытий(NetОбъект);
        //  Можно  использовать  уже  скомпилированную  сборку,  так  как  при
        //врап.СоздатьОберткуДляСобытий  создается  файл  ВрапперДляSignalRClient_SignalRClietHello.dll
        ПолучитьОбертку(NetОбъект);

        ДобавитьОбработчик  ОберткаСобытий.ОшибкаСобытия,ОшибкаСобытия;


        ДобавитьОбработчик  ОберткаСобытий.ПриОтключении,  ПриОтключении;
        ДобавитьОбработчик  ОберткаСобытий.ОшибкаСоединения,  ОшибкаСоединения;
        ДобавитьОбработчик  ОберткаСобытий.ПриИзмененииСостоянияСоединения,  ПриИзмененииСостоянияСоединения;
        ДобавитьОбработчик  ОберткаСобытий.ПриПолученииСообщения,  ПриПолученииСообщения;
        ДобавитьОбработчик  ОберткаСобытий.ПриАвторизации,  ПриАвторизации;
        ДобавитьОбработчик  ОберткаСобытий.ПриПолученииФайла,  ПриПолученииФайла;
        ДобавитьОбработчик  ОберткаСобытий.ПриПодключенииНовогоПользователя,  ПриПодключенииНовогоПользователя;
        ДобавитьОбработчик  ОберткаСобытий.ПриОтключенииПользователя,  ПриОтключенииПользователя;
        ДобавитьОбработчик  ОберткаСобытий.ПриПолученииКоманды,  ПриПолученииКоманды;
        ДобавитьОбработчик  ОберткаСобытий.ПриПолученииОтветаКоманды,  ПриПолученииОтветаКоманды;
        //NetОбъект==Клиент
        Клиент.Зарегистрироваться(ИмяПользователя());
КонецПроцедуры


 

Не  буду  расписывать  все  обработчики,  покажу  только  некоторые

 

/

/    параметр  Данные:Аннимный  Тип
//  Свойства  параметра
//  id:System.String
 //  ИмяПользователя:System.String
 //  СписокПользователей:System.Collections.Generic.List`1[[SignalRClient.User,  SignalRClient,  Version=1.0.0.0,  Culture=neutral,  PublicKeyToken=null]]
&НаКлиенте

Процедура  ПриАвторизации(Данные)
        пользователи=Элементы.Получатель.СписокВыбора;
        пользователи.Очистить();
        Элем=пользователи.Добавить("Всем","Всем");
        ЭтотОбъект.Получатель="Всем";

        Сообщить("ПриАвторизации  "+Врап.ВСтроку(Данные));
        ИД=  Данные.id;

        Для  каждого  Юзер    Из  Данные.СписокПользователей    Цикл

                ДобавитьНовогоПользователя(Юзер.ConnectionId,  Юзер.Name)


        КонецЦикла;
КонецПроцедуры

//    параметр  Данные:Аннимный  Тип
//  Свойства  параметра
//  ОтКого:System.String
 //  FileName:System.String
 //  id:System.String
 //  Данные:System.Byte[]
&НаКлиенте

Процедура  ПриПолученииФайла(Данные)
        Сообщить("ПриПолученииФайла  "+Врап.ВСтроку(Данные));
        Массив=Данные.Данные;
        имяФайла  =Врап.ПолучитьТип("System.IO.Path").Combine(Объект.КаталогПолученныхФайлов,  Данные.FileName);
        Врап.ПолучитьТип("System.IO.File").WriteAllBytes(имяФайла,Массив);
        ДобавитьСообщение(Данные.ОтКого,  "Отправлен  файл  "+  Данные.FileName,  Данные.id,  имяФайла);

        Клиент.ОтправитьСообщение(СтрШаблон("Получен  файл  %1  размер  %2  байт",  Данные.FileName,Врап.ОбернутьЛюбойОбъект(Данные.Данные).Length),  Данные.id);
КонецПроцедуры

//    параметр  Данные:Аннимный  Тип
//  Свойства  параметра
//  Имя:System.String
 //  сообщение:System.String
 //  IdОтправителя:System.String
&НаКлиенте
Процедура  ПриПолученииСообщения(Данные)
        Сообщить("ПриПолученииСообщения  "+Врап.ВСтроку(Данные));
        ДобавитьСообщение(Данные.Имя,Данные.сообщение,Данные.IdОтправителя,"")
КонецПроцедуры 

 

Здесь  применяются  объекты  и  статические  методы  классов  .Net,  обернутые  через  врап=новый  COMОбъект("NetObjectToIDispatch45");

Отправка  сообщений  происходит  также  через  Net  объект

&НаКлиенте
Процедура  КомандаОтправитьСообщение(Команда)
        //  Вставить  содержимое  обработчика.
        Если  ПустаяСтрока(объект.Сообщение)  Тогда
                показатьПредупреждение(,"Сообщение  не  заполнено");
                возврат
        КонецЕсли;

        ИДПолучателя=ЭтотОбъект.Получатель;

        Если  ПустаяСтрока(ИДПолучателя)  Тогда
                показатьПредупреждение(,"Не  выбран  получатель");
                возврат
        КонецЕсли;

        Если  Объект.ПоИмени  и  ИДПолучателя="Всем"  Тогда
                показатьПредупреждение(,"Нельзя  отправлять  по  имени  Всем");
                возврат
        КонецЕсли;

        Сообщение=Объект.Сообщение;
        Попытка
                Если  Объект.ПоИмени  Тогда
                        Пользователи=  Элементы.Получатель.СписокВыбора;
                        Имя=Пользователи.НайтиПоЗначению(ИДПолучателя).Представление;
                        //  Можно  отправлять  ассинхронно  без  Wait
                        //  Но  могут  быть  проблемы  с  отловом  ошибок
                        //  На  всякий  случай  поставим  1  сек  ожидания
                        //  для  предотвращения  взаимных  блокировок
                        Клиент.ОтправитьСообщениеПоИмени(Сообщение,Имя).Wait(1000);
                ИначеЕсли  Получатель="Всем"  Тогда
                        Клиент.ОтправитьСообщение(Сообщение,  "").Wait(1000);
                Иначе
                        Клиент.ОтправитьСообщение(Сообщение,ИДПолучателя).Wait(1000);
                КонецЕсли;

                Объект.Сообщение="";

        исключение
                Сообщить(ОписаниеОшибки());
                Если  Врап.ПоследняяОшибка<>  Неопределено  Тогда
                        ПоказатьПредупреждение(,Врап.ПоследняяОшибка.Message);
                КонецЕсли;
        КонецПопытки;
КонецПроцедуры

 

Реализованы  следующие  команды:  КомандаОтправитьФайл,  КомандаВычислитьСложение  (отправляется  команда  и  параметры  клиенту,  результат  получается  асинхронно).

Перейду  с  серверной  части.  Она  написана  на  Asp.Net  с  использованием  Nancy  в  котором  кроме  сервера  SignalR  реализован  сайт  с  клиентом  SignalR

Вот  реализация  Хаба

 

public  class  HelloHub  :  Hub

{

 static  List<User>  Users  =  new  List<User>();

 

 bool  ПользовательЗарегистрирован(User  user)

      {

       var  curId  =  Context.ConnectionId;

var  имя  =  Users.Where(x  =>  x.ConnectionId  ==  curId).Select (x=>x.Name).SingleOrDefault();

                        user.Name  =  имя;

                        user.ConnectionId  =  curId;

                        return  (!String.IsNullOrWhiteSpace(имя));

 }

 

 public  void  SendEcho(string  str,  string  Кому)

   {

       var  user  =  new  User();

       if  (!ПользовательЗарегистрирован(user))

            return;

 

      if  (string.IsNullOrWhiteSpace(Кому))

             Clients.Others.addMessage(user.Name,  str,  user.ConnectionId);

                  else

             Clients.Client(Кому).addMessage(user.Name,  str,  user.ConnectionId);

   }

 

  public  void  SendByName(string  str,  string  Кому)

        {

           var  user  =  new  User();

           if  (!ПользовательЗарегистрирован(user))

                 return;

 

 foreach(var  клиент  in  Users.Where(x  =>  x.Name.ToUpper()  ==  Кому.ToUpper()).Select(x  =>  x.ConnectionId))

    Clients.Client(клиент).addMessage(user.Name,  str,  user.ConnectionId);

  }

  public  void  Send(string  name2,  string  message)

       {

             var  user  =  new  User();

             if  (!ПользовательЗарегистрирован(user))

                   return;

 

              Clients.All.addMessage(user.Name,  message,  user.ConnectionId);

       }

 

  

  public  void  SendFile(string  Кому,string  FileName,  byte[]  Data,  bool  isCompressed)

     {

           var  user  =  new  User();

           if  (!ПользовательЗарегистрирован(user))

                                return;

 

          if  (Users.Any(x  =>  x.ConnectionId  ==  Кому))

              {

Clients.Client(Кому).GetFile(user.Name,FileName,user.ConnectionId,Data,isCompressed);

                }

 

  public  void  EvaluteCommand(string  Кому,string  command,  byte[]  Data,  bool isCompressed)

       {

           var  user  =  new  User();

           if  (!ПользовательЗарегистрирован(user))

                 return;

 

           if  (Users.Any(x  =>  x.ConnectionId  ==  Кому))

           {

 Clients.Client(Кому).EvaluteCommand(user.Name,command,user.ConnectionId,Data,  isCompressed);

                        }

 

                }

 

  public  void  ResultCommand(string  Кому,string  command,byte[]  Data,bool  isCompressed)

                {

                        var  user  =  new  User();

                        if  (!ПользовательЗарегистрирован(user))

                                return;

 

 

  if  (Users.Any(x  =>  x.ConnectionId  ==  Кому))

   {

 Clients.Client(Кому).ResultCommand(user.Name,command,user.ConnectionId,Data,  isCompressed);

                        }

 

                }

                //  Подключение  нового  пользователя

  

  public  void  Connect(string  userName)

  {

    var  id  =  Context.ConnectionId;

    if  (!Users.Any(x  =>  x.ConnectionId  ==  id))

       {

           Users.Add(new  User  {  ConnectionId  =  id,  Name  =  userName  });

           //  Посылаем  сообщение  текущему  пользователю

           Clients.Caller.onConnected(id,  userName,  Users);

           //  Посылаем  сообщение  всем  пользователям,  кроме  текущего

            Clients.AllExcept(id).onNewUserConnected(id,  userName);

                        }

                }

 

                //  Отключение  пользователя

  public  override  System.Threading.Tasks.Task  OnDisconnected(bool  stopCalled)

  {

       var  id  =  Context.ConnectionId;

       var  item  =  Users.FirstOrDefault(x  =>  x.ConnectionId  ==id);

            if  (item  !=  null)

                    {

                        Users.Remove(item);

                        Clients.All.onUserDisconnected(id,  item.Name);

                      }

 

                        return  base.OnDisconnected(stopCalled);

                }

        }

 

Ссылки на SignalR  Работа с SignalR

http://metanit.com/sharp/mvc5/16.1.php

Публикация вэб сервиса

http://professorweb.ru/my/ASP_NET/sites/level3/3_1.php

http://metanit.com/sharp/mvc/13.2.php

Файлы для публикации лежат в ..\SignalR\ФайлыДляПубликации\

Для сервера SignalR требуется сервер должен использовать Windows 8, Windows Server 2012 или более поздней версии, и WebSocket должен быть включен в IIS.

 http://www.asp.net/signalr/overview/getting-started/supported-platforms

Попробовал поработать с Xamarin. В общем использовать можно, но еще сыро. Проще использовать WinMobile 10.

В папке SignalRMobile лежит недоделанный пример. Проблемы с инициализацией IOS модуля, ограничения на события с 4 мя параметрами и отсутствием времени не стал его доделывать.

 

В папке SignalRHelloClient лежит сборка для использования её в 1С

В папке SignalRClient лежит WPF приложение. Там же лежит основной модуль клиента SignalRClietHello.cs используемый обеими клиентами.

 

SignalRNancy это сервер.

 

Все файлы лежат по ссылке   Использование  сборок  .NET  в    7.x  b  8.x.  Создание  внешних  Компонент

Для использования нужна  .NET Framework 4.6

https://msdn.microsoft.com/Ru-ru/library/ms171868(v=vs.110).aspx

Для VS 2015 нужно обновление апдейт

Внешний отчет лежит в ВнешниеОтчеты\SignalRClient.epf

Написал статью на хабре по данной тематике ASP.NET Core, Angular 2, SignalR для чайников

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Serginio 830 25.12.15 16:44 Сейчас в теме
Добавил рабочий вариант для Android на Xamarin. Проверял на эмуляторе. На IOS не проверял.
2. Serginio 830 25.12.15 16:47 Сейчас в теме
Из пакетов убрал Xamarin.Forms.2.0.0.6490 он 20 мб
3. Makushimo 157 06.05.16 05:37 Сейчас в теме
а что нужно прочитать, чтобы понять то, что тут написано?
adhocprog; 1c.pro.fun; asolokha; twe; seevkik; rabota.v8.1c; Steelvan; Nizikov; VVi3ard; zif74; METAL; +11 Ответить
4. Serginio 830 06.05.16 08:11 Сейчас в теме
(3) В статье есть ссылки
Ссылки на SignalR Работа с SignalR

http://metanit.com/sharp/mvc5/16.1.php

Публикация вэб сервиса

http://professorweb.ru/my/ASP_NET/sites/level3/3_1.php

http://metanit.com/sharp/mvc/13.2.php

Если нужно только для 1С, то только опубликовать вэб сервис. Файлы здесь

http://infostart.ru/public/238584/

еще можно почитать
http://infostart.ru/public/448668/
http://infostart.ru/public/417830/
adhocprog; seevkik; +2 Ответить
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37799    unichkin    74    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    7907    quazare    33    

Работа с журналом регистрации. Выходим за границы платформы

Журнал регистрации Бесплатно (free)

Работа с журналом регистрации нестандартными средствами. А также немного про использование платформы .NET в экосистеме 1С.

12.05.2020    6500    YPermitin    27    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    30726    ids79    26    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30993    tormozit    100    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    26506    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    20197    kuzyara    34    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    17683    YPermitin    72    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78508    tormozit    131    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8811    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    30903    HostHost    40    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    35700    Yashazz    50    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    49061    tormozit    42    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    12711    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    55621    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    52633    ids79    54    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    45499    tormozit    74    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    30143    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    26069    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    32819    ids79    16    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16203    m-rv    2    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    91433    ids79    52    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    38660    avalakh    25    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    25720    json    15    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20587    m-rv    17    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    65605    ids79    12    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    37367    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    26941    YPermitin    14    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    31322    m-rv    21    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19963    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    51221    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    55523    ids79    25    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28504    itriot11    34    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    25934    dmurk    146    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    45362    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    36238    ellavs    126    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77163    Serginio    110    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27857    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    32382    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    42422    Смешной 1С    30    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    35709    ids79    40    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    22869    Vladimir Litvinenko    27    

Использование сборок .NET в 1С 7. и 8.x. Создание внешних Компонент. Промо

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

1 стартмани

28.11.2013    83877    238    Serginio    71    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    42064    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    27697    ids79    31    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29592    grumagargler    28    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    42865    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    38225    ids79    42