gifts2017

Печать ценников и этикеток для УТ 8.2 с выбором цены и организации для УТ 10.3

Опубликовал Олег Кобяков (kobol) в раздел Печать - Ценники

Возможность печати ценников и этикеток из документов и подборов. Добавлена возможность выбора Организации и цены. для ут 10.3

За основу взята обработка http://infostart.ru/public/75613/ в свою очередь автор взял её у Alexsisit PechatCennikov.epf  http://infostart.ru/public/21680/ и он доработал под себя. Мне показалось неудобно, что организация и тип цен выбираются из настроек пользователя по умолчанию. Пришлось ввести поле выбора организации и выбора типа цен. Это удобно при ведении нескольких организаций в одной базе.  

Используя количество, можно печатать необходимое количество этикеток.

Для печати  на принтер этикеток нужна компонента 1CBarCode.exe

Скачать файлы

Наименование Файл Версия Размер
Печать ценников и этикеток для УТ 8.2 88
.epf 48,53Kb
13.01.14
88
.epf 48,53Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. марина Марина (Marishka_2014) 25.09.14 21:26
Добрый день! При загрузки из любого документа вылетает ошибка
{Форма.Форма.Форма(451)}: Ошибка при вызове метода контекста (Выполнить)
СписокШт=Запрос.Выполнить().Выгрузить();
по причине:
{(4, 12)}: Поле не найдено "Штрихкоды.ПредставлениеШтрихкода"
Штрихкоды.<<?>>ПредставлениеШтрихкода

Конфигцрация Комплексная автоматизация 1.1 Как можно исправить ?
2. Денис Ан (Denis_CFO) 25.09.14 21:41
(1) Marishka_2014, надо полностью запрос смотреть. там однозначно реквизита с таким именем нет ( "Штрихкоды.ПредставлениеШтрихкода" ). пишите по-больше информации.
3. марина Марина (Marishka_2014) 25.09.14 22:42
(2) Denis_CFO, Процедура ЗаполнитьПоСсылке(СписокТоваров);

ТаблЦен=ПолучитьТаблицуЦен(СписокТоваров.выгрузитьКолонку("Номенклатура"));
	ЭлементыФормы.Индикатор1.МаксимальноеЗначение=СписокТоваров.Количество();
    сч=0;

	Для Каждого Эл Из СписокТоваров Цикл
		сч=сч+1;
		ЭлементыФормы.Индикатор1.Значение=сч;
        ОбработкаПрерыванияПользователя();
		НовСтр=Товары.Найти(Эл.Номенклатура,"Номенклатура");
		Если НовСтр=Неопределено Тогда 
			НовСтр=Товары.Добавить();
		КонецЕсли;
		
		Попытка
			НовСтр.Единица=эл.ЕдиницаИзмерения;
		Исключение
			НовСтр.Единица=эл.номенклатура.ЕдиницаХраненияОстатков;
		КонецПопытки;
		
		Запрос = Новый Запрос(
		"ВЫБРАТЬ
		|   Штрихкоды.Штрихкод,
		|	Штрихкоды.ТипШтрихкода,
		|	Штрихкоды.ПредставлениеШтрихкода
		|ИЗ
		|	Справочник.Номенклатура КАК шНоменклатура
		|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.Штрихкоды КАК Штрихкоды
		|		ПО шНоменклатура.Ссылка = Штрихкоды.Владелец
	    |ГДЕ
		|	шНоменклатура.Ссылка В ИЕРАРХИИ(&Ссылка)");
		Запрос.УстановитьПараметр("Ссылка",Эл.Номенклатура);
		СписокШт=Запрос.Выполнить().Выгрузить();
	
		НовСтр.Колво=1;
		НовСтр.Номенклатура=Эл.Номенклатура;
		НовСтр.Артикул=Эл.Номенклатура.Артикул;
		НовСтр.Страна=Эл.Номенклатура.СтранаПроисхождения;
		НовСтр.ШтрихКод = СписокШт.Получить(0).Штрихкод;
		НовСтр.ТипШтрихкода = СписокШт.Получить(0).ТипШтрихкода;
		НовСтр.ПредставлениеШтрихкода = СписокШт.Получить(0).ПредставлениеШтрихкода;

		НовСтр.Цена=0;
		Кол=0;
		
		ЕстьСтр=ТаблЦен.Найти(Эл.Номенклатура,"Номенклатура");
		Если ЕстьСтр<>Неопределено Тогда 
			НовСтр.Цена=ЕстьСтр.Цена;
		КонецЕсли;
		
		Если СсылкаНаОБъект <> Неопределено Тогда
		ЕстьстрК=СсылкаНаОБъект.товары.найти(Эл.Номенклатура,"Номенклатура");
			Если ЕстьСтрК<>Неопределено Тогда
			    Кол = ЕстьстрК.количество;
				НовСтр.Колво = Кол;
			КонецЕсли;
		КонецЕсли;
		
		Если (НовСтр.Цена=0) или (Кол=0)  Тогда 
			НовСтр.Флаг  = Ложь;
			НовСтр.Колво = 0;
		Иначе
			НовСтр.Флаг=Истина;
		КонецЕсли;
		
		//еСЛИ ТипЗНЧ(СсылкаНаОбъект)=Тип("ДокументСсылка.ПоступлениеТоваровУслуг") Тогда
		//	НовСтр.Флаг=Истина;
		//	
		//	Естьстр=СсылкаНаОБъект.товары.найти(Эл.Номенклатура,"Номенклатура");
		//	Кол=0;
		//				
		//	Если Естьстр<>Неопределено Тогда
		//		Кол = Естьстр.количество;
		//		НовСтр.Колво = Кол;
		//	КонецЕсли;	
		//	Если НовСтр.Цена=0 или Кол=0  Тогда 
		//		НовСтр.Колво=0;
		//		НовСтр.Флаг=Ложь;
		//	КонецЕсли;	
		//КонецЕсли;
	КонецЦикла;
	ЭлементыФормы.Индикатор1.Значение=0;
КонецПроцедуры
...Показать Скрыть
4. Олег Кобяков (kobol) 26.09.14 05:16
Так написано было что под ут 10.3, а ввиду изменения сайта сейчас не вижу где написано.
5. Александр Беляков (belakov83) 01.03.15 15:39
(1) Marishka_2014, как Вы решили проблему?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа