gifts2017

Выбор периода для управляемых форм

Опубликовал Денис Зубарев (deniz.zubarev.1985) в раздел Программирование - Работа с интерфейсом

Форма выбора стандартного периода для управляемых форм

Пример (8.3 интерфейс такси):

 

На любой форме добавляем кнопку.

в команде кнопки прописываем:

 

&НаКлиенте
Процедура ВыбратьПериод(Команда)

         ОписаниеОповещения = Новый ОписаниеОповещения("РезультатВыбораПериода",ЭтотОбъект);
         ОткрытьФорму("ОбщаяФорма.ФормаВыбораПериода",,,,,,ОписаниеОповещения);

КонецПроцедуры

 

&НаКлиенте
Процедура РезультатВыбораПериода(Результат, ДополнительныеПараметры) Экспорт

         Если Результат <> Неопределено Тогда
                  ЭтотОбъект.ДатаНачала = Результат.ДатаНачала;
                  ЭтотОбъект.ДатаОкончания = Результат.ДатаОкончания; 
         КонецЕсли;

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ВыборПериодаУпрФормы.cf
.cf 12,15Kb
26.06.14
30
.cf 12,15Kb 30 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Адепт Адептов (Adeptus) 27.06.14 10:11
Не плохо но вот это получше выглядит и поудобнее!
http://infostart.ru/public/90540/
2. Дмитрий Елисеев (w-divin) 27.06.14 14:53
(0) я просто в шоке от таких публикаций. А сделайте еще публикации с "ПоказатьВопрос" и "ПоказатьПредупреждение". А еще можно вообще весь СП выложить...

(1) Adeptus, лучше, но не канает в УФ )))
3. Дмитрий Елисеев (w-divin) 27.06.14 14:54
А еще и обработку скачивать с 2мя реквизитами и 12ю строками текста - вообще превосходно...
4. MaxxiMiliSan (MaxxiMiliSan) 27.06.14 15:34
5. Андрей Лещанов (Nuuq) 09.02.15 18:18
Я вот так сделал:
- в обработке определено 2 реквизита Дата1 и Дата2
- в УФ форме добавлена кнопка и команда формы

&НаКлиенте
Процедура КомандаВыбратьПериод(Команда)
	
	Диалог = Новый ДиалогРедактированияСтандартногоПериода();								 
	Диалог.Период = Новый СтандартныйПериод(Объект.Дата1, Объект.Дата2);	    
	Если (Диалог.Редактировать()) Тогда
		Объект.Дата1 = Диалог.Период.ДатаНачала;
		Объект.Дата2 = Диалог.Период.ДатаОкончания;
	КонецЕсли;

КонецПроцедуры
...Показать Скрыть


... по-моему просто и удобно
nikivr; AlkB; ehcore; unichkin; adminfo2002; dj_serega; mnemchinov; RSConsulting; nick_krsk; +9 Ответить 2
6. Katano 28.03.15 03:41
(5) Nuuq, А как же модальность ))
7. Марина Чирина (chmv) 03.04.15 13:25
8. Игорь П (ehcore) 22.06.16 10:45
(5) Nuuq, спасибо! Изменил немного код для использования в режиме модальности:
&НаКлиенте
Процедура ВыбратьПериод(Команда)
    Диалог = Новый ДиалогРедактированияСтандартногоПериода();                                 
    Диалог.Период = Новый СтандартныйПериод(Объект.Дата1, Объект.Дата2);        
	ОписаниеОповещенияОЗакрытии = Новый ОписаниеОповещения("ВыполнитьПослеВыбораПериода",ЭтотОбъект);
	Диалог.Показать(ОписаниеОповещенияОЗакрытии); 
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьПослеВыбораПериода(Результат, Параметры) Экспорт
	Если Результат <> Неопределено Тогда
		Объект.Дата1 = Результат.ДатаНачала;
		Объект.Дата2 = Результат.ДатаОкончания;
	КонецЕсли;	
КонецПроцедуры	
...Показать Скрыть


Написав сообщение увидел, что код почти повторяет код автора темы, за исключением использования выбора периода через стандартные периоды.
Craig; irvin12345; +2 Ответить 1
9. Fanzang (irvin12345) 24.10.16 03:44
(8) ehcore, Сначала сделал то же самое, а потом увидел ваш комментарий.
Ваш вариант все равно лучше, тк не везде есть общая форма выбора периода, а в моём случае - выбирает дату а не период (ЗУП ГУ)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа