gifts2017

Настройка получения почты через SSL в стандартном почтовом клиенте 1С без дополнительных библиотек и изменения кода через стороннюю бесплатную программу stunnel

Опубликовал Даниил Матвеев (cargobird) в раздел Администрирование - Системное

Настроено получение почты через SSL в стандартном почтовом клиенте без дополнительных библиотек и изменения кода через стороннюю бесплатную программу stunnel.

Прошу прощения у уважаемых коллег, если информация не нова.

Тем не менее, когда 17 сентября mail.ru стал работать только через SSL, возник вопрос о подключении через этот протокол и 1C-ного почтового клиента.

Исходные данные: почтовый клиент в УТ 10.3 сравнительно недавнего релиза на платформе 8.2 и тоже относительно свежей.

Последовательность действий проста.

1. Скачиваем программу stunnel-5.03-installer.exe  с https://www.stunnel.org/downloads.html

2. Устанавливаем. Перезагрузка не требуется.

3. Заходим в stunnel.conf.

4. Ищем текст pop.gmail.com заменяем на pop.mail.ru

5. Ищем текст smtp.gmail.com заменяем на smtp.mail.ru

6. Запускаем stunnel (повисает в трее).

7. В почтовом клиенте меняем адреса smpt и pop3 серверов на 127.0.0.1.

8. Проверяем подключение - работает.

Вот пожалуй и всё, спасибо за внимание...

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Виталий Довыденко (d_vit) 18.09.14 08:20
Огромное спасибо!
Все очень доступно описано и самое главное все заработало.
Кстати это же справедливо и для Яндекса:
pop.yandex.ru
smtp.yandex.ru
cargobird; +1 Ответить
2. Bon Aqua (BonAb) 18.09.14 09:34
Если вы используете платформу 8.3, то там уже поддерживает SSL.
Только включается она в коде.
Я включал так:
//
Профиль.ИспользоватьSSLSMTP = истина;
Профиль.ПортSMTP = 465;

Профиль.ИспользоватьSSLPOP3 = истина;
Профиль.ПортPOP3 = 995;
//
Krimskiy_xan; Serge_ASB; 1v7; z86; VladimirSpirin; simuljakr; foxsis; Vilenskiy; rozer; cargobird; +10 Ответить 3
3. CargoBird (cargobird) 18.09.14 09:51
(2) BonAb, спасибо за информацию, в будущем пригодится.

Но задача ставилась именно без изменения кода.
К тому же данный вариант подходит для удаленной настройки на терминале, так как не требует перезагрузки сервера, достаточно администраторских прав.
4. Канат Джумадылов (Fox-trot) 18.09.14 11:15
Прошу прощения у уважаемых коллег, если информация не нова.

тысячи их
5. CargoBird (cargobird) 18.09.14 11:18
(4) Fox-trot ))
Знал бы заранее про stunnel, также бы нагуглил)
6. Канат Джумадылов (Fox-trot) 18.09.14 12:31
(5) CargoBird,
без дополнительных библиотек

это малость преувеличено. или тунель не является дополнительной? и что тогда ты понимаешь под термином "библиотека"?
а вот указал бы в заголовке "тунель" мобыть я и не зашел бы сюда
7. Xer shi (Xershi) 18.09.14 12:40
(6) Fox-trot, так если вы в теме то давно известно, что 8.2 не поддерживает SSL. А в статье и написано что используется сторонняя прога.
8. Maxim k (maxis33) 18.09.14 12:56
Использовал такую штуку еще на 7.7 - реально помогла....
9. CargoBird (cargobird) 18.09.14 12:56
(6) Fox-trot, принято, приношу извинения, исправил заголовок.
10. Алексей Сидоров (alexstav) 19.09.14 08:08
А для 1С Предприятия 7.7 для получение почты с Яндекса работать будет? а то с 16 сентября "ROM-Mail" не работает
11. Алексей Сидоров (alexstav) 19.09.14 08:40
(8) maxis33,
А поподробнее как устанвливал?
12. CargoBird (cargobird) 19.09.14 08:45
(10) alexstav, по идее stunnel должен работать вне зависимости от почтовой программы и платформы.

Вчера настроил подобным же образом 1С Предприятие 8: CRM Стандарт на управляемых формах на почту yandex - сработало.

Значит и для 7.7 тоже должно помочь...
13. CargoBird (cargobird) 19.09.14 08:47
(11) alexstav, 1С-ки то это касается только в изменении адресов pop3 и smtp в коде или почтовом клиенте на локальный 127.0.0.1. Остальное - установка и настройка stunnel, как написано.
14. Алексей Сидоров (alexstav) 19.09.14 08:47
я менял в файле pop.gmail.com на pop.yandex.ru
и smtp.gmail.com на smtp.yandex.ru

у меня при запуске stunnel.exe вываливатся ошибка
Server is down(invalid configuration file)

conf файл прилагаю

помогите разобраться.... в чем дело
Прикрепленные файлы:
stunnel.conf
15. CargoBird (cargobird) 19.09.14 08:52
(14) alexstav, это оригинальный файл? Там осталось gmail, yandex не вижу.
16. Алексей Сидоров (alexstav) 19.09.14 09:02
Да, пардон, ошибся, не тот выслал
сейчас исправленный прикрепил ...

также прилагаю скрин ошибки, в трее он появляется, но красный
Прикрепленные файлы:
stunnel.conf
17. CargoBird (cargobird) 19.09.14 09:12
(16) alexstav, не вижу ошибок.
С оригинальным (не измененным) файлом stunnel.conf программа запускается?
18. Алексей Сидоров (alexstav) 19.09.14 09:22
(17) CargoBird,

со стандартным файлом stunnel.conf тоже не запускается

WIN XP sp2 права Администратора
Прикрепленные файлы:
19. CargoBird (cargobird) 19.09.14 09:41
(18) alexstav, запускал на Windows 7 Максимальная и на Windows Server не помню какой версии без проблем.

Дома есть машина под Windows XP SP3, если найду время вечером - попробую установить.

Единственное, что пока могу сказать - мне показалось важным в самом начале при установке stunnel заполнять произвольными данными ответы на вопросы, а в последнем вопросе (про сервер) указать localhost.
20. Алексей Сидоров (alexstav) 19.09.14 09:55
"мне показалось важным в самом начале при установке stunnel заполнять произвольными данными ответы на вопросы, а в последнем вопросе (про сервер) указать localhost. "
в точку! Спасибо! теперь запустился!
второй вопрос:

7. В почтовом клиенте меняем адреса smpt и pop3 серверов на 127.0.0.1.
где это делать? Вот кусок кода из 1С:
ЗагрузитьВнешнююКомпоненту("ROM-Mail.dll");
Почта=СоздатьОбъект("AddIn.Mail");
//Почта = СоздатьОбъект("AddIn.AddInMail");
Почта.СерверПриема=СокрЛП(Константа.СерверПриема);
Почта.ПортПриема="110";
Почта.Логин=СокрЛП(Константа.ПочтаЛогин);
Почта.Пароль=СокрЛП(Константа.ПочтаПароль);
Почта.ОставлятьНаСервере=Константа.ОставлятьПочтуНаСервере;
Почта.ПоказыватьПредупреждения=0;
Почта.Отключиться();
Если Почта.Подключиться("Прием")=0 Тогда
Сообщить("Не удалось подключиться к серверу!"); //а=10/0;
Почта.Отключиться();
Возврат;
ЗаписьЖурналарегистрации("Не удалось подключиться к POP3 серверу!");
ЗавершитьРаботуСистемы(0);
Иначе
Сообщить("Подключение к POP3 серверу прошло успешно");
КонецЕсли;

Сообщить("На сервере "+Почта.КоличествоСообщений()+" сообщений");

Для i=1 По Почта.КоличествоСообщений() Цикл
..... ......
21. CargoBird (cargobird) 19.09.14 10:15
(20) alexstav, видимо вместо
Почта.СерверПриема=СокрЛП(Константа.СерверПриема); 

вставить
Почта.СерверПриема="127.0.0.1";

или поменять в режиме предприятия значение константы "Сервер приема" на 127.0.0.1

Сервера отправки в вашем коде не вижу, если найдете - то по тому же принципу поменять и его.
22. Дамир Шамаев (NU_User) 19.09.14 11:17
mail.ru

Почта-то подключается, и даже отправляет, но почему то виснет на

ИнтернетПочта.ПолучитьЗаголовки();

Затем возвращает массив с незаполненными элементами,
всё пусто, только есть дата получения (дата отправки тоже пустая)

а лог вот такой

2014.09.19 11:19:33 LOG5[5328]: Service [mail-smtp] accepted connection from 127.0.0.1:52065
2014.09.19 11:19:33 LOG5[5328]: s_connect: connected 94.100.180.160:465
2014.09.19 11:19:33 LOG5[5328]: Service [mail-smtp] connected remote server from 192.168.1.38:52066
2014.09.19 11:19:33 LOG5[5728]: Service [mail-pop3] accepted connection from 127.0.0.1:52067
2014.09.19 11:19:33 LOG5[5728]: s_connect: connected 217.69.139.74:995
2014.09.19 11:19:33 LOG5[5728]: Service [mail-pop3] connected remote server from 192.168.1.38:52068
2014.09.19 11:25:33 LOG3[5328]: transfer: s_poll_wait: TIMEOUTclose exceeded: closing
2014.09.19 11:25:33 LOG5[5328]: Connection closed: 58 byte(s) sent to SSL, 260 byte(s) sent to socket

всё .... что не так?

А может такое быть что пока регламентное задание получает эти самые заголовки (делает она это прилично долго - 25мин), другому пользователю не доступно получение писем от "занятого" сервера?
23. Алексей Сидоров (alexstav) 19.09.14 11:17
Всем Огромное Спасибо! Все заработало! даже на WIN SERVER 2012
24. CargoBird (cargobird) 19.09.14 12:21
(22) NU_User, сомневаюсь, что это проблема, связанная именно с stunnel.

Может попробуете для начала погуглить по ИнтернетПочта.ПолучитьЗаголовки(); - я посмотрел, выходит много ответов на вопросы, связанные именно с этим методом и некоторые из них похожи по описанию на ваш.
25. Дамир Шамаев (NU_User) 19.09.14 16:02
(24) CargoBird, ну оно вроде заработало, правда очень долго на этом месте сидит ..., честно говоря, не знаю как было раньше
26. Алексей Темный (yspex) 22.09.14 12:23
Есть + и - у почтового клиента.

Минусы:
1. Если Вы планируете отправлять, получать большие файлы, то база будет разрастаться в разы.
2. Долго синхронизирует заголовки писем, если в браузере в папке Входящие, много писем. (бухгалтера) просят оставлять почту на сервере и не удалять ее при получении, что не есть хорошо.

Плюсы:
Как для бухгалтера отличный вариант, сразу все в 1с, удобно и комфортно, это при не большом объеме писем и их размере.

Все же больше всего отдаю предпочтение следующим почтовым клиентам: Outlook, TheBat, Thunder, а лучше через вебку ходить, надежно и практично!

Зеленоград; +1 Ответить 1
27. CargoBird (cargobird) 22.09.14 12:28
(26) yspex, так оно, но у пользователей CRM-конфигураций, как правило, выхода нет...
То же касается различных обработок рассылок писем из 1С (7.7 - без вариантов, на платформах ниже 8.3 - до перехода на 8.3 с поддержкой SSL).
Если есть выбор - соглашусь, предпочтительнее внешний почтовый клиент.
28. lexuslam lexuslam (lexuslam) 23.09.14 18:26
Ошибка при вызове метода контекста (Подключиться): Аутентификация не прошла (SMTP error code 535, Authentication credentials invalid)
29. CargoBird (cargobird) 23.09.14 22:36
(28) lexuslam, Authentication credentials invalid - судя по гуглу это ошибка авторизации SMTP сервера. Возможно неверно указаны имя пользователя и пароль - как правило они те же самые, что и у POP3 сервера. Есть вероятность, что ошибка на стороне провайдера почты - в этом случае лучше обратиться к ним в техподдержку.
30. lefthander (lefthander) 24.09.14 09:44
сервисы QIP.RU работают без SSL :)
31. CargoBird (cargobird) 24.09.14 10:32
(30) lefthander, простите, каким образом это относится к 1С?)
32. Dmitry Malygin (pawonex) 26.09.14 20:44
Крайне полезный пост!!! Без понтов, что очень радует! Благодарствую от души! Автор большой молодец, что написал доступно, для не опытных пользователей!
slax; Vovan58; help1Ckr; smit1c; cargobird; +5 Ответить 1
33. rhtr Иванов (rhtr) 27.09.14 08:12
Автору конечно плюс за труды, но баян ребята http://infostart.ru/public/58093/, об этом ещё с 2009 года есть публикация.
CaSH_2004; andrewks; Vovan58; cargobird; +4 Ответить 1
34. Язва Жопы (Sergafan10) 27.09.14 10:48
(31) таким, что у меня не взлетело, нопремер, пришлось сделать учётку на квипе и не мудряццо
35. CargoBird (cargobird) 27.09.14 14:04
(33) rhtr, действительно...
Да и не одна (гугл "stunnel infostart").
Еще раз приношу извинения за ненамеренный повтор.
36. CargoBird (cargobird) 27.09.14 14:10
(34) Sergafan10, пока за 10 дней внедрений stunnel не было ни одного отказа ни в локалке, ни в терминале.
Если опишете возникшую проблему или поделитесь ситуацией, в которой это сто процентов не работает, буду признателен.
37. Алексей Азов (unknown181538) 29.09.14 02:06
У меня такая же ошибка, как у (28) :(
Так что спасибо за идею с QIP.RU
38. Мария В (VictorySoft) 02.10.14 20:48
Спасибо! Очень полезная информация!
cargobird; +1 Ответить
39. Сергей Племянников (Serge_ASB) 10.10.14 09:30
(2) BonAb,
Подскажите, как в Документообороте 8 КОРП, редакция 1.2 (1.2.4.2) настроить электронную почту с Яндекса (yandex.ru).
При прямой настройке внутренней почты ругается, что connection broken, а при использовании stunnel - connection 127.0.0.1, 110 refused.
В коде текста Ssl глобальным поиском не нашел. Возможно, данная конфа не поддерживает SSL. Чего делать в таком случае?
40. CargoBird (cargobird) 10.10.14 15:12
(39) Serge_ASB, можете для начала выложить конфигурационный файл stunnel.conf?

Поддержка SSL не в конфигурации, а в платформе, причем в 8.3. То есть если у вас платформа 8.3, то надо править код в почтовой обработке как сказано у BonAb: найти где настраивается профиль и внести соответствующие изменения.
41. Алексей Лажанев (lalexrus) 18.10.14 10:14
(32) pawonex, есть одно НО. один туннель - это именно что "один". Т.е. не получиться одновременно отправлять в "две руки". В таких случаях надо в конфиге прописывать несколько портов (разных) под определенные "почты", ну и естественно несколько учетных записей ЭП в 1С. Тогда можно параллельно отправлять в два-три (и более) потока.
42. Роман Антонов (ronhard) 20.10.14 15:26
Полезная статья, но есть один вопрос, который хотелось бы уточнить: протоколы POP3 и SMTP работают по 110 и 25 портам соответственно. При использовании SSL стандартные порты для этих протоколов это 995 и 465 (993 для IMAP по моему). Таким образом в случае использования firewall наверное надо будет для stunnel открывать эти порты?
43. Павел Третьяков (Acid Megatron) 21.10.14 19:51
Подскажите,
платформа 8.2, server win2008, почта Яндекс,
все установилось, но письмо отсылается только при проверке учётной записи, во всех остальных случаях теряется.
Что я могу делать не так?
Прикрепленные файлы:
stunnel.conf
44. CargoBird (cargobird) 26.10.14 17:54
(42) ronhard, да, надо открывать и эти порты.
45. CargoBird (cargobird) 26.10.14 18:37
(43) Acid Megatron, если еще актуально: смоделировал ситуацию с вашим stunnel.conf на встроенном почтовом клиенте в УТ 10.3, но в Windows 7 Professional - письма отправляются и принимаются, возможно проблема не в stunnel. Возможно еще что-то блокирует по портам SSL.
46. Павел Третьяков (Acid Megatron) 27.10.14 11:52
(45) CargoBird, спасибо за ответ
Буду ковыряться дальше.
47. Василий Чибисов (vasichib) 22.11.14 09:59
Большое спасибо! Выручили!
48. Eugene Mc (emc2) 26.11.14 11:13
Здравствуйте, все!
Подскажите пожалуйста
Сделал всё как описано выше, но выходит ошибка

Ошибка при вызове метода контекста (Подключиться): Can not authenticate to SMTP server: 535 Incorrect authentication data: authentication failed for <***@mail.ru>

Заранее благодарен!
49. CargoBird (cargobird) 28.11.14 15:41
(48) emc2, давайте посмотрим на всякий случай stunnel.conf, выложите, если не сложно...
50. Сергей Огородников (Serg O.) 23.12.14 10:49
спасибо за прогу...

странно что 1С такой "простой" заплатки не сделали... для платформы 8.2

хотят наверное чтобы все скорее на 8.3 и управляемые формы переходили...

хотя многие до сих пор на 7.7 сидят...и никак отказаться от нее не могут
(и сама фирма 1С все равно их продолжает сопровождать кстати)

а 8.2 вообще "свежая"... и только все к ней все привыкли (бухгалтера, менеджеры и т.д.)
и на тебе...не работает ничего... ни рассылки (спам конечно..) ни обмен письмами с клиентами
cargobird; +1 Ответить
51. simuljakr (simuljakr) 10.03.15 13:53
При нажатии на кнопку "Проверить настройки учетной записи" выдает ошибку:
Ошибка при вызове метода контекста (Подключиться): SMTP greeting failure: 421 SMTP connection broken (reply)


Сделал все как в инструкции.
Тестировал на платформе 8.3, конфигарация УТ 10.3

В чем может быть причина ?
52. daniilmat (cargobird) 10.03.15 15:04
(51) simuljakr, это сообщение возникает именно из-за того, что пытаетесь подключиться не через SSL и отказано в доступе. Напишите, пожалуйста, настройки почтового клиента (pop3 и smtp сервера) и можно еще выложить получившийся stunnel.conf.

Исправлено: видимо делаете через код, напишите тогда, пожалуйста, кусок этого кода.
53. Сергей Антонов (serga2007) 16.04.15 12:45
Друзья, помогите настроить почту mail.ru на 1с предприятие 8.2 через stunnel!
Вроде все сделал как тут написано, но не работает:(((
Картинки прилагаю
Прикрепленные файлы:
stunnel.conf
54. Xer shi (Xershi) 16.04.15 12:53
55. Даниил Матвеев (cargobird) 16.04.15 13:11
(53) serga2007, на картинке в адресах POP3 и SMTP в конце лишние точки, если я не ошибаюсь...
56. Сергей Антонов (serga2007) 16.04.15 13:24
(54) Xershi, а это не то? stunnel.conf?
57. Xer shi (Xershi) 16.04.15 13:29
(56) serga2007, это ваша 1с есть файл вот его настроить. И проверьте без точки на конце: 127.0.0.1
58. Даниил Матвеев (cargobird) 16.04.15 13:49
(56) serga2007, содержимое файла правильное
59. Даниил Матвеев (cargobird) 16.04.15 13:56
(56) serga2007, уберите точки в конце адресов в настройке учетной записи
60. Сергей Антонов (serga2007) 17.04.15 10:54
Убрал точки, проверка проходит успешно, но при отправки письма выходит ошибка: @mail.ru. {ОбщийМодуль.УправлениеЭлектроннойПочтой.Модуль(1195)}: Ошибка при вызове метода контекста (Послать): Неверный синтаксис команды. Возможно ошибка в написании почтового адреса (SMTP error code 501, Syntactically invalid EHLO argument(s))
Прикрепленные файлы:
61. Xer shi (Xershi) 17.04.15 11:13
(60) serga2007, они кажись перешли на ссл там порт не 25
62. Даниил Матвеев (cargobird) 17.04.15 11:20
(60) serga2007, порты в настройках учетной записи указаны правильные (именно по ним происходит перенаправление на порты SSL в файле stunnel.conf)

Во-первых, традиционно сервера требуют SMPT-аутентификацию - поставьте флаг "Требуется SMPT аутентификация".

Во-вторых прочтите, пожалуйста, следующее, возможно надо изменить имя компьютера:

— При отправке почты выдается ошибка сервера: ’501 Syntactically invalid EHLO argument(s)’(код ошибки 0x800CCC63). Такая ошибка выдается, если имя компьютера (работающего под управлением Windows) содержит недопустимые символы:
(``{_}’’, русские буквы или пробелы). Его следует изменить через Панель Управления > Сеть > Идентификация.
Также необходимо проверить имя, указанное через Панель управления > Сеть > TCP/IP > DNS (при использовании коммутируемого соединения через модем DNS должен быть отключен)
63. Даниил Матвеев (cargobird) 17.04.15 11:22
(61) Xershi, возможно вы не в курсе, о чем речь идет.

В файле stunnel.conf содержится информация о перенаправлении по портам, указанным в настройках учетной записи:

[gmail-pop3]
client = yes
accept = 127.0.0.1:110
connect = pop.yandex.ru:995

[gmail-imap]
client = yes
accept = 127.0.0.1:143
connect = imap.gmail.com:993

[gmail-smtp]
client = yes
accept = 127.0.0.1:25
connect = smtp.yandex.ru:465

То есть порты в настройке из присланного скриншота указаны верно.
64. Xer shi (Xershi) 17.04.15 12:25
(63) cargobird, неа, я перевел платформу на 8.3. А в конфе дописал код который отправляет 2 из 6 методов отправки почты по CDO.Messange и эпликейшн аутлук.
65. Даниил Матвеев (cargobird) 17.04.15 12:29
(64) Xershi, человек, судя по скриншоту, пытается настроить подключение из базы на платформе 8.2...
Поэтому и пытаемся сделать через "прокладку" stunnel.
66. Сергей Антонов (serga2007) 17.04.15 15:23
67. Даниил Матвеев (cargobird) 17.04.15 15:56
(66) serga2007, как у вас, получилось?
68. Сергей Антонов (serga2007) 21.04.15 10:46
(67) cargobird, пока не получилось:((( Я вот думаю может порты закрыты?
69. Даниил Матвеев (cargobird) 21.04.15 10:57
(68) serga2007, если выход в интернет через аппаратный или программный шлюз - то все возможно...
Тогда надо знать порты, по которым разрешен SSL или прописывать свои, и их уже указывать в stunnel.conf вместо стандартных SSL-портов.

Ошибка та же, номер 501?
70. Алена З (Duduka80) 24.04.15 09:27
Добрый день ! с 20 апреля выдает такую ошибку не какие до этого действия с настройками не проводились все работало хорошо Подскажите что это и как с этим бороться ? Ошибка при вызове метода контекста (Послать): Неизвестная ошибка (SMTP error code 503, Administrative prohibition -- authorization required. Users in your domain are not allowed to send email without authorization. See http://help.mail.ru/mail-help/mailer/popsmtp for details.)
71. Даниил Матвеев (cargobird) 24.04.15 10:13
(70) Duduka80, добрый день!
Видимо где-то слетела аутентификация по SMTP.
Если настраиваете почту в форме, то должна быть галочка "Требуется аутентификация SMPT".
Если через код, то надо выставлять способ аутентификации СпособSMTPАутентификации.Login
72. Даниил Матвеев (cargobird) 24.04.15 10:15
(70) Duduka80, на всякий случай, напишите название конфигурации с которой работаете...
73. Алена З (Duduka80) 24.04.15 10:39
Спасибо огромное !!!! Действительно галочки на требуется аутентификация SMPT не было , поставила все заработало))))))
cargobird; +1 Ответить
74. Sesh Ren (Deroswent) 08.06.15 17:28
(2) BonAb, а где это прописавать то? в каком месте то????
75. Даниил Матвеев (cargobird) 08.06.15 20:30
(74) Deroswent, место зависит от того, какая у вас конфигурация.
Это настройки почтового профиля интернета (ИнтернетПочтовыйПрофиль)
Можно запустить глобальный поиск по конфигурации ИнтернетПочтовыйПрофиль, там будет примерно такой код (это я взял из глобального поиска по Бухгалтерии 3.0):
	Профиль = ИнтернетПочтовыйПрофиль(УчетнаяЗапись);
	Соединение = Новый ИнтернетПочта;
	Соединение.Подключиться(Профиль);

Вот примерно в такое найденное и вставляйте...
76. Jurii (jmw) 05.08.15 11:20
(74) Deroswent, вернее встань на строке „ИнтернетПочтовыйПрофиль“ и нажми F12 и впиши:
(Код взят из УТ 10.3)
77. Ал Нар (nab1985) 12.08.15 13:00
Здравствуйте!

Не знаю что и делать, после первой установки stunnel, все сразу заработало, не следующий день начал выдавать ошибку :
"cannot authenticate to smtp server 535 incorrect authentication data".

У меня 1С Предприятие 8.3, конфигурация 1С Консолидация ПРОФ, и платформа и конфигурация последние версии.
Настройки учетной записи в 1С Консолидация прикрепил.
Файл stunnel тоже.
Прикрепленные файлы:
78. Ал Нар (nab1985) 12.08.15 13:05
И если можно подскажите, куда нужно зайти в 1С, чтобы включить SSL?
Может получится обойтись без stunnel .
79. Даниил Матвеев (cargobird) 12.08.15 14:52
(78) nab1985, судя по скриншотам у вас поддержка SSL еще не прописана на уровне интерфейса.
А на уровне кода - в комментариях несколько раз упомянуты места, которые надо изменять - но по-видимому у вас конфигурация типовая.
Попробуйте еще в гугле включить доступ к аккаунту непроверенных приложений: Google
Если не получится - пишите, подумаем где еще может быть затык.
80. Ал Нар (nab1985) 12.08.15 15:24
(79) Забыл написать, что доступ непроверенных приложений в гугле включил.
Но, результата нет.

Я правильно Вас понял, что разрешение использовать SSL можно включать в некоторых конфигурациях прямо с пользовательского режима, даже не заходя в конфигуратор?

Может у меня только в конфигурации это как-то включается? Если нужно, быть может какой-то код из конфигуратора прислать?


81. Даниил Матвеев (cargobird) 12.08.15 15:47
(80) nab1985, у вас, видимо, это только в конфигураторе.
Поищите, пожалуйста, код, связанный с ИнтернетПочтовыйПрофиль, подобно тому, что описано в посте (76) .
Если сами не разберетесь - пишите сюда, посмотрим.
82. Ал Нар (nab1985) 12.08.15 16:01
(81) Вот этого нашел, насколько это полезно будет, не могу сказать, не силен в этих кодах всех :

// Устанавливает соединение с сервером электронной почты
// Параметры:
// Профиль       - ИнтернетПочтовыйПрофиль - профиль учетной записи электронной
//                 почты, через который необходимо установить соединение
//
// Возвращаемое значение:
// Соединение (тип ИнтернетПочта)
//
Функция УстановитьСоединениеССерверомЭлектроннойПочты(Профиль) Экспорт
	
	Соединение = Новый ИнтернетПочта;
	Соединение.Подключиться(Профиль);
	
	Возврат Соединение;
	
КонецФункции

////////////////////////////////////////////////////////////­////////////////////
// Блок системных и вспомогательных функций подсистемы
//

// По переданной ссылке на учетную запись формирует профиль почтового соединения
//
// Параметры
// УчетнаяЗапись - СправочникСсылка.УчетнаяЗаписьЭлектроннойПочты - 
//                 параметры профиля в виде соответствия
//
// Возвращаемое значение
// Почтовый профиль (тип ИнтернетПочтовыйПрофиль)
//
Функция СформироватьИнтернетПрофиль(знач УчетнаяЗапись,
                                    знач Пароль = Неопределено,
                                    знач ФормироватьSMTPПрофиль = Истина,
                                    знач ФормироватьPOP3Профиль = Истина) Экспорт
	
	Профиль = Новый ИнтернетПочтовыйПрофиль;
	
	Профиль.Пользователь = УчетнаяЗапись.Пользователь;
	
	Профиль.ВремяОжидания = УчетнаяЗапись.ВремяОжидания;
	
	Если ЗначениеЗаполнено(Пароль) Тогда
		Профиль.Пароль = Пароль;
	Иначе
		Профиль.Пароль = УчетнаяЗапись.Пароль;
	КонецЕсли;
	
	Если ФормироватьSMTPПрофиль Тогда
		Профиль.АдресСервераSMTP = УчетнаяЗапись.SMTPСервер;
		Профиль.ПортSMTP         = УчетнаяЗапись.ПортSMTP;
		
		Если      УчетнаяЗапись.SMTPАутентификация = Перечисления.ВариантыSMTPАутентификации.АналогичноPOP3 Тогда
			Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
			Профиль.ПользовательSMTP   = УчетнаяЗапись.Пользователь;
			Профиль.ПарольSMTP         = УчетнаяЗапись.Пароль;
		ИначеЕсли УчетнаяЗапись.SMTPАутентификация = Перечисления.ВариантыSMTPАутентификации.ЗадаетсяПараметрами Тогда
			
			Если      УчетнаяЗапись.СпособSMTPАутентификации = Перечисления.СпособыSMTPАутентификации.CramMD5 Тогда
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.CramMD5;
			ИначеЕсли УчетнаяЗапись.СпособSMTPАутентификации = Перечисления.СпособыSMTPАутентификации.Login Тогда
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;
			ИначеЕсли УчетнаяЗапись.СпособSMTPАутентификации = Перечисления.СпособыSMTPАутентификации.Plain Тогда
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.Plain;
			ИначеЕсли УчетнаяЗапись.СпособSMTPАутентификации = Перечисления.СпособыSMTPАутентификации.БезАутентификации Тогда
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
			Иначе
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
			КонецЕсли;
			
			Профиль.ПользовательSMTP = УчетнаяЗапись.ПользовательSMTP;
			Профиль.ПарольSMTP       = УчетнаяЗапись.ПарольSMTP;
			
		ИначеЕсли УчетнаяЗапись.SMTPАутентификация = Перечисления.ВариантыSMTPАутентификации.POP3ПередSMTP Тогда
			Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
			Профиль.POP3ПередSMTP = Истина;
		Иначе
			Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
		КонецЕсли;
	КонецЕсли;
	
	Если ФормироватьPOP3Профиль Тогда
		Профиль.АдресСервераPOP3 = УчетнаяЗапись.POP3Сервер;
		Профиль.ПортPOP3         = УчетнаяЗапись.ПортPOP3;
		
		Если      УчетнаяЗапись.СпособPOP3Аутентификации = Перечисления.СпособыPOP3Аутентификации.APOP Тогда
			Профиль.АутентификацияPOP3 = СпособPOP3Аутентификации.APOP;
		ИначеЕсли УчетнаяЗапись.СпособPOP3Аутентификации = Перечисления.СпособыPOP3Аутентификации.CramMD5 Тогда
			Профиль.АутентификацияPOP3 = СпособPOP3Аутентификации.CramMD5;
		Иначе
			Профиль.АутентификацияPOP3 = СпособPOP3Аутентификации.Обычная;
		КонецЕсли;
	КонецЕсли;
	
	Возврат Профиль;
	
КонецФункции
...Показать Скрыть
83. Даниил Матвеев (cargobird) 12.08.15 21:39
(82) nab1985, по видимому перед
Возврат Профиль;
в функции Функция СформироватьИнтернетПрофиль надо вставить две строки, обведенные на картинке в посте (76)
После внесения изменений в конфигурацию параметры подключения измените уже на нормальные для SSL, то есть обычные для SSL адреса и порты, которые вы вставляли в stunnel.conf.
И попробуйте подключиться, вроде должно заработать.
84. Ал Нар (nab1985) 13.08.15 09:04
(83) После того как я вставлю эти две строки, мне нужно просто закрыть конфигуратор, в ответ на предложение сохранить изменения ответить положительно, и больше ничего в нем не надо делать?
85. Ал Нар (nab1985) 13.08.15 11:00
(83) ВСЕ ЗАРАБОТАЛО!

Нюанс только один, когда нажимаю "Проверка учетной записи" показывает что все успешно, и тестовое письмо доходит без проблем на почту.
Но когда прост хочу отправить письмо, пишет :

мэйл проверка. {ОбщийМодуль.УправлениеЭлектроннойПочтой.Модуль(1095)}: Ошибка при вызове метода контекста (Подключиться): SMTP greeting failure: 421 SMTP connection broken (reply)
86. Даниил Матвеев (cargobird) 13.08.15 11:26
(85) nab1985, попробуйте поставить порт SMTP равным 25.
87. Даниил Матвеев (cargobird) 13.08.15 12:04
(85) nab1985, или... у вас какой сейчас порт стоит?
88. Ал Нар (nab1985) 13.08.15 12:26
(87) Я создал учетную запись к mail.ru

pop.mail.ru - 995
smtp.mail.ru - 465

На 25 попробовал поменять, при проверке учетной записи, сразу ошибку выдает
89. Ал Нар (nab1985) 13.08.15 12:32
(87)
Ошибка :
tls/ssl failure for smtp.mail.ru invalid token probably not an ssl server(87)
90. Даниил Матвеев (cargobird) 13.08.15 13:20
(89) nab1985, такой момент.
Не знаю вашего уровня, поэтому распишу подробно.
Вы можете зайти в Конфигуратор и посмотреть, слева вверху дерева метаданных конфигуратора справа от надписи "Конфигурация" горит такой значок <!> или нет?
Если горит, закройте Предприятие оставив Конфигуратор открытым, и нажмите F7.
Тогда изменения по тем двум строкам будут внесены в информационную базу.
И снова попробуйте проверить и послать почту с портами 995 и 465.
91. Ал Нар (nab1985) 13.08.15 13:22
Кстати, такое вот дело, я создаю письмо в 1С-ке, нажимаю отправить, он не отправляет, показывает мне 421 ошибку, но при этом мне приходит сообщение Test на почту.

Чего это с ним?
92. Ал Нар (nab1985) 13.08.15 13:31
(90) Я очень слабоват в работе с конфигуратором, спасибо что расписали.
Значка (!) нет, я так понимаю с помощью F7 я должен был сохранить внесенные мною изменения. Я это сделал.
И поэтому у меня заработала проверка учетной записи, не работает только отправка самих сообщений.
93. Даниил Матвеев (cargobird) 13.08.15 14:57
(92) nab1985, можете зайти в код и оттуда скопировать и отправить сюда строчки, которые вы вставили?
Вообще эта ошибка выдается, когда не установлено SSL-шифрование для SMTP.
Если все делали правильно - по идее этих двух строк должно быть достаточно.
94. Ал Нар (nab1985) 14.08.15 08:59
(93) Здравствуйте!!!

Вот код, в самом низу вставка, может действительно что-то не так вставил :

// По переданной ссылке на учетную запись формирует профиль почтового соединения
//
// Параметры
// УчетнаяЗапись - СправочникСсылка.УчетнаяЗаписьЭлектроннойПочты - 
//                 параметры профиля в виде соответствия
//
// Возвращаемое значение
// Почтовый профиль (тип ИнтернетПочтовыйПрофиль)
//
Функция СформироватьИнтернетПрофиль(знач УчетнаяЗапись,
                                    знач Пароль = Неопределено,
                                    знач ФормироватьSMTPПрофиль = Истина,
                                    знач ФормироватьPOP3Профиль = Истина) Экспорт
	
	Профиль = Новый ИнтернетПочтовыйПрофиль;
	
	Профиль.Пользователь = УчетнаяЗапись.Пользователь;
	
	Профиль.ВремяОжидания = УчетнаяЗапись.ВремяОжидания;
	
	Если ЗначениеЗаполнено(Пароль) Тогда
		Профиль.Пароль = Пароль;
	Иначе
		Профиль.Пароль = УчетнаяЗапись.Пароль;
	КонецЕсли;
	
	Если ФормироватьSMTPПрофиль Тогда
		Профиль.АдресСервераSMTP = УчетнаяЗапись.SMTPСервер;
		Профиль.ПортSMTP         = УчетнаяЗапись.ПортSMTP;
		
		Если      УчетнаяЗапись.SMTPАутентификация = Перечисления.ВариантыSMTPАутентификации.АналогичноPOP3 Тогда
			Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
			Профиль.ПользовательSMTP   = УчетнаяЗапись.Пользователь;
			Профиль.ПарольSMTP         = УчетнаяЗапись.Пароль;
		ИначеЕсли УчетнаяЗапись.SMTPАутентификация = Перечисления.ВариантыSMTPАутентификации.ЗадаетсяПараметрами Тогда
			
			Если      УчетнаяЗапись.СпособSMTPАутентификации = Перечисления.СпособыSMTPАутентификации.CramMD5 Тогда
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.CramMD5;
			ИначеЕсли УчетнаяЗапись.СпособSMTPАутентификации = Перечисления.СпособыSMTPАутентификации.Login Тогда
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;
			ИначеЕсли УчетнаяЗапись.СпособSMTPАутентификации = Перечисления.СпособыSMTPАутентификации.Plain Тогда
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.Plain;
			ИначеЕсли УчетнаяЗапись.СпособSMTPАутентификации = Перечисления.СпособыSMTPАутентификации.БезАутентификации Тогда
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
			Иначе
				Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
			КонецЕсли;
			
			Профиль.ПользовательSMTP = УчетнаяЗапись.ПользовательSMTP;
			Профиль.ПарольSMTP       = УчетнаяЗапись.ПарольSMTP;
			
		ИначеЕсли УчетнаяЗапись.SMTPАутентификация = Перечисления.ВариантыSMTPАутентификации.POP3ПередSMTP Тогда
			Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
			Профиль.POP3ПередSMTP = Истина;
		Иначе
			Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
		КонецЕсли;
	КонецЕсли;
	
	Если ФормироватьPOP3Профиль Тогда
		Профиль.АдресСервераPOP3 = УчетнаяЗапись.POP3Сервер;
		Профиль.ПортPOP3         = УчетнаяЗапись.ПортPOP3;
		
		Если      УчетнаяЗапись.СпособPOP3Аутентификации = Перечисления.СпособыPOP3Аутентификации.APOP Тогда
			Профиль.АутентификацияPOP3 = СпособPOP3Аутентификации.APOP;
		ИначеЕсли УчетнаяЗапись.СпособPOP3Аутентификации = Перечисления.СпособыPOP3Аутентификации.CramMD5 Тогда
			Профиль.АутентификацияPOP3 = СпособPOP3Аутентификации.CramMD5;
		Иначе
			Профиль.АутентификацияPOP3 = СпособPOP3Аутентификации.Обычная;
		КонецЕсли;
	КонецЕсли;
	
	Профиль.ИспользоватьSSLSMTP = Истина;
	Профиль.ИспользоватьSSLPOP3 = Истина;
	
	Возврат Профиль;
	
КонецФункции
...Показать Скрыть
95. Даниил Матвеев (cargobird) 14.08.15 09:02
(94) nab1985, на работе нет платформы 8.3...
На выходных посмотрю, в чем еще может быть дело.
96. Ал Нар (nab1985) 14.08.15 09:16
Спасибо, очень буду ждать
97. Ал Нар (nab1985) 14.08.15 10:41
(75) здесь Вы указывает что нужно вставить вот в такой код.

Я хотел уточнить, нужно было стереть то что указано тут (75) и вставить на его место те две строки или просто дополнительно к этим строкам добавить строки :

Профиль.ИспользоватьSSLSMTP = Истина;
Профиль.ИспользоватьSSLPOP3 = Истина;

????????
98. Ал Нар (nab1985) 14.08.15 10:47
(95) Извините еще вопросик.

Я переустановил stunnel, проверка прошла успешно, но при отправке сообщения с 1С, выдает сообщение :

Ошибка при вызове метода контекста (Послать): Сервер требует аутентификации (SMTP error code 530)

что это может быть???
99. Даниил Матвеев (cargobird) 14.08.15 10:53
(97) nab1985, во-первых, я писал про пост (76), во вторых - да, добавить, так что, видимо, все правильно...
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа