gifts2017

Минимализмы

Опубликовал Сергей (ildarovich) в раздел Программирование - Практика программирования

Приводится подборка кратчайших решений некоторых задач. Ранее эти решения были разбросаны по комментариям к чужим публикациям.

После упразднения блогов стало негде хранить небольшие короткие решения, сделанные в ходе обсуждения интересных задач других авторов. Решил собрать все такие свои решения в одну статью, которую надеюсь постепеннно дополнять. Большинство решений выполнено в стиле "минимализма" и, наверное, не могут служить примером для подражания. То есть это такие сублиматы кода, которые перед употреблением, возможно, следует еще "размочить" комментариями.

С другой стороны, есть конкурсы по "гольфу" для программистов, где требуется решить задачу с использованием минимального количества команд. Приведенные решения можно использовать для соответствующей тренировки. 

Решения приведены с минимумом пояснений или вообще без них. Заинтересовавшимся стоит посмотреть ссылки на исходные обсуждения или задать вопросы здесь. Постараюсь на них ответить.

1. Квайн (программа, распечатывающая свой собственный текст)

http://infostart.ru/public/87861/

С="С="";Л=Лев(С,3);П=Сред(С,3);Сообщить(Л+Л+П+П)";Л=Лев(С,3);П=Сред(С,3);Сообщить(Л+Л+П+П)
Процедура КВН(К)С="Процедура КВН(К)С="";Л=Лев(С,19);П=Сред(С,19);Сообщить(Л+Л+П+П)КонецПроцедуры";Л=Лев(С,19);П=Сред(С,19);Сообщить(Л+Л+П+П)КонецПроцедуры

2. Колонка сжато

http://infostart.ru/public/82347/

Суть задачи в том, что в колонке табличной части находятся целые числа. Необходимо "сжать" ряд чисел, заменив подряд идущие числа их диапазоном.

Например: 1, 3, 4, 5, 7, 10, 11, 12, 16 должно превратиться в 1, 3-5, 7, 10-12, 16. 

Функция КолонкаСжато(ДокументСсылка, ИмяТабличнойЧасти, ИмяКолонки, Слэш = ",", Тире = "-")
    Запрос = Новый Запрос("ВЫБРАТЬ Различные " + ИмяКолонки + " ИЗ Документ." + ДокументСсылка.Метаданные().Имя + "." + ИмяТабличнойЧасти + " ГДЕ Ссылка = &Ссылка Упорядочить ПО " + ИмяКолонки);
    Запрос.УстановитьПараметр("Ссылка", ДокументСсылка);
    Ряд = Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку(ИмяКолонки);
    Если Ряд.Количество() = 0 Тогда Возврат ""
    КонецЕсли;
    Ряд.Добавить(0); Ряд.Добавить(0);
    Сжато = Строка(Ряд[0]);
    Для ё = 1 По Ряд.Количество() - 3 Цикл
        Если Число(Ряд[ё + 1]) - Число(Ряд[ё - 1]) <> 2 Тогда
            Сжато = Сжато + Слэш + Строка(Ряд[ё])
        ИначеЕсли Число(Ряд[ё + 2]) - Число(Ряд[ё]) <> 2 Тогда
            Сжато = Сжато + Тире
        КонецЕсли
    КонецЦикла;
    Возврат СтрЗаменить(Сжато, Тире + Слэш, Тире)
КонецФункции

3. Сортировка слиянием

http://infostart.ru/public/70024/

Дано два отсортированных по возрастанию массива А и В. Необходимо вывести по возрастанию все элементы этих массивов. 

ёж = 0; 
Для уж = 0 По А.Количество() + В.Количество() - 1 Цикл 
    що = (уж - ёж) = В.Количество() ИЛИ ёж < А.Количество() И А[ёж] < В[уж - ёж]; 
    Сообщить(?(що, "а" + ёж + "=" + А[ёж], "в" + (уж - ёж) + "=" + В[уж - ёж])); 
    ёж = ёж + що 
КонецЦикла
ё = 0; 
Для Сч = 1 По А.Количество() + В.Количество() Цикл 
    ж = (Сч - 1 - ё) = В.Количество() ИЛИ ё < А.Количество() И А[ё] < В[Сч - 1 - ё]; 
    Сообщить(?(ж, "А[" + ё + "]=" + А[ё], "В[" + (Сч - 1 - ё) + "]=" + В[Сч - 1 - ё])); 
    ё = ё + ж 
КонецЦикла

4. Срезы последних (интерполяция периодических сведений)

http://infostart.ru/public/77568/

"Срезы последних" - одна из первых задач, на которой спотыкается начинающий программист 1С. Хорошо поняв идею виртуального регистра "Срез последних", мы ожидаем такой же простоты, если задана не одна дата, на которую нужно выбрать сведения, а несколько. Но, увы, приходится использовать два запроса. В первом мы выбираем ближайшие в прошлом даты, на которые были установлены значения, а во втором по датам определяем сами значения.

Оказывается, при большом желании можно уложиться в один запрос. Вот этот запрос для примера решения задачи "Продажи с выводом цены заданного типа, действующей на момент отгрузки".

ВЫБРАТЬ 
    Продажи.Период,
    Продажи.Контрагент, 
    Продажи.Номенклатура, 
    СУММА(Продажи.КоличествоОборот) КАК Количество, 
    СУММА(Продажи.СтоимостьОборот) КАК Стоимость, 
    МИНИМУМ(РАЗНОСТЬДАТ(ЦеныНоменклатуры.Период, Продажи.Период, ДЕНЬ) * &Много + ЦеныНоменклатуры.Цена) 
    - МИНИМУМ(РАЗНОСТЬДАТ(ЦеныНоменклатуры.Период, Продажи.Период, ДЕНЬ) * &Много) КАК Цена 
ИЗ 
    РегистрНакопления.Продажи.Обороты(&НачалоПериода, &КонецПериода, День, ) КАК Продажи 
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры 
            ПО Продажи.Номенклатура = ЦеныНоменклатуры.Номенклатура 
            И (ЦеныНоменклатуры.ТипЦен = &ТипЦен) 
            И (ЦеныНоменклатуры.Период < = Продажи.Период)
СГРУППИРОВАТЬ ПО 
    Продажи.Период, 
    Продажи.Контрагент, 
    Продажи.Номенклатура

Идея в том, чтобы вместо поиска периода, на котором начинается актуальная цена, искать саму цену. Для этого подобрана функция, которая "отправляет" цену прошлого периода на свой "эшелон", высота которого зависит от древности цены. Ширина "эшелона" задается параметром "Много" - это величина, гарантированно перекрывающая диапазон изменения цены (1000000, 10000000 и т.п.). После нахождения ближайшей (нижайшей) "летящей" цены, высота соответствующего "эшелона" вычитается и цена "опускается на землю". 

Можно подобрать функцию для дат, булевых и строковых значений.

Кроме краткости записи, других достоинств у запроса нет. Минусы - некоторый проигрыш по времени "классическому" запросу из-за большего объема вычислений в группировках, необходимость думать над значением "Много", работа только с простыми типами.

Вообще, вместе с этим, известно четыре способа интерполяции. Интересно было бы провести вычислительный эксперимент по сравнению их эффективности. Пока всегда выигрывал классический способ.

5. ЗначениеСвойства

http://infostart.ru/public/89809/

Для получения значения одного свойства выбранного объекта хватает одной строки кода, которую можно оформить в виде функции или использовать "инлайн"

ЗначениеСвойства = РегистрыСведений.ЗначенияСвойствОбъектов.Получить(Новый Структура("Объект, Свойство", ОбъектСсылка, ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию(ИмяСвойства))).Значение;

6. Остатки на каждый день

http://infostart.ru/public/102435/

Стандартная выборка из виртуального регистра остатков и оборотов не показывает остатки на периодах, в которых нет оборотов. В СКД, то есть вне запроса проблема легко решается, а для использования внутри запроса приходится "городить огород". У многих это выливается в несколько запросов, тогда как можно обойтись и одним. Остатки здесь получаются суммированием оборотов. По тому же принципу платформа рассчитывает остатки внутри периода хранения итогов.

ВЫБРАТЬ РАЗЛИЧНЫЕ
    КурсыВалют.Период
ПОМЕСТИТЬ Дни
ИЗ
    РегистрСведений.КурсыВалют КАК КурсыВалют
ГДЕ
    КурсыВалют.Период МЕЖДУ &НачалоПериода И &КонецПериода
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    Движения.Номенклатура,
    ДНИ.Период,
    СУММА(ВЫБОР
            КОГДА Движения.Период = &НачалоПериода
                ТОГДА Движения.КоличествоКонечныйОстаток
            ИНАЧЕ ВЫБОР
                    КОГДА Движения.Период < = ДНИ.Период
                        ТОГДА Движения.КоличествоОборот
                    ИНАЧЕ 0
                КОНЕЦ
        КОНЕЦ) КАК КоличествоКонечныйОстаток
ИЗ
    Дни КАК ДНИ,
    РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(&НачалоПериода, &КонецПериода, День, , Номенклатура = &Номенклатура) КАК Движения

СГРУППИРОВАТЬ ПО
    Движения.Номенклатура,
    ДНИ.Период

Правда, здесь рассчитываются остатки на конец каждого дня (это легко поправить, сдвинув даты на -1). Регистр "КурсыВалют" взят для краткости и для разнообразия - все даты внутри периода можно получать и по другому. Классический вариант проигрывает по быстродействию предложенному примерно в 1.5 раза (проверялось на файловой базе УПП). 

7. Связывание таблиц значений по ФИФО

Если имеется две таблицы с колонками: Период, Документ, Сумма, то часто возникает задача построения объединенной таблицы "Результат" с колонками Период1, Документ1, Период2, Документ2, Сумма, в которой документы двух таблиц связаны по ФИФО. Чтобы функция Результат.Свернуть("Период1,Документ1", "Сумма") давала первую таблицу, а Результат.Свернуть("Период2,Документ2", "Сумма") - вторую. 

Такой задачей, является, например, распределение оплат по отгрузкам.

Вот требуемая функция. Осторожнее, так как она меняет исходные таблицы! 

Функция СвязываниеПоФИФО(А, Б, ё = 0, ж = 0) Экспорт
    Результат = НовыйТаблицаЗначений("Период1, Документ1, Период2, Документ2, Сумма");
    Пока ё < А.Количество() И ж < Б.Количество() Цикл
        Сумма = Мин(А[ё].Сумма, Б[ж].Сумма);
        ЗаполнитьЗначенияСвойств(Результат.Добавить()
        , Новый Структура("Период1, Документ1, Период2, Документ2, Сумма"
        , А[ё].Период, А[ё].Документ, Б[ж].Период, Б[ж].Документ, Сумма));
        А[ё].Сумма = А[ё].Сумма - Сумма;
        Б[ж].Сумма = Б[ж].Сумма - Сумма;
        ё = ё + (А[ё].Сумма = 0);
        ж = ж + (Б[ж].Сумма = 0)
    КонецЦикла;
    Возврат Результат 
КонецФункции

8. Формирование синонима переменной из идентификатора

http://infostart.ru/public/162834/

Вариант на основе стэйт-машины

Функция Синонимайзер(Имя, Ответ = "", Стэйт = 7, б = "") Экспорт
   Для ё = 1 По СтрДлина(Имя) Цикл
      а = Сред(Имя, ё, 1);
      Стэйт = (НРег(а) <> а) * 4 + Цел(Стэйт / 2);
      Ответ = Ответ + ?(Стэйт = 2, НРег(б), ?(ё = 2, ВРег(б), б)) + ?(Стэйт = 4 ИЛИ Стэйт = 5, " ", "");
      б = а
   КонецЦикла;
   Возврат Ответ + б
КонецФункции

Выгодное отличие здесь в том, что символ вырезается из строки и проверяется на регистр только один раз. Если б не надо было первую букву делать заглавной - было бы еще красивее.

9. Сравнение двух строк

http://infostart.ru/public/174530/

Результатом сравнения двух строк является массив, который показывает, что от "От" до "До" позиции строки совпадают (ОК = Истина) или нет.

Функция ТаблицаСравненияСтрок_(С1, С2) Экспорт
   Ответ = Новый ТаблицаЗначений; //Ответ = НоваяТаблицаЗначений("От, До, ОК");
   Ответ.Колонки.Добавить("От");
   Ответ.Колонки.Добавить("До"); 
   Ответ.Колонки.Добавить("ОК");  
   ЗаполнитьЗначенияСвойств(Ответ.Добавить(), Новый Структура("От, ОК", 1, Сред(С1, 1, 1) = Сред(С2, 1, 1)));
   Для ё = 2 По Макс(СтрДлина(С1), СтрДлина(С2)) Цикл
      Если Ответ[0].ОК <> (Сред(С1, ё, 1) = Сред(С2, ё, 1)) Тогда
         ЗаполнитьЗначенияСвойств(Ответ.Вставить(0), Новый Структура("От, ОК", ё, НЕ Ответ[1].ОК));                            
         Ответ[1].До = ё - 1
      КонецЕсли      
   КонецЦикла;
   Ответ[0].До = Макс(СтрДлина(С1), СтрДлина(С2));
   Возврат Ответ
КонецФункции

С дихотомией

Процедура РазДва(Ответ, С1, С2, От, До)
   Если От + 2 > До И (Сред(С1, От, 1) = Сред(С2, От, 1)) <> (Сред(С1, До, 1) = Сред(С2, До, 1)) Тогда
      ЗаполнитьЗначенияСвойств(Ответ.Вставить(0), Новый Структура("От, ОК", До, НЕ Ответ[1].ОК));
      Ответ[1].До = От
   ИначеЕсли  От + 1 < До И Сред(С1, От, До - От + 1) <> Сред(С2, От, До - От + 1) Тогда
      РазДва(Ответ, С1, С2, От, Цел((От + До) / 2));
      РазДва(Ответ, С1, С2, Цел((От + До) / 2), До)   
   КонецЕсли
КонецПроцедуры
Функция ТаблицаСравненияСтрок(С1, С2) Экспорт
   Ответ = Новый ТаблицаЗначений;
   Ответ.Колонки.Добавить("От");
   Ответ.Колонки.Добавить("До");
   Ответ.Колонки.Добавить("ОК");
   ЗаполнитьЗначенияСвойств(Ответ.Добавить(), Новый Структура("От, ОК", 1, Сред(С1, 1, 1) = Сред(С2, 1, 1)));
   РазДва(Ответ, С1, С2, 1, Макс(СтрДлина(С1), СтрДлина(С2)));
   Ответ[0].До = Макс(СтрДлина(С1), СтрДлина(С2));
   Возврат Ответ
КонецФункции

10. Ход конем

http://forum.infostart.ru/forum1/topic78895/message844453/#message84445

Определить количество и поля клеток, доставаемых конем, в зависимости от его положения на доске

 

ВЫБРАТЬ 1 у, "a" х
ПОМЕСТИТЬ а
ОБЪЕДИНИТЬ ВЫБРАТЬ 2, "b"
ОБЪЕДИНИТЬ ВЫБРАТЬ 3, "c"
ОБЪЕДИНИТЬ ВЫБРАТЬ 4, "d"
ОБЪЕДИНИТЬ ВЫБРАТЬ 5, "e"
ОБЪЕДИНИТЬ ВЫБРАТЬ 6, "f"
ОБЪЕДИНИТЬ ВЫБРАТЬ 7, "g"
ОБЪЕДИНИТЬ ВЫБРАТЬ 8, "h"
;
ВЫБРАТЬ г.х, д.у
ИЗ а а, а г, а д
ГДЕ а.х = &ах И (а.у - г.у) * (а.у - г.у) + (&бу - д.у) * (&бу - д.у) = 5


11. Сгибы листка (задача с собеседования)

http://infostart.ru/public/175509/

Функция возвращает строку, в которой 0 - сгиб от нас, 1 - к нам. Первый параметр - необходимое число сложений, второй и третий параметры служебные. Всего в записи функции 77 символов. Не по-русски потому, что так короче.

function W(k,a=0,b=0)return?(k<1,"",W(k-1,a+b)+a%2+W(k-1,a+1+b,1))endfunction

Если предположить, что число сгибов не может быть отрицательным, то можно сэкономить еще 2 символа. Итого 75 символов. Можно ли короче?

function W(k,a=0,b=0)return?(k,W(k-1,a+b)+a%2+W(k-1,a+b+1,1),"")endfunction

12. Найти кратчайший путь коня между двумя заданными клетками

http://forum.infostart.ru/forum1/topic78895/message839037/#message839037

Первая функция размечает доску, вторая рекурсивно перечисляет пути из конечной точки. 
Разметка идет "по спирали". Номер витка (круга) соответствует минимальному расстоянию от начальной точки. На каждом витке неразмеченные клетки просматриваются в паре с каждой клеткой последнего витка. Если расстояние (сумма квадратов разности координат равно пяти) соответствует шагу коня клетка включается в следующий виток (круг). И так пока в круг не попадет конечная клетка. В каждой клетке запоминается массив клеток предыдущего витка, из которых попадают в текущую. Это дает возможность рекурсивно раскрутить пути до начальной точке "при спуске".

Функция Спираль(А, Б, Круг = 0)Экспорт
    Поле = НоваяТаблицаЗначений("Х, У, Круг, Связи");
    Для К = 0 По 63 Цикл 
        ЗаполнитьЗначенияСвойств(Поле.Добавить(), Новый Структура("Х, У, Круг, Связи", Цел(К / 8), К % 8, (К = А) - 1, Новый Массив))
    КонецЦикла;
    Пока Поле[Б].Круг < 0 Цикл 
        Целина = Поле.НайтиСтроки(Новый Структура("Круг", -1));
        Трек = Поле.НайтиСтроки(Новый Структура("Круг", Круг));
        Для Каждого С Из Целина Цикл
            Для Каждого К Из Трек Цикл
                Если (С.Х - К.Х) * (С.Х - К.Х) + (С.У - К.У) * (С.У - К.У) = 5 Тогда
                    С.Круг = Круг + 1;
                    С.Связи.Добавить(К.Х * 8 + К.У)
                КонецЕсли
            КонецЦикла
        КонецЦикла;
        Круг = Круг + 1
    КонецЦикла;
    Возврат Поле
КонецФункции
Процедура Спуск(Б, Поле, Знач Путь = "") Экспорт
    Путь = Сред("abcdefgh", Б / 8 + 1, 1) + (Б % 8 + 1) + " " + Путь;
    Если Поле[Б].Связи.Количество() = 0 Тогда
        ЗаполнитьЗначенияСвойств(Пути.Добавить(), Новый Структура("Путь", Путь))
    Иначе
        Для Каждого К Из Поле[Б].Связи Цикл
            Спуск(К, Поле, Путь)
        КонецЦикла
    КонецЕсли
КонецПроцедуры

13. Функция для превращения строки в дату по форматной строке

http://infostart.ru/public/200111/

Функция СтрокаВДату(Знач ФорматДаты, Знач Дано, Ошибка = Ложь) Экспорт 
    Попытка 
        ё = Формат('00010101', "ДФ=" + ФорматДаты) // - необязательная проверка первого правильности параметра 
    Исключение 
        Ошибка = Истина; 
        Возврат '00010101' 
    КонецПопытки; 
    Ч = Новый Соответствие; 
    Для ё = 1 По СтрДлина(ФорматДаты) + 7 Цикл 
        Ч[Сред(ФорматДаты + "dMyHhms", ё, 1)] = 0	// - инициализация частей даты 
    КонецЦикла; 
    Для ё = 1 По 12 Цикл 
        Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMММ"), Формат(ё, "ЧЦ=4; ЧВН=")); // - замена названий месяцев числами 
        Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMМ" ), Формат(ё, "ЧЦ=3; ЧВН=")) 
    КонецЦикла; 
    Для ё = 1 По СтрДлина(ФорматДаты) Цикл 
        Ч[Сред(ФорматДаты, ё, 1)] = 10 * Ч[Сред(ФорматДаты, ё, 1)] + Найти("123456789", Сред(Дано, ё, 1)); // - накопление частей даты 
        Ошибка = Ошибка ИЛИ Найти("dMyHhms", Сред(ФорматДаты, ё, 1)) И НЕ Найти("0123456789", Сред(Дано, ё, 1)) // - необязательная проверка на цифры 
    КонецЦикла; 
    Ч["y"] = Ч["y"] + ?(Ч["y"] < 50, 2000, ?(Ч["y"] < 100, 1900, 0)); // - дополнение двух цифр года до четырех 
    Попытка 
        Возврат Дата(Ч["y"], Ч["M"], Ч["d"], Ч["H"] + Ч["h"], Ч["m"], Ч["s"]) 
    Исключение 
        Ошибка = Истина; 
        Возврат '00010101' 
    КонецПопытки 
КонецФункции 

14. Сжатое представление последовательности дат запросом

http://forum.infostart.ru/forum26/topic112033/message1160294/#message1160294

Задача похожа на сжатое представление ряда чисел, только роль чисел играют даты. Дана последовательность дат. Нужно заменить ее последовательностью непрерывных интервалов дат. Вот решение

ВЫБРАТЬ 
    Даты.Дата, 
    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ ДатыДо.Дата) КАК Номер 
ПОМЕСТИТЬ НомераДат 
ИЗ 
    ВТДаты КАК Даты 
    ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТДаты КАК ДатыДо 
        ПО (ДатыДо.Дата < = Даты.Дата) 
СГРУППИРОВАТЬ ПО 
    Даты.Дата 
; 

//////////////////////////////////////////////////////////////////////////////// 
ВЫБРАТЬ 
    МИНИМУМ(НомераДат.Дата) КАК ДатаНач, 
    МАКСИМУМ(НомераДат.Дата) КАК ДатаКон 
ИЗ 
    НомераДат КАК НомераДат 
СГРУППИРОВАТЬ ПО 
    ДОБАВИТЬКДАТЕ(НомераДат.Дата, ДЕНЬ, -НомераДат.Номер)

15. Размещение восьми ферзей на шахматной доске для СУБД Oracle

Найти запросом все варианты размещения 8-ми ферзей на шахматной доске, чтобы они не били друг друга.

В Oracle много чего есть, включая рекурсию. Поэтому режение получилось коротким. Задача взята с Хабра из раздела "ненормальное программирование"

http://habrahabr.ru/post/228373/#first_unread

with 
    x(i) as (select level from dual connect by level < = 8),
    q(z, j) as (select '', 1 from dual 
                union all 
                select z || y.i, j + 1 from q inner join x y 
                    on not exists(select 1 from x where i < j and (y.i - substr(z, i, 1)) / (j - i) IN (-1, 0, 1))) 

cycle z set cyclemark to 'X' default '-'

select translate('a1 b2 c3 d4 e5 f6 h7 g8', '12345678', z) from q where j = 8 + 1

16. Добавить к дате и разность дат

Функции для работы с датами как в языке запросов

http://infostart.ru/public/308429/

Функция ДобавитьКДате(Дата1, Количество, Период) Экспорт
	Шаг = Новый Структура("Год, Квартал, Месяц, Неделя, День, Час, Минута, Секунда", 12, 3, 1, -604800, -86400, -3600, -60, -1);
	Возврат ?(Шаг[Период] > 0, ДобавитьМесяц(Дата1, Количество * Шаг[Период]), Дата1 - Количество * Шаг[Период])
КонецФункции
Функция РазностьДат(Дата1, Дата2, Период) Экспорт
	Шаг = Новый Структура("Год, Квартал, Месяц, Неделя, День, Час, Минута, Секунда", 12, 3, 1, -604800, -86400, -3600, -60, -1);
	Возврат Цел(?(Шаг[Период] > 0, Год(Дата2) * 12 + Месяц(Дата2) - 1, '00010101' - Дата2) / Шаг[Период]) 
		  - Цел(?(Шаг[Период] > 0, Год(Дата1) * 12 + Месяц(Дата1) - 1, '00010101' - Дата1) / Шаг[Период])
КонецФункции

ну и раз зашла речь о датах...

Функция Квартал

Функция Квартал(Дата) Экспорт  
    Возврат Цел((Месяц(Дата) - 1) / 3) + 1
КонецФункции

Названия месяцев прописью

Формат(Дата(1, НомерМесяца, 1),"ДФ=ММММ")

Название дней недели прописью

Формат(Дата(1, 1, 2 + НомерДняНедели),"ДФ=дддд")

17. Получение таблицы и массива, заполненных последовательностью чисел от 0 до N-1

Иногда бывает нужно быстро получить готовый массив с последовательностью чисел от 0 до N-1. Например, чтобы пронумеровать строки таблицы значений путем загрузки в нее колонки с номерами строк. Это можно очень быстро сделать, используя "Порождающий запрос". Все необходимые функции очень компактны. Поэтому они приведены здесь.

// Возвращает текст запроса, формирующего таблицу чисел rN с одной колонкой X (eng), содержащую ряд: 0, 1, (N - 1).
function ProtoText(N, M = 1000000000) export
    return ?(N > 2
    , ProtoText(M - Int(M - Sqrt(N)))
    + strreplace(strreplace(";select top #2 a.X * #1 + b.X X into r#2 from r#1 a, r#1 b", "#2", format(N, "NG=")), "#1", format(M - Int(M - Sqrt(N)), "NG="))
    , "select 0 X into r2 union select 1")
endfunction

// Возвращает таблицу, содержащую последовательность чисел: 0, 1, 2, ..., (ЧислоСтрок - 1)
Функция ПоследовательностьЧиселТаблицей(ЧислоСтрок) Экспорт
	Запрос = Новый Запрос(СтрЗаменить(ProtoText(ЧислоСтрок), "into r" + format(ЧислоСтрок, "NG="), ""));
	Возврат Запрос.Выполнить().Выгрузить()
КонецФункции

// Возвращает массив, содержащий последовательность чисел: 0, 1, 2, ..., (ЧислоЭлементов - 1) 
Функция ПоследовательностьЧиселМассивом(ЧислоЭлементов) Экспорт
	Возврат ПоследовательностьЧиселТаблицей(ЧислоЭлементов).ВыгрузитьКолонку(0)
КонецФункции

18. Простой трюк для быстрого объединения таблиц значений

Стандартный способ объединения двух таблиц значений заключается в организации цикла, в котором строки второй таблицы приписываются в конец копии первой. Для этого используется следующий простой код:

ОбъединениеТаблиц = Таблица1.Скопировать();
Для Каждого Строка Из Таблица2 Цикл ЗаполнитьЗначенияСвойств(ОбъединениеТаблиц.Добавить(), Строка) КонецЦикла

Все возможности оптимизация данного способа ограничиваются записью в одну строку и выбором таблицы с меньшим количеством элементов в качестве источника добавляемых строк.

Предлагаемый трюк заключается в последовательном выполнении трех действий:

1)      Вторая (добавляемая) таблица копируется в таблицу-результат;

2)      В начало таблицы результата перед уже скопированной таблицей вставляется столько пустых строк, сколько строк в первой таблице. Таким образом «освобождается место» для первой таблицы;

3)      Затем первая таблица помещается на освобожденное место методом выгрузки-загрузки колонок.  Фокус в том, что при загрузке колонки в таблицу значений, если загружаемая колонка короче целевой, то оставшиеся элементы целевой колонки не меняются.

Схематичное описание той же последовательности действий приведено на рисунке ниже

Схема способа

Реализация предложенного способа очень проста и выполняется следующим фрагментом программного кода:

ОбъединениеТаблиц = Таблица2.Скопировать();
Для ё = 1 По Таблица1.Количество() Цикл ОбъединениеТаблиц.Вставить(0) КонецЦикла;
Для ё = 0 По Таблица1.Колонки.Количество() - 1 Цикл 
	ОбъединениеТаблиц.ЗагрузитьКолонку(Таблица1.ВыгрузитьКолонку(ё), ё) 
КонецЦикла;

 

Колонок в таблицах значений обычно всегда значительно меньше, чем строк. Поэтому такой способ содержит меньше отдельных действий и в результате выполняется платформой быстрее построчного копирования. Ускорение зависит от соотношения числа строк и столбцов и может достигать полутора раз.

19. Загадка суммы и произведения

Пусть x и y два целых числа 1 < = x < = y притом x + y  < = 100.
Салли сказали только сумму x + y, а вот Полю произведение xy.
Салли и Пол честнейшие ребята, это всем известно, они и друг другу отродясь не врали.
И вот такой вышел у них разговор:
Пол: «Не знаю я, что это за числа.»
Салли: «Тоже новость. Я знаю, что ты не знаешь.»
Пол: «Ну твоя то сумма мне теперь известна.»
Салли: «Да уж и мне теперь твое произведение.»
Каковы числа?

ВЫБРАТЬ 0 КАК Х
ПОМЕСТИТЬ Бит
ОБЪЕДИНИТЬ ВЫБРАТЬ 1
;
ВЫБРАТЬ	Бит0.Х + 2 * (Бит1.Х + 2 * (Бит2.Х + 2 * (Бит3.Х + 2 * (Бит4.Х + 2 * (Бит5.Х + 2 * Бит6.Х))))) КАК Х
ПОМЕСТИТЬ Ряд
ИЗ Бит КАК Бит6, Бит КАК Бит5, Бит КАК Бит4, Бит КАК Бит3, Бит КАК Бит2, Бит КАК Бит1, Бит КАК Бит0
;
ВЫБРАТЬ Ряд1.Х КАК Х, Ряд2.Х КАК У, Ряд1.Х + Ряд2.Х КАК Сумма, Ряд1.Х * Ряд2.Х КАК ХУ
ПОМЕСТИТЬ Пробы
ИЗ Ряд КАК Ряд1, Ряд КАК Ряд2
ГДЕ 1 < Ряд1.Х И Ряд1.Х < Ряд2.Х И Ряд1.Х + Ряд2.Х <= 100
;
ВЫБРАТЬ РАЗЛИЧНЫЕ Сумма
ПОМЕСТИТЬ ТабуСумм
ИЗ Пробы
ГДЕ ХУ В (ВЫБРАТЬ ХУ ИЗ Пробы СГРУППИРОВАТЬ ПО ХУ ИМЕЮЩИЕ КОЛИЧЕСТВО(*) = 1)
;
ВЫБРАТЬ	ХУ КАК Произведение
ПОМЕСТИТЬ ЧислаПоля
ИЗ Пробы
ГДЕ	НЕ Сумма В (ВЫБРАТЬ * ИЗ ТабуСумм)
СГРУППИРОВАТЬ ПО ХУ
ИМЕЮЩИЕ КОЛИЧЕСТВО(РАЗЛИЧНЫЕ Сумма) = 1
;
ВЫБРАТЬ Сумма, МАКСИМУМ(Произведение), МАКСИМУМ(Х), МАКСИМУМ(У)
ИЗ Пробы ВНУТРЕННЕЕ СОЕДИНЕНИЕ ЧислаПоля ПО ХУ = Произведение
ГДЕ НЕ Сумма В (ВЫБРАТЬ * ИЗ ТабуСумм)
СГРУППИРОВАТЬ ПО Сумма
ИМЕЮЩИЕ КОЛИЧЕСТВО(РАЗЛИЧНЫЕ Произведение) = 1

20. Поразрядное исключающее ИЛИ

Для решения задачи Задача о 64 монетах, двух заключённых и одной шахматной доске написан запрос

ВЫБРАТЬ
	Дано.Икс
ПОМЕСТИТЬ Дано
ИЗ
	&Дано КАК Дано
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
	1 КАК Вес
ПОМЕСТИТЬ Позиции

ОБЪЕДИНИТЬ

ВЫБРАТЬ
	2

ОБЪЕДИНИТЬ

ВЫБРАТЬ
	4

ОБЪЕДИНИТЬ

ВЫБРАТЬ
	8

ОБЪЕДИНИТЬ

ВЫБРАТЬ
	16

ОБЪЕДИНИТЬ

ВЫБРАТЬ
	32
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
	СУММА(Разряды.Вес * (Разряды.Икс - (ВЫРАЗИТЬ(Разряды.Икс / 2 + 0.5 КАК ЧИСЛО(10, 0))) * 2 + 2)) КАК Икс
ИЗ
	(ВЫБРАТЬ
		Позиции.Вес КАК Вес,
		СУММА((ВЫРАЗИТЬ(Дано.Икс / Позиции.Вес + 0.5 КАК ЧИСЛО(10, 0))) - 1) КАК Икс
	ИЗ
		Дано КАК Дано,
		Позиции КАК Позиции
	
	СГРУППИРОВАТЬ ПО
		Позиции.Вес) КАК Разряды


Этот запрос определяет шесть разрядов контрольной суммы, полученных выполнением поразрядного суммирования по модулю два чисел, заданных в таблице "Дано". Приведенный запрос может использоваться при создании и проверке контрольных соотношений, при других действиях в арифметике полей Галуа GF(2^6). Запрос легко обобщается на другие разрядности.

21. Определение длины строки в запросе

Это тема из обсуждения "Как с помощью запроса посчитать количество символов в реквизите"

ВЫБРАТЬ
	Дано.НомерСтроки,
	Дано.Строка
ПОМЕСТИТЬ Дано
ИЗ
	&Дано КАК Дано
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
	0 КАК ё
ПОМЕСТИТЬ Р0

ОБЪЕДИНИТЬ

ВЫБРАТЬ
	1
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
	2 * Р1.ё + Р0.ё КАК ё
ПОМЕСТИТЬ Р10
ИЗ
	Р0 КАК Р1,
	Р0 КАК Р0
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
	4 * Р32.ё + Р10.ё КАК ё
ПОМЕСТИТЬ Р3210
ИЗ
	Р10 КАК Р32,
	Р10 КАК Р10
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
	16 * Р54.ё + Р3210.ё + 1 КАК ё
ПОМЕСТИТЬ Р543210
ИЗ
	Р10 КАК Р54,
	Р3210 КАК Р3210
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
	Дано.НомерСтроки,
	Дано.Строка,
	МАКСИМУМ(Р543210.ё) КАК ДлинаСтроки
ИЗ
	Дано КАК Дано,
	Р543210 КАК Р543210
ГДЕ
	ПОДСТРОКА(Дано.Строка, Р543210.ё, 1) + "!" <> "!"

СГРУППИРОВАТЬ ПО
	Дано.НомерСтроки,
	Дано.Строка

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Maxim Kolkin (the1) 09.10.14 08:51
2. Алексей Потехин (trumanl) 09.10.14 10:59
Классная подборка, так сказать на "подумать".
Конечно в реальных задачах не часто этому можно найти применение, но кое-что взял на заметку.
Спасибо! Люблю читать Ваши статьи.
3. Денис Соломасов (Denis S) 09.10.14 11:08
Спасибо за статью! Хорошая пища для ума будет)
marsovna; +1 Ответить
4. John Smith (PiccaHut001) 09.10.14 11:11
"15. Размещение восьми ферзей на шахматной доске для СУБД Oracle" и 1С неразрывно связаны. Я вот, каждый день прихожу на работу, попью чаю, и сразу думаю, как-бы разместить 8(ВОСЕМЬ!!!) ферзей на шахматной доске. Ситуация очень жизненная, у каждого дома должно быть 4 набора шахмат, чтобы получилось восемь ферсей, а то некомильфо. Спасибо автору, не поленился, и собрал вместе такие нужные ссылки.
vovaikilko; Krasnyj; cypherpunks01; Захаров_Николай; pomestnik; myr4ik07; badboychik; DoctorRoza; EMelihoff; Maxis; zainaz; talych; Dimon2005; ojiojiowka; ya.Avoronov; Mingrel; fordes; sorb; CyberCerber; DimaBab; fzt; nixel; Дмитрий74Чел; RailMen; Nuobu; palsergeich; succub1_5; CratosX; smit1c; jmi; fomix; AllexSoft; Steelvan; ssega; tehas; sashocq; Mihas_01; mbreaker; alexnecro; Mi4man; alexinzaz; Pawlick; Anchoret; sh_max; sergelemon; Aleks_Antonuk; Sasha_jr; SeiOkami; +48 Ответить 1
5. Tindir Mindir (tindir) 09.10.14 11:22
забавно, что если 1с писать на басурманском, то он легким движениме руки начинета походить на JS со сторонними библиотеками=)
6. Сергей (ildarovich) 09.10.14 11:46
(4) PiccaHut001, здесь задачу 15 и ее решение я привел по нескольким причинам:
- возможно, кто-то захочет ее решить на "1С" и можно будет сравнить длину решения;
- возможно, кому-либо будет интересно как выглядит язык запросов СУБД Oracle;
- возможно, кому-либо будут интересны новые возможности языка запросов Oracle, примененные в этом решении, так как эти возможности могут когда-либо появиться и в 1С, в том числе, и нашими стараниями.

А вообще это известная классическая задача, которую можно решить для тренировки или просто для удовольствия, если нравится программировать.
7. Владимир Гусев (adhocprog) 09.10.14 11:55
8. Alex Necro (alexnecro) 09.10.14 12:51
(5) tindir, Чем? Тем, что в нём тоже есть слова?

вот 1С:
function W(k,a=0,b=0)return?(k<1,"",W(k-1,a+b)+a%2+W(k-1,a+1+b,1))endfunction

вот JS:
function W(k,a,b) {return (k<1?"":W(k-1,a+b)+a%2+W(k-1,a+1+b,1))}

вот Pascal:
function W(k: real,a: real,b: real) begin if (k<1) then result:=""; else result:=W(k-1,a+b)+a%2+W(k-1,a+1+b,1)); end; end

вот VB:
function W(k,a,b) if (k<1) then W:="" else W:=W(k-1,a+b)+a%2+W(k-1,a+1+b,1)) end if end function

может на VB больше похоже? или может все языки одинаковые?
9. Эмиль Карапетян (amon_ra) 09.10.14 14:30
Достаточно интересная подборка и описано все занимательно, однако, названия переменных состоящих из одной буквы или какого-то странного слога ломает глаза и заставляет напрягать мозг(
Я наверно из тех, кто уж лучше переменную назовет по длиннее зато ясненько-понятненько.)
Designer1C; Mingrel; fordes; CyberCerber; DimaBab; daMaster; Zhilyakovdr; Tavalik; jmi; illUMI; Steelvan; ssega; help1Ckr; +13 Ответить 1
10. Андрей Торопчин (fjay69) 09.10.14 14:34
function W(k,a=0)return?(k,"",W(k-1,0)+a+W(k-1,1))endfunction

Что я делаю не так?
11. Валерий Агеев (awa) 09.10.14 14:35
Задача 11.
Итого 75 символов. Можно ли короче?
Можно.
функция г(ё,н="0")return?(ё,г(ё-1)+н+г(ё-1,1),"")endfunction
Итого 60 символов.
12. Андрей Торопчин (fjay69) 09.10.14 14:39
(11) awa, про аргумент по умолчанию я и забыл)
13. Валерий Агеев (awa) 09.10.14 14:42
(10) У нас одинаковые решения! Объединяя их, получаем 58 символов.
функция г(ё,н=0)return?(ё,г(ё-1)+н+г(ё-1,1),"")endfunction
14. Сергей (ildarovich) 09.10.14 14:54
(9) amon_ra, я первое время спорил, потому что сохранились привычки программирования и чтения программ на других языках, а теперь просто соглашусь. И буду стараться использовать в других подходящих случаях содержательные названия переменных. Раз уж так все здесь привыкли (со своим уставом в чужой монастырь не ходят).
И еще тут был интерес сделать код не скучно-понятным, а смешным (ёж, уж, що, ох, ах, ух) и нарядным. Но не все это правильно понимают - слишком серьезные тут многие, что-ли.
15. Сергей (ildarovich) 09.10.14 15:12
(13) awa, - супер! Мне тогда показалось, что без третьего параметра никак не обойтись, хотя ощущение его ненужности было. Вывод: нельзя было останавливаться на достигнутом!
16. Яков Коган (Yashazz) 10.10.14 01:23
Кое-что уже можно сделать иначе, благо возможности платформы растут, но...
Спасибо за полузабытое удовольствие читать красивый код, спасибо за "вкусные" и изящные решения. Эстетично.Стильно. Прям даже не 1С, а настоящее программирование.
Респект ишшо раз!

p.s. и да, это случай, когда (14) более уместны именно одно-двух-буквенные переменные, опять же ностальгия...
karpik666; +1 Ответить
17. Андрей Карпов (karpik666) 10.10.14 06:13
Долго пытался вникнуть в рекурсию в решении задачи 11. И пока думал пришел к другому решению:
По сути при каждом складывании листа изгиб никуда не девается, он так и будет занимать свой 0 или 1 в последовательности, просто каждый раз добавляем слева и справа для каждого изгиба в последовательности 0 и 1, например: был 0, при следующем изгибе добавляем 0 и 1 получаем 001, затем еще раз сгибаем: 0010011. Поэтому при решении такой задачи использовал Массив и функцию вставить, чтобы он динамически раздвигался. Может мое решение не такое изящное, но мне кажется более понятное.

Наконец-то разобрался=) идея получается точно такая же, просто у меня реализация ужасная.
18. Андрей Карпов (karpik666) 10.10.14 06:27
И еще хотел спросить по решению:
function W(k,a=0,b=0)return?(k,W(k-1,a+b)+a%2+W(k-1,a+b+1,1),"")endfunction

Разве 1С такое может, чтобы переменная, если равна нулю, то одновременно передавала и значение Ложь, а если не равно, то Истина?
19. ффф ыыы (zqzq) 10.10.14 08:23
(14) ildarovich, Понятные и адекватные названия переменных и нормальное оформление кода - это не изобретение 1С, а общемировая практика хорошего программирования. См. классическую книгу С. Макконел "Совершенный код" (S. MacConnel "Code Complete"). Кстати, по поводу "ужей" и "ежей" там тоже было:
Не используйте имена, которые совершенно не связаны с тем, что представляют переменные Использование имен вроде margaret и pookie практиески гарантирует, что никто другой их не поймет. Не называйте переменные в честь девушки, жены, любимого сорта пива и т. д., если только девушка, жена или сорт пива не являются представляемыми в программе «сущностями». Но даже тогда
вы должны понимать, что все в мире изменяется, поэтому имена девушка, жена и любимыйСортПива гораздо лучше!
timeforlive; egoludens; Mingrel; fordes; nixel; daMaster; gavrikprog; eugeniezheludkov; dr.death; ssega; monkbest; Sardukar; sergelemon; Sasha_jr; awk; gradi; A.Sytchev; Taktic; +18 Ответить 1
20. Сергей (ildarovich) 10.10.14 10:09
(19) zqzq, есть у меня эта книга, читал ее.
Но для меня в задаче 3 уж и еж - являются представляемыми в программе сущностями. Они как бы идут (ползут) по массиву в процессе его обработки. При этом их положение взаимосвязано - как и в природе, если они встречаются. В этом и был интерес в этих названиях. Ну и "що" - это просторечное "что", которое отмечает результат сравнения - что случилось и куда двигаться ежу.
Знаете, есть даже конкурсы, в которых программы пишутся так, чтобы получались стихи. У нас программы на русском языке и мы можем придать за счет этого им больше выразительности.
Это упражнение, этюд, я не призываю так оформлять все свои программы.
Но польза от таких упражнений есть.
Например, в работе http://infostart.ru/public/294285/ я постарался, не теряя смысла, назвать все переменные короткими четырехбуквенными словами, отражающими еще смысл данных переменных. Порадовался богатству языка: у нас очень много коротких выразительных слов: тень, ранг, след, рост, путь, плюс. Там только "змея" оказалось не на месте, хотя и отражала зигзагообразный порядок обхода массива. Но, посмотрев на результаты со стороны, послушав критику людей, которым это представление динамики выполнения программы оказывается недостаточно близким (у них могут быть свои ассоциации), решил больше так не делать и использовать все же в дальнейшем более понятные словосочетания в качестве имен переменных.

Ну и потом, объясните мне, почему в математических формулах используются короткие названия сущностей. Ведь формулы должны быть еще более понятны: они исключительно для чтения читателями.
Prometeus2011; amon_ra; +2 Ответить 2
21. Эмиль Карапетян (amon_ra) 10.10.14 10:58
(14) ildarovich, Как раз юмор понятен, но если один пример, то читается легко, но после 3-4 уже сложнова-то прочитывать код.
22. Эмиль Карапетян (amon_ra) 10.10.14 11:05
(20) ildarovich, А вы оказывается не плохой философ! ) Вы уж не обижайтесь на наши придирки - мы просто еще не постигли дзен программирования) Теперь на ваши куски кода смотрю иным взглядом)
23. p m (pm74) 10.10.14 16:21
на форуме была задача по смыслу почти обратная № 2 :
По строке вида "1,2,3,5,9-15" найти количество цифр в последовательности.

Вот решение в духе минимализма:
Строка="1,2,3,5,9-15";
Число=0;
Выполнить("Строка=""Вычислить(""+Вычислить("""+СтрЗаменить(Строка,",",""")*-1+"")+Вычислить(""+Вычислить(""")+""")*-1+"")""");
Выполнить("Число=Вычислить("+СтрЗаменить(СтрЗаменить(Строка,"-","0*"),"(","(1+")+")");
Сообщить("Результат ="+Число);
...Показать Скрыть
ildarovich; +1 Ответить 1
24. Сергей (ildarovich) 10.10.14 16:51
(23) pm74, ага, видел краем глаза уже с решением. Оригинальная идея. Тогда не нашел возможности улучшить. Но вообще бы подумал как бы это записать покрасивее и обобщить.
25. Антон Егоров (egorovntn) 12.10.14 18:35
Да не которые примеры интересны, давно думал как это реализовать еще с олимпиад известные задачи, а руки то не доходили...
26. Александр Полтава (Патриот) 14.10.14 18:19
сразу в глаза бросилась ненужность параметра Б. Хотел своё сокращение привести
function W(k,a=0,b=0)return?(k,W(k-1,a+b)+b+W(k-1,a+b+1,1),"")endfunction
залез в комменты почитать и понял, что я на несколько дней опоздал, и уже найдены решения где от него полностью избавились =((
27. Андрей Акулов (DrAku1a) 15.10.14 07:03
Заметочки про 1С:Предприятие # Про быстрые массивы - вот это действительно ВЕЩЬ! и как раз в стиле минимализма...
ildarovich; +1 Ответить
28. Андрей Акулов (DrAku1a) 15.10.14 07:36
(8) alexnecro, да это как языки общения - в принципе, используются для одной общей цели (общаться с железом) - просто немного разная специфика у каждого языка. Простейшие задачи с примитивными расчетами - можно решать практически в любом языке высокого уровня (а может и не только высокого). Выбор языка - вопрос удобства, надёжности и простоты общения на нём...

Например, оперируя в Delphi - мне не хватает удобных коллекций данных, реализованных в 1С (список, таблица значений, структура, соответствие), универсальности типов значений, беззаботного отношения к создаваемым объектам. Всё это можно реализовать, конечно - через компоненты. Интерфейс и функционал стандартных компонентов - тоже уступает 1С и тоже навёрстывается компонентами... Зато в Delphi я могу написать программу, не связанную с базой данных, выполняющую вообще - другие функции...
29. Александр Полтава (Патриот) 15.10.14 17:52
(26) Решил ещё раз штурмануть задачу 11, но уже с целью выведения формулы определения i-того символа в нужной последовательности (причём количество сгибаний нас не интересует, т.к. последовательность n-того порядка является началом любой другой последовательности более старшего порядка, значит можно исходить из того, что мы имеем независимую (от n, например) бесконечную последовательность). Возможно продолбался бы я не один день с этой идеей, если бы вовремя не заметил, что наша последовательность, это запись самодвойственной функции! С которыми я по первому курсу универа пропарился немало, т.к. преподаватель дискретной математики очень заинтересовал нерешёнными досель вопросами в этой области. Подробностей не помню, но смысл в том, что пока такой формулы нет и не предвидится (что её нельзя вывести, тоже вроде не доказано), так что я смело отказался от данной затеи.
Но вдруг кого заинтересует более решаемая задача - Написать суперкороткую функцию, которой на вход мы скармливаем номер символа последовательности, рождаемой в задаче 11, а на выходе выплёвывается искомый символ. В принципе сиё достигается небольшой модификацией исходного решения. На досуге накидаю.
30. Сергей Кирпо (Sardukar) 16.10.14 07:46
(20) ildarovich,
"Ну и потом, объясните мне, почему в математических формулах используются короткие названия сущностей. Ведь формулы должны быть еще более понятны: они исключительно для чтения читателями. "

Чтобы математики другим казались умнее.
31. Рамиль Баширов (bashirov.rs) 16.10.14 10:44
Не плохо написано! Спасибо за собранный материал. Ждем еще...
32. DAnry (DAnry) 16.10.14 12:17
Спасибо! Хорошая подборка. Интересные оригинальные решения, так сказать гимнастика для мозга. Но есть и полезные, которые можно использовать в работе.
33. Михаил (KeyFire) 21.10.14 10:32
Спасибо. Познавательно.
34. Сергей (ildarovich) 26.10.14 09:53
Добавил задачу 16 про недостающие функции для работы с датами (как в языке запросов).
На самом деле довольно интересно то, что
ДобавитьКДате('20120131', 1, "Месяц") = '20120229', 
ДобавитьКДате('20120131', 3, "Месяц") = '20120430',
ДобавитьКДате('20120130', 3, "Месяц") = '20120430'
ДобавитьКДате('20120229', 1, "Год") = '20130228'

Также не все обращают внимание, что
РазностьДат('20131231235959','20140101000000',"Год") = 1 и
РазностьДат('20131231235959','20140101000000',"Час") = 1
Как в шутке про прошлогодние салаты на Новый год

Также интересно, что инициализация структуры Шаг
может проводиться таким образом
Шаг = Новый Структура("Месяц, Секунда", 1, -1);
Шаг.Добавить("Минута", Шаг.Секунда * 60);
Шаг.Добавить("Час", Шаг.Минута * 60);
Шаг.Добавить("День", Шаг.Час * 24);
Шаг.Добавить("Неделя", Шаг.День * 7);

Шаг.Добавить("Квартал", Шаг.Месяц * 3);
Шаг.Добавить("Год", Шаг.Квартал * 4);
...Показать Скрыть


Это упростит поддержку 1С в поселении на Марсе :-)
35. Александр Топольский (AlexanderKai) 27.10.14 09:05
(18) karpik666,
Может. Так по умолчанию принято.
36. ZLENKO.PRO (ZLENKO) 31.10.14 18:22
Возможно я ошибаюсь, но в алгоритме "7. Связывание таблиц значений по ФИФО" часть записей одной из таблиц, которые не "связались" не попадут в результирующую таблицу ?

Когда будет обработана последняя запись "меньшей" из таблиц, то цикл прервется по условию "Пока ё < А.Количество() И ж < Б.Количество() Цикл", т.к. условие "И".
Просто заменить на "ИЛИ" тоже нельзя - неправильно будет работать :-(
Просто я помню возился с такой задачкой и "красивого" алгоритма не получилось :-(
Изначально написал почти такой же алгоритм, но "не взлетело"...
Пришлось добавлять "обработку хвостов" и вся "красивость" исчезла.
37. ZLENKO.PRO (ZLENKO) 31.10.14 18:49
(34) ildarovich, "ДобавитьКДате('20120229', 1, "Год") = '20130228'"

А еще вариант: ДобавитьКДате('20110228',ГОД, 1) = '20120228', а не '20120229' :-)
38. Сергей (ildarovich) 31.10.14 19:23
(36) ZLENKO.PRO, нет, не ошибаетесь, я должен был добавить в описание, что предварительно добиваемся, чтобы А.Итог("Сумма") = Б.Итог("Сумма") за счет ПРЕДВАРИТЕЛЬНОГО дописывания последней записи к таблице с меньшей суммой. В коде, откуда это было выдернуто, это делалось в другом модуле.

(37) Так вроде бы тоже самое и написано. - Ровно тот же пример.
Про 20120228 + Год, наверное, стоит добавить.
39. Алексей Р. (miniogn) 05.11.14 10:04
16. Добавить к дате и разность дат

В данном случае получается красиво. Но в ущерб скорости. Создание структур вовсе не обязательно делать для такой задачи.
40. Сергей (ildarovich) 05.11.14 10:20
(39) miniogn, в комментариях к статье, где обсуждалась задача было сказано (ссылка приведена), что создание структуры Шаг можно вынести из тела функции для повышения производительности. Можно сделать ее глобальной и создавать ее один раз в соответствующем модуле. Это решит все проблемы с производительностью.
Наверное, эту мысль нужно было перенести и сюда.

Но вот еще что действительно интересно.
Если этот прием понимать как реализацию сложного селекта, с большим количеством ИначеЕсли, в котором проверяются строки или числа, то не будет ли это просто быстрее? Сколько "стоит" создание структуры? - Можно еще исследовать этот вопрос. Для данной задачи я делал замеры - получается медленнее, но не намного. Числа есть в упомянутых комментариях.
41. Сергей (ildarovich) 06.11.14 20:24
Добавил минимализм 17.
Приведен набор из трех коротких функций. С его помощью можно получать готовый массив любого заданного размера N, содержащий последовательность чисел от 0 до N - 1. Этот массив затем, например, можно загрузить в нужную колонку таблицы значений, чтобы перенумеровать ее строки, не используя цикл. Такой способ в 3 раза МЕДЛЕННЕЕ нумерации таблицы значений в цикле. Поэтому для практических целей он не подойдет - только как основа для какого-либо другого решения.

Используется "Порождающий запрос" (с), текст которого генерируется для заданного числа N очень короткой рекурсивной функцией prototext.
42. Алексей Р. (miniogn) 12.11.14 12:38
(40) ildarovich, >Можно сделать ее глобальной и создавать ее один раз в соответствующем модуле. Это решит все проблемы с производительностью.
На сервере будете создавать? А как же клиент... Или будет вызов сервера.
Или каждый раз перед вызовом создавать локально и заполнять? Тоже мало смысла.

В общем еще хуже будет. В исходном варианте хотя бы рабочий вариант.
43. Сергей (ildarovich) 12.11.14 14:48
(42) miniogn, затраты времени на создание этой структуры не значительны.
Я говорил про вынос определения этой структуры из тела функции, если вдруг время ее выполнения будет критично. Куда помещать определение структуры Шаг - зависит от задачи. По моему мнению на клиенте массовых вычислений с использованием этих функций быть не должно. Скорее всего, это будет какой-либо алгоритм, выполняемый на сервере.
44. Сергей (ildarovich) 01.12.14 13:02
Добавил задачу 18.
"Простой трюк для быстрого объединения таблиц значений".
Первоначально эта задача была опубликована как отдельная статья, которую набрала довольно большой рейтинг.
К сожалению, из-за досадной ошибки в замерах эффект предложенного метода в статье был сильно завышен. В статье говорилось об ускорении в 10 и более раз. Тогда как на самом деле максимальное ускорение - всего в полтора раза. Поэтому статья, получившая незаслуженные оценки, была снята с публикации, а ее начинка помещена сюда под номером 18.
45. И А (mylogin) 01.12.14 13:24
Все возможности оптимизация данного способа ограничиваются записью в одну строку и выбором таблицы с меньшим количеством элементов в качестве источника добавляемых строк.


Я всегда думал, что выигрыш в производительности от уменьшения количества строк кода возникает только при отладке.
46. Сергей (ildarovich) 01.12.14 13:26
(45) mylogin, некоторый выигрыш все-таки есть. Посмотрите в статье Заметочки про 1С:Предприятие 8
47. И А (mylogin) 01.12.14 13:30
(46) ildarovich, Да, действительно. Спасибо, будем знать.
48. Галина ГГГ (gigagr) 03.12.14 16:16
Спасибо за собранный материал.
49. aspirator 23 (aspirator23) 06.12.14 15:34
(44) ildarovich, Спасибо.Из кода 5% выжимают, а тут 50. Подарок.
50. A R (StaticUnsafe) 30.12.14 09:26
(6) ildarovich, решал задачу с ферзями на 1С, удивлял препода в инсте )))
51. Станислав Копылов (ksuman) 14.01.15 22:48
(6) ildarovich,
возможно, кто-то захочет ее решить на "1С" и можно будет сравнить длину решения;


Я конечно поддерживаю различные задачки по развитию аналитического мышления, и часть задач мне нравится, но замечу Вам, что нельзя вводить в заблуждение наивных программистов 1С краткостью решения, тем более когда сие осуществляется путем исключения пробелов и необходимых переносов строк. Погоня за краткостью, может привезти к противоположному результату и будут противоречить двум основополагающим принципам программирования:

1. Компактности и/или Быстродействие, при этом компактность кода подразумевается не то что видим мы, а то что компилируется в исполняемый модуль, сколько временных переменных используется, сколько создается и уничтожается объектов/классов, сколько при этом расходуется памяти. С учетом того что пример показан в среде 1С, компактность скомпилированного кода может даже потерять значительно. Вот в языке "C" там есть такой оператор для целых чисел ++ или --, также как и =- и =+, которые реально делали отдельные операции компактными и быстрыми. Однако в С++ и дальше они утратили свой смысл для классов с перегрузкой операторов, но все же мы можем с помощью отладчиков как то увидеть, что реально делается.
Пример, когда увеличение кода ведет к повышению его производительности:
а) Перем ЕстьДанные,Наименование,НашАдрес,НашаСтруктура, ТабЗнИст; // объявление ряда переменных вначале процедуры - исключает ряд операций по манипуляции со стеком и пулом свободной памяти.
б) //Описание кода в таком виде
ЕстьДанные=ИсходныйНаборСтруктур.Свойство("НашаСтруктура",НашаСтруктура);
Если ЕстьДанные Тогда
НашАдрес=НашаСтруктура.Адрес;
Наименование=НашаСтруктура.Наименование;
КонецЕсли;
// будет выполняться быстрее и компактнее чем в нижестоящем, за счет исключения лишних обращений к каждому из объектов и вычислении у него адреса свойства или метода.
НашАдрес=ИсходныйНаборСтруктур.НашаСтруктура.НашАдрес;
Наименование=ИсходныйНаборСтруктур.НашаСтруктура.Наименование;

2. Наглядность кода - если целью решения задачи является Демонстрация или Создание библиотек функций для дальнейшего использования, то это святое. Код должен быть понятным легко и без напряга. Здесь же во многих задачах как раз и приходится напрягаться, чтобы понять какая переменная за что отвечает. Ещё давно, когда делал первые шаги к программированию, была рекомендация по использованию имен переменных для читабельности кода. Например все счетчики, которые использовались в циклах обычно именовались в таком порядке (i, j, k), целые числа (n, m, l), вещественные: (x, y, z), другие все переменные были носили понятные имена и начинались с префиксами, подсказывающими их тип (chPath, uFileName, bResultPath).

Конечно мы не в Си рассматриваем примеры, но можно было бы хотя бы рядом с кратким решением (если уж так хочется блеснуть низкой длинной решения), выводить структурированное и с нормальными и понятными именами. А так же упор делать на реальной производительности, а не не посчете символов кода.
52. Сергей (ildarovich) 14.01.15 23:48
(51) ksuman, спасибо за такой подробный комментарий.

Не буду спорить, я много раз слышал эти доводы и сам много раз говорил те же слова другим.

Но когда ищешь короткое решение и находишь "легальную" возможность его сокращения, то психологически трудно вовремя затормозить, не убрав еще одну строчку, обратившись к реквизиту через десять точек и тому подобное.
Те решения, от которых я отталкивался были в пять и больше раз длиннее. Совершенно ненужная избыточность в них точно была. И минимизация заключалась не только в сокращении имен переменных и записи в одну строчку. Где-то я переборщил. Я это уже понял. Здесь больше чем в других программистких сообществах ценят не компактность кода, а простоту и наглядность кода. Буду иметь это ввиду, наступая на горло своим привычкам.

Ну и, кстати, в начале статье открытым текстом написано, что приведены сублиматы кода и перед использованием их следует размачивать.

возможно, кто-то захочет ее решить на "1С" и можно будет сравнить длину решения
это относилось к обоснованию того, зачем нам здесь код на Oracle. В исходной статье можете посмотреть каким был исходный код. Видно, что имена переменных и форматирование кода там были очень краткими и совсем "не в стиле 1С". Полюбопытствуйте, как пишут ораклисты. Я написал код в их стиле и гораздо короче и гибче, применив рекурсию. Попробуйте предложить несокращаемое компактно-понятно-наглядное решение на 1С для этой задачи.

Про то, что явное объявление локальных переменных экономит время раньше не знал.
53. Сергей (ildarovich) 10.02.15 11:17
Добавил задачу 19 "загадка суммы и произведения". Приведено короткое решение этой переборной по сути задачи. Использован один пакетный запрос и техника искусственных таблиц. О задаче узнал от scientes. Запросы в пакете отражают последовательность ограничений, накладываемых на числа Х и У.
54. ффф ыыы (zqzq) 12.02.15 15:07
За остатки на каждый день спасибо, полезный запрос. Можно туда же добавить и начальный остаток из вашего комментария к той статье (проверил - вроде правильно считает).
55. Сергей (ildarovich) 18.02.15 16:56
Добавил задачу 20 "Расчет поразрядного исключающего ИЛИ". Сам запрос понадобился для решения головоломки про 64 монеты http://habrahabr.ru/post/250585/. Но вообще его можно использовать для подсчета контрольных сумм по исключающему ИЛИ, инвертирования двоичных разрядов в числах и прочих поразрядных битовых операциях.
56. Сергей (ildarovich) 27.02.15 18:30
Добавил задачу 21 "Как с помощью запроса посчитать количество символов в реквизите?" Большую часть кода там занимается часть, формирующая таблицу чисел 1-64.
57. mailrum2004 30.03.15 16:41
Интересно, спасибо! Запрос из "19. Загадка суммы и произведения" не заработал сразу.
дописал в первой строке "КАК Х"
ВЫБРАТЬ 0 КАК Х
ildarovich; +1 Ответить 1
58. Сергей (ildarovich) 30.03.15 16:44
(57) mailrum2004, спасибо за замечание: была опечатка, сейчас поправлю.
59. Василий Коровин (vasyak319) 30.03.15 17:53
Функции Квартал не хватает "+1" перед ";"
60. Сергей (ildarovich) 02.04.15 11:40
(59) vasyak319, спасибо, поправил
61. Николай Клементьев (Rusmus) 05.06.15 10:43
задачу 21 (Определение длины строки в запросе) у себя делаю по такому принципу:

ВЫБРАТЬ
Дано.*,
ЕСТЬNULL(ё, "256+") КАК Длина
ИЗ
Дано
ЛЕВОЕ СОЕДИНЕНИЕ Р543210
ПО ПОДСТРОКА(Дано.Строка,ё,1) <> "" И ПОДСТРОКА(Дано.Строка,ё+1,1) = ""

Преимущества:
не портится таблица Дано - записи с длинными строками не пропадут, одинаковые записи не сгруппируются
полей в Дано может быть сколько угодно; не надо писать список в разделе "сгруппировать по"

Как думаете, какая будет разница по скорости?
ildarovich; +1 Ответить 1
62. Сергей (ildarovich) 05.06.15 13:05
(61) Rusmus, отличная идея! - Возьму на вооружение. - Согласен насчет преимуществ. Одно уточнение: нужно писать
ПО ПОДСТРОКА(Дано.Строка,ё,1)  + "!" <> "!" И ПОДСТРОКА(Дано.Строка,ё+1,1) + "!"= "!" 
чтобы Длина строки "мама мыла раму" не считалась равной одновременно 4, 9 и 13.

По скорости, думаю, выигрыша не будет. За счет двойного вычисления подстроки может быть даже проигрыш в простых случаях. Но преимущества перевешивают.
63. Николай Клементьев (Rusmus) 05.06.15 15:19
(62) спасибо за дополнение.
64. Александр Воронов (ya.Avoronov) 28.08.15 16:12
Я тут один такой?

- Прочитал статью - лайкнул статью;
- Прочитал комментарии - лайкнул пару комментариев;
- Лайкнул бы и автора);
- Не нашел применения сему в своей жизни - забыл все как в страшном сне.

Ощущение, как во время олимпиады по информатике в 9 классе.
65. Сан Саныч (herfis) 19.02.16 13:42
Очень соблазнительный вариант простого алгоритма "Остатки на каждый день". Автор также везде советует его в комментариях к другим публикациям. Заявляется, что его производительность лучше стандартного "тяжелого" варианта. Но ведь это только для отчета с фиксированными группировками. Подавляющее большинство реальных отчетов базируются на СКД и имеют настраиваемые группировки. А значит - не получится в запросе выполнить свертку. А в этом случае на вход СКД приползет в разы большее количество детальных записей, чем в "тяжелом" варианте. Тесты не проводил, но вполне может оказаться, что на отчетах обрабатывающих большое количество данных такая оптимизация может выйти боком.
66. Сергей (ildarovich) 19.02.16 15:04
(65) herfis, трудно возражать на неконкретные замечания типа "если кто-то кое-где у нас порой", или
Тесты не проводил, но вполне может оказаться
Во-первых, приведите (в виде текста запроса) тот вариант, который вы считаете лучшим. Насколько я понимаю, всего есть два разных популярных принципа восстановления остатков на дни без оборотов. В первом суммируются обороты. Во втором остатки на дни с оборотами интерполируются по принципу срезов последних. Я за первый вариант и против второго, который кажется мне объединением недостатков разных техник.
Но и в первом и втором группировки для получения остатков фиксируются. Ну а как иначе? Здесь я ничего принципиально не менял (как в "Баттерфляй", например), просто записал известный прием короче (в одном запросе). Поэтому данное замечание кажется странным.
67. Сан Саныч (herfis) 19.02.16 16:33
(66) ildarovich, Вы правы. Заработался. В голове все смешалось :) Приношу извинения. Вылетело из головы, что в "тяжелом" варианте тоже фиксированные группировки. Сейчас как раз делаю новый отчет с использованием этого подхода. В комментариях к статье http://infostart.ru/public/102435 приложил рабочую формулу для начального остатка.
68. Сергей (ildarovich) 24.02.16 13:40
Следующая серия минимализмов опубликована в продолжении этой статьи, которая называется "Минимализмы 2".
69. Олег Родионов (Ovrfox) 21.06.16 15:19
К задаче 20. Поразрядное исключающее ИЛИ
Насколько я понял в последнем запросе ошибка
Должно быть примерно так:
ВЫБРАТЬ
Разряды.Вес * (СУММА (Разряды.Икс) - ВЫРАЗИТЬ(СУММА(Разряды.Икс) / 2 + 0.5 КАК ЧИСЛО(10, 0)) * 2 + 2) КАК Икс
ИЗ
(ВЫБРАТЬ
Позиции.Вес КАК Вес,
СУММА((ВЫРАЗИТЬ(Дано.Икс / Позиции.Вес + 0.5 КАК ЧИСЛО(10, 0))) - 1) КАК Икс
ИЗ
Дано КАК Дано,
Позиции КАК Позиции

СГРУППИРОВАТЬ ПО
Позиции.Вес) КАК Разряды
70. Сергей (ildarovich) 21.06.16 23:50
(69) Ovrfox, нет, там ВСЕ ПРАВИЛЬНО. Запрос в результате получает ОДНО число. Это контрольная сумма, полученная поразрядным ксором шести разрядов чисел в таблице Дано.
Запрос довольно хитрый. Хитрость в том, младшие биты заранее (на промежуточных этапах) выделять не нужно. Их можно выделить уже после суммирования, что и сделано. То есть младший бит суммы (XOR) равен сумме (XOR) младших битов.
Я проверял запрос в консоли. Можете тоже проверить сами.
71. Олег Родионов (Ovrfox) 22.06.16 10:21
(70) Верно, Без вложенного запроса не обойтись.
Сначала вычисляем четность по разрядно, а потом приводим ее к числу.
Но если кому то нужна четность по разрядно, то ее можно получить и одним запросом.
	               ВЫБРАТЬ
	               	СУММА(Разряды.Вес * Разряды.Икс) КАК Икс
	               ИЗ
	               	(ВЫБРАТЬ
	               		Позиции.Вес КАК Вес,
	               		СУММА((ВЫРАЗИТЬ(Дано.Икс / Позиции.Вес + 0.5 КАК ЧИСЛО(10, 0))) - 1) - (ВЫРАЗИТЬ(СУММА((ВЫРАЗИТЬ(Дано.Икс / Позиции.Вес + 0.5 КАК ЧИСЛО(10, 0))) - 1) / 2 + 0.5 КАК ЧИСЛО(10, 0))) * 2 + 2 КАК Икс
	               	ИЗ
	               		Дано КАК Дано,
	               		Позиции КАК Позиции
	               	
	               	СГРУППИРОВАТЬ ПО
	               		Позиции.Вес) КАК Разряды
...Показать Скрыть

PS: Как хреново, что обычных мат операций (как целочисленное деление) нет в языке запросов 1С!
72. Сергей (ildarovich) 22.06.16 11:54
(71) Ovrfox, это метод "в лоб". В нем вычислений
- (ВЫРАЗИТЬ(Разряды.Икс / 2 + 0.5 КАК ЧИСЛО(10, 0))) * 2 + 2
гораздо больше. Во столько раз, сколько чисел в таблице Дано. А в моем варианте для сокращения объема вычислений используется интересная математическая закономерность. То есть все не просто так.

По поводу отсутствия некоторых функций в языке запросов тоже сожалею. Громоздкость некоторых конструкций сильно раздражает. Есть, правда, некоторые мысли по этому поводу (что можно сделать). Может, дойдут руки.
73. Олег Родионов (Ovrfox) 22.06.16 13:12
(72)Насколько я знаю MS SQL, то значение (ВЫРАЗИТЬ(Дано.Икс / Позиции.Вес + 0.5 КАК ЧИСЛО(10, 0)) - 1) скорее всего будет вычислено для каждого элемента (декартового произведения таблиц запроса) один раз, а не два.
Операция же с суммами будет выполнена один раз для каждого значения группировки. Это очевидно.
Это означает, что в упомянутом запросе вычислений ровно столько же, сколько и в Вашем варианте. Ни на одно больше.
74. Сергей Вн (EmpireSer) 25.07.16 15:25
(0), А ни кто не обратил внимание, что код из "13. Функция для превращения строки в дату по форматной строке" может обрабатывать строки и не по шаблону?
Например он спокойно обрабатывает шаблон:
СтрокаВДату("yyyy-MM-ddTHH-mm-ss", "2016-10-01 07:20:34");


Учитывая такое поведение и мои условия у меня получилась вот такая функция из твоей:
Функция ДатаИВремяИзСтроки(Знач ДатаИВремяСтрокой, Знач ФорматДаты, Знач ВызыватьИсключение = Истина) Экспорт
	Перем Результат;
	// Исходный код разработан Сергеем (Ник: ildarovich)(http://infostart.ru/profile/28527/)
	//   упоминается в Минимализмы (http://infostart.ru/public/306536/)
	
	ДатаИВремяСтрокой = СокрЛП(ДатаИВремяСтрокой);
	ФорматДаты = СокрЛП(ФорматДаты);
	
	#Область ДатаИВремяИзСтроки_ОбработкаКоллекцииФорматовДат
	Если ЭтоМассив(ФорматДаты) Тогда
		Для Индекс = 0 По ФорматДаты.Количество() - 1 Цикл
			Результат = ДатаИВремяИзСтроки(ДатаИВремяСтрокой, ФорматДаты[Индекс], Ложь);
			Если Результат <> Неопределено Тогда
				Возврат Результат;
			КонецЕсли;
		КонецЦикла;
		
		Если ВызыватьИсключение Тогда
			ТекстОшибки = СтрокаПараметрыПодставить("Переданные шаблоны форматов даты не подходят для конвертации строки ""%1""."
				,	ДатаИВремяСтрокой
			);
			ВызватьИсключение ТекстОшибки;
		КонецЕсли;
		Возврат Неопределено;
	КонецЕсли;
	#КонецОбласти
	
	Попытка
		Ч = Формат('00010101', "ДФ=" + ФорматДаты); // - необязательная проверка первого правильности параметра
	Исключение
		Если ВызыватьИсключение Тогда
			ТекстОшибки = СтрокаПараметрыПодставить("Передан не правильный шаблон формата даты ""%1""."
				, ФорматДаты
			);
			ВызватьИсключение ТекстОшибки;
		КонецЕсли;
		Возврат Неопределено;
	КонецПопытки;
	Ч = Новый Соответствие();
	Для Индекс = 1 По СтрДлина(ФорматДаты) + 7 Цикл
		Ч[Сред(ФорматДаты + "dMyHhms", Индекс, 1)] = 0;    // - инициализация частей даты
	КонецЦикла;
	Для Индекс = 1 По 12 Цикл
		ДатаИВремяСтрокой = СтрЗаменить(ДатаИВремяСтрокой, Формат(Дата(1, Индекс, 1), "ДФ=MMММ"), Формат(Индекс, "ЧЦ=4; ЧВН=")); // - замена названий месяцев числами 
		ДатаИВремяСтрокой = СтрЗаменить(ДатаИВремяСтрокой, Формат(Дата(1, Индекс, 1), "ДФ=MMМ" ), Формат(Индекс, "ЧЦ=3; ЧВН=")); 
	КонецЦикла;
	
	Ошибка = Ложь;
	Для Индекс = 1 По СтрДлина(ФорматДаты) Цикл
		Ч[Сред(ФорматДаты, Индекс, 1)] = 10 * Ч[Сред(ФорматДаты, Индекс, 1)] + Найти("123456789", Сред(ДатаИВремяСтрокой, Индекс, 1)); // - накопление частей даты
		Ошибка = Ошибка ИЛИ Найти("dMyHhms", Сред(ФорматДаты, Индекс, 1)) И НЕ Найти("0123456789", Сред(ДатаИВремяСтрокой, Индекс, 1)); // - необязательная проверка на цифры
	КонецЦикла; 
	Ч["y"] = Ч["y"] + ?(Ч["y"] < 50, 2000, ?(Ч["y"] < 100, 1900, 0)); // - дополнение двух цифр года до четырех 
	Попытка
		Результат = Дата(Ч["y"], Ч["M"], Ч["d"], Ч["H"] + Ч["h"], Ч["m"], Ч["s"]);
	Исключение
		Если ВызыватьИсключение Тогда
			ВызватьИсключение;
		КонецЕсли;
		Возврат Неопределено;
	КонецПопытки;
	
	ДатаИВремяСтрокойНовая = Формат(Результат, "ДФ=" + ФорматДаты);
	Если Лев(ДатаИВремяСтрокой, СтрДлина(ДатаИВремяСтрокойНовая)) = ДатаИВремяСтрокойНовая Тогда
		Возврат Результат;
	КонецЕсли;
	
	Если ВызыватьИсключение Тогда
		ТекстОшибки = СтрокаПараметрыПодставить("Шаблон формата даты ""%1"" не подходит для конвертации строки ""%2""."
			, ФорматДаты
			,	ДатаИВремяСтрокой
		);
		ВызватьИсключение ТекстОшибки;
	КонецЕсли;
	Возврат Неопределено;
КонецФункции
...Показать Скрыть
75. Николай ~ ~ (kuzyara) 30.08.16 06:29
(74) EmpireSer, действительно. Думаю стоит сделать ограничение на входной шаблон этой функции, тогда получится более компактный вариант:
Функция СтрокаВДату(Знач Строка, Знач ФорматДаты) Экспорт
	Ч = Новый Соответствие; 
	Для ё = 1 По СтрДлина(ФорматДаты) + 6 Цикл 
	    Ч[Сред(ФорматДаты + "dMyHms", ё, 1)] = 0
	КонецЦикла; 
	Для ё = 1 По СтрДлина(ФорматДаты) Цикл 
	    Ч[Сред(ФорматДаты, ё, 1)] = 10 * Ч[Сред(ФорматДаты, ё, 1)] + Найти("123456789", Сред(Строка+ФорматДаты, ё, 1));
	КонецЦикла; 
	Ч["y"] = Ч["y"] + ?(0 < Ч["y"] И Ч["y"] < 50, 2000, ?(0 < Ч["y"] И Ч["y"] < 100, 1900, 0));
	Возврат Дата(Макс(Ч["y"], 1), Макс(Ч["M"],1), Макс(Ч["d"],1), Ч["H"], Ч["m"], Ч["s"]);
КонецФункции
...Показать Скрыть

Процедура КнопкаВыполнитьНажатие(Кнопка)
	Тесты = "dd MM yy
	|yy-MM-dd HH:mm
	|dd MM yy HH mm ss
	|dd MM yyyy
	|MM dd, yyyy, HH:mm
	|dd.MM.yy
	|MM, dd, yyyy
	|yyyyMMdd
	|HH-mm-ss, dd-MM-yy
	|dd
	|dd MM HH:mm:ss yyyy
	|HH:mm:ss
	|HH:mm
	|yyyy-MM-dd HH:mm:ss
	|yyyy-MM-dd
	|yyyy/MM/dd
	|dd/MM/yy
	|MM dd yyyy
	|dd MM yyyy
	|dd MM yyyy
	|yyyy-MM
	|yyyy
	|MM, dd, yyyy
	|dd-MM-yyyy
	|ddMMyyyy";
	Пройдено=0;
	ВсегоТестов = СтрЧислоСтрок(Тесты);
	ТекДата = Дата("20160112131415");
	Для й=1 по ВсегоТестов Цикл
		ТекФормат = СтрПолучитьСтроку(Тесты, й);
		ТекСтрока = Формат(ТекДата, "ДФ='"+ТекФормат+"'");
		ТестДата = СтрокаВДату(ТекСтрока, ТекФормат);
		ТестСтрока = Формат(ТестДата, "ДФ='"+ТекФормат+"'");
		РезультатТеста = ТекСтрока = ТестСтрока;
		Сообщить("Тест "+й+" - "+РезультатТеста+" 	["+ТекФормат+"] - ["+ТекСтрока+"]: "+ТестДата);
		Пройдено = Пройдено + РезультатТеста;
	КонецЦикла;
	Сообщить("Пройдено тестов: "+Пройдено+"/"+ВсегоТестов);
КонецПроцедуры
...Показать Скрыть

Тест 1 - Да 	[dd MM yy] - [12 01 16]: 12.01.2016 0:00:00
Тест 2 - Да 	[yy-MM-dd HH:mm] - [16-01-12 13:14]: 12.01.2016 13:14:00
Тест 3 - Да 	[dd MM yy HH mm ss] - [12 01 16 13 14 15]: 12.01.2016 13:14:15
Тест 4 - Да 	[dd MM yyyy] - [12 01 2016]: 12.01.2016 0:00:00
Тест 5 - Да 	[MM dd, yyyy, HH:mm] - [01 12, 2016, 13:14]: 12.01.2016 13:14:00
Тест 6 - Да 	[dd.MM.yy] - [12.01.16]: 12.01.2016 0:00:00
Тест 7 - Да 	[MM, dd, yyyy] - [01, 12, 2016]: 12.01.2016 0:00:00
Тест 8 - Да 	[yyyyMMdd] - [20160112]: 12.01.2016 0:00:00
Тест 9 - Да 	[HH-mm-ss, dd-MM-yy] - [13-14-15, 12-01-16]: 12.01.2016 13:14:15
Тест 10 - Да 	[dd] - [12]: 12.01.0001 0:00:00
Тест 11 - Да 	[dd MM HH:mm:ss yyyy] - [12 01 13:14:15 2016]: 12.01.2016 13:14:15
Тест 12 - Да 	[HH:mm:ss] - [13:14:15]: 01.01.0001 13:14:15
Тест 13 - Да 	[HH:mm] - [13:14]: 01.01.0001 13:14:00
Тест 14 - Да 	[yyyy-MM-dd HH:mm:ss] - [2016-01-12 13:14:15]: 12.01.2016 13:14:15
Тест 15 - Да 	[yyyy-MM-dd] - [2016-01-12]: 12.01.2016 0:00:00
Тест 16 - Да 	[yyyy/MM/dd] - [2016/01/12]: 12.01.2016 0:00:00
Тест 17 - Да 	[dd/MM/yy] - [12/01/16]: 12.01.2016 0:00:00
Тест 18 - Да 	[MM dd yyyy] - [01 12 2016]: 12.01.2016 0:00:00
Тест 19 - Да 	[dd MM yyyy] - [12 01 2016]: 12.01.2016 0:00:00
Тест 20 - Да 	[dd MM yyyy] - [12 01 2016]: 12.01.2016 0:00:00
Тест 21 - Да 	[yyyy-MM] - [2016-01]: 01.01.2016 0:00:00
Тест 22 - Да 	[yyyy] - [2016]: 01.01.2016 0:00:00
Тест 23 - Да 	[MM, dd, yyyy] - [01, 12, 2016]: 12.01.2016 0:00:00
Тест 24 - Да 	[dd-MM-yyyy] - [12-01-2016]: 12.01.2016 0:00:00
Тест 25 - Да 	[ddMMyyyy] - [12012016]: 12.01.2016 0:00:00
Пройдено тестов: 25/25
...Показать Скрыть
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа