gifts2017

Подбор товаров для УТ11 с выводом картинки, с возможностью выбора склада

Опубликовал Dmitriy (ddd_l) в раздел Обработки - Обработка документов

Возникла необходимость по-быстрому сделать подбор товаров с выводом картинки товара и возможностью подбора товаров с разных складов.
Обработка для УТ 11, протестирована на 11.1.1.13 и 11.1.10.86. Надеюсь, кому-нибудь поможет.

Обработка делалась по-быстрому, поэтому встраивается в конфигурацию.
Позволяет просматривать остатки товаров по характеристикам с отбором не только по складу, указанному в заказе клиента.
Сначала вставляем в обработки из внешнего отчета, затем подключаем в документ "Заказ клиента" в форме документа.
В модуль формы "Заказ клиента" также надо добавить код команды для открытия формы подбора:

&НаКлиенте
Процедура ОткрытьПодборБыстрый(Команда)
	
	Отказ = Ложь;
	Если Не ЗначениеЗаполнено(Объект.Соглашение)
		Или Не ЗначениеЗаполнено(Объект.Валюта) Тогда
		ОчиститьСообщения();
		СообщитьОбОшибкахОткрытияПодбора(Отказ);
	КонецЕсли;
	Если Отказ Тогда
		Возврат;
	КонецЕсли;
	
	ПараметрЗаголовок = НСтр("ru = 'Подбор товаров в %Документ%'");
	Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
		ПараметрЗаголовок = СтрЗаменить(ПараметрЗаголовок, "%Документ%", Объект.Ссылка);
	Иначе
		ПараметрЗаголовок = СтрЗаменить(ПараметрЗаголовок, "%Документ%", "заказ клиента");
	КонецЕсли;
	
	ПараметрыФормы = Новый Структура;
	ПараметрыФормы.Вставить("Соглашение",               Объект.Соглашение);
	ПараметрыФормы.Вставить("ЦенаВключаетНДС",          Объект.ЦенаВключаетНДС);
	Если Объект.ХозяйственнаяОперация = ПредопределенноеЗначение("Перечисление.ХозяйственныеОперации.ПередачаНаКомиссию") Тогда
		ПараметрыФормы.Вставить("ОтборПоТипуНоменклатуры", Новый ФиксированныйМассив(НоменклатураКлиентСервер.ОтборПоТоваруМногооборотнойТаре()));
		ПараметрыФормы.Вставить("СкрыватьРучныеСкидки", Истина);	
	КонецЕсли;
	ПараметрыФормы.Вставить("РежимПодбораИспользоватьСкладыВТабличнойЧасти", Истина);
	ПараметрыФормы.Вставить("ИспользоватьДатыОтгрузки",                      Истина);
	ПараметрыФормы.Вставить("СкрыватьПодакцизныеТовары",               Объект.НалогообложениеНДС = ПредопределенноеЗначение("Перечисление.ТипыНалогообложенияНДС.ПродажаОблагаетсяЕНВД"));
	ПараметрыФормы.Вставить("ОтображатьФлагСкрыватьПодакцизныеТовары", Объект.НалогообложениеНДС = ПредопределенноеЗначение("Перечисление.ТипыНалогообложенияНДС.ПродажаОблагаетсяЕНВД"));
	ПараметрыФормы.Вставить("Склад",                                   Объект.Склад);
	ПараметрыФормы.Вставить("Валюта",                                  Объект.Валюта);
	ПараметрыФормы.Вставить("Заголовок",                               ПараметрЗаголовок);
	ПараметрыФормы.Вставить("Дата",                                    Объект.Дата);
	ПараметрыФормы.Вставить("Документ",                                Объект.Ссылка);
	
	Если Не Объект.Соглашение.Пустая() Тогда
		СегментНоменклатуры = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Объект.Соглашение, "СегментНоменклатуры");
		ПараметрыФормы.Вставить("СегментНоменклатуры", СегментНоменклатуры);
	КонецЕсли;
	
	ФормаПодбора = ПолучитьФорму("Обработка.ПодборТоваровБыстрый.Форма", ПараметрыФормы, , "КлючОбщейФормыПодбора");
	ФормаПодбора.УстановитьВладельца(ЭтаФорма.УникальныйИдентификатор);
	ФормаПодбора.Открыть();
	
КонецПроцедуры
 

В процедуре УстановитьДоступностьЭлементовПоСтатусуСервер()
добавить строку

МассивЭлементов.Добавить("ТоварыОткрытьПодборБыстрый");

Скачать файлы

Наименование Файл Версия Размер
Подбор товаров с картинками для УТ11 22
.epf 17,73Kb
19.04.15
22
.epf 17,73Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. gosu lamer (gosulamer) 19.04.15 22:05
2. sockor sockor (sockor) 21.04.15 10:32
в типовом функционале присутствует выбор складов при подборе
3. Антон Чехов (upitersobaka) 21.07.15 09:40
Возможно при небольшом количестве позиций номенклатуры данная обработка и работает нормально, но когда пробывал работать с данным подбором с количествоам номенклатурных позиций с учетом характеристик больше 100 тысяч , то обработку подбора можна смело выкидывать на мусорку . Сам запрос работает быстро а, вот вывод товаров в форму подбора занимает очень много времени (больше минуты , когда критичным является уже 5 секунд). Очень тормозит и позиционирование на товаре в списке из за вывода картинки , так как каждый раз происходить поиск товара в огромном списке.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа