gifts2017

Проверка реквизитов сотрудников (физических лиц) для зарплатных отчетов в пенсионный фонд (РСВ-1, СЗВ-6-1(2)) и ФНС (2-НДФЛ). Обычные и управляемые формы. Расширенная

Опубликовал Максим Князев (mad_maksim) в раздел Отчеты - Анализ учета

Обработка предназначена для проверки полноты и корректности заполнения сведений о физлицах, необходимых для заполнения отчётов 2-НДФЛ и РСВ-1 (ФИО, ИНН, СНИЛС, адреса, паспорт).

Для конфигураций на платформе 8.2 (ЗУП 2.5, УПП 1.3, КА 1.1, ЗКБУ 1.0 и прочие на ОБЫЧНЫХ формах, содержащие структуру справочников и регистров как в ЗУП 2.5). НЕ подходит для БП 2.0.

За основу взята обработка http://infostart.ru/public/65913/.

Обработка позволяет быстро проверить наличие и корректность необходимых сведений о сотрудниках для сдачи персонифицированной отчётности (РСВ-1, СЗВ-6) и отчётности в налоговую (2-НДФЛ).

Так же пригодится для текущего контроля актуальности сведений (например, для подачи сведений в банк или выдачи справки 2-НДФЛ сотруднику).

 

Поля на форме:

Организация - можно выбрать организацию, по которой будет проводиться проверка. Если не указывать организацию, то будет произведена проверка физлиц, работающих во всех организациях. При этом не будут проверяться реквизиты организации, необходимые для отчётности (ОКОПФ и номер ПФР организации).

Проверять всех, независимо от дохода – будут проверены реквизиты всех физических лиц.

Налоговый период – период (год), за который сдаётся отчётность. Обязательный реквизит для заполнения. Для квартальных отчётов необходимо выбирать год, в который попадает отчётный период.

Проверять договорников – при установке проверяются работки на договорах ГПХ.

Проверяемые реквизиты – список проверок для выполнения.

Проверка адреса прописки в сервисе 1С – сверка адресов в сервисе 1С (всегда актуальный классификатор. Необходимо соединение с Интернет).

Логин – логин на сайте users.v8.1c.ru. Необходим для проверки адресов в сервисе 1С.

Пароль – пароль на сайте users.v8.1c.ru. Необходим для проверки адресов в сервисе 1С.

Проверка запускается по кнопке Проверка. Ход проверки отображается индикатором на форме обработки.

 

Проверяемые реквизиты:

1.      Реквизиты организации (производится всегда):

     1.1.   Заполнение ОКОПФ;

     1.2.   Заполнения рег. номера в ПФР.

2.      ФИО физического лица:

     2.1.   Проверка на полноту ФИО;

     2.2.   Проверка на языковую принадлежность символов.

3.      Дата рождения:

     3.1.   Дата не указана;

     3.2.   Указана неверная дата (дата больше даты конца выбранного периода).

4.      ИНН физического лица:

     4.1.   Наличие ИНН;

     4.2.   Контрольная сумма ИНН.

5.      СНИЛС физического лица:

     5.1.   Наличие СНИЛС;

     5.2.   Контрольная сумма СНИЛС.

6.      Удостоверение личности:

     6.1.   Наличие паспортных данных;

     6.2.   Наличие кода документа, удостоверяющего личность (1-99);

     6.3.   Для документов, КРОМЕ «Паспорт иностранного гражданина», «Свидетельство о рассмотрении ходатайства о признании беженцем на территории Российской Федерации по», «Вид на жительство», «Удостоверение беженца в Российской Федерации», «Временное удостоверение личности гражданина Российской Федерации», «Справка об освобождении из места лишения свободы», «Иные документы», предусмотрена проверка правильности ввода серии и номера удостоверения;

     6.4.   Для паспорта РФ предусмотрена проверка даты выдачи паспорта (точность до месяца на конец выбранного периода).

7.      Адрес регистрации (по прописке) (кроме иностранцев и нерезидентов):

     7.1.   Наличие адреса;

     7.2.   Наличие почтового индекса в адресе;

     7.3.   Соответствие адреса адресному классификатору (актуальный КЛАДР должен быть загружен в базу);

     7.4.   Проверка на недопустимые символы в номерах дома (разрешены цифры и буквы), корпуса (разрешены цифры и буквы) и квартиры (разрешены цифры).

     7.5.   NEW!!! Проверка соответствия адреса адресному классификатору в сервисе 1С (сверка с актуальным классификатором без загрузки его в базу). Необходимо ввести логин и пароль для авторизации на сайте users.v8.1c.ru.

8.      Адрес за пределами РФ (для иностранцев (гражданство НЕ РФ) и нерезидентов (по НДФЛ)):

     8.1.   Наличие адреса в произвольной форме;

     8.2.   Корректное заполнение страны в справочнике.

9.      Адрес для информирования (актуален для 2010 года):

     9.1.   Наличие адреса;

     9.2.   Для адреса, соответствующего структуре КЛАДР, проверяется соответствие адреса адресному классификатору (актуальный КЛАДР должен быть загружен в базу).

 

Чтобы для проверки адресов не загружать весь КЛАДР в базу, можно воспользоваться отчётом проверки используемых регионов в базе: http://infostart.ru/public/348153/

Для конфигураций на платформе 8.3 (ЗУП 3.0, ЗКГУ 3.0, ERP 2, КА 2, БП 3.0 и прочие на УПРАВЛЯЕМЫХ формах, содержащие структуру справочников и регистров как в ЗУП 3.0).

Обработка предназначена для проверки полноты и корректности заполнения сведений о физлицах, необходимых для заполнения отчётов 2-НДФЛ и РСВ-1.

Обработка позволяет быстро проверить наличие и корректность необходимых сведений о сотрудниках для сдачи персонифицированной отчётности (РСВ-1, СЗВ-6) и отчётности в налоговую (2-НДФЛ).

Так же пригодится для текущего контроля актуальности сведений (например, для подачи сведений в банк или выдачи справки 2-НДФЛ сотруднику).

 

Поля на форме:

Организация - можно выбрать организацию, по которой будет проводится проверка. Если не указывать организацию, то будет произведена проверка физлиц, работающих во всех организациях. При этом не будут проверяться реквизиты организации, необходимые для отчётности (ОКОПФ и номер ПФР организации).

Проверят всех, независимо от дохода – будут проверены реквизиты всех сотрудников, иначе только тех, у которых был доход в выбранном периоде.

Налоговый период – период (год), за который сдаётся отчётность. Обязательный реквизит для заполнения. Для квартальных отчётов необходимо выбирать год, в который попадает отчётный период.

Проверять договорников – при установке проверяются работки на договорах ГПХ.

Проверяемые реквизиты – список проверок для выполнения.

Проверка адресов (КЛАДР / ФИАС) – выбор адресного классификаторы, на соответствие которому будет проводится проверка адресов. Возможна сверка с классификатором, загруженным в базу, или в веб-сервисе 1С (зависит от настроек базы). Рекомендуется включить в базе использование веб-сервиса 1С для проверки адресов.

 

Проверка запускается по кнопке Проверка. Результат проверки выводится в отдельное окно.

 

Проверяемые реквизиты:

1.      Реквизиты организации (производится всегда):

     1.1.   Заполнение ОКОПФ;

     1.2.   Заполнения рег. номера в ПФР.

2.      ФИО физического лица:

     2.1.   Проверка на полноту ФИО;

     2.2.   Проверка на языковую принадлежность символов.

3.      Дата рождения:

     3.1.   Дата не указана;

     3.2.   Указана неверная дата (дата больше даты конца выбранного периода).

4.      ИНН физического лица:

      4.1.   Наличие ИНН;

      4.2.   Контрольная сумма ИНН.

5.      СНИЛС физического лица:

     5.1.   Наличие СНИЛС;

     5.2.   Контрольная сумма СНИЛС.

6.      Удостоверение личности:

     6.1.   Наличие паспортных данных;

     6.2.   Наличие кода документа, удостоверяющего личность (1-99);

     6.3.   Для документов, КРОМЕ «Паспорт иностранного гражданина», «Свидетельство о рассмотрении ходатайства о признании беженцем на территории Российской Федерации по», «Вид на жительство», «Удостоверение беженца в Российской Федерации», «Временное удостоверение личности гражданина Российской Федерации», «Справка об освобождении из места лишения свободы», «Иные документы», предусмотрена проверка серии и номера удостоверения;

     6.4.   Для паспорта РФ предусмотрена проверка даты выдачи паспорта (точность до месяца на конец выбранного периода).

7.      Адрес регистрации (по прописке) (кроме иностранцев и нерезидентов):

     7.1.   Наличие адреса;

     7.2.   Наличие почтового индекса в адресе;

     7.3.   Соответствие адреса адресному классификатору (Рекомендуется использовать веб-сервис 1С при наличии подключения к Интернет).

8.      Адрес за пределами РФ (для иностранцев (гражданство НЕ РФ) и нерезидентов (по НДФЛ)):

     8.1.   Наличие адреса в произвольной форме;

     8.2.   Корректное заполнение страны в справочнике.

9.      Адрес для информирования (актуален для 2010 года):

     9.1.   Наличие адреса;

     9.2.   Наличие почтового индекса в адресе;

     9.3.   Соответствие адреса адресному классификатору (только структурированные адреса).


Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Проверка реквизитов сотрудников (физических лиц) для зарплатных отчетов в пенсионный фонд (РСВ-1, СЗВ-6-1(2)) и налоговую (2-НДФЛ). Обычные формы
.epf 64,69Kb
20.01.16
51
.epf 1.02 64,69Kb 51 Скачать
Проверка реквизитов сотрудников (физических лиц) для зарплатных отчетов в пенсионный фонд (РСВ-1, СЗВ-6-1(2)) и налоговую (2-НДФЛ). Управляемые формы
.epf 20,13Kb
20.01.16
36
.epf 1.01 20,13Kb 36 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Николай Ожерельев (nozherelyev) 18.11.15 15:32
а у нас в 8.3 вот такая ошибка вылетела - Значение не является значением объектного типа (Субъект РФ)
2. Максим Князев (mad_maksim) 20.11.15 11:53
(1) nozherelyev, на какой конфигурации (название и релиз) Вы используете обработку? Ещё нужен хотя бы скриншот с ошибкой.
3. Наталья Иванова (Nativan) 20.01.16 16:45
Добрый день! Файл скачала, но обработка не запускается. ЗУП 2.5.98.1 платформа 8.3
4. Наталья Иванова (Nativan) 20.01.16 17:02
Обработка заработала. Нужно было скачать файл для 8.2, хотя у меня платформа 8.3, но ЗУП 2.5.
5. Юрий Машков (newtype) 21.01.16 09:27
Логин и пароьб на обычной форме-для SQL ?
6. Максим Князев (mad_maksim) 21.01.16 09:51
(5) newtype, логин и пароль к сайту users.v8.1c.ru. Читайте описание.
7. Юрий Машков (newtype) 21.01.16 10:22
1С:Предприятие 8.2 (8.2.19.106) Зарплата и Управление Персоналом, редакция 2.5 (2.5.94.1)
Выбрал все проверки,они прошли, но в начале проверок появилось сообщение :
(http://www.1c.ru)
по причине:
Ошибка разбора XML: - [1,1]
Фатальная ошибка:
Extra content at the end of the document
SystemId: https://api.orgaddress.1c.ru/orgaddress/v1?wsdl
{Форма.Форма.Форма(4610)}: Ошибка при вызове конструктора (WSОпределения)
Возврат Новый(Тип("WSОпределения"), Параметры);
по причине:
Ошибка разбора XML: - [1,1]
Фатальная ошибка:
Extra content at the end of the document
SystemId: https://api.orgaddress.1c.ru/orgaddress/v1?wsdl
{Форма.Форма.Форма(4610)}: Ошибка при вызове конструктора (WSОпределения)
Возврат Новый(Тип("WSОпределения"), Параметры);
по причине:
Ошибка разбора XML: - [1,1]
Фатальная ошибка:
Extra content at the end of the document
SystemId: https://api.orgaddress.1c.ru/orgaddress/v1?wsdl
{Форма.Форма.Форма(4610)}: Ошибка при вызове конструктора (WSОпределения)
Возврат Новый(Тип("WSОпределения"), Параметры);
по причине:
Ошибка разбора XML: - [1,1]
Фатальная ошибка:
Extra content at the end of the document
SystemId: https://api.orgaddress.1c.ru/orgaddress/v1?wsdl

Если это из-за того, что не ввёл пароль и логин , то хотелось бы видеть ошибочное сообщение на русском языке .
8. Юрий Машков (newtype) 21.01.16 10:47
После ввода логина и пароля получил сообщения типа :
Ошибка разбора XML: - [1,1]
Фатальная ошибка:
Extra content at the end of the document
SystemId: https://логин:пароль@api.orgaddress.1c.ru/orgaddress/v1?wsdl
{Форма.Форма.Форма(4610)}: Ошибка при вызове конструктора (WSОпределения)
Возврат Новый(Тип("WSОпределения"), Параметры);
по причине:
Ошибка разбора XML: - [1,1]
Фатальная ошибка:
Extra content at the end of the document

Проверял адреса.
9. Максим Князев (mad_maksim) 27.01.16 12:55
(8) newtype, не удаётся получить такую ошибку. Проверил на последнем релизе ЗУПа 2.5.98.2 (платформа 8.2.19.130). Из ошибок только то, что 1С сломала свой сервис проверки адресов, и пока не понятно, когда починит (индекс не подбирается).
10. Максим Князев (mad_maksim) 14.02.16 10:58
(9) mad_maksim, веб-сервис проверки адресов 1С снова работает.
11. Александр Отр (ИНТЕГРА) 10.05.16 15:08
Для подключения в качестве внешней:
1. Добавить процедуру в форму:
&НаКлиенте
Процедура ВыполнитьКоманду(Идентификатор) экспорт
	ЭтаФорма.Открыть();
КонецПроцедуры

2. добавить код в модуль объекта:

&НаКлиенте
Процедура ВыполнитьКОманду() экспорт
КонецПроцедуры

// Сервисная экспортная функция. Вызывается в основной программе при регистрации обработки в информационной базе
// Возвращает структуру с параметрами регистрации
//
// Возвращаемое значение:
//		Структура с полями:
//			Вид - строка, вид обработки, один из возможных: "ДополнительнаяОбработка", "ДополнительныйОтчет", 
//					"ЗаполнениеОбъекта", "Отчет", "ПечатнаяФорма", "СозданиеСвязанныхОбъектов"
//			Назначение - Массив строк имен объектов метаданных в формате: 
//					<ИмяКлассаОбъектаМетаданного>.[ * | <ИмяОбъектаМетаданных>]. 
//					Например, "Документ.СчетЗаказ" или "Справочник.*". Параметр имеет смысл только для назначаемых обработок, для глобальных может не задаваться.
//			Наименование - строка - Наименование обработки, которым будет заполнено наименование элемента справочника по умолчанию.
//			Информация  - строка - Краткая информация или описание по обработке.
//			Версия - строка - Версия обработки в формате “<старший номер>.<младший номер>” используется при загрузке обработок в информационную базу.
//			БезопасныйРежим - булево - Принимает значение Истина или Ложь, в зависимости от того, требуется ли устанавливать или отключать безопасный режим 
//							исполнения обработок. Если истина, обработка будет запущена в безопасном режиме. 
//
//
Функция СведенияОВнешнейОбработке() Экспорт
	
	//Инициализируем структуру с параметрами регистрации
	
	//Определяем список объектов, вызывающих обработку
	ОбъектыНазначенияФормы = Неопределено;
	//ОбъектыНазначенияФормы = Новый Массив;
	//ОбъектыНазначенияФормы.Добавить("Документы.КадровыйПеревод");
	ПараметрыРегистрации = ПолучитьПараметрыРегистрации("ДополнительнаяОбработка", ОбъектыНазначенияФормы);
	ПараметрыРегистрации.Версия = "1.0.0.1";

	//Определяем команды для печати формы
	
	ТаблицаКоманд = ПолучитьТаблицуКоманд();

	ДобавитьКоманду(ТаблицаКоманд,
		Метаданные().Синоним,				// Представление команды в пользовательском интерфейсе
		Метаданные().Имя,					// Уникальный идентификатор команды
		"ВызовКлиентскогоМетода",,""
	);

	ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

	Возврат ПараметрыРегистрации;

КонецФункции

//
// ВСПОМОГАТЕЛЬНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ РЕГИСТРАЦИИ ОБРАБОТКИ
//

// Формирует структуру с параметрами регистрации регистрации обработки в информационной базе
//
// Параметры:
//	ОбъектыНазначенияФормы - Массив - Массив строк имен объектов метаданных в формате: 
//					<ИмяКлассаОбъектаМетаданного>.[ * | <ИмяОбъектаМетаданных>]. 
//					или строка с именем объекта метаданных 
//	НаименованиеОбработки - строка - Наименование обработки, которым будет заполнено наименование элемента справочника по умолчанию.
//							Необязательно, по умолчанию синоним или представление объекта
//	Информация  - строка - Краткая информация или описание обработки.
//							Необязательно, по умолчанию комментарий объекта
//	Версия - строка - Версия обработки в формате “<старший номер>.<младший номер>” используется при загрузке обработок в информационную базу.
//
//
// Возвращаемое значение:
//		Структура
//
Функция ПолучитьПараметрыРегистрации(Вид, ОбъектыНазначенияФормы = Неопределено, НаименованиеОбработки = "", БезопасныйРежим=Ложь, Информация = "")

	Если ТипЗнч(ОбъектыНазначенияФормы) = Тип("Строка") Тогда
		ОбъектНазначенияФормы = ОбъектыНазначенияФормы;
		ОбъектыНазначенияФормы = Новый Массив;
		ОбъектыНазначенияФормы.Добавить(ОбъектНазначенияФормы);
	КонецЕсли; 
	
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Вид", Вид);
	ПараметрыРегистрации.Вставить("БезопасныйРежим", БезопасныйРежим);
	ПараметрыРегистрации.Вставить("Назначение", ОбъектыНазначенияФормы);
	
	Если Не ЗначениеЗаполнено(НаименованиеОбработки) Тогда
		НаименованиеОбработки = ЭтотОбъект.Метаданные().Представление();
	КонецЕсли; 
	ПараметрыРегистрации.Вставить("Наименование", НаименованиеОбработки);
	
	Если Не ЗначениеЗаполнено(Информация) Тогда
		Информация = ЭтотОбъект.Метаданные().Комментарий;
	КонецЕсли; 
	ПараметрыРегистрации.Вставить("Информация", Информация);
	
	ПараметрыРегистрации.Вставить("Версия", "1.0.0.0");

	Возврат ПараметрыРегистрации;

КонецФункции

// Формирует таблицу значений с командами печати
//	
// Возвращаемое значение:
//		ТаблицаЗначений
//
Функция ПолучитьТаблицуКоманд()

	Команды = Новый ТаблицаЗначений;
	
	//Представление команды в пользовательском интерфейсе
	Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
	
	//Уникальный идентификатор команды или имя макета печати
	Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
	
	//Способ вызова команды: "ОткрытиеФормы", "ВызовКлиентскогоМетода", "ВызовСерверногоМетода"
	// "ОткрытиеФормы" - применяется только для отчетов и дополнительных отчетов
	// "ВызовКлиентскогоМетода" - вызов процедуры Печать(), определённой в модуле формы обработки
	// "ВызовСерверногоМетода" - вызов процедуры Печать(), определённой в модуле объекта обработки
	Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
	
	//Показывать оповещение.
	//Если Истина, требуется показать оповещение при начале и при завершении работы обработки. 
	//Имеет смысл только при запуске обработки без открытия формы
	Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
	
	//Дополнительный модификатор команды. 
	//Используется для дополнительных обработок печатных форм на основе табличных макетов.
	//Для таких команд должен содержать строку ПечатьMXL
	Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

	Возврат Команды;

КонецФункции

// Вспомогательная процедура.
//
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование = "ВызовСерверногоМетода", ПоказыватьОповещение = Ложь, Модификатор = "ПечатьMXL")
	
	НоваяКоманда = ТаблицаКоманд.Добавить();
	НоваяКоманда.Представление = Представление;
	НоваяКоманда.Идентификатор = Идентификатор;
	НоваяКоманда.Использование = Использование;
	НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
	НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры
...Показать Скрыть
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа