gifts2017

[УТ 10.3] Округление в ТОРГ-12 и Счет-фактуре выданном, при пересчете рублёвых сумм договора в у.е.

Опубликовал Алексей Ермилов (Alex_E) в раздел Печать - Печатные формы документов

УТ 10.3.32.2 - при печати документов реализации, при договоре в у.е., в ТОРГ-12 как с услугами, так и без, округляются суммы без НДС и суммы НДС, при печати счет- фактуры по таким документам округления нет.
Пустячок, а неприятно, ВПФ - исправляет ситуацию...

В модуле документа счет-фактура выданный начиная со строки 4577 (релиз УТ 10.3.32.2) видим код:

 

	Для Каждого СтрокаСчетаФактуры Из ДанныеДляПечати.ТабличнаяЧасть Цикл
		
		СтрокаСчетаФактуры.Сумма = СтрокаСчетаФактуры.Сумма * Курс / Кратность;
		СтрокаСчетаФактуры.СуммаНДС = СтрокаСчетаФактуры.СуммаНДС * Курс / Кратность;
		
	КонецЦикла;

В модуле РТиУ сумма НДС считается с округлением (строка 371), дальше не смотрел - видно, что при пересчёте у.е. в рубли округление есть:

 

		Если СуммыВРублях Тогда
			Сумма          = Сумма       + СуммаРуб;
			СуммаНДС       = СуммаНДС    + Окр( ВыборкаСтрокТовары.СуммаНДС * КоэфКурса, 2, 1);
		Иначе
			Сумма          = Сумма       + ВыборкаСтрокТовары.Сумма;
			СуммаНДС       = СуммаНДС    + ВыборкаСтрокТовары.СуммаНДС;
		КонецЕсли;

Результат - сумма по счет - фактуре без НДС и всего могут расходиться с теми же суммами в ТОРГ-12, что реально призошло у клиента.

Дальше не копал, с помощью обработки "Конструктор внешних печатных форм" от SeiOkami (http://infostart.ru/profile/309462/ SeiOkami@yandex.ru  vk.com/SeiOkami) сваял ВПФ, в модуле которой изменены две строки:

 

	Для Каждого СтрокаСчетаФактуры Из ДанныеДляПечати.ТабличнаяЧасть Цикл
		
		СтрокаСчетаФактуры.Сумма = Окр(СтрокаСчетаФактуры.Сумма * Курс / Кратность, 2);//ЕАЮ добавил округление
		СтрокаСчетаФактуры.СуммаНДС = Окр(СтрокаСчетаФактуры.СуммаНДС * Курс / Кратность, 2); //ЕАЮ добавил округление
		
	КонецЦикла;

На печать теперь выводятся одинаковые суммы :-) 

В принципе, если конфигурация уже пилёная, можно исправить модуль счет-фактуры...

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Счет-фактура для печати договоров в у.е. как в ТОРГ-12
.epf 81,24Kb
06.06.15
4
.epf 81,24Kb 4 Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа