gifts2017

Диалоговое окно "Вопрос" со шрифтом большого формата

Опубликовал Осипов Сергей (fixin) в раздел Программирование - Работа с интерфейсом

Системные диалоги в 1С имеют мелкий шрифт, многих пользователей это напрягает.
Пришлось написать альтернативу функции Вопрос, с большим шрифтом.

 

Поддерживается таймаут и режимы Да+Нет и Дат+Нет+Отмена. В случае передачи других режимов вызывается типовой диалог.

 

Вызывается функция примерно так:

Сообщить(ВОпросБольшой("Вы уверены в том что хотите сделать, хорошо подумали? Очень хорошо подумали? Дважды? Трижды? Точно берете на себя ответственность?", РежимДиалогаВопрос.ДаНет, 30,  КодВозвратаДиалога.Нет, "Вопросик", КодВозвратаДиалога.Да))

 

Сама форма находится в обработке «Вопрос большой». Код функции по вызову этой обработки выглядит так:

 

Функция ВопросБольшой(ТекстВопроса, Кнопки, Таймаут = Неопределено, КнопкаПоУмолчанию = Неопределено, Заголовок = Неопределено, КнопкаТаймаута = Неопределено)Экспорт
       //Сообщить(САП.ВОпросБольшой("Вы уверены в том что хотите сделать, хорошо подумали? Очень хорошо подумали? Дважды? Трижды? Точно берете на себя ответственность?", РежимДиалогаВопрос.ДаНет, 30,  КодВозвратаДиалога.Нет, "Вопросик", КодВозвратаДиалога.Да))
      
      
       #Если Клиент Тогда
             Ф = Обработки.ВопросБольшой.ПолучитьФорму();
             Ф._ТекстВопроса = ТекстВопроса;
             Ф._Кнопки = Кнопки;
             Ф._ТаймАут = Таймаут;
             Ф._КнопкаПоУмолчанию = КнопкаПоУмолчанию;
             Ф._Заголовок = Заголовок;
             Ф._КнопкаТаймАута = КнопкаТаймаута;
             Возврат Ф.ОткрытьМодально();
       #КонецЕсли
КонецФункции

 

 

Вот как выглядит окно с тремя кнопками:

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
down.zip
.zip 3,37Kb
26.09.15
0
.zip 3,37Kb 0 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Михаил Коваль (mihey) 26.09.15 17:24
Не кошерно нынче модально формы открывать, тогда уже нужен и аналог ПоказатьБольшойВопрос :)
2. Юрий Былинкин (ardn) 26.09.15 17:30
3. Осипов Сергей (fixin) 26.09.15 19:06
(1)(2) я только с месяц как изучил УФ, но как знать, может и для УФ напишу ПоказатьБольшойВопросУФ. ;-)
Ксати, три года пользователь на проходной (охранник) сидел с мелким шрифтом и только год назад я удосужился по доброте душевной ему поменять размер букв. Мелочь, а человеку приятно.
4. BigB (BigB) 26.09.15 19:49
Господи, какое убожество.
ТС учи мат часть.
&НаКлиенте
Процедура Команда1(Команда)
	ТекстВопроса=Новый ФорматированнаяСтрока("Текст вопроса",Новый Шрифт( ,30, Истина));
	ПоказатьВопрос(Новый ОписаниеОповещения("ПослеЗакрытияВопроса",ЭтотОбъект),ТекстВопроса,РежимДиалогаВопрос.ДаНетОтмена)
КонецПроцедуры

&НаКлиенте
Процедура ПослеЗакрытияВопроса(Результат, Параметры) Экспорт
	Если Результат=КодВозвратаДиалога.Да Тогда
	ИначеЕсли Результат=КодВозвратаДиалога.Нет Тогда
	КонецЕсли
КонецПроцедуры
...Показать Скрыть

Прикрепленные файлы:
BurningChrome; kgn2011; Glebis; u_n_k_n_o_w_n; ardn; klinval; D.B.Sokolov; +7 Ответить 2
5. Осипов Сергей (fixin) 27.09.15 00:56
(4) в режиме совместимости с 8.1 работает? гыгыгыгы...
Я понимаю, что УФ - это модно, но не стоит забывать про те конторы, где еще на них не перешли. ;-)
6. Валерий К (klinval) 28.09.15 09:32
(5) fixin, ну с таким же успехом можно было бы вам сказать: "А в <Режим использования модальности = Не использовать> работать будет?". Получается, что ваш вариант работает на 8.1, а (4) работает с не модальными окнами, может стоит плюсануть BigB и подправить статью, внеся туда предложенный в четвертом сообщении код?
7. Осипов Сергей (fixin) 28.09.15 11:40
(6) Замечание Большого Би нормальное и важное (я например не знал, что в УФ такое можно, но сама задача решалась не на УФ), но сам вопрос слишком мелкий, кому интересно, комменты прочитает. ;-)
8. Андрей Карпов (karpik666) 28.09.15 16:23
Для обычных форм, предложенная вами идея уже реализована, но там не вопрос да и нет, а просто оповещение, например в зуп. Обработка называется: "СообщенияВыполняемыхДействий" .
P.S. Не могу понять зачем в коде функция "Сообщить"?
9. Вадим Латышев (pro1c@inbox.ru) 20.10.15 12:31
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа