ЕГАИС - Запрос остатков обособленного подразделения (Управляемая форма)

Обмен - Интеграция с WEB

Предлагаю Вам независимую программу для контроля остатков обособленного подразделения в системе ЕГАИС.
На управляемой форме.

Программа позволит Вам запросить остатки вашего обособленного подразделения по его регистрационному коду в системе ЕГАИС, через подготовленную УТМ.

Программа независима от конфигурации. Работает на последней платформе 8.2. (8.2.19) на управляемой форме. Для нее требуется CURL, джакарта с действующим ключом и рабочий УТМ (ЕГАИС).

Принцип работы программы очень прост - заполняете FSRARID - регистрационный номер точки в системе ЕГАИС и нажимаете кнопку получить остатки. Через некоторое время (2- 5 минут) приходят остатки.

Кто не знает, что такое ЕГАИС и УТМ, смотрите эти ссылки:

//infostart.ru/public/417228/

//infostart.ru/public/407871/

//infostart.ru/public/412834/

Код программы открыт. Результат программы - таблица с номенклатурой в разрезе справок А и Б.

Скачать файлы

Наименование Файл Версия Размер
Запрос остатков ЕГАИС
.epf 16,05Kb
20.05.16
44
.epf 16,05Kb 44 Скачать

См. также

Комментарии
1. Дмитрий Федосеев (Федосеев) 25.01.16 10:55 Сейчас в теме
В каких единицах получаются данные из ЕГАИС в штуках или декалитрах ?
2. Дмитрий Никс (aximo) 668 25.01.16 12:22 Сейчас в теме
ответ ФС-РАР такой - кеги идут в декалитрах, все остальное в бутылках (штуки)
3. Дмитрий Федосеев (Федосеев) 29.01.16 19:40 Сейчас в теме
(2) aximo, Вот я загрузил например сообщение ЕГАИС (ТТН от поставщика) там есть название и количество, получается что только из названия и то не всегда я могу понять в штуках мне пришло или декалитрах ? Я правильно понял?
Или для ттн всегда в декалитрах,а для остатков в штуках и декалитрах?
4. Vladimir A (wowik) 276 10.03.16 11:53 Сейчас в теме
Добрый день.
Запустил Вашу обработку, получил ответ от егаис.
Обработка показывает, что на остатках всего 1ш какого-то вина. Это нормально?
Или в егаис на организации ничего не числится более?
5. Дмитрий Никс (aximo) 668 10.03.16 11:56 Сейчас в теме
Если висит бутылка вина, значит, она как-то туда попала. Если ничего нет - вернет пустой запрос... проверено
6. Vladimir A (wowik) 276 10.03.16 12:26 Сейчас в теме
(5) aximo, проверял на 3 магазинах: на одном 1шт числится, на 2-х других ничего не возвращает.
Поставщики отправляли кучу продукции на эти торговые точки. В чем может быть дело? Или остатки в егаис появятся перед стартом продаж через егаис?
7. Дмитрий Никс (aximo) 668 10.03.16 12:51 Сейчас в теме
(6) так вы их не принимали... все верно!
8. Vladimir A (wowik) 276 10.03.16 13:48 Сейчас в теме
(7) aximo, принятые ттн также есть.
9. Дмитрий Никс (aximo) 668 10.03.16 13:51 Сейчас в теме
(8) wowik, мы ставили на баланс и проверяли этой обработкой.... лично проверял! работает на многих точках.... что у вас, нужно смотреть
10. Vladimir A (wowik) 276 10.03.16 17:09 Сейчас в теме
(9) aximo, вроде что-то получил от егаис. Как-то странно ответ приходит от егаис, не через 5 минут, а через несколько часов я так понял.
Вопрос: где строки 80, 81 - http://prntscr.com/adho1z ?
11. Vladimir A (wowik) 276 10.03.16 17:44 Сейчас в теме
(10) wowik, все работает, отбор был установлен в табличной части. Спасибо. Плюсую.
12. Vladimir A (wowik) 276 18.03.16 16:04 Сейчас в теме
Есть одно замечание, нужно удалять запросы после получения, чтобы они не накапливались.
Может кому понадобится (добавил в Вашу обработку кнопочку):

&НаКлиенте
Процедура УдалитьОтветСУТМ(Команда)
	
	 Оповещение 	= Новый ОписаниеОповещения("УдалитьЗапросыЗавершение", ЭтотОбъект, Новый Структура);
	 ТекстВопроса 	= "Удалить выбранные запросы из УТМ?";
	 ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);

КонецПроцедуры
 

&НаКлиенте
Процедура УдалитьЗапросыЗавершение(Результат, ДополнительныеПараметры) Экспорт
	
	Если Результат = КодВозвратаДиалога.Да Тогда 
		Для каждого ВыделеннаяСтрока из Элементы.ВходящиеОтветы.ВыделенныеСтроки Цикл
			СтрокаТаблицы = Объект.ВходящиеОтветы.НайтиПоИдентификатору(ВыделеннаяСтрока);
			ТекстЗапроса = СтрокаТаблицы.Ссылка;
			ЗапросCURL	= "-X DELETE "+ТекстЗапроса+" ";
			КомандаСистемы("curl "+ЗапросCURL);
		КонецЦикла;   
		
		ОбновимВходящиеДанныеЕГАИС(); 		
	КонецЕсли;	
	
КонецПроцедуры
...Показать Скрыть
13. Дмитрий Сидоренко (kavladiego) 07.07.16 12:48 Сейчас в теме
Получаю вот такую историю при запросе
Запрос по остаткам точки с ИД 020000155304 сформирован: C:\Users\Ира\AppData\Local\Temp\QueryParameters.xls
Невозможно открыть файл ответа C:\Users\Ира\AppData\Local\Temp\answer.xml
Файлы запроса и ответа удалены!
Что делаю не так?
1С Розница 2.2 (2.2.3.10)
14. Дмитрий Никс (aximo) 668 07.07.16 16:54 Сейчас в теме
(13) kavladiego, курл у вас не установлен. именно он создает файл ответа
15. Андрей Тарлыков (Tarlich) 69 18.08.16 23:35 Сейчас в теме
Что не так ? выходит сообщения :
Прикрепленные файлы:
16. Дмитрий Никс (aximo) 668 19.08.16 08:10 Сейчас в теме
Оставьте свое сообщение