gifts2017

Глокая Куздра программирования 1С

Опубликовал Владимир Потапов (keleg) в раздел Сообщество - О жизни

Как писать программы на 1С, чтоб их понял не только процессор, но и человек?
Вводная статья по рефакторингу в среде 1С

Известен такой анекдот. Вызывает профессор-лингвист студента к доске и говорит: «Пиши: Глокая куздра штеко будланула бокра и курдячит бокренка». «Чего-чего?» было спросил студент, но с авторитетом профессора спорить не стал и честно записал эту абракадабру. А теперь, - сказал профессор, объясни – о чем говорится в этом предложении? На студента стало жалко смотреть и лектор сжалился.

- Ну, кто здесь главное действующее лицо?
- Ку… куздра, - промямлил студент
- А какая она, эта куздра?
- Глокая! - уже уверенней произнес студент
- А на кого направлено действие?
- На бокра!
- И что эта куздра сделала?
- Она его будланула! – выкрикнули из аудитории со смехом.
- И штеко, причем, будланула, добавил, улыбнувшись, профессор.
- А вот бокр – он живой?
Студент задумался…
- А! Да! У него бокренок есть!
- У бочки тоже есть бочонок, но это не значит, что она живая. Если бы бокр был неживой, мы бы сказали «булданула бокр», это винительный падеж «кого, что».

Итак, не зная смысла ни одного существительного, прилагательного или глагола мы уже можем достаточно много рассказать о происшедшем. Информацию об этом мы извлекли из вроде бы незначащих вещей – падежей, союзов, окончаний, определяющих отношения между словами в предложении.

Теперь вернемся от языковедения к программированию. При чем здесь Глокая куздра? Много говорилось о том, что названия процедур, функций и переменных должны быть «говорящими» должны соответствовать логике их использования. Но не менее говорящими должны быть и связи между идентификаторами! Даже не зная конкретного смысла программы, можно с первого взгляда увидеть, как она устроена.

Как этого достичь?
Возьмем Глокую куздру.
Но что это? Известно, что Глокая куздра может выполнять несколько действий. Она умеет будлануть, а умеет и курдячить т.е. представляет собой несколько связанных действий. Также известно, что эта куздра именно глокая, т.е. есть изменяемый параметр, явно в природе существуют и другие куздры – неглокие. В 1С логичнее всего оформить нашу куздру как обработку. Ведь бокров она именно «обрабатывает». Теперь, если ввести в тексте программы
Куздра. (с точкой), то система покажет все, что эта куздра умеет делать. Глокая пусть будет реквизитом обработки. Сегодня Куздра будет Глокая, т.е.
Куздра.Глокая = Истина

Дальше возьмемся за бокра. Документ или справочник наш герой, не так важно, т.к. сам он ничего не делает, кроме одного: как мы помним, куздра его будланула. Т.е. явно состояние бокра изменилось, произошло действие! Что у нас отвечает за действие, что в 1С заменяет глаголы? Процедуры и функции. Теперь нужно выбрать, что будем применять. Можно написать

Куздра.Будланула(бокра);
и это будет почти по-русски. Но из этой записи совершенно не понятно, изменился бокр или нет. Опять же, куздра булданула его штеко т.е. с параметром. Получится
Куздра.Булданула(Бокра, Штеко)
Здесь непонятно, кого куздра булданула – бокра или штеко, что является результатом действия, а что - его параметром. Самый правильный выход – написать
Бокр = Куздра.Будланула(Бокр, Штеко)

Теперь все методически правильно. Бокр является параметром и результатом (т.е. изменено его состояние, это объект над которым произошло действие), штеко – параметр. Соответственно продолжим наше повествование. Из него не совсем понятно, когда же это все кончится, когда глокая куздра все-таки закурдячит бокренка, ведь висящая программа нам не нужна. Допустим, бокренка есть функция Конец(), которая определяет конец закурдяченности. Получится такая вот такая конструкция

Пока Не Бокренок.Конец() Цикл 
  Бокренок = Куздра.Курдячит(Бокренок)
КонецЦикла

Здесь мы выразили непрерывное, повторяющееся действие через цикл (допустив, что прекращение действия зависит от Бокренка. Если оно зависит, например, от Бокра или состояния самой ГлокойКуздры, это тоже можно было выразить). Дальше еще можно добавить связь между Бокром и Бокренком. Оба они бокры! Значит, это можно выразить, объединив их в структуру, что может понадобиться, например, если нужно будет передать куда-то всех бокров скопом, а не поодиночке.

Итого у нас получилось
Куздра.Глокая = Истина;
Бокры.Бокр = Куздра.Будланула(Бокры.Бокр, Штеко);
Пока Не Бокры.Бокренок.Конец() Цикл 
  Бокры.Бокренок = Куздра.Курдячит(Бокры.Бокренок); 
КонецЦикла;

Конечно, по сравнению с богатством русского языка, в пересказе на макроязыке 1С некоторые нюансы шедевра потерялись, но главная нить по-прежнему вполне улавливается. А значит и в языке программирования операторы отношения и присваивания имеют выразительный смысл, который можно и нужно использовать!

Формализуем правила
  • Связанные между собой по-смыслу действия процедуры и функции полезно объединять
  • Нужно четко отделять само действие, объект, на который действие направлено и параметры действия. Это три разные вещи!
  • Для показа изменения состояния объектов данных нагляднее использовать функции, а не процедуры. А так как функция возвращает только один результат не нужно одной процедурой менять все сразу!
    ГлокаяКуздра(Бокра, Бокренка, Будланула, Курдячит)
    
    это не наш путь!
  • Продолжение - следует!

    См. также

    Подписаться Добавить вознаграждение

    Комментарии

    1. Александр Шишкин (Шёпот теней) 15.10.08 08:53
    Гы....
    Классно!

    Теперь решён извечный спор моей души - когда функция а когда процедура...

    Во-О-от спасибо!
    2. Владимир Потапов (keleg) 15.10.08 09:14
    Ну да, если изменение делать только через функции, то введя в поиске, например, "Параметр = " получим все места, где этот параметр меняется.
    В случае использования для изменения процедур это уже не работает, придется анализировать код. А зачем делать лишнюю работу? :-)
    Правда, если в глубине объекта меняется очень многое, не стоит писать что-то типа
    Объект.Поле.Поле = Функция(1);
    Объект.Поле.Поле2 = Функция(2);
    Объект.Поле.Поле3 = Функция(3);
    можно свернуть такую конструкцию через отдельную функцию
    Объект.Поле = Функция1(Объект.Поле)
    но это уже тема для отдельной статьи по методам рефакторинга.
    Шёпот теней; +1 Ответить 1
    3. Venger (venger) 15.10.08 12:50
    Да, штеко накурдячено:-)) Свежо
    4. Альтаир (Altair777) 15.10.08 16:44
    + Аффтар жжот :-)
    И весело, и занимательно, и правильно.
    5. Maniac (Eugeneer) 15.10.08 17:09
    да травы курнул некисло.
    lomok; venger; +2 Ответить
    6. Maljaev (maljaev) 15.10.08 17:26
    (0) Уважаемый, вам нужно на курсах 1С преподавать, не иначе! С таким свежим и неординарным подходом штеко умные программисты наконец-то появятся.
    Патриот; +1 Ответить
    7. Юрий Португалов (Sprite) 15.10.08 17:32
    Интересные факты:
    «Гло́кая ку́здра ште́ко будлану́ла бо́кра и курдя́чит бокрёнка» — искусственная фраза русского языка, в которой все корневые морфемы заменены на бессмысленные сочетания звуков.
    Пример был предложен академиком Л. В. Щербой в 1930-е и использовался на вводных лекциях к курсу «Основы языкознания». Широкую известность эта фраза приобрела после публикации научно-популярной книги Льва Успенского «Слово о словах».

    Согласно устному рассказу Ираклия Андроникова, впервые (в конце 1920-х годов) фраза звучала: «Кудматая бокра штеко будланула тукастенького бокрёночка».

    В детективе Александры Марининой «Убийца поневоле» встречается персонаж — бывший уголовник по кличке Бокр, который взял себе это прозвище, прочитав в тюремной библиотеке книгу Успенского «Слово о словах».
    Точная фраза Щербы до сих пор неизвестна. Сам он произносил её в разное время по-разному, и верификация изначального варианта, судя по всему, невозможна.
    Ещё в декабре 1863 года Льюис Кэрролл, после любительского спектакля «Альфред Великий» прочёл гостям четверостишье (состояло целиком из несуществующих слов, за исключением служебных, чем формально было родственно глокой куздре), которое позже использовал как пролог к своей поэме «Бармаглот», приведённой в книге Алиса в Зазеркалье. Бармаглот — вероятно, первая попытка ввести в язык несуществующие слова, подчиняющиеся, тем не менее, всем законам языка.

    Баллада о Джаббервокке. стихотворение Льюиса Кэрролла, входящее в повесть-сказку «Алиса в Зазеркалье»:

    Сварнело. Провко ящуки
    Паробуртелись по вселянке
    Хворчастны были швабраки
    Зелиньи чхрыли в издомлянке.

    "Сын! Джаббервокка берегись:
    Ужасны клюв его и лапа.
    И птицы Джубджуб стерегись
    И опаужься Бендерцапа!"

    Взяв свой чумеч, он шел на шум,
    Искал врага кровавологи
    И подле дерева Тумтум
    Остановился на дороге.

    Стоит грозумчив и гневок, -
    Вдруг огнеглазый и рычащий,
    Дымясь восторгом, Джаббервокк
    Летит к нему глумучей чащей.

    Но вкривь-вкось чумеч кривой
    Чикчикает над Джаббервокком,
    И вот с отрубленной главой
    Герой несется торжескоком.

    "Как? Он убил его? Смотри!
    Хитральчик мой, сынок лучавый!
    О, харара! О, харара!
    Какой денек героеславый"...
    Шёпот теней; +1 Ответить
    8. Сhe Burashka (CheBurator) 15.10.08 19:30
    Хорошо, но конечно за приведенное переложение на язык 1С - двойка!
    потому что упущено СУЩЕСТВЕННОЕ УСЛОВИЕ. а именно "И"
    "булданула бокра И курдячит бокренка" - т.е. в данной фразе следовало бы учесть тот факт, что эти два события "булдание бокра" И " кудрячение бокренка" - возвращают ИСТИНУ при соблюдении двух условий. В данном примере этот наиважнейший аспект - упущен.
    Садитесь, два!
    9. Сhe Burashka (CheBurator) 15.10.08 19:34
    Можно предположить, что Куздра стала глокой именно после булдания бокра и глокой является именно во время курдчания бокренка... то есть типа так:
    ..
    Бокры.Бокр = Куздра.Булданула(Бокры.Бокр, Штеко);
    Пока Не Бокры.Бокренок.Конец() Цикл
    Бокры.Бокренок = Куздра.Курдячит(Бокры.Бокренок);
    Куздра.Глокая = Истина;
    КонецЦикла;
    Куздра.Глокая = Ложь;
    ..
    согласитесь - результат состояния Куздры - принципиально иной ву автора и приведенном мной коменте...
    Altez; Шёпот теней; +2 Ответить
    10. Kivduts (kivduts) 16.10.08 06:06
    Сhe Burashka к вам вопрос у вас дети есть? Я конечно согласен критика нужна, и всякий хлам гнать надо, но не все люди умны как вы, но и есть такие кто умнее вас.
    Шёпот теней; +1 Ответить 1
    11. Аркадий Кучер (Abadonna) 16.10.08 06:35
    Все давно описано Л. Кэрролом :) Алиса в Зазеркалье.
    БАРМАГЛОТ
    Варкалось. Хливкие шорьки
    Пырялись по паве,
    И хрюкотали зелюки.
    Как мюмзики в мове 22.
    О бойся Бармаглота, сын! 28
    Он так свирлеп и дик,
    А в глуще рымит исполин -
    Злопастный Брандашмыг! 29
    Но взял он меч, и взял он щит,
    Высоких полон дум.
    В глущобу путь его лежит
    Под дерево Тумтум.
    Он стал под дерево и ждет,
    И вдруг граахнул гром -
    Летит ужасный Бармаглот
    И пылкает огнем!
    Раз-два, раз-два! Горит трава,
    Взы-взы – стрижает меч,
    Ува! Ува! И голова
    Барабардает с плеч!
    О светозарный мальчик мой!
    Ты победил в бою!
    О храброславленный герой,
    Хвалу тебе пою!
    Варкалось 30. Хливкие шорьки
    Пырялись по наве.
    И хрюкотали зелюки.
    Как мюмзики в мове.
    Шёпот теней; +1 Ответить
    12. Владимир Потапов (keleg) 16.10.08 07:10
    Спасибо за комментарии!
    Отдельное спасибо ЧеБурашке :-) Заставил еще раз задуматься над смыслом великого произведения :-)
    1) В момент булданутия Бокра Куздра уже была глокой (см. первоисточник)
    2) В моей интерпретации при любых условиях срабатывают и будание Бокра, и курдячение бокренка. Так что, считаю, все вполне корректно. Другой вопрос - что было бы, если бы Бокр не булданулся? Но об этом и первоисточник, и моя программа, умалчивают. Да и нет в 1С нормальной работы с исключениями :-)
    Шёпот теней; +1 Ответить 1
    13. К. (Razamataz) 16.10.08 11:43
    Прикольно :)

    to Сhe Burashka: Ну с Вашими выводами действительно можно поспорить ;)

    1) куздра штеко булданула бокра -- прошедшее время, а курдячит настоящее, поэтому "и" тут конечно есть, но ставить в коде в одно выражение имхо не правильно, поэтому с этим у автора всё ок;
    2) а вот опираясь на различие времен глокая куздра именно сейчас, я строчку
    Код
     Куздра.Глокая = Истина; 
    Показать полностью
    сместил бы на одну позицию вниз;
    3) А вот использовать
    Код
     Куздра.Глокая = Истина; 
    Показать полностью
    внутри цикла это помоему методически не правильно, т.к. как говорится масло масленное, всмысле уже после первогог выполнения присвоена истина, поэтому эту строку надо вынести за пределы цикла или же например тогда уж использовать тип число и увеличивать её величину по мере выполнения цикла, например
    Код
     Куздра.Глокая = Куздра.Глокая + ПриростГлокости; 
    Показать полностью


    И в целом тогда можно получить например след. картину:

    Код
     
    Результат = Куздра.Булданула(Бокры.Бокр, Штеко);
    
    Бокры.Бокр = Результат.Пациенс;
    Бокры.Бокр.Глок = Результат.ЭкспириенсПациенса;
    Куздра.Глок = Результат.ЭкспириенсАгенса; //хотя это уместнее разместить внутри функции Булданула(),
                                                                        //т.к. относится к тому же объекту
    
    Пока Куздра.ХочетГлоку() ИЛИ Не Бокры.Бокренок.Конец() Цикл 
             Результат = Куздра.Курдячит(Бокры.Бокренок);
             Бокры.Бокренок = Результат.Пациенс;
             Бокры.Бокренок.ЖизненнаяСила -= Результат.ЭкспириенсПациенса;
             Куздра.Глок += Результат.ЭкспириенсАгенса;
    КонецЦикла;
    Показать полностью
    14. Сhe Burashka (CheBurator) 16.10.08 13:27
    (10) да, у меня дети есть - сын 16 лет, который уже сейчас зарабатывает себе на свои ежедневные подростково/юношеские потребности сам.
    А насчет того что есть люди и поумнее меня - полностью с вами согласен!
    И с удовольствие черпаю у таких людей мудрость и знания в силу своих возможностей.
    15. Елена (Lyekka) 16.10.08 13:30
    Правильно, может оно и правильно, но сомневаюсь, что народ прямо сейчас возьмётся перелопачивать весь код, написанный до сего момента. Цель, разумеется, должна быть идеальной. Но и жить вне компьютера тоже стоит, ИМХО.
    16. Сhe Burashka (CheBurator) 16.10.08 13:36
    (12) эээ.. тут можно и подискутировать...
    Однозначно можно утверждать что куздра - глокая в настоящем времени, то есть во время кудлачения бокренка...
    Каково было состояние куздры ранее и каково будет состояние куздры после окончания кудлачения бокренка - тут я бы не взялся утверждать однозначно...
    То есть, тут мы выходим на применение fuzzy-логики...
    17. Сhe Burashka (CheBurator) 16.10.08 13:39
    Также можно сделать предположение, раз существует оператор "И" в утверждении - то осуществившееся событие булдания и настоящее событие кудрячения - неразрывно связаны..
    НО! По правилам русского языка союз "И" в ряде случаев рассматривается как союз "А", т.е. фраза может быть прочитана и так: " Глокая куздра штеко булданула бокра, А курдячит бокренка» - в этом случае математическое описание с учетом смысловой нагрузки во фразе - будет совершенно другое...!!!!
    18. Maljaev (maljaev) 16.10.08 13:45
    Всё-таки я предпочитаю более традиционное изложение методических материалов. В этом плане соседняя тема о том как избежать ошибок нравится мне больше. После множества прочтенных мануалов читать подобное изложение и понимать его очень сложно - возможно с непривычки.

    P.S. Кстати, Шепот, а че ты все посты подряд плюсуешь? Плюсани тогда и меня, что ли... :)
    Шёпот теней; +1 Ответить 1
    19. Олег Пономаренко (O-Planet) 16.10.08 14:37
    Вы тут ваще о чем? 0_о

    Я ниасилил даже заголовок, хотя статья, наверное, интересная. :((( Сперва подумал, что она - на эльфийском. Но потом пришел к заключению, что это какой-то мало распространенный гоблинский диалект. Не думал, что столько народу знают гоблинский. Йа - нуп...
    20. VasilyKushnir (vasilykushnir) 16.10.08 14:51
    (19) Олежа, забей... Я же забил и нормально себя чувствую. Чем бы дитё не тешилось...
    Трям.
    21. Maljaev (maljaev) 16.10.08 15:09
    (19) Пора заканчивать с РПГ... :)
    22. Сhe Burashka (CheBurator) 16.10.08 23:28
    О чем показывает обсуждение данного материала? а о том, что немногим субъектам нашего сообщества доступно абстрагирование... ;-)
    23. Сhe Burashka (CheBurator) 16.10.08 23:38
    +1 глокой куздре! я хорошо оттянулся!
    24. Олег Пономаренко (O-Planet) 17.10.08 01:10
    Уточнил... Тут ашипка. Точнее, особенность используемого аффтором гоблинского наречия. Бокренок - это ваще женский род, только в просторечии, как типа мы говорим "малыш", обращаясь к подруге. И правильно - не кудрячит, а куздра куздрячит. В условии цикла надо использовать не "Конец()", а "Ооойааай()" Иначе смысл не ясен...
    daMaster; +1 Ответить
    25. Сhe Burashka (CheBurator) 17.10.08 01:25
    > куздра куздрячит.
    давайте не будем скатываться к примитивизму...
    "куздра куздрячит" - понятно, что это обозначает действие _изначально_ характерное для куздры... но как таковая куздра сама по себе - нас не интересует... "кузрячит" - эквивалентно "рабочий работает" - т.е. энтропия данного сообщеняи близка к 0... "Куздра ... курдячит" - гораздо более емкое обпределение действия, которое поязволяет сделат вывод о том, что куздра имеет не одну степень свободы (куздрячит) а - гораздо больше! т.е. отсюда можно сделать вывод что куздра - суть многофункциональный объект/субъект! это подтверждается также и тем, что куздра еще может/умеет/выполняет БУЛДАНИЕ БОКРА, т.е. как минимум, куздра имеет три стпени свободы - 1.куздрячение (как изначально принадлежащее куздре по самоей ее сути) 2. кудрячение (бокренка!!!! не кого именно, а как минимум - бокренка) и 3. булдание (бокра, а не кого попало)...
    ..
    вышеприведенный анализ позволяет также сделать вывод о том, что куздра - многофункциональный субъект/объект с избирательной "программой" действия, определяемой окружающей обстановкой (бокренка - кудрячит, болдание - бокра), т.е. присутствует обратная связь в определяющих мотивах поведения куздры...
    ..Вопрос о том, является ли куздра искуственным объектом/субъектом, однозначно определяемым конечным набором кортежей "действие куздры - объект вблизи куздры", или же куздра является объектом живой природы с ненормированным поведением в условиях нормированной/ненормированной внешней обстановки - на данный момент остается открытым...
    26. Александр Шишкин (Шёпот теней) 17.10.08 08:44
    (18)

    В чём величие абстрактного искусства?

    В том, что оно имеет несколько уровней познания, оно изначально отказывается от ведения по знакомым тропинкам и предлагает человеку заняться творчеством самостоятельно. Причем совершенно не отвергает весь предыдущий путь развития, опыт предыдущего знания.

    Вот я и голосую за это, за нестандартное, за новый взгляд, за новое прочтение и мне нравится, что программисты это не только знатоки кода и бухгалтерии, но ещё и люди высокой культуры. За согласие, за попытку найти примирение. За высказывания, которые дополняют ответ, за попытку найти правду или истину, за критику, а не за желание проявить своё эго.

    Воо-о-оот такое мнение моё….
    27. Аркадий Кучер (Abadonna) 17.10.08 09:16
    (26)>В чём величие абстрактного искусства?
    Что касаемо художников-абстракционистов, то лично я бы с удовольствием бил бы их по башке рамами от их же "картин" ;)
    28. Альтаир (Altair777) 17.10.08 09:52
    По поводу искусства вообще и программирование в частности у меня давно есть такое мнение.
    Основные критерии к программе:
    1) Она должна работать правильно
    2) Она должна работать быстро
    3) Она должна работать красиво

    Это картина или стихотворение может нравится или нет... у каждого свой вкус. Это субъективно.
    А программа должна работать! Это объективная реальность.
    vasilykushnir; +1 Ответить 1
    29. Владимир Потапов (keleg) 17.10.08 10:12
    Ну, а чтобы программа работала правильно, быстро и красиво, ее логика должна быть понятна разработчику.
    Начиная с первого десятка тысяч строк кода это не так-то просто, уж поверьте :-)
    Потому и появилась такая дисциплина, как рефакторинг.
    Читайте следующую статью!
    30. Василий Демидов (Душелов) 17.10.08 10:15
    (28) это в условиях, когда 1 программист. Попробуйте работать над программой в числе 20-30 разработчиков, и когда каждый пишет, как хочет...
    31. Альтаир (Altair777) 17.10.08 10:21
    (30) Или как я сейчас.
    Пришел на новую работу, смотрю конфу.... И фшоке :-)
    32. Александр Шишкин (Шёпот теней) 17.10.08 10:38
    написать программу в 10 строк может каждый
    написать программу в 100 строк может упорный
    написать программу в 1000 строк может талант
    написать программу в 10 000 строк может гений
    33. Альтаир (Altair777) 17.10.08 12:02
    (32) спорно, очень спорно... "Краткость - сестра таланта" :-)
    Как Вам такое, например?

    Код
    Если Инд=1 Тогда
       Инд=2;
    ИначеЕсли Инд=2 Тогда
       Инд=3;
    ИначеЕсли Инд=3 Тогда
       Инд=4;
    .....................
    .....................
    .....................
    ИначеЕсли Инд=998 Тогда
       Инд=999;
    ИначеЕсли Инд=999 Тогда
       Инд=1000;
    КонецЕсли;
    
    Показать полностью
    34. Евгений Мартыненков (JohnyDeath) 17.10.08 12:35
    (33) А строк-то 11 получилось ;) , так что это ближе к "каждому" ;)
    35. Владимир Потапов (keleg) 17.10.08 12:49
    (33)
    На самом деле код не так прост :-)
    Код
    Функция ИндексВерен(Индекс)
      Возврат (Индекс>=0) И (Индекс<=100) И ЦелоеЧисло(Индекс);
    КонецФункции
    {**************}
    Если ИндексВерен(Индекс) тогда
      Индекс = Индекс+1;
    КонецЕсли;
    
    Показать полностью


    А еще функцию ЦелоеЧисло() нужно описать, кажется, нет там встроенной нормально (не успеваю, убегать нужно)
    36. Альтаир (Altair777) 17.10.08 14:08
    (34) мне было лень писать остальные
    Код
    ИначеЕсли
    Показать полностью
    от 5 до 997
    Но если Вы настаиваете, я напишу обработочку, которая этот текст создаст и потом результат сюда помещу.
    1999 строка получицца, кажицца :-)
    37. Альтаир (Altair777) 17.10.08 14:09
    +36 съелось почему-то "остальные
    Код
    ИначеЕсли
    Показать полностью
    от 5 до 997"
    38. Альтаир (Altair777) 17.10.08 14:10
    +37 и снова :-)
    что-то глючат теги code /code

    мне было лень писать остальные ИначеЕсли от 5 до 997
    39. Аркадий Кучер (Abadonna) 17.10.08 14:11
    (36)>Но если Вы настаиваете, я напишу обработочку
    Обязательно напиши, только увеличь верхнюю границу до 100 тысяч :)))
    40. Евгений Мартыненков (JohnyDeath) 17.10.08 14:12
    (36) если напишешь, то ты уже перейдёшь в разряд "упорный" ;)
    41. Альтаир (Altair777) 17.10.08 14:15
    (39) и (40) запроста! :-)
    А мя за флуд не забанят?
    42. Альтаир (Altair777) 17.10.08 14:27
    +41 Поэтому на всякий случай помещаю только текст процедуры :-)
    Код
    Процедура Сформировать()
       Перем Инд, Тек;
       Тек=СоздатьОбъект("Текст");
       Тек.КодоваяСтраница(0);
       Тек.ДобавитьСтроку("Если Инд=1 Тогда");
       Тек.ДобавитьСтроку(СимволТабуляции+"Инд=2;");
       Для Инд=2 По 10000 Цикл
          Тек.ДобавитьСтроку("ИначеЕсли Инд="+Инд+" Тогда");
          Тек.ДобавитьСтроку(СимволТабуляции+"Инд="+(Инд+1)+";");
       КонецЦикла;
       Тек.ДобавитьСтроку("КонецЕсли;");
       Тек.Показать();
    КонецПроцедуры
    
    Показать полностью
    43. Альтаир (Altair777) 17.10.08 14:33
    (39) > Обязательно напиши, только увеличь верхнюю границу до 100 тысяч :)))
    Я только до 10 тысяч увеличил. Больше мне моя природная скромность не позволила :-)
    44. Владимир (Forego) 18.10.08 21:48
    Из уважения к академику Щербе, автору фразы : у него куздра буДланула бокра
    45. Александр Шишкин (Шёпот теней) 18.10.08 22:47
    (32) +

    в 10 строках кода существует хотя бы одна ошибка... Закон программирования...

    во-О-от...
    46. Евгений Кабанов (kabanoff) 20.10.08 17:12
    У меня с абстрагированием нормально, но материал (имхо) всё равно трудный. Не проще ли изложить на удобочитаемых предложениях типа "Клара у Карла украла кораллы, а Карл у Клары украл кларнет"? По-моему, так даже будет интересней.
    47. Аркадий Кучер (Abadonna) 20.10.08 17:20
    (46)>на удобочитаемых предложениях типа "Клара у Карла украла кораллы,
    Чтобы склонить Клару к оралу,
    Карл у Клары украл кораллы....
    :)))))))))
    48. Альтаир (Altair777) 20.10.08 19:54
    Вопрос. Это у меня глючит браузер или комментарии редактируются после.
    Я помню реплику Шёпот теней по поводу неодинаковых строк кода
    Кажется, это было в (45)
    А сейчас там осталось
    > (32) +
    >
    > в 10 строках кода существует хотя бы одна ошибка... Закон программирования...
    >
    > во-О-от...

    Я еще тогда хотел заметить, что в той процедуре, которую я смеха ради привел для примера (см. ее генератор в 42), нет ни одной одинаковой строки :-)
    49. Альтаир (Altair777) 20.10.08 20:01
    (47) кажется, это должно звучать так :-)

    Клара у Карла украла кораллы,
    Что бы Карла сконить к оралу,
    А Карл у Клары украл кларнет,
    Что бы Клару склонить на .....
    50. Евгений Кабанов (kabanoff) 21.10.08 10:37
    (47 и 49) Кажется вы форумом ошиблись. Сексуальные проблемы решают не здесь.
    51. Anonimka (anonimka) 21.10.08 12:02
    Прочла с удовольствием :)
    Спасибо, занятно.
    52. Альтаир (Altair777) 21.10.08 12:06
    (50)
    1) Какие проблемы? Какой секс?
    2) Это не наши проблемы, а Карла и Клары
    3) Это Abadonna первый начал... с Вашей подачи... :-)
    53. Альтаир (Altair777) 21.10.08 12:12
    (51) Вы про поэзию? Я смущен :-)
    54. Евгений Кабанов (kabanoff) 21.10.08 13:18
    (52) Каждый думает в меру своей распущенности.
    55. Альтаир (Altair777) 21.10.08 14:06
    (54) И какая же она у меня с Абадонной?
    Вас, кстати, не смущают слова КонецЕсли, КонецПроцедуры, КонецФункции?
    Уж как-то Вы нетерпимы... чересчур.
    Или просто Вам нужно было вставить свое "веское" слово? Так вставьте по сабжу.
    А слово "вставить" не смущает? :-)
    56. Евгений Кабанов (kabanoff) 21.10.08 16:07
    to 55
    > И какая же она у меня с Абадонной?
    Вы вообще что хотели узнать?

    > Вас, кстати, не смущают слова КонецЕсли, КонецПроцедуры, КонецФункции?
    > Уж как-то Вы нетерпимы... чересчур.
    Меня смущают Ваши комментарии по поводу моего сообщения 46.

    > Или просто Вам нужно было вставить свое "веское" слово? Так вставьте по сабжу.
    А сообщения 47 и 49 по сабжу?
    57. Альтаир (Altair777) 21.10.08 16:28
    to 55

    > Вы вообще что хотели узнать?
    Догадайтесь с 3 раз :-)
    ----------------------------------------
    55. Altair777 21.10.2008
    (54) И какая же она у меня с Абадонной?
    ----------------------------------------
    54. kabanoff 21.10.2008
    (52) Каждый думает в меру своей распущенности.
    ----------------------------------------
    Вы о моей распущенности судите по невинному стишку? :-)

    > Меня смущают Ваши комментарии по поводу моего сообщения 46.
    Я не комментировал это сообщение

    > А сообщения 47 и 49 по сабжу?
    Нет. Но это была глубокая ночь... Увидел в прямом эфире сообщение Абадонны и не смог удержаться, что бы немного не улучшить его :-)
    58. Альтаир (Altair777) 21.10.08 16:29
    59. Альтаир (Altair777) 21.10.08 16:49
    (56) > Меня смущают Ваши комментарии по поводу моего сообщения 46.
    Вот сейчас прокомментирую :-)

    > 46. kabanoff 20.10.2008
    > У меня с абстрагированием нормально, но материал (имхо) всё равно трудный. Не проще ли изложить на удобочитаемых предложениях типа "Клара у Карла украла кораллы, а Карл у Клары украл кларнет"? По-моему, так даже будет интересней.

    Дело в том, что в этой фразе совсем нету абстрагирования, только голые ;-) факты.
    И объяснять смысл, заключенный в этом блоге, там бессмысленно. (сорри за тавтологию)
    Мы пытались с Абадонной абстрагировать, развить действие.. И результат?
    А Вы сами же нас стали посылать... на секс-форумы :-)
    60. Евгений Кабанов (kabanoff) 21.10.08 17:13
    (59) При чем здесь факты? Ну и что? Я от программирования на конкретном языке абстрагируюсь, а Вы от чего?
    Следующие сообщения не вижу смысла комментировать, ибо спорить не о чем.
    61. Олег Пономаренко (O-Planet) 21.10.08 17:17
    (44) >> Из уважения к академику Щербе, автору фразы : у него куздра буДланула бокра

    Он понял неправильно. Там было все по-другому 8)
    62. Альтаир (Altair777) 21.10.08 17:26
    (60) А в данной статье абстрагируются как раз от фактов .
    Никто не знает, кто такие "куздра" и "бокра". Да это и не суть важно.
    Важны их свойства и методы.

    Интересно, а как можно абстрагироваться от языка программирования?
    В маш.кодах свой стиль и свои приемы, в Делфях - другие...
    И это во многих отраслях человеческой дейятельности. Не факт что из хорошего скрипача, виртуозно владеющего смычком, получится хотя бы посредственный скульптор.
    63. Василий (ded00786) 29.10.08 11:06
    Вот это бредятина :)
    Однозначно +
    64. vkr (vkr) 30.10.08 11:55
    Прошу прощения за маленькое уточнение, но - куздра "буДЛанула" бокрёнка... :)
    65. vkr (vkr) 30.10.08 11:56
    Еще раз прошу прощения - опечатался - куздра "буДЛанула" бокра...
    66. Сергей Троицкий (tsd) 02.11.08 16:52
    67. Rusk (Rusk51) 21.01.11 19:02
    Иванова Маша ударила кружку и дубасила кружечку. Ну ка примени теперь свои знания. По отношению к бокру .Смысловое.
    Заранее прошу прощения - дочке объясняю основы логики программирования. Это её пример.
    68. Ийон Тихий (cool.vlad4) 21.01.11 21:05
    Еще примерчик из кибериады :D
    Лопотуй голомозый, да бундет грывчато
    В кочь турмельной бычахе, что коздрой уснит,
    Окошел бы назакрочь, высвиря глазята,
    А порсаки корсливые вычат намрыд!


    Три, самолож выверстный, вертяшку сум воздлинем,
    Секливой апелайде и боровайка кнется,
    Гренит малополешный тем перезлавским тринем,
    И отмурчится бамба, и голою вернется.


    Грызнотвурога жуждя, голенистый лолень
    Самошпака миманку...
    Для написания сообщения необходимо авторизоваться
    Прикрепить файл
    Дополнительные параметры ответа