gifts2017

Поиск и замена ссылок для 1с 8.2

Опубликовал Олег Кравчук (kravchuk) в раздел Администрирование - Сервисные утилиты

Аналог старой доброй обработки под 1С 81 в реализации под 1С 82. Управляемая форма.

Аналог старой доброй обработки под 1С 81 в реализации под 1С 82.

В плане функционала обработка ничем не отличается от аналогичной под 81, особенности только в реализации.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ПоискИЗаменаЗначений.epf
.epf 13,32Kb
11.10.16
1486
.epf 13,32Kb 1486 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. batys (batys) 30.12.09 13:50
Беру, спасибо +
Еще бы групповую обработку как в 8.1 или такая уже есть?
2. Дмитрий Агафонов (waltar) 01.01.10 18:35
А конвертировать стандартную обработку в 1Сv8.2 не судьба?
3. dushelov (Душелов) 01.01.10 20:22
(2) Понятие "управляемые формы" Вам о чем-то говорит?
4. Max Golovchenko (lizaniashvily) 02.01.10 10:01
Спосибо.

_________________
Stungun электрошокер в Москве.
5. NtS (NtS) 29.03.10 21:11
в УНФ делаю замену одной валюты на другую, ошибка:
{Форма.Форма.Форма(177)}: Ошибка при вызове метода контекста (Найти): Неверное имя колонки
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
по причине:
Неверное имя колонки
6. Паланик (Паланик) 07.10.10 14:03
Я щас поглядел, нашел причину, там имя колонки в ТЗ "ВалютаДт", а он ищет по "Валюта", почему так - рыть не стал, тупо поставил счетчик, на какой итерации нестыковка и воткнул условие, где добавляю "Дт" к имени колонки. (извратился, зато за 5 сек)
7. Надежда Елисеева (Hoppius) 18.01.11 13:30
Извините, но у меня эта обработка в режиме "1С:Предприятие" не открывается совсем%) и никаких ошибок не выдает..
Solo1; Chifa; +2 Ответить
8. Константин Гейнрих (CyberCerber) 18.03.11 15:17
Спасибо за обработку! Только она не заменяет сотрудников как исполнителей задач. Надо еще пробегаться по реквизитам адресации:

                  Если Метаданные.Задачи.Содержит(СтрокаТаблицы.Метаданные) Тогда
				Для Каждого Реквизит Из СтрокаТаблицы.Метаданные.РеквизитыАдресации Цикл
					Если Реквизит.Тип.СодержитТип(ТипЗнч(Ссылка)) И Параметры.Объект[Реквизит.Имя] = Ссылка Тогда
						Параметры.Объект[Реквизит.Имя] = ПравильныйЭлемент;
					КонецЕсли;
				КонецЦикла;
			КонецЕсли;
...Показать Скрыть
9. serguey (diaz) 05.09.11 10:34
Не открывается и никаких ошибок не выдает..
10. Иван (habum) 22.09.11 17:07
Спасибо за обработку. Часто пользуюсь, выручает конкретно.
11. Денис Храмцов (DioSka) 22.09.11 18:52
Спасибо, очень пригодилось!
12. Олег Кравчук (kravchuk) 23.09.11 07:50
13. Олег Кравчук (kravchuk) 23.09.11 07:53
(9) diaz, Видимо вы пытаетесь открыть обработку в режиме обычного приложения, а так как обработка не содержит обычных форм она и не открывается. Попробуйте ее открыть в режиме управляемого приложения.
14. Михаил Лашко (mlashko) 10.01.12 12:59
Гораздо удобнее стандартного средства.
15. finch (fin7) 15.01.12 10:32
Спасибо за обработку. Пользовалась не раз. Ошибок не выдает
16. Иван Сидоров (itit) 20.01.12 15:04
17. Иван Сидоров (itit) 20.01.12 15:49
в зиуп даже неоткрывается
18. Гость 20.02.12 10:28
Спасибо за обработку, пригодилась
19. Павел Ладейщиков (flack) 21.02.12 17:44
Хорошая обработка. Спасибо!
itit, в ЗУПе и не откроется, т.к. она для Управляемого приложения.
А для ЗУПа подойдет и стандартная с диска ИТС.
21. Илья Фамилия (Murom) 20.03.12 12:16
Очень помогла обработка в УТ 11.
Какие-то умники вели сначала учет на 2ух складах, потом решили вести на 1ом. Столько ошибок понаделали...
Обработкой за 1 мин все подправил.
PS: Вот почему 1с не сделала все универсальные обработки под управляемые формы...
22. Татьяна Черных (tanya_charm) 21.03.12 11:32
спасибо за обработку, помогла в переносе для бгу
23. Сергей Старых (tormozit) 26.11.12 11:27
В инструментах разработчика есть мощный инструмент для решения тех же задач "Поиск дублей и замена ссылок".
24. Илья Ванчугов (Vanchez) 18.07.13 13:31
Лично у меня не открывается в БП 3.0, но открывается в УТ 11. Платформа 8.2.16.368
25. Открытые бизнес-решения Общество с ограниченной ответственностью (Open-BS) 19.07.13 14:58
А как посмотреть ссылки на номенклатуру? В УТ 11 что эта обработка, что стандартная, не дает выбрать справочник "номекнлатура"
27. Solo * (Solo1) 16.10.15 15:18
Не открывается и ошибок не выдает!!!
28. Олег Кравчук (kravchuk) 28.10.15 13:57
(25) Open-BS,
У справочника номенклатуры может быть представление "Позиция номенклатуры".
29. Олег Кравчук (kravchuk) 28.10.15 13:58
(27) Solo1,

Скорей всего вы пытаетесь открыть ее в режиме обычного приложения.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа