[8.2] Универсальная обработка "Регистрация изменений для обмена" (управляемые формы)

Опубликовал Василий Демидов (Душелов) в раздел Обмен - Перенос данных из 1C8 в 1C8

Универсальная обработка "Регистрация изменений для обмена".
Сделана на управляемых формах, работает на всех клиентах.
В толстом клиенте доступен конструктор запроса при произвольной регистрации.

Обработка предназначена для разработчиков обмена данными в произвольных конфигурациях.

Позволяет:

1. Просматривать список метаданных участвующих в обмене

2. Просматривать список объектов для которых зарегистрированы изменения. Для этого достаточно установить флажок "Загружать изменения" и нажать на кнопку "Зарегистрированные изменения"

3. Добавлять и снимать регистрацию для объектов, а так же использовать запросы для выбора данных (в толстом клиенте можно использовать конструктор запросов)

Скачать файлы

Наименование Файл Версия Размер
Обработка
.zip 19,66Kb
29.01.10
1119
.zip 19,66Kb 1119 Бесплатно

См. также

Комментарии
1. dushelov (Душелов) 29.01.10 12:09 Сейчас в теме
В очередной раз понадобилось, а от 1С пока ничего такого нет.
Сделал свой аналог, который был для 8.1
2. Сергей Кучеров (СергейКа) 610 29.01.10 12:24 Сейчас в теме
Пока не качаю, но на заметку беру
3. Reaper_1c Reaper_1c (Reaper_1C) 94 29.01.10 15:26 Сейчас в теме
(1) Зачем людей обманывать? В релизе конвертации 2.1.2.1 все уже давно есть.
4. dushelov (Душелов) 29.01.10 18:18 Сейчас в теме
(3) Точно? Уверены? Под 8.2 на управляемых формах?
Вы, случаем, сами никого не обманываете?
5. Илья Ануфриев (aipnnov) 159 04.02.10 09:01 Сейчас в теме
Надо добавить и удаление регистрации, как в 8.1.
6. dushelov (Душелов) 04.02.10 22:19 Сейчас в теме
7. Илья Ануфриев (aipnnov) 159 08.02.10 08:50 Сейчас в теме
(6) Посмотри обработку "ОбработкаРегистрацияИзменненийДляОбмена" типовой конфы УТ, там все есть.
8. dushelov (Душелов) 08.02.10 09:18 Сейчас в теме
(7) Я смотрел. Что именно "Надо добавить и удаление регистрации, как в 8.1." ?
По-моему одной произвольной регистрации запросом предостаточно.
9. Илья Ануфриев (aipnnov) 159 08.02.10 09:31 Сейчас в теме
(8) У тебя есть удаление всей регистрации, но может надо добавить удаление отдельного элемента регистрации, который не нужен для обмена?
Я это имел в виду.
10. dushelov (Душелов) 08.02.10 09:56 Сейчас в теме
(9) А, понятно. Сделаю произвольное снятие регистрации :)
11. Надежда Харитонова (сингер) 18.02.10 14:04 Сейчас в теме
Здравствуйте. Извените, я не профи, но довольно с большим опытом самоучки... Обычно у меня не было проблем с выгрузкой/загрузкой данных в 1Сv8.1, но вот, перешла на 8.2 Версия 8.2.10.77 конф. Упр. небольшой фирмой и немогу вообще разобраться.Мне неоходимо выгрузить справочники из УТ (есть на платф. 8.1, и есть уже сконвертированная под 8.2) - неполучается, пишет ошибку: при загрузке номенклатуры - пишет не найден родитель наименования...
12. dushelov (Душелов) 18.02.10 14:15 Сейчас в теме
(11) Этот вопрос лучше задать на форуме. Так быстрее получится.
13. Паша Паша (maz2000) 06.05.10 10:56 Сейчас в теме
чёт не открывается обработка. Со всеми управляемыми формами:)
14. Сергей Сергей (volens-nolens) 24.08.11 23:18 Сейчас в теме
Reaper_1C пишет:

(1) Зачем людей обманывать? В релизе конвертации 2.1.2.1 все уже давно есть.


Для управляемых форм одинес до сих пор ничего не написал.
15. Сергей Сергей (volens-nolens) 24.08.11 23:19 Сейчас в теме
если пытаться зарегистрировать сразу все "Справочники" или "Документы" и т.д. - вылетает ошибка.
16. Иван Котов (ikot) 08.09.11 12:13 Сейчас в теме
У меня работает на все 100. Спасибо!
17. Сергей Ожерельев (Поручик) 3493 04.10.11 08:16 Сейчас в теме
В модуле формы после строки

Процедура ПоказатьОбъекты(ИндексСтроки = Неопределено, Уровень = 0)


добавить

	Если Не ЗначениеЗаполнено(УзелОбмена) Тогда
		Возврат;
	КонецЕсли; 


Иначе при выборе вида плана обмена выдаётся ошибка
{Форма.Форма.Форма(75)}: Ошибка при вызове метода контекста (ВыбратьИзменения)
ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(УзелОбмена, УзелОбмена.НомерОтправленного + 1);
по причине:
Недопустимое значение параметра (параметр номер '1')
18. Алексей Потехин (trumanl) 11 14.11.11 10:48 Сейчас в теме
Спасибо за обработку! Работает только довольно долго..
19. Алексей Потехин (trumanl) 11 14.11.11 17:06 Сейчас в теме
Выявил еще один несущественный баг. Если выбрать какой-либо из типов объектов и нажать "Показать объекты", то после повторного нажатия список ниже возникающих объектов, зарегистрированных к обмену, задвоится.

В модуле формы строки кода
	Если ИндексСтроки = Неопределено ИЛИ Уровень = 0 Тогда
		ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(УзелОбмена, УзелОбмена.НомерОтправленного + 1);
	Иначе
		ТекСтрока = ДанныеОбмена.НайтиПоИдентификатору(ИндексСтроки);
		Фильтр = Новый Массив;
		Если Уровень = 2 Тогда
			МетаданныеОбъекта = Метаданные.НайтиПоПолномуИмени(ТекСтрока.Название + "." + ТекСтрока.Объект);
			Фильтр.Добавить(МетаданныеОбъекта);
		ИначеЕсли Уровень = 1 Тогда
			Для Каждого Стр Из ТекСтрока.ПолучитьЭлементы() Цикл
				МетаданныеОбъекта = Метаданные.НайтиПоПолномуИмени(Стр.Название + "." + Стр.Объект);
				Фильтр.Добавить(МетаданныеОбъекта);
			КонецЦикла;
		КонецЕсли;
		ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(УзелОбмена, УзелОбмена.НомерОтправленного + 1, Фильтр);
	КонецЕсли;
...Показать Скрыть

заменить на
	Если ИндексСтроки = Неопределено ИЛИ Уровень = 0 Тогда
		ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(УзелОбмена, УзелОбмена.НомерОтправленного + 1);
		// очистка
		Для Каждого СтрКонф Из ДанныеОбмена.ПолучитьЭлементы() Цикл
			Для Каждого СтрТип Из СтрКонф.ПолучитьЭлементы() Цикл
				Для Каждого Стр Из СтрТип.ПолучитьЭлементы() Цикл
					Стр.ПолучитьЭлементы().Очистить();
				КонецЦикла;
			КонецЦикла;
		КонецЦикла;
	Иначе
		ТекСтрока = ДанныеОбмена.НайтиПоИдентификатору(ИндексСтроки);
		Фильтр = Новый Массив;
		Если Уровень = 2 Тогда
			МетаданныеОбъекта = Метаданные.НайтиПоПолномуИмени(ТекСтрока.Название + "." + ТекСтрока.Объект);
			Фильтр.Добавить(МетаданныеОбъекта);
			// очистка
			ТекСтрока.ПолучитьЭлементы().Очистить();
		ИначеЕсли Уровень = 1 Тогда
			Для Каждого Стр Из ТекСтрока.ПолучитьЭлементы() Цикл
				МетаданныеОбъекта = Метаданные.НайтиПоПолномуИмени(Стр.Название + "." + Стр.Объект);
				Фильтр.Добавить(МетаданныеОбъекта);
				// очистка
				Стр.ПолучитьЭлементы().Очистить();
			КонецЦикла;
		КонецЕсли;
		ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(УзелОбмена, УзелОбмена.НомерОтправленного + 1, Фильтр);
	КонецЕсли;
...Показать Скрыть
20. Андрей - (Motor24) 13.12.11 13:00 Сейчас в теме
21. Алексей Масалыгин (CnupT) 19 15.12.11 09:05 Сейчас в теме
trumanl пишет:
Выявил еще один несущественный баг.


Поручик пишет:
В модуле формы после строки ....


Скажите, внесены ли исправления, указанные коллегами Поручиком и trumanl? Можно ли рекомендовать
данную обработку конечным пользователям без допиливания?
22. БИЗНЕС РЕШЕНИЯ (Para_1987) 71 13.01.12 08:56 Сейчас в теме
Номальная обработка, помогла)
23. Надежда (Izolda) 22.01.12 22:08 Сейчас в теме
Классная обработка. Только не работает для снятия с плана обмена конкретного объекта конфигурации.
24. Галина Галина (a4a) 31.01.12 15:03 Сейчас в теме
С надеждой, что эта обработка выручит в тяжелой борьбе с настройкой обмена из Ут11 БП2.0
26. Bob Bob (bobmaxm) 13.02.12 16:47 Сейчас в теме
Очень удобно настраивать обмен. Без нее никак не взлетал. Спасибо!!!
27. Олег Иванов (ogeniv) 20.02.12 17:54 Сейчас в теме
Обработке уж два года, а от 1с до сих пор нет внятного аналога. Спасибо большое
28. Сергей Ожерельев (Поручик) 3493 17.03.12 22:31 Сейчас в теме
Сообщество не будет возражать, если выложу модифицированный вариант отдельной публикацией? Кроме исправления указанных багов, добавил изменение номеров сообщений.
29. Сергей Ожерельев (Поручик) 3493 17.03.12 22:36 Сейчас в теме
+ Добавлена возможность для регистрации обработки в справочнике "Дополнительные обработки" для конфигураций на БСП.
30. Александр Лобачёв (SANILLA) 22.04.13 12:30 Сейчас в теме
(28) Поручик, конечно выкладывай, посмотрим :)
31. Александр Лобачёв (SANILLA) 22.04.13 12:32 Сейчас в теме
(19) trumanl, да действительно очень долго выполняет ...
щас исправлю этот баг
32. Сергей Ожерельев (Поручик) 3493 22.04.13 12:49 Сейчас в теме
(30) Уже год как выложено и развилось в самостоятельную работу с добавленными фичами. Луркайте поиск
33. Сергей Ожерельев (Поручик) 3493 22.04.13 12:53 Сейчас в теме
(30) Если разуть глаза, то ссылка есть прямо в описании.
34. Александр Лобачёв (SANILLA) 22.04.13 12:53 Сейчас в теме
(32) Поручик, понял, спасибо большое, щас найду.
35. Александр Лобачёв (SANILLA) 22.04.13 12:56 Сейчас в теме
(33) Поручик, да вижу, благодарю.
37. Дмитрий Переверзев (webdimon) 18.02.14 13:10 Сейчас в теме
38. Катя Иванова (Katarina_Proza) 23.06.14 09:55 Сейчас в теме
39. Андрей Ро (AndrewVVS) 22.01.15 14:58 Сейчас в теме
При переходе на платформу 8.3.5 столкнулся с тем, что перестали выгружаться базы через выгрузку в .dt. Нашел на форумах, что дело может быть в планах обмена, если они есть,то их нужно почистить (удалить) регистрацию + предлагаются самописные обработки :). Я так понимаю, что для удаления регистрации подойдет типовая обработка "ОбработкаРегистрацияИзменненийДляОбмена" конфигураций на обычных формах УТ 10.3, ЗУП 2.5, БП 2.0. Пишу здесь, возможно кому информация пригодится...