gifts2017

Нормализация наименований контрагентов

Опубликовал Андрей Андреевич (nalivai-chai) в раздел Обработки - Обработка справочников

Приводит к стандарту наименования контрагентов:
1) Символы в верхний регистр;
2) Поиск аббревиатур и подстановка (аббревиатуры ФОРМ ОРГАНИЗАЦИЙ, ТИПОВ ПОМЕЩЕНИЙ и проч.)
3) Выделение наименования организации по КАВЫЧКАМ, все что внутри кавычек считается наименование организации
4) Устанавливает порядок: "НАИМЕНОВАНИЕ ОРГАНИЗАЦИИ" "АББРЕВИАТУРА ФОРМЫ ОРГАНИЗАЦИИ" "АББРЕВИАТУРА ТИПА ПОМЕЩЕНИЯ" ПРОЧ. (можно изменять порядок)
5) Прочие действия (удаление кавычек, удаление двойных пробелов, запятых, расстановка пробелов после запятых... и т.п.
6) Печать исправлений.

(Обновление: увеличена скорость обработки, тонкие возможности настройки нормализации, отбор)

Перед исправлением наименований контрагентов, есть возможность

     - выбрать контрагентов для исправления;

     - отредактировать изменяемое наименование в ручную;

и только после принять исправления.

Если все символы наименования контрагента в верхнем регистре, то у контрагента не устанавливается пометка на исправление, даже если его наименование не соответствует полученному стандарту.

Возможен отбор контрагентов.

Контрагенты со стандартизированным наименованием не отбираются повторно.

Печать исправлений.

Скачать файлы

Наименование Файл Версия Размер
НормализацияНаименованийКонтрагентов 302
.epf 49,99Kb
30.08.14
302
.epf 49,99Kb Бесплатно

См. также

Contragent+ 5.0 от 2 500
Вознаграждение за ответ
Сумма: 0 $m
Добавили:
Sergy Sergy (Sergyhmao) (0.73 $m)
Подписаться Добавить вознаграждение
Комментарии
1. Сергей Ожерельев (Поручик) 06.04.10 21:04
Пример обработки - затраченного времени из-за тупости персонала, которым кол на голове теши, всё равно будут валить в справочник всякую шнягу.
Посмотришь на некоторых "манагеров" - и остаётся только плюнуть, ну что с дебилов взять.
cool.vlad4; +1 Ответить
2. nalivai (nalivai-chai) 07.04.10 09:18
))))) ну, это норма, от манагеров требовать вводить нормально контрагентов, это как от детей 1 класса требовать дифференциальные уравнения решать.
3. Александр Рытов (Арчибальд) 07.04.10 10:10
Процедура ПриЗаписи()
//......
Если Найти("ОАО_ООО_ЗАО", Врег(Лев(СокрЛ(Наименование),3))) > 0 Тогда
   СтатусВозврата(0);
   Форма.Закрыть();
   Возврат;
КонецЕсли;
//.........
КонецПроцедуры
...Показать Скрыть

8-)
4. Андрей Д. (detec) 16.03.11 10:04
По-хорошему контрагентов должна заводить бухгалтерия по факту предоставления бумажного договора. Это действительно не обязанность манагеров. Более того, это нужно запрещать. Иначе создадут левого контрагента, оформят на него отгрузку с отсрочкой и потом ищи этого контрагента.
nalivai-chai; +1 Ответить
5. ArCtic (ArCtic) 13.09.11 05:39
все офигенно, только для 8.1 эта обработка не подходит:(
7. Елена (shadowslight) 21.12.11 16:58
Мне единственное не очень прельщает в этой обработке верхний регистр.
8. Марина Мандракова (garant21) 19.03.12 22:55
Спасибо, хорошая обработка. Плюс
9. Александр Забалуев (zabaluev) 20.07.12 23:27
Обработка не знает букву "Ё", например, Общество с ограниченной ответственностью "ЁРТ" переделала в "РТ ООО".
Ведь есть такая буква в алфавите!
RodinMax; Зеленоград; +2 Ответить
10. Брест Беларусь (zhleonid8) 30.08.12 00:06
скажу так, она заслуживает внимания
11. AOchkasov (aochkasov) 24.01.13 12:11
Обработка очень полезная. Привел с ее помощью справочник в нормальный вид. Однозначно плюс. Единственное что бы порекомендовал, сделать след. т.к. если не может записать обработка останавливается.
Процедура ПринятьИсправления() Экспорт

Для Каждого СтрокаТЧ Из Контрагенты Цикл

Если СтрокаТЧ.Исправить Тогда

ОбъектКонтрагента = СтрокаТЧ.Контрагент.ПолучитьОбъект();
Если Не ОбъектКонтрагента.ЭтоГруппа Тогда
Если ПустаяСтрока(ОбъектКонтрагента.НаименованиеПолное) Тогда
ОбъектКонтрагента.НаименованиеПолное = ОбъектКонтрагента.Наименование;
КонецЕсли;
КонецЕсли;

ОбъектКонтрагента.Наименование = СтрокаТЧ.ИсправленноеНаименование;
Попытка
ОбъектКонтрагента.Записать();
Исключение
Сообщить("Не удалось записать Контрагента: "+ОбъектКонтрагента ,СтатусСообщения.Важное);
Продолжить;
КонецПопытки;

КонецЕсли;

КонецЦикла;

КонецПроцедуры


и убрать верхний регистр, но это уже по своему усмотрению
Функция НормализацияНаименованияКонтрагента(Знач Наименование) Экспорт

Перем ПозПервКав;
Перем ПозПослКав;

// Проверяем таблицы активных аббревиатур
Если мТипыОрганизацийАкт = Неопределено
Или мАббрПрочиеАкт = Неопределено
Или мАббрТипыПомещенийАкт = Неопределено
Или мАббрФормыОрганизацийАкт = Неопределено Тогда

ЗаполнитьТаблицыАктивныхАббревиатур();

КонецЕсли;


// Все символы в верхний регистр.
//Наименование = ВРег(Наименование);
12. Sergy Sergy (Sergyhmao) 18.07.14 11:59