gifts2017

Универсальная история изменения документов и справочников

Опубликовал Сергей Золотухин (RTFM) в раздел Программирование - Практика программирования

Универсальная история изменения документов и справочников, позволяет сохранять изменения только тех реквизитов документов, справочников, а также их табличных частей, которые действительно изменились. Те реквизиты которые не изменились не попадают в историю. Это позволяет отслеживать кто, когда и что именно изменил в документе или справочнике.

Универсальная история изменения документов и справочников, позволяет сохранять изменения только тех реквизитов документов, справочников, а также их табличных частей, которые действительно изменились. Те реквизиты которые не изменились не попадают в историю. Это позволяет отслеживать кто, когда и что именно изменил в документе или справочнике. Не имеет ссылок на объекты метаданных, что позволяет удалять объекты метаданных, помеченных на удаление, через обработку удаление помеченных на удаление, без проверки на ссылание этого объекта в этом справочнике.

Чтобы эту историю внедрить в Вашу конфигурацию, необходимо:

  1. Создать Справочник ИзмененияДокументов со следующими параметрами:
  2. Длина наименования 150, Длина кода 20, Тип Кода Строка.
    Реквизиты Справочника:
               Пользователь - Тип:СправочникСсылка.Пользователи
               GUID_Объекта - Тип:Строка, Длина: 36
               ДатаИзменения - Дата, Состав даты: Дата и время
          Табличная часть "Изменения" справочника, содержит Реквизиты:
               Реквизит - Тип:Строка, Длина:200
               ЗначениеДо - Тип: Строка, неограниченная
               ЗначениеПосле - Тип: Строка, неограниченная

  3. Создать ФормуСписка и ФормуЭлемента Справочника, в форме элемента сделать её только для просмотра.

  4. В общем модуле, который выполняется на клиенте, либо создав новый, разместить экспортируемую процедуру:

	 Процедура ЗаписатьИзмененияДокументаВСправочникИзмененияДокументов(Объект) ЭКСПОРТ

    Если Объект.ЭтоНовый() Тогда
        ID = Новый УникальныйИдентификатор;
        Если Сред(Объект.Метаданные().ПолноеИмя(), 1, Найти(Объект.Метаданные().ПолноеИмя(), ".")-1) = "Документ" Тогда
            Объект.УстановитьСсылкуНового(Документы[Объект.Метаданные().Имя].ПолучитьСсылку(ID));
        ИначеЕсли Сред(Объект.Метаданные().ПолноеИмя(), 1, Найти(Объект.Метаданные().ПолноеИмя(), ".")-1) = "Справочник" Тогда
            Объект.УстановитьСсылкуНового(Справочники[Объект.Метаданные().Имя].ПолучитьСсылку(ID));
        КонецЕсли;
    КонецЕсли;

    Изменения = Истина;
    ДатаИзм = ТекущаяДата();

    //Изменения реквизитов
    ЗапросПроверкаРеквизитов = Новый Запрос;
    ЗапросПроверкаРеквизитов.Текст = "ВЫБРАТЬ
                                     |  *
                                     |ИЗ
                                     |  " + Сред(Объект.Метаданные().ПолноеИмя(), 1, Найти(Объект.Метаданные().ПолноеИмя(), ".")) + Объект.Метаданные().Имя + " КАК ОбъектМетаданных
                                     |ГДЕ
                                     |  ОбъектМетаданных.Ссылка = &Ссылка";

    ЗапросПроверкаРеквизитов.УстановитьПараметр("Ссылка", Объект.Ссылка);
    ВыборкаПроверкаРеквизитов = ЗапросПроверкаРеквизитов.Выполнить().Выбрать();
    Если ВыборкаПроверкаРеквизитов.Следующий() Тогда
        Для Каждого Рек Из Объект.Метаданные().Реквизиты Цикл
            Если Объект[Рек.Имя] <> ВыборкаПроверкаРеквизитов[Рек.Имя] Тогда
                Если Изменения Тогда
                    НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                    НовЭлемент.Наименование = Строка(Объект.Ссылка);
                    НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                    НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                    НовЭлемент.ДатаИзменения = ДатаИзм;
                    Изменения = Ложь;
                КонецЕсли;
                НовСтр = НовЭлемент.Изменения.Добавить();
                НовСтр.Реквизит = Рек.Имя;
                НовСтр.ЗначениеДо = Строка(ВыборкаПроверкаРеквизитов[Рек.Имя]);
                НовСтр.ЗначениеПосле = Строка(Объект[Рек.Имя]);
                Если НовЭлемент.Изменения.Количество() = 99999 Тогда
                    НовЭлемент.Записать();
                    Изменения = Истина;
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;
        Если ВыборкаПроверкаРеквизитов.ПометкаУдаления <> Объект.ПометкаУдаления Тогда
            Если Изменения Тогда
                НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                НовЭлемент.Наименование = Строка(Объект.Ссылка);
                НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                НовЭлемент.ДатаИзменения = ДатаИзм;
                Изменения = Ложь;
            КонецЕсли;
            НовСтр = НовЭлемент.Изменения.Добавить();
            НовСтр.Реквизит = "ПометкаУдаления";
            НовСтр.ЗначениеДо = Строка(ВыборкаПроверкаРеквизитов.ПометкаУдаления);
            НовСтр.ЗначениеПосле = Строка(Объект.ПометкаУдаления);
        КонецЕсли;
    Иначе
        Для Каждого Рек Из Объект.Метаданные().Реквизиты Цикл
            Если Изменения Тогда
                НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                НовЭлемент.Наименование = Строка(Объект.Ссылка);
                НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                НовЭлемент.ДатаИзменения = ДатаИзм;
                Изменения = Ложь;
            КонецЕсли;
            НовСтр = НовЭлемент.Изменения.Добавить();
            НовСтр.Реквизит = Рек.Имя;
            НовСтр.ЗначениеДо = "";
            НовСтр.ЗначениеПосле = Строка(Объект[Рек.Имя]);
            Если НовЭлемент.Изменения.Количество() = 99999 Тогда
                НовЭлемент.Записать();
                Изменения = Истина;
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;

    //Проверка на изменение табличных частей документа
    Для Каждого ТЧ из Объект.Метаданные().ТабличныеЧасти Цикл

        ЗапросПроверкаТЧ = Новый Запрос;

        ЗапросПроверкаТЧ.Текст = "ВЫБРАТЬ
                                     |  *
                                     |ИЗ
                                     |  " + Сред(Объект.Метаданные().ПолноеИмя(), 1, Найти(Объект.Метаданные().ПолноеИмя(), ".")) + Объект.Метаданные().Имя + "." + ТЧ.Имя + " КАК ОбъектМетаданных
                                     |ГДЕ
                                     |  ОбъектМетаданных.Ссылка = &Ссылка
                                     |УПОРЯДОЧИТЬ ПО
                                     |  НомерСтроки";

        ЗапросПроверкаТЧ.УстановитьПараметр("Ссылка", Объект.Ссылка);
        ВыборкаПроверкаТЧ = ЗапросПроверкаТЧ.Выполнить().Выбрать();
        Для Каждого СтрТЧ Из Объект[ТЧ.Имя] Цикл
            Если ВыборкаПроверкаТЧ.Следующий() Тогда
                Для Каждого Рек Из Объект.Метаданные().ТабличныеЧасти[ТЧ.Имя].Реквизиты Цикл
                    Если СтрТЧ[Рек.Имя] <> ВыборкаПроверкаТЧ[Рек.Имя] Тогда
                        Если Изменения Тогда
                            НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                            НовЭлемент.Наименование = Строка(Объект.Ссылка);
                            НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                            НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                            НовЭлемент.ДатаИзменения = ДатаИзм;
                            Изменения = Ложь;
                        КонецЕсли;
                        НовСтр = НовЭлемент.Изменения.Добавить();
                        НовСтр.Реквизит = ТЧ.Имя + ":" + Строка(СтрТЧ.НомерСтроки) + " - " + Рек.Имя;
                        НовСтр.ЗначениеДо = Строка(ВыборкаПроверкаТЧ[Рек.Имя]);
                        НовСтр.ЗначениеПосле = Строка(СтрТЧ[Рек.Имя]);
                        Если НовЭлемент.Изменения.Количество() = 99999 Тогда
                            НовЭлемент.Записать();
                            Изменения = Истина;
                        КонецЕсли;
                    КонецЕсли;
                КонецЦикла;
            Иначе
                Для Каждого Рек Из Объект.Метаданные().ТабличныеЧасти[ТЧ.Имя].Реквизиты Цикл
                    Если Изменения Тогда
                        НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                        НовЭлемент.Наименование = Строка(Объект.Ссылка);
                        НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                        НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                        НовЭлемент.ДатаИзменения = ДатаИзм;
                        Изменения = Ложь;
                    КонецЕсли;
                    НовСтр = НовЭлемент.Изменения.Добавить();
                    НовСтр.Реквизит = ТЧ.Имя + ":" + Строка(СтрТЧ.НомерСтроки) + " - " + Рек.Имя;
                    НовСтр.ЗначениеДо = "";
                    НовСтр.ЗначениеПосле = Строка(СтрТЧ[Рек.Имя]);
                    Если НовЭлемент.Изменения.Количество() = 99999 Тогда
                        НовЭлемент.Записать();
                        Изменения = Истина;
                    КонецЕсли;
                КонецЦикла;
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;

    Если Не Изменения Тогда
        НовЭлемент.Записать();
    КонецЕсли;

КонецПроцедуры

И в нужном документе/справочнике в модуле объекта вконце процедуры ПередЗаписью() размещаем следующее:

	 #Если Клиент Тогда
Если Не Отказ Тогда
    НашиДороботки.ЗаписатьИзмененияДокументаВСправочникИзмененияДокументов(ЭтотОбъект);
КонецЕсли;
#КонецЕсли

4. На форме документа/Элемента объекта метаданных документа/справочника, для которого необходимо отслеживать историю изменений, можно разместить кнопку "История изменений", которая будет отбирать из справочника только те элементы которые по данному документу/справочнику. Для этого разместим кнопку на командной панели(ну или где Вам угодно) и в обработчике нажатия на кнопку  написать следующее:

	 Процедура ДействияФормыИсторияИзменений(Кнопка)

    ФормаИзменений = Справочники.ИзмененияДокументов.ПолучитьФормуСписка();
    ФормаИзменений.СправочникСписок.Отбор.GUID_Объекта.ВидСравнения = ВидСравнения.Равно;
    ФормаИзменений.СправочникСписок.Отбор.GUID_Объекта.Использование = Истина;
    ФормаИзменений.СправочникСписок.Отбор.GUID_Объекта.Значение = Строка(ЭтотОбъект.Ссылка.УникальныйИдентификатор());

    ФормаИзменений.Открыть();

КонецПроцедуры

Обновляем информационную базу и все. При каждом изменении в справочник добавляются элементы (изменения которые внесли пользователи). Думаю данная история изменений будет кому-то интересна и удобна.

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Эстер Коган (e.kogan) 29.09.10 16:50
Почему не оформлено как подсистема? (О том, что баян - промолчу)
2. Виталий (vit1c) 29.09.10 17:07
Zупер!!! Пользую. Нравится.
3. Анютка (Чертеночек) 29.09.10 17:37
кому боян, а кому НРАВИТСЯ:)))):{}
4. Александр Окулов (PowerBoy) 30.09.10 09:20
"Если НовЭлемент.Изменения.Количество() = 99999 Тогда"

я хренею от такого кода :o
5. Asdam (Asdam) 30.09.10 10:13
НашиДороботки
Это от слова робот?
6. Дмитрий Елисеев (w-divin) 30.09.10 10:15
ну йопт... ну зачем все в базу-то пихать???

и выполнение на клиенте - это не есть гуд... можно даже сказать есть бэд...

+(4) тоже понравилось... опять же на клиенте )))
7. Сергей Золотухин (RTFM) 30.09.10 13:41
(1) Извините новичек еще, первая публикация... Сам написал это еще ы 2009 году, решил щас поделиться, может кому пригодиться...

(4) Бывают такие большие документы, где производсится изменений более чем 99999, а ограничение табличной части есть 99999 строк, для этого и есть данная проверка, он записывает один элемент истории и создает другой элемент, где указываются оставшиеся изменения после 99999. Надеюсь внятно разъяснил)) (на практике встретил, пришлось добавить данное условие ибо не дает тогда записать такие большие документы...)

(5) Извиняюсь за орфографическую ошибку)))

(6) а затем чтобы быстро(по одному щелчку мыши) и любой компентентый юзер мог просмотреть историю изменения документов или справочников.

(6) А выполнение на клиенте это и есть гуд! Так как на сервер объект не передашь ибо мутабельное значение, и на сервере не сможешь проверить какие на данный момент времени перед записью значения в объекте, а какие еще пока хранятся в базе, чтобы выявить изменения вносимые текущим юзером.
Для этого предусматривается разграничение прав на данный справочник, всем абсолютно юзерам даются права на добавление, просмотр и ввод по строке. (ни каких изменений в истории никто не сможет сделать, а это уже хорошо).
Если ты имел ввиду про дополнительный обработчик, который на стороне клиента, ну это не 8.2 с тонким клиентом чтоб так беспокоится, на 8.1 он итак очень "толстый" и сильно не "напрягает" клиент.
8. Никита Уколов (zzerro) 30.09.10 15:08
(7 )... Так как на сервер объект не передашь ...

Это вообще как понимать?
9. Дмитрий Елисеев (w-divin) 30.09.10 15:10
(7) с такими объемами как вы описываете (и с какими я работал) база дохнет довольно быстро... По крайней мере у нас документы правлись по 5-10 раз на дню, и документы и документоооборот немаленькие. Держать эту информацию в базе ИМХО нецелесообразно, хотя бы потому что сам просмотр изменений вызывается крайне редко по отношению к вводу документов и получениям данных из базы...

по поводу сервера - например XML-сериализацию еще никто не отменял... поищи на просторах интернета примеры проведения документов на сервере в привелигированых модулях... у нас в разных базах реализовано 3 схемы хранения истории изменений: XML, отдельная sql-база, отдельная 1С-база, в зависимости от объема рабочей базы и частоты изменений используем одну из них... вся обработка истории проходит на сервере со всеми вытекающими плюсами (с использованием привилегированных модулей)...

опять же - "чтобы быстро(по одному щелчку мыши) и любой компентентый юзер мог просмотреть историю" это совершенно не зависит от расположения данных

плюс: "Бывают такие большие документы, где производсится изменений более чем 99999" 99999 раз получать размер тч, тем более на клиенте - ну не есть это гут... совсем не есть...

"на 8.1 он итак очень "толстый"" во-первых все зависит от конфы, а во-вторых зачем еще утолщать и так очень толстое???
10. Сергей Золотухин (RTFM) 30.09.10 15:21
(8) При попытки передачи объекта на сервер ругается на мутабельное значение!
11. Сергей Золотухин (RTFM) 30.09.10 15:34
(9) Я тебя не заставляю пользоваться моим примером реализации, хочешь пиши свой :) . У нас данная история не используется для всех документов и справочников, а для основных, где как раз такая детальная история и необходима. Работает данная история уже довольно долго и база не сдохла... :) и не сдохнет!
Я не заметил сильного "заторможения" работы при записи документов от обычной записи.
Я конечно понял что Вы имели ввиду что это не идеал и далеко это не так, ну я не кого не принуждаю его использовать, просто поделился, меня данный вариант устраивает. При томуж очень просто в кончоле отчетов накидать отчет по изменениям для руководства :-Р
12. k k (cool.dkf) 30.09.10 15:34
(10) Все правильно - напрямую серверу передать такие значения нельзя. Где-то я уже видел что-то подобное, но все равно +
13. Дмитрий Елисеев (w-divin) 30.09.10 16:27
(11) Один из смыслов оставлять комменты тут - это как раз указать автору на негативные стороны выставленного решения... а вы как-то неадекватно на конструктивную критику реагируете... по поводу "хочешь - пиши свой" - смотри пост (9) - там сказано что у меня уже написано и работают 3 различных механизма хранения истории изменений.

Заметьте - я не написал что обработка плохая или никому не нужная - я указал на минусы, которые присутствуют в её реализации, потому как тема актуальная еще со времен клюшек... И как всегда в механизмах регистрации изменений хочется задать вопрос (хотя ответ очевиден :D ): берем документ с 5000 строк, удаляем первую строку и имеем 5000 записей об изменении.... верно? или я что-то упустил?

ну и раз уже пошла такая тема, то оригинальностью данная разработка тоже не блещет (навскидку не говоря о платных вариантах):
http://infostart.ru/public/22167/
http://infostart.ru/public/19364/
http://infostart.ru/public/63420/
14. Руслан Микулович (rumik007) 30.09.10 17:17
И в нужном документе/справочнике в модуле объекта вконце процедуры ПередЗаписью() размещаем следующее:




#Если Клиент Тогда

Если Не Отказ Тогда

НашиДороботки.ЗаписатьИзмененияДокументаВСправочникИзмененияДокументов(ЭтотОбъект);

КонецЕсли;

#КонецЕсли


:idea: Наверное лучше бы было оформить через подписку на событие.
15. Сергей Золотухин (RTFM) 30.09.10 17:41
(13) Конструктивная критика принята :)

берем документ с 5000 строк, удаляем первую строку и имеем 5000 записей об изменении.... верно? или я что-то упустил?


Почти угадал :)
Один элемент справочника "Изменение документов" и с табличной частью как минимум строк 4999, но и более, все зависит от количества реквизитов в ТЧ измененного документа и как они изменились по отношению к значениям которые хранились в записи на строку выше...)))
16. Сергей Золотухин (RTFM) 30.09.10 17:46
(14) Идея хорошая... не подумал сразу, спасибо :)
17. Дмитрий Елисеев (w-divin) 30.09.10 18:36
(15) хех...болезнь... у меня в механизме в xml реализован контроль удаления строк, но он тож далек от идеала и никак не помогает при изменении порядка строк ((( но хоть что-то... уже легше... ... а так хотелось....

в 13 я имел ввиду записи об изменениях - т.е. то что видит пользователь при анализе, а не количество записей в бд...
18. Сергей Золотухин (RTFM) 30.09.10 20:25
(17) ну я же написал, пользователь видит одну строку с одним изменением документа пользователем. (Ну это является элементом справочника) Далее открывает этот элемент справочника и в шапке отображается кто, когда и какой документ/справочник изменил, а ниже табличная часть со строками изменения реквизитов. Вот в ней, табличной части справочника, уже много строк.(показывается в каждой строке реквизит далее значение до, значение после)
19. Осипов Михаил (Michael_Osipov) 01.10.10 08:26
Может быть и не идеал, но работает как надо. Для нескольких документов с небольшими изменениями как раз то, что нужно. Моя благодарность автору.
20. Андрей Крутских (K_A_O) 03.10.10 08:50
Только за Найти(Объект.Метаданные().ПолноеИмя(), ".")-1) = "Документ" хочется минус поставить
21. Евгения Крючкова (Djekiss) 10.10.10 12:07
Клёво! Всё работает!! оргомное СПАСИБО АВТОРУ!!!!!!!!!!!! :{}
Давно не могла решить эту проблему: как же можно отслеживать кто, когда и что именно изменил в документе или справочнике!? Теперь буду знать кому именно по голове стучать :evil: !!!!) еще раз спасибо! :D
22. Евгения Крючкова (Djekiss) 10.10.10 12:14
Клёво! Всё работает!! ОГРОМНОЕ СПАСИБО АВТОРУ!!!!!
Давно не знала как решить эту проблему: как же отслеживать кто, когда и что именно изменил в документе или справочнике... Теперь буду знать кому надо по голове стучать!!!)))) Еще раз СПАСИБО! :{}
23. Максим Зудин (kasper076) 15.10.10 08:50
(17) Может стоит пренебречь изменением номера строки? Т.е. исключить этот реквизит из проверки ТЧ.
24. rhtr Иванов (rhtr) 16.10.10 07:41
ПЛЮСУЮ, а на счет событий это уже каждый дадумает сам)
25. Брест Беларусь (zhleonid8) 18.10.11 17:03
автору респекти призыв на 8,2
26. Илья (i132) 06.03.12 12:44
RTFM, инетерсно, почему вы используете запрос а не сравниваете реквизиты ссылки и объекта?

Если построили запрос "выбрать * из ссылка" то мне кажется было бы быстрее быстрее перебирать выборка.Колонки чем перебирать реквизиты метаданных, кроме того в такой запрос попадают и табличные части в виде таблицы значений. Еще в выборку попадут стандртные реквизиты, которые вы пропустили: дата, номер, код, наименование, проведен...

Сравнение табличных частей мне кажется быстрее сравнивать через ЗначениеВстркуВнутр( табЧасть.Выгрузить()) для каждой строки табчасти вызывать Объект.Метаданные() -должно заметно увеличивать время обработки записи.

Перед присвоением ГУИД-ссылки новому объекту стоит проверить была ли уже ему присвоена другая ссылка (ГУИД <> "00000000-0000-0000-0000-000000000000")

Для поиска справочника с изменениями может быть не достаточно одного ГУИД -надо еще искать и по виду - можно создать два справочника разных видов но с одним ГУИД (в вашем случае этого не будет вы каждый раз получаете новый ГУИД)
27. Алексей Лейт (AlekseiLeit) 09.04.12 09:50
Спасибо автору. Пригодилось
28. Станислав Сидоряк (WildDancer) 22.06.12 06:48
Просто и со вкусом, и главное отлично работает. Спасибо
29. Станислав Сидоряк (WildDancer) 22.06.12 07:23
Немного поторопился. Конфликтует с моей доработкой)
30. Константин Константин (kosb_64) 22.06.12 16:42
Уже ставил "+", только он пропал куда-то. Работает отлично. Ставлю ещё раз "+"!!
31. Дмитрий Кузнецов (kudim) 21.06.16 12:48
А зачем записывать изменения в событии ПередЗаписью? а если в процессе проверки ПриЗаписи формы или Объекта получим отказ и не запишем? история то уже сохранится.
Логичнее тогда уж фиксировать записанные изменения после записи объекта.