Раскраска заголовков вертикальных ресурсов в СКД

Опубликовал Александр ягольник (Alex Y) в раздел Программирование - Работа с интерфейсом

Как покрасить заголовки ресурсов, расположенных вертикально? Предложенный вариант решает эту проблему

 

Когда мне поручили создать отчет, в котором виды выплат по каждому сотруднику будут располагаться вертикально, а периоды (месяцы) горизонтально, то проблема решилась достаточно быстро длягодаря Infostart и серому веществу ;).

Но когда мне поручили раскрасить строки в разные цвета, я изрядно поломал голову и, в итоге, уперся в стену. ячейки с ресурсами красились успешно, а их горизонтальные заголовки - ни в какую! Чего только не перепробовал, вспомнить страшно.

Но всё решилось банально просто - постобработкой табличного документа. Вначале формируется документ на основе СКД, а потом меняется цвет нужных ячеек по их содержимому. Можно задавать оригинальное форматирование, а можно брать из соседней правой ячейки с ресурсом.

 


    ДокументРезультат=ЭлементыФормы.Результат;
   
ПроцессорВывода=Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
   
ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
   
ПроцессорВывода.НачатьВывод();
    Пока Истина Цикл
       
ЭлементРезультата=ПроцессорКомпоновки.Следующий();
        Если
ЭлементРезультата=Неопределено Тогда
            Прервать;
        Иначе
           
ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
        КонецЕсли;
    КонецЦикла;
   
ПроцессорВывода.ЗакончитьВывод();

   
МассивЦвета = Новый Массив();
   
МассивЦвета.Добавить("Уровень начисленный");
   
МассивЦвета.Добавить("Всего нач с учетом компенсаций");
   
МассивЦвета.Добавить("Всего начислено");
   
МассивЦвета.Добавить("Уровень на руки");
   
МассивЦвета.Добавить("На руки с учетом компенсаций");
   
МассивЦвета.Добавить("На руки со всех видов начислений");
   
МассивЦвета.Добавить("НДФЛ со всех видов начислений");

    Для каждого
Элемент Из МассивЦвета Цикл
       
НайденнаяОбласть = ДокументРезультат.НайтиТекст(Элемент);
        Пока
НайденнаяОбласть <> Неопределено Цикл
           
СоседняяЯчейка = ДокументРезультат.Область(НайденнаяОбласть.Верх, НайденнаяОбласть.Право + 1, НайденнаяОбласть.Низ, НайденнаяОбласть.Право + 1);
           
НайденнаяОбласть.ЦветФона = СоседняяЯчейка.ЦветФона; //Цвет;
           
НайденнаяОбласть.Шрифт = СоседняяЯчейка.Шрифт; //Цвет;
           
НайденнаяОбласть = ДокументРезультат.НайтиТекст(Элемент, НайденнаяОбласть);
        КонецЦикла;

    КонецЦикла;


 

Приведенный код требует правки каждый раз, когда меняется наименование заголовка ресурса в СКД.

Если у кого-то данная задача имеет более изящное решение, буду рад увидеть Ваш вариант.

См. также

Добавить вознаграждение
Комментарии
1. Алексей Константинов (alexk-is) 6075 25.08.10 13:47 Сейчас в теме
(0) Почему бы не раскрасить текст модуля в статье?
2. Александр ягольник (Alex Y) 160 25.08.10 14:14 Сейчас в теме
Спасибо за разукрашку :)
3. vers139 (vers139) 50 25.08.10 14:41 Сейчас в теме
первую часть кода можно заменить одной строкой:
СкомпоноватьРезультат(ЭлементыФормы.Результат, ДанныеРасшифровки);
4. Эстер Коган (e.kogan) 1816 25.08.10 16:06 Сейчас в теме
А всё в целом - условным оформлением.
Оно и ресурсы красит, и детальные записи, и по любому (в том числе аналогичному ресурсам) условию.

Если у вас задача, выходящая за рамки возможностей УО - расскажите, с интересом прочитаю.
5. Игорь Исхаков (Ish_2) 957 25.08.10 17:03 Сейчас в теме
Причем тут СКД ?
Статью нужно было назвать "Как я научился раскрашивать ячейки табличного документа".
It-developer; Spartan; +2 Ответить
6. Александр ягольник (Alex Y) 160 26.08.10 17:55 Сейчас в теме
Уважаемые комментаторы!
Возможно я неясно выразился в своей статье.

Задача была следующая:
1. используя СКД создать отчет с вертикальным размещением ресурсов
2. раскрасить строки разных ресурсов в разные цвета

Стандартный отчет в СКД раскрашивает только ячейки с циферками. А фон заголовка ресурса оставляет белым.

Если кто-то в рамках СКД для версии платформы (8.2.10.77) сумеет раскрасить заголовок (вертикально расположенный), проставлю пиво. Или переведу соотв.сумму на телефон.
7. Cube_krsk 31 27.08.10 06:19 Сейчас в теме
(6)

1С:Предприятие 8.2 (8.2.12.78)
Зарплата и Управление Персоналом, редакция 2.5 (2.5.19.3)

Типовой отчет. Группировочные строки подразделений Администрация, Бухгалтерия и Снабжение раскрашены в разные цвета.

Пиво поставить не забудь.
8. Cube_krsk 31 27.08.10 06:21 Сейчас в теме
+(7) Забыл сказать: раскрашивание производилось исключительно средствами СКД и исключительно в режиме 1С:Предприятие.

И на платформе 1С:Предприятие 8.1 (8.1.15.14) то же самое могу повторить.
9. Boris Leleko (Boris-Leleko) 292 30.08.10 16:51 Сейчас в теме
Вообще-то для этого в СКД есть макет. И в если мне память не изменяет в нём можно заголовки оформлять. А вообще ваш вариант вполне жизнеспособен. Чё с макетом возиться, когда несколько строк можно написать...
10. Александр ягольник (Alex Y) 160 30.08.10 17:41 Сейчас в теме
(7) Уважаемый Cube_krsk! Внимательно прочитайте тему! Речь идет не о раскраске группировок, а о раскраске заголовков РЕСУРСОВ, размещенных вертикально.
Т.е. если у каждого сотрудника "Начальное сальдо", "Оклад по дням" и прочее будут располагаться не в колонках, а построчно.
Так что - незачет.
11. Leja Leja (Leja) 13.09.10 09:33 Сейчас в теме
Тоже сталкивалась с проблемой раскраски заголовков ресурсов, спасибо Вам за инфу.
Но возник тупой вопрос - куда именно вставлять приведенный код? (модуль формы отчета и модуль отчета отсутствуют, СКД не программное) :oops:
12. Александр ягольник (Alex Y) 160 13.09.10 09:45 Сейчас в теме
(11) Поскольку у меня это внешняя обработка, то в модуле формы при обработке нажатия на кнопку "Сформировать" я запускаю процедуру "ВывестиОтчет". Там и помещаю приведенный код.

"СКД не программное" - т.е. вы формируете СКД из обработки "Консоль"? Если так, то я использую консоль на этапе отладки, а потом на основе работы с ней делаю внешний отчет.
13. Leja Leja (Leja) 13.09.10 14:36 Сейчас в теме
(12) у меня это внешний отчет, модулей никаких нет, есть только макет, который является схемой компоновки данных - открываю его в конструкторе.
Значит, чтобы применять Ваш метод, нужно переделывать отчет, добавлять формы и делать оттуда вызов (работу) с СКД ? :(
14. Александр ягольник (Alex Y) 160 13.09.10 16:11 Сейчас в теме
(13) Если уж хотите получить что-то сверх стандартных возможностей, то осваивайте написание своих форм. Это не так сложно, если подобрать достаточно простую, но удобную из типовых. Либо посмотрите на те примеры, что публикуют на этом сайте.