gifts2017

Проверка обновлений

Опубликовал malev КонецЕсли (malev) в раздел Программирование - Практика программирования

Проверялка обновлений с изменениями от 27.09.2011
Позволяет узнать последние релизы конфигураций из списка а также последние номера комплектов регламентированной отчетности. Обработка требует наличия v7plus.dll

27.09.2011

изменен список конфигураций

01.03.2011

  • изменен тип флажка в таблицах (с текстового "+" на графический, стандартный флажок)
  • есть возможность проверить какой был последний комплект отчетности
  • при установленном флажке "Проверять при запуске", при наличии обновлений в окно сообщений выводится название конфигурации и номер релиза.
  • в списке обновленных конфигураций теперь можно убрать например уже скаченную или неинтересующую вас конфигурацию (в общем списке она остается, но уже с актуальным номером релиза)
  • по просьбе po.l.i, добавлена конфигурация "Торговля и склад 7.7"

20.02.2011 - добавлены кнопки сортировки списка конфигураций, возможность печати текущих релизов и обновлений, флажок проверки обновлений при запуске обработки.

17.02.2011 - немного изменен интерфейс, добавлена функция склонения, добавлены кнопки перемещения конфигураций в списке, добавлены некоторые базовые конфигурации, устранены мелкие недоработки. Обработка в стадии тестирования.

30.01.2011 - первая тестовая версия обработки.

Скачать файлы

Наименование Файл Версия Размер
Обработка 441
.zip 141,78Kb
27.09.11
441
.zip 141,78Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Rusk (Rusk51) 31.01.11 20:02
Довольно удобно, еще бы что бы автоматом скачивала с файлообменов типа slil.ru :)
2. malev КонецЕсли (malev) 31.01.11 20:07
можно и не через файлообменники, но думаю здесь ее тогда забанят.
3. Алексей (Alav) 01.02.11 01:35
Эта та обработка которая через info.dat проверяет обновления, просто в новой обертке?

Или она без info.dat может качать?
4. malev КонецЕсли (malev) 02.02.11 17:57
Отчасти да, навеяно этой обработкой, но без info.dat (думаю сделать несложно, но позже) и код все таки переработан в большей части, также в той обработке я не видел чтоб по 8-ке обновления получать можно.
5. Саня Пупкин (pupkinSana) 03.02.11 10:14
6. Юрий Щербаков (ufo58) 21.02.11 10:49
Все бы хорошо ...
Только сейчас актуальна версия бух проф 7 522
А уже не в первой подобной обработке показывает с опозданием
наример, сейчас обновлениях вашей обработки стоит 521-я
с чем это связано?
7. Лидия Лидин фа (lidalidinfa3740) 21.02.11 11:21
Установила программу 1С бухгалтерия8 базовая версия. При открытии пишет-не обнаружен ключ защиты программы. Что делать? подскажите пожалуйста!
8. Юрий Щербаков (ufo58) 21.02.11 12:10
вопрос 6 снят
хорошая работа
9. malev КонецЕсли (malev) 21.02.11 20:25
номера релизов на скриншотах показаны для демонстрации работы обработки
10. Егор Киреев (po.l.i) 25.02.11 16:28
добавте Торговля+Склад 7.7
11. malev КонецЕсли (malev) 27.02.11 22:37
в следующей версии будет
12. vadim Pronin (vadimvad) 01.03.11 21:21
13. malev КонецЕсли (malev) 01.03.11 22:13
vadimvad пишет: Как скачивать?

Если вопрос по поводу скачивания конфигураций то данная обработка это не поддерживает
14. Андрей Акулов (DrAku1a) 02.03.11 02:10
Когда-то пробовал наваять подобное на 8-ке. Инфу о релизах брал отсюда: http://www.1c.ru/rus/support/release/categ.jsp?GroupID=88.
Так до уму так и не довел - много времени занимает, а вот актуально ли?..
15. malev КонецЕсли (malev) 02.03.11 07:10
DrAku1a пишет: Когда-то пробовал наваять подобное на 8-ке. Инфу о релизах брал отсюда: http://www.1c.ru/rus/support/release/...GroupID=88.
Так до уму так и не довел - много времени занимает, а вот актуально ли?..

Извините, но не совсем понял суть вопроса. Информация о релизах берется также как и из самих конфигураций 1С. А если Вы спрашиваете про актуальность обработки, она лично мне очень помогает, т.к. работаю у франчайзи.
16. Андрей Акулов (DrAku1a) 02.03.11 13:29
(15) Вот для франчайзи - да, актуально... Еще бы перечень баз на обновлении у клиентов, перечень файлов обновлений, проверять - какие скачивать обновления, кому из клиентов нужно установить, потом составлять расписания, потом... А что неужели нет стандартной такой конфы от 1С-ников?
18. Алексей Гришков (asg1975) 28.09.11 16:47
Прошу прощения но в чем прикол, все это на сайте и так видно и для простых смертных, не говоря уже о франчайзи...
19. sumixam (sumixam) 30.09.11 14:53
(17) malev, полезная вещь всегда пригодится
20. Александр Шур (supershurik) 15.10.11 12:26
Хорошая программа. У меня все получилось.
21. neon1 Ефимова (neon1) 24.10.11 21:44
24. nirbolz 23.05.12 18:15
О хорошая обработка, здорово было бы если она еще бы позволяла скачивать релизы.
25. Денис Вовк (CyberWo1f) 04.04.14 14:40
Хорошая обработка. Надо бы на 8 такую сделать.