gifts2017

Больничный лист по беременности и родам

Опубликовал Ольга Симонова (lel4ik) в раздел Управление - Практика учета

По новому законодательству можно теперь начислять пособия по беременности и родам, как по старым правилам, так и по новым, на усмотрение сотрудника. В ЗиК 306 и выше  это не предусмотрено.

В модуле документа "Больничный лист"  в конце процедуры СформироватьСлои() добавить следующие строки:

Если ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам Тогда
	Форма.Закладки.УдалитьВсе();
	Форма.Закладки.ДобавитьЗначение("Постоянный,Основной","Основная");
	Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Расчет за период после 01.01.2011"); 
	ЕстьЗакладкаПереходногоПериода = 1;
	Форма.Закладки.ДобавитьЗначение("Постоянный,Средний","Средний заработок");
	Форма.Закладки.ДобавитьЗначение("Постоянный,Комментарий","Комментарий");
КонецЕсли;

И в процедуре  Печать(ПараметрПечати = "") строки 6730 добавить:

Если ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам Тогда
	Печать2010(ПараметрПечати);  
КонецЕсли;

Реализация  расчета

в модуле формы в районе 1318 после строки:

Форма.РасчетВпереходномПериодеПоПравилам2011.Видимость(0);

добавить:

Если (ДатаНачалаСобытия >= ДатаНачалаРеформыСоцСтрахования) И (ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) Тогда 
	Форма.РасчетВпереходномПериодеПоПравилам2011.Видимость(1); 
КонецЕсли;

в ГМ в районе 50563 перед строкой: 

НетПереходногоПериода=0;

вместо строки:

Если (ДатаНачалаБолезни < ДатаНачалаРеформыСоцСтрахования) Тогда

пробить (заменить на) строку:

Если (ДатаНачалаБолезни < ДатаНачалаРеформыСоцСтрахования) ИЛИ (ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) Тогда

Отпуск по уходу за ребенком. Расчет по-новому и по-старому. Реализация на  http://infostart.ru/public/82554/.

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Vladimir (Boroda) 18.02.11 17:38
Что-т я не допонял: это для конфигурации 1С:Бухгалтерский учёт или для ЗиК 306?
2. Ольга Симонова (lel4ik) 18.02.11 20:23
3. Геннадий Малиновский (Гена) 18.02.11 22:18
Вы дали поправку не в модуле дока, а в модуле формы...
поэтому вкладка то появилась... и две печатные формы... а вот сам расчёт идёт только по-новому...

добавьте:
1. крыжик или переключатель выбора варианта расчёта
2. ну и по п.1 само ветвление расчёта в ГМ(?)
konyavka; lookindenis; +2 Ответить 2
4. Геннадий Малиновский (Гена) 18.02.11 23:21
для реализации (3) предлагаю:
1. в модуле формы в районе 1318 после строки
Форма.РасчетВпереходномПериодеПоПравилам2011.Видимость(0);

добавить:
Если (ДатаНачалаСобытия >= ДатаНачалаРеформыСоцСтрахования) И (ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) Тогда
Форма.РасчетВпереходномПериодеПоПравилам2011.Видимость(1);
КонецЕсли;


2. в ГМ в районе 50563 перед строкой:
НетПереходногоПериода=0;

вместо строки
Если (ДатаНачалаБолезни < ДатаНачалаРеформыСоцСтрахования) Тогда

пробить (заменить на) строку
Если (ДатаНачалаБолезни < ДатаНачалаРеформыСоцСтрахования) ИЛИ (ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) Тогда
Nicholas; artbear; MANEK; lel4ik; +4 Ответить
5. Ольга Симонова (lel4ik) 19.02.11 12:04
6. Геннадий Малиновский (Гена) 20.02.11 09:22
(5) надо всё доделывать до конца... поправки касаются не только б/л по декрету, но и отпуска по уходу...

сделайте аналогичные изменения и в доке ОУ - две вкладки среднего и выбор расчёта по новому или по старому...
7. Ольга Симонова (lel4ik) 20.02.11 11:03
Я начинающий программист, так что сильно не ругайтесь. А вообще большое спасибо за поправки. Учить меня некому, учусь сама.
8. Oleg (ZolotareffOY) 25.02.11 11:14
Здравствуйте !!!
Я не програмист. Как редактировать модули не знаю.
А больничный по беремености и родам уже нужно расчитывать. Какие есть еще варианты расчета больничного.
У меня девочка работает 8 месяцев, а программа даже в расчет январь 2011 года месяца не берет.
9. Геннадий Малиновский (Гена) 25.02.11 13:02
так, господа... сейчас ДАМ подписал поправки... с БиР здесь разобрались... надо делать и ОУ (отпуск по уходу за ребёнком)... хватит лодырничать...
10. Сергей (Ulfhedhinn) 01.03.11 02:49
Очень хорошо, но плюсовать пока не буду. Оформите пост с учетом предложенных Геной поправок и не забудьте про отпуск по уходу. А еще желательно переоформите это для 307 релиза. Щас снова возникнет ситуация, что каждый будет постить свои маленькие поправочки и собирать урожай плюсов. Давайте уж лучше пусть урожай соберет один человек, зато пост действительно будет стоить урожая ;)
11. Ершова Ольга (lushka) 10.03.11 08:56
Такой еще косяк вылез - в глобальнике
глСобратьДанныеДляБЛ2010
было
//ПредельнаяВеличинаБазы = Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Получить(КонГода(ДатаОграничения));
стало
ПредельнаяВеличинаБазы = Окр((Константа.ОграничениеРазмераБЛ.Получить(КонГода(ДатаОграничения))) * 12,2);


ссылается на предельную величину базы страховых взносов, которая до 01.01.2011 была равна 415000, а теперь 463000 в итоге неправильно ограничивает размер пособия
12. Nicholas Mikuslas (Nicholas) 10.03.11 11:40
(11) ОграничениеРазмераБЛ = 18720.00, умножаем на 12, получаем - 224640.00.

Предлагаю сделать так:
//ОдноЦе [<>] ОАО "Рога и копыта" 10.03.2011 16:00:51
//Comments: Используем предельную величину базы страховых взносов 2010-го года
//Been:
//ДатаОграничения = Макс(ДатаПереходаНаСтраховыеВзносы,ДатаНачалаБолезни);
//Turn:

ДатаОграничения = Мин(Макс(ДатаПереходаНаСтраховыеВзносы, ДатаНачалаБолезни), '31.12.2010');
//EndОдноЦе [<>]

И, видимо, нужно еще внести изменения в глСобратьДанныеДляБЛ2011:
//ОдноЦе [<>] ОАО "Рога и копыта" 10.03.2011 16:30:56
//Comments: Используем предельную величину базы страховых взносов 2010-го года
//Been:
//ПредельнаяВеличинаБазы2010 = Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Получить(КонГода(ДатаНачалаБолезни));
//Turn:

ПредельнаяВеличинаБазы2010 = Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Получить(КонГода(Мин(ДатаНачалаБолезни, '31.12.2010')));
//EndОдноЦе [<>]
13. Nicholas Mikuslas (Nicholas) 10.03.11 14:28
(9) Форма документа ОтпускПоУходуЗаРебенком:

1. Добавляем новый реквизит на форму:
//Nicholas modified ОАО "Рога и копыта" 05.03.2011
//Comments: О внесении изменений в Федеральный закон «Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством...
//Диалог: изменен
// Новый реквизит NРасчетС2011
//Модуль: изменен
//Таблицы: без изменений


2. В процедуре РассчитатьСреднийЗаработок():
//Nicholas [<>] ОАО "Рога и копыта" 05.03.2011 17:57:28
//Comments: О внесении изменений в Федеральный закон «Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством...
//Been:
//Если ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года Тогда
//Turn:

Если (ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2011года)
И (
NРасчетС2011 = 1) Тогда
//EndNicholas [<>]


3. В Процедуре Печать():
//Nicholas [<>] ОАО "Рога и копыта" 05.03.2011 17:58:40
//Comments: О внесении изменений в Федеральный закон «Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством...
//Been:
//Если ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года Тогда
//Turn:

Если (ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2011года)
И (
NРасчетС2011 = 1) Тогда
//EndNicholas [<>]

4. В Процедуре СформироватьСлои() после Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011", "Средний заработок"):
//Nicholas [+] ОАО "Рога и копыта" 04.03.2011 18:39:02
//Comments: О внесении изменений в Федеральный закон «Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством...

Форма.Закладки.ДобавитьЗначение("Постоянный,Средний", "Расчет за период до 01.01.2011");
//EndNicholas [+]
14. Ершова Ольга (lushka) 11.03.11 05:01
Nicholas пишет:
(11) ОграничениеРазмераБЛ = 18720.00, умножаем на 12, получаем - 224640.00.

ну это смотря в каком регионе :) у нас например - 34583,34
а вобще, да, не совсем правильно, поторопилась
15. Dmitri X (yugraman) 14.03.11 07:47
lushka пишет:

Такой еще косяк вылез - в глобальнике
глСобратьДанныеДляБЛ2010
было
//ПредельнаяВеличинаБазы = Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Получить(КонГода(ДатаОграничения));
стало
ПредельнаяВеличинаБазы = Окр((Константа.ОграничениеРазмераБЛ.Получить(КонГода(ДатаОграничения))) * 12,2);


ссылается на предельную величину базы страховых взносов, которая до 01.01.2011 была равна 415000, а теперь 463000 в итоге неправильно ограничивает размер пособия

А где сказано, что должен использоваться предел 415000? В п.19.1 Постановления 375 сказано "Средний дневной заработок, из которого исчисляются пособия по временной нетрудоспособности, по беременности и родам застрахованным лицам, не может превышать средний дневной заработок, определяемый путем деления предельной величины базы .... на день наступления страхового случая, на 365". Это изменение внесено до закона 21-ФЗ и его не отменяли. Так что для отпуска по беременности и родам в 2011 г. вроде как надо использовать текущее значение предела - 463000р.
16. Dmitri X (yugraman) 14.03.11 07:57
lushka пишет:
[IS-QUOTE]Nicholas пишет:
(11) ОграничениеРазмераБЛ = 18720.00, умножаем на 12, получаем - 224640.00.

ну это смотря в каком регионе у нас например - 34583,34[/IS-QUOTE]

От региона ж не зависит, везде 415000/12=34583,33. А предел 18720.00 не используется с 2010 года.
17. Евгений Сотников (SotnikovEO) 16.03.11 08:40
Не учтено что больничный может быть продолжение, при печати не учтено что больничный может рассчитываться по правилам 2011 года.
Вот мои дополнения к поправкам больничного (смотреть метки SEO):
//------> Процедура СформироватьСлои()
Процедура СформироватьСлои()

Форма.Закладки.УдалитьВсе();
Форма.Закладки.ДобавитьЗначение("Постоянный,Основной","Основная");
ЕстьЗакладкаПереходногоПериода = 0;
Если (ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года) Тогда

Если (ДатаНачалаСобытия < ДатаНачалаРеформыСоцСтрахования) и (Окончание >= ДатаНачалаРеформыСоцСтрахования) Тогда

Если ПервичныйБольничный.Выбран() = 0 Тогда
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Расчет за период после 01.01.2011");
ЕстьЗакладкаПереходногоПериода = 1;
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний","Средний заработок");
Иначе
// проверим есть ли в первичном БЛ данные заработка
ПредыдущийПервичный = ПервичныйБольничный;
Пока ПредыдущийПервичный.ПервичныйБольничный.Выбран() = 1 Цикл
ПредыдущийПервичный = ПредыдущийПервичный.ПервичныйБольничный;
КонецЦикла;
ПервичныйДокумент = ПредыдущийПервичный;

Если (ПервичныйДокумент.ЗаработокЗаПервыйГод+ПервичныйДокумент.ЗаработокЗаВторойГод
+ПервичныйДокумент.ЗаработокЗаПервыйГодДругиеСтрахователи
+ПервичныйДокумент.ЗаработокЗаВторойГодДругиеСтрахователи) = 0 Тогда
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Расчет за период после 01.01.2011");
КонецЕсли;
КонецЕсли;
ИначеЕсли (ПустоеЗначение(Окончание) = 0) и (Окончание < ДатаНачалаРеформыСоцСтрахования) Тогда
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний","Средний заработок");
ИначеЕсли ПервичныйБольничный.Выбран() = 0 Тогда
//{seo
//Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Средний заработок");
Если ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам Тогда
ЕстьЗакладкаПереходногоПериода = 1;
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний","Средний заработок");
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Расчет за период после 01.01.2011");
Иначе
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Средний заработок");
КонецЕсли;
//seo}
КонецЕсли;
//------> Процедура Печать()
Процедура Печать(ПараметрПечати = "")

Если ((Проведен()=0)или(Модифицированность()=1)) Тогда
Если Вопрос("Распечатать можно только записанный документ."+РазделительСтрок+" Записать и распечатать документ?","Да+Нет")="Нет" Тогда
Возврат
КонецЕсли;
Если ПередЗаписью()=0 Тогда
глОткрытьОбработчик(ОбработчикСообщений, Вид()+НомерДок);
Возврат
Иначе
Записать();
КонецЕсли;
КонецЕсли;

Если ПустоеЗначение(ДатаНачалаСобытия)=1 Тогда
//ПолучитьДатуНачалаСобытия();
ДатаНачалаСобытия = глПолучитьДатуНачалаСобытияБЛ(Контекст)
КонецЕсли;

Если ДатаНачалаСобытия < '01.01.2005' Тогда
Печать2004(ПараметрПечати)
ИначеЕсли ДатаНачалаСобытия < '01.01.2006' Тогда
Печать2005(ПараметрПечати);
ИначеЕсли ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года Тогда
//{seo
//Печать2011(ПараметрПечати);
Если ТипБолезни=Перечисление.ТипБолезни.ПоБеременностиИРодам Тогда
Если (ЗаработокЗаВторойГод+ЗаработокЗаПервыйГод+ЗаработокЗаВторойГ­одДругиеСтрахователи+ЗаработокЗаПервыйГодДругиеСтрахователи)>0 Тогда
Печать2011(ПараметрПечати);
Иначе
Печать2010(ПараметрПечати);
КонецЕсли;
Иначе
Печать2011(ПараметрПечати);
КонецЕсли;
//seo}
ИначеЕсли ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года Тогда
Anatolka; +1 Ответить
18. Анатолий (Anatolka) 16.03.11 11:58
и всетаки как выбрать метод расчета? из (3) поправка 1 так тут и не добавили?
19. lefthander (lefthander) 01.04.11 17:38
Anatolka пишет:
всетаки как выбрать метод расчета?

Только дополнив шапку реквизитом и выводом его на форму в виде флажка.
Я другого способа не вижу.
Останавливает пока то, что через 1-2 релиза 1С введет свой реквизит и все созданные документы придется править.
Как всегда. Но расчетчики прижали... видимо с 4 апреля буду вводить у себя, ждать 1с уже трудно.
20. rjhev korum (корум) 05.04.11 18:41
Если в тему заглядывают несчастные, кому приходится бороться с Комплексной - кроме вышеописанных танцев с бубном не забудьте поправить отчет РасходыПредприятияЗаСчетФСС.
Строка 1682, меняем
		Если Документ.ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года Тогда

на
		Если (Документ.ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года) ИЛИ ((Документ.типБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) и (Документ.флРасчетс2011=0))  Тогда


Иначе при печати оборотного листа вместо нужных цифр увидим нули.

Глобальный модуль, процедура глСобратьДанныеДляБЛВыбор

//Если Документ.ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2010года Тогда
Если (Документ.ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2010года)
или ((Документ.флрасчетс2011 = 0) и (документ.ТипБолезни = перечисление.ТипБолезни.ПоБеременностиИРодам))
21. Светлана Фоменко (safia-med) 03.09.14 12:13
как выбрать метод расчета?