Поздравлялка с 8 марта

Сообщество - Поздравления

30 открыток и генератор случайных чисел, чтобы у 10 женщин не вылазила одна и та же картинка ;)
Ну и для разнообразия кнопка "Еще!" - выдает случайную картинку из набора.
Версии платформы 8.1 и 8.2 (обычное приложение).

Обработка сделана на платформе 8.2, но в режиме совместимости 8.1.

За основу была взята  "коллекция ГБ" (//infostart.ru/public/74947/), но что мешает прилепить генератор случайных чисел и дамам открытки? Wink

Так как генератор случайных чисел работает на разнице дат ТекущееВремя - НачалоСуток, то быстрое нажатие кнопки "Ещё!" иногда выдает ту же картинку.

Как это исправить:

Первую строку модуля формы заменить на Перем НомерКартинки;, а в процедуре УстановитьКартинкуПоНомеру() эту строку убрать.

В строке, где инициируется новая последовательность, добавить эту переменную. Должно получиться вот что:

НомерПоследовательностиГСЧ (ТекущаяДата() - НачалоДня(ТекущаяДата())) + НомерКартинки;

Чтобы поместить обработку в автозагрузку, надо в модуле приложения в процедуре ПриНачалеРаботыСистемы() дописать такую строчку:
Обработки.Поздравлялка8марта.ПолучитьФорму().Открыть();

Это если обработка встроенная, заодно проверить на доступность прав и по физлицу пользователя проверить пол м/ж.

Я сделал это, используя ПланВидовХарактеристик.НастройкиПользователей, создав новый предопределенный элемент и в модуле приложения проверял эту настройку:


Если УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ЗапуститьПоздравлялку") = Истина Тогда
  Обработки.Поздравлялк8марта.ПолучитьФорму().Открыть
();
КонецЕсли;

 

P.S. За идею с картинками благодарю Sirruf (//infostart.ru/profile/47009/)

Раз уж я взял без спроса его идею, прошу также отблагодарить и автора оригинала
//infostart.ru/public/74947/

Обновление: добавил и для платформы 8.1

Скачать файлы

Наименование Файл Версия Размер
Обработка "Поздравлялка с 8 марта" (8.2)
.7z 3,31Mb
07.03.17
199
.7z 3,31Mb 199 Скачать бесплатно
Поздравлялка для платформы 8.1
.epf 3,45Mb
07.03.17
56
.epf 3,45Mb 56 Скачать бесплатно
Обработка "Поздравлялка с 8 марта" (8.2) - не сжатая
.epf 3,45Mb
07.03.17
32
.epf 3,45Mb 32 Скачать бесплатно

См. также

Комментарии
1. JokerIV IV (JokerIV) 04.03.11 12:07 Сейчас в теме
2. Юрий Тимофеев (Tatitutu) 3623 04.03.11 12:21 Сейчас в теме
3. vladal (Vladal) 04.03.11 12:38 Сейчас в теме
(1) Теперь работает. Добавил файл для 8.1, пришлось назад копипастить из 8.2 в 8.1
4. vladal (Vladal) 04.03.11 12:39 Сейчас в теме
(2) Угу, попробуй там написать "инфостарт" - матофильтр сработает.
5. Александр Зубцов (iov) 361 04.03.11 13:34 Сейчас в теме
(4) именно суровая действительность и отсутствие логики порой приводят к причудливым формам уродства. Что мы и наблюдаем в данном примере
6. roman romanov (rsu555) 04.03.11 13:45 Сейчас в теме
в 8.2 запускаю ошибка файловой операции 'D:\Данные\Обработки\82.epf'
по причине:
Неверный формат хранилища данных 'file://D:/Данные/Обработки/82.epf'
7. vladal (Vladal) 04.03.11 14:00 Сейчас в теме
(6) странно. Я из своей рабочей базы сохранил.
Может, управляемое приложение?

Когда дочитаю Радченко 8.2 до нужного места, возможно, перепишу под управляемое приложение.
8. vladal (Vladal) 04.03.11 15:14 Сейчас в теме
(7) Вот, нашел рекомендации:

- В свойствах конфигурации установить галочку "использовать обычные формы в управляемом приложении"
- обработка должна быть интегрирована в конфигурацию (а не быть внешней обработкой)
- предприятие должно быть запущенно в режиме толстого клиента.
9. roman romanov (rsu555) 04.03.11 15:16 Сейчас в теме
vladal пишет:

(6) странно. Я из своей рабочей базы сохранил.

Может, управляемое приложение?



Когда дочитаю Радченко 8.2 до нужного места, возможно, перепишу под управляемое приложение.


нет это я лопухнулся.. без расширения файл, вот я и подумал что это обработка, а оказался архив, в котором обработка..все работает спасибо
10. vladal (Vladal) 04.03.11 15:23 Сейчас в теме
(9) Вот и хорошо. Только для 8.2 я еще упаковал 7zip, выиграл 100 килобайт.
Это он так сохранился без расширения?
11. vladal (Vladal) 04.03.11 15:25 Сейчас в теме
(2) Кстати, вон девушка тоже столкнулась с подобным:
http://www.forum.mista.ru/topic.php?id=536396#11
12. Сисой Сисой (Сисой) 81 04.03.11 18:22 Сейчас в теме
Автору не кажется, что сжимать обработку для 1С 8 в формате 7z - извращение?
Может, стоит использовать более привычные большинству пользователей форматы?
13. vladal (Vladal) 04.03.11 19:43 Сейчас в теме
(12) нет, автору так не кажется.

Я им лет 5 пользуюсь - он бесплатен, хорошо жмёт в своем формате, лучше РАР и ЗИП, мультиязычен, встраивается в проводник.
Если надо - перезалью не сжатый. Если найду быстро ;)
14. Николай Ф. (finik1) 05.03.11 02:11 Сейчас в теме
Спасибо! Всех поздравил!
15. Аркадий Кучер (Abadonna) 3676 05.03.11 03:38 Сейчас в теме
(10)
Только для 8.2 я еще упаковал 7zip, выиграл 100 килобайт.

А копейку уронишь - нагибаешься её поднять? ;)
16. Алексей Заболотнов (z-alexey) 1251 05.03.11 10:51 Сейчас в теме
>P.S. За идею с картинками благодарю Sirruf (http://infostart.ru/public/82288/)
а ссылка на свою же обработку :)
17. vladal (Vladal) 06.03.11 11:54 Сейчас в теме
(15)
А копейку уронишь - нагибаешься её поднять?

И таки да, а шобы и нет?
18. vladal (Vladal) 06.03.11 12:40 Сейчас в теме
(16) Упс... что было в буфере... Спасибо, поправил.
19. Алексей Прокопенко (axelload) 26.09.11 11:57 Сейчас в теме
Скачал, пользуюсь, радуюсь :)
20. vladal (Vladal) 29.09.11 16:15 Сейчас в теме
21. Александр (Sanek_159) 24.02.12 14:18 Сейчас в теме
(20) vladal, Готовит сани с лета =). И я вот начинаю в предверии праздника подготовку.
22. Master07 (Master07) 27.02.12 11:49 Сейчас в теме
Спасибо! Актуально перед празжничком!
23. Андрей Козлов (AndreyMurom) 05.03.12 10:38 Сейчас в теме
Спасибо большое, надо поздравить девчонок с праздником.
24. Андрей Козлов (AndreyMurom) 06.03.12 19:59 Сейчас в теме
А можете кто-нибудь подсказать, что можно дописать, чтобы обработка запускалась в развернутом виде?
25. vladal (Vladal) 06.03.12 22:10 Сейчас в теме
(24) Я задумывал, как модальное окно. Развернуть можно программно, а можно и свойствами формы - Способ отображения окна = Максимизированное.
26. vladal (Vladal) 06.03.12 23:02 Сейчас в теме
Только что допилил модуль приложения, процедуру ПриНачалеРаботыСистемы()

	// ВЛ - 2012-03-06 - Поздравлялка с 8 марта
	ТекМесяц = Месяц(Текущаядата());
	ТекДень = День(ТекущаяДата());
	Если ТекМесяц = 3 Тогда
	
		// Мурррт!
		Если ТекДень >= 6 И ТекДень <= 8 Тогда
		
			// Отвосьмимартим
			Пол = ПараметрыСеанса.ТекущийПользователь.ФизЛицо.Пол;
			Если Пол = Перечисления.ПолФизическихЛиц.Женский Тогда
			
				Поздравлялка8Марта = Обработки.Поздравлялка8марта.ПолучитьФорму();
				Поздравлялка8Марта.Открыть();
			
			КонецЕсли;
		
		КонецЕсли;
	
	КонецЕсли;
	
КонецПроцедуры // ПриНачалеРаботыСистемы()
...Показать Скрыть
27. Oleg karp (Oleg1708) 07.03.12 12:52 Сейчас в теме
28. Ловыгин Антон (wunderland) 199 23.02.13 11:25 Сейчас в теме
а тем кто под 7.7 спину гнет так и сидеть без поздравления?
29. vladal (Vladal) 23.02.13 12:19 Сейчас в теме
(28) wunderland, ну почему же? Есть несколько просмотрщиков.
И зачем сидеть без поздравления?
Можешь написать сам или помочь?
Оставьте свое сообщение