gifts2017

Отказ от создания ненайденных элементов при перегрузке с помощью Конвертации данных с предупреждением

Опубликовал Владимир Щербаков (sherbv) в раздел Программирование - Практика программирования

Иногда при перегрузке из одной базы в другую встает следующая задача:
В базе приемнике нельзя создавать элемент определенного вида справочника, но необходимо предупреждать пользователя о том, что такой элемент не был найден.

Конвертация данных предлагает стандартный механизм, позволяющий НЕ создавать НЕнайденные элементы. (рис.1)

Но этот механизм не предупреждает пользователя о том, что объект не найден.

Данную задачу можно было бы решить следующим образом:

Снять галку «Не создавать новый объект в приемнике, если он НЕ найден»

И прописать контроль создания элемента в обработчике загрузки справочника «После загрузки» (рис. 2)

Обработчик события После загрузки
Если НЕ ОбъектНайден Тогда
    Сообщить("Не найден " + Объект + " поиск идет по наименованию и дате рождения");
    Отказ = Истина;
КонецЕсли;

К сожалению, данный механизм работает только при выгрузке непосредственно этого справочника. Когда же элемент справочника выгружается по ссылке, программа все равно создает этот элемент.

Данную проблему можно решить с помощью следующего кода во все том же обработчике «После загрузки» (рис. 3)

Если НЕ ОбъектНайден Тогда
    Сообщить("Не найден " + Объект + " поиск идет по наименованию и дате рождения");
    Отказ = Истина;

    СписокУдаляемыхПодразделений = Новый СписокЗначений();

    Для Каждого СтрокаДанных Из мГлобальныйСтекНеЗаписанныхОбъектов Цикл
 
        ТекОбъект = СтрокаДанных.Значение.Объект;
        Если ТипЗнч(ТекОбъект) = Тип("СправочникОбъект.ФизическиеЛица") Тогда
            СписокУдаляемыхПодразделений.Добавить(СтрокаДанных.Ключ);
            НппСсылки = СтрокаДанных.Ключ;
            ДобавитьСсылкуВСписокЗагруженныхОбъектов(0, НппСсылки, ТекОбъект.Ссылка);
        КонецЕсли;
   
    КонецЦикла;

    Для Каждого Стр Из СписокУдаляемыхПодразделений Цикл
        мГлобальныйСтекНеЗаписанныхОбъектов.Удалить(Стр.Значение);
    КонецЦикла;

КонецЕсли;

Данный код анализирует список отложенных для записи объектов (именно оттуда и создаются элементы, когда они загружаются по ссылкам) и удаляет оттуда элементы нашего справочника.

Данный пример рассмотрен на основе конвертации справочника "Физические лица"

Возможно есть более оптимальные методы, буду рад их услышать.

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Gr0ck (gr0ck) 31.03.11 17:00
Здорово, жаль что поздно, уже сам разобрался в этом)
2. Сергей Начина (serg_gres) 01.04.11 00:33
Уже точно не помню как было дело, но у меня приблизительно такой же метод не сработал.
Причем если объектов < 5000 (есть переменная для кэширования такая) - то все ОК, если больше - все плохо.
Так и не разобрался в чем там было дело, пошел другим путем.

А на каких объемах Вы тестировали?
3. Владимир Щербаков (sherbv) 01.04.11 04:15
Объемы не такие большие, применял пару раз на 2000 тыс вроде и на 500
Подозревал, что на больших может не сработать.
4. Андрей Крутских (K_A_O) 08.04.11 19:10
Можно использовать обработчик "Поля поиска".
Там, кроме предупреждений можно организовать свой поиск по значениям, переданных как параметры
dima_gsv; +1 Ответить
5. Сергей Начина (serg_gres) 08.04.11 19:58
Блин, а ведь точно...
Надо будет попробовать.
6. dima_gsv (dima_gsv) 28.05.13 11:57
Спасибо за подсказку про "Поля поиска".
Я в обработчик "Поля поиска" ПКО вставил следующий код. Код до условия отрабатывает стандартный алгоритм поиска. Само условие - это наше предупреждение.
// сам поиск непосредственно и без алгоритма поиска
СсылкаНаОбъект = НайтиЭлементПоСвойствамПоиска(ТипОбъекта, ИмяТипаОбъекта, СвойстваПоиска, СтруктураСвойств, 
	СтрокаИменСвойствПоиска, ПоискПоДатеНаРавенство);
//
ОбъектНайден = ЗначениеЗаполнено(СсылкаНаОбъект);

ПрекратитьПоиск = Истина;

Если не ОбъектНайден Тогда
	Сообщить("Контрагент с ИНН (" + СвойстваПоиска["ИНН"] + ") не найден!");
КонецЕсли;
...Показать Скрыть

После загрузки все сообщения пропускаю через фильтр отсеивающий одинаковые строки и на выходе получаю то, что надо довнести ручками в базу. Фильтр одинаковых строк сделал в виде внешней обработки:
СписокУникальныхСтрок = Новый СписокЗначений;

Для ИИ = 1 По ЭлементыФормы.Текст.КоличествоСтрок() Цикл
	
	Стр = ЭлементыФормы.Текст.ПолучитьСтроку(ИИ);
	Если СписокУникальныхСтрок.НайтиПоЗначению(Стр) <> Неопределено Тогда
		Продолжить;
	КонецЕсли;
	
	СписокУникальныхСтрок.Добавить(Стр);
КонецЦикла;

ЭлементыФормы.Текст.Очистить();

Для каждого Стр Из СписокУникальныхСтрок Цикл

	ЭлементыФормы.Текст.ДобавитьСтроку(Стр);

КонецЦикла;
...Показать Скрыть
soft-servis; zul333; +2 Ответить
7. Lusha_28 (Lusha_28) 15.01.14 09:55
Спасибо за статью, очень помогла, у меня стояла задача в приемнике все ненайденные (т.е. их поля поиска) сложить в регистр сведений, Вашим способом хорошо получилось.
8. John Smith (PiccaHut001) 14.10.14 16:44
"К сожалению, данный механизм работает только при выгрузке непосредственно этого справочника. Когда же элемент справочника выгружается по ссылке, программа все-равно создает этот элемент." - И почему я не удивляюсь. Перенос данных без программирования, с этим справится любой квалифицированный пользователь...бла-бла-бла...прочее маркетинговое *овно от Бориса. 1С в очередной раз облажалась, опять приходится допиливать напильником
9. Андрей Кравчук (АндрейКр) 13.06.16 14:00
Спасибо! Очень помогло. Тоже столкнулся с этой проблемой. Если объект выгружается по ссылке, то нет возможности в "ПослеЗагрузки" отказать в этом. А у меня именно в ПослеЗагрузки есть возможность определить надо ли загружать объект.
Чтобы объект не загружался в "ПослеЗагрузки", использовал код:
Отказ=Истина;
ДобавитьСсылкуВСписокЗагруженныхОбъектов(НППГлобальнойСсылки, НппСсылки, Объект.Ссылка);
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа