gifts2017

Исправление некоторых ошибок ОС для перехода с ББУ7 на БГУ8

Опубликовал Владимир Московой (mvv1975) в раздел Отчеты - Бухгалтерские

Исправление ошибок ведения ОС на забалансе и проверка на уникальность инвентарных номеров.

Как известно в ББ? контроль за ведением учета был слабеньким.

 1. В частности по ОС на счете А21. Что делает обработка по кнопке "Признак списания при вводе в эксплуатацию у ОС забалансом":

 а. проставляет СписыватьПриПриемеКУчету=1 для ОС, с остатками на счете А21, если таковой не стоял

 б. СпособНачисленияАмортизации=1, т.е. "1- не начислять"

 в.  КоличественныйУчет=1 если Количество на остатке больше одного, т.е. по данному ОС ведется групповой учет

 

2. Главное, с чем я столкнулся и потерял много времени - так уж получилось что в справочнике ОС задвоились инвентарные номера (т.е. коды элементов). В базе вроде стоит галочка об уникальности, но вот такие вот дела.

по кнопке "Повторения инвентарных номеров" для каждого ОС с неуникальным номеров к инв. номеру приписывается буковка "к" - уникальность восстановлена.

Для справки: первый из партии двойников номер не меняет, второй будет с буквой "к", третий "к2" и т.д.

05.07.2011 Исправил обработку - справочник смотрю не по остаткам (иначе оставались повторения у списанных ОС), а именно справочник, ну и номера меняю, приписывая буквы алфавита по порядку - а, затем б и т.д. П.С. думал обработка уже не нужна никому, но вроде еще кто-то скачивает.

06.12.11 Хм. Давненько никого не переводил. Запустил свою обработку, а она оказывается не совсем правильно испраляла номера. Поправил. Теперь если номера повторяются трижды, до будут дописаны буквы "а" и "б". Если 4 раза - то "а", "б" и "в" и т.д.

Скачать файлы

Наименование Файл Версия Размер
Исправление ошибок ИБ ББУ7 910
.ert 62,00Kb
06.12.11
910
.ert 62,00Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. adeich adeich (adeich) 20.05.11 09:28
Молодец!!! При первых переносах писал подобную и исправлял UChoice, проверю твою в "действии".
Обработке однозначно +, тем более многие стали делать перенос еще только, а подводных камней там множество
2. adeich adeich (adeich) 20.05.11 22:06
проверил обработку, честно скажу РАБОТАЕТ, но..... Но столкнулся с таким, если длина номера уже 15 символов, т.е. максимальна, то присвоение номера не происходит. немного переделал для себя, сделал проверку на префикс и "обрезнание" значащих нулей
3. Владимир Московой (mvv1975) 20.05.11 22:15
(2) Точно. Если номера под завязку то будет трабл. Будет время, выведу в табличную часть - пусть бухи сами новые номера присваивают
4. adeich adeich (adeich) 21.05.11 12:43
(3) я поступил проще. Сделал формат номера чмсловым и отключил контроль уникальности, а уж потом запускал обработку.
Но эти "танцы с бубном" не для бухов, а для тех кто "понимает" :D
5. adeich adeich (adeich) 23.05.11 23:04
(3) в дополнение.
Проше, при прbcвоении нового инвномера брать не весь его, число от старого, обрезая префикс и лидирующие нули. Функцию проверки префикса можно вытащить из UChoice
6. Кира Борисова (bkn_oktava) 03.06.11 09:52
Спасибо за идею! Хорошо, что хоть кто-то занимается этим! :!:
7. Всеволод ------------- (brozex) 04.07.11 15:39
Меня больше интересовал вопрос восстановления уникальности инвентарных номеров. После первого прохождения обработки много исправились, но остались и одинаковые. Пришлось добавить счета С01,П01 и даже после этого они остались. Пришлось добавить этап 2- перебор именно по справочнику. Для переноса в ББУ 8.0 важна уникальность всего справочника, даже если ОС нет на остатках. Пример: ОС А и В имеют одинаковые инвентарные номера. А - на остатках нет, В есть. При загрузке правил переноса в БГУ у вас стоят все флажки, сначала переноситься справочник, а затем остатки. В итоге может получится так, что В не будет в справочнике вообще, а А появится в документах остатков. Всё равно Спасибо за обработку!
---------------------------------------------------------
Сообщить("Этап 2");
ТЗ.УдалитьСтроки();
СпрОС=СоздатьОбъект("Справочник.ОсновныеСредства");
СпрОС.ИспользоватьВладельца(ВыбраннаяФирма);
СпрОС.ПорядокНаименований();
СпрОС.ВыбратьЭлементы();
Пока СпрОС.ПолучитьЭлемент()=1 Цикл
ТЗ.НоваяСтрока();
ТЗ.ИнНомер = СпрОС.Код;
ТЗ.КолВо = 1;
КонецЦикла;
ТЗ.Свернуть("ИнНомер","КолВо");

ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
Если ТЗ.КолВо>1 Тогда
СпрОС.ВыбратьЭлементы(); Первый=1;
Пока СпрОС.ПолучитьЭлемент() = 1 Цикл
Если СокрЛП(СпрОС.Код)=СокрЛП(ТЗ.ИнНомер) Тогда
Если Первый=1 Тогда
Иначе
СпрОС.Код=Прав("000000000000000000000"+СокрЛП(ТЗ.ИнНомер)+"к"+Строка(Первый)),15);
СпрОС.Записать();
КонецЕсли;
Сообщить("Записан "+СокрЛП(СпрОС.Наименование)+" с инв. номером "+СокрЛП(СпрОС.Код)+" со стоимостью "+СокрЛП(СпрОС.ПервоначальнаяСтоимость));
Первый=Первый+1;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
8. Владимир Московой (mvv1975) 06.07.11 00:16
(7) Вы правы. Я обработку давно поправил - справочник смотрю не по остаткам, а именно справочник, ну и номера меняю, приписывая буквы алфавита по порядку - а, затем б и т.д.
Забыл обработку заменить
9. Anna Vlasova (Njurick) 08.07.11 20:50
Спасибо огромное!!! Очень выручили :)
10. Алексей Т (QwertyShum) 03.09.11 19:56
спасибо! Но у меня не получилось. В базе куча ОС с одинаковыми номерами (по 10-15 одинаковых встречаются). Обработка добавляет к ним букву "а". Получается такая же куча ОС с одинаковыми номерами, но еще с буквой "а".
11. Анна Код (annkod) 07.09.11 09:23
Спасибо, обработка очень помогает!
Для себя добавила еще одну процедурку по исправлению признака группового учета (мелочь, но мешает переносу).
Процедура ПризнакГрУчетаОС()
СпрОС=СоздатьОбъект("Справочник.ОсновныеСредства");
СпрОС.ИспользоватьВладельца(ВыбраннаяФирма);
СпрОС.ВыбратьЭлементы();
Пока СпрОС.ПолучитьЭлемент() = 1 Цикл
Если СпрОС.ЭтоГруппа()=1 Тогда Продолжить; КонецЕсли;
Если (СпрОС.ВидНФА<>Перечисление.ВидыНФА.ОС) и (СпрОС.ВидНФА<>Перечисление.ВидыНФА.Казна) и (СпрОС.КоличественныйУчет=1) Тогда
СпрОС.КоличественныйУчет=0;
Сообщить("Записано ОС "+СокрЛП(СпрОС.Код)+" "+СокрЛП(СпрОС.Наименование));
СпрОС.Записать();
КонецЕсли;
Если (СпрОС.СписыватьПриПриемеКУчету=1) и (СпрОС.КоличественныйУчет=0) Тогда
СпрОС.КоличественныйУчет=1;
Сообщить("Записано ОС "+СокрЛП(СпрОС.Код)+" "+СокрЛП(СпрОС.Наименование));
СпрОС.Записать();
КонецЕсли;

КонецЦикла;
КонецПроцедуры
12. Саша Ильиных (I2020) 10.09.11 12:09
Помогла неоднократно, еденственное способ начисления амортизации не для всех правильно ставится
13. Ирина (irina_ph) 16.09.11 20:22
Спасибо очень нужная вещь попробую в ближайшее время...
15. Ирина (irina_ph) 21.09.11 13:26
Скажите а кто-то использовал эту обработку в редакции 6.2?
16. lusefer 123456 (lusefer) 27.09.11 20:52
Помогла, огромное спасибо
17. Олег Наумов (Oleg51) 03.10.11 07:07
Спасибо, вещь нужная. Вот только если база с большим кол.-вом ошибок, то таким способом повторения
не ликвидируются(если десятками повторы есть). В 8-ке сервис->групповая обработка справочников и документов
позволяет все ошибки, связанные с порядком погашения стоимости и способом начисления амортизации(в случае, если
порядок погаш.стоим = начислять амортизацию) исправить за 10 минут.
18. Анна Тихонова (nu_to4ka) 06.10.11 08:31
Взяла за основу, спасибо за идею! Очень много времени экономит!
19. Богдан Максименко (bogdan87) 31.10.11 10:13
Спасибо за обработку! Экономит время при переносе!
20. Viktor (kurvik) 14.11.11 14:51
Как раз это и нужно.Замучались бухгалтера. Спасибо за разработку.
21. Андрей Т (Twirus) 15.11.11 10:03
Спасибо очень нужная вещь.
22. Антон Гутник (gudok1703) 29.11.11 20:19
Присоединяюсь к спискам благодарствующих++
23. Елена (ElenaV) 01.12.11 13:43
Очень много уходит времени на проверку правильности ведения ОС в ББУ77.
Иногда ошибки можно обнаружить только после переноса остатков и проведения документов в БГУ8.
На что уходит очень много времени и очень неудобно.
Надеюсь, что ваша обработка будет очень полезна.
Обязательно попробую.
24. Елена (ElenaV) 01.12.11 13:57
Проверила.
Очень полезная обработка.
Спасибо.
25. Марина Николаева (mnikol) 13.12.11 14:49
Несколько десятков подведомственных учреждений переводили с 7.7 на БГУ. Двойные инвентарные номера - пракимчески у всех и в огромном количестве. Ваша обработка - просто спасение. Спасибо!
28. denker (sergm79) 18.01.12 20:09
столько работы...спасибо - будем пробовать
29. Олег Коваленко (OleGazz) 18.01.12 20:15
спасибо, всё прошло оперативнинько)
30. анна Анютка (anna30) 22.01.12 15:19
а как ее открыть в 6.2? здесь формат epf...
31. Андрей Скачёк (Andro_sas) 29.01.12 14:03
Занят сейчас переходом. Буду пробовать вашим. Надеюсь поможет.
32. Андрей Скачёк (Andro_sas) 30.01.12 21:26
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(4761)}: Ошибка записи объекта
ТипОбъекта = Ввод остатков ОС и НМА
Объект = Ввод остатков ОС и НМА 00000003 от 31.12.2011 0:00:00
ОписаниеОшибки = Ошибка при вызове метода контекста (Записать): Номер года в литерале типа 'Дата' превышает 3999.
ПозицияМодуля = Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(4754)
КодСообщения = 26
ВызватьИсключение СтрокаСообщенияОбОшибке;
вот такая ошибка
33. Екатерина Мерзлякова (Katya.buh) 03.02.12 19:10
Как это все ко времени.Большое спасибо!!!!
34. элла иванова (2011b11) 06.02.12 13:04
Спасибки, действительно как все во время. Попробуем воспользоваться Вашим переходом.
35. Алекс Ю (AlexO) 14.02.12 01:41
А как работает обрабокта открыветсяв 8-ке и подключается к 7-ке? Как и где она ищет ошибки - из 8-ки подключением к 7-ке?
36. k (k) 14.02.12 09:06
подскажите, с чем может быть связано: после свертки базы на 31.12.11 не перносятся остатки из ББУ 7.7 в БГУ 8.2
37. Agema (Agema) 15.02.12 10:53
(36) k, не переносятся вообще? или останавливается на каком-то этапе?
Какая ошибка выскакивает? Может даты неправильно ставите ? Даты переноса я, например вообще не ставил.
И внимательно почитайте инструкцию по переносу - Rul77_BGU8.txt:
Инструкция по переносу данных из "1С:Бухгалтерии для бюджетных учреждений 7.7, ред. 6.2"
в "1С:Бухгалтерию государственного учреждения 8"
--
Автору обработки, спасибо!
38. Viktor (kurvik) 18.02.12 12:01
<<Очень много уходит времени на проверку правильности ведения ОС в ББУ77.
Иногда ошибки можно обнаружить только после переноса остатков и проведения документов в БГУ8.
На что уходит очень много времени и очень неудобно.
Надеюсь, что ваша обработка будет очень полезна. >>
-полность согласен с автором.Как раз приступили к переносу данных.База большая-времени мало.Спасибо за обработку и взаимовыручку.
39. Danazanat SSG (Danazanat) 04.03.12 22:06
В комплексе с другими обработки значительно ускоряет перенос. Правда про ЦМО так и не понял ... ))
41. Иванов Иван (ivan321) 27.03.12 12:41
Использовал обработку не раз, поскольку все переносимые базы были с ошибками. Спасибо.
42. Anatoliy (NOVOPRO) 13.04.12 07:54
Тоже возникла такая ошибка
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(4761)}: Ошибка записи объекта
ТипОбъекта = Ввод остатков ОС и НМА
Объект = Ввод остатков ОС и НМА 00000003 от 31.12.2011 0:00:00
ОписаниеОшибки = Ошибка при вызове метода контекста (Записать): Номер года в литерале типа 'Дата' превышает 3999.
ПозицияМодуля = Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(4754)
КодСообщения = 26
ВызватьИсключение СтрокаСообщенияОбОшибке;
вот такая ошибка
43. Александр Пушкин (Sasha25) 01.05.12 08:38
Спасибо обработка очень хорошая и очень помогла
44. Антон Смыслов (anton.smyslov) 02.05.12 20:10
Большое спасибо за обработку, очень полезная!
45. Антон Смыслов (anton.smyslov) 02.05.12 20:48
(36) k, вообще-то, выполнять свертку базы для переноса остатков из 7.7 в 8.2 не нужно. Просто нужно выполнить выгрузку данных при помощи специальных обработок.
46. Антон Смыслов (anton.smyslov) 09.05.12 06:25
Может я не совсем правильно понял, эта обработка открывается через меню "Сервис-Дополнительные возможности"? У меня выдает ошибку при открытии
ОткрытьФорму("Отчет",,ТекущийКаталог+Отчеты.ФайлОтчета);
{Обработка.ДополнительныеВозможности.Форма.Модуль(147)}: Ошибка создания внешнего отчета D:\1С\Базы 1С\77777777\Гикало\ExtForms\ISPRAVLENIEOSHIBOKIB.ert

причем пытался открыть и в редакции 6.1 и в 6.2
47. Agema (Agema) 09.05.12 07:43
(46) anton.smyslov,
эта обработка открывается через меню "Сервис-Дополнительные возможности"?

Так добавляют в список и потом можно открыть, а можно сразу с любого места запустить: Файл-Открыть и ткнуть на обработку.
Такая ошибка может возникнуть по разным причинам. Вот некоторые из них:
-платформа 1С7 ниже 27
-проблемы с сетью
-диск поврежден, или вирус
-"кашперский"
48. Александр (T-AleXandr) 16.05.12 22:39
Очень нужная обработка при переходе с 7.7 на 8. Особенно заинтересовал Контроль уникальности Инвентарных номеров в справочнике Основных средств. Обязательно попробую, хотя считаю что лучше добавлять не буквы, а цифры (установить количество знаков предельно допустимых для задвоенных Основных средств) через дефис после основного Инвентарного номера.
52. Аня Босая (Leanna) 12.01.14 19:49
Большое спасибо, в свое время при переносе помогло.
53. tazmag tazmag (tazmag) 03.07.14 14:40
Да уж сколько не переносил базы почти во всех бывают косяки о ошибки в ОС, если бы не обработка пришлось бы пальцами лопатить
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа