gifts2017

Консоль администратора

Опубликовал Александр Шкураев (salexdv) в раздел Администрирование - Системное

Поклонникам командной строки посвящается!
Обработка призвана облегчить труд администратора(программиста).
Позволяет упростить выполнение часто используемых действий.

Назначение:

  • Открытие форм списка справочников, документов, обработок и отчетов
  • Упрощенный запуск произвольных алгоритмов
  • Вычисление простых арифметических выражений (миникалькулятор)


Есть помощь в наборе команд и имен справочников(документов).

Есть возможность передавать в команды параметры.

Для себя сделал так: Добавил обработку в конфигурацию, затем добавил в меню пункт с обработкой и назначил ему сочетание клавиш.
Теперь у меня на CTRL+F12 появляется консоль. Выполнять частые действия стало проще и приятней :-).

Настройки пользовательских команд сохраняются в каталоге программы в файле SettingsCA.xml.
Есть возможность экспорта/импорта данных настроек.

Для получения справки необходимо набрать команду "/?"

Приятного пользования! Smile

http://shkuraev.ru

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
КонсольАдминистратора.epf
.epf 18,17Kb
22.07.11
314
.epf 18,17Kb 314 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

0. Александр Шкураев (salexdv) 21.07.11 12:09
Поклонникам командной строки посвящается!
Обработка призвана облегчить труд администратора(программиста).
Позволяет упростить выполнение часто используемых действий.

Перейти к публикации

1. Сергей Рудаков (fishca) 21.07.11 12:09
2. Alxd (salexdv) 21.07.11 12:30
(1) Хотел вообще как в игрушках, по кнопке ~ и с полупрозрачностью :D
3. Павел Кострома (minikos) 21.07.11 12:34
{ВнешняяОбработка.КонсольАдминистратора.МодульОбъекта(144)}: Ошибка при вызове метода контекста (ОткрытьФайл): Ошибка доступа к файлу 'C:\Program Files\1cv82\8.2.13.219\bin\SettingsCA.xml'

Как так?

Параметры нельзя в команды передавать? Было бы очень не плохо...
4. Alxd (salexdv) 21.07.11 12:47
(3) Может правов нет?

Насчет параметров я думал. Надеюсь скоро реализовать.
Будет что-то типа
"УбитьПользователя &Иванов"
5. Павел Кострома (minikos) 21.07.11 12:54
(4) да, извиняюсь, все ок... 1С не под админом запущена.
6. Сергей Рудаков (fishca) 21.07.11 13:03
(4)
"УбитьПользователя &Иванов"

Казнить нельзя помиловать :D или же "РасстрелятьПользователя &Иванов" :D
7. Alxd (salexdv) 21.07.11 14:21
Добавил возможность передавать в команду параметры.
Количество параметров не ограничено. В алгоритме команды они доступны через структуру "ПараметрыКоманды".
Вызов осуществляется так:
<ИмяКоманды> &<Параметр0> &<Параметр1> &<Параметр и т.д.>

УбитьПользователя &Иванов &Срочно! :)
8. UncleVader (UncleVader) 22.07.11 10:16
Классная задумка!
Но с полтычка не взлетела :(

написал команду ПартииТовара
ТекТовар = Справочники.Номенклатура.НайтиПоКоду(ПараметрыКоманды.Параметр0);
Если ТекТовар=Неопределено Тогда
	Сообщить("Не найден товар с кодом "+ПараметрыКоманды.Параметр0);
	Возврат;
Иначе
	Сообщить("Найден товар "+ТекТовар);
КонецЕсли;
ТЗ = РегистрыНакопления.ПартииТоваров.Остатки(,Новый Структура("Товар",ТекТовар));
ТЗ.ВыбратьСтроку();
...Показать Скрыть


при ее вызове получаю
console> партиитовара &1
{Обработка.КонсольАдминистратора.Форма.Форма.Форма(104)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода

Что не так?
9. UncleVader (UncleVader) 22.07.11 10:23
Кажется понял, некорректно отрабатывается "Возврат"
10. Alxd (salexdv) 22.07.11 10:31
(9) Возврат неоткуда делать.
Алгоритмы все же должны быть "Особыми" :-)
11. UncleVader (UncleVader) 22.07.11 11:05
Предложения
мелкий тюнинг:
1. Добавить сплиттер в окно настройки параметров
2. Скролить историю команд курсорными кнопками не в цикле, а снизу доверху
из глобального:
Насколько реально реализовать на упр. формах?
12. Alxd (salexdv) 22.07.11 11:42
(11) 1 и 2 сделаю
А вот с управляемыми формами будет изврат. Надо будет делить команды на клиентские и серверные
и выполнять их разными методами, что-то вроде

&НаСервере
Функция ВыполнитьСервернуюКоманду(Алгоритм)
Выполнить(Алгоритм)
КонецФункции

&НаКлиента
Функция ВыполнитьКлиентскуюКоманду(Алгоритм)
Выполнить(Алгоритм)
КонецФункции

Вот только как взаимодействовать между сервером и клиентом - никак :)
Поковыряюсь, может реализую
13. Ярослав Радкевич (WKBAPKA) 22.07.11 14:54
Полезная вещь. но нет возможности открывать отчеты :(
14. Alxd (salexdv) 22.07.11 15:22
15. Maxim Kolkin (the1) 22.07.11 15:34
Беспощадно плюсую! Этапять!
16. Alxd (salexdv) 22.07.11 15:37
17. Alxd (salexdv) 22.07.11 15:38
(11) Сделал мелкий тюнинг
(13) Добавил возможность открывать отчеты
18. UncleVader (UncleVader) 22.07.11 19:59
Встроил в свою нетленку, как зафиксировать авторство? ;)
19. Andrey Krapivin (kr_andr) 23.11.11 10:28
20. Alxd (salexdv) 23.11.11 12:29
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа