gifts2017

Отправка почты с использованием основного почтового клиента ОС

Опубликовал Kostya Petrov (Администратор 1С) в раздел Программирование - Универсальные функции

В публикации описан фрагмент кода, позволяющий отправлять печатные формы с помощью почтового клиента операционной системы (напр. Outlook, Bat и т.д.)

В Управлении торговлей 10.3 в печатных формах документов есть кнопка "отправить по электронной почте", правда ей можно воспользоваться,  если в настройках учета установлена галка "использовать встроенный почтовый клиент". Т.к. встроенный почтовый клиент часто не используют, этот удобный механизм не задействуется. Поэтому для отправки печатной формы накладной необходимо ее сначала сохранить на диск, затем вложить в письмо внешнего почтового клиента.

 Ниже описаны изменения в конфигурации, которые необходимо внести, для автоматического создания письма во внешнем почтовом клиенте по  кнопке "отправить по электронной почте ". Тестировалось для 8.1 УТ 10.3.

  1. Для начала в конфигураторе, если не включена возможность изменений, ее необходимо включить (конфигурация - поддержка- настройка поддержки)

  2. Добавить общий модуль "_управлениеПочтой" (см. рис2), в него скопировать процедуры: "ОтправитьПечатнуюФормуВнешнимТранспортом" и "КорректировкаНаименования" (ниже приведены см. п. 4).

  3. В общем модуле "УправлениеОтчетами" отредактировать процедуру "ОтправитьДокументПоЭлектроннойПочте", закомментировав сообщение и добавив вызов нашей процедуры "ОтправитьПечатнуюФормуВнешнимТранспортом". Редактируемый фрагмент этой процедуры:

	 Если НЕ Константы.ИспользованиеВстроенногоПочтовогоКлиента.Получить() Тогда
    //ОбщегоНазначения.СообщитьОбОшибке("Отправлять документы по электронной почте можно только из встроенного почтового клиента.
    // |В настоящее время в настройках параметров учета установлено использование основного почтового клиента операционной системы.");
    //Предупреждение("Операция не выполнена");
    _управлениеПочтой.ОтправитьПечатнуюФормуВнешнимТранспортом (Документ, УправлениеПользователями.ПолучитьЗначениеПоУмолчанию     (ПараметрыСеанса.ТекущийПользователь,"ОсновнойКаталогФайлов"),ИмяФайлаВложения); // изменения программиста начало
    Возврат;
КонецЕсли;

     4. Текст модуля  _управлениеПочтой:
 
Процедура ОтправитьПечатнуюФормуВнешнимТранспортом (ПолеТабличногоДокумента, КаталогФормирования="",имяФайлаВложения) Экспорт

    Расширение="xls";

    Файл = Новый Файл(КаталогФормирования);
    Если Файл.Существует() Тогда
        ИмяФайла = КаталогФормирования;
    Иначе
        ИмяФайла = КаталогВременныхФайлов();
    КонецЕсли;

    Если Не ПустаяСтрока(ИмяФайла) Тогда
        Если Не Прав(ИмяФайла, 1) = "\" Тогда
            ИмяФайла = ИмяФайла + "\";
        КонецЕсли;
    КонецЕсли;

    ОтносительноеИмя =КорректировкаНаименования(имяФайлаВложения, ложь);
    ИмяФайлаБезРасширения = ИмяФайла + ОтносительноеИмя;

    ИмяФайла = ИмяФайлаБезРасширения + ".xls";
    ПолеТабличногоДокумента.Записать(ИмяФайла, ТипФайлаТабличногоДокумента.XLS97);

    Почта=Новый Почта;
    Почта.Подключиться();
    Сообщ=Новый ПочтовоеСообщение;
    Сообщ.Тема=имяФайлаВложения;
    Сообщ.Текст="";
    ВыбФайл=Новый Файл(ИмяФайла);
    Если ВыбФайл.Существует() Тогда
        Данные=Новый ДвоичныеДанные(ИмяФайла);
        Сообщ.Вложения.Добавить(Данные,ВыбФайл.Имя);
    КонецЕсли;
    //УчетнаяЗапись=УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ПараметрыСеанса.ТекущийПользователь,"ОсновнаяУчетнаяЗапись");
    //Сообщ.Получатели.Добавить(УчетнаяЗапись.АдресЭлектроннойПочты);
    Почта.Послать(Сообщ,);
    Почта.Отключиться();

    Попытка
        УдалитьФайлы(ИмяФайла);
        //Сообщить("Удален файл "+ИмяФайла);
    Исключение
        Сообщить(ОписаниеОшибки());
    КонецПопытки;

КонецПроцедуры


Функция КорректировкаНаименования(Знач ИсходнаяСтрока, Выводитьсообщения=Истина)

    Наименование=СокрЛП(ИсходнаяСтрока);
    ДлиннаНаим=СтрДлина(Наименование);
    СписокЗаменяемыхимволов=новый СписокЗначений;

    Если ДлиннаНаим=0 Тогда
        Сообщение="Не заполнена проверяемая строка!";
        #Если Клиент Тогда
            Если Выводитьсообщения Тогда
                Сообщить(Сообщение);
            КонецЕсли;
        #КонецЕсли
    КонецЕсли;

    Для i=0 По ДлиннаНаим-1 Цикл  
        Стр=Прав(Наименование,ДлиннаНаим-i);  
        // руск. алф. 192- 255 англ. алф. мал. 65-90 англ. алф. бол. 97-122 пробел=32 цифры АSCI дес.
        Если (((КодСимвола(Стр)>1039) И (КодСимвола(Стр)<1106)) ИЛИ ((КодСимвола(Стр)>64) И (КодСимвола(Стр)<94)) ИЛИ ((КодСимвола(Стр)>96) И (КодСимвола(Стр)<123)) ИЛИ ((КодСимвола(Стр)>47) И (КодСимвола(Стр)<58)) И (КодСимвола(Стр)<>32)) Тогда
        Иначе
            СписокЗаменяемыхимволов.Добавить(Лев(Стр,1));
        КонецЕсли;
    КонецЦикла;

  Для каждого ЭлементСписка Из СписокЗаменяемыхимволов Цикл
      Если ЭлементСписка.Значение=" " Тогда
          Наименование=СтрЗаменить(Наименование,ЭлементСписка.Значение,"_");
          Сообщение="В наименование колонки "+ИсходнаяСтрока+" встречается недопустимый символ (пробел) "+ЭлементСписка.Значение+", он будет заменен на '_'";
          #Если Клиент Тогда
              Если Выводитьсообщения Тогда
                  Сообщить(Сообщение);
              КонецЕсли;
          #КонецЕсли
      Иначе
          Наименование=СтрЗаменить(Наименование,ЭлементСписка.Значение,"");
          Сообщение="В наименование колонки "+ИсходнаяСтрока+" встречается недопустимый символ "+ЭлементСписка.Значение+", он будет удален";
          #Если Клиент Тогда
              Если Выводитьсообщения Тогда
                  Сообщить(Сообщение);
              КонецЕсли;
          #КонецЕсли  
        КонецЕсли
    КонецЦикла;
    Возврат Наименование;
КонецФункции

См. также

Подписаться Добавить вознаграждение
Комментарии
0. Kostya Petrov (Администратор 1С) 22.09.11 05:08
В публикации описан фрагмент кода, позволяющий отправлять печатные формы с помощью почтового клиента операционной системы (напр. Outlook, Bat и т.д.)

Перейти к публикации

1. Доржи Балбаров (Angeros) 22.09.11 05:08
Спс. Идея обязательно пригодиться.
2. Сергей (sstar90) 22.09.11 12:21
Спасибо за идею, попробуем
3. Сергей (Che) Коцюра (CheBurator) 22.09.11 21:05
как в снеговике это с извращениями сделано...
открой для себя
1. встроенный в винды штатный транспорт отправки писем CDO
.
на 7.7 в любой конфигурации для ЛЮБОГО отчета достаточно всего одной обработки
http://infostart.ru/public/14180/
http://infostart.ru/public/14131/
4. Kostya Petrov (Администратор 1С) 22.09.11 21:24
(3) CheBurator,
О CDO знаю, твои обработки конечно хороши, но есть недостаток - письмо отправленное через CDO не сохранится в корпоративной почте в папке исходящие.
5. Kostya Petrov (Администратор 1С) 22.09.11 21:29
(3) а этот момент иногда является принципиальным
6. Константин (Kazan) 12.10.11 05:21
Не проходит авторизацию пока ручками не откроешь клиент. win live mail 2011
7. Анна Плевако (plevako) 12.10.11 14:48
8. Евгений Левченко (MYRZILKA123) 21.10.11 16:25
спасибо попробовал теперь пользуюсь.
9. Александр (Sanek_159) 11.05.12 15:12
Здравствуйте!
Конфигурация УПП 1.3.25
Когда делаю отправку из 1C появляется окно с сообщением: "С запрошенным действием не связана программа электронной почты.Установите программу электронной почты или,если она уже установлена,создайте связь в панели управления "Программы по умолчанию""
Если вхожу в Панель управления-Программы по умолчанию там всегда выбрана конфигурация Другая. Редактирую ее-выставляю Mozilla Thunderbird как почтовую программу по умолчанию, жму ОК. Перезахожу-все остается на своих местах. Если выбираю другую конфигурацию(Microsoft Windows или Не Microsoft) то все равно активной остается конфигурация Другая.
PS: пробовал с другого ПК где установлен outlook 2010, ничего не происходит и ошибка не вываливается. Подскажите, пожалуйста, что может быть не так?
10. Kostya Petrov (Администратор 1С) 12.05.12 19:01
Я не силен в настройках ОС, а я так понимаю дело именно в них. Код рабочий. У вас работает пункт меню Windows "отправить->адресат", вызываемый по щелчку правой кнопки мыши на любом файле?
Вот что яндекс говорит, может поможет: "http://forum.windowsfaq.ru/showthread.php?t=91294"
11. Ivan Haos (haous) 03.10.12 16:19
А для УТП для Украины 8.2 подойдет?
12. Kostya Petrov (Администратор 1С) 05.10.12 16:48
Попробуйте,
скорее всего да
13. Константин Купрюхин (BlackStar) 19.12.12 17:00
А с MS Outlook работает у кого нибудь? У меня при нажатии на отправку на секунду часы появляются, и больше ничего, почтовый клиент не открывается. При этом пункт меню Windows "отправить->адресат" работает нормально
14. isn Игнатьев (isn) 22.05.13 10:04
Здравствуйте!
Вы можете в пункте 3 опубликовать всю процедуру которая в итоге должна появится?
15. Kostya Petrov (Администратор 1С) 22.05.13 19:04
(14) isn,

В моем релизе (10.3.10.14) она с учетом моих правок выглядит так:

Процедура ОтправитьДокументПоЭлектроннойПочте(Документ, ИмяФайлаВложения = "") Экспорт

Если НЕ Константы.ИспользованиеВстроенногоПочтовогоКлиента.Получить() Тогда
//ОбщегоНазначения.СообщитьОбОшибке("Отправлять документы по электронной почте можно только из встроенного почтового клиента.
// |В настоящее время в настройках параметров учета установлено использование основного почтового клиента операционной системы.");
//Предупреждение("Операция не выполнена");
_управлениеПочтой.ОтправитьПечатнуюФормуВнешнимТранспортом (Документ, УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ПараметрыСеанса.ТекущийПользователь,"ОсновнойКаталогФайлов"),ИмяФайлаВложения); //изменения программиста
Возврат;
КонецЕсли;

ФормаОтправкиДокумента = ПолучитьОбщуюФорму("НастройкаОтправкиОтчета");
ФормаОтправкиДокумента.Отчет = Документ;
ФормаОтправкиДокумента.ИмяФайлаВложения = СтрЗаменить(ИмяФайлаВложения, ".", " ");
ФормаОтправкиДокумента.ТемаСообщения = ИмяФайлаВложения;
ФормаОтправкиДокумента.ОткрытьМодально();

КонецПроцедуры
16. Александр (Sanek_159) 29.08.13 11:00
(13) BlackStar, Тоже не открывается (Outlook 2010), часы на секунду и все. Удалось решить кому проблему?
При использовании программы по умолчанию Mozilla Thunderbird открывается только программа, но не создается новое письмо, в чем может быть проблема?
17. Александр Никитин (AHuk) 04.09.13 18:22
Спасибо огромное. Но есть вопрос, как передать тему и текст и получателя - это ясно, но можно ли передать текст в HTML коде? и у меня вложения в виде "v8_C56_7a.tmp" формируется, в чём может быть проблема?
Прикрепленные файлы: