gifts2017

ЗиК 314 Отчет по перечислению НДФЛ в бюджет

Опубликовал Николай Таскаев (niktas2009@yandex.ru) в раздел Отчеты - Бухгалтерские

Отчет о перечисленных суммах НДФЛ. Показывает суммы исчисленных, удержанных, перечисленных налогах по разным ставкам и остаток, если не все налоги удалось правильно перечислить.
Исправлена ошибка по дате периода документов.

Отчет о перечисленных суммах НДФЛ. Показывает суммы исчисленных, удержанных, перечисленных налогах по разным ставкам и остаток если не все налоги удалось правильно перечислить.
Подразумевается, что налоги перечисляются в текущем месяце и месяце следующем за расчетным периодом. Т.е. в отчет попадают документы перечисления НДФЛ с налогами периода ЯНВАРЬ, которые введены по дате в январе или феврале. Для ввода использовалась измененная процедура стандартного документа "Перечисление НДФЛ в бюджет". http://infostart.ru/public/86020/

Скачать файлы

Наименование Файл Версия Размер
ВедомостьНДФЛ.ert 92
.ert 80,50Kb
27.03.12
92
.ert 80,50Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Александр Лыткин (TrinitronOTV) 10.10.11 18:20
2. rimma_n (rimma_n) 11.10.11 11:18
Огромный ----------! обработка не работает!!! Автор тупо скопировал куски из разных обработокэ Поясняю:

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(РасчВед)
|Период с НачПериода по КонПериода;
|Сотрудник = ЖурналРасчетов."+ЖурналДляЗапроса+".Объект;
|ФизЛицо = ЖурналРасчетов."+ЖурналДляЗапроса+".Объект.ОсновнойЭлемент;
|Должность = ЖурналРасчетов."+ЖурналДляЗапроса+".Объект.ОсновнойЭлемент.Должность;
|Подразделение = ЖурналРасчетов."+ЖурналДляЗапроса+".Объект.ОсновнойЭлемент.Подразделение;
|Расчет = ЖурналРасчетов."+ЖурналДляЗапроса+".ВидРасч;
|Результат = ЖурналРасчетов."+ЖурналДляЗапроса+".Результат;
|Функция НДФЛ = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛ);
|Функция НДФЛУд = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛУдержанный);
|Функция НДФЛсД = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛсДивидендов);
|Функция НДФЛсДУд = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛсДивидендовУдержанный);
|Функция НДФЛпо35 = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛпо35процентов);
|Функция НДФЛпо35Уд = Сумма(Результат) когда (Расчет=ВидРасчета.НДФЛпо35процентовУдержанный);";
ТекстЗапроса = ТекстЗапроса + "
|Группировка ФизЛицо без групп;";

Это первый запрос - собираются начисленный НДФЛ. Группировка по ФизЛицо!

..................

далее запрос по документу Перечисление НДФЛвБюджет:

ЗапросКДокументам = СоздатьОбъект("Запрос");
НачалоПериода = НачМесяца(ДатаАктуальности);
КонецПериода = КонМесяца(ДатаАктуальности);
//Перечисления могут быть в следующем месяце по дате документа но Месяц налогового периода другой
КонецПериодаПлюс = КонМесяца(ДОБАВИТЬМЕСЯЦ(ДатаАктуальности,1));
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с НачалоПериода по КонецПериодаПлюс;
|Обрабатывать НеПомеченныеНаУдаление;
|ДокументПеречНДФЛ = Документ.ПеречислениеНДФЛВБюджет.ТекущийДокумент;
|Сотрудник = Документ.ПеречислениеНДФЛВБюджет.Сотрудник;
|Подразделение = Документ.ПеречислениеНДФЛВБюджет.Сотрудник.Подразделение;
|СтавкаДок = Документ.ПеречислениеНДФЛВБюджет.Ставка;
|СуммаДок = Документ.ПеречислениеНДФЛВБюджет.Сумма;
|Функция ПеречисленоНДФЛ = Сумма(СуммаДок) когда ((СтавкаДок=13)или(СтавкаДок=30)) ;
|Функция ПеречисленоНДФЛсД = Сумма(СуммаДок) когда ((СтавкаДок=9)или(СтавкаДок=15)) ;
|Функция ПеречисленоНДФЛ35 = Сумма(СуммаДок) когда (СтавкаДок=35);
|Группировка Сотрудник;
|Условие(ДокументПеречНДФЛ.МесяцНалоговогоПериода = КонецПериода);
|Условие(Сотрудник в СписокСотров);
|"//}}ЗАПРОС
;

1 ошибка.Обратите внимание - группировка по Сотрудник! напоминаю - Физлицо из первого запроса - это Сотрудник.Основной элемент.

2 ошибка. Условие(ДокументПеречНДФЛ.МесяцНалоговогоПериода = КонецПериода)
Если посмотреть документ ПеречислениеНДФЛВБюджет, то там МесяцНалоговогоПериода - это начало периода.
т.е. документы не находятся в любом случае. а если и найдутся(!?), то далее

Пока ТаблицаНДФЛ.ПолучитьСтроку() =1 Цикл
Сотр = ТаблицаНДФЛ.ФизЛицо;
НомерСтроки = 0;
Если ТаблицаПеречНДФЛ.НайтиЗначение(Сотр,НомерСтроки,"Сотрудник")=1 Тогда

конечно же, фигушки. сотрудник и физлицо - разные элементы
Автор проверял хоть свою обработку перед публикацией?
Помещаю исправленную http://infostart.ru/public/93931/
3. Александр Лыткин (TrinitronOTV) 11.10.11 14:42
жаль, что такие вещи бывают
4. niktas (niktas2009@yandex.ru) 11.10.11 16:57
(2) rimma_n,

ФизЛицо не мешает просто по совместителям внутренним налог считается по Основному элементу.

А с датой да промашка
Сбило с толку это ----- при смене периода Дата становится КонецПериода

//******************************************************************************
// глСменитьПериод(ДатаАктуальности,Направление)
//
// Параметры:
// ДатаАктуальности- дата
// Направление - направление сдвига даты:
// 1 - увеличивает на один период журнала расчетов,
// -1 - уменьшает на один период журнала расчетов,
// 0 - не изменяет
// (по умолчанию 0)
//
// Возвращаемое значение:
// Возвращает описатель периода журнала расчетов, соответствующий новому значению
// параметра ДатаАктуальности.
//
// Описание:
// В зависимости от указанного направления сдвигает параметр ДатаАктуальности на
// один период журнала расчетов.
// Если дата не задана, устанавливает изначально конец текущего периода журнала
// расчетов Зарплата.
// ДатаАктуальности всегда устанавливается в конец периода журнала.
//
Функция глСменитьПериод(ДатаАктуальности,Направление=0) Экспорт
ЖР = СоздатьОбъект("ЖурналРасчетов.Зарплата");
Если ТипЗначения(ДатаАктуальности)<>3 Тогда
ДатаАктуальности = ЖР.КонецТекущегоПериода()
КонецЕсли;
Если Направление=1 Тогда
ДатаАктуальности = ЖР.КонецПериодаПоДате(ЖР.КонецПериодаПоДате(ДатаАктуальности)+1)
ИначеЕсли Направление=-1 Тогда
ДатаАктуальности = ЖР.НачалоПериодаПоДате(ДатаАктуальности)-1
КонецЕсли;
Возврат ЖР.ОписательПериода(ДатаАктуальности)
КонецФункции // глСменитьПериод
5. Валентина Романова (still_) 19.10.11 09:41
Не сразу въехала, но мне немного непонятно зачем такая табличка нужна. Когда формируешь ведомость за месяц, там тоже самое стоит. А форма 2 НДФЛ формирует исчисленный налоги с начала года. Может я не поняла в чем тут суть. А?
6. Android Android (Rodriguezz) 01.11.11 04:16
Тоже не могу понять суть данной обработки.
7. Anna (AB3012) 21.12.11 15:26
Не сразу въехала, но мне немного непонятно зачем такая табличка нужна. Когда формируешь ведомость за месяц, там тоже самое стоит. А форма 2 НДФЛ формирует исчисленный налоги с начала года.
8. Ruslan (flash82) 02.02.12 07:48
9. Vladimir (Boroda) 30.03.12 23:48
ЗиК 314...? А если не секрет, зачем сдавать НДФЛ из такого древнего релиза? Там и формат выгружаемого файла, очевидно, старый, не соответствует последним требованиям...