gifts2017

СТАБИЛЬНАЯ Загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в Excel (код открыт скачать можно бесплатно)

Опубликовал ренат васильев (SkyLink2012) в раздел Обмен - Загрузка и выгрузка в Excel

В таких случаях многие заказывают соответствующие обработки у собственных штатных программистов, фирм-франчайзи или сторонних разработчиков, но это дополнительные расходы и время.

Как быть, если по различным причинам такой возможности нет?

У каждого пользователя профессиональной версии 1С:Предприятие 8 подобная обработка уже есть! На диске ИТС!

Типовая обработка «ЗагрузкаДанныхИзТабличногоДокумента.epf», находиться в разделе «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

Обратите внимание, начиная с Февраля 2010 г. на диске ИТС данная обработка для конфигураций на платформе 8.1 находиться в другом разделе: «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Платформа 1С:Предприятие 8.1» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

 

Загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в Excel

Имеются исходные данные:

  • Прайс-лист в Excel «ПрайсОнлайнХимСнаб.xls» — Microsoft Office Excel 97-2003 (.xls)
  • Типовая конфигурация Управление торговлей Ред.10.3, релиз 10.3.10.4, платформа 8.2 (8.2.10.77)
  • Необходимо загрузить в 1С из Excel не только наименования товаров и цены как в Примере 1, а также артикулы и штрих-кода, при этом необходимо чтобы номенклатура загружалась не в один каталог (группу), а распределялась по производителям в справочнике номенклатуры 1С.

загрузка 1с +из excel

Для того чтобы из Прайс-листа можно было загрузить справочник номенклатуры в 1С:Управление торговлей 8 с автоматическим распределением по группам (производители) необходимо будет подготовить форму файла для загрузки. Понадобиться добавить колонку с указанием единицы измерения (шт.) и производителя товара, при этом наименование производителя в прайс-листе должно соответствовать наименованию группы в справочнике номенклатуры программы 1С:Управление торговли 8.

1с 8 excel

Используем типовую обработку «ЗагрузкаДанныхИзТабличногоДокумента.epf» которая идет на ИТС.

1. Запускаем программу 1С

2. Для запуска обработки выбираем пункт меню «Файл»>«Открыть».

выгрузка в 1с из excel

3. В октрывшемся окне находим файл обработки, который располагается на диске ИТС в каталоге \1CIts\EXE\EXTREPS\UNIREPS82\UploadFromTableDocument

Если предварительно вы скопировали файл обработки на свой компьютер, то можете выбрать его.

ex2_04.jpg

Откроется окно

1с 8.1 excel

Обратите внимание, что загрузка данных будет осуществляться в три этапа:

Этап 1 — загрузка наименований и установка значений реквизитов новых элементов справочников необходимых для начала работы (единица измерения, ставка НДС, признак товар/услуга). 
Этап 2 — загрузка цен. 
Этап 3 — загрузка штрих-кодов

4. Этап 1. Загрузка наименований

Устанавливаем «Режим загрузки» — Загрузка в справочник

«Вид справочника» — Номенклатура

1с 8.2 excel

5. В закладке «Табличный документ» нажимаем кнопку image011.jpg«Открыть файл», в появившемся окне выбора находим каталог, в котором у нас находиться прайс-лист в Excel из которого мы планируем загружать данные в 1С.

загрузка из excel 1с 8

Первоначально файл может не отобразиться. Установите Тип файла «Лист Excel (*.xls)»

импорт из excel в 1с

Выбираем наш файл

номенклатура из excel в 1с

Файл успешно прочитался

7. Далее выбираем закладку «Настройка»

1с загрузка из excel

Отражаются реквизиты карточки номенклатуры.

загрузка справочников 1с из excel

8. Настраиваем параметры загрузки наименований

Для удобства установим «Ручную нумерацию колонок»

На данном этапе загружаем только те реквизиты, которые позволят начать работать с программой, поэтому снимаем галочки с полей, которые нас пока не интересуют

«Первая строка данных табличного документа» — смотрим наш прайс-лист, отбрасываем шапку, данные для загрузки начитаются с девятой строки — ставим «9» (см.Рис. 2 «Прайс-лист»)

«Не создавать новых элементов» — галочку НЕ ставим, опция нужна, если планируем только изменять уже имеющиеся элементы.

ex2_12.jpg

Строки «Наименование» и «Полное наименование» — устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе наименование в третьей колонке — ставим «3»

Строка «Родитель» — в колонке «Режим загрузки» выбираем «Искать», в колонке «№ Колонки табличного документа» — в нашем прайс-листе производители в четвертой колонке — ставим «4».

Если необходимости распределения по производителям нет и загрузить все новые элементы требуется в одну папку, тогда в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем группу номенклатуры, в которую будем загружать данные из прайс-листа.

Строка «Артикул» — ставим галку в колонке «Поле поиска» (вторая колонка) — программа проверит наличие в базе данных 1С элемента с таким артикулом, и если таковой уже существует, то новый элемент с таким наименованием создаваться не будет. Устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе артикул во второй колонке — ставим «2»

Строка «Базовая единица измерения» — в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем единицу измерения (в нашем случае — шт.)

Строка «Весовой» — в нашем случае товар НЕ весовой, поэтому «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Нет»

Строка «Ставка НДС» — в нашем случае для всех загружаемых элементов устанавливаем НДС 18%, для этого в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «18%».

1с 8.2 загрузка из excel

Если товары идут с разным НДС, который указывается в отдельной колонке загружаемого прайс-листа, то в колонке «Режим загрузки» установите «Искать» и номер соответствующей колонки прайс-листа в «№ Колонки табличного документа».

Строка «Услуга» — в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Нет» (в нашем случае все позиции это товары).

Строка «Вид номенклатуры» — в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Товар».

Мы задали минимальные значения новых элементов справочника номенклатуры, которые позволят начать работать.

Если вы готовы задать значения недостающих реквизитов сейчас, то укажите и их.

Нажимаем «Загрузить» в правом нижнем углу, на вопрос нажимаем «Да»

перенос в 1с из excel

как загрузить в 1с excel

Если загрузка пройдет нормально, то по результатам будет выдано сообщение об успешной загрузке.

8. Проверяем наличие новых элементов в соответствующих группах справочника номенклатуры.

ex2_16.jpg

ex2_17.jpg

На настоящий момент мы загрузили из прайс-листа в Excel наименования товаров в справочник номенклатуры 1С.

ex2_18.jpg

Как видите, реквизиты «Единица для отчетов» и «Единица хранения остатков» остались не заполненными.

Следующим шагом необходимо установить данные реквизиты, т.к. они потребуются при загрузке цен, штрих-кодов и дальнейшей работе.

Возможны два варианта:

Ручной.

Данные реквизиты создаются программой автоматически, при первом открытии и сохранении карточки номенклатуры. Если допустима ручная установка, то можно этот шаг пропустить и перейти сразу к этапу загрузки цен. Если не планируется загрузка штрих-кодов, то вполне допустимо даже оставить как есть — при первом использовании элемента номенклатуры необходимо будет отрыть и сохранить карточку товара.

Недостаток: ручная процедура открытия и записи может быть довольно трудоёмкой и занять довольно много времени при большом количестве элементов справочника.

Автоматический.

Возможна и автоматическая загрузка единиц измерения, но она рассчитана для продвинутых пользователей и потребует базовых навыков в программировании 1С.

Возможны два варианта: с идентификацией по артикулу или наименованию.

Идентификация по Артикулу более предпочтительна, но в прайс-листе колонки с артикулами может и не быть.

Вариант 1. Идентификация по Артикулу

ex2_19.jpg

Ставим «галку» в поле «Не создавать новых элементов» и снимаем «галки» со всех строк.

Строка «Артикул» — ставим галку в колонке «Поле поиска» (вторая колонка). Устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе артикул во второй колонке — ставим «2»

В строках «Единица для отчетов» и «Единица хранения остатков» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С. Например, наш специалист из отдела внедрения, за пару минут предложил такой код:

ex2_20.jpg

 СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул", ТекущиеДанные["Артикул"]); БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796); ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификаторуquot;,БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры); Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент(); НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения); НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения; НайденнаяЕдиницаОбъект.Коэффициент = 1; НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры; Попытка НайденнаяЕдиницаОбъект.Записать(); Результат = НайденнаяЕдиницаОбъект.Ссылка; Исключение Сообщить("Не удалось записать"); КонецПопытки; Иначе Результат =ТекСпр.Ссылка; КонецЕсли; 
//© Компания "Онлайн" 2010, www.online-ufa.ru

Если планируется многократное повторение данной процедуры, то в алгоритм необходимо дополнительно добавить процедуру проверки, чтобы исключить повторный ввод единиц измерения с тем же наименованием.

Вариант 2. В случае идентификации по Наименованию

ex2_21.jpg

Ставим «галочку» в поле «Не создавать новых элементов»

Снимаем «галки» со всех строк

Строка «Наименование» — ставим галку в колонке «Поле поиска» (вторая колонка). Устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе наименования в третьей колонке — ставим «3»

В строках «Единица для отчетов» и «Единица хранения остатков» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С, например такой:

ex2_22.jpg

 
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Наименование"]);
БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796);
ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("
ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры);
Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения);
НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения;
НайденнаяЕдиницаОбъект.Коэффициент = 1;
НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры;
Попытка НайденнаяЕдиницаОбъект.Записать();
Результат = НайденнаяЕдиницаОбъект.Ссылка;
Исключение Сообщить("Не удалось записать");
КонецПопытки;
Иначе Результат =ТекСпр.Ссылка;
КонецЕсли;



//© Компания "Онлайн" 2010, www.online-ufa.ru

9. Открываем карточку товара, проверяем правильность загрузки реквизитов

ex2_23.jpg

Если всё правильно, то можно приступить ко второму этапу — загрузке цен из прайс-листа в Excel.

Если в будущем планируется использовать данную процедуру загрузки данных с такими же настройками параметров загрузки, то рекомендуем сохранить текущие настройки. Для этого нажмите кнопочку image043.png «Сохранить настройки» и понятно назовите текущую настройку, например, «Загрузка наименований товаров из прайс-листа Excel».

ex2_24.jpg

В следующий раз сможете загрузить сохраненные настройки, нажав на кнопку image046.jpg «Восстановить настройки» и выбрав нужную из списка.

ex2_25.jpg

10. Этап 2. Загрузка цен

В «Управление торговлей» Ред.10.3 установка цен производится с помощью документа «Установка цен номенклатуры».

Используем ту же обработку «ЗагрузкаДанныхИзТабличногоДокумента.epf» с диска ИТС.

ex2_26.jpg

11. Устанавливаем «Режим загрузки» — «Загрузка в табличную часть».

ex2_27.jpg

12. В поле «Ссылка» выбираем «Установка цен номенклатуры».

ex2_28.jpg

После этого в том же самом поле «Ссылка» снова нажимаем на кнопку выбора

Открывается журнал документов «Установка цен номенклатуры».

Здесь можно выбрать уже существующий документ, в который мы хотим добавить новые элементы, или создать Новый (рекомендуется), в документе указываем какой «Тип цен» будем загружать (в нашем примере «Розничная»).

ex2_29.jpg

Нажимаем «Ок» и сохраняем пока пустой документ.

Теперь выбираем этот новый сохранённый документ из журнала в строке «Ссылка».

В поле «Табличная часть» выбираем «Товары».

ex2_30.jpg

13. Обратите внимание, что сейчас нужно перейти закладку «Табличный документ» и снова выбрать наш прайс-лист в Excel из которого мы загрузили наименования, а теперь будем загружать цены (см. пункт 5).

14. Настраиваем параметры загрузки

Опять устанавливаем «Первая строка данных табличного документа» — как и при загрузке наименований, ставим «9» и «Ручную нумерацию колонок».

В строке «Номенклатура» устанавливаем режим загрузки «Искать», «№ Колонки табличного документа» — в нашем примере ставим «3». Если необходима идентификация по артикулу, то в колонке "Искать по" выбираем "Артикул", а в «№ Колонки табличного документа» ставим номер колонки с артикулами - в нашем примере "2".

В строке «Цена» устанавливаем режим загрузки «Искать», «№ Колонки табличного документа» — ставим номер колонки с ценами, которые хотим загрузить, сначала будем загружать розничную цену, значит, ставим «5».

ex2_31.jpg

В строке «Валюта» устанавливаем Режим загрузки «Устанавливать», выбираем валюту (в примере «руб.»)

В строке «Единица измерения» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С. Например, такой код: 

ex2_31_1.jpg

 СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Номенклатура"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков; 

В строке «Тип цен» устанавливаем Режим загрузки «Устанавливать», выбираем цену, которую будем загружать «Розничная».

ex2_32.jpg

Если в вашем прайс-листе цены товаров приведены в разных валютах, которая указывается в отдельной колонке загружаемого прайс-листа, то в колонке «Режим загрузки» установите «Искать» и номер соответствующей колонки прайс-листа в «№ Колонки табличного документа».

В строке «Способ расчета цены» устанавливаем Режим загрузки «Устанавливать», выбираем «По процентной наценке на базовый тип»

ex2_33.jpg

Нажимаем «Загрузить» и отвечаем «Да»

ex2_34.jpg

Если загрузка пройдет нормально, то по результатам будет выдано сообщение об успешной загрузке.

15. Открываем документ «Установка цен номенклатуры», в который загружали данные (нажав кнопочку с изображением лупы image065.jpg в строке «Ссылка»)

ex2_35.jpg

16. Проверяем документ, если всё в порядке нажимаем «Ок».

Цены должны установиться.

17. Открываем справочник номенклатуры, проверяем закладку «Цены» в карточке загруженных элементов, нажимаем кнопку «Перечитать текущие цены».

ex2_36.jpg

Если всё в порядке, то можно приступать к загрузке остальных цен (оптовые, закупочные и т.д.). Процедура аналогична.

Обратите внимание, что 1С:Управление торговлей 8 поддерживает расчет одних цен на основании других. Поэтому загружать, возможно, будет достаточно только одну базовую цену, например Розничную или наоборот Закупочную, а для других цен указать алгоритмы формирования (скидка %, наценка %, округление до знака и т.д.).

Если в будущем планируется использовать данную процедуру загрузки данных с такими же настройками параметров загрузки, то рекомендуем сохранить текущие настройки. Для этого нажмите кнопочку image043.png «Сохранить настройки» и понятно назовите текущую настройку, например, «Загрузка Розничных Цен из прайс-листа Excel».

ex2_37.jpg

В следующий раз сможете загрузить сохраненные настройки, нажав на кнопкуimage046.jpg «Восстановить настройки» и выбрав нужную из списка.

ex2_38.jpg

18. Этап 3. Загрузка штрих-кодов

Используем всё ту же обработку «ЗагрузкаДанныхИзТабличногоДокумента.epf» с диска ИТС.

ex2_39.jpg

19. Устанавливаем «Режим загрузки» — «Загрузка в регистр сведений». 
"Вид регистра" выбираем "Штрихкоды".

ex2_40.jpg

20. Обратите внимание, что сейчас нужно перейти закладку «Табличный документ» и снова выбрать наш прайс-лист в Excel из которого мы загрузили наименования и цены, а теперь будем загружать штрихкоды (см. пункт 5).

21. Настраиваем параметры загрузки

Опять устанавливаем параметр «Первая строка данных табличного документа» - ставим «9» и «Ручную нумерацию колонок».

ex2_41.jpg

Настраиваем параметры загрузки

Удаляем «галки» со всех строк, с которых возможно.

В оставшихся строках устанавливаем параметры

В строке «Штрихкод» устанавливаем Режим загрузки «Искать», в колонке «№ Колонки табличного документа» пишем как в нашем прайс-листе «9».

ex2_42.jpg

В строке «Владелец» в колонке «Описание типов» открываем окно «Редактирование типа данных» устанавливаем (оставляем) галку только в поле «Номенклатура». Режим загрузки устанавливаем «Искать». Для идентификации по Артикулу, в колонке «№ Колонки табличного документа» пишем номер колонки, в которой в нашем прайс-листе указаны артикулы — т.е. «2». В колонке «Искать по», устанавливаем «Артикул».

ex2_43.jpg

В случае, если в прайс-листе нет колонки с артикулами, то в колонке «Искать по» необходимо выбрать «Наименование», а в ячейке «№ Колонки табличного документа» указать номер колонки прайс-листа с наименованиями.

В строке «Тип штрихкода» в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «EAN13».

В строке «Единица измерения» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С. Например, такой код:

ex2_43_1.jpg

 CсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Владелец"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков; 

ex2_44.jpg

В строке «Качество» в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Новый».

В строках «Характеристика номенклатуры», «Серия номенклатуры», «Удалить код» в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» оставляем пустые ячейки.

Нажимаем «Загрузить»

Открываем карточку товара, проверяем наличие штрих-кода.

ex2_45.jpg

Если в будущем планируется использовать данную процедуру загрузки данных с такими же настройками параметров загрузки, то рекомендуем сохранить текущие настройки. Для этого нажмите кнопочку image043.png «Сохранить настройки» и понятно назовите текущую настройку, например, «Загрузка штрих-кодов товаров из прайс-листа Excel».

ex2_46.jpg

В следующий раз сможете загрузить сохраненные настройки, нажав на кнопкуimage046.jpg «Восстановить настройки» и выбрав нужную из списка.

ex2_47.jpg

 

См. также

Подписаться Добавить вознаграждение

Комментарии

. ренат васильев (SkyLink2012) 02.03.12 17:15
Bublik2011! Для коррекции единиц хранения измерения номенклатуры в справочнике штрих-коды или штрихкоды создайте в конфигураторе - "Новая" - "Обработка" и вставьте код по действию "Выполнить".

Процедура КнопкаВыполнитьНажатие(Кнопка)
	ВыборкаШК = РегистрыСведений.Штрихкоды.Выбрать();
	Пока ВыборкаШК.Следующий() Цикл
		Если ВыборкаШК.Владелец = ВыборкаШК.ЕдиницаИзмерения.Владелец Тогда
			Продолжить;
		КонецЕсли;
		Если ВыборкаШК.Владелец.ЭтоГруппа Тогда
			Продолжить;
		КонецЕсли;
		Состояние("Обрабатывается: "  + ВыборкаШК.Владелец);
		Запись = ВыборкаШК.ПолучитьМенеджерЗаписи(); 
		Запись.Прочитать();
		
		Запись.ЕдиницаИзмерения = Запись.Владелец.ЕдиницаХраненияОстатков;
		Попытка
			Запись.Записать()
		Исключение
			ОбщегоНазначения.СообщитьОбОшибке(ОписаниеОшибки())
		КонецПопытки;
		Состояние("Обрабатывается: ......");
		
	КонецЦикла;
	Сообщить("Обработка завершена!");
КонецПроцедуры


...Показать Скрыть



Прикрепленные файлы:
CorrectEAN-13.epf
0. ренат васильев (SkyLink2012) 01.01.70 03:00
В таких случаях многие заказывают соответствующие обработки у собственных штатных программистов, фирм-франчайзи или сторонних разработчиков, но это дополнительные расходы и время.

Как быть, если по различным причинам такой возможности нет?

У каждого пользователя профессиональной версии 1С:Предприятие 8 подобная обработка уже есть! На диске ИТС!

Типовая обработка «ЗагрузкаДанныхИзТабличногоДокумента.epf», находиться в разделе «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

Обратите внимание, начиная с Февраля 2010 г. на диске ИТС данная обработка для конфигураций на платформе 8.1 находиться в другом разделе: «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Платформа 1С:Предприятие 8.1» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

Перейти к публикации

1. Ваня Иванов (boygena) 09.11.11 13:21
Очень удобно и работает без ошибок. Пока ошибок еще не нашел =))) Поставил +
2. ренат васильев (SkyLink2012) 10.11.11 17:44
Да, иметь под рукой диск ИТС или найти по ФТП-поиску обработку - решение многих проблем.
3. Petr (sevipa) 20.11.11 01:09
Да, походу это единственный путь, как без доработок используя только типовые возможности непросто загрузить номенклатуру и цены, а загрузить с предсказуемым результатом... вот только научить этому порядку менеджеров отдела снабжения будет достаточно проблематично. Даже имея подобную инструкцию... А так +
4. Кирилл Краснов (kirillkr) 20.11.11 23:32
Замечательное описание. Огромное спасибо.

Кстати, а никто не видел такую же обработку для управляемых форм?
5. Павел В (PaulV) 26.11.11 20:38
Споткнулся на пункте 14: мне нужен был поиск по артикулу.

Решил так:
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул",ТекущиеДанные.Номенклатура.Артикул);
Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков;
6. ренат васильев (SkyLink2012) 26.11.11 21:42
Да, пришлось тоже поменять при загрузке (условие: коды разные, наименования:попадаются одинаковые) Едениц для Отчетов:

Еденица для отчетов
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоКоду(ТекущиеДанные["Код"]); 
 БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796);
 ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры);
 Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент(); 
 НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения); 
НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения; 
 НайденнаяЕдиницаОбъект.Коэффициент = 1; 
 НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры; 
 Попытка НайденнаяЕдиницаОбъект.Записать(); 
 Результат = НайденнаяЕдиницаОбъект.Ссылка; 
  Исключение Сообщить("1Не удалось записать"+ТекущиеДанные["Наименование"]); 
 КонецПопытки; 
 Иначе Результат =ТекСпр.Ссылка; 
  КонецЕсли;

...Показать Скрыть



Еденица для хранения остатков
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоКоду(ТекущиеДанные["Код"]); 
 БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796);
 ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры);
 Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент(); 
 НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения); 
НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения; 
 НайденнаяЕдиницаОбъект.Коэффициент = 1; 
 НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры; 
 Попытка НайденнаяЕдиницаОбъект.Записать(); 
 Результат = НайденнаяЕдиницаОбъект.Ссылка; 
  Исключение Сообщить("2Не удалось записать"+ТекущиеДанные["Наименование"]); 
 КонецПопытки; 
 Иначе Результат =ТекСпр.Ссылка; 
  КонецЕсли;
 
 
...Показать Скрыть
7. Ольга Василенко (Volga1904) 11.12.11 19:26
Очень удобное описание, спасибо
8. ренат васильев (SkyLink2012) 13.12.11 09:08
Я бы с удовольствием еще-бы добавил описания и ключевых поисковых слов. Но боюсь, лишнее модераторы добавят в минус-слова
9. Алексей Коновалов (Magicanin) 13.12.11 09:36
Где скачать? Не вижу ничего)
10. Модератор раздела Ирина Пятакова (Alraune) 13.12.11 10:19
(8) Так добавьте, не надо бояться )))
11. Pawlik (Pawlick) 14.12.11 15:22
5 лет иметь под рукой ТАКОЙ функционел и не использоватьего!?

Ребятам из компании 1С - МИНУС за отсутствие рекомендаций по использованию;

Ребятам из Компании "Онлайн" - БРАВО!
Bublik2011; +1 Ответить
12. ренат васильев (SkyLink2012) 14.12.11 16:13
Буду очень счастлив, если порекомендуете статью или способ импорта знакомым
13. Кирилл Раковский (RakovskiyK) 19.12.11 16:41
тааак. беру на тест очередную обработку. :)
Bublik2011; +1 Ответить
14. Павел Хорев (w22u) 25.12.11 16:42
(12) SkyLink2012, эту статью порекомендую своим знакомым, только если есть возможность быстрее победить неустановившиеся единицы хранения остатков через эту разработку: http://infostart.ru/public/61676/
почему бы не воспользоваться?
15. Василий Орлов (Bublik2011) 28.12.11 18:33
w22u таки беспроблемно грузятся и еденицы. Мне, правда, пришлось, в отличие от Skylink2k выборку делать по кодам, а не по артикулу и номенклатуре. В аттаче есть файл настройки.
Прикрепленные файлы:
ed_xranenija_ostatkow.mxlz
16. Василий Орлов (Bublik2011) 28.12.11 18:37
SkyLink2k Предлагаю включить в описание загрузку изображений и картинок в 1с 8 УТ из Excel. Загрузка идет в Хранилище информации. Если поменять переменную - загрузка картинок пойдет в отдельный файл.

В аттаче - файл настроек для той-же обработки в Номенклатуру. Во вкладке "настройка"-"восстановить настройки из файла.."- открыть этот файл из аттача. В "События"-"При записи" должна быть такая функция:

Если Объект.БазоваяЕдиницаИзмерения.Пустая()=Ложь Тогда
	
	ЗапросЕдИзм = Новый Запрос();
	ЗапросЕдИзм.Текст = ""
	|ВЫБРАТЬ
	|	ЕдиницыИзмерения.Ссылка
	|ИЗ
	|	Справочник.ЕдиницыИзмерения КАК ЕдиницыИзмерения
	|ГДЕ
	|	ЕдиницыИзмерения.Владелец = &Владелец
	|	И ЕдиницыИзмерения.ЕдиницаПоКлассификатору = &ЕдиницаПоКлассификатору"";
	
	ЗапросЕдИзм.УстановитьПараметр(""Владелец"", Объект.Ссылка);
	ЗапросЕдИзм.УстановитьПараметр(""ЕдиницаПоКлассификатору"",Объект.БазоваяЕдиницаИзмерения.Ссылка);
	
	Выборка = ЗапросЕдИзм.Выполнить().Выбрать();
	Если Выборка.Количество() <= 0 Тогда
		
		Ед = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
		Ед.ЕдиницаПоКлассификатору = Объект.БазоваяЕдиницаИзмерения.Ссылка;
		Ед.Вес = 1;
		Ед.Владелец = Объект.Ссылка;
		Ед.Коэффициент = 1;
		Ед.Наименование = Объект.БазоваяЕдиницаИзмерения.Наименование;
		Ед.Записать();
		Объект.ЕдиницаДляОтчетов = Ед.Ссылка;
		Объект.ЕдиницаХраненияОстатков = Ед.Ссылка;
	КонецЕсли;
КонецЕсли;

НомерСтолбцаИзображение = 8;
НомерСтолбцаОписаниеИзображение = 3; 


ЗапросСуществующих = Новый Запрос();
ЗапросСуществующих.Текст = ""
|ВЫБРАТЬ
|	ХранилищеДополнительнойИнформации.Ссылка
|ИЗ
|	Справочник.ХранилищеДополнительнойИнформации КАК ХранилищеДополнительнойИнформации
|ГДЕ
|	ХранилищеДополнительнойИнформации.Объект = &Объект
|	И ХранилищеДополнительнойИнформации.Наименование = &Наименование"";

Объект.Записать();

ФайлКартинки = Новый Файл(СокрЛП(ТекстыЯчеек[НомерСтолбцаИзображение]));
 //Предупреждение(ФайлКартинки.Существует());
Если ФайлКартинки.Существует() Тогда
	//Предупреждение(""!"");
	ЗапросСуществующих.УстановитьПараметр(""Объект"", Объект.Ссылка);
	ЗапросСуществующих.УстановитьПараметр(""Наименование"", СокрЛП(ТекстыЯчеек[НомерСтолбцаОписаниеИзображение]));
	Выборка = ЗапросСуществующих.Выполнить().Выбрать();
	Если Выборка.Количество() <= 0 Тогда
	//	Предупреждение(""!!"");
		ХранилищеОбъект = Справочники.ХранилищеДополнительнойИнформации.СоздатьЭлемент();
		ХранилищеОбъект.ВидДанных = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение;
		ХранилищеОбъект.Хранилище = Новый ХранилищеЗначения(Новый Картинка(ТекстыЯчеек[НомерСтолбцаИзображение]),Новый СжатиеДанных);
		ХранилищеОбъект.Объект = Объект.Ссылка;
		ХранилищеОбъект.Наименование = СокрЛП(ТекстыЯчеек[НомерСтолбцаОписаниеИзображение]);
		ХранилищеОбъект.ИмяФайла = ТекстыЯчеек[НомерСтолбцаИзображение];
		ХранилищеОбъект.Записать();
		Объект.ОсновноеИзображение=ХранилищеОбъект.Ссылка;
	КонецЕсли;
КонецЕсли;

...Показать Скрыть
Прикрепленные файлы:
load_image.mxlz
isheninp; decide; МимохожийОднако; +3 Ответить 1
17. Александр (МимохожийОднако) 09.01.12 08:17
Хорошее описание, которого не хватает на ИТС. Может быть, есть еще где-нибудь подобные описания?
18. ренат васильев (SkyLink2012) 19.01.12 16:08
(16) Bublik2011, сердечное спасибо за замечание)
19. ренат васильев (SkyLink2012) 19.01.12 16:13
(17) МимохожийОднако, есть в копирайтах и в комментариях. А на какую тему подобное описание интересно? Очень хочу, чтобы статья была полезная , необходимая и решающая большинство проблем.
20. Александр (МимохожийОднако) 19.01.12 19:50
(19)Сходу ответить сложно. Думаю, статистика наиболее популярных "баянистых" вопросов вокруг универсальных обработок и отчетов с ИТС и типовых конфигураций может натолкнуть на наиболее популярную тематику. Например, для меня интересен набор методов при использовании Универсальной обработки подбора объектов.
21. Анатолий Дмитрук (progres488) 25.01.12 21:58
Ребят а кто как бориться если в артикле стоит 0 перед число, у меня ексель съедает ноль и пото мне находит номенклатуру ко артиклу
22. ренат васильев (SkyLink2012) 27.01.12 17:15
(21) progres488, а что если столбец в Екзеле присвоить формат столбца - текстовый?
23. Сергей (InShallaH) 10.02.12 16:06
Действительно удобно. Но, к сожалению, для большинства менеждеров проще попросить написать большую красную кнопку "Сделать Все".
24. Валерий Карпов (Yakud3a) 20.02.12 05:18
Всё просто и понятно, молодца, как то не обращал внимания на эту обработку на ИТС
25. Владимир Водин (BalVlad) 21.02.12 08:47
Отличная статья с подробным описанием. Спасибо и плюс.
26. Антон Цыкин (takeshi3) 27.02.12 13:27
29. анна79 (Анна79) 19.03.12 09:21
А вы можете сделать такую большую красную кнопку? "Сделать все!!!" Спасибо обработка просто отличная, да еще и бесплатная...
30. Klavdiya (kvp) 16.04.12 15:17
Спасибо! действительно отлично все описано, и эту обработку раньше игнорировала, а выходит очень даже полезная.
31. Stamper (Stamper) 18.04.12 19:06
использовать UNIREPS -- это очень правильно
горы времени экономит
32. Алексей Роза (DoctorRoza) 02.05.12 18:08
Вы можете выложить эту статью в более удобном формате, например, в word'e? Я имею в виду Ваш исходный файл, источник, а не сохраненную страницу из браузера. Материал нужный, как раз отличное пособие для пользования обработкой. Заранее благодарю!
33. ренат васильев (SkyLink2012) 03.05.12 09:26
(32) DoctorRoza, к вечеру накатаю, хорошо? Прошу, наберитесь терпения. Очень счастлив, что статья будет полезна и избавит Вас и ваших друзей от ошибок и вбухивания средств-времени впустую. :)
34. Алексей Роза (DoctorRoza) 03.05.12 10:14
35. НЕ ЗНАЮ (NE_ZNAIY) 28.05.12 17:14
Ещё одно спасибо за труд.
36. Константин (lawko) 02.06.12 14:32
Также отплюсовал, т.к. просто поражен был тем, что может выдать эта обработка, которая буквально "валялась" на виду, но и в голову не приходило, что можно добиться таких результатов. Огромнейшее спасибо за статью!
Из ручного труда осталось вбивать лишь значения свойств товара и загрузка изображений.
Еще раз большое спасибо!
37. Олег Шалимов (CaSH_2004) 20.06.12 02:31
Замечательная статья, но вот вопрос: зачем в теме сабжа указано
код открыт скачать можно бесплатно

если суть просто в описании?
Какой код и что скачивать?
38. ренат васильев (SkyLink2012) 20.06.12 09:53
(37) CaSH_2004, прошу Вас, воспринимайте это как элемент SEO оптимизации. :)
40. Виталий (vitaliyua) 19.09.12 11:56
А как быть с созданием групп? Например, переносим справочник номенклатуры, в настройках Обработки негде указывать, группа это или элемент. Как быть?
42. ренат васильев (SkyLink2012) 02.10.12 17:04
(41) gravizapa, Ваш способ модификации обработки - это очень актуально. Создавайте свою ветку. Не надо рассеивать внимание , Вам очень это необходимо сделать. Ваш способ - он более устойчив и скоростнее , как и загрузка из Excel через ADO )) А в этой ветке уж по старинке, что есть в комплекте с основной конфигурацией.

Зачем создавать лишнее, если есть доступный и бесплатный инструмент?
43. ренат васильев (SkyLink2012) 02.10.12 17:11
(40) vitaliyua, А если попробовать так:
1) в первой колонке - название Группы, во второй колонке - родитель (наименование или код?)

2) В настройке: в строке Наименование-
НоваяГруппа = Справочники.Номенклатура.СоздатьГруппу(); 
НоваяГруппа.Наименование = СокрЛП(ТекстыЯчеек[1]); 
НоваяГруппа.Родитель =ТекущиеДанные["Родитель"];
...Показать Скрыть


в Настройке Родитель - искать по колонке № 2 искать по Наименованию
44. Александр Теплов (gravizapa) 02.10.12 17:38
(43) SkyLink2012, да просто с помощью той же самой обработки я делал описание, по сути то же самое,только описание другое
45. oksevi (oksevi) 10.10.12 15:40
Спасибо за подробное описание.
Осваиваем.
Подскажите, пожалуйста, можно ли и каким образом еще один из параметров в прайс-листе добавить как дополнительный реквизит номенклатуры? Конфигурация 1С:Бухгалтерия 8
46. Алекс Ю (AlexO) 10.10.12 16:07
все бы хорошо, но кроме номенклатуры, типовая грузит все другие справочники крайне плохо - не ищет по строковым полям, задваивает позиции, переносит только после идеального соответствия номера и наименования.
Да и по поводу загрузки "связанных" справочников - тоже вопросы.
Так что все равно нужно писать свои обработки.
и фразы
наш специалист из отдела внедрения, за пару минут предложил такой код:

очень умиляют, спасибо :)
видимо, и остальные специалисты, и в самой 1С в том числе, также пишут весь код "за пару минут".
47. Василий Орлов (Bublik2011) 13.10.12 12:07
(46) AlexO, предлагаю, чтобы не задваивалось, прерывание ставитьпо признаку. Извините, у меня так пока

        Если Лев(ТаблицаЗначенийМассив[НомерСтроки].КодТовара,3)<>"001"  Тогда
                  Продолжить;
        КонецЕсли;
...Показать Скрыть


Но лучше загрузка и синхронизация справочников 1с по ГУИД (Уникальный идентификатор) в качестве подстраховки

1. Найти из УникальныйИдентификатор код элемента
Функция НайтиЭлементПоИД (строкаИД)
				ГУИД=Новый УникальныйИдентификатор(строкаИД);
		Для Каждого МД Из Метаданные.Справочники Цикл
			РезСсылка=Справочники[МД.Имя].ПолучитьСсылку(ГУИД);			
			Если РезСсылка.ПолучитьОбъект()<>Неопределено Тогда
				Возврат РезСсылка.Код;
			КонецЕсли;
		КонецЦикла;	 
КонецФункции
...Показать Скрыть



2.Найти УникальныйИдентификатор по коду

Функция НайтиЭлементПоКоду(строкаКод)
	НоменклатураСсылка = Справочники.Номенклатура.НайтиПоКоду(СокрЛП(строкаКод));
Если НЕ НоменклатураСсылка.Пустая() Тогда
   Сообщить("GUID = " + НоменклатураСсылка.УникальныйИдентификатор());
КонецЕсли; 
КонецФункция
...Показать Скрыть



Для обработки загрузка, естественно, вводятся только одна-две , э-э-э-э, отличия . Первое - "ТекстыЯчеек[1]".

а) в поле "представление реквизита" - например "комментарий"
б) режим загрузки - "вычислять"
в) в поле "выражение"
Сообщить("В табличном документе есть данные - 1столбец:"+Строка(ТекстыЯчеек[1])+"  2столбец:"+Строка(ТекстыЯчеек[2])+" 3столбец"+Строка(ТекстыЯчеек[3])); 


И второе отличие ЗагрузкаДанныхИзТабличногоДокумента.epf найти по Уникальному Идентификатору - в выражение вместо "Возврат" пишется "Результат". То есть для ЗагрузкаДанныхИзТабличногоДокумента это будет иметь вид:

//Функция НайтиЭлементПоИД (строкаИД) //это тоже не надо
				ГУИД=Новый УникальныйИдентификатор(строкаИД);
		Для Каждого МД Из Метаданные.Справочники Цикл
			РезСсылка=Справочники[МД.Имя].ПолучитьСсылку(ГУИД);			
			Если РезСсылка.ПолучитьОбъект()<>Неопределено Тогда
//Возврат РезСсылка.Код; // ТУТ уже вставляется все что возможно Код Наименование Комментарий НаименованиеПолное
Результат РезСсылка.Код
			КонецЕсли;
		КонецЦикла;	 
//КонецФункции //и это не надо
...Показать Скрыть


Поиск по уникальному идентификатору занимает долгое время, зато уж гарантированно)) Для парсера или для синхронизации уж точно пригодится. Технология XML c ИдЭлемента - это наверно в другой ветке.
48. Азиз Абдукаримов (azeraus) 06.11.12 10:02
Хорошая статья с подробными описаниями, очень помогло, но я бы хотел спросить, КАК МОЖНО АВТОМАТИЧЕСКИ СОЗДАТЬ ДОГОВОРА КОНТРАГЕНТОВ при загрузке в справочник контрагентов. Извините за таков "простой вопрос" просто в 1С пока разбираюсь не очень.
49. Василий Орлов (Bublik2011) 06.11.12 10:55
(48) azeraus, Если задача создать справочник с договорами контрагентов. Я бы предложил поочередно внести контрагентов с минимально необходимыми реквизитами, а затем список договоров. Мог-бы видеоролик предложить или идею скриншот приаттачить, если перечислите, какие данные-реквизиты интересуют для обновления.
50. Азиз Абдукаримов (azeraus) 06.11.12 15:43
(49) Bublik2011, База новая, у контрагентов в списке договоров нет ни одного пункта.Контрагентов загрузил (проставил - юр.лицо, наименование, полное наименование, галочка "Покупатель"). Я бы хотел на вкладке счета и договора создать новый договор контрагента и указать его основным с проставлением следующих реквизитов:
1. Наименование "Основной договор"
2. Вид договора "С покупателем"
3. Ведение взаиморасчетов "По договору в целом", валюта "тенге"
4. Условия договора "Без дополнительных условий"
Как это все можно сделать?
Ваша идея насчет скриншотов или видеоролика очень бы мне помогла.
Заранее спасибо!
51. Сергей Валутин (Bacemo) 06.11.12 16:11
52. Vladimir Vladimir (VladimirVladimir) 20.11.12 17:41
Подскажите как добавить новые группы номенклатуры из файла. Спасибо.
53. Александр Емельянов (alex54) 09.12.12 09:01
хорошая штука, но мне нужно указать помимо начальной строки - еще и конечную, чтоб загрузить весь прайс, а потом частями загружать в нужные папки
а так приходиться перед этим лопатить эксел предварительно, что тоже не удобно

можно это дело как-то поправить?

заранее огромное спасибо
54. Александр (Мощный) 09.12.12 11:19
(53) alex54,
а зачем начальная и конечная? если есть начальная, т.е. строка ехеля каким-то образом выделенная, например наименование группы размещенное по какому-то фиксированному адресу, например, в обьединении ячеек.. Тогда до признака окончаниия строк или следующей такой ячейки реализуется а один проход
55. Александр (Мощный) 09.12.12 11:23
(52) VladimirVladimir, Если в ехеле будут каким-то образом идентифицироваться группа ( или отступом, или обьединением ячннк или цвнтом, или шрифтом, то проблем как понимаеие нет - все в один проход
56. Александр Емельянов (alex54) 09.12.12 11:31
мне присылают прайсы, как правило, где номенклатура в алфавитном порядке без разделения
вот я и хочу, обозначив 1 и последнюю строку, выделенную часть загрузить в одну папку, затем выделив другую часть - загрузить в другую



к примеру аккумуляторы в одну папку
амортизаторы в другую ..... и т.д.

приходиться каждый раз лишнее удалять... загружать, а потом опять открывать документ по-новой (((

может я делаю что-то не так? подскажите
57. Александр Емельянов (alex54) 09.12.12 11:34
(55) Мощный, спасибо, кажется малость доходит, но в моем случае все-равно надо дорабатывать эксел, типа раскрасить все в разные цвета или добавить пустые строки... я правильно понимаю?
58. Александр Емельянов (alex54) 09.12.12 11:36
а вот была бы возможность выбрать заданный диапазон в обработке - было бы круто ) загрузил файл и меня начальную и конечную ячейки - загружай что хочешь и куда хочешь
59. Александр Емельянов (alex54) 09.12.12 12:18
(54) Мощный, что-то ничего не выходит ((( грузит весь список, хотя разделение есть, что-то я не догоняю (((







60. Александр (Мощный) 09.12.12 13:30
(59) alex54, к сожалению у меня нет такой обработки с ИТС, а ежли есть, то искать просто некогда.. Обработки пишу сам.. Поэтому не сочтите за труд, ежли такая обработка есть перешлите на досуге подделаю.. tihon1t@mail.ru
А что касаемо алгоритма с группами, сброшу сегодня попозже, ну например с опознаванием ячеек на обьединение
Если не лень сбросьте и исходную, и доделанную постараюсь понять почему весь список попадает без учет разделения
61. Александр Емельянов (alex54) 09.12.12 13:34
62. Василий Орлов (Bublik2011) 09.12.12 15:03
(59) alex54, Было-бы здорово, если-бы заранее в строку прописать для товара кроме артикула еще и родителя (см фото)



Иначе придется придумать, куда (наверное в "при обработку и загрузке") засунуть переменную "НазваниеКаталогПродукции". На деле это будет так:


-В первой строке есть название. Название АВТОСВЕЧИ установить в переменную НазваниеКаталогПродукции.
-Во второй строке нет названия, есть товар. Для товара установить Родителя с названием из переменной НазваниеКаталогПродукции.
-Во третьей строке нет названия, есть товар. Для товара установить Родителя с названием из переменной НазваниеКаталогПродукции.
-В Строке ХХ ....


Вот один из шаблонов для определения группы товара

Запрос=новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ 
|	Номенклатура.Наименование,
|	Номенклатура.Ссылка как Результат,
|	Номенклатура.ЭтоГруппа	
|ИЗ
|	Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|	Номенклатура.ЭтоГруппа
|	И Номенклатура.Наименование = &Наименование
|";
Запрос.УстановитьПараметр("Наименование","Прочее");
РезультатЗапрсаВМассиве = Запрос.Выполнить().Выбрать();

Если 		Выборка.Количество()=0  Тогда
		Вопрос("Не найдено ни одного родителя, необходимо создать новый или записывать в отдельную группу ДляРазбросаПоКаталогам. Сейчас прервать загрузку?", РежимДиалогаВопрос.ДаНет)
	  Если Ответ = КодВозвратаДиалога.Да Тогда
            Возврат; //выйти из цикла или процедуры
	  КонецЕсли;
ИначеЕсли Выборка.Количество()>1 Тогда
	Предупреждение("Найдено более двух родителей. Надо с этим что-то предпринять..",60);
КонецЕсли;

Пока РезультатЗапрсаВМассиве.Следующий() Цикл
        	Результат= РезультатЗапроса.Результат 
	//Объект = РезультатЗапроса.ссылка.ПолучитьОбъект();
         //Объект.наименование = что-то с элементом
         //Объект.записать();
  КонецЦикла; 
...Показать Скрыть


Вот еще несколько шаблонов, кроме "Работа с Текстом (Строкой) 1с" при загрузке прайса:

Сообщить(" в текущих данных Код сейчас  "+Строка(ТекущиеДанные["Код"]));
Сообщить(" в текущих данных Владелец сейчас  "+Строка(ТекущиеДанные["Владелец"]));

Сообщить(" в ТекстыЯчеек[1] сейчас  "+Строка(Строка(ТекстыЯчеек[1])));
Сообщить(" в ТекстыЯчеек[2] сейчас  "+Строка(Строка(ТекстыЯчеек[2])));

...Показать Скрыть


Понимаете, сейчас только осталось в программный код перевести рассказ "-В первой строке есть названи и т.д. (см выше)" Задача интересная - определить переменную таким образом, чтобы она изменялась или читалась из прайса. Вот вижу еще один маневр:


Если значение из колонки два пустая, следовательно, в колонке 1 - название группы


	   Если СтрДлина(СокрЛП(Строка(Строка(ТекстыЯчеек[2]))))=0 Тогда	   
текстПеременнаяРодительДляСледующихСтрок=Строка(ТекстыЯчеек[1]));
			  //хочется в Результат и наити по наименованию 
			  //засунуть Результат=Строка(ТекстыЯчеек[2])); 
			  //но надо ссылку найти	    ссылПеременнаяРодительДляСледующихСтрок=Справочники.Номенклатура.НайтиПоНаименованию(Строка(ТекстыЯчеек[2]));
		         Если ссылПеременнаяРодительДляСледующихСтрок.ЭтоГруппа Тогда			 
				 	Результат=ссылПеременнаяРодительДляСледующихСтрок; 
			 КонецЕсли; 
	   КонецЕсли; 
...Показать Скрыть


В-общем, надо будет поэксперементировать с вкладками "События-Перед записью объекта" и "События-При записи объекта". Ответ наверно чуть позже.


Если известно, что количество стобцов всегда одинаковое и всегда соответсвует, тогда скину свою обработку. У меня так и есть: "Обработка для поставщика 1", "Обработка для поставщика 2". Только я требую от поставщиков прайсы с кодами или со штрихкодами. Так можно избежать ошибки при количестве товаров в базе более 25000
63. Александр (Мощный) 09.12.12 15:21
64. Александр (Мощный) 09.12.12 15:26
(62) Bublik2011, извините но реальному усру это .. не торт в общем.. Все должно быть намного проще, т.е. ехелька без предобработки
И по хорошему, представленную вещчть надо бы переделать процентов на 95
65. Василий Орлов (Bublik2011) 09.12.12 15:32
(52) VladimirVladimir, Действительно, сложно наверно. Вероятно обязательно указать ЕденицуИзмерения. А для группы это не предусмотрено.

Наверно создать группу лучше в два этапа
1. Создать группы
2. Назначить каждой группе родителя


Вот пример:
1. Создаете файл: каждая строка - название группы без спец символов вроде кавычек. Допускается тире, цифры, пробел.

Название группы1
Вторая группа
Автозапчасти
Велосипеды
Шины


Создаете обработку (или из аттача берите) с текстом для кнопки "Выполнить"

	
	  файл = Новый ТекстовыйДокумент;
	  адресФайла="C:\ТекстСНовымиГруппами.txt";
	Попытка файл.Прочитать(адресФайла);
	Исключение 
		Предупреждение("файл по данному адресу не найден");	
	КонецПопытки;
Для Сч=1 По файл.КоличествоСтрок() Цикл	
		ОбработкаПрерыванияПользователя();
		Стр = файл.ПолучитьСтроку(Сч);
		Состояние("обработка файла "+Строка(Сч));
	НоваяГруппа = Справочники.Номенклатура.СоздатьГруппу();
	//НоваяГруппа.Код = Строка(ТекстыЯчеек[2]);
	НоваяГруппа.Наименование = СокрЛП(Стр);	
	НоваяГруппа.Записать();
КонецЦикла;

...Показать Скрыть
Прикрепленные файлы:
СозданиеГруппы.epf
66. Василий Орлов (Bublik2011) 09.12.12 15:41
(64) Мощный, ну так интересно.. Консоль-же переделали ведь. Очень предпочитаю придерживатьмя тематике группы. Да, бывают моменты - сложно создать группу. Бывают crazy вроде меня, которые усложняю моменты, делают проверку соответсвии в тех местах, где не это не требуется. :) Мне иногда парсить прайсы с сайтов приходится и искать товары по УникальномуИдентификатору. Конечно, ерунда, есть решение проще. В остальном - этот продукт "Загрузка данных" - просто идеален. Загрузка Справочника номенклатуры мз Excel в стандартном виде - незаменимая вещь. Она доступна и решает 80% проблем. Позволяет избежать лишних затрат. Очень рад, что мне тоже нравится эта обработка. Рассматриваю эту универсальную стандартную обработку, идущую в комплекте с 1с как эдакий черновик, после чего можно сформулировать Техническое Задание.
67. ренат васильев (SkyLink2012) 09.12.12 15:52
(60) Мощный,


Если не лень сбросьте и исходную, и доделанную постараюсь понять почему весь список попадает без учет разделения


Наверное мне кажется, но вижу, что "Устанавливать"-"Свечи". Потому и "весь список попадает без учет разделения".


А что касаемо алгоритма с группами, сброшу сегодня попозже, ну например с опознаванием ячеек на обьединение


Поверьте пожалуйста, создано столько замечательных обработок с различными объектами. Обновлены методы работы с объектами,например, понравилась статья "Загрузка из EXCEL в 1С тремя методами. Часть I. MS ADODB.Connection". Но все равно приходится, черт побери, да, приходится иногда загружать с помощью "Универсальной загрузки справочников". Проще и надежнее. Извините, если ошибаюсь.
68. Александр (Мощный) 09.12.12 16:00
(66) Bublik2011, Так я и говорю, что исключительно для внутреннего употребления, как правило для обучения.. То есть технологическая..
69. Александр Емельянов (alex54) 09.12.12 17:06
ребят, не надо создавать группы в обработке, они созданы, это не так уж и сложно сделать вручную и родителя

обработка все делает на ура, единственно что нужно, так это задать диапазон загрузки

со строки такой - до строки такой.......... и все

и не надо во всем прайсе дописывать родителя, я его устанавливаю в из готовых заготовок

это еще и потому, что у разных поставщиков на одинаковую номенклатуру - разные родители или вообще нет

вот есть у меня прайс на 5000 наименований и даже разделение есть по группам (как задумал поставщик) а у меня другие для этого группы (родитель)
я устанавливаю куда грузить и задаю диапазон в прайсе....все.... остальное там идеально

если надо, я прикреплю обработку, которая есть у меня, сюда
70. Александр Емельянов (alex54) 09.12.12 17:19
попробовал вот эту обработку http://infostart.ru/public/125082/

архи неудобная, НО, что там удачно, так это возможность задать диапазон загрузки

если это реализовать в данной версии - цены бы не было )
71. Александр Емельянов (alex54) 10.12.12 20:04
есть что нового по теме? из бюджетных ничего пока подобрать не могу (
72. Александр Емельянов (alex54) 18.12.12 15:57
(68) Мощный, есть что нового ?
73. Василий Орлов (Bublik2011) 16.01.13 04:47
(72) alex54, Сколько бы обработок вроде ЗагрузкаданныхизТабличногоДокумента конечно не появлялось, эта остается классикой. Грех просто предьявлять претензии, исходный код открыть - изучай, не хочу... Еще чем мне нравится эта обработка - тем что вы читаете данные из внешнего источника, показываете их с помощью объекта табличное поле и только затем выбираете алгоритм загрузки в 1С.

Но что-то в ней не хватает. Конечно стандарта офисных документов ODF (Open Document Format). Теперь возможно загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в OpenOffice ODF (Open Document Format). Как можно загрузить в 1с8 из OpenOffice ? Можно прочитать http://infostart.ru/public/158951/
74. Кирилл Краснов (kirillkr) 18.01.13 17:49
А как можно перед добавлением строки в табличную часть выполнить код - надо ли добавлять новую строку или нет.
Например, мне выкладывают прайс лист и помимо номенклатуры выдают все шк, т.е. одинаковых строк отличающихся только ШК - уйма. Как сделать так, чтобы в ценообразование загружать каждую номенклатуру единожды?
75. Алексей (fgremlin) 11.02.13 20:06
А на управляемых интерфейсах запускал кто нибудь эту обработку? Что-то у меня не получилось... :( поделитесь опытом!
76. Nikolas Nikolay (NikolasI) 25.03.13 11:50
Полезная обработка.
Сейчас пытаюсь забить при помощи нее Номенклатуру поставщика. Не получается - помогите кто сможет.
То есть у нас есть своя номенклатура, в ней артикулы совпадают с поставщиком, наименования некоторые отличаются.
Соответсвенно надо произвести поиск поля Наименования по артикулу справочника Номенклатура.

Написал такое:

СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул",ТекущиеДанные.Номенклатура.Артикул);
Результат=СсылкаНоменклатуры.Наименование;


Выдает такое:
Поле объекта не обнаружено (Номенклатура)
Загружен элемент справочника: <>


Что не так делаю?
77. Алексей (fgremlin) 25.03.13 12:12
(76) NikolasI,
А куда грузишь? Редакция, конфигурация?
78. Алексей (fgremlin) 25.03.13 12:25
(76) NikolasI,
Теоретически там код писать не нужно...
В представлении реквизита "Номенклатура" ставишь искать по полю табличного документа (артикул) - из твоей таблицы с данными, в поле "искать по" выбираешь "Артикул", и все, должен привязывать к нужному родителю в номенклатуре найдя его по артикулу...
Смотрел в редакции УТ 11, в живую не проверял, но раньше пробовал таким образом другие справочники грузить.
79. Nikolas Nikolay (NikolasI) 25.03.13 13:51
Оу!
Спасибо! :)
Видимо я перемудрил...
80. Voldemar Nikolaev (passtools) 26.03.13 00:42
Как добавлять рисунки картинки по артиклу? Все рисунки и товары илеют одинаковые артикулы.
81. Василий Орлов (Bublik2011) 26.03.13 14:55
(80) passtools, например записать изображение можно отдельной обработкой


		ОбъектСсылка=Справочники.Номенклатура.НайтиПоКоду(КодЭлемента);
		ОбъектСправочник=ОбъектСсылка.ПолучитьОбъект();

	 ХранилищеОбъект = Справочники.ХранилищеДополнительнойИнформации.СоздатьЭлемент();
		ХранилищеОбъект.ВидДанных = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение;
		ХранилищеОбъект.Хранилище = Новый ХранилищеЗначения(Новый Картинка(СокрЛП(ПолеВвода2+ВходныеДанные+".jpg")),Новый СжатиеДанных);
		ХранилищеОбъект.Объект = ОбъектСсылка;
		ХранилищеОбъект.Наименование = СокрЛП(ОбъектСсылка.Наименование);
		ХранилищеОбъект.ИмяФайла = СокрЛП("РасположениеФайлов"+".jpg");
		ХранилищеОбъект.Записать();
				
		ОбъектСправочник.ОсновноеИзображение=ХранилищеОбъект.Ссылка;
        ОбъектСправочник.Записать();

...Показать Скрыть


Или применить ее в этой теме, где ОбъектСсылка - это найденный товар по артикулу . Вечером посмотрю другие шаблоны ..

В смысле- "одинаковые артикулы" ? У меня было такое, пришлось по Кодам или по УникальнымИдентификаторам искать. Подробнее?
82. Voldemar Nikolaev (passtools) 26.03.13 15:09
Bublik2011 В смысле- "одинаковые артикулы" ? Я наверное не точно передал смысл. " Одинаковые артикулы " Я имел в виду, что у каждого товара свой артикул, и названия рисунков так же имеют тот же артикут товара. Названия рисунка это артикул товара. Так же некоторые товары имеют несколько фото с добавлением _1.jpg _2.jpg _3.jpg
83. Василий Орлов (Bublik2011) 27.03.13 13:31
(82) passtools, да, это удобно загрузить номенклатуру с изображениями от контрагентов и обновлять свою базу.Но недавно избавился от гемора по сжатию файловой базы и чистки Справочники.ХранилищеЗначений. Может не надо так много грузить?) Если такое количество картнок надо для сайта, то лучше качественное и большое фото держать вне файловой базы и подгружать при выгрузке из отдельного файла. Как? Это другой вопрос))

А пока, думаю, чтобы найти несколько фото с добавлением _1.jpg _2.jpg _3.jpg, можно
1)перебирать каталог
2)явно указать в строке таблицы и проверять: пустая строка ? есть файл? например так
ФайлКартинки = Новый Файл(СокрЛП("c:\Мои документы\Jooob\foto\"+(Строка(ТекстыЯчеек[2]))+"__"+(Строка(ТекстыЯчеек[5]))+"_a.jpg"));
Если ФайлКартинки.Существует() Тогда
......	
КонецЕсли;

...Показать Скрыть

3) в аттаче архив - НАДО проверить на одном товаре. Может не работать, синтаксис, опять-таки((

Чорт! Ну ей Богу, если срочно, то лучше обработку создать с перебором файлов, если в названии файла есть артикул - запись.
Прикрепленные файлы:
РаботаСИзображениями_MXLZ.zip
84. Voldemar Nikolaev (passtools) 27.03.13 16:00
(81) Bublik2011, " где ОбъектСсылка - это найденный товар по артикулу " он у меня не находит изображения. Мне кажется надо прописать где ОбъектСсылка не по коду, а надо по артикулу. Вот только я в программировании НОЛЬ. не знаю что точно прописать, чтобы искал файлы по артикулу а не по коду. Может так ОбъектСсылка=Справочники.Номенклатура.НайтиПоАртикулу(АртикулЭлемента); А то выдает такую ошибку Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(1,55)}: Переменная не определена (КодЭлемента) Код который Вы выложили я вставил в обработчик, указав в настройке Основное изображение -> Вычислить.
85. Voldemar Nikolaev (passtools) 28.03.13 13:36
(65) Bublik2011, Для какой версии СозданиеГруппы.epf ? Он у меня выводит ошибку. Мой УТ 10.3

Вот что выводит.

{Справочник.ВнешниеОбработки.Форма.ФормаЭлемента(189)}: Ошибка при вызове метода контекста (Создать): Ошибка подключения внешних метаданных: Ошибка загрузки документа.
Внешняя обработка не может быть прочитана текущей версией программы.
Прикрепленные файлы:
86. Василий Орлов (Bublik2011) 28.03.13 16:11
я обязательно напишу подробно решение этого вопроса-по артикулам. мне не лень, просто физически за комп не могу приземлиться)) С утра 29.03 попытаюсь порекомендовать простое решение. Поверьте, оно есть. Решение очень простое. Буду весьма рад, что типовая обработка работы со справочниками пригодится в приенении. Я аж прям фэн этого решения от 1С ))) Пока рекомендую взглянуть на http:// help1c . com/faq8.html - работа с примитивными справочниками.

Пожалуйста, вместо скриншота ошибки - скриншот какие данные есть, на примере http://forum.infostart.ru/ajax/show_comment.php?t=45830&c=54 .
87. Алексей (fgremlin) 02.04.13 16:42
Господа практикующие программеры, подскажите:
каким кодом можно корректно сформировать упаковки для номенклатуры. Использую индивидуальные наборы для номенклатуры (что-бы для каждой позиции указывать количество в упаковке).
Использую 1С:Предприятие 8.2 (8.2.17.153) Управление торговлей, редакция 11.0 (11.0.9.15)
Предполагаю поступать таким образом:
1. Для начала формирую конечные единицы (шт.), грузить в справочник "Упаковки", тут трудность только в формировании наименования. В конфигурации это делается таким кодом:
СокрЛП(СокрЛП(ЕдиницаИзмерения) + " (" + Формат(Коэффициент,"ЧРД=.") + " " + СокрЛП(ЕдиницаИзмеренияВладельца) + ")")

2. Сформировать упаковки, тут две трудности:
а. Выбрать и установить конечную единицу измерения (родительскую)
б. Сформировать наименование из родительской единицы измерения и текущей.

И все эти единицы требуется проверять на наличие и если такие существуют, то грузить их не требуется...

Может кто делал подобное?
88. Алексей (fgremlin) 02.04.13 17:55
(87) fgremlin,
Понемногу решаю вопрос, результаты буду выкладывать тут, чтобы сохранялась информация для тех, кто столкнется с подобными проблемами.
При описании предполагаю, что читающий осознал все вышеописанное в самой статье и в обсуждениях:
Итак, грузим "конечные" единицы (шт) потому, что их потом потребуется использовать в качестве родителей для более крупных упаковок:
скрин настроек обработки во вложении, обратите внимание на то, что
1. поле "наименование" спущено в самый низ для того чтобы наименованию было из чего формироваться ("Единица измерения", "Коэффициент") и по нему проверяется наличие данной упаковки
2. Поиск происходит в том числе по полю "Владелец" что-бы владелец подставлялся из справочника номенклатуры (работает по наименованию)
3. Заполнял поля только необходимые для меня, остальные добавляйте "по вкусу".

код формирования наименования такой:
Результат = СокрЛП(СокрЛП(ТекущиеДанные.ЕдиницаИзмерения) + " (" + Формат(ТекущиеДанные.Коэффициент,"ЧРД=.") + " " + СокрЛП(ТекущиеДанные.ЕдиницаИзмерения) + ")");



p.s. В понимании некоторых процессов могу заблуждаться, прошу коллег попровлять меня.
p.p.s. ... to be continued...
Прикрепленные файлы:
89. Алексей (fgremlin) 03.04.13 11:57
(87) fgremlin,
Продолжаем разговор:
гружу упаковки (которые состоят из конечных упаковок)
Скрин настроек во вложении.
Комментарии и код:
1. Как и в прошлой загрузке Владелец ищется по наименованию номенклатуры из колонки таблицы.
2. Родитель (конечная упаковка из которой состоит текущая) ищется и заполняется кодом:

//Ищем конечную единицу для номенклатуры:
Штука = Справочники.ЕдиницыИзмерения.НайтиПоКоду(796);
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоКоду(ТекущиеДанные.Владелец.Код);
Если Не(СсылкаНоменклатуры.Пустая()) Тогда
	КонУпаковка = Справочники.УпаковкиНоменклатуры.НайтиПоРеквизиту("ЕдиницаИзмерения",Штука,,СсылкаНоменклатуры);
	Если КонУпаковка.Пустая() Тогда 
		Сообщить("Нет конечной упаковки!!!");	
	КонецЕсли;
Иначе
    Сообщить("Не найдена номенклатура");	
КонецЕсли;

Сообщить(""+КонУпаковка.Ссылка.Наименование);
Результат = КонУпаковка.Ссылка;
...Показать Скрыть


3. Ставим флаг "Состоит из других упаковок"
4. "Единица измерения" из классификатора ставлю вручную, но ничего не мешает поискать по коду или наименованию в классификаторе...
5. Количество в упаковке берем из колонки таблицы.
6. Коэффициент пересчитываем из текущих данных таким кодом:

//Пересчитываем коэффициенты на основании конечной единицы
КонечныйКоэффициент = ТекущиеДанные.Родитель.Коэффициент;
КоличествоУпаковок = ТекущиеДанные.КоличествоУпаковок;
Результат = КонечныйКоэффициент*КоличествоУпаковок;
...Показать Скрыть


7. Ну и, конечно же наименование, которое формируется из текущих данных по штатным алгоритмам таким кодом и вроде даже проверяется на уникальность не позволяя задвоить упаковку:


Результат = СокрЛП(СокрЛП(ТекущиеДанные.ЕдиницаИзмерения) + " (" + Формат(ТекущиеДанные.Коэффициент,"ЧРД=.") + " " + СокрЛП(ТекущиеДанные.Родитель.ЕдиницаИзмерения) + ")");


Ну, вот как-то так.
В общем и целом данной обработкой можно делать много чего.
Надеюсь кому нибудь это пригодится.
При загрузке использовались исключительно материалы данной статьи и ветки форума, за что авторам огромное спасибо.
Прикрепленные файлы:
SkyLink2012; Bublik2011; +2 Ответить
90. Сергей Мельник (SerGan757) 16.08.13 22:08
кто поможет? почему не работает? нужно цену из накладной умножить на коэффициент, но уперся и мучаюсь...

цена1 = 0.86; 
цена2 = ТекстыЯчеек[24];
выражение1 =	цена2*цена1;
Результат = Вычислить(выражение1);

Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(1,3)}: Ошибка в выражении
Преобразование значения к типу Число не может быть выполнено
91. Василий Орлов (Bublik2011) 17.08.13 10:09
Ответ: SerGan757, надо писать в кавычках

цена1 = "0.86" ; 
цена2 = "8";
выражение1 =   цена2*цена1;
...Показать Скрыть



Но я бы воспользовалься функцией ПривестиСтрокуКЧислу . Гарантия избежать всевозможных ошибок.

цена1 = ОбщегоНазначения.ПривестиСтрокуКЧислу("0.86") ; 
цена2 = ОбщегоНазначения.ПривестиСтрокуКЧислу(8);
выражение1 =   цена2*цена1;
...Показать Скрыть


Вот функция ПривестиСтрокуКЧислу, которая находится УправлениеТорговлей-Общие-ОбщиеМодули-ОбщегоНазначения-ПривестиСтрокуКЧислу

Функция ПривестиСтрокуКЧислу(ЧислоСтрокой, ВозвращатьНеопределено = Ложь) Экспорт
	
	ОписаниеТипаЧисла = Новый ОписаниеТипов("Число");
	ЗначениеЧисла = ОписаниеТипаЧисла.ПривестиЗначение(ЧислоСтрокой);
	
	Если ВозвращатьНеопределено И (ЗначениеЧисла = 0) Тогда
		
		Стр = Строка(ЧислоСтрокой);
		Если Стр = "" Тогда
			Возврат Неопределено;
		КонецЕсли;
		
		Стр = СтрЗаменить(СокрЛП(Стр), "0", "");
		Если (Стр <> "") И (Стр <> ".") И (Стр <> ",") Тогда
			Возврат Неопределено;
		КонецЕсли;
	КонецЕсли;
	
	Возврат ЗначениеЧисла;	
	
КонецФункции

...Показать Скрыть
92. Сергей Мельник (SerGan757) 17.08.13 10:25
СПАСИБО РАБОТАЕТ!!!вот результат
цена1 ="0.85"; 
цена2 = ОбщегоНазначения.ПривестиСтрокуКЧислу(ТекстыЯчеек[4]);
Результат = цена1*цена2;
93. Наталья (valya977) 16.10.13 01:05
Довольно часто пользуюсь данной обработкой.Спасибо за полный и понятный показ действий очень удобно и экономит много времени.
94. Наталья (valya977) 16.10.13 02:49
А есть возможность делать отбор по номенклатуре (не загружать то что уже есть в справочниках)?
95. Василий Орлов (Bublik2011) 16.10.13 14:46
Предпочел-бы запросом делать отбор по номенклатуре, чтобы не загружать то что уже есть в справочниках. Тогда можно фильтровать по нескольким признакам.

Вот вариант, без создания единиц хранения остатков при создании. Подходит? Не проверял, как работает, но синтаксических ошибок нет. Предусмотрен вариант ошибки , что артикул или строка, по которому ведется поиск, незаполнен.

АртикулДляПоиска=СокрЛП(ТекстыЯчеек[40]);

Если НЕ ЗначениеЗаполнено(АртикулДляПоиска) Тогда
	Режим = РежимДиалогаВопрос.ДаНет;		
			Ответ = Вопрос("Пустая строка для поиска, возможен иной результат", Режим);
			Если Ответ = КодВозвратаДиалога.Да Тогда
			    //
			Иначе		
				Возврат 0;					
			КонецЕсли;
КонецЕсли;

	
Запрос=новый Запрос;
Запрос.Текст="
|  ВЫБРАТЬ  
|	Номенклатура.Ссылка,
|	Номенклатура.Код,
|	Номенклатура.Артикул,
|	Номенклатура.Поставщик
|ИЗ
|	Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|	Номенклатура.Артикул = &kjhgfd
//|	И Номенклатура.Поставщик = &fghjk
|";
Запрос.УстановитьПараметр("fghjk",АртикулДляПоиска);

РезультатЗ = Запрос.Выполнить().Выгрузить();
РезультатЗапроса = Запрос.Выполнить();

		//Если НЕ РезультатЗапроса.Пустой() Тогда
		//	СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];	
		//	  	Ссылка=СтрокаРезультата.Ссылка ;
		//КонецЕсли;

	Если  РезультатЗапроса.Пустой() Тогда			
			Объект=Справочники.Номенклатура.СоздатьЭлемент();
	  		Объект.Артикул=АртикулДляПоиска;
			Объект.БазоваяЕдиницаИзмерения=Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("796");
					Попытка 
						Объект.Записать();
						Результат=Объект.Ссылка;				
					Исключение 
						Сообщить("Не удалось записать  "+СокрЛП(ОписаниеОшибки()));
					КонецПопытки; 					
	Иначе 				
		СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];	
	    Результат=СтрокаРезультата.Ссылка ;  		 					
	КонецЕсли;	

...Показать Скрыть
96. Василий Орлов (Bublik2011) 02.03.14 14:57
Как видите, реквизиты «Единица для отчетов» и «Единица хранения остатков» остались не заполненными.


Попробовал загружать номенклатуру без идентификации по артикулу и коду. Вот, например код, который вставляется "Нумерация объектов-События-При записи объектов"

Мне понравилась идея вместо постоянной писанины обработок сразу создать номенклатуру, штрихкод, единицы измерения БЕЗ ПОВТОРНЫХ запусков. Ну. знаете, например, чекбокс "не создавать новые" и т.п. Но быдьте осмотрительны, ИДЕНТИФИКАЦИИ по коду\артикулу нет. Это уже самостоятельно :)

КолонкаШтрихкоды=-3; //если не заполнена или неохота записывать -1
 //если пусто -1


Спр=Объект.Ссылка.ПолучитьОбъект();
СсылкаНоменклатуры=Объект.Ссылка;
						БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("796");
						ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры);
						//Сообщить(ТекСпр.Пустая());
						
						Если ТекСпр.Пустая() Тогда 
						НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент(); 
								НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения); 
								НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения; 
								НайденнаяЕдиницаОбъект.Коэффициент = 1; 
								НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры;
								Попытка НайденнаяЕдиницаОбъект.Записать();
									СпрКод=Справочники.Номенклатура.НайтиПоКоду(СсылкаНоменклатуры.Код).ПолучитьОбъект();
									Объект.ЕдиницаДляОтчетов = НайденнаяЕдиницаОбъект.Ссылка;
									Объект.ЕдиницаХраненияОстатков = НайденнаяЕдиницаОбъект.Ссылка;							
									Объект.ЕдиницаИзмеренияМест= НайденнаяЕдиницаОбъект.Ссылка;
						    Исключение Сообщить("Не удалось записать еденицу "+" "+ ОписаниеОшибки()); 
							КонецПопытки;
						 //Сообщить(Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры).Пустая());
						КонецЕсли;		
Объект.Записать();


Если КолонкаШтрихкоды>0 И ЗначениеЗаполнено(СокрЛП(ТекстыЯчеек[КолонкаШтрихкоды])) Тогда	
Запрос=новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ
|	Штрихкоды.Штрихкод,
|	Штрихкоды.Владелец.Ссылка,
|	Штрихкоды.Владелец.Код Код,
|	Штрихкоды.ХарактеристикаНоменклатуры.Ссылка,
|	Штрихкоды.ХарактеристикаНоменклатуры.Наименование
|ИЗ
|	РегистрСведений.Штрихкоды КАК Штрихкоды
|ГДЕ
|	Штрихкоды.Штрихкод = &lkjhgfds
//|	И Штрихкоды.ХарактеристикаНоменклатуры.Наименование ПОДОБНО &srgdthfyjuki
|";
Запрос.УстановитьПараметр("lkjhgfds",СокрЛП(ТекстыЯчеек[КолонкаШтрихкоды]));
//Запрос.УстановитьПараметр("srgdthfyjuki",СокрЛП(?(Результат.ВГраница()>=ХаракНоменклатуры, СокрЛП(Результат[ХаракНоменклатуры]), "")));
	РезультатЗапроса = Запрос.Выполнить();
	Если НЕ РезультатЗапроса.Пустой() Тогда
		СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];	
		длорпавы = СтрокаРезультата.Код;
		Xcvghjkjbv("нашли владельца штрихкода, "+Строка(длорпавы)+" "+Строка(СтрокаРезультата.ВладелецСсылка)) ;
	Иначе		
	    				Запись= РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
						Запись.Штрихкод                       = СокрЛП(ТекстыЯчеек[КолонкаШтрихкоды]);
						Запись.Владелец                       = СсылкаНоменклатуры;
						Запись.ТипШтрихкода                 = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;
						Запись.ЕдиницаИзмерения                 = СсылкаНоменклатуры.ЕдиницаХраненияОстатков;
						Запись.Качество                       = Справочники.Качество.НайтиПоНаименованию("Новый");
 							Попытка
						Запись.Записать(Истина);
							Исключение
								Xcvghjkjbv("Не удалось записать ШК: "+" для элемента: "+Строка(Объект)+" "+СокрЛП(Объект.Код)+" ||| "+ ОписаниеОшибки());
							КонецПопытки;
		
		
		
		
		
		
	КонецЕсли;
КонецЕсли;	

...Показать Скрыть


97. Алексей Шарапов (Isperator) 28.03.14 15:37
Полезная статья. Мне как раз помогла.
98. Kutnor Kutnor (Kutnor) 24.04.14 16:36
скажите пожалуйста, а как загружать с характеристиками? Я попробовал у меня штрихкоды загрузились, а характеристики к ним нет.
Вот ошибка:
Ячейка[R2C5](Характеристика номенклатуры): Не найден
Добавлена запись № 1.

прикрепляю файл который пробовал загрузить.
Прикрепленные файлы:
тест.xls
99. Kutnor Kutnor (Kutnor) 24.04.14 16:39
вот еще файл настроек.
я пропустил 2 первых этапа, т.к. у меня уже цена на товар есть и сам товар есть, нужно просто в него добавить штрихкоды и характеристики.
Штрихкоды добавились, а характеристики нет.
Прикрепленные файлы:
100. Василий Орлов (Bublik2011) 25.04.14 01:15
(99) Kutnor, Решил проблему так: сравниваю цены (история1), на этом этапе создаются характеристики.

"Я Пойду по другому пути" (с)DJ Ленин :) То есть решил Штрихкоды добавить, а затем характеристики выяснить необходимость добавления характеристики, а потом - добавить штрихкод. Фанатею по EAN13 или Code128 производителя (история2)

Итак, характеристики можно добавить так например, извините на неправильное названия переменных, написанных впопыхах)

		Если (Какое то условие, что цена ОТЛИЧАЕТСЯ и надо вводить характеристику) Тогда
			ЗапросХНА=новый Запрос;
			ЗапросХНА.Текст="
			|     ВЫБРАТЬ
			|	ХарактеристикиНоменклатуры.Ссылка,
			|	ХарактеристикиНоменклатуры.Владелец.Код
			|from
			|	Справочник.ХарактеристикиНоменклатуры КАК ХарактеристикиНоменклатуры
			|where
			|	ХарактеристикиНоменклатуры.Наименование ПОДОБНО &харнаим
			|	И ХарактеристикиНоменклатуры.Владелец = &харнокод
			|   И НЕ ХарактеристикиНоменклатуры.ПометкаУдаления
			|";
			ЗапросХНА.УстановитьПараметр("харнокод",НоменклЦ);
			ЗапросХНА.УстановитьПараметр("харнаим",ХарактеристикаНаименованиеЕ);
			РезультатПустой1 = ЗапросХНА.Выполнить().Пустой();		
		Если РезультатПустой1 И УстанавливатьХарактеристикиНовые Тогда		
		Характеристика          = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
		Характеристика.Владелец = НоменклЦ;
		Характеристика.Наименование = ХарактеристикаНаименование;	
			Попытка 
				Характеристика.Записать();
				новШк = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи(); 
					  новШк.Владелец         = НоменклЦ; 
					  новШк.ЕдиницаИзмерения = НоменклЦ.ЕдиницаХраненияОстатков; 
					  новШк.ТипШтрихкода     = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13; 
					  новШк.Качество         = Справочники.Качество.Новый; 
					  новШк.Штрихкод         = РаботаСТорговымОборудованием.СформироватьШтрихКод(); 
					  новШк.ХарактеристикаНоменклатуры = Характеристика.Ссылка;
					  новШк.Записать();
				
			Исключение 
				Сообщить(СокрЛП(ОписаниеОшибки())) ;
			КонецПопытки;
		Иначе	
			 Сообщить(СокрЛП(СокрЛП(ТекстыЯчеек[1]))+";"+СокрЛП(ХарактеристикаНаименование)+";"+СокрЛП(ЦенаНоменклатуры)+";"+Формат((Строка(БазоваяЦцена)), "ЧЦ=13; ЧДЦ=0; ЧГ=0"));
		    КонецЕсли;
            Иначе
                  Сообщить(СокрЛП(СокрЛП(ТекстыЯчеек[1]))+";"+СокрЛП("")+";"+СокрЛП(ЦенаНоменклатуры)+";"+Формат((Строка(БазоваяЦцена)), "ЧЦ=13; ЧДЦ=0; ЧГ=0"));
            КонецЕсли;



...Показать Скрыть



Это преступление, давать грязный кусок кода. Не знаю, что поможет тебе Kuthor , приаттаченая настройка или подробнее история1 или история2 ? С утра попробую разобраться в вопросе)) Обратил внимание на рисунок настроек. Как и говорил, предлагаю свой вариант (приаттаченный скрин настроек). ЧЕМ ОН НЕУДОБЕН ?


По крайней мере, ОБРАБОТКА ОШИБКИ - "ХАРАКТЕРИСТИКА НЕ НАЙДЕНА" в ЭТОМ ответе есть. Если честно - один товар - много характеристик - это История3 Какая из историй будет полезна?
Прикрепленные файлы:
101. Василий Орлов (Bublik2011) 25.04.14 01:46
(98) Kutnor, это сообщение изменю, пока сделайте бэкап базы.

Думаю, подход к делу надо изменить. В настройках.
1) Качество - устанавливать
2) Единицы измерения - вычислять
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа